Bedienungs- und Servicehandbuch Keysight Trueform Series

Keysight Trueform Series Wellenformgenerator
Bedienungs- und Servicehandbuch

Dieses Dokument enthält Benutzer-, Service- und Programmierinformationen für Signalgeneratoren der Serie Keysight Trueform Series. Die neueste Firmware und Dokumentation finden Sie unter www.keysight.com/find/trueform.

Das aktuelle Datenblatt mit sämtlichen Spezifikationen und typischen Merkmalen finden Sie unter cp.literature.keysight.com/litweb/pdf/5991-3272EN.pdf.

Keysight ist dankbar für Ihre Kommentare und Anregungen zur Verbesserung dieser Dokumentation. Ihr Feedback zu diesem Dokument können Sie eingeben auf www.keysight.com/find/trueformdocfeedback.

Keysight BenchVue-Software

Signalgeneratoren der Serie Keysight Trueform Series arbeiten mit der BenchVue-Software, die eine einfach zu bedienende Steuerung mehrerer Geräte bietet. Ausführlichere Informationen finden Sie unter www.keysight.com/find/benchvue.

Verwenden Sie die BenchVue-Software für Folgendes:

  • Anzeige und Steuerung all Ihrer Laborgeräte über einen einzigen Bildschirm
  • Speichern/Abrufen des Status aller Laborgeräte
  • Abfragen von Daten und Screenshots von mehreren Geräten

Zeit sparen durch:

  • Zeitlich synchronisiertes Exportieren von Daten mehrerer Geräte in Excel, Word, MATLAB
  • Exportieren von Signalgeneratordaten in Word
  • Hin- und Herschieben von Signalen zwischen dem Signalgenerator und Oszilloskop
  • Integrierte Bibliothek zum Herunterladen von Gerätedokumentationen, Software-Treibern, Firmware-Updates, FAQs, Videos und vielem mehr

Von überall aus:

  • Apps für unterwegs zur Überwachung und Steuerung Ihrer Laborgeräte

Vorabinformationen

Sicherheitsinformationen und Vorschriften

Modelle und Optionen

Maximale Wellenformfrequenzen je Modell

Benutzerinformationen

Einführung in das Gerät

Inbetriebnahme

Bedienung des Frontplattenmenüs

Menüreferenz der Frontplatte

LAN-Konfigurationsverfahren

Arbiträrsignal einrichten

Merkmale und Funktionen

Tutorial Erzeugung von Wellenformen

Tutorial Animationen

SCPI-Programmierreferenz

Einführung in die SCPI-Sprache

Interne Funktionssignale

Alphabetische Liste der SCPI-Befehle und Abfragen

Programmierbeispiele

Befehl Schnellübersicht

Gerätestatus nach dem Zurücksetzen auf die Werkseinstellungen

SCPI-Fehlermeldungen

Service- und Reparaturinformationen

Service und Reparatur - Einführung

Kalibrierung und Anpassung: 33500 Series

Kalibrierung und Anpassung: 33600 Series

Blockdiagramm - 33500 Series

Blockdiagramm - 33600 Series

Stromversorgungen - 33500 Series

Stromversorgungen - 33600 Series

Fehlerbehebung - 33500 Series

Fehlerbehebung - 33600 Series

Selbsttests

Ersatzteile

Demontage - 33500 Series

Demontage - 33600 Series

Batterieaustausch

Installation der optionalen GPIB-Schnittstelle

IO Libraries und Gerätetreiber

Die Software Keysight IO Libraries Suite einschließlich Installationsanweisungen befindet sich auf der Keysight IO Libraries Suite CD und ist im Lieferumfang des Geräts enthalten.

Informationen über Anschluss und Konfiguration von USB-, LAN- und GPIB-Schnittstellen finden Sie in der Anleitung Keysight USB/LAN/GPIB Interfaces Connectivity Guide auf der Keysight IO Libraries Suite CD und unter www.keysight.com/find/connectivity.

Webschnittstelle

Das Gerät umfasst eine integrierte Web-Schnittstelle. Sie können diese Schnittstelle über ein LAN für den Remote-Zugang zum Gerät verwenden und über einen Java™-fähigen Webbrowser wie Microsoft Internet Explorer steuern.

Bild einer Webschnittstelle

Verwendung der Webschnittstelle:

  1. Erstellen Sie eine LAN-Verbindung von Ihrem PC zum Gerät.
  2. Öffnen Sie den Internet-Browser des PCs.
  3. Starten Sie die Webschnittstelle des Geräts durch Eingabe der IP-Adresse des Geräts oder des gültigen Hostnamens im Adressfeld des Browsers.
  4. Folgen Sie den Anweisungen der Online-Hilfe für die Web-Schnittstelle.

Beispielprogramme

Auf der Produktseite der Website (www.keysight.com/find/trueform) finden Sie mehrere Beispielprogramme. Es handelt sich dabei um anwendungsorientierte Programme, die verschiedene Programmierumgebungen demonstrieren. Dieses Dokument enthält außerdem Programmierbeispiele, um Ihnen beim Einstieg zu helfen.

Keysight Technologies kontaktieren

Bild eines Telefons

Sie können sich für Garantie, Service oder technischen Support an Keysight Technologies wenden.

    In den USA: (800) 829-4444

    In Europa: 31 20 547 2111

    In Japan: 0120-421-345

Unter www.keysight.com/find/assist finden Sie die Keysight-Kontaktinformationen weltweit oder können Ihren Keysight-Ansprechpartner kontaktieren.

© Keysight Technologies, Inc. 2013 - 2015

Edition 3

September, 2015


Sicherheitsinformationen und Vorschriften

Hinweise

© Keysight Technologies, Inc. 2013, 2014

Jede Vervielfältigung dieses Handbuchs (inkl. elektronische Speicherung, Abfrage oder Übersetzung) ist gemäß den Bestimmungen der internationalen sowie der US-Urheberrechtsgesetze ohne vorherige schriftliche Genehmigung durch Keysight Technologies, Inc. verboten.

Handbuchinformationen

Keysight Technologies, Inc.
900 S. Taft Ave.
Loveland, CO 80537 USA

Updates und Lizenzen für Software und Dokumentation

Keysight veröffentlicht Softwareupdates, um Fehler zu beheben und die Produkte zu verbessern. Die neueste Firmware und Dokumentation finden Sie unter www.keysight.com/find/trueform.

Ein Teil der in dieses Produkt integrierten Software ist unter den Bedingungen der General Public License Version 2 („GPLv2“) lizenziert. Lizenztext und Quellcode finden Sie unter www.keysight.com/find/GPLV2.

Dieses Produkt nutzt Microsoft Windows CE. Keysight empfiehlt dringend, auf allen Windows-basierten Computern, die mit Windows CE-Geräten verbunden sind, aktuelle Antivirensoftware einzusetzen. Ausführlichere Informationen finden Sie unter www.keysight.com/find/truevolt.

Garantie

Keysight Technologies behält sich vor, die in diesem Dokument enthaltenen Informationen in zukünftigen Ausgaben jederzeit ohne Vorankündigung zu ändern. Keysight Technologies bietet nur im gesetzlich vorgeschriebenen Rahmen Gewährleistung für die in dieser Dokumentation enthaltenen Informationen. Dies betrifft insbesondere deren Eignung oder Tauglichkeit für einen bestimmten Zweck. Keysight Technologies übernimmt keine Haftung für Fehler, die in diesem Dokument enthalten sind, und für zufällige Schäden oder Folgeschäden im Zusammenhang mit der Lieferung, Ingebrauchnahme oder Nutzung dieser Dokumentation oder der enthaltenen Informationen. Falls zwischen Keysight und dem Benutzer eine separate schriftliche Vereinbarung mit abweichenden Gewährleistungsbedingungen hinsichtlich der in diesem Dokument enthaltenen Informationen existiert, so gelten diese schriftlich vereinbarten Bedingungen.

Technologielizenzen

Die in diesem Dokument beschriebene Hardware und/oder Software wird unter einer Lizenz geliefert und darf nur entsprechend den Lizenzbedingungen genutzt oder kopiert werden.

Nutzungsbeschränkungen

Wenn Software für den Gebrauch durch die US-Regierung bestimmt ist, wird sie als „kommerzielle Computer-Software“ gemäß der Definition in DFAR 252.227-7014 (Juni 1995), als „kommerzielle Komponente“ gemäß der Definition in FAR 2.101(a), als „nutzungsbeschränkte Computer-Software“ gemäß der Definition in FAR 52.227-19 (Juni 1987) oder einer vergleichbaren Agentur- oder Vertragsbestimmung ausgeliefert und lizenziert. Die Nutzung, Vervielfältigung und Weitergabe von Software unterliegt den Standardbestimmungen für kommerzielle Lizenzen von Keysight Technologies. US-Regierung und -Behörden (außer Verteidigungsministerium) erhalten keine Rechte, die über die Rechte an „nutzungsbeschränkter Computer- Software“ gemäß FAR 52.227- 19(c)(1-2) (Juni 1987) hinausgehen. Zur US-Regierung zählende Benutzer erhalten keine Rechte, die über die Rechte an „nutzungsbeschränkter Computer- Software“ gemäß FAR 52.227-14 (Juni 1987) oder DFAR 252.227-7015 (b)(2) (November 1995) hinausgehen, soweit in technischen Daten anwendbar.

Sicherheitshinweise

Der Hinweis VORSICHT weist auf eine Gefahr hin. Dieser Hinweis macht auf Arbeitsweisen, Anwendungen o. ä. aufmerksam, die bei falscher Ausführung zur Beschädigung des Produkts oder zum Verlust wichtiger Daten führen können. Wenn ein Verfahren mit dem Hinweis VORSICHT gekennzeichnet ist, dürfen Sie erst fortfahren, wenn Sie alle aufgeführten Bedingungen verstanden haben und diese erfüllt sind.

Der Hinweis WARNUNG weist auf eine Gefahr hin. Dieser Hinweis macht auf Arbeitsweisen, Anwendungen o. ä. aufmerksam, die bei falscher Ausführung zu Personenschäden, u. U. mit Todesfolge, führen können. Wenn ein Prozess mit dem Hinweis WARNUNG gekennzeichnet ist, dürfen Sie erst fortfahren, wenn Sie alle aufgeführten Bedingungen verstanden haben und diese erfüllt sind.

Sicherheitssymbole

Wechselstrom
Wechselstrom
Gehäusemasse
Gehäusemasse (Funktionserdung)

Standby-Stromversorgung. Die Einheit ist bei Abschaltung nicht vollständig vom Stromnetz getrennt.
Vorsicht - Stromschlaggefahr
Vorsicht Stromschlaggefahr
Vorsicht - Lesen Sie die diesbezüglichen Hinweise in den Begleitdokumenten
Vorsicht Lesen Sie die diesbezüglichen Hinweise in den Begleitdokumenten
Abbildung Boden mit Kreis
Schutzerdungsanschluss (Schutzerdung)
CE-Zeichen
Das CE-Zeichen ist eine registrierte Marke der Europäischen Gemeinschaft.
ETL Intertek Logo | Das ET-Zeichen ist eine eingetragene Marke von Intertek. Betrifft nur Geräte der 33500 Series.
Das CSA-Zeichen mit dem Index 'c' und 'us' gibt an, dass das Gerät gemäß den geltenden kanadischen oder US-amerikanischen Standards zertifiziert ist. Betrifft nur Geräte der 33600 Series.
N10149 Logo | Das C-Tick-Zeichen ist eine registrierte Marke der Spectrum Management Agency of Australia. Dies kennzeichnet die Einhaltung der australischen EMC Rahmenrichtlinien gemäß den Bestimmungen des Radio Communication Act von 1992.
Logo mit einer eingekreisten 40
Enthält mindestens eine der über dem maximalen Konzentrationswert liegenden 6 gefährlichen Substanzen (MCV), 40 Jahre EPUP.
1SM 1-A | Dieser Text weist darauf hin, dass es sich bei dem Gerät um ein Produkt der Industrial Scientific and Medical Group 1, Klasse A (CISPR 11, Clause 4) handelt.
ICES/NMB-001

Dieses ISM-Gerät entspricht der kanadischen Norm ICES-001.

Cet appareil ISM est conforme à la norme NMB-001 du Canada.

Dieses Produkt entspricht der Kennzeichnungsanforderung der WEEE-Richtlinie (2002/96/EC). Die fixierte Produktkennzeichnung gibt an, dass dieses elektrische/elektronische Produkt nicht im Hausmüll entsorgt werden darf.

Wenden Sie sich für die Entsorgung von Produkten an die nächste Keysight Geschäftsstelle. Informationen finden Sie ebenfalls unter www.keysight.com/environment/product.

Dieses Gerät ist kompatibel mit Klasse A (für den professionellen Gebrauch) und zum Einsatz in elektromagnetischen Umgebungen außerhalb des Wohnraums.

Sicherheitshinweise

Die folgenden allgemeinen Sicherheitshinweise müssen in allen Betriebsphasen des Geräts beachtet werden. Die Nichtbeachtung dieser Sicherheitshinweise bzw. besonderer Warnungen oder Anweisungen an anderer Stelle dieses Handbuchs verstößt gegen Sicherheitsstandards, Herstellervorschriften und die sachgemäße Benutzung des Geräts. Keysight Technologies übernimmt bei Missachtung dieser Voraussetzungen durch den Kunden keine Haftung.

Allgemeines

Verwenden Sie dieses Produkt keinesfalls in einer vom Hersteller nicht angegebenen Weise. Die Schutzeinrichtungen dieses Produkts können in ihrer Wirksamkeit beeinträchtigt werden, wenn es anders als in der Betriebsanleitung beschrieben verwendet wird.

Vor dem Anschluss an das Stromnetz

Stellen Sie sicher, dass alle erforderlichen Sicherheitsvorkehrungen getroffen wurden. Stellen Sie alle Verbindungen zu der Einheit her, ehe Sie den Strom einschalten.

Erdung des Geräts

Dieses Produkt ist mit Schutzerdungsanschlüssen versehen. Um die Gefahr eines Stromschlags zu minimieren, muss das Gerät über ein geerdetes Netzkabel an das Stromversorgungsnetz angeschlossen werden. Dabei muss der Schutzleiter fest mit dem Schutzkontakt der Steckdose verbunden sein. Bei einer Unterbrechung des Schutzleiters (Erdung) oder bei Trennung des Geräts vom Schutzerdungsanschluss besteht die Gefahr eines Stromschlags, der zu Verletzungen führen kann.

  • Nicht in einer explosiven Umgebung betreiben.
  • Gerät nicht in der Nähe entflammbarer Gase oder Dämpfe betreiben.
  • Die Abdeckungen des Geräts dürfen nur von qualifizierten Service-Technikern entfernt werden, die sich der damit verbundenen Gefahren bewusst sind. Das Gerät muss stets vom Netz genommen und von jedem externen Stromkreis getrennt werden, ehe die Abdeckung des Geräts entfernt wird.

Keine Änderungen am Gerät vornehmen

Bauen Sie keine Ersatzteile ein und nehmen Sie keine unbefugten Änderungen am Gerät vor. Geben Sie das Gerät gegebenenfalls zur Wartung oder Reparatur an Keysight Technologies Sales und das Service Office, damit die Sicherheit des Geräts weiterhin gewährleistet ist.

Bei Beschädigungen

Geräte, von denen Sie annehmen, sie könnten beschädigt sein, müssen außer Betrieb genommen und bis zur Reparatur durch einen qualifizierten Techniker gegen jegliche Wiederinbetriebnahme gesichert werden.

Sofern nicht anders in den Spezifikationen vermerkt, ist dieses Gerät bzw. System für den Einsatz in geschlossenen Räumen der Installationskategorie II, Verschmutzungsgrad 2 gemäß IEC 61010-1 beziehungsweise 664 vorgesehen. Es ist für den Betrieb bei maximaler relativer Luftfeuchtigkeit von 5% bis 80% und bei höchstens 40 °C (nicht kondensierend) bestimmt. Dieses Gerät bzw. System ist für den Betrieb in Höhen bis zu 3000 Meter und Temperaturen zwischen 0 °C und 55 °C bestimmt.

Technischer Support

Wenn Sie Fragen zu Ihrer Lieferung haben oder Informationen über Garantie, Service oder technischen Support wünschen, wenden Sie sich an Keysight Technologies.

Declaration of Conformity

Declarations of Conformity for this product and for other Keysight products may be downloaded from the Keysight Regulatory Web site:

http://regulations.products.keysight.com/DoC/search.htm


Modelle und Optionen

In diesem Abschnitt sind die Modelle und Optionen der Geräteserie Trueform Series beschrieben. Informationen über das Laden von Lizenzen für Optionen über das vordere Bedienfeld finden Sie unter Lizenzinstallation. Informationen zum Laden von Lizenzen über SCPI finden Sie unter SYSTem:LICense commands.

Gerätemodelle

Gerätemodelle mit Nummern in Form von 335XXA oder 335XXB zählen zur 33500 Series und Gerätemodelle mit Nummern in Form von 336XXA zählen zur 33600 Series. Insgesamt umfassen die Geräte der 33500 Series und 33600 Series die Wellenformgeneratoren der Trueform Series. Sofern nicht anderweitig vermerkt, beziehen sich jegliche Informationen des Handbuchs auf alle Geräte der Trueform Series.

Zur Bestimmung der Gerätemodellnummer siehe Kennzeichnung auf dem vorderen Bedienfeld des Geräts. Ebenso können Sie eine *IDN?-Suche über die Remoteschnittstelle durchführen oder [System] > Help > About auf dem vorderen Bedienfeld drücken.

Die Modell- und Optionsnummern der Trueform Series sind in der unteren Tabelle angegeben und beschrieben.

Modell | Beschreibung | Optionen
33521A | 30 MHz Ein Kanal Arbiträrsignale NISPOM-Sicherheit 1 MSa Speicher pro Kanal | 002 - 16MSa Arb Speicher 004 - GPIB- Schnittstelle 010 - Hochstabile OCXO-Zeitbasis
33522A | 30 MHz Zwei Kanäle Arbiträrsignale NISPOM-Sicherheit 1 MSa Speicher pro Kanal | 002 - 16MSa Arb Speicher 004 - GPIB- Schnittstelle 010 - Hochstabile OCXO-Zeitbasis
33509B | 20 MHz Ein Kanal Keine Arbiträrsignale | OCX - Hochstabile OCXO Zeitbasis hinzufügen SEC - NISPOM & Datensicherheit aktivieren
33510B | 20 MHz Zwei Kanäle Keine Arbiträrsignale | OCX - Hochstabile OCXO Zeitbasis hinzufügen SEC - NISPOM & Datensicherheit aktivieren
33511B | 20 MHz Ein Kanal Arbiträrsignale | MEM - 16 MSa Speicher pro Kanal OCX - Hochstabile OCXO Zeitbasis hinzufügen SEC - NISPOM & Datensicherheit aktivieren
33512B | 20 MHz Zwei Kanäle Arbiträrsignale | MEM - 16 MSa Speicher pro Kanal OCX - Hochstabile OCXO Zeitbasis hinzufügen SEC - NISPOM & Datensicherheit aktivieren IQP - IQ Baseband Signal-Player hinzufügen
33519B | 30 MHz Ein Kanal Keine Arbiträrsignale | OCX - Hochstabile OCXO Zeitbasis hinzufügen SEC - NISPOM & Datensicherheit aktivieren
33520B | 30 MHz Zwei Kanäle Keine Arbiträrsignale | OCX - Hochstabile OCXO Zeitbasis hinzufügen SEC - NISPOM & Datensicherheit aktivieren
33521B | 30 MHz Ein Kanal Arbiträrsignale | MEM - 16 MSa Speicher pro Kanal OCX - Hochstabile OCXO Zeitbasis hinzufügen SEC - NISPOM & Datensicherheit aktivieren
33522B | 30 MHz Zwei Kanäle Arbiträrsignale | MEM - 16 MSa Speicher pro Kanal OCX - Hochstabile OCXO Zeitbasis hinzufügen SEC - NISPOM & Datensicherheit aktivieren IQP - IQ Baseband Signal-Player hinzufügen
33611A | 80 MHz Ein Kanal Arbiträrsignale | MEM - 64 MSa Speicher pro Kanal OCX - Hochstabile OCXO Zeitbasis hinzufügen SEC - NISPOM & Datensicherheit aktivieren
33612A | 80 MHz Zwei Kanäle Arbiträrsignale | MEM - 64 MSa Speicher pro Kanal OCX - Hochstabile OCXO Zeitbasis hinzufügen SEC - NISPOM & Datensicherheit aktivieren IQP - IQ Baseband Signal-Player hinzufügen
33621A | 120 MHz Ein Kanal Arbiträrsignale | MEM - 64 MSa Speicher pro Kanal OCX - Hochstabile OCXO Zeitbasis hinzufügen SEC - NISPOM & Datensicherheit aktivieren GPB - GPIB-Schnittstellenmodul – werkseitig installiert
33622A | 120 MHz Zwei Kanäle Arbiträrsignale | MEM - 64 MSa Speicher pro Kanal OCX - Hochstabile OCXO Zeitbasis hinzufügen SEC - NISPOM & Datensicherheit aktivieren IQP - IQ Baseband Signal-Player hinzufügen GPB - GPIB-Schnittstellenmodul – werkseitig installiert

Ein- und Zweikanal-Upgrades für die 33500 Series

Modell | Beschreibung
335BW1U | Erhöhung der Bandbreite auf 30 MHz für Einkanalmodelle
335BW2U | Erhöhung der Bandbreite auf 30 MHz für Zweikanalmodelle
335ARB1U | Hinzufügen von Arbiträrwellenformen zu Einkanalmodellen
335ARB2U | Hinzufügen von Arbiträrwellenformen zu Zweikanalmodellen
335MEM1U | 16 MSa Speicher pro Kanal für Einkanalmodelle
335MEM2U | 16 MSa Speicher pro Kanal für Zweikanalmodelle
33500U-OCX | Hochstabile OCXO-Zeitbasis hinzufügen
335SECU | NISPOM- und Datensicherheit hinzufügen
335IQPU | IQ Baseband Signal-Player hinzufügen
33522B-DST | Alle Software-Optionen zu Demo-Zwecken aktivieren

Ein- und Zweikanal-Upgrades für die 33600 Series

Modell | Beschreibung
336BW1U | Erhöhung der Bandbreite auf 120 MHz für Einkanalmodelle
336BW2U | Erhöhung der Bandbreite auf 120 MHz für Zweikanalmodelle
336MEM1U | 64 MSa Speicher pro Kanal für Einkanalmodelle
336MEM2U | 64 MSa Speicher pro Kanal für Zweikanalmodelle
33600U-OCX | Hochstabile OCXO-Zeitbasis hinzufügen
336SECU | NISPOM- und Datensicherheit hinzufügen
336IQPU | IQ Baseband Signal-Player hinzufügen
33622A-DST | Alle Software-Optionen zu Demo-Zwecken aktivieren
3446GPBU | GPIB benutzerinstallierbares Schnittstellenmodul


Maximale Wellenformfrequenzen je Modell

33500 Series, Niedrigfrequenzmodelle

33509B 33510B 33511B 33512B

Wellenform | Maximale Frequenz
Sinus | 20 MHz
Rechteck/Puls | 20 MHz
Rauschen | 20 MHz
Sägezahn/Dreieck | 200 kHz
PRBS | 50 Mbps
Arbiträrsignal | 160 MSa/s

33500 Series, Hochfrequenzmodelle

33521A 33522A 33519B 33520B 33521B 33522B oder andere Modelle der 33500 Series mit Option 335BW1U oder 335BW2U.

Wellenform | Maximale Frequenz
Sinus | 30 MHz
Rechteck/Puls | 30 MHz
Rauschen | 30 MHz
Sägezahn/Dreieck | 200 kHz
PRBS | 50 Mbps
Arbiträrsignal | 250 MSa/s

33600 Series, Niedrigfrequenzmodelle

33611A 33612A

Wellenform | Maximale Frequenz
Sinus | 60 MHz bis zu 10 Vpp 80 MHz bis zu 8 Vpp
Rechteck/Puls | 50 MHz bis zu 10 Vpp
Rauschen | 60 MHz bis zu 10 Vpp 80 MHz bis zu 8 Vpp
Sägezahn/Dreieck | 800 kHz
PRBS | 100 Mbps
Arbiträrsignal | 660 MSa/s

33600 Series, Hochfrequenzmodelle

33621A 33622A oder andere Modelle der 33600 Series mit Option 336BW1U oder 336BW2U.

Wellenform | Maximale Frequenz
Sinus | 60 MHz bis zu 10 Vpp 80 MHz bis zu 8 Vpp 120 MHz bis zu 4 Vpp
Rechteck/Puls | 50 MHz bis zu 10 Vpp 100 MHz bis zu 4 Vpp
Rauschen | 60 MHz bis zu 10 Vpp 80 MHz bis zu 8 Vpp 120 MHz bis zu 4 Vpp
Sägezahn/Dreieck | 800 kHz
PRBS | 100 Mbps bis zu 10 Vpp 200 Mbps bis zu 4 Vpp
Arbiträrsignal | 1 GSa/s


Benutzerinformationen

Einführung in das Gerät

Inbetriebnahme

Bedienung des Frontplattenmenüs

Menüreferenz der Frontplatte

LAN-Konfigurationsverfahren

Arbiträrsignal einrichten

Merkmale und Funktionen

Tutorial Erzeugung von Wellenformen


Einführung in das Gerät

Bei der Keysight Technologies Trueform Series handelt es sich um eine Serie von Synthesizer-Wellenformgeneratoren mit integrierten Funktionen zum Erzeugen von Arbiträrwellenformen und Pulsen.

Das Gerät auf einen Blick

Das vordere Bedienfeld auf einen Blick

Das Display des vorderen Bedienfelds auf einen Blick

Zahleneingabe auf dem vorderen Bedienfeld

Das hintere Bedienfeld auf einen Blick

Das Gerät auf einen Blick

Das Gerät eignet sich sowohl als autonomes Laborgerät als auch für den Systemeinsatz und stellt somit heute und in Zukunft eine vielseitige Lösung dar.

Umfangreiche Funktionsausstattung

  • 16 Standardwellenformen
  • Integrierter 16-Bit (33500 Series) oder 14-Bit (33600 Series) Arbiträrwellenformgenerator
  • Integrierter Pulsgenerator mit programmierbaren Anstiegs-/Abfallzeiten
  • LCD-Display mit Anzeige von numerischen Werten und Signalformen
  • Einfache Bedienung über Drehknopf und Zifferntastatur
  • Speicherung von Gerätezuständen unter benutzerdefinierten Namen
  • Robustes Gehäuse, leicht zu transportieren, rutschhemmende Füße
  • Isolierte Ausgänge zur Vermeidung von Erdungsschleifen

Flexible Systemfunktionen

  • Wellenformspeicher von 1MSa (33500 Series) oder 4 MSa (33600 Series) zum Herunterladen. Dieser kann auf 16 MSa (33500 Series) oder 64 MSa (33600 Series) erweitert werden.
  • USB-, GPIB-, und LAN-Remoteschnittstellen (GPIB ist bei einigen Modellen optional; siehe Modelle und Optionen für nähere Informationen.)
  • Kompatibel mit LXI Klasse C
  • SCPI (Standard Commands for Programmable Instruments) Kompatibilität

Das vordere Bedienfeld auf einen Blick

Beim BNC-Anschluss sind sowohl Buchse als auch mittlerer Stecker am vorderen Bedienfeld des Geräts bis zu ±42 Vpk vom Gehäuse isoliert. Die Buchsen dieses BNC-Anschlusses sind miteinander verbunden und der interne Schaltkreis hält die isolierte Spannung auf ±42 Vpk gegen Gehäuse. Ein Überschreiten der Isolationsspannung über ±42 Vpk vom Gehäuse kann zur Beschädigung des Geräts sowie zu Personenschäden, u. U. mit Todesfolge, führen.

Vorderes Bedienfeld, mit Kennzeichnung

Element | Beschreibung
1 | USB-Anschluss
2 | Ein/Aus Standby-Schalter
3 | Display
4 | Menü-Softkeys
5 | Fixierte Funktionstasten (Spalte mit sieben Tasten)
6 | Manuelle Triggertaste
7 | Sync-Anschluss
8 | Zifferntastatur
9 | Kanal 1 und Kanal 2 (je nach Modell)
10 | Drehknopf und Pfeiltasten

Hinweis

Durch Gedrückthalten einer Taste des vorderen Bedienfelds oder eines Softkeys erhalten Sie kontextbezogene Online-Hilfe.

Das Display des vorderen Bedienfelds auf einen Blick

Display des vorderen Bedienfelds

Element | Beschreibung
1 | Beschreibung Kanal 1
2 | Beschreibung Kanal 2 (je nach Modell)
3 | Wellenformparameter
4 | Wellenformanzeige
5 | Sweep-, Modulations- oder Burst-Parameter
6 | Softkey-Funktionsbezeichnungen

Zahleneingabe auf dem vorderen Bedienfeld

Sie haben zwei Möglichkeiten, Zahlen über das vordere Bedienfeld einzugeben:

  • Verwenden Sie den Drehknopf und die Cursor-Tasten, um die Zahl zu ändern. Drehen Sie den Drehknopf, um eine Zahl zu ändern (im Uhrzeigersinn erhöhen sich die Zahlen). Über die Pfeiltasten unterhalb des Drehknopfs kann der Cursor bewegt werden.
    Drehknopf und Pfeiltasten

  • Verwenden Sie die Zifferntastatur zur Eingabe von Zahlen und die Softkeys zum Auswählen von Einheiten. Über die [+/-]-Taste kann das Vorzeichen einer Zahl geändert werden.
    Zifferntastatur

Das hintere Bedienfeld auf einen Blick

Die hinteren Bedienfelder an den Geräten der 33500 Series und 33600 Series haben ähnliche Funktionen, jedoch variiert deren Position (wie unten aufgeführt).

33500 Series

Hinteres Bedienfeld, mit Zahlen gekennzeichnet

33600 Series

Element | Beschreibung
1 | Externer10 MHz Referenzeingang
2 | Interner 10 MHz Referenzausgang
3 | GPIB-Anschluss
4 | Gehäusemasse
5 | Geräte-Kabelschloss
6 | Wechselstrom
7 | Eingang für externe Modulation
8 | Ext. Trig/Gate/FSK/Burst (Eingang und Ausgang)
9 | USB-Schnittstellenanschluss
10 | LAN-(Local Area Network)Schnittstelle

Beim BNC-Anschluss des externern 10 MHz-Referenzeingangs sind sowohl Buchse als auch mittlerer Stecker am hinteren Bedienfeld des Geräts bis zu ±42 Vpk vom Gehäuse isoliert. Die Buchse dieses BNC-Anschlusses ist vom Rest des Geräts isoliert. Der interne Schaltkreis hält die isolierte Spannung auf ±42 Vpk gegen Gehäuse. Ein Verbinden dieses Eingangs mit über ±42 Vpk vom Gehäuse kann zur Beschädigung des Geräts sowie zu Personenschäden, u. U. mit Todesfolge, führen.

Beim BNC-Anschluss des externern Modulationseingangs sind sowohl Buchse als auch mittlerer Stecker am hinteren Bedienfeld des Geräts bis zu ±42 Vpk vom Gehäuse isoliert. Die Buchse dieses BNC-Anschlusses ist mit den Buchsen der BNC-Anschlüsse am vorderen Bedienfeld verbunden. Der interne Schaltkreis hält die isolierte Spannung auf ±42 Vpk gegen Gehäuse. Ein Verbinden der Ausgänge mit über ±42 Vpk vom Gehäuse kann zur Beschädigung des Geräts sowie zu Personenschäden, u. U. mit Todesfolge, führen.

Warnung

Dies ist ein Gerät der Schutzklasse 1 (Gehäuse muss an eine Schutzerdung angeschlossen werden). Der Netzstecker darf nur an eine Netzsteckdose mit Schutzerdungsanschluss angeschlossen werden.


Inbetriebnahme

Dieser Abschnitt beschreibt grundlegende Abläufe für eine schnelle Inbetriebnahme dieses Geräts.

  • Vorbereitung des Geräts
  • Einstellen des Tragegriffs
  • Einstellen der Ausgangsfrequenz
  • Einstellen der Ausgangsamplitude
  • Einstellen der DC-Offsetspannung
  • Einstellen der oberen (HiLevel) und unteren Pegel (LoLevel)
  • Ausgabe einer DC-Spannung
  • Einstellen des Tastverhältnisses eines Rechtecksignals
  • Konfigurieren eines Pulssignals
  • Auswählen eines gespeicherten Arbiträrsignals
  • Benutzen des integrierten Hilfesystems
  • So montieren Sie das Gerät im Gestell

Vorbereitung des Geräts

Überprüfen Sie, ob Sie die folgenden Teile erhalten haben. Falls etwas fehlt, setzen Sie sich bitte mit der nächstgelegenen Geschäftsstelle von Keysight oder dem autorisierten Keysight-Händler in Verbindung.

  • Netzkabel (für das Bestimmungsland)
  • Kalibrierzertifikat
  • Produktreferenz-CD der Keysight Trueform Series (Produktsoftware, Programmierungsbeispiele und Handbücher)
  • Keysight IO Libraries Suite CD
  • USB 2.0-Kabel

    Hinweis: Die gesamte Produktinformation befindet sich auf der Produktreferenz-CD der Keysight Trueform Series. Die neueste Firmware und Dokumentation finden Sie unter www.keysight.com/find/trueform.

Das Gerät kann mit einer Netzspannung von 100-240 V, 50/60 Hz oder 100-120 V, 400 Hz verwendet werden. Die zu verwendende Höchstspannung beträgt 150 VA. Stellen Sie sicher, dass ein Netzkabel verwendet wird, welches der Nennleistung des Geräts und den in Ihrem Land geltenden Vorschriften zu Elektroinstallationen entspricht. Netzkabel und LAN-, GPIB- oder USB-Kabel wie gewünscht anschließen. Gerät durch Drücken des Ein-/Aus-Schalters links unten am vorderen Bedienfeld einschalten. Das Gerät führt einen Selbsttest durch und zeigt in einer Meldung Informationen zur Hilfe und die aktuelle IP-Adresse an. Außerdem wird auf dem Display die GPIB-Adresse angezeigt, wenn die GPIB-Option installiert und aktiviert ist.

Netz schalter: Netzschalter

Die Standardfunktion des Geräts ist ein Sinussignal mit 1 kHz und 100 mVpp (an einem 50 Ω-Widerstand). Beim Einschalten des Geräts werden die Kanalausgangsanschlüsse deaktiviert. Um den Ausgang eines Kanalanschlusses zu aktivieren, Taste über dem Kanalanschluss drücken und dann den Softkey Output Off / On.

Wenn sich das Gerät nicht eingeschaltet, prüfen Sie, ob das Netzkabel korrekt angeschlossen ist. Stellen Sie außerdem sicher, dass das Gerät an eine stromführende Spannungsquelle angeschlossen ist. Wenn die LED unter dem Netzschalter nicht leuchtet, ist das Gerät nicht mit der Netzspannung verbunden. Leuchtet die LED gelb, ist das Gerät mit der Netzspannung verbunden, steht jedoch im Standby-Modus. Wenn sie grün leuchtet, ist das Gerät eingeschaltet.

Schlägt der Selbsttest fehl, erscheint die Meldung ERR oben rechts. Außerdem wird deutlich folgende Meldung angezeigt: "Check for error messages in the error queue."

Siehe SCPI Fehlermeldungen für Hinweise zu Fehlercodes. Siehe Service und Reparatur - Einführung für Hinweise zur Rücksendung des Geräts zur Durchführung von Servicemaßnahmen.

Zum Ausschalten des Geräts Netzschalter etwa 500 ms gedrückt halten. Dies verhindert ein Ausschalten des Geräts durch unbeabsichtigtes Berühren des Netzschalters.

Einstellen des Tragegriffs

Fassen Sie den Griff an beiden Seiten, ziehen Sie ihn nach außen und drehen Sie ihn.

Einstellen des Tragegriffs

Einstellen der Ausgangsfrequenz

Die Standarfrequenz beträgt 1 kHz. Sie können die Frequenz ändern und die Frequenz in Periodeneinheiten statt in Hz angeben.

Frequenz über den Drehknopf ändern:
Taste Parameters Softkey Frequency Drehknopf und Pfeiltasten

Frequenz über die Zifferntastatur ändern:

Taste Parameters Softkey Frequency Zifferntastatur
Beenden, indem Frequenzeinheiten gewählt werden:

Softkeys Frequency units

Ändern der Einheiten von Frequenz zu Periode:

Softkey Frequency / Period (Period)

Einstellen der Ausgangsamplitude

Die Standardfunktion des Geräts ist ein Sinussignal mit 1 kHz und 100 mVpp (an einem 50 Ω-Widerstand).

Nachfolgend wird gezeigt, wie Sie die Amplitude zu 50 mVpp ändern.

  1. Drücken Sie auf [Units] > Amp/Offs oder High/Low, um Amp/Offs sicherzustellen.

    Im Display wird die beim Einschalten automatisch gewählte Amplitude bzw. die zuletzt manuell gewählte Amplitude angezeigt. Bei einer Funktionsumschaltung bleibt die Amplitudeneinstellung erhalten, sofern der aktuelle Wert für die neue Funktion zulässig ist. Um zu wählen, ob Sie das Spannungsniveau als Amplituden- und Offsetwerte oder als Werte der oberen und unteren Ebene eingeben wollen, drücken Sie auf [Units] und dann auf den zweiten Softkey. In diesem Fall wird Amp/Offs markiert.

    Amplitude zu High/Low ändern
  2. Geben Sie den gewünschten Amplitudenwert ein.
    Drücken Sie auf [Parameters] > Amplitude. Geben Sie über die Zifferntastatur den Wert 50 ein.

    50 für Amplitude eingeben
  3. Wählen Sie die gewünschte Maßeinheit.

    Drücken Sie den betreffenden Maßeinheit-Softkey. Nach dem Wählen der Maßeinheit gibt das Gerät eine Wellenform mit der angezeigten Amplitude aus (sofern der Ausgang aktiviert ist). Drücken Sie in diesem Beispiel mVpp.

    Sie können den gewünschten Wert auch mit dem Drehknopf und den Pfeiltasten einstellen. Dann benötigen Sie keinen Maßeinheit-Softkey. Sie können die Art der Maßeinheiten jederzeit ändern. Drücken Sie einfach auf [Units] > Ampl As und wählen Sie dann die gewünschte Maßeinheit.

    Angezeigte Amplitudeneinheiten

Einstellen der DC-Offsetspannung

Beim Einschalten des Geräts ist der DC-Offset 0 V. Nachfolgend wird gezeigt, wie der Offset zu –1,5 VDC geändert wird.

  1. Drücken Sie auf [Parameters] > Offset.

    Im Display wird die beim Einschalten automatisch gewählte Offset-Spannung oder die zuletzt manuell gewählte Spannung angezeigt. Bei einer Funktionsumschaltung bleibt die Offsetspannung erhalten, sofern diese für die neue Funktion zulässig ist.

    Wählen Sie den zu ändernden Offsetwert
  2. Geben Sie den gewünschten Offsetwert ein.
    Verwenden Sie dabei die Zifferntastatur, um –1,5 einzugeben.

    Geben Sie für den Offsetwert -1,5 ein
  3. Wählen Sie die gewünschte Maßeinheit.
    Drücken Sie den Softkey für die gewünschten Einheiten. Nach dem Wählen der Maßeinheit gibt das Gerät die Wellenform mit dem angezeigten Offsetwert aus (sofern der Ausgang aktiv ist). Drücken Sie in diesem Beispiel auf V. Die Spannung wird eingestellt (siehe unten).
    Wählen Sie VDC für Spannungseinheiten

Sie können den gewünschten Wert auch mit dem Drehknopf und den Pfeiltasten einstellen.

Einstellen der oberen (HiLevel) und unteren Pegel (LoLevel)

Sie können ein Signal definieren, indem Sie dessen Amplitude und DC-Offsetspannung einstellen, wie oben beschrieben. Ein Signal kann jedoch auch definiert werden, indem Sie hohe (Höchst-) und niedrige (Mindest-)werte einstellen. Diese Vorgehensweise bietet sich für digitale Anwendungen an. In folgendem Beispiel wird der HiLevel-Wert auf 1,0 V und der LoLevel-Wert auf 0,0 V gesetzt.

  1. Drücken Sie auf [Units] > Ampl/Offs, um wie unten beschrieben zu High/Low zu wechseln.
  2. Drücken Sie auf [Parameters] > High Level. Wählen Sie über die Zifferntastatur oder den Drehknopf und die Pfeiltasten den Wert 1,0 V. (Wenn Sie die Zifferntastatur verwenden, müssen Sie den Softkey der Einheit V wählen, um den Wert einzugeben.)
    Geben Sie +1,000 für den High Level ein
  3. Drücken Sie auf den Softkey Low Level und stellen Sie den Wert ein.
    Geben Sie nochmals den Wert 0,0 V über die Zifferntastatur oder den Drehknopf ein.
    Geben Sie 0,0 für den Low Level ein

Diese Einstellungen (High-Level = 1,0 V und Low-Level = 0,0 V) entsprechen den Werten 1,0 Vpp für die Amplitude und 500 mV für den Offset.

Ausgabe einer DC-Spannung

Sie können eine konstante DC-Spannung von -5 V bis +5 V in 50 Ω ausgeben oder -10 V bis +10 V in hochohmiger Last.

  1. Drücken Sie auf [Waveforms] > More > DC.
    Der Offset-Wert wird markiert.
    DC-Spannungen eingeben
  2. Geben Sie die gewünschte Offsetspannung ein.
    Geben Sie 1,0 über die Zifferntastatur oder den Drehnkopf ein und drücken Sie auf den Softkey V, wenn Sie die Zifferntastatur verwendet haben.
    Geben Sie 1,0 DCV ein

Einstellen des Tastverhältnisses eines Rechtecksignals

Beim Einschalten des Geräts wird das Tastverhältnis für Rechtecksignale standardmäßig auf 50 % eingestellt. Das Tastverhältnis ist durch die minimale Pulsbreitenspezifikation von 16 ns bei der 33500 Series oder von 5 ns bis 4 Vpp und 8 ns bis 10 Vpp bei der 33600 Series begrenzt. Nachfolgend wird gezeigt, wie das Tastverhältnis zu 75% geändert werden kann.

  1. Wählen Sie die Signalform "Square" (Rechteck).
    Drücken Sie auf [Waveforms] > Square.
  2. Drücken Sie auf den Softkey Duty Cycle.
    Bei dem angezeigten Tastverhältnis handelt es sich entweder um den Einschaltwert oder um den zuvor ausgewählten Prozentsatz. Das Tastverhältnis ist definiert als der Zeitabschnitt, an dem das Rechtecksignal auf "HIGH" steht.
    Geben Sie das Tastverhältnis ein
  3. Geben Sie das gewünschte Tastverhältnis ein.
    Wählen Sie über die Zifferntastatur oder den Drehknopf und die Pfeiltasten das Tastenverhältnis 75. Wenn Sie die Zifferntastatur verwenden, drücken Sie auf Percent um die Eingabe zu beenden. Das Gerät passt sofort das Tastverhältnis an und gibt ein Rechtecksignal mit dem angegebenen Wert aus (wenn der Ausgang aktiviert ist).
    Rechtecksignal mit 75 % Tastenverhältnis

Konfigurieren eines Pulssignals

Sie können das Gerät für die Ausgabe eines Pulssignals mit variabler Pulsbreite und Flankenzeit konfigurieren. Nachfolgend wird gezeigt, wie Sie das Gerät für die Ausgabe eines periodischen 500 ms-Pulsesignals mit einer Pulsbreite von 10 ms und Flankenzeiten von 50 ns konfigurieren.

  1. Wählen Sie die Signalform "Pulse".
    Drücken Sie auf [Waveforms] > Pulse, um die Pulsfunktion auszuwählen.
  2. Stellen Sie die gewünschte Pulsperiode ein.
    Drücken Sie auf die Taste [Units] und dann Frequency/Period, um Period auszuwählen. Drücken Sie dann auf [Parameters] > Period. Stellen Sie die Periode auf 500 ms ein.
    Wählen Sie die Pulsperiode
  3. Stellen Sie die gewünschte Pulsbreite ein.
    Drücken Sie auf [Parameters] > Pulse Width. Stellen Sie dann die Pulsbreite auf 10 ms ein. Die Pulsbreite ist definiert als das Zeitintervall zwischen dem 50 %-Schwellenwert der Anstiegsflanke und dem 50 %-Schwellenwert der nächsten Abfallflanke.
    Stellen Sie die Pulsbreite auf 10 ms ein
  4. Stellen Sie die Flankenzeit für beide Flanken ein.
    Drücken Sie auf den Softkey Edge Times und stellen Sie die Flankenzeit für beide Flanken (die positive und die negative) auf 50 ns ein. Die Flankenzeit ist definiert als das Zeitintervall vom 10 %-Schwellenwert bis zum 90 %-Schwellenwert jeder Flanke.

Auswählen eines gespeicherten Arbiträrsignals

Neun verschiedene Arbiträrsignale sind in einem nichtflüchtigen Speicher abgelegt. Sie heißen Cardiac, D-Lorentz, Exponential Fall, Exponential Rise, Gaussian, Haversine, Lorentz, Negative Ramp und Sinc.

Nachfolgend wird gezeigt, wie Sie die integrierte Wellenform "exponentieller Abfall" über das vordere Bedienfeld auswählen. Informationen über das Erstellen benutzerdefinierter Arbiträrwellenformen finden Sie unter Set Up Arbitrary Waveform.

  1. Drücken Sie auf [Waveforms] > Arb > Arbs.
  2. Wählen Sie Select Arb und wählen Sie über den Drehknopfs Exp_Fall. Drücken Sie auf Select.
    Nach Auswahl von Exp_Fall

Benutzen des integrierten Hilfesystems

Das integrierte Hilfesystem bietet zu jeder Taste und jedem Softkey kontextsensitive Hilfe. Außerdem steht Ihnen eine Liste mit Hilfethemen für die manuelle Bedienung zur Verfügung.

Rufen Sie die Hilfe-Informationen zu einer Funktionstaste auf

Drücken und halten Sie einen Softkey oder eine Taste, z. B. [Waveforms]. Falls der Hilfe-Text so lang ist, dass er nicht vollständig auf dem Display angezeigt werden kann, können Sie den nicht sichtbaren Text über den Softkey "Down arrow" oder den Drehknopf anzeigen.

Drücken Sie zum Verlassen der Hilfe auf Done.

Rufen Sie die Liste der Hilfe-Themen auf.

Drücken Sie zum Aufrufen der Liste mit den Hilfe-Themen auf [System] > Help. Um die Liste durchzublättern, drücken Sie die Softkeys Up / Down Arrow oder betätigen Sie den Drehknopf. Wählen Sie das Thema Get HELP on any key und drücken Sie anschließend Select. Die Themen können je nach Modell und Firmware-Version von der oben gezeigten Liste abweichen.

Drücken Sie zum Verlassen der Hilfe auf Done.

Rufen Sie die Hilfe-Information zu angezeigten Meldungen auf.

Wenn ein Grenzwert überschritten oder eine ungültige Einstellung vorgenommen wird, zeigt das Gerät eine Fehlermeldung an. Das integrierte Hilfesystem liefert zusätzliche Informationen über die letzte Meldung. Drücken Sie auf [System] > Help. Wählen Sie dann das Thema View the last message displayed und drücken Sie auf Select.

Drücken Sie zum Verlassen der Hilfe auf Done.

Hinweis

Hilfe in Ihrer Landessprache

Alle Meldungen, die kontextsensitive Hilfe und die Hilfe-Themen können auf Englisch, Chinesisch, Französisch, Deutsch, Japanisch, Koreanisch und Russisch angezeigt werden. Die Softkey-Funktionsbezeichnungen und Statuszeilen-Meldungen sind nicht übersetzt. Um Ihre Landessprache zu wählen, drücken Sie auf [System] > System Setup > User Settings > Help Lang. Wählen Sie dann die gewünschte Sprache.

So montieren Sie das Gerät im Gestell

Sie können das Gerät mit einem der beiden optionalen Kits, von denen jedes Anleitungen und Montagekomponenten enthält, in einem 19-Zoll-Gestell montieren. Neben dem Gerät können Sie noch ein beliebiges weiteres Keysight System II-Gerät gleicher Größe einbauen.

Hinweis

Entfernen Sie den Tragegriff und die Gummistoßdämpfer auf der Vorder- und Rückseite, bevor Sie das Gerät in ein Gestell einbauen.

Um den Griff zu entfernen, müssen Sie ihn in die aufrechte Position drehen und die Enden nach außen ziehen.

Zum Entfernen eines Stoßdämpfers müssen Sie diesen an einer Ecke anziehen und dann vom Gehäuse abziehen.

Symmetrie 0 | Symmetrie 100
Vorderseite | Rückseite (Untenansicht)

Um ein einzelnes Gerät zu montieren, bestellen Sie Adapter-Kit 5063-9240.
Abbildung 5063-9240

Zum Einbau von zwei Geräten nebeneinander benötigen Sie den Verbindungssatz 5061-9694 und den Flanscheinbausatz 5063-9212. Die Laufschienen im Gestell müssen benutzt werden.
Abbildung 5061-8769

Hinweis

Um Überhitzung zu vermeiden, darf die Luftzirkulation zum Gerät und im Gerät nicht behindert werden. Luft zirkuliert von der Rückseite des Geräts über beide Seiten und die Unterseite. Stellen Sie sicher, dass mindestens eine Seite freisteht, damit die zirkulierende Luft entweichen kann. Stellen Sie sicher, dass der Lüfter an der Rückseite des Geräts freisteht und die Luft frei zirkulieren kann.

Die Lüfter der Geräte der 33600 Series arbeiten bei konstanter Geschwindigkeit und einer Umgebungstemperatur von 28 °C. Die Geschwindigkeit wird erhöht, wenn die Umgebungstemperatur 28 °C übersteigt.

Die Geräte der 33600 Series melden grenzwertige Innentemperaturen und schalten sich aus, wenn die Temperaturgrenzwerte nicht eingehalten werden. Der Ausfall der Lüfter kann zum Abschalten führen.


Menüreferenz der Frontplatte

Bedienung des Frontplattenmenüs

Dieser Abschnitt stellt die Tasten und Menüs der Frontplatte vor. Unter Merkmale und Funktionen, Menüreferenz der Frontplatte, LAN Konfigurationsverfahren und Arbiträrsignal einrichten finden Sie zusätzliche Informationen über die Frontplattenbedienung.

  • Lastwiderstand wählen
  • Gerät zurücksetzen
  • Moduliertes Signal ausgeben
  • FSK-Signal ausgeben
  • PWM-Signal ausgeben
  • Frequenzwobbelung ausgeben
  • Burst-Signal ausgeben
  • Wobbelung oder Burst-Signal auslösen
  • Speichern oder Abfragen des Gerätezustands

Lastwiderstand wählen

Das Gerät verfügt über eine unveränderliche Ausgangsimpedanz von 50 Ω für die Kanalanschlüsse der Frontplatte. Falls die Lastimpedanz vom angegebenen Wert abweicht, werden falsche Amplituden- und Offsetwerte angezeigt. Der Lastwiderstandswert dient lediglich zur Überprüfung, dass die angezeigten Spannungswerte der erwarteten Last entsprechen.

  1. Drücken Sie eine Kanalausgangstaste, um den Bildschirm Kanalkonfiguration zu öffnen. Beachten Sie, dass die aktuellen Lastwiderstandwerte (in diesem Fall zweimal 50 Ω) in den Registerkarten oben im Bildschirm angezeigt werden.
  2. Beginnen Sie mit der Angabe des Lastwiderstands, indem Sie Output Load drücken.
    Lastwiderstand angeben
  3. Wählen Sie den gewünschten Lastwiderstand mit dem Drehknopf oder der Zifferntastatur, um die gewünschte Lastimpedanz auszuwählen, oder drücken Sie Set to 50 Ω oder Set to High Z.

Gerät zurücksetzen

Um das Gerät auf die Werkseinstellung zurückzusetzen, drücken Sie [System] > Set to Defaults > Yes.

Moduliertes Signal ausgeben

Ein moduliertes Signal besteht aus einem Trägersignal und einem Modulationssignal. In der Amplitudenmodulation (AM) wird die Trägeramplitude durch das Modulationssignal verändert. In diesem Beispiel erfolgt die Ausgabe eines AM- signals mit einem Modulationsgrad von 80%. Das Trägersignal ist ein Sinussignal mit einer Frequenz von 5kHz und das Modulationssignal ein Sinussignal mit einer Frequenz von 200Hz.

  1. Wählen Sie Signalform, Frequenz und Trägeramplitude.
    Drücken Sie [Waveforms] > Sine. Drücken Sie die Softkeys Frequency, Amplitude und Offset, um das Trägersignal zu konfigurieren. Wählen Sie in diesem Beispiel ein 5 kHz Sinussignal mit einer Amplitude von 5 Vpp und einem Offset von 0 V.

    Beachten Sie, dass Sie die Amplitude in Vpp, Vrms oder dBm angeben können.
  2. Wählen Sie AM.
    Drücken Sie [Modulate] und wählen Sie AM mit dem Softkey Type. Drücken Sie dann den Softkey Modulate, um die Modulation zu starten. Beachten Sie, dass die Taste [Modulate] beleuchtet ist und die Statusmeldung "AM Modulated by Sine" oben links im Display angezeigt wird.
  3. Wählen Sie den Modulationsgrad.
    Drücken Sie den Softkey AM Depth und stellen Sie den Wert dann mit der Zifferntastatur oder mit Drehknopf und Pfeilen auf 80%.
  4. Wählen Sie die Modulationssignalform.
    Drücken Sie Shape, um die Form des Modulationssignals zu wählen. Wählen Sie in diesem Fall die Signalform „Sine“.
  5. Drücken Sie AM Freq. Bei 33500 Series müssen Sie zunächst den Softkey More drücken, um zum richtigen Menü zu gelangen. Stellen Sie den Wert mit der Zifferntastatur oder mit Drehknopf und Pfeilen auf 200 Hz. Drücken Sie Hz zur weiteren Eingabe der Zahl, wenn Sie die Zifferntastatur verwenden.

FSK-Signal ausgeben

Mit der FSK modulation können Sie das Gerät so konfigurieren, dass die Ausgangsfrequenz zwischen zwei voreingestellten Werten (als "Trägerfrequenz" und "Hop-Frequenz" bezeichnet) "wechselt". Die Geschwindigkeit, mit der der Ausgang zwischen diesen beiden Frequenzen wechselt, wird vom internen Wiederholratengenerator oder dem Signalpegel am rückseitigen Anschluss Ext Trig bestimmt. In diesem Beispiel stellen Sie die "Träger"-Frequenz auf 5 kHz und die "Hop"-Frequenz auf 500 Hz, mit einer FSK-Rate von 100 Hz.

  1. Wählen Sie Signalform, Frequenz und Trägeramplitude.
    Drücken Sie [Waveforms] > Sine. Drücken Sie die Softkeys Frequency, Amplitude und Offset, um das Trägersignal zu konfigurieren. Wählen Sie in diesem Beispiel ein 5 kHz Sinussignal mit einer Amplitude von 5 Vpp und einem Offset von 0 V.
  2. Wählen Sie FSK.
    Drücken Sie [Modulate] und wählen Sie dann FSK mit dem Softkey Type. Drücken Sie dann den Softkey Modulate, um die Modulation zu starten. Beachten Sie die Statusmeldung "FSK-moduliert" oben links in der Anzeige.
  3. Stellen Sie die "Hop"-Frequenz ein.
    Drücken Sie den Softkey Hop Freq und stellen Sie dann den Wert mit der Zifferntastatur oder mit Drehknopf und Pfeilen auf 500 Hz ein. Stelen Sie bei Verwendung der Zifferntastatur sicher, die Eingabe durch einen Druck auf Hz zu beenden.
    Stellen Sie die Hop-Frequenz auf 500
  4. Geben Sie die FSK-"Wechsel"-Rate an.
    Drücken Sie den Softkey FSK Rate und stellen Sie den Wert dann mit der Zifferntastatur oder mit Drehknopf und Pfeilen auf 100 Hz.
    Stellen Sie die FSK-Rate auf 100 Hz

An dieser Stelle gibt das Gerät ein FSK-Signal aus, wenn die Kanalausgabe aktiviert ist.

PWM-Signal ausgeben

Sie können das Gerät so konfigurieren, dass es ein pulsbreitenmoduliertes (pulse width modulated: PWM) Signal ausgibt. PWM steht nur für das Pulssignal zur Verfügung und die Pulsbreite ist vom Mosulationssignal abhängig. Der Wert der Pulsbreitenschwankung wird als Pulsbreitenabweichung bezeichnet und kann als Prozentsatz der Signalperiode (d. h. des Tastverhältnisses) oder in Zeiteinheiten angegeben werden. Wenn Sie z. B. einen Puls mit einem Tastverhältnis von 20 % angeben und dann PWM mit einer Abweichung von 5% aktivieren, schwankt das Tastverhältnis von 15% bis 25%, je nach Modulationssignal.

Um von Pulsbreite zum Tastverhältnis eines Pulssignals zu wechseln, drücken Sie [Units].

In diesem Beispiel geben Sie Pulsbreite und Pulsbreitenabweichung für ein 1 kHz Pulssignal von 5‑Hz mit einem 5Hz Sinuswellen-Modulationssignal an.

  1. Wählen Sie die Parameter des Trägersignals.
    Drücken Sie [Waveforms] > Pulse. Verwenden Sie die Softkeys Frequency, Amplitude, Offset, Pulse Width und Edge Times zur Konfiguration des Trägersignals. In diesem Beispiel wählen Sie ein Pulssignal von 1 kHz mit der Amplitude 1 Vpp, dem Offsetwert Null, eine Pulsbreite von 100 µs, und eine Flankenzeit von 50 ns (Anstiegs- und Abfallflankenzeit).
    Alle Pulseinstellungen
  2. Wählen Sie PWM.
    Drücken Sie [Modulate] > Type > PWM. Drücken Sie dann den ersten Softkey (Modulate), um die Modulation zu starten. Beachten Sie die Statusmeldung "PWM Modulated by Sine", die oben links im Display angezeigt wird.
    PWM-Modulation durch Sinus
  3. Pulsbreitenabweichung einstellen.
    Drücken Sie den Softkey Width Dev und stellen Sie den Wert dann mit der Zifferntastatur oder mit Drehknopf und Pfeilen auf 20 µs.
    Stellen Sie die Pulsbreitenabweichung auf 20 Mikrosekunden
  4. Wählen Sie die Modulationsfrequenz.
    Drücken Sie den Softkey PWM Freq und stellen Sie dann den Wert mit der Zifferntastatur oder mit Drehknopf und Pfeilen auf 5 Hz.
    PWM-Frequenz auf 5 Hz einstellen
  5. Wählen Sie die Modulationssignalform.
    Drücken Sie Shape, um die Form des Modulationssignals zu wählen. Wählen Sie in diesem Fall die Signalform „Sine“.

Um das aktuelle PWM-Signal anzuzeigen, müssen Sie es an ein Oszilloskop ausgeben. Dabei sehen Sie, wie die Pulsbreite variiert (in diesem Fall von 80 bis 120 µs). Bei einer Modulationsfrequenz von 5 Hz ist die Abweichung deutlich.

Frequenzwobbelung ausgeben

Bei der Frequenzwobbelung bewegt sich das Gerät mit der von Ihnen angegebenen Wobbelrate von der Start- bis zur Stop-Frequenz. Sowohl die Richtung der Wobbelung (aufwärts oder abwärts) als auch deren Zeitverlauf (linear oder logarithmisch) oder die Verwendung einer Frequenzliste sind wählbar. In diesem Beispiel geben Sie eine gewobbelte Sinuswelle von 50 Hz bis 5 kHz aus.

  1. Wählen Sie Funktion und Amplitude für die Wobbelung.
    Für Wobbelungen können Sie Sinus-, Rechteck-, Sägezahn-, Puls-, Dreiecks-, PRBS- oder Arbiträrsignale auswählen (Rauschen und DC sind nicht zulässig). Wählen Sie in diesem Beispiel die Signalform Sinus und eine Amplitude von 5 Vpp.
    Sinuswelle 5 Vpp
  2. Wählen Sie die Betriebsart Wobbelung.
    Drücken Sie [Sweep] und überprüfen Sie, dass die Wobbelcharakteristik "linear" aktuell für den zweiten Softkey ausgewählt ist. Drücken Sie den Softkey Sweep, um die Wobbelung einzuschalten. Beachten Sie die Statusmeldung Linear Sweep oben in der Registerkarte für den Stromkanal. Die Taste leuchtet ebenfalls.
  3. Stellen Sie die Start-Frequenz ein.
    Drücken Sie Start Freq und stellen Sie dann den Wert mit der Zifferntastatur oder mit Drehknopf und Pfeilen auf 50 Hz.
    Startfrequenz auf 50 stellen
  4. Stellen Sie die Stop-Frequenz ein.
    Drücken Sie Stop Freq und stellen Sie dann den Wert mit der Zifferntastatur oder mit Drehknopf und Pfeilen auf 5 kHz.

Nun gibt das Gerät eine kontinuierliche Folge von Wobbelzyklen von 50 Hz bis 5 kHz aus, wenn die Ausgabe aktiviert ist.

Stop-Frequenz auf 5 kHz einstellen

Sie können auch die Frequenzgrenzen für die Wobbelung einstellen (mit Mittenfrequenz und Frequenzspanne). Diese Parameter stehen in direktem Zusammenhang mit den Start- und Stop-Frequenzen (siehe oben) und bieten mehr Flexibilität. Im vorliegenden Beispiel müssen Sie die Mittenfrequenz auf 2.525 kHz und die Wobbelbandbreite auf 4.950 kHz einstellen, um die gleichen Ergebnisse zu erhalten.

Wobbelung von Parametereinheiten

Um eine Frequenzwobbelung durchzuführen, drücken Sie zweimal auf [Trigger]. Der erste Druck wählt die Triggerbetriebsart „Manual“, der zweite sendet einen Trigger. Ausführlichere Informationen finden Sie unter Trigger-Wobbelung oder Burst.

Burst-Signal ausgeben

Sie können das Gerät so konfigurieren, dass es einen Burst, d.h. ein Signal für eine bestimmte Anzahl von Zyklen ausgibt. Sie können die zeitlichen Abstände zwischen Burst-Signalen mit dem internen Timer des Geräts oder der Signalstufe des Ext Trig Anschlusses auf der Rückseite prüfen. In diesem Beispiel wird ein Sinus-Burst mit einer Länge von drei Zyklen und einer Burst-Periode von 20 ms ausgegeben.

  1. Wählen Sie die Signalform und die Amplitude des Burst-Signals.
    Für Burst-Signale können Sie Sinus-, Rechteck-, Sägezahn-, Puls-, Arbiträr-, Dreieck- oder PRBS-Signale wählen. Rauschen ist nur im "Gate"-Burstmodus zulässig, DC it nicht zulässig. Wählen Sie in diesem Beispiel die Signalform Sinus und eine Amplitude von 5 Vpp.
    Sinuswelle 5 Vpp
  2. Wählen Sie die Burst-Betriebsart.
    Drücken Sie [Burst] > Burst Off/On. Beachten Sie die Statusmeldung N Cycle Burst, Trig Imm, die in der Registerkarte des aktuellen Kanals angezeigt wird.
    Burst-Anzeige in Registerkarte
  3. Wählen Sie die Burst-Anzahl.
    Drücken Sie # of Cycles und stellen Sie die Anzahl mit der Zifferntastatur oder dem Drehknopf auf "3". Drücken Sie Enter zur weiteren Dateneingabe, wenn Sie die Zifferntastatur verwenden.
    Setzen Sie den Zykluszähler auf 3
  4. Geben Sie die Burst-Periode an.
    Drücken Sie Burst Period und stellen Sie mit Zifferntastatur oder Drehknopf und Pfeilen 20 ms ein. Die Burst-Periode ist das Zeitintervall zwischen dem Anfang eines Bursts und dem Anfang des nächsten Bursts. Das Gerät gibt jetzt eine kontinuierliche Folge von Bursts mit je drei Zyklen aus (in 20 ms-Intervallen).
    Stellen Sie die Burst-Periode auf 20 ms ein.

Durch Drücken der Taste [Trigger] können Sie einen einzelnen Burst (mit der spezifizierten Anzahl von Zyklen) erzeugen. Ausführlichere Informationen finden Sie unter Trigger-Wobbelung oder Burst.

Sie können außerdem ein externes Torsignal verwenden, um "Gated Bursts" zu erzeugen, wenn ein Burst erzeugt wird, während ein Gate-Signal am Eingang vorhanden ist.

Wobbelung oder Burst-Signal auslösen

Sie können für Wobbelungen und Bursts eine von verschiedenen Triggerarten über die Frontplatte auswählen:

  • Direkte oder "automatische" Trigger (Standard): Die Geräteausgabe erfolgt kontinuierlich, wenn der Wobbel- oder Burstmodus ausgewählt ist.
  • Extern: Die Triggerung wird durch den Anschluss Ext Trig der Rückwand kontrolliert .
  • Manuell: Löst bei jedem Druck auf [Trigger] einen einzelnen Wobbelzyklus bzw. Burst aus. Halten Sie [Trigger] gedrückt, um das Gerät erneut zu triggern.
  • Timer: Wählt einen oder mehrere Trigger mit einem festgelegten Zeitabstand.

Wenn Wobbelung oder Burst eingestellt ist, wird durch einen Druck auf [Trigger] das Triggermenü angezeigt. Eine beleuchtete [Trigger]-Taste (kontinuierlich oder blinkend) zeigt an, dass einer oder beide Kanäle auf einen manuellen Trigger warten. Die Taste leuchtet kontinuierlich, wenn das Triggermenü ausgewählt ist und blinkt, wenn das Triggermenü nicht ausgewählt ist. Die Taste [Trigger] ist deaktiviert, wenn sich das Gerät im Remotemodus befindet.

Ein Druck auf [Trigger], wenn die Taste kontinuierlich leuchtet, löst einen manuellen Trigger aus. Ein Druck auf [Trigger], wenn die Taste blinkt, wählt das Triggermenü; ein zweiter Druck löst einen manuellen Trigger aus.

Speichern oder Abfragen des Gerätezustands

Sie können Gerätezustände in einer beliebigen Anzahl von Gerätezustandsdateien (Erweiterung: .sta) speichern. Sie können dies zu Backup-Zwecken tun oder Ihren Gerätezustand auf einem USB-Speichergerät speichern und auf ein anderes Gerät mit ähnlichen Konfigurationen laden. Ein gespeicherter Gerätezustand enthält die gewählte Funktion, Frequenz, Amplitude, DC-Offset, Tastverhältnis, Symmetrie und alle verwendeten Modulations- oder Burst-Parameter. Das Gerät speichert keine flüchtigen Arbiträrsignale.

  1. Wählen Sie den gewünschten Speicherort.
    System-Taste Store - Softkey Recall Softkey Store State
  2. Drücken Sie Name und geben Sie den Namen für den ausgewählten Speicherort an.

    Tastenfeld und Drehknopf

    33500 Series
    Wenn Sie weitere Zeichen hinzufügen möchten, drücken Sie die rechte Pfeiltaste so oft, bis der Cursor sich rechts vom derzeiten Namen befindet, und drehen Sie dann am Drehknopf. Um ein Zeichen zu löschen, drehen Sie den Drehknopf, bis Sie zum Leerzeichen vor dem Großbuchstaben A gelangen. Um alle Zeichen von der Cursor-Position bis zum Ende der Zeile zu löchen, drücken Sie [+/-]. Sie können Zahlen direkt über die Zifferntatatur eingeben.

    33600 Series
    Verwenden Sie die Frontplatten-Pfeile nach rechts und nach links (unter dem Drehknopf) zur Auswahl der zu bearbeitenden Zeichen. Sie können nach dem letzten Zeichen ein neues Endzeichen hinzufügen. Wählen Sie dann mit dem Drehknopf das gewünschte Zeichen aus und gehen Sie mit den Pfeilen zum nächsten zu bearbeitenden Zeichen.

    Sie können ein oder mehrere Zeichen mit den Softkeys Delete Char und Clear Entry löschen.

    Drücken Sie Done, wenn Sie die Namenseingabe beendet haben.
  3. Speichern Sie den Gerätezustand ab.
    Speichern Sie den Softkey State

So stellen Sie einen gespeicherten Zustand wieder her (bzw. rufen ihn wieder auf):
Softkey Store - Recall Softkey Recall State


Menüreferenz der Frontplatte

Dieses Kapitel beginnt mit einer Übersicht über die Frontplattenmenüs. Der restliche Teil dieses Kapitels enthält Beispiele für die Verwendung dieser Menüs.

Wählt die Wellenform

  • Sinus
  • Rechteck
  • Sägezahn
  • Puls
  • Arbiträrsignal
  • Dreieck
  • Rauschen
  • PRBS
  • Gleichstrom

Konfiguriert wellenformspezifische Parameter

  • Periode/Frequenz
  • Amplitude oder Hohes und Niedriges Spannungsniveau
  • Offset
  • Phase
  • Tastgrad
  • Symmetrie
  • Pulsbreite
  • Flankenzeiten
  • Arbiträrsignal
  • Samplingrate
  • Filter
  • Arb-Phase
  • Bandbreite
  • PRBS -Daten
  • Bitrate

Gibt Einheiten- und Parametereinstellungen an

  • Arb-Rate: Sa/s, Freq oder Periode
  • Spannung als Amplitude/Offset oder Hoch/Niedrig
  • Amplitudeneinheiten:Vpp, Vrms oder dBm
  • Pulsbreite oder Tastgrad
  • Burst-Phase als Grad, Radiant oder Sekunden
  • Arb-Phase als Grad, Radiant, Sekunden oder Proben
  • Frequenzwobbelung als Center/Span oder Start/Stop

Konfiguriert Modulationsparameter

  • Modulation ein oder aus
  • Modulationsart: AM, FM, PM, PWM, BPSK, FSK oder Summe
  • Modulationsquelle
  • Modulationsparameter (variiert nach Modulationsart)

Konfiguriert die Parameter für die Frequenzwobbelung

  • Wobbelung ein oder aus
  • Sweep-Typ: Linear, logarithmisch oder Frequenzliste
  • Wobbelzeit
  • Start-/Stopp-Frequenzen oder Center/Span-Frequenzen
  • Dwell-, Halte- und Rücklaufzeiten

Konfiguriert Burst-Parameter

  • Burst ein oder aus
  • Burst-Modus: getriggert (N-Zyklus) oder externally-gated
  • Zyklen pro Burst (1 bis 100.000.000 oder unendlich)
  • Start-Burstphasenwinkel (-360° bis +360°)
  • Burst-Periode

Softkey Store - Recall

Speichern und Abrufen von Gerätezuständen

  • Speichern von Gerätezuständen in nicht-flüchtigem Speicher.
  • Zuordnung von Kundennamen zu Speicherorten.
  • Abrufen gespeicherter Gerätezustände.
  • Löschen gespeicherter Gerätezustände.
  • Wahl der Einschaltkonfiguration des Geräts (beim letzten Ausschalten oder Werkseinstellungen).

Softkey I/O Config

Konfiguriert die E/A-Schnittstellen des Geräts

  • LAN ein- und ausschalten
  • Konfiguration des LAN (IP-Adresse und Netzwerkkonfiguration)
  • LAN zurücksetzen
  • USB-Einstellungen angeben
  • GPIB-Adresse auswählen

Softkey Instr Setup

Führt Systemverwaltungsaufgaben aus

  • Selbsttest durchführen
  • Gerät kalibrieren
  • Inhalt des Gerätespeichers löschen (sicher gemäß NISPOM)
  • Lizenzmerkmale installieren
  • Firmware aktualisieren

Softkey System Setup

Konfiguriert Systemparameter

  • Bildschirmlayout einrichten
  • Wahl der Sprache für Frontplattenmeldungen und Hilfetexte
  • Wahl zwischen Dezimalpunkt oder Dezimalkomma (für die Anzeige numerischer Werte im Display)
  • Display ein- und ausschalten
  • Fehlersignalton aktivieren oder deaktivieren
  • Klick auf das Tastenfeld aktivieren / deaktivieren
  • Bildschirmschoner aktivieren oder deaktivieren
  • Helligkeit des Displays anpassen
  • Datum und Uhrzeit einstellen
  • Dateien und Ordner verwalten (kopieren, umbenennen, löschen, Screenshot etc.)
  • Konfigurieren des 10 MHz Referenzoszillators

Zeigt die Liste der Hilfethemen an

  • Abrufen der zuletzt angezeigten Meldung
  • Abrufen der Fernsteuerungs-Fehlerwarteschlange
  • Abrufen der Hilfe für eine bestimmte Taste
  • Erfahren Sie, wie man technische Unterstützung erhält
  • Abrufen von "Info"-Daten - Seriennummer, IP-Adresse, Firmware-Version etc.

Aktiviert und konfiguriert Kanäle

  • Kanal ein- und ausschalten
  • Angeben, welcher Kanal für die Menüs aktiviert ist
  • Lastwiderstand wählen (1 Ω bis 10 kΩ oder unendlich)
  • Aktivieren / Deaktivieren der automatischen Amplitudenbereichswahl
  • Wahl der Signalpolarität (normal oder invertiert)
  • Angeben der Spannungsgrenzen
  • Angeben, ob es sich um einen normalen oder angesteuerten Ausgang handelt
  • Zweikanaloperation konfigurieren (koppeln, verfolgen und kombinieren)

Konfiguriert Triggereinstellungen und „Sync“-Ausgangssignal

  • Bei Aufleuchten einen manuellen Trigger ausführen
  • Triggerquelle für Wobbelung, Burst oder Arbiträrsignal-Vorlauf angeben
  • Triggerstufe, -zahl und -verzögerung angeben
  • Neigung (steigende oder fallender Flanke) für externe Triggerquelle angeben
  • Neigung (steigende oder fallende Flanke) für das Triggerausgangssignal angeben
  • Signalausgang über den "Sync"-Anschluss aktivieren / deaktivieren
  • Sync-Quelle, Polarität, Modus, Marker-Punkt etc.


LAN-Konfigurationsverfahren

Zum Einrichten der Netzwerkkommunikation über die LAN-Schnittstelle müssen unter Umständen mehrere Parameter festgelegt werden. In erster Linie müssen Sie eine IP-Adresse einrichten. Möglicherweise müssen Sie Ihren Netzwerkadministrator bitten, Ihnen beim Einrichten der Kommunikationsverbindung zur LAN-Schnittstelle zu helfen.

  1. Wählen Sie das Menü „I/O“.
    Drücken Sie [System] > I/O Config.
  2. Wählen Sie das Menü LAN-Einstellungen.
    Drücken Sie den Softkey LAN Settings.

    Sie können zur Einstellung der LAN-Einstellungen Modify Settings wählen, die LAN-Dienste ein- und wieder ausschalten oder die LAN-Einstellungen auf die Standardwerte zurücksetzen.
    Menü "LAN-Einstellungen"

    Dieser Bildschirm spiegelt das 33500 Series Display wider. Zur 33600 Series gehört auch eine Statusanzeige oben rechts, die anzeigt, ob die LAN-Verbindung korrekt oder fehlerhaft ist.
  3. Drücken Sie Modify Settings.
    Ändern Sie die LAN-Einstellungen

    Nutzen Sie für den Zugriff auf die meisten Elemente dieses Bildschirms den ersten Softkey, um von DHCP zu Manual zu wechseln. Ist DHCP aktiviert, erstellt das DHCP (Dynamic Host Configuration Protocol) automatisch eine IP-Adresse, wenn Sie das Gerät an das Netzwerk anschließen, vorausgesetzt, der DHCP-Server wird gefunden und ist dazu fähig. DHCP richtet, falls erforderlich, auch automatisch die Subnet Mask und die Gateway-Adresse ein. Dies ist im Allgemeinen der einfachste Weg, eine LAN-Kommunikation für Ihr Gerät einzurichten. Sie brauchen lediglich die Einstellung DHCP On beizubehalten. Näheres erfahren Sie von Ihrem Netzwerkadministrator.
  4. Richten Sie ein Internet-Protokoll ein („IP Setup“).
    Wenn Sie nicht DHCP verwenden (wenn der erste Softkey auf Manual steht), müssen Sie zuerst einen IP-Setup einschließlich der IP-Adresse durchführen und möglicherweise zusätzlich eine Subnet Mask und eine Gateway-Adresse einrichten. Die Schaltflächen IP Address und Subnet Mask befinden sich auf dem Hauptbildschirm. Drücken Sie More, um die Gateway zu konfigurieren.

    Haupt-LAN-Konfigurationsbildschirm

    Welche IP-Adresse, Subnet Mask und Gateway zu verwenden sind, erfahren Sie von Ihrem Netzwerkadministrator. Alle IP-Adressen weisen die Punktnotation „nnn.nnn.nnn.nnn“ auf, wobei es sich bei „nnn“ jeweils um einen Byte-Wert im Bereich von 0 bis 255 handelt. Eine neue IP-Adresse können Sie über die Zifferntastatur (nicht mit dem Drehknopf) eingeben. Geben Sie die Ziffern und die Punkt-Trennzeichen einfach über die Tastatur ein. Verwenden Sie die Links-Cursor-Taste als Rücktaste. Geben Sie keinesfalls führende Nullen ein.
  5. Konfigurieren Sie das "DNS Setup" (optional)
    DNS (Domain Name Service) ist ein Internet-Dienst, der die Namen von Domains in IP-Adressen übersetzt. Fragen Sie Ihren Netzwerkadministrator, ob ein DNS in Verwendung ist und falls ja, welcher Name für den Host, für die Domain und welche Adresse für den DNS-Server verwendet werden sollen.
  1. "Hostname" einstellen. Drücken Sie Host Name und geben Sie den Hostnamen ein. Beim Hostnamen handelt es sich um den Host-Anteil des Domain-Namens, der anschließend in eine IP-Adresse übersetzt wird. Der Hostname wird als Zeichenfolge mit dem Drehknopf und den Cursor-Tasten (zum Auswählen und Ändern von Zeichen) eingegeben. Der Hostname kann Buchstaben, Ziffern und Bindestriche ("-") enthalten. Die Tastatur können Sie nur für die numerischen Zeichen verwenden.
  2. Richten Sie die Adresse des "DNS Server" ein. Drücken Sie auf dem Bildschirm LAN-Konfiguration More, um zum zweiten von drei Softkey-Sets zu gehen.
    DNS Konfigurationsbildschirm

    Geben Sie die Primäre DNS und die Sekundäre DNS ein. Näheres erfahren Sie von Ihrem Netzwerkadministrator.

Weitere Informationen zu IP-Adressen und zur Punktnotation

Adressen in Punktnotation ("nnn.nnn.nnn.nnn", wobei "nnn" einem Byte-Wert von 0 bis 255 entspricht) müssen sorgfältig angegeben werden, da die meisten PC-Web-Softwares Byte-Werte, die mit Nullen beginnen, als Zahlen im Oktalformat (mit Basis 8) interpretieren. So entspricht z. B. "192.168.020.011" tatsächlich dem Dezimalwert "192.168.16.9", da ".020" als "16" im Oktalformat interpretiert wird, und ".011" als "9". Um Missverständnisse auszuschließen, empfiehlt es sich, ausschließlich Dezimalwerte (von 0 bis 255) ohne führende Nullen zu verwenden.


Arbiträrsignal einrichten

Das Gerät umfasst einen integrierten Arbiträrsignal-Editor, mit dem Sie Arbiträrsignale erstellen und bearbeiten können. Sie können diese Signale direkt durch Bearbeiten der Spannungswerte erstellen, oder durch eine Kombination von bis zu 12 verschiedenen Arten von Standardsignalen.

In folgendem Tutorial wird eine Basiswellenform erstellt und bearbeitet.

Interne Signale einfügen

  1. Starten Sie den integrierten Arbiträrsignal-Editor durch einen Druck auf [Waveforms] > Arb > Arbs. Drücken Sie Edit New, übernehmen Sie den Standarddateinamen und drücken Sie dann Start Editor. Nun sehen Sie ein 0 VDC Signal mit exakt 8 Punkten (33500 Series) oder 32 Punkten (33600 Series).
    Standardwellenform

    Das restliche Tutorial betrifft den integrierten Signal-Editor in einem 33500 Series Gerät (Mindestgröße des Signals: 8 Punkte). Wenn Sie dieses Tutorial für ein 33600 Series Gerät verwenden, beachten Sie bitte, dass das Signal mindestens 32 Punkte groß sein muss.
  2. Drücken Sie Insert Built-in > Choose Wave. Wählen Sie mit Drehknopf oder den Pfeilen unter dem Drehknopf D-Lorentz und drücken Sie OK. Verwenden Sie die Zifferntastatur und den Softkey V, der angezeigt wird, wenn Sie auf der Zifferntastatur einen Wert eingeben, um die Amplitude auf 2 V einzustellen, und drücken Sie dann OK. Nun hat das Signal 100 zusätzliche Punkte, da das D-Lorentz-Signal mit 100 Punkten vor dem ursprünglichen Signal eingefügt wurde.
    Nach Einfügen von D-Lorentz
  3. Nehmen wir einmal an, dass Sie die soeben vorgenommene Änderung rückgängig machen wollen. Drücken Sie [System] > Undo. Nun sind Sie wieder bei der ursprünglichen 0 V-Wellenform.
    Nach Rückgängigmachen von D-Lorentz
  4. Um das D-Lorentz-Signal wiederherzustellen, drücken Sie Redo. Drücken Sie dann zum Beenden Done.
    Nach Wiederherstellen von D-Lorentz
  5. Nun fügen wir eine Sinuswelle ein. Beginnen Sie mit einem Druck auf Choose Wave. Stellen Sie sicher, dass Sinus (Standardeinstellung) markiert ist und drücken Sie OK. Hilfreiche Informationen über die verschiedenen Parameter auf dem Bildschirm erhalten Sie durch einen Druck auf Parameter Help. Drücken Sie dann zum Verlassen des Hilfe-Bildschirms Done.
    Einrichten der Sinusparameter
  6. Stellen Sie mit der Zifferntastatur und den Softkeys Pfeil nach oben und Pfeil nach unten die Amplitude auf 3,5 V, die Cycles auf 4 und die Points auf 200. Übernehmen Sie die Standardwerte für alle anderen Einstellungen und drücken Sie OK.
    Nach Einfügen der Sinuswelle

  7. Beachten Sie, dass der erste Softkey, Select Point #, markiert ist. Stellen Sie den Marker auf den 270. Punkt des Signals, indem Sie die Zahl 270 mit der Zifferntastatur eingeben und auf Enter drücken.
    Markieren Sie Punkt 270
  8. Drücken Sie Choose Wave, wählen Sie Square und drücken Sie dann OK. Stellen Sie die Amplitude auf 3 V, den Offset auf -2 V, die Zyklen auf 8 und die Punkte auf 100. Drücken Sie OK. Beachten Sie, dass die 8 Rechteckwellenzyklen eingefügt wurden und beim Marker beginnen. Drücken Sie Done.
    Nach Einfügen der Rechteckwelle

Signalmerkmale bearbeiten

  1. Drücken Sie Edit Params und stellen Sie dann die Sampling Rate auf 100 Sa/s. Drücken Sie Cycle Period und beachten Sie, dass sie auf 4,08 Sekunden eingestellt wurde. Diese Zahl ergibt sich aus den 408 Abtastwerten im Signal und der Abtastgeschwindigkeit von 100 Sa/s.
    Abtastgeschwindigkeit auf 100 stellen
  2. Ändern Sie die Cycle Period zu 2,04 Sekunden und drücken Sie dann Sampling Rate. Sie wird nun auf 200 Sa/s eingestellt, um das Signal mit 408 Punkten in 2,04 Sekunden abzuspielen.
    Zeitwert halbieren
  3. Drücken Sie Done, um den Bildschirm zur Parameterbearbeitung zu verlassen. Drücken Sie Edit Points und beachten Sie, dass der Softkey Point # hervorgehoben ist. Geben Sie als Anzahl 160 ein und drücken Sie Enter, um den Marker zu verschieben.
    Stellen Sie den Marker auf 160
  4. Drücken Sie Voltage und ändern Sie den Spannungswert des gewählten Punktes zu 4,2 V. Drücken Sie Point # und ändern Sie den Punkt-Marker zu 150, um den Marker vom Punkt zu entfernen. Wenn Sie Enter drücken, um die Eingabe von Punkt 150 zu beenden, sehen Sie die 4,2 V-Anomalie in der gerade erstellten Welle bei Punkt 160.
    Spannung ändern zu 4,2

"Pan"- und "Zoom"-Funktion

  1. Drücken Sie für eine Detailansicht des Punktes [System] > Pan/Zoom Control. Beachten Sie, dass der erste Softkey auf Horizontal steht, was bedeutet, dass der aktuelle Zoomvorgang entlang der horizontalen (Zeit-) Achse erfolgt. Ändern Sie Zoom zu 500%, wird die Sinussignalanomalie deutlicher.
    Horizontalen Zoom auf 500 einstellen
  2. Stellen Sie nun den ersten Softkey auf Vertical, um vertikal zu zoomen. Stellen Sie den Zoom auf 500 %. Beachten Sie, dass wir die Spannungsachse vergrößert haben, uns aber zu weit unten befinden, um die 4,2 V Anomalie im Sinussignal zu sehen.
    Vertikalen Zoom auf 500 einstellen
  3. Drücken Sie Pan und stellen Sie den Wert Pan auf 3 V, um eine höhere Position im Signal einzunehmen. Der Punkt 4,2 V ist nun deutlich sichtbar.
    Pan auf 3 V
  4. Um erneut das gesamte Signal anzuzeigen, drücken Sie auf Show All. Drücken Sie dann auf Done und erneut auf Done, um zum Bildschirm Edit Points zurückzukehren.
    Nach "Alle anzeigen"

Punkte hinzufügen, entfernen, kopieren und einfügen

  1. Drücken Sie 15 Mal auf Insert Point und beobachten Sie die Anzeige aufmerksam. Sie sehen 15 neue Signalpunkte auf der gleichen Spannungsebene.
    Punkt 15 Mal einfügen
  2. Ändern Sie Point # auf 220 und drücken Sie 20 Mal auf Remove Point. Beobachten Sie die Anzeige dabei aufmerksam, um zu sehen, wie Punkte vom Signal entfernt werden.
    20 Mal Punkte entfernen
  3. Sie können Punkte auch bearbeiten, indem Sie eine Spannungstabelle verwenden. Drücken Sie auf Advanced Edit > Edit Via Table. Setzen Sie Point # auf 200 und stellen Sie dann Voltage für Punkt 200 auf 3 V. Verwenden Sie den Drehknopf zum Navigieren in den Zeilen und stellen Sie den Wert Voltage für Punkte 205 und 210 auf 3 V. Drücken Sie Done.
    Bearbeiten über Tabelle 200-210
  4. Beachten Sie die drei 3 V Spitzen, die Sie soeben an den Punkten 200, 205 und 210 im Signal erstellt haben.
    Bearbeiten über Tabelle 200-210
  5. Drücken Sie Cut/Copy Paste und stellen Sie Marker 1 auf 150. Drücken Sie dann den ersten Softkey und ändern Sie den Marker zu Marker 2. Stellen Sie Marker 2 auf 300. Der durch die Marker definierte Bereich ist nun schwarz hervorgehoben.
    Kopiermarker einstellen
  6. Drücken Sie Copy, dann Paste und dann At Start. Beachten Sie, dass der kopierte Abschnitt jetzt am Beginn des Signals verdoppelt ist.
    Zu Beginn einfügen
  7. Drücken Sie nun Paste > At End. Der gleiche Signalabschnitt wird nun ganz am Ende angezeigt.
    Am Ende einfügen
  8. Drücken Sie nun Paste und ändern Sie Point # zu 500. Drücken Sie dann OK, wird der gleiche Signalabschnitt bei Punkt 500 eingefügt. Drücken Sie Done, um das Menü Cut/Copy Paste zu verlassen.
    Bei 500 einfügen

Math-Funktionen ausführen

Mit dem integrierten Signaleditor können Sie mathematische Operationen am Signal durchführen. Stellen Sie zuerst Marker ein, um den Abschnitt des Signals festzulegen, den Sie ändern möchten. Dann können Sie diesen Signalabschnitt zu einem anderen Signal hinzufügen, von diesem abziehen oder mit diesem multiplizieren, oder das Signal auf andere Arten umwandeln, die sich nicht nicht auf andere Signale beziehen.

  1. Drücken Sie Perform Math. Stellen Sie Marker 1 auf 400 und Marker 2 auf 500.
    Stellen Sie die Marker auf 400 und 500
  2. Drücken Sie Add und wählen Sie dann Haversine und OK. Stellen Sie Amplitude auf 3 V und Offset auf 0 V ein und drücken Sie OK. Beachten Sie, dass der hervorgehobene Abschnitt als Ergebnis der Haversine-Addition jetzt in der Mitte ansteigt.
    Haversine hinzufügen
  3. Drücken Sie nun Multiply und wählen Sie Sine (Sinuswelle) (drücken Sie OK). Stellen Sie für Cycles 2 ein und drücken Sie OK.
    Mit Sinuswelle multiplizieren
  4. Stellen Sie nun Marker 1 auf 200 und Marker 2 auf 600.
    Stellen Sie die Marker auf 200 und 600
  5. Drücken Sie Advanced Math > Mirror > OK.
    Erweiterte math. Funktionen - Mirror
  6. Lernen Sie mehr über die Schnittstelle, indem Sie andere Advanced Math Funktionen testen, beispielsweise Invert, Absolute, Scale etc. Drücken Sie Operation Help, um ausführlichere Informationen zu erhalten.


Merkmale und Funktionen

Dieses Kapitel bietet Informationen zu Gerätemerkmalen wie der Bedienung von Frontplatte und Remote-Schnittstelle. Vielleicht möchten Sie zunächst Menüreferenz der Frontplatte lesen. Siehe SCPI Programming Reference für Details zu SCPI-Befehlen und -abfragen. Dieser Abschnitt behandelt folgende Themen:

Ausgangskonfiguration

Pulssignale

Amplitudenmodulation (AM) und Frequenzmodulation (FM)

Phasenmodulation (PM)

FSK-Modulation (Frequenzumtastung)

Pulsbreitenmodulation (PWM)

Summenmodulation

Frequenzwobbelung

Burst-Betriebsart

Triggerung

Zweikanaloperationen

IQ-Player (Option)

Systembezogene Vorgänge

Konfiguration der Remoteschnittstelle

Externe Zeitbasisreferenz

Integrierter Signaleditor

In diesem Dokument werden "Standard"-zustände und -werte definiert. Hierbei handelt es sich um die Standardeinstellungen beim Einschalten des Geräts, die Betriebsart Power-down recall wurde nicht aktiviert (siehe Abspeichern des Gerätezustands).


Ausgangskonfiguration

Dieser Abschnitt beschreibt die Ausgangskanalkonfiguration. Viele Befehle, die mit der Ausgangskonfiguration zusammenhängen, beginnen mit SOURce1: oder SOURce2: um einen bestimmten Kanal anzugeben. Ist nichts angegeben, ist Kanal 1 der Standardkanal. So legt z. B. VOLT 2.5 den Ausgang für Kanal 1 auf 2,5 V fest und SOUR2:VOLT 2.5 führt den gleichen Vorgang für Kanal 2 aus.

Das Display des Geräts umfasst eine "Registerkarte" für jeden Kanal, der verschiedene Aspekte zur Ausgangskonfiguration jedes Kanals zusammenfasst:
Registerkarten Kanalkonfiguration

Bei einem Zwei-Kanal-Gerät ist die Registerkarte für Kanal 1 gelb und die Registerkarte für Kanal 2 grün.

Ausgangsfunktion

Das Gerät enthält acht Standardsignale: Sinus, Rechteck,Sägezahn, Puls, Dreieck, Rauschen, PRBS (pseudozufällige Binärfolge) und DC. Weiterhin enthält es neun integrierte Arbiträrsignale, und Sie können benutzerdefinierte Signale mit dem integrierten Signaleditor erstellen.

Die nachfolgende Tabelle zeigt, welche Ausgangsfunktionen mit Modulation, Wobbelung bzw. Burst kombiniert werden können (•). Die Auswahl einer Funktion, die nicht mit einer Modulation oder einem Modus kombiniert werden darf, deaktiviert die Modulation oder den Modus.

Träger | AM | FM (Frequenzmodulation) | PM (Phasenmodulation) | FSK | BPSK | PWM | Summe | Burst | Wobbelung
Sinus und Rechteck | • | • | • | • | • |  | • | • | •
Puls | • | • | • | • | • | • | • | • | •
Dreieck und Sägezahn | • | • | • | • | • |  | • | • | •
Gaußsches Rauschen | • |  |  |  |  |  | • | •a |
PRBS | • | • | • |  |  |  | • | • |
Arbiträrsignal | • | • | •b |  | •b |  | • | • | •
Sequenz | • |  |  |  |  |  | • |  |

(a) Nur Gated Burst

(b) Gilt für Abtast-Taktgeber, nicht für das gesamte Signal

  • Frequenzbeschränkungen: Durch eine Änderung der Funktionen kann sich die Frequenz ändern, um die Frequenzgrenzen der neuen Funktion einzuhalten.
  • Amplitudenbegrenzungen: Wenn sie Ausgangseinheiten Vrms oder dBm sind, kann das Ändern der Funktionen die Amplitude für die neue Funktion aufgrund von Variation der Signalform maximal senken. Wird beispielsweise eine 5 Vrms Rechteckwelle (in 50 Ω) in eine Sinuswelle geändert, sinkt sie auf 3,536 Vrms (Obergrenze Sinus).
  • Amplitude und Offset können nicht kombiniert werden, um die Geräteleistung zu überschreiten. Die zuletzt eingestellte kann geändert werden, um innerhalb der Grenzen zu bleiben.
  • Sie können ein zu testendes Gerät (DUT) schützen, indem Sie obere und untere Ausgangsspannungsgrenzen festlegen.
  • Frontplatte:

    Taste Channel Softkey Output (Off) Softkey Output (On)

    Andere Wellenform auswählen:
    Taste Waveform
  • Beispielsweise zur Angabe eines DC-Signals:
    Taste Waveforms Softkey More Softkey DC

    Generieren von DC-Ausgang:
    Taste Channel Softkey Output (Off) Softkey Output (On)
  • SCPI: [SOURce[1|2]:]FUNCtion <function>

Der Befehl APPLy konfiguriert ein Signal mit einem Befehl.

Ausgangsfrequenz

Der Ausgangsfrequenzbereich ist abhängig von Funktion, Modell und Ausgangsspannung, wie hier gezeigt. Die Standardfrequenz ist 1 kHz für alle Funktionen und die Mindestfrequenzen sind in der Tabelle unten dargestellt.

Funktion | Minimale Frequenz
Sinus | 1 µHz
Rechteck | 1 µHz
Sägezahn/Dreieck | 1 µHz
Puls | 1 µHz
PRBS | 1 µbps
Arbiträrsignal | 1 µSa/s
  • Frequenzbeschränkungen: Durch eine Änderung der Funktionen kann sich die Frequenz ändern, um die Frequenzgrenzen der neuen Funktion einzuhalten. Arbiträrsignale behalten ihre letzte Frequenzeinstellung bei.
  • Einschränkungen der Burst-Funktion: Für intern getriggerte Bursts beträgt die minimale Frequenz 126 µHz.
  • Einschränkungen des Tastverhältnisses: Für Rechteck- und Pulssignale ist bei 33500 Series der Tastgrad durch die minimale Pulsbreitenspezifikation von 16-ns begrenzt. So kann beispielsweise bei 1 kHz das Tastverhältnis sehr niedrig eingestellt werden (0,01%), da dies zu einer Pulsbreite von 100 ns führen würde. Bei 1 MHz beträgt das minimale Tastverhältnis 1,6% und bei 10 MHz 16%. Beim Wechsel zu einer Frequenz, die das aktuelle Tastverhältnis nicht generieren kann, wird das Tastverhältnis so angepasst, dass die minimale Pulsbreitenspezifikation eingehalten wird.

    Bei 33500 Series Geräten beträgt die minimale Pulsbreite 16 ns. Bei 33600 Series Geräten beträgt die minimale Pulsbreite 5 ns bis 4 Vpp und 8 ns bis 10 Vpp.
  • Frontplatte:
    Taste Parameters Softkey Frequency Tastenfeld und Drehknopf
  • SCPI: [SOURce[1|2]:]FREQuency {<frequency>|MINimum|MAXimum|DEFault}

Der Befehl APPLy konfiguriert ein Signal mit einem Befehl.

Ausgangsamplitude

Die Standardamplitude beträgt 100 mVpp (in 50 Ω) für alle Funktionen.

  • Einschränkung des Offset-Spannungsbereichs: Der Zusammenhang zwischen Ausgangsamplitude und Offset-Spannung wird durch die untenstehende Gleichung beschrieben. Vmax beträgt ±5 V für eine 50 Ω Last oder ±10 V für eine hochohmige Last.

    Vpp < 2(Vmax – |Voffset|)
  • Einschränkungen durch den Lastwiderstandswert: Beträgt die Amplitude 10 Vpp und Sie ändern den Lastwiderstand von 50 Ω auf "high impedance" (OUTPut[1|2]:LOAD INF), verdoppelt sich die angezeigte Amplitude und beträgt dann 20 Vpp. Der Wechsel von "high impedance" zu 50 Ω halbiert die angezeigte Amplitude. Die Einstellung des Lastwiderstands beeinflusst die tatsächliche Ausgangsspannung nicht; sie ändert lediglich die Werte, die über die Remote-Schnittstelle angezeigt und abgefragt werden. Die tatsächliche Ausgangsspannung ist abhängig von der verbundenen Last.
  • Einschränkungen durch die Maßeinheit: Amplitudeneinschränkungen werden manchmal durch die ausgewählten Ausgangseinheiten bestimmt. Dies kann auftreten, wenn die Einheiten aufgrund der Unterschiede der Scheitelfaktoren verschiedener Funktionen Vrms oder dBm entsprechen. Wenn Sie z. B. ein 5 Vrms Rechtecksignal (in 50 Ω) in ein Sinussignal ändern, passt das Gerät die Amplitude auf 3,536 Vrms an (der obere Grenzwert für Sinussignale in Vrms). Zudem generiert die Remote-Schnittstelle einen "Settings conflict"-Fehler.
  • Sie können die Ausgangsamplitude in Vpp, Vrms oder dBm einstellen. Die Ausgangsamplitudenmaßeinheit „dBm“ ist nicht verfügbar, wenn Sie den Lastwiderstand „high impedance“ spezifiziert haben. Ausführlichere Informationen finden Sie unter Ausgangseinheiten.
  • Einschränkungen bei Arbiträrsignalen: Bei Arbiträrsignalen ist der Amplitudenbereich eingeschränkt, falls die Signalpunkte nicht den vollen Bereich des Ausgangs-D/A-Wandlers abdecken. Z. B. nutzt das integrierte "Sinc"-Signal nicht den gesamten Wertebereich, weshalb seine maximale Amplitude auf 6,087 Vpp (in 50 Ω) begrenzt ist.
  • Eine Änderung der Amplitude kann die Ausgabe bei bestimmten Spannungswerten aufgrund des Wechsels des Ausgangsabschwächers kurz unterbrechen. Die Amplitudenregelung gewährleistet jedoch, dass die Ausgangsspannung bei einer Bereichsumschaltung niemals den aktuellen Wert überschreitet. Um solche Unterbrechungen zu vermeiden, muss die automatische Bereichswahl mit VOLTage:RANGe:AUTO OFF deaktiviert werden. Der Befehl APPLy aktiviert die automatische Bereichswahl.
  • Durch die Einstellung von oberem und unterem Pegel werden auch Signalamplitude und -Offset eingestellt. Stellen Sie beispielsweise den oberen Pegel auf +2 V und den unteren Pegel auf -3 V, führt dies zu einer Amplitude von 5 Vpp mit einem Offset von -500 mV.
  • Der Ausgangssignalpegel eines DC-Signals wird durch die Offsetspannung (DC Offset Voltage) kontrolliert. Der DC-Pegel darf zwischen ±5 V (50 Ω Last) und ±10 V (hochohmige Last) liegen.
  • Frontplatte:
    Taste Parameters Softkey Amplitude Tastenfeld und Drehknopf

    So verwenden Sie stattdessen einen oberen und einen unteren Pegel:
    Taste Units Softkey Amp/Offs - High/Low (Amp/Offs) Softkey Amp/Offs - High/Low (High/Low)
  • SCPI:
    [SOURce[1|2]:]VOLTage {<amplitude>|MINimum|MAXimum|DEFault}

    [SOURce[1|2]:]VOLTage:HIGH {<voltage>|MINimum|MAXimum|DEFault}

    [SOURce[1|2]:]VOLTage:LOW {<voltage>|MINimum|MAXimum|DEFault}

Der Befehl APPLy konfiguriert ein Signal mit einem Befehl.

DC-Offsetspannung

Der Standard-Offset für alle Funktionen ist 0 V.

  • Einschränkungen durch die Amplitude: Der Zusammenhang zwischen Offset-Spannung und Ausgangsamplitude ist unten beschrieben. Die Ausgangs-Spitzenspannung (DC plus AC) darf die Ausgangswerte des Geräts nicht überschreiten (±5 V in 50 Ω Last oder ±10 V in einen offenen Schaltkreis).
  • Der Zusammenhang zwischen Offset-Spannung und Ausgangsamplitude ist unten beschrieben. Vmax ist die maximale Spitzenspannung für den gewählten Lastwiderstand (5 V für eine 50 Ω Last oder 10 V für eine hochohmige Last).

    |Voffset| < Vmax - Vpp/2

    Ist die angegebene Offsetspannung nicht gültig, passt das Gerät den Wert auf die maximal zulässige DC-Spannung mit der angegebenen Amplitude an. Über die Remote-Schnittstelle wird ebenfalls der Fehler "Data out of range" generiert.
  • Einschränkungen durch den Lastwiderstandswert: Der Offset-Bereich ist abhängig von der Einstellung des Lastwiderstands. Wenn Sie zum Beispiel den Offset auf 100 mVDC festlegen und dann den Lastwiderstand von 50 Ω auf "high impedance" stellen, verdoppelt sich der auf der Frontplatte angezeigte Offset-Spannungswert auf 200 mVDC (es wird kein Fehler generiert). Wenn Sie von "high impedance" auf 50 Ω wechseln, halbiert sich der angezeigte Offset-Spannungswert. Ausführlichere Informationen finden Sie unter OUTPut[1|2]:LOAD. Eine Änderung des Lastwiderstands ändert nicht die Spannung an den Ausgangsanschlüssen des Geräts. Sie ändert lediglich die an der Frontplatte angezeigten Werte und die Werte, die über die Remote-Schnittstelle abgefragt werden. Die Spannung am Ausgang des Geräts ist abhängig von der Last, die mit dem Gerät verbunden ist. Ausführlichere Informationen finden Sie unter OUTPut[1|2]:LOAD.
  • Einschränkungen bei Arbiträrsignalen: Bei Arbiträrsignalen ist der Amplitudenbereich eingeschränkt, falls die Signalpunkte nicht den vollen Bereich des Ausgangs-D/A-Wandlers abdecken. Z. B. nutzt das integrierte "Sinc"-Signal nicht den gesamten Wertebereich, weshalb seine maximale Amplitude auf 6,087 Vpp (in 50 Ω) begrenzt ist.
  • Durch die Einstellung von oberem und unterem Pegel werden auch Signalamplitude und -Offset eingestellt. Stellen Sie beispielsweise den oberen Pegel auf +2 V und den unteren Pegel auf -3 V, führt dies zu einer Amplitude von 5 Vpp mit einem Offset von -500 mV.
  • Wählen Sie für die Ausgabe eines DC-Spannungspegels die DC-Spannungsfunktion (FUNCtion DC) und stellen Sie dann die Offset-Spannung ein (VOLTage:OFFSet). Gültige Werte liegen zwischen ±5 VDC in 50 Ω oder ±10 VDC in einen offenen Schaltkreis. Wenn das Gerät im DC-Modus arbeitet, hat die Einstellung der Amplitude keine Auswirkungen.
  • Frontplatte:
    Taste Waveforms Softkey More Softkey DC Tastenfeld und Drehknopf
  • SCPI:
    [SOURce[1|2]:]VOLTage:OFFSet {<offset>|MINimum|MAXimum|DEFault}

    [SOURce[1|2]:]VOLTage:HIGH {<voltage>|MINimum|MAXimum|DEFault}

    [SOURce[1|2]:]VOLTage:LOW {<voltage>|MINimum|MAXimum|DEFault}

Der Befehl APPLy konfiguriert ein Signal mit einem Befehl.

Ausgangseinheiten

Gilt nur für Ausgangsamplitude.

  • Ausgangseinheiten: Vpp (Standardeinstellung), Vrms oder dBm.
  • Die Einstellung ist flüchtig.
  • Die Einheitenauswahl gilt für Frontplatten- und Remoteschnittstellenvorgänge. Wenn Sie beispielsweise über die Remoteschnittstelle "VRMS" wählen, werden die Einheiten auf der Frontplatte als "VRMS" bezeichnet.
  • Amplitudeneinheiten können nicht dBm sein, wenn für den Lastwiderstand "High Impedance" gewählt wurde. Die Berechnung von dBm erfordert eine finite Lastimpedanz. In diesem Fall werden Einheiten zu Vpp konvertiert.
  • Sie können Einheiten umwandeln. So wandeln Sie z. B. 2 Vpp in den entsprechenden Vrms-Wert um:
    Taste Units Softkey Ampl as (Vpp) Softkey Vrms

    Bei einem Sinussignal beträgt der Effektivwert 707.1 mVrms.
  • Frontplatte:
    Taste Units Softkey Ampl as (Vpp)
  • SCPI: [SOURce[1|2]:]VOLTage:UNIT {VPP|VRMS|DBM}

Lastwiderstand

Das Gerät verfügt über eine unveränderliche Ausgangsimpedanz von 50 Ω für die Kanalanschlüsse der Frontplatte. Falls die Lastimpedanz vom angegebenen Wert abweicht, werden falsche Amplituden- und Offsetwerte angezeigt. Der Lastwiderstandswert dient lediglich zur Überprüfung, dass die angezeigten Spannungswerte der erwarteten Last entsprechen.

  • Lastwiderstand: 1 Ω bis 10 kΩ, oder unendlich. Der Standardwert beträgt 50 Ω. Die Registerkarte oben an jedem Kanal gibt den Wert der Einstellung an.
    Registerkarten zeigen die Impedanz an
  • Wenn Sie einen 50 Ω Lastwiderstand angeben, aber in einen offenen Schaltkreis enden, wird der Ausgang doppelt so hoch wie der angegebene Wert. Setzen Sie beispielsweise den DC-Offset auf 100 mVDC (und geben eine 50 Ω Last an), enden jedoch in einem offenen Schaltkreis, beträgt der tatsächliche Offset 200 mVDC.
  • Der Wechsel der Einstellung des Lastwiderstands passt die angezeigte Ausgangsamplitude und den Offset an (es wird kein Fehler generiert). Beträgt die Amplitude 10 Vpp und Sie ändern den Lastwiderstand von 50 Ω auf "high impedance" (OUTPut[1|2]:LOAD INF), verdoppelt sich die angezeigte Amplitude und beträgt dann 20 Vpp. Der Wechsel von "high impedance" zu 50 Ω halbiert die angezeigte Amplitude. Die Einstellung des Lastwiderstands beeinflusst die tatsächliche Ausgangsspannung nicht; sie ändert lediglich die Werte, die über die Remote-Schnittstelle angezeigt und abgefragt werden. Die tatsächliche Ausgangsspannung ist abhängig von der verbundenen Last.

    Die Ausgangslast kann die Signalqualität für Pulse und andere Funktionen mit Hochgeschwindigkeits-Übergängen beeinträchtigen. Ein hoher Lastwiderstand kann Reflexionen erzeugen.
  • Einheiten werden in Vpp umgewandelt, wenn für den Lastwiderstand "high impedance" eingestellt ist.
  • Sie können den Lastwiderstand nicht ändern, wenn Spannungsbegrenzungen aktiviert sind, da das Gerät nicht wissen kann, für welche Widerstandseinstellung die Begrenzungen gelten. Deaktivieren Sie stattdessen die Spannungsbegrenzungen, stellen Sie den neuen Widerstandswert ein, passen Sie die Spannungsbegrenzungen an und aktivieren Sie die Spannungsbegrenzungen erneut.
  • Frontplatte: Taste Channel Softkey Output Load
  • SCPI: OUTPut[1|2]:LOAD {<ohms>|INFinity|MINimum|MAXimum|DEFault}

Tastverhältnis (Rechteckwellen)

Das Tastverhältnis einer Rechteckwelle ist der Zeitabschnitt pro Zyklus, während dessen das Signal auf einem hohen Pegel ist (vorausgesetzt, die Wellenform ist nicht invertiert). (Nähere Informationen zum Tastverhältnis eines Pulssignals finden Sie unter Pulssignale.)

Tastverhältnis 20 Prozent | Tastverhältnis 80 Prozent
20% Tastverhältnis | 80% Tastverhältnis
  • Tastverhältnis:0,01% bis 99,99% bei niedrigen Frequenzen; bei höheren Frequenzen niedrigerer Bereich. Im flüchtigen Speicher gespeichert; Standardwert 50%.
  • Diese Einstellung geht beim Wechsel zu einer anderen Funktion nicht verloren. Für ein modulierendes Rechtecksignal wird immer ein Tastverhältnis von 50% benutzt; die Tastverhältniseinstellung gilt nur für ein Rechteckträgersignal.
  • Frontplatte:
    Taste Waveforms Softkey Square Softkey Duty Cycle Tastenfeld und Drehknopf

    Drücken Sie bei Verwendung des Tastenfelds Percent, um den Vorgang abzuschließen:
    Softkey Percent
  • SCPI: [SOURce[1|2]:]FUNCtion:SQUare:DCYCle {<percent>|MINimum|MAXimum}

Der Befehl APPLy setzt das Tastverhältnis auf 50%.

Symmetrie (Sägezahnsignale)

Betrifft nur Sägezahnsignale. Das Symmetrieverhältnis ist definiert als das prozentuale Verhältnis der Anstiegsdauer (vorausgesetzt, das Signal ist nicht invertiert).

Symmetrie 0 | Symmetrie 100
0% Symmetrie | 100% Symmetrie
  • Die Symmetrie (Standardeinstellung 100%) wird in einem flüchtigen Speicher gespeichert und geht bei einem Wechsel zu und von anderen Signalen nicht verloren.
  • Wenn das Modulationssignal für AM, FM, PM oder PWM ein Sägezahnsignal ist, gilt die Symmetrieeinstellung nicht.
  • Frontplatte:
    Taste Waveforms Softkey Ramp Softkey Symmetry

    Wählen Sie dann eine der folgenden Optionen. Die Option Symmetry ermöglicht die Verwendung von Drehknopf oder Tastenfeld zur Angabe eines Werts.
    Softkeys Symmetry choices

    Drücken Sie bei Verwendung des Tastenfelds Percent, um den Vorgang abzuschließen:
    Softkey Percent
  • SCPI: [SOURce[1|2]:]FUNCtion:RAMP:SYMMetry {<percent>|MINimum|MAXimum|DEFault}

Der Befehl APPLy stellt die Symmetrie auf 100%.

Automatische Spannungsbereichswahl

Die automatische Spannungsbereichswahl ist in der Standardeinstellung aktiviert und das Gerät wählt die optimalen Einstellungen für den Abschwächer aus. Ist die automatische Spannungsbereichswahl deaktiviert, verwendet das Gerät die aktuellen Abschwächereinstellungen und wechselt die Abschwächer-Relais nicht.

  • Sie können die automatische Spannungsbereichswahl deaktivieren, um zeitweise Unterbrechungen zu beseitigen, die vom Abschwächer beim Amplitudenwechsel verursacht werden. Beachten Sie jedoch Folgendes:
  • Genauigkeit und Auflösung von Amplitude und der Offsetspannung (sowie die Signalformgenauigkeit) können beeinträchtigt werden, wenn die Amplitude auf einen Wert unterhalb der Bereichsumschaltgrenze reduziert wird, die mit aktivierter automatischer Spannungsbereichswahl auftreten würde.
  • Möglicherweise kann die minimale Amplitude bei aktivierter automatischer Bereichswahl nicht erreicht werden.
  • Manche Gerätespezifikationen gelten bei deaktivierter automatischer Bereichswahl evtl. nicht.
  • Frontplatte:
    Taste Channel Softkey Range (Auto)
    oder
    Taste Channel Softkey Range (Auto) Softkey Range (Hold)
  • SCPI: [SOURce[1|2]:]VOLTage:RANGe:AUTO {OFF|0|ON|1|ONCE}

Der Befehl APPLy aktiviert die automatische Bereichswahl immer.

Ausgangskontrolle

In der Standardeinstellung wird die Ausgangskontrolle beim Einschalten zum Schutz der weiteren Ausstattung deaktiviert. Unten ist beschrieben, wie der Ausgang eines Kanals aktiviert wird. Wenn der Kanalausgang aktiviert ist, leuchtet die entsprechende Kanaltaste.

  • Wenn ein externer Stromkreis eine übermäßige Spannung auf einen Kanalausgangsanschluss anwendet, generiert das Gerät eine Fehlermeldung und deaktiviert den Ausgang. Um den Ausgang wieder zu aktivieren, muss die Überlastung entfernt und der Kanal erneut eingeschaltet werden.
  • Frontplatte:
    Taste Channel Softkey Output (Off) Softkey Output (On)
  • SCPI: OUTPut[1|2] {ON|1|OFF|0}

Der Befehl APPLy aktiviert stets den Kanalausgangsanschluss.

Signalpolarität

Im normalen Modus (Standardeinstellung) verläuft das Signal zu Zyklusbeginn in positiver Richtung. Im invertierten Modus erfolgt das Gegenteil.

  • Wie unten dargestellt, ist das Signal bezüglich der Offset-Spannung invertiert. Die Offset-Spannung bleibt bei der Invertierung des Signals unverändert.

    Ohne Offset-Spannung | Mit Offset-Spannung
    Keine Offset-Spannung | Mit Offset-Spannung
  • Das Sync-Signal in Kombination mit einem invertierten Signal wird nicht inventiert.
  • Frontplatte:
    Taste Channel Softkey Polarity (Normal)
    oder
    Taste Channel Softkey Polarity (Normal) Softkey Polarity (Inverted)
  • SCPI: OUTPut[1|2]:POLarity {NORMal|INVerted}

Sync Ausgangssignal

Ein Sync-Ausgang befindet sich am Anschluss Sync der Frontplatte. Alle Standard-Ausgangsfunktionen (außer DC und Rauschen) verfügen über ein zugehöriges Sync Signal. Wenn Sie bei Anwendungen das Signal Sync nicht ausgeben wollen, können Sie den Anschluss Sync deaktivieren. Das Signal Sync kann bei einem Zweikanalgerät von jedem Ausgangskanal abgeleitet werden.

Allgemeines Verhalten

  • In der Standardeinstellung wird das Signal Sync von Kanal 1 abgeleitet und wird an den Anschluss Sync (aktiviert) weitergeleitet.
  • Wenn das Signal Sync deaktiviert ist, ist der Ausgangspegel am Anschluss Sync logischerweise "niedrig."
  • Die Polarität des Signals Sync ist durch OUTPut:SYNC:POLarity {INVerted|NORMal} angegeben.
  • Beim Invertieren eines Signals (siehe Signalpolarität) wird das entsprechende Sync Signal nicht invertiert.
  • Für Sinus-, Puls-, Sägezahn-, Rechteck- und Dreiecksignale ist das Sync Signal ein Rechtecksignal, das in der ersten Zyklushälfte "hoch" ist und in der letzten Zyklushälfte "niedrig". Die Spannungswerte des Sync Signals sind TTL-kompatibel, wenn seine Lastimpedanz 1 kΩ überschreitet.
  • Bei Arbiträrsignalen steigt das Sync Signal zu Beginn des Signals an und fällt in der Mitte des Arbiträrsignals ab. Sie können dieses Standardverhalten umgehen, indem Sie MARKer:POINt verwenden, um den Punkt des Arbiträrsignals anzugeben, an dem das Sync zu "niedrig" wechselt.

Modulation

  • Für intern modulierte AM, FM, PM und PWM ist das Sync Signal ein auf das Modulationssignal (nicht das Trägersignal) bezogenes Rechtecksignal mit einem Tastverhältnis von 50%. Das Sync Signal ist während der ersten Hälfte des modulierten Signals ein TTL-Hoch-Signal. Sie können das Sync Signal so einrichten, dass es dem Trägersignal folgt. Verwenden Sie dazu den Befehl OUTPut:SYNC:MODE {CARRier|NORMal|MARKer}, wenn mit interner Modulation moduliert wird.
  • Für extern modulierte AM, FM, PM und PWM ist das Sync Signal auf das Trägersignal (nicht auf das Modulationssignal) bezogen und es handelt sich um ein Rechtecksignal mit einem Tastverhältnis von 50%.
  • Sie können dieses Standardverhalten umgehen, indem Sie Sync zwingen, sich stets auf das Trägersignal zu beziehen (OUTPut[1|2]:SYNC:MODE CARRier).
  • Für FSK bezieht sich das Sync Signal auf die FSK-Rate. Das Sync Signal ist ein TTL-Hoch-Signal am Übergang zur "Hop"-Frequenz.

Wobbelung

  • Das Sync-Signal geht am Anfang des Wobbelzyklus in den HIGH-Zustand über und in der Mitte des Wobbelzyklus in den Zustand LOW. Das Sync Signal wird mit dem Wobbel synchronisiert, ist jedoch nicht gleich der Wobbelzeit, da die Zeit die Rearm-Zeit einbezieht.
  • Bei Frequenzwobbelungen mit Marker On entspricht das Sync-Signal zu Anfang des Wobbelzyklus einem TTL-Hoch-Signal und bei der Marker-Frequenz einem LOW-Signal. Geändert werden kann dies mit dem Befehl OUTPut[1|2]:SYNC:MODE MARKER.

Burst

  • Bei einem getriggerten Burst entspricht das Sync Signal einem TTL-Hoch-Signal, wenn der Burst beginnt. Am Ende der angegebenen Anzahl von Zyklen entspricht das Sync Signal einem TTL-niedrig-Signal (je nach Start-Phase ist die Sync-Flanke nicht unbedingt mit dem Nulldurchgang synchron). Bei einer unendlichen Burst-Anzahl entspricht das Sync Signal dem eines kontinuierlichen Signals.
  • Bei einem "externally-gated burst" folgt das Sync Signal dem externen Torsignal. Doch das Signal wird vor Ende des letzten Zyklus nicht "niedrig" (je nach Start-Phase evtl. kein Nulldurchgang).

Konfiguration des Sync-Ausgangs

  • Frontplatte:
    Umschalten zwischen Sync ein bzw. aus:
    Taste Trigger Softkey Sync (On)

    Sync-Konfigurierung:
    Taste Trigger Softkey Sync Setup
  • SCPI:
    OUTPut:SYNC {ON|1|OFF|0}

    OUTPut[1|2]:SYNC:MODE {NORMal|CARRier|MARKer}

    OUTPut[1|2]:SYNC:POLarity {NORMal|INVerted}

    OUTPut:SYNC:SOURce {CH1|CH2}


Pulssignale

Wie unten dargestellt, besteht ein Puls- oder Rechtecksignal aus einer Periode, einer Anstiegs- und einer Abfallflanke.

Periode

  • Periode: Reziprokwert von Maximalfrequenz bis 1.000.000 s. Der Standardwert ist 1 ms.
  • Das Gerät passt die Pulsbreite und die Flankenzeit automatisch der angegebenen Periode an.
  • Frontplatte:

    Pulssignal wählen:

    Wählen Sie Periode anstatt Frequenz:
    Freunits einstellen
    Taste Units Softkey Frequenz - Periode (Frequenz) Softkey Frequenz/Periode (Periode)

    Periode einstellen:
    Taste Parameters Softkey Period
  • SCPI: [SOURce[1|2]:]FUNCtion:PULSe:PERiod {<seconds>|MINimum|MAXimum|DEFault}

Pulsbreite

Die Pulsbreite ist die Zeit vom 50% Schwellenwert der steigenden Flanke eines Pulses bis zum 50% Schwellenwert der nächsten fallenden Flanke.

  • Pulsbreite: bis 1.000.000 s (siehe unten aufgeführte Einschränkungen). Die Standardpulsbreite beträgt 100 μs. Die minimale Pulsbreite beträgt 16 ns bei 33500 Series Geräten und 5 ns bis 4 Vpp oder 8 ns bis 10 Vpp bei 33600 Series Geräten.
  • Die angegebene Pulsbreite muss auch kleiner sein als der Unterschied zwischen Periode und Mindestpulsbreite.
  • Das Gerät passt die Pulsbreite an die angegebene Periode an.
  • Frontplatte:
    Taste Waveforms Softkey Pulse Softkey Pulse Width
  • SCPI: [SOURce[1|2]:]FUNCtion:PULSe:WIDTh {<seconds>|MINimum|MAXimum|DEFault}

Tastverhältnis eines Pulssignals

Das Tastverhältnis eines Pulssignals ist folgendermaßen definiert:

Tastverhältnis = 100(Pulsbreite)/Periode

Die Pulsbreite ist die Zeit vom 50% Schwellenwert der steigenden Flanke eines Pulses bis zum 50% Schwellenwert der nächsten fallenden Flanke.

  • Tastverhältnis eines Pulssignals: 0,01% bis 99,99% (siehe unten aufgeführte Einschränkungen). Der Standardwert beträgt 10%.
  • Das Tastverhältnis eines Pulssignals muss folgenden Einschränkungen entsprechen, die durch die Mindestpulsbreite (WMin) bestimmt werden. Das Gerät passt das Tastverhältnis eines Pulssignals an die angegebene Periode an.

    Tastverhältnis > 100(minimale Pulsbreite) / Periode

    und

    Tastverhältnis < 100(1 – (minimale Pulsbreite/ Periode))

    Die minimale Pulsbreite beträgt 16 ns bei 33500 Series Geräten und 5 ns bis 4 Vpp oder 8 ns bis 10 Vpp bei 33600 Series Geräten.
  • Je länger die Flanken, desto größer ist die Mindestpulsbreite. Daher beschränken längere Flanken das Tastverhältnis mehr als kürzere Flanken.
  • Frontplatte:

    Pulsfunktion auswählen:
    Taste Waveforms Softkey Pulse

    Umschalten zu Tastverhältnis:
    Taste Units Softkey Width / Duty Cycle (Width) Softkey Width / Duty Cycle (Duty Cycle)

    Tastverhältnis eingeben:
    Taste Parameters Softkey Duty Cycle
  • SCPI: [SOURce[1|2]:]FUNCtion:PULSe:DCYCle {<percent>|MINimum|MAXimum|DEFault}

Flankenzeiten

Die Flankenzeiten stellen die Übergangszeiten für die Anstiegs- und Abfallflanken des Pulssignals ein (unabhängig oder zusammen). Die Flankenzeit entspricht der Zeit zwischen den Grenzwerten 10% und 90%.

  • Flankenzeit: Mindestens 8,4 ns für 33500 Series und 2,9 ns bis 4 Vpp oder 3,3 ns bis 10 Vpp für 33600 Series. Maximal 1 μs und Standardwert 10 ns.
  • Die angegebene Flankenzeit muss kleiner sein als die spezifizierte Pulsbreite, wie unten dargestellt. Das Gerät passt die Flankenzeit an die angegebene Pulsbreite an.
  • Frontplatte:
    Taste Waveforms Softkey Pulse Softkey Edge Times
  • SCPI:
    [SOURce[1|2]:]FUNCtion:PULSe:TRANsition:LEADing {<seconds>|MINimum|MAXimum|DEFault}

    [SOURce[1|2]:]FUNCtion:PULSe:TRANsition:TRAiling {<seconds>|MINimum|MAXimum|DEFault}

    [SOURce[1|2]:]FUNCtion:PULSe:TRANsition[:BOTH] {<seconds>|MINimum|MAXimum|DEFault}


Amplitudenmodulation (AM) und Frequenzmodulation (FM)

Ein moduliertes Signal besteht aus einem Trägersignal und einem Modulationssignal. In AM wird die Trägeramplitude durch den Spannungspegel des Modulationssignals verändert. In FM wird die Trägerfrequenz durch den Spannungspegel der Modulationssignals verändert. Das Gerät akzeptiert eine interne oder externe Modulationsquelle. Bei einem Zweikanalgerät kann ein Kanal den anderen modulieren.

Wählen Sie AM oder FM, bevor Sie andere Modulationsparameter einrichten. Weitere Informationen über die Modulation erhalten Sie unter Modulation.

Auswahl von AM oder FM

  • Bei diesem Gerät kann nur ein Modulationsmodus für einen Kanal aktiviert werden. Wenn AM oder FM aktiviert ist, sind alle anderen Modulationen deaktiviert. Bei Zweikanalmodellen sind die beiden Modulationen der beiden Kanäle unabhängig voneinander und das Gerät kann modulierte Wellenformen von zwei Kanälen hinzufügen. Ausführlichere Informationen finden Sie unter PHASe:SYNChronize und COMBine:FEED.
  • Für Wobbelung oder Burst können AM oder FM nicht aktiviert werden. Durch Aktivieren von AM oder FM werden Wobbelung und Burst deaktiviert.
  • Um ein mehrmaliges Umschalten der Signalform zu vermeiden, sollte die Modulation nach der Konfiguration anderer Modulationsparameter aktiviert werden.
  • Frontplatte:
    (Modulation) Softkey Type (AM)
    oder
    Taste Modulate (Modulation) Softkey Type (AM) Softkey FM Softkey Type (FM)

    Dann Modulation einschalten:
    Taste Modulate Softkey Modulate (Off) Softkey Modulate (ON)

    Das Signal wird mit den aktuellen Träger- und Modulationssignaleinstellungen ausgegeben.
  • SCPI:
    [SOURce[1|2]:]AM:STATe{ON|1|OFF|0}

    [SOURce[1|2]:]FM:STATe {ON|1|OFF|0}

Trägersignalform

  • AM oder FM Trägerform: Sinus (Standardeinstellung), Rechteck, Sägezahn, Puls, Dreieck, Rauschen (nur AM), PRBS oder Arbiträrsignal. DC kann nicht als Trägersignal verwendet werden.
  • Bei FM muss die Trägerfrequenz stets mindestens der Frequenzabweichung entsprechen. Bei dem Versuch, eine Abweichung eintzustellen, die größer ist als die Trägerfrequenz, stellt das Gerät eine Abweichung ein, die der Trägerfrequenz entspricht.
  • Trägerfrequenz plus Abweichung dürfen die maximalen Frequenzwerte für die gewählte Funktion plus 100 kHz nicht überschreiten. Wenn Sie versuchen, für die Abweichung einen ungültigen Wert einzustellen, passt das Gerät sie an den zulässigen Höchstwert für die derzeitige Trägerfrequenz an. Die Remoteschnittstelle generiert zudem den Fehler "Data out of range".
  • Frontplatte:
    Taste Waveform
    Wählen Sie eine Signalform.
  • SCPI:
    [SOURce[1|2]:]FUNCtion <function>

Der Befehl APPLy konfiguriert ein Signal mit einem Befehl.

Trägerfrequenz

Die maximale Trägerfrequenz variiert je nach Funktion, Modell und Ausgangsspannung, wie hier dargestellt. Die Standardeinstellung für alle Funktionen mit Ausnahme von Arbiträrsignalen ist 1 kHz. Die "Frequenz" des Arbiträrsignals wird auch mit dem Befehl FUNCtion:ARBitrary:SRATe eingestellt.

  • Frontplatte:
    Taste Parameters Softkey Frequency Tastenfeld und Drehknopf
  • SCPI: [SOURce[1|2]:]FREQuency {<frequency>|MINimum|MAXimum|DEFault}

Der Befehl APPLy konfiguriert ein Signal mit einem Befehl.

Modulieren der Wellenform

Das Gerät akzeptiert eine interne oder externe AM- oder FM-Modulationsquelle. Bei einem Zweikanalgerät können Sie einen Kanal mit dem anderen modulieren.

Hinweis

Eine Modulation von Rauschen mit Rauschen, PRBS mit PRBS oder Arbiträrsignal mit Arbiträrsignal ist nicht möglich.
  • Das Modulationssignal (interne Quelle) kann folgenden Formen entsprechen:
  • Sinuswelle
  • Rechteck mit einem Tastverhältnis von 50% Modulation Rechteck 50
  • UpRamp mit einer Symmetrie von 100% Modulation UpRamp 100
  • Dreieck mit 50% Symmetrie Modulationsdreieck 50
  • DnRamp mit 0% Symmetrie Modulation DnRamp 0
  • Rauschen - weißes Gaußsches Rauschen
  • PRBS - Pseudozufällige Binärfolge (Polynom PN7)
  • Arb - Arbiträrsignal
  • Frontplatte:
    Taste Modulate (Modulation) Softkey Type (AM)
    oder
    Taste Modulate (Modulation) Softkey Type (AM) Softkey FM

    Wählen Sie dann die Modulationsform:
    Softkey Shape (Sine)
  • SCPI:
    [SOURce[1|2]:]AM:INTernal:FUNCtion <Funktion>

    [SOURce[1|2]:]FM:INTernal:FUNCtion <Funktion>

Modulation der Signalfrequenz

Das Gerät akzeptiert eine interne oder externe Modulationsquelle.

  • Modulationsfrequenz (interne Quelle): Mindestwert 1 µHz, Maximalwerte variieren je nach Modell, Funktion und Ausgabe, wie hier dargestellt.
  • Modulationsfrequenz (externe Quelle): 0 bis 100 kHz
  • Frontplatte:
    Taste Modulate (Modulation) Softkey Type (AM) Softkey More (nur 33500 Series) Softkey AM Freq

    oder
    Taste Modulate (Modulation) Softkey Type (AM) Softkey FM Softkey FM Freq

    Geben Sie dann die AM oder FM Frequenz mit Drehknopf und Tastenfeld ein:
    Tastenfeld und Drehknopf

  • SCPI:
    [SOURce[1|2]:]AM:INTernal:FREQuency {<frequency>|MINimum|MAXimum|DEFault}

    [SOURce[1|2]:]FM:INTernal:FREQuency {<frequency>|MINimum|MAXimum|DEFault}

Modulationsgrad (AM)

Der Modulationsgrad ist ein Prozentsatz, der die Amplitudenvariation darstellt. Bei einem Grad von 0% entspricht die Amplitude der Hälfte der Trägeramplitudeneinstellung. Bei einem Grad von 100% variiert die Amplitude entsprechend dem Modulationssignal von 0% bis 100% der Trägeramplitude.

  • Modulationsgrad: 0% bis 120%. Der Standardwert beträgt 100%.
  • Selbst bei einem Grad von über 100% überschreitet das Gerät nicht den Spitzenwert von ±5 V am Ausgang (in eine 50 Ω Last). Um einen Modulationsgrad über 100% zu erzielen, kann die Trägeramplitude des Ausgangs reduziert werden.
  • Frontplatte:
    Taste Modulate (Modulation) Softkey Type (AM) Softkey AM Depth Tastenfeld und Drehknopf
  • SCPI: [SOURce[1|2]:]AM[:DEPTh] {<depth_in_percent>|MINimum|MAXimum}

Zweiseitenband-AM mit unterdrücktem Träger

Das Gerät unterstützt zwei Arten der Amplitudenmodulation, "Normal" und Zweiseitenband-AM mit unterdrücktem Träger (DSSC). Im DSSC ist der Träger nicht vorhanden, wenn die Amplitude des Modulationssignals nicht größer als Null ist.

  • Frontplatte:
    Taste Modulate (Modulation) Softkey Type (AM) Softkey More Softkey DSSC Off/On (OFF) Softkey DSSC Off/On (ON)
  • SCPI: [SOURce[1|2]:]AM:DSSC{ON|1|OFF|0}.

Frequenzhub (FM)

Die Frequenzhub-Einstellung ist die maximale Abweichung der Frequenz des modulierten Signals von der Trägerfrequenz.

Ist der Träger ein PRBS-Signal, verursacht der Frequenzhub einen Wechsel der Bitrate, der der Hälfte der eingestellten Frequenz entspricht. So entspricht beispielsweise ein Hub von 10 kHz einem Wechsel der Bitrate um 5 KBPS.

  • Frequenzhub: 1 µHz bis (Trägerfrequenz)/2, Standard 100 Hz.
  • Bei FM muss die Trägerfrequenz stets mindestens der Frequenzabweichung entsprechen. Bei dem Versuch, eine Abweichung eintzustellen, die größer ist als die Trägerfrequenz, stellt das Gerät eine Abweichung ein, die der Trägerfrequenz entspricht.
  • Trägerfrequenz plus Abweichung dürfen die maximalen Frequenzwerte für die gewählte Funktion plus 100 kHz nicht überschreiten. Wenn Sie versuchen, für die Abweichung einen ungültigen Wert einzustellen, passt das Gerät sie an den zulässigen Höchstwert für die derzeitige Trägerfrequenz an. Die Remoteschnittstelle generiert zudem den Fehler "Data out of range".
  • Frontplatte:
    Taste Modulate (Modulation) Softkey Type (AM) Softkey FM Softkey Freq Dev Tastenfeld und Drehzahl
  • SCPI: [SOURce[1|2]:]FM[:DEViation] {<peak_deviation_in_Hz>|MINimum|MAXimum|DEFault}

Modulationsquelle

Das Gerät akzeptiert eine interne oder externe Modulationsquelle. Bei einem Zweikanalgerät können Sie einen Kanal mit dem anderen modulieren.

Bei 33600 Series kann die Modulationsquelle so konfiguriert werden, dass entweder ein ±5 V Signal oder ein ±1 V Signal akzeptiert wird. Details finden Sie unter INPut:ATTenuation[:STATe].
  • Modulationsquelle: Intern (Standard), anderer Kanal oder Extern. Die externe Modulationsquelle kann bis 100 kHz betragen.
  • Mit der externen Quelle moduliert ein externes Signal das Trägersignal. Modulationsgrad (AM) oder Frequenzhub (FM) werden mit dem ±5 V Signalpegel am Modulation In Anschluss der Rückwand gesteuert. Der externe Modulationseingang hat eine -3 dB Bandbreite von 100 kHz.
  • AM-Beispiel: bei einem Modulationsgrad von 100% und einem Modulationssignal von +5 V entspricht der Ausgang der Maximalamplitude. Bei einem Modulationssignal von -5 V entspricht der Ausgang der minimalen Amplitude.
  • FM-Beispiel: Bei einem Hub von 10 kHz entspricht ein +5 V Signalpegel einem Anstieg der Frequenz um 10 kHz. Niedrigere externe Signalpegel ergeben eine geringere Abweichung und negative Signalpegel reduzieren die Frequenz unter der Trägerfrequenz.
  • Frontplatte:
    Wählen Sie nach dem Aktivieren von AM oder FM die Modulationsquelle gemäß der Darstellung:
    Softkey Source (Internal)
  • SCPI:
    [SOURce[1|2]:]AM:SOURce {INTernal|EXTernal|CH1|CH2}

    [SOURce[1|2]:]FM:SOURce {INTernal|EXTernal|CH1|CH2}


Phasenmodulation

Phasenmodulation (PM)

Ein moduliertes Signal besteht aus einem Trägersignal und einem Modulationssignal. Die Phasenmodulation hat große Ähnlichkeit mit der Frequenzmodulation; bei PM wird jedoch die Phase des modulierten Signals entsprechend der aktuellen Spannung des Modulationssignals verändert.

Ausführlichere Informationen zu den Grundlagen der Phasenmodulation finden Sie unter Tutorial - Modulation.

Auswahl der Phasenmodulation

  • Es kann nur jeweils ein Modulationsmodus aktiviert werden. Das Aktivieren der PM deaktiviert den zuvor eingestellten Modulationsmodus.
  • Das Aktivieren der PM deaktiviert die Modi Wobbelung und Burst.
  • Frontplatte: Taste Modulate (Modulation) Softkey Type (AM) Softkey PM

    Das Signal wird mit den aktuellen Träger- und Modulationssignaleinstellungen ausgegeben.
  • Um ein mehrmaliges Umschalten der Signalform zu vermeiden, sollte die Modulation nach der Konfiguration anderer Modulationsparameter aktiviert werden.
  • SCPI: [SOURce[1|2]:]PM:STATe {ON|1|OFF|0}

Trägersignalform

  • PM Trägerform: Sinus (Standardeinstellung), Rechteck, Sägezahn, Dreieck, Puls, PRBS oder Arbiträrsignal. Rauschen oder DC können nicht als Trägersignale verwendet werden.
  • Frontplatte: Taste Waveform

    Wählen Sie dann ein beliebiges Signal außer Rauschen oder DC.
  • SCPI: [SOURce[1|2]:]FUNCtion <function>
  • Der Befehl APPLy konfiguriert ein Signal mit einem Befehl.
  • Ist der Träger ein Arbiträrsignal, betrifft die Modulation den Abtast-Taktgeber und nicht den vollständigen Zyklus, der durch die Arbiträgsignal-Abtasteinstellung definiert ist. Daher ist die Anwendung der Phasenmodulation auf Arbiträrsignale begrenzt.

Trägerfrequenz

Die maximale Trägerfrequenz variiert je nach Funktion, Modell und Ausgangsspannung, wie hier dargestellt. Die Standardeinstellung für alle Funktionen mit Ausnahme von Arbiträrsignalen ist 1 kHz. Die Trägerfrequenz muss höher sein als 20 Mal die Spitzenmodulationsfrequenz.

  • Frontplatte:
    Softkey AM Freq oder Softkey FM Freq oder eine beliebige andere Frequenztaste.

    Nach Auswahl der Frequenztaste:
    Tastenfeld und Drehknopf
  • SCPI: [SOURce[1|2]:]FREQuency {<frequency>|MINimum|MAXimum|DEFault}
  • Der Befehl APPLy konfiguriert ein Signal mit einem Befehl.

Modulieren der Wellenform

Das Gerät akzeptiert eine interne oder externe Modulationsquelle.

  • Das Modulationssignal (interne Quelle) kann folgenden Formen entsprechen:
  • Sinuswelle
  • Rechteck mit einem Tastverhältnis von 50% Modulation Rechteck 50
  • UpRamp mit einer Symmetrie von 100% Modulation UpRamp 100
  • Dreieck mit 50% Symmetrie Modulationsdreieck 50
  • DnRamp mit 0% Symmetrie Modulation DnRamp 0
  • Rauschen - weißes Gaußsches Rauschen
  • PRBS - Pseudozufällige Binärfolge (Polynom PN7)
  • Arbiträrsignal
  • Rauschen ist zwar als Modulationssignalform verwendbar, aber Rauschen und DC können nicht als Trägersignalform verwendet werden.
  • Frontplatte:
    Taste Modulate (Modulation) Softkey Type (AM) Softkey PM Softkey Shape (Sine)
  • SCPI: [SOURce[1|2]:]PM:INTernal:FUNCtion <function>

Modulation der Signalfrequenz

Das Gerät akzeptiert eine interne oder externe Modulationsquelle. Der externe Modulationseingang hat eine -3 dB Bandbreite von 100 kHz.

  • Modulationsfrequenz (intern): Standardwert 10 Hz, Mindestwert 1 µHz; Höchstwert variiert je nach Modell, Funktion und Ausgangsspannung, wie hier beschrieben.
  • Frontplatte:
    Taste Modulate (Modulation) Softkey Type (AM) Softkey PM Softkey PM Freq

    Stellen Sie dann die Frequenz des Modulationssignals ein:
    Tastenfeld und Drehknopf
  • SCPI: [SOURce[1|2]:]PM:INTernal:FREQuency {<frequency>|MINimum|MAXimum|DEFault}

Phasenhub

Als Phasenhub wird die maximale Abweichung der Phase des modulierten Signals vom Trägersignal bezeichnet. Der Phasenhub kann auf Werte zwischen 0 und 360 Grad eingestellt werden (Standardwert: 180).

  • Frontplatte:
    Taste Modulate (Modulation) Softkey Type (AM) Softkey PM Softkey Phase Dev

    Stellen Sie dann den Phasenhub ein:
    Tastenfeld und Drehknopf
  • SCPI: [SOURce[1|2]:]PM:DEViation {<deviation in degrees>|MINimum|MAXimum|DEFault}
  • Wenn der Träger ein Arbiträrsignal ist, gilt der Hub für den Abtast-Taktgeber. Daher ist die Auswirkung auf das gesamte Arbiträrsignal geringer als die bei Standardsignalen beobachtete. Das Ausmaß der Reduzierung ist abhängig von der Punktzahl des Arbiträrsignals.

Modulationsquelle

Das Gerät akzeptiert eine interne oder externe Modulationsquelle.

  • Modulationsquelle: Intern (Standard), anderer Kanal oder Extern. Die externe Modulationsquelle kann bis 100 kHz betragen.
  • Wenn Sie die Modulationsquelle External wählen, wird das Trägersignal mit einem externen Signal moduliert. Der ±5 V Signalpegel am Rückwandanschluss Modulation In steuert den Phasenhub. Wird der Hub beispielsweise auf 180 Grad eingestellt, entspricht ein +5 V Signal einem Phasenhub von 180 Grad. Niedrigere Pegel erzeugen einen geringeren Hub.
  • Frontplatte:
    Taste Modulate (Modulation) Softkey Type (AM) Softkey PM Softkey Source (Internal)
  • SCPI: [SOURce[1|2]:]PM:SOURce {INTernal|EXTernal|CH1|CH2}


FSK-Modulation (Frequenzumtastung)

Mit der FSK modulation können Sie das Gerät so konfigurieren, dass die Ausgangsfrequenz zwischen zwei voreingestellten Werten (als "Trägerfrequenz" und "Hop-Frequenz" bezeichnet) "wechselt". Die Geschwindigkeit, mit der der Ausgang zwischen diesen beiden Frequenzen wechselt, wird vom internen Wiederholratengenerator oder dem Signalpegel am rückseitigen Anschluss Ext Trig bestimmt.

Unter Bedienung des Frontplatten-Menüs - FSK-Signal ausgeben sinden Sie ausführlichere Informationen über die FSK-Modulation mit der Frontplatte.

Wahl der FSK-Modulation

FSKey:STATe {OFF|ON}

  • Es kann nur jeweils ein Modulationsmodus aktiviert werden. Wenn Sie FM wählen, wird der zuvor gewählte Modulationstyp deaktiviert.
  • Sie können FSK nicht aktivieren, wenn Wobbelung oder Burst aktiviert ist. Das Aktivieren von FSK deaktiviert die Modi Wobbelung und Burst.
  • Um ein mehrmaliges Umschalten der Signalform zu vermeiden, sollte die Modulation nach der Konfiguration anderer Modulationsparameter aktiviert werden.

FSK-Trägerfrequenz

[SOURce[1|2]:]FREQuency {<frequency>|MINimum|MAXimum|DEFault}

Die maximale Trägerfrequenz variiert je nach Funktion, Modell und Ausgangsspannung, wie hier dargestellt. Die Standardeinstellung für alle Funktionen mit Ausnahme von Arbiträrsignalen ist 1 kHz.

  • Wenn die externe Quelle gewählt wurde, wird die Ausgangsfrequenz durch den Signalpegel am rückseitigen Anschluss Ext Trig bestimmt. Wenn das externe Signal sich im LOW-Zustand befindet, wird die Trägerfrequenz ausgegeben. Wenn es sich im HIGH-Zustand befindet, wird die Hop-Frequenz ausgegeben.

FSK-Hop-Frequenz

[SOURce[1|2]:]FSKey:FREQuency {<frequency>|MINimum|MAXimum|DEFault}

Die maximale alternierende ("Hop") Frequenz ist abhängig von der Funktion. Die Standardeinstellung für alle Funktionen ist 100 Hz. Das interne Modulationssignal ist ein Rechtecksignal mit einem Tastverhältnis von 50%.

Funktion | Minimale Hop-Frequenz | Maximale Hop-Frequenz
Sinus | 1 µHz | (variiert je nach Modell, wie hier gezeigt).
Rechteck
Sägezahn/Dreieck
Puls
  • Wenn die externe Quelle gewählt wurde, wird die Ausgangsfrequenz durch den Signalpegel am rückseitigen Anschluss Ext Trig bestimmt. Wenn das externe Signal sich im LOW-Zustand befindet, wird die Trägerfrequenz ausgegeben. Wenn es sich im HIGH-Zustand befindet, wird die Hop-Frequenz ausgegeben.

FSK-Rate

[SOURce[1|2]:]FSKey:INTernal:RATE {<rate_in_Hz>|MINimum|MAXimum}

Die FSK-Rate ist die Rate, mit welcher die Ausgangsfrequenz bei interner FSK-Modulation zwischen der Trägerfrequenz und der „Hop“-Frequenz umschaltet.

  • FSK-Rate (interne Quelle): 125 µHz (33500 Series) oder 250 µHz (33600 Series) bis 1 MHz, Standardeinstellung: 10 Hz.
  • Bei Verwendung einer externen FSK-Modulationsquelle ist die eingestellte FSK-Rate ohne Bedeutung.

FSK-Quelle

[SOURce[1|2]:]FSKey:SOURce {INTernal|EXTernal}

Kann intern (Standard) oder extern sein.

  • Wenn die Quelle Internal gewählt wurde, wird die Rate, mit welcher die Ausgangsfrequenz zwischen der Trägerfrequenz und der „Hop“-Frequenz umschaltet, durch die spezifizierte FSK-Rate bestimmt. Das interne Modulationssignal ist ein Rechtecksignal mit einem Tastverhältnis von 50%.
  • Wenn die externe Quelle gewählt wurde, wird die Ausgangsfrequenz durch den Signalpegel am rückseitigen Anschluss Ext Trig bestimmt. Wenn das externe Signal sich im LOW-Zustand befindet, wird die Trägerfrequenz ausgegeben. Wenn es sich im HIGH-Zustand befindet, wird die Hop-Frequenz ausgegeben.
  • Der für die externe FSK-Modulation verwendete Anschluss (Ext Trig) ist nicht der gleiche Anschluss, der für extern modulierte AM-, FM-, PM- und PWM-Signale verwendet wird (Modulation In). Bei Verwendung für FSK hat der Anschluss Ext Trig keine einstellbare Flankenpolarität.


Pulsbreitenmodulation (PWM)

Dieses Kapitel behandelt die PWM (Pulsbreitenmodulation). PWM steht nur für das Pulssignal zur Verfügung und die Pulsbreite ist vom Mosulationssignal abhängig. Der Wert der Pulsbreitenschwankung wird als Pulsbreitenabweichung bezeichnet und kann als Prozentsatz der Signalperiode (d. h. des Tastverhältnisses) oder in Zeiteinheiten angegeben werden. Wenn Sie z. B. einen Puls mit einem Tastverhältnis von 20 % angeben und dann PWM mit einer Abweichung von 5% aktivieren, schwankt das Tastverhältnis von 15% bis 25%, je nach Modulationssignal.

Das Gerät akzeptiert eine interne oder externe Modulationsquelle.

Auswahl von PWM

  • PWM kann nicht aktiviert werden, wenn Sweep oder Burst aktiviert sind.
  • Um ein mehrmaliges Umschalten der Signalform zu vermeiden, sollte die Modulation nach der Konfiguration anderer Modulationsparameter aktiviert werden.
  • Frontplatte:
    Taste Waveforms Softkey Pulse
    Taste Modulate (Modulation) Softkey Type (AM) Softkey PWM
    Softkey (Off) Modulate Softkey (ON) Modulate

    Das Signal wird mit den aktuellen Träger- und Modulationssignaleinstellungen ausgegeben.
  • SCPI: [SOURce[1|2]:]PWM:STATe {ON|1|OFF|0}

Modulieren der Wellenform

Das Gerät akzeptiert eine interne oder externe Modulationsquelle.

  • Das Modulationssignal (interne Quelle) kann folgenden Formen entsprechen:
  • Sinuswelle
  • Rechteck mit einem Tastverhältnis von 50% Modulation Rechteck 50
  • UpRamp mit einer Symmetrie von 100% Modulation UpRamp 100
  • Dreieck mit 50% Symmetrie Modulationsdreieck 50
  • DnRamp mit 0% Symmetrie Modulation DnRamp 0
  • Rauschen - weißes Gaußsches Rauschen
  • PRBS - Pseudozufällige Binärfolge (Polynom PN7)
  • Arbiträrwellenform
  • Frontplatte:

    Taste Waveforms Softkey Pulse
    Taste Modulate (Modulation) Softkey Type (AM) Softkey PWM Softkey Shape (Sine)
  • SCPI: [SOURce[1|2]:]PWM:INTernal:FUNCtion <function>

Modulation der Signalfrequenz

Das Gerät akzeptiert eine interne oder externe Modulationsquelle. Der externe Modulationseingang hat eine -3 dB Bandbreite von 100 kHz.

  • Modulationsfrequenz (interne Quelle): Die Standardeinstellung ist 10 Hz und der Minimalwert beträgt 1 µHz. Die Maximalfrequenz variiert je nach Funktion, Modell und Ausgangsspannung, wie hier dargestellt.
  • Frontplatte:
    Taste Waveforms Softkey Pulse
    Taste Modulate (Modulation) Softkey Type (AM) Softkey PWM Softkey PWM Freq
  • SCPI: [SOURce[1|2]:]PWM:INTernal:FREQuency {<frequency>|MINimum|MAXimum|DEFault}

Abweichung der Breite oder des Tastverhältnisses

Die PWM-Abweichungseinstellung entspricht der maximalen Abweichung der Breite der modulierten Pulswellenform. Sie kann in Zeiteinheiten oder als Tastverhältnis eingestellt werden.

  • Vorderes Bedienfeld:
    Taste Waveforms Softkey Pulse
    Taste Modulate (Modulation) Softkey Type (AM) Softkey PWM Softkey Width Dev

    Einstellung der Abweichung durch das Tastverhältnis:
    Taste Units Softkey Width / Duty Cycle (Width) Softkey Width / Duty Cycle (Duty Cycle)
    Taste Modulate Softkey Dty Cyc Dev
  • SCPI: [SOURce[1|2]:]PWM:DEViation {<deviation>|MINimum|MAXimum|DEFault}
  • Die Summe der Pulsbreite und Abweichung muss folgender Formel entsprechen:

    Pulsbreite + Abweichung < Periode – 16 ns (33500 Series)

    Pulsbreite + Abweichung < Periode – 8 ns (33600 Series über 4 Vpp)

    Pulsbreite + Abweichung < Periode – 5 ns (33600 Series bis einschließlich 4 Vpp)
  • Bei Bedarf passt das Gerät die Abweichung an die angegebene Periode an.

Modulationsquelle

Das Gerät akzeptiert eine interne oder externe Modulationsquelle.

  • Modulationsquelle: Intern (Standard), anderer Kanal oder Extern. Die externe Modulationsquelle kann bis 100 kHz betragen.
  • Bei Auswahl der externen Modulationsquelle External wird die Abweichung durch den ±5 V Signalpegel (optional ±1 V bei 33600 Series Geräten) am rückseitigen Anschluss Modulation In gesteuert. Haben Sie beispielsweise die Abweichung auf 1 µs eingestellt, entspricht ein +5 V Signal (optional + 1 V bei der 33600 Series) einer Erhöhung der Breite um 1 µs. Niedrigere Signalpegel erzeugen eine geringere Abweichung.
  • Frontplatte:
    Taste Waveforms Softkey Pulse
    Taste Modulate (Modulation) Softkey Type (AM) Softkey PWM Softkey Source (Internal)
  • SCPI: [SOURce[1|2]:]PWM:SOURce {INTernal|EXTernal|CH1|CH2}

Pulswellenform

  • Die einzige für PWM verfügbare Signalform ist das Pulssignal.
  • Frontplatte:
    Taste Waveforms Softkey Pulse
  • SCPI: FUNCtion PULSe
  • Der Befehl APPLy konfiguriert ein Signal mit einem Befehl.

Pulsperiode

Der Pulsperiodenbereich reicht vom Reziprokwert der maximalen Frequenz bis 1.000.000 s (Standardwert 100 µs). Beachten Sie, dass die Wellenformperiode die maximale Abweichung begrenzt.

  • Vorderes Bedienfeld:
    Taste Waveforms Softkey Pulse
    Taste Units Softkey Frequency - Period (Frequency) Softkey Frequency / Period (Period)
  • SCPI: [SOURce[1|2]:]FUNCtion:PULSe:PERiod {<seconds>|MINimum|MAXimum|DEFault}


Summenmodulation

Die Summenmodulation fügt einem Trägersignal ein Modulationssignal hinzu; sie wird meist verwendet, um einem Träger ein Gaußsches Rauschen hinzuzufügen. Das Modulationssignal wird dem Träger als Prozentsatz der Trägersignalamplitude hinzugefügt.

Summe aktivieren

  • Um ein mehrmaliges Umschalten der Signalform zu vermeiden, sollte die Summe nach der Konfiguration anderer Modulationsparameter aktiviert werden.
  • Frontplatte:
    Taste Modulate (Modulation) Softkey Type (AM) Softkey Sum
    Softkey (Off) Modulate Softkey (ON) Modulate
  • SCPI: [SOURce[1|2]:]SUM:STATe {ON|1|OFF|0}

Modulieren der Wellenform

Das Gerät akzeptiert eine interne oder externe Modulationsquelle. Bei einem Zweikanalgerät können Sie einen Kanal mit dem anderen modulieren.

  • Das Modulationssignal (interne Quelle) kann folgenden Formen entsprechen:
  • Sinuswelle
  • Rechteck mit einem Tastverhältnis von 50% Modulation Rechteck 50
  • UpRamp mit einer Symmetrie von 100% Modulation UpRamp 100
  • Dreieck mit 50% Symmetrie Modulationsdreieck 50
  • DnRamp mit 0% Symmetrie Modulation DnRamp 0
  • Rauschen
  • PRBS mit PN7 Sequenz
  • Arbiträrsignal
  • Frontplatte:
    Taste Modulate (Modulation) Softkey Type (AM) Softkey Sum Softkey Shape (Sine)
  • SCPI: [SOURce[1|2]:]SUM:INTernal:FUNCtion <function>

Modulation der Signalfrequenz

Das Gerät akzeptiert eine interne oder externe Modulationsquelle. Bei einem Zweikanalgerät können Sie einen Kanal mit dem anderen modulieren.

  • Modulationsfrequenz (interne Quelle): Die Standardeinstellung ist 100 Hz und der Minimalwert beträgt 1 µHz. Die Maximalfrequenz variiert je nach Funktion, Modell und Ausgangsspannung, wie hier dargestellt.
  • Frontplatte:
    Taste Modulate (Modulation) Softkey Type (AM) Softkey Sum Softkey Sum Freq Tastenfeld und Drehknopf
  • SCPI: [SOURce[1|2]:]SUM:INTernal:FREQuency {<frequency>|MINimum|MAXimum|DEFault}

Summenamplitude

Die Summenamplitude entspricht der Amplitude des zum Träger hinzugefügten Signals (in Prozent der Trägeramplitude).

  • Amplitudeneinstellung: 0 bis 100% der Trägeramplitude, 0,01% Auflösung.
  • Die Summenamplitude bleibt ein konstanter Teil der Trägeramplitude und verfolgt die Trägeramplitudenänderungen.
  • Frontplatte:
    Taste Modulate (Modulation) Softkey Type (AM) Softkey Sum
    Softkey Modulate Sum Ampl Tastenfeld und Drehknopf
  • SCPI: [SOURce[1|2]:]SUM:AMPLitude {<amplitude>|MINimum|MAXimum|DEFault}

Modulationsquelle

Das Gerät akzeptiert eine interne oder externe Modulationsquelle. Bei einem Zweikanalgerät können Sie einen Kanal mit dem anderen modulieren.

  • Modulationsquelle: Intern (Standard), anderer Kanal oder Extern. Die externe Modulationsquelle kann bis 100 kHz betragen.
  • Mit der externen Quelle wird das Trägersignal durch den ±5 V Signalpegel (optional ±1 V bei 33600 Series Geräten) am Rückwandanschluss Modulation In hinzuaddiert. Wenn Sie beispielsweise die Summenamplitude auf 10% einstellen und steht das Modulationssignal auf +5 V (optional +1 V bei der 33600 Series), entspricht der Ausgang der Maximalamplitude (110% der Trägeramplitude). Wenn das Modulationssignal -5 V (optional -1 V bei der 33600 Series) beträgt, entspricht der Ausgang der minimalen Amplitude (90% der Trägeramplitude).

    Wenn Sie den anderen Kanal als Quelle für die SUM-Modulation verwenden, empfiehlt es sich, stattdessen die Funktion Combine zu verwenden. Die Funktion Combine weist weniger Einschränkungen und weniger Verzögerung auf als SUM mit dem anderen Kanal.
  • Frontplatte:
    Taste Modulate (Modulation) Softkey Type (AM) Softkey Sum Softkey Source (Internal)
  • SCPI: [SOURce[1|2]:]SUM:SOURce {INTernal|EXTernal|CH1|CH2}


Frequenzwobbelung

Bei der Frequenzwobbelung bewegt sich das Gerät mit der angegebenen Wobbelrate von der Start- bis zur Stop-Frequenz. Sowohl die Richtung der Wobbelung (aufwärts oder abwärts) als auch deren Zeitverlauf (linear oder logarithmisch) ist wählbar. Sie können das Gerät auch so konfigurieren, dass es auf einen externen oder manuellen Trigger hin einen einzelnen Wobbelzyklus (einmalige Frequenzveränderung von der Start-Frequenz bis zur Stop-Frequenz) ausgibt. Für Wobbelungen können Sie Sinus-, Rechteck-, Sägezahn-, Puls-, Dreiecks- oder Arbiträrsignale auswählen (PRBS, Rauschen und DC sind nicht zulässig).

Sie können eine Haltezeit angeben, während der die Wobbelung bei der Stop-Frequenz bleibt, und eine Wobbelrücklaufzeit, während der sich die Frequenz von der Stop-Frequenz zur Startfrequenz linear ändert.

Ausführlichere Informationen finden Sie unter Frequenzwobbelung.

Wahl der Wobbelung

Der Wobbel- oder Listenmodus kann nicht mit einer Burst- oder Modulationsbetriebsart kombiniert werden. Wenn Sie die Wobbelbetriebsart wählen, wird die Burst-Betriebsart oder eine Modulationsbetriebsart gegebenenfalls automatisch deaktiviert.

  • Um ein mehrmaliges Umschalten der Signalform zu vermeiden, den Wobbelmodus erst nach der Konfiguration anderer Parameter aktivieren.
  • Frontplatte:

    Taste Sweep Softkey Sweep (OFF) Softkey Sweep Off/On (ON)
  • SCPI:
    [SOURce[1|2]:]FREQuency:MODE SWEEP

    [SOURce[1|2]:]SWEep:STATe {ON|1|OFF|0}

Start- und Stop-Frequenzen

Die Start- und Stopfrequenz stellt die oberen und unteren Frequenzgrenzen für die Wobbelung ein. Die Wobbelung beginnt bei der Startfrequenz, wobbelt bis zur Stopfrequenz und nimmt dann eine Rückstellung auf die Startfrequenz vor.

  • Start- und Stop-Frequenzen: 1 µHz bis Maximalfrequenz für die Wellenform. Die Wobbelung erfolgt über den gesamten Frequenzbereich hinweg phasenkontinuierlich. Die Standardstartfrequenz beträgt 100 Hz. Die Standarfrequenz beträgt 1 kHz.
  • Für eine Aufwärtswobbelung der Frequenz muss die Start-Frequenz kleiner sein als die Stop-Frequenz. Für eine Abwärtswobbelung der Frequenz wird dieses Verhältnis umgekehrt.
  • Sync-Einstellung Normal: Der Sync Puls ist während der gesamten Wobbelung hoch.
  • Sync-Einstellung Träger: Der Sync Puls hat ein 50% Tastverhältnis für jeden Signalzyklus.
  • Sync-Einstellung Marker: Der Sync Puls steigt anfangs an und sinkt bei der Marker-Frequenz. Geändert werden kann dies mit dem Befehl OUTPut[1|2]:SYNC:MODE MARKER.
  • Frontplatte:
    Taste Sweep Softkey Start Freq Tastenfeld und Drehknopf

    Taste Sweep Softkey Stop Freq Tastenfeld und Drehknopf
  • SCPI:
    [SOURce[1|2]:]FREQuency:STARt {<frequency>|MINimum|MAXimum|DEFault}

    [SOURce[1|2]:]FREQuency:STOP {<frequency>|MINimum|MAXimum|DEFault}

Mittenfrequenz und Wobbelbandbreite

Sie können auch die Frequenzgrenzen für die Wobbelung einstellen (mit Mittenfrequenz und Frequenzspanne). Diese Parameter stehen in direktem Zusammenhang mit den Start- und Stop-Frequenzen (siehe oben) und bieten mehr Flexibilität.

  • Mittenfrequenz: 1 µHz bis Maximalfrequenz für die Wellenform. Der Standardwert beträgt 550 Hz.
  • Wobbelbandbreite: Jeder Wert zwischen ±Maximalfrequenz für die Wellenform. Der Standardwert beträgt 900 Hz.
  • Stellen Sie für eine Aufwärtswobbelung der Frequenz eine positive Wobbelbandbreite ein und für eine Abwärtswobbelung eine negative Wobbelbandbreite.
  • Sync-Einstellung Normal: Der Sync Puls ist während der gesamten Wobbelung hoch.
  • Sync-Einstellung Träger: Der Sync Puls hat ein 50% Tastverhältnis für jeden Signalzyklus.
  • Sync-Einstellung Marker: Der Sync Puls steigt anfangs an und sinkt bei der Marker-Frequenz. Geändert werden kann dies mit dem Befehl OUTPut[1|2]:SYNC:MODE MARKER.
  • Frontplatte:
    Taste Units Softkey Start-Stop Cntr-Span (Start-Stop) Softkey Start-Stop Cntr-Span (Cntr-Span)
    Taste Sweep Softkey Center Tastenfeld und Drehknopf
    Taste Sweep Softkey Span Tastenfeld und Drehknopf
  • SCPI:
    [SOURce[1|2]:]FREQuency:CENTer {<frequency>|MINimum|MAXimum|DEFault}

    [SOURce[1|2]:]FREQuency:SPAN {<frequency>|MINimum|MAXimum|DEFault}

Wobbelbetriebsart

Wobbelungen sind mit linearem oder logarithmischen Zeitverlauf möglich, oder mit einer Liste von Wobbelfrequenzen. Bei einer linearen Wobbelung variiert das Gerät die Ausgangsfrequenz während des Wobbelns linear. Eine logarithmische Wobbelung variiert die Ausgangsfrequenz logarithmisch.

Der ausgewählte Modus hat keine Auswirkung auf den Wobbelrücklauf (von Stop zu Start, wenn einer eingestellt ist). Der Wobbelrücklauf ist stets linear.

  • Frontplatte:
    Taste Sweep Softkey Type (LINEAR)
    Softkeys LINEAR Log List
  • SCPI: [SOURce[1|2]:]SWEep:SPACing {LINear|LOGarithmic}

Wobbelzeit

Die Wobbelzeit legt die erforderlichen Sekunden für die Wobbelung von der Startfrequenz bis zur Endfrequenz fest. Das Gerät berechnet die Anzahl der Punkte in der Wobbelung, die auf der Wobbelzeit basieren.

  • Wobbelzeit: 1 ms bis 250.000 Sekunden, Standardwert: 1 s. Für eine lineare Wobbelung im sofortigen Triggermodus beträgt die maximale Gesamtwobbelzeit (inkl. Haltezeit und Rücklaufzeit) 8.000 s. Die maximale Gesamtwobbelzeit für lineare Wobbelungen mit anderen Triggermodi beträgt 250.000 s, und die maximale Gesamtwobbelzeit für logarithmische Wobbelungen beträgt 500 s.
  • Frontplatte:
    Taste Sweep Softkey Sweep Time Tastenfeld und Drehknopf
  • SCPI: [SOURce[1|2]:]SWEep:TIME {<seconds>|MINimum|MAXimum|DEFault}

Halte-/Rücklaufzeit

Die Haltezeit gibt die Zeit an (in Sekunden), um bei der Stop-Frequenz zu bleiben, und die Rücklaufzeit gibt die Anzahl der Sekunden an, die für den Rücklauf von der Stop-Frequenz bis zur Start-Frequenz erforderlich sind.

  • Haltezeit und Rücklaufzeit: 0 bis 3600 Sekunden (Standardwert 0).
  • Frontplatte:
    Taste Sweep Hold &Return Softkey Softkey Hold Time
    Tastenfeld und Drehknopf

    Taste Sweep Hold & Return Softkey Softkey Hold Time
    Tastenfeld und Drehknopf
  • SCPI:
    [SOURce[1|2]:]SWEep:HTIMe {<hold_time>|MINimum|MAXimum|DEFault}

    [SOURce[1|2]:]SWEep:RTIMe {<return_time>|MINimum|MAXimum|DEFault}

Markerfrequenz

Evtl. können Sie die Frequenz einstellen, bei der das Signal am Sync Anschluss der Frontplatte während der Wobbelung in einen logischen LOW-Zustand übergeht. Das Sync Signal wechselt am Anfang der Wobbelung stets von niedrig zu hoch.

  • Markerfrequenz: 1 µHz bis Maximalfrequenz für die Wellenform. Der Standardwert beträgt 500 Hz.
  • Beim Aktivieren der Wobbelbetriebsart muss die Markenfrequenz zwischen der angegebenen Start-Frequenz und der Stop-Frequenz liegen. Falls Sie versuchen, eine außerhalb dieses Bereichs liegende Markenfrequenz zu spezifizieren, wird die Markerfrequenz automatisch gleich der Start-Frequenz oder der Stop-Frequenz eingestellt (je nachdem, welche dieser beiden Frequenzen der gewünschten Markenfrequenz näher liegt).
  • Sie können die Markerfrequenz nicht mit den Frontplattenmenüs konfigurieren, außer die Sync Quelle entspricht dem Wobbelkanal.
  • Frontplatte:
    Taste Sweep Softkey Sweep Off/On (OFF) Softkey Sweep Off/On (ON)
    Trigger-Taste Softkey Sync Setup
  • SCPI: [SOURce[1|2]:]MARKer:FREQuency {<frequency>|MINimum|MAXimum|DEFault}

Trigger-Quelle für die Wobbelung

In der Wobbelbetriebsart gibt das Gerät nach jedem Trigger einen einzelnen Wobbelzyklus aus. Nach Abschluss eines Wobbelzyklus wartet das Gerät auf den nächsten Trigger. Während dieser Zeit wird die Start-Frequenz ausgegeben.

  • Trigger-Quelle für die Wobbelung: Immediate (Standardeinstellung), extern, Zeit oder manuell.
  • Mit der (internen) Quelle Immediate gibt das Gerät eine kontinuierliche Folge von Wobbelzyklen aus, deren Rate durch den Gesamtwert aus Haltezeit, Wobbelzeit und Rücklaufzeit bestimmt wird. Die Wobbelzeit für diese Quelle ist auf 8000 Sekunden begrenzt.
  • Mit der externen Quelle akzeptiert das Gerät einen Hardware-Trigger am rückseitigen Ext Trig Anschluss und startet jedes Mal eine Wobbelung, wenn Ext Trig einen TTL-Puls mit der angegebenen Polarität empfängt.
  • Die Triggerperiode muss mindestens so groß sein wie die angegebene Wobbelzyklusdauer.
  • Mit der manuellen Quelle gibt das Gerät jedesmal eine Wobbelung aus, wenn die Frontplattentaste [Trigger] gedrückt wird.
  • Frontplatte:
    Trigger-Taste (Trigger) Softkey Source (Immed)
  • Steigung der Flanke für die Triggersignalflanke angeben:
    Trigger-Taste Softkey Trig Out Setup Softkey Trig Out (Off)
  • SCPI:
    TRIGger[1|2]:SOURce {IMMediate|EXTernal|TIMer|BUS}

    TRIGger[1|2]:SLOPe {POSitive|NEGative}

Weitere Informationen siehe unter Triggerung.

Trigger Out-Signal

Der rückseitige Anschluss Ext Trig, der nur für Burst und Wobbelung verwendet wird, gibt jetzt ein "Trigger out" Signal an. Ist diese Option aktiviert, gibt dieser Anschluss zu Beginn des Bursts oder der Wobbelung einen Puls aus, entweder mit einer Anstiegsflanke (Standard) oder einer Abfallflanke.

  • Ist die Triggerquelle Immediate (intern) ausgewählt, gibt das Gerät zu Beginn von Wobbelung oder Burst ein Rechtecksignal mit einem Tastverhältnis von 50% über den Ext Trig Anschluss aus. Die Signalfrequenz entspricht der angegebenen Burst-Periode oder der gesamten Wobbelzeit.
  • Wenn die externe Triggerquelle ausgewählt ist, deaktiviert das Gerät das "Trigger out"-Signal. Der Ext Trig Anschluss kann nicht gleichzeitig für Wobbelung oder Burst und Trigger Out verwendet werden (ein extern getriggertes Signal verwendet den gleichen Anschluss für die Triggerung von Wobbelung oder Burst).
  • Wenn die manuelle oder Bus-Triggerquelle gewählt wurde, gibt das Gerät einen Puls am Anfang eines jeden Wobbelzyklus oder Bursts (>1 μs Pulsbreite bei 33500 Series Geräten und 100 ns bei 33600 Series Geräten) über den Ext Trig Anschluss aus.
  • Um festzulegen, ob das Gerät auf einer ansteigenden oder abfallenden Flanke des Ext Trig Anschlusses triggert, drücken Sie [Trigger] > Trig Out Setup. Wählen Sie dann die gewünschte Flanke durch Drücken von Trig Out.
  • SCPI:
    OUTPut:TRIGger:SLOPe {POSitive|NEGative}

    OUTPut:TRIGger {ON|1|OFF|0}

Frequenzliste

Im Frequenzlistenmodus bewegt sich das Gerät durch eine Liste von Frequenzen und verweilt bei jeder Frequenz eine angegebene Periode. Das Fortschreiten durch die Liste kann auch durch Triggern kontrolliert werden.

  • Der Wobbel- oder Listenmodus kann nicht mit einer Burst- oder Modulationsbetriebsart kombiniert werden. Wenn Sie die Wobbelbetriebsart wählen, wird die Burst-Betriebsart oder eine Modulationsbetriebsart gegebenenfalls automatisch deaktiviert.
  • Um ein mehrmaliges Umschalten der Signalform zu vermeiden, aktivieren Sie den Listenmodus, nachdem Sie seine Parameter konfiguriert haben.
  • Frontplatte: Liste aktivieren, bevor andere Listenparameter eingestellt werden. Drücken Sie [Sweep] > Type > List.
  • SCPI:
    [SOURcd[1|2]:]FREQuency:MODE LIST

    [SOURce[1|2]:]LIST:FREQuency <freq1>[, <freq2>, etc.]
  • Das Fortschreiten in der Liste wird durch das Triggersystem kontrolliert. Wenn die Triggerquelle intern oder direkt ist, bestimmt die Verweilzeiteinstellung (LIST:DWELl) die Verweilzeit bei jeder Frequenz. Für alle anderen Triggerquellen wird die Verweilzeit durch den Abstand des Triggerereignisses bestimmt.


Burst-Betriebsart

Das Gerät kann ein Signal ausgeben für eine spezifizierte Anzahl von Zyklen, den sogenannten Burst. Ein Burst ist zulässig mit Sinus-, Quadrat-, Dreieck-, Sägezahn-, Impuls-, PRBS- oder Arbiträrsignalen (Nutzsignale sind nur zulässig in der Betriebsart "Gated Burst"; DC ist nicht zulässig).

Weitere Informationen unter Tutorial - Burst.

Wahl der Betriebsart „Burst“

Burst kann nicht aktiviert werden, wenn die Sweep oder Modulation aktiviert sind. Durch die Aktivierung von Burst werden Sweep und Modulation ausgeschaltet.

  • Um ein mehrmaliges Umschalten der Signalform zu vermeiden, den Burst-Modus erst nach der Konfiguration anderer Parameter aktivieren.
  • Frontplatte:
    Burst-Taste Softkey Burst Off Softkey Burst On
  • SCPI: [SOURce[1|2]:]BURSt:STATe {ON|1|OFF|0}

Betriebsart Burst

Burst hat zwei Betriebsarten, die im Folgenden beschrieben werden. Die ausgewählte Betriebsart steuert die zulässige Triggerquelle und die anderen anzuwendenden Burst-Parameter.

  • Betriebsart Triggered Burst (Standardeinstellung): Das Gerät gibt jedes Mal bei Empfang eines Triggers ein Signal für eine spezifizierte Anzahl von Zyklen aus (Burst-Anzahl). Nach der Ausgabe der spezifizierten Anzahl von Zyklen stoppt das Gerät und wartet auf den nächsten Trigger. Das Gerät kann einen internen Trigger verwenden, um einen Burst-Vorgang auszulösen oder Sie können durch Drücken der Bedienfeldtaste [Trigger], durch Auslösen eines Trigger-Signals über den rückseitigen Anschluss Ext Trig oder durch Senden eines Software-Triggers (Trigger-Befehl über die Fernsteuerungsschnittstelle) einen externen Trigger wählen.
  • Betriebsart External Gated Burst: Das Ausgangssignal wird durch ein externes Torsignal am rückseitigen Anschluss Ext Trig ein- oder ausgeschaltet. Wenn das Torsignal sich im Zustand WAHR befindet, gibt das Gerät ein kontinuierliches Signal aus. Geht das Torsignal in den Zustand FALSE über, wird der aktuelle Signalzyklus beendet, die Ausgangsspannung bleibt auf dem durch die Start-Burst-Phase der gewählten Signalform vorgegebenen Wert. Bei der Signalform „Noise“ wird die Signalausgabe beim TRUE/FALSE-Übergang des Torsignals sofort beendet.
Parameter | Burst-Betriebsart (BURS:MODE) | Burst-Anzahl (BURS:NCYC) | Burst-Periode (BURS:INT:PER) | „Burst Phase“ (BURS:PHAS) | Triggerquelle (TRIG:SOUR)Betriebsart
Getriggerter Burst-Modus: Interner Trigger | TRIGgered | Verfügbar | Verfügbar | Verfügbar | IMMediate
Getriggerter Burst-Modus: Externer Trigger | TRIGgered | Verfügbar | Nicht verwendet | Verfügbar | EXTernal, BUS
Betriebsart „Gated Burst“: Externer Trigger | GATed | Nicht verwendet | Nicht verwendet | Verfügbar | Nicht verwendet
Betriebsart „Timer Burst“: Interner Trigger | TRIGgered | Verfügbar | Nicht verwendet | Verfügbar | TIMer
  • In der Betriebsart „Gated“ werden Burst-Anzahl, Burst-Periode und Triggerquelle nicht berücksichtigt (nur für Betriebsart „Triggered Burst“). Manuelle Trigger werden ignoriert; keine Fehlermeldung angezeigt.
  • In der Betriebsart „Gated“ können Sie die Polarität des Signals über den rückseitigen Anschluss Ext Trig angeben ([SOURce[1|2]:]BURSt:GATE:POLarity {NORMal|INVerted}). Standardeinstellung ist NORMal (TRUE = HIGH).
  • Frontplatte:
    Burst-Taste Softkey NCycle
  • SCPI: [SOURce[1|2]:]BURSt:MODE {TRIGgered|GATed}

Signalfrequenz

Sie können die Signalfrequenz in den beiden Burst-Betriebsarten „Triggered“ und „External Gated“ angeben. In der Betriebsart „triggered“ wird ein Signal mit der spezifizierten Signalfrequenz mit der durch „Burst count“ spezifizierten Anzahl von Zyklen ausgegeben. In der Betriebsart „external gated“ wird ein Signal mit der spezifizierten Signalfrequenz dann ausgegeben, wenn das externe Torsignalsignal sich im Zustand TRUE befindet.

Das unterscheidet sich von der „Burst-Periode," bei der (nur in der getriggerten Betriebsart) das Zeitintervall zwischen den Bursts spezifiziert wird.

  • Signalfrequenz: 1 µHz bis Maximalfrequenz für die Wellenform. Der Standardwert beträgt 1 kHz. (Bei einem intern getriggerten Burst-Signal liegt die Mindestfrequenz bei 126 µHz für die 33500 Series oder bei 251 µHz für die 33600 Series.)
  • Frontplatte:
    Taste Parameters Softkey Frequency Tastenfeld und Drehknopf
  • SCPI: [SOURce[1|2]:]FREQuency {<frequency>|MINimum|MAXimum|DEFault}

Der Befehl APPLy konfiguriert ein Signal mit einem Befehl.

Burst-Anzahl

Anzahl der Zyklen (1 bis 100.000.000 oder unendlich) pro Burst. Betrifft nur die (intern oder extern) getriggerte Burst-Betriebsart.

  • Bei der Triggerquelle Immediate wird die angegebene Anzahl der Zyklen kontinuierlich ausgegeben, die Rate wird durch die Burst-Periode bestimmt. Die Burst-Periode ist die Zeit zwischen den Starts aufeinanderfolgender Bursts. Außerdem muss die Burst-Anzahl kleiner sein als das Produkt aus Burst-Periode und Signalfrequenz:

    Burst-Periode > (Burst-Anzahl)/(Signalfrequenz) + 1µsec (33500 Series)

    Burst-Periode > (Burst-Anzahl)/(Signalfrequenz) + 500 ns (33600 Series)
  • Das Gerät vergrößert die Burst-Periode automatisch bis zum Maximalwert (Die Signalfrequenz bleibt dabei unverändert).
  • In der Betriebsart „Gated Burst“ wird die Burst-Anzahl ignoriert. Wenn Sie jedoch die Burst-Anzahl durch einen Fernsteuerungsbefehl ändern, während der Funktionsgenerator sich in der Burst-Betriebsart „Gated“ befindet, behält das Gerät die neue Burst-Anzahl „im Gedächtnis“ und verwendet nach dem Umschalten in die Betriebsart „Triggered“ diesen Wert.
  • Frontplatte:
    Burst-Taste Softkey Number of cycles Tastenfeld und Drehknopf
    oder
    Burst-Taste Softkey N Cycles Infinite Softkey N Cycles Infinite
  • SCPI: [SOURce[1|2]:]BURSt:NCYCles {<num_cycles>|INFinity|MINimum|MAXimum}

Burst-Periode

Die Burst-Periode, die nur in der intern getriggerten Burst-Betriebsart verwendet wird, ist die Zeit vom Start eines Burst bis zum Start des nächsten Burst (1 µs bis 8000 s, Standardzeit 10 ms bei der 33500 Series). Bei der 33600 Series beträgt der Bereich 1 µs bis 4000 s und die Standardzeit liegt ebenso bei 10 ms. Die Burst-Periode unterscheidet sich von der „Signalfrequenz“, welche die Frequenz des als Burst ausgegebenen Signals angibt.

  • Die Burst-Periode wird nur dann verwendet, wenn die Triggerung Immediate aktiviert wurde. Bei manueller oder externer Triggerung (oder in der Burst-Betriebsart Gated) ist die Burst-Periode ohne Bedeutung.
  • Es ist nicht möglich, eine Burst-Periode zu spezifizieren, die so kurz ist, dass die spezifizierte Anzahl von Bursts mit der spezifizierten Frequenz nicht ausgegeben werden kann. Wenn die Burst-Periode zu kurz ist, wird sie vom Gerät automatisch auf einen geeigneten Wert abgeändert.
  • Frontplatte:
    Burst-Taste Softkey Burst Period Tastenfeld und Drehknopf
  • SCPI: [SOURce[1|2]:]BURSt:INTernal:PERiod {<seconds>|MINimum|MAXimum}

Startphase

Startphase des Bursts von -360 bis +360 Grad (Standardwert 0).

  • Einheiten der Startphase spezifizieren mit UNIT:ANGLe.
  • Stets auf der Frontplatte in Grad angezeigt (nie in Radiant). Wurde der Wert über die Remoteschnittstelle auf Radiant eingestellt, wandelt das Gerät den Wert auf dem Bedienfeld in Grad um.
  • Bei den Signalformen Sinus, Rechteck und Sägezahn entspricht 0 Grad dem Punkt, an dem das Signal 0 V (oder den DC-Offset) von unten nach oben schneidet. Bei Ausgangssignalen entspricht 0 Grad dem ersten Signalpunkt. Die Startphase hat keine Auswirkungen auf Rauschen.
  • Die Start-Phase wird auch in der "Gated Burst"-Betriebsart verwendet. Geht das Torsignal in den Zustand FALSE über, wird der aktuelle Signalzyklus beendet und der Ausgang bleibt bei dem Spannungswert der Start-Burst-Phase.
  • Frontplatte:
    Burst-Taste Softkey Start Phase Tastenfeld und Drehknopf
  • SCPI: [SOURce[1|2]:]BURSt:PHASe {<angle>|MINimum|MAXimum}

Burst-Triggerquelle

Im getriggerten Burst-Modus:

  • Das Gerät gibt jedes Mal bei Empfang eines Triggers ein Signal mit der spezifizierten Anzahl von Zyklen (Burst-Anzahl) aus. Nach der Ausgabe der angegebenen Anzahl von Zyklen stoppt das Gerät und wartet auf den nächsten Trigger.
  • IMMediate (intern): bei aktiviertem Burst-Modus erfolgt die Geräteausgabe kontinuierlich. Die Geschwindigkeit der Burst-Erstellung wird mit dem Befehl BURSt:INTernal:PERiod festgelegt.
  • EXTernal: Das Gerät akzeptiert Hardware-Trigger über den rückseitigen Anschluss Ext Trig. Das Gerät gibt immer dann einen Burst mit der angegebenen Zahl von Zyklen aus, wenn Ext Trig einen Pegelübergang mit der korrekten Polarität (TRIGger[1|2]:SLOPe) empfängt. Externe Triggersignale während eines Bursts werden ignoriert.
  • BUS (Software): das Gerät initiiert immer dann einen Burst, wenn ein Bus-Trigger (*TRG) empfangen wird. Die Taste [Trigger] auf der Frontplatte ist beleuchtet, wenn das Gerät auf einen Bus-Trigger wartet.
  • EXTernal oder BUS: Burst-Anzahl und Burst-Phase bleiben wirksam, die Burst-Periode wird jedoch ignoriert.
  • TIMer: Die Abstände zwischen Triggerereignissen werden durch einen Timer festgelegt, wobei der erste Trigger erfolgt, sobald INIT auftritt.
  • Frontplatte:
    Trigger-Taste Softkey Trigger Setup (Trigger) Softkey Quelle (Immed)
  • Um festzulegen, ob das Gerät auf einer ansteigenden oder abfallenden Flanke eines Signals triggert, muss die externe Triggerquelle vor der Auswahl von Trigger Setup gewählt werden.
  • SCPI:
    TRIGger[1|2]:SOURce {IMMediate|EXTernal|TIMer|BUS}

    TRIGger[1|2]:SLOPe {POSitive|NEGative}

Weitere Informationen siehe unter Triggerung.

Wird das Tastverhältnis auf ein getriggertes Burst-Rechtecksignal geändert, wenn der Triggermodus auf Timer gestellt ist, endet der aktuelle Burst und ein zusätzlicher Burst wird ausgeführt, bevor das Tastverhältnis des Burst wechselt.

Trigger Out-Signal

Der rückseitige Anschluss Ext Trig, der nur für Burst und Wobbelung verwendet wird, gibt jetzt ein "Trigger out" Signal an. Ist diese Option aktiviert, gibt dieser Anschluss zu Beginn des Bursts oder der Wobbelung einen Puls aus, entweder mit einer Anstiegsflanke (Standard) oder einer Abfallflanke.

  • Ist die Triggerquelle Immediate (intern) ausgewählt, gibt das Gerät zu Beginn von Wobbelung oder Burst ein Rechtecksignal mit einem Tastverhältnis von 50% über den Ext Trig Anschluss aus. Die Signalfrequenz entspricht der angegebenen Burst-Periode oder der gesamten Wobbelzeit.
  • Wenn die externe Triggerquelle ausgewählt ist, deaktiviert das Gerät das "Trigger out"-Signal. Der Ext Trig Anschluss kann nicht gleichzeitig für Wobbelung oder Burst und Trigger Out verwendet werden (ein extern getriggertes Signal verwendet den gleichen Anschluss für die Triggerung von Wobbelung oder Burst).
  • Wenn die manuelle oder Bus-Triggerquelle gewählt wurde, gibt das Gerät einen Puls am Anfang eines jeden Wobbelzyklus oder Bursts (>1 μs Pulsbreite bei 33500 Series Geräten und 100 ns bei 33600 Series Geräten) über den Ext Trig Anschluss aus.
  • Frontplatte
    Burst-Taste Softkey Burst Off alt="Burst Off-Softkey" Softkey Burst On
    Trigger-Taste Softkey Trig Out Setup
    Anschließend diesen Softkey verwenden, um die gewünschte Flankenrichtung zu wählen:
    Softkey Trig Out (Off)
  • SCPI:
    OUTPut:TRIGger:SLOPe {POSitive|NEGative}

    OUTPut:TRIGger {ON|1|OFF|0}


Triggerung

In diesem Abschnitt wird das Triggersystem des Geräts beschrieben.

Trigger-Überblick

Diese Trigger-Informationen gelten nur für Wobbelung und Burst. Ein Wobbelzyklus oder Burst kann durch einen internen, einen externen oder einen manuellen Trigger ausgelöst werden.

  • Interne oder „automatische“ Triggerung (Standard): Die Geräteausgabe erfolgt kontinuierlich, wenn der Wobbel- oder Burstmodus ausgewählt ist.
  • Extern: Verwendet den rückseitigen Anschluss Ext Trig, um den Wobbelzyklus oder Burst auszulösen. Das Gerät gibt bei jedem Impuls am Eingang Ext Trig einen einzelnen Wobbelzyklus oder einen Burst aus. Sie können wählen, ob das Gerät an der absteigenden oder an der abfallenden Flanke triggert.
  • Manuell: Bei manueller Triggerung wird jedes Mal, wenn Sie die Taste [Trigger] drücken, ein einzelner Wobbelzyklus oder ein Burst ausgegeben.
  • Wenn Sie eine Liste wobbeln, verschiebt der Trigger das Signal zur nächsten Frequenz in der Liste.
  • In der Fernsteuerungsbetriebsart oder wenn eine andere Funktion als Wobbelung oder Burst gewählt wurde, ist die Taste [Trigger] deaktiviert.

Triggerquellen

Diese Trigger-Informationen gelten nur für Wobbelung und Burst. Sie müssen die Quelle spezifizieren, aus welcher das Gerät einen Trigger akzeptiert.

  • Triggerquellen für Wobbelung und Burst: Immediate (Standardeinstellung), External, Manual oder Timer.
  • Das Instrument akzeptiert einen manuellen Trigger, einen Hardware-Trigger über den rückseitigen Eingang Ext Trig oder einen internen Trigger (kontinuierliche Ausgabe von Wobbelzyklen oder Bursts). Sie können Bursts ebenso über einen Timer triggern. Beim Einschalten des Gerätes wird automatisch der Soforttrigger gewählt.
  • Die Einstellung der Triggerquelle ist flüchtig; beim Einschalten des Gerätes wird automatisch die Triggerquelle „Internal“ gewählt (vorderes Bedienfeld) oder „Immediate“ (Remoteschnittstelle) gewählt oder *RST.
  • Frontplatte:
    Wobbelung oder Burst aktivieren. Gehen Sie anschließend wie folgt vor:
    Trigger-Taste (Trigger) Softkey Source (Immed)
  • SCPI: TRIGger[1|2]:SOURce {IMMediate|EXTernal|TIMer|BUS}
  • Der Befehl APPLy wählt automatisch die Triggerquelle Immediate.

Soforttrigger

Betriebsart Interner Trigger (Standardeinstellung): Das Gerät gibt kontinuierlich Wobbel oder Bursts aus (entsprechend der spezifizierten Wobbelzeit oder Burst-Periode).

Frontplatte:
Trigger-Taste Softkey Source IMMED

SCPI: TRIGger:SOURce IMMediate

Manuelle Triggerung

Betriebsart manuelle Triggerung (nur vorderes Bedienfeld): Um das Gerät manuell zu triggern, drücken Sie auf [Trigger]. Das Gerät löst bei jedem Druck auf [Trigger] einen einzelnen Wobbelzyklus bzw. Burst aus. Die Taste leuchtet, wenn Sie sich im Trigger-Menü befinden, und das Gerät wartet auf einen manuellen Trigger. Die Taste blinkt, wenn das Gerät auf einen Trigger wartet, Sie aber nicht im Trigger-Menü sind. Die Taste ist deaktiviert, wenn sich das Gerät im Remotemodus befindet.

Externe Triggerung

Im externen Trigger-Modus akzeptiert das Gerät einen Hardware-Trigger über den rückseitigen Anschluss Ext Trig. Das Gerät löst jedes Mal einen einzelnen Wobbelzyklus oder Burst aus, wenn Ext Trig einen TTL-Impuls mit der spezifizierten Flanke erhält. Der externe Trigger-Modus funktioniert wie der manuelle Trigger-Modus abgesehen davon, dass der Trigger am Anschluss Ext Trig erfolgt.

Sie unten: Trigger Input Signal.

Frontplatte:
Trigger-Taste Softkey (Trigger) Source (Immed) Softkey External trigger

Um festzulegen, ob das Instrument auf der ansteigenden oder abfallenden Flanke triggert, drücken Sie Trigger Setup und wählen Sie die Flankenrichtung durch Drücken auf Slope.

SCPI:
TRIGger:SOURce EXTernal

TRIGger[1|2]:SLOPe {POSitive|NEGative}

Software- (Bus-) Triggerung

Nur über Remoteschnittstellen verfügbar, ähnelt dem manuellen Trigger-Modus über das vordere Bedienfeld, aber das Gerät wird über einen Bus-Trigger-Befehl getriggert. Das Gerät löst bei jedem empfangenen Bus-Trigger-Befehl einen einzelnen Wobbelzyklus bzw. Burst aus. Die Taste blinkt, wenn ein Bus-Trigger-Befehl empfangen wird.

Senden Sie zur Wahl der Bus-Triggerquelle den folgenden Befehl TRIGger:SOURce BUS:

Um das Gerät über die Remoteschnittstelle (GPIB, USB oder LAN) zu triggern, wenn die Bus-Quelle gewählt wurde, TRIG oder *TRG senden (triggern). Die Taste [Trigger] auf der Frontplatte ist beleuchtet, wenn das Gerät auf einen Bus-Trigger wartet.

Timer-Triggerung

Der Timer-Trigger-Modus gibt in einem bestimmten Zeitabstand Trigger aus. Senden Sie zur Wahl der Bus-Triggerquelle den folgenden Befehl TRIGger:SOURce TIMer.

Trigger-Eingangssignal

Dieser rückseitige Anschluss wird in den folgenden Betriebsarten benutzt:

  • Modus Trigger-Ablenkung: Drücken Sie Trigger Setup > Source Ext oder führen Sie TRIG:SOUR EXT aus (Wobbelzyklus muss aktiviert sein). Wenn ein Pegelübergang mit der korrekten Polarität über den Anschluss Ext Trig empfangen wird, gibt das Gerät einen einzelnen Wobbelzyklus aus.
  • Modus Externe FSK-Modulation: Drücken Sie die Taste Source oder führen Sie FSK:SOUR EXT aus (FSK muss aktiviert sein). Wenn das externe Signal sich im LOW-Zustand befindet, wird die Trägerfrequenz ausgegeben. Wenn das externe Signal sich im HIGH-Zustand befindet, wird die Hop-Frequenz ausgegeben. Die maximal zulässige FSK-Rate beträgt 100 kHz.
  • Getriggerter Burst-Modus: Drücken Sie Trigger Setup > Source Ext oder führen Sie TRIG:SOUR EXT aus (Wobbelzyklus muss aktiviert sein). Das Instrument gibt jedes Mal, wenn es aus der spezifizierten Triggerquelle einen Trigger empfängt, ein Signal mit der spezifizierten Anzahl von Zyklen (Burst-Anzahl) aus.
  • Betriebsart External Gated Burst: Softkey Gated drücken oder BURS:MODE GAT ausführen, Burst muss dabei aktiviert sein. Wenn das externe Torsignal sich im Zustand WAHR befindet, gibt das Gerät ein kontinuierliches Signal aus. Geht das Torsignal in den Zustand FALSE über, wird der aktuelle Signalzyklus beendet. Das Gerät stoppt, die Ausgangsspannung bleibt auf dem durch die Start-Burst-Phase vorgegebenen Wert. Bei Noise-Signalen wird die Signalausgabe gestoppt, sobald das Torsignal auf FALSE übergeht.

Trigger-Ausgangssignal

Das Trigger-Ausgangssignal ist auf die Chassis-Masse bezogen und befindet sich physisch neben dem externen Modulationseingang, welcher potenzialfrei ist. Achten Sie besonders darauf, beim Anschließen oder Trennen dieser Kabel die beiden Signale nicht gleichzeitig zu berühren. Trennen Sie die Anschlüsse des Geräts von der Netzspannung, bevor Sie diese Kabel anschließen oder trennen.
  • Der rückseitige Anschluss Ext Trig, der nur für Burst und Wobbelung verwendet wird, gibt jetzt ein "Trigger out" Signal an. Ist diese Option aktiviert, gibt dieser Anschluss zu Beginn des Bursts oder der Wobbelung einen Puls aus, entweder mit einer Anstiegsflanke (Standard) oder einer Abfallflanke.
    Trigger Out, die ansteigende Flanke wird angezeigt

    Das obere Diagramm zeigt die Triggerung bei der 33500 Series. Bei der 33600 Series beträgt die Pulsbreite 100 ns und der Spannungspegel ist programmierbar (+3.3 V ist nicht unbedingt gezeigt). Siehe TRIGger:LEVel für nähere Informationen zur Einstellung dieses Werts.
  • Interne (sofortige) oder Timer-Triggerquelle: Das Gerät gibt am Anfang eines Wobbel- oder Burst-Zyklus über den Anschluss Ext Trig ein Rechtecksignal mit einem 50 %-Arbeitszyklus aus. Die Signalperiode entspricht der spezifizierten Wobbelzeit oder Burst-Periode.
  • Externe Triggerquelle: Das Gerät deaktiviert das Signal „Trigger Out“. Der rückseitige Anschluss Ext Trig kann nicht für beide Vorgänge gleichzeitig verwendet werden (ein extern getriggertes Signal verwendet den gleichen Anschluss für das Triggern von Wobbelung oder Burst).
  • Bus- (Software-) oder manuelle Triggerquelle: Das Gerät gibt am Anfang jedes Wobbel- oder Burstzyklus einen Impuls mit (>1 μs pulse width) über den Anschluss Ext Trig aus.
  • Frontplatte: Wobbelung oder Burst aktivieren. Gehen Sie anschließend wie folgt vor:
    Trigger-Taste Softkey Trig Out Setup
    Anschließend diesen Softkey verwenden, um die gewünschte Flankenrichtung zu wählen:
    Softkey Trig Out (Off)
  • SCPI:
    OUTPut:TRIGger:SLOPe {POSitive|NEGative}

    OUTPut:TRIGger {ON|1|OFF|0}


Zweikanaloperationen

Dieser Abschnitt behandelt die meisten Themen zum Bereich Zweikanalbetrieb. Er behandelt nicht den Bereich optional IQ Player.

Zweikanaloperation einleiten

Sie geben die Zweikanal-Konfiguration ein, indem Sie zuerst auf eine Kanalausgangstaste drücken, dann auf More und dann auf Dual Channel.

Frequenzkopplung

Über die Frequenzkopplung können Sie Frequenzen oder Abtastraten mit einem konstanten Frequenzverhältnis oder Versatz zwischen ihnen koppeln. Taste Freq Cpl drücken, um die Frequenzkopplung ein oder auszuschalten, dann Taste Freq Cpl Settings drücken, um die Frequenzkopplung zu konfigurieren.

Über den Softkey Freq Cpl Settings wird das unten gezeigte Menü angezeigt. Der erste Softkey ermöglicht es, anzugeben, ob Sie die Frequenzen mit einem Frequenzverhältnis oder einem Versatz koppeln möchten, über den zweiten Softkey können Sie das Verhältnis oder den Versatz festlegen.

Amplitudenkopplung

Amplitudenkopplung, aktiviert über den Softkey Ampl Cpl, koppelt die Amplitude und Offset-Spannung zwischen den Kanälen, so dass eine Änderung der Amplitude oder des Offsets auf einem Kanal sich auf beide Kanäle auswirkt.

Tracking

Tracking, konfiguriert über den Softkey Tracking, hat drei verschiedene Betriebsarten: Off, On und Invert. Wurde Tracking deaktiviert, arbeiten beide Kanäle unabhängig voneinander. Wurde Tracking aktiviert, verhalten sie sich wie ein einziger Kanal. Der dritte Modus, Invert, bewirkt, dass sich die Ausgänge der Kanäle ineinander umkehren. Es entsteht ein Differenzialkanal, der beide Ausgänge verwendet.

Combine

Die Funktion Combine kombiniert zwei Ausgänge zu einem Anschluss. Wenn Sie CH2 aus dem Menü Channel 1 wählen, werden sie auf Kanal 1 kombiniert; wählen Sie CH1 im Menü Channel 2, werden sie auf Kanal 2 kombiniert.

In der Abbildung unten ist die obere Wellenform ein 100 mVpp-1 kHz Sinussignal auf Kanal 1, die untere Wellenform ein 100 mVpp-Sinussignal mit 5 kHz auf Kanal 2.

Die Abbildung unten zeigt die zwei auf Kanal 1 kombinierten Ausgänge. Beachten Sie, dass die X-Achse komprimiert wurde (verkleinert), um mehr Zyklen anzuzeigen.

Die kombinierten Signale müssen nicht vom selben Typ sein; zum Beispiel zeigt die Abbildung den selben 5 kHz-Kanal auf Kanal 2 kombiniert mit einer 100 mVpp-Rechteckwelle auf Kanal 1.

Werden Signale kombiniert, werden die DC-Offset-Werte nicht miteinander addiert. Nur der DC-Offset des Empfangskanals wird im kombinierten Ausgang verwendet. Die Abbildung unten zeigt einen DC-Offset von 50 mV addiert zu Kanal 1. Der zu Kanal 2 addierte 50 mV Offset wird ignoriert.

Sie können Combine auch mit Bursts verwenden. Auf der Abbildung unten zum Beispiel werden ein 1 kHz Sinussignal auf Kanal 1 und ein Burst mit drei Zyklen eines 5 kHz Sinussignals auf Kanal 2 abgebildet.

Werden diese Signale auf Kanal 1 kombiniert, ist das Ergebnis eine einfache Addition der Amplituden beider Signale, wie unten abgebildet.

Sie können die Signale auch auf Kanal 2 kombinieren, wie unten angezeigt.


Option IQ Player

IQ-Player (Option)

Der optionale IQ-Player wird verwendet, um duale Arbiträrsignale wiederzugeben, wie z.B. IQ Baseband-Signale.

Ein duales Arbiträrsignal entspricht einer Stereo-Musikdatei. Es verfügt über zwei Informationskanäle, die die gleiche Anzahl von Samples enthalten, jeweils zusammen beginnen und enden und stets bei der gleichen Abtastrate abgespielt werden.

Dateiformate

Die nativen .ARB und .BARB-Dateien des Geräts können entweder einen oder zwei Datenkanäle enthalten. Diese Dateien werden typischerweise mit der Software Keysight BenchLink Waveform Builder erstellt, sie können direkt auf dem Gerät wiedergegeben werden.

Sie können auch Dateien mit den Endungen .DAT, .ASC, .I und .Q. direkt wiedergeben. Diese Dateiformate enthalten ein oder zwei Spalten ASCII-Zahlen von -1.0 und 1.0, entweder in wissenschaftlicher oder dezimaler Schreibweise. Diese Daten stellen die relative „Form“ des Signals mit dem aktuellen Amplitudenbereich dar.

Schließlich können Sie ein- oder zweispaltige Datendateien im Format .CSV oder .TXT importieren. Um eine Datei zu importieren, drücken Sie auf [Waveforms] > Arb > Arbs > Import Data. Es wird eine Menüschnittstelle geöffnet, über die Sie schnell durch den Prozess des Dateiimports geführt werden.

Frontplatte

Sobald Sie ein duales Arbiträrsignal als aktives Signal haben, verändert sich die Farbe der Registerkarte nach Violett, wie unten abgebildet.

Bildschirm duales Arbiträrsignal

Die Signalabbildung ist ein Konstellationsdiagramm, aber Sie können sie in ein Zeitbereichsdiagramm umändern. Dazu drücken Sie [System] > System Setup > Screen Layout. Sie gelangen zum folgenden Menü:

Durch Drücken des Softkeys Time verändert sich die Graphik in ein Zeitbereichsdiagramm:

Bildschirmanzeige Zeitansicht Dual arb

Abgleichskorrektur

Drücken Sie More im Menü [Parameters], Sie gelangen zur Seite 2 des Menüs [Parameters]:

Seite 2 des Menüs Parameters

In diesem Menü können Sie Balance Adjust drücken, um ein Menü zu öffnen, mit dem Sie Amplitudenabgleichsverstärkung und Kanal-Offset festlegen können:

Dual Arb IQ Abgleich

IQ Arb Versatz

Um kleineren Zeitversatz zwischen den Kanälen zu kompensieren, drücken Sie zuerst eine der Kanalausgangstasten und dann auf More, um auf Seite 2 des Menüs zu gelangen:

Ausgabe Duales Abiträrsignal Seite 2

In diesem Menü drücken Sie auf IQ Arb Skew, um das folgende Menü zu öffnen, über das Sie einen Zeitversatz von bis zu 4 ns bei der 33500 Series oder bis zu 1 ns bei der 33600 Series kompensieren können:

Menü IQ Arb Versatz

SCPI-Befehle

Es gibt acht SCPI-Befehle im Zusammenhang mit dem IQ Player:

Duale Arbiträrsignale laden

[SOURce[1|2]:]DATA:ARBitrary[1|2] <arb_name>, {<binary_block>|<value>, <value>, . . .}

[SOURce[1|2]:]DATA:ARBitrary[1|2]:DAC <arb_name>, {<binary_block>|<value>, <value>, . . .}

[SOURce[1|2]:]DATA:ARBitrary2:FORMat {AABB|ABAB}

Wiedergabe dualer Arbiträrsignale anpassen

FUNCtion:ARBitrary:BALance:GAIN {<percent>|MINimum|MAXimum|DEFine}

FUNCtion:ARBitrary:BALance:OFFSet{1|2} {<volts>|MINimum|MAXimum|DEFault}

FUNCtion:ARBitrary:BALance[:STATe] {ON|1|OFF|0}

FUNCtion:ARBitrary:SKEW[:STATe] {ON|1|OFF|0}

FUNCtion:ARBitrary:SKEW:TIME [{<time>|MINimum|MAXimum|DEFault}]


Übergeordnete Systemfunktionen

Systembezogene Vorgänge

In diesem Abschnitt werden die Themen Speicherung von Gerätezuständen, Abrufen des Ausschalt-Gerätezustands, Fehlerbedingungen, Selbsttest und Display-Steuerung behandelt. Diese sind zwar ohne Bezug zur Erzeugung von Signalen, jedoch wichtig für das Funktionieren des Gerätes.

Abspeichern des Gerätezustands

  • Es gibt zwei Möglichkeiten für das Abspeichern und Abrufen von Gerätezuständen:
  • Benannte Statusdateien über die Frontplatte oder MMEMory:STORe:STATe und MMEMory:LOAD:STATe
  • Speicherorte 1 bis 4 mit *SAV und *RCL

    • Bei 33600 Series Geräten werden Zustandsdateien, die mit *SAV und *RCL verknüpft sind, in Dateien mit dem Namen STATE_0.STA bis STATE_4.STA gespeichert. Diese Dateien befinden sich im Verzeichnis Settings im internen Speicher. Sie können diese Dateien über MMEMory commands verwalten.
  • Sie können auch den speziellen Speicherort 0 mit *SAV und *RCL verwenden, aber Speicherort 0 wird beim Ausschalten mit dem aktuellen Gerätezustand überschrieben.
  • Beide Speichermethoden speichern die ausgewählte Funktion (inklusive Arbiträrsignale), Frequenz, Amplitude, DC-Offset, Tastverhältnis, Symmetrie und Modulationsparameter.
  • Wenn Sie ein Arbiträrsignal aus einem permanenten Speicher löschen, nachdem der Gerätezustand gespeichert wurde, gehen die Signaldaten verloren und das Gerät verwendet stattdessen den „exponentiellen Anstieg“.
  • Gespeicherte Daten werden nicht beeinflusst durch *RST; ein gespeicherter Zustand bleibt bestehen, bis er überschrieben oder ausdrücklich gelöscht wird.
  • Frontplatte:
    System-Taste Softkey Store - Recall

    So speichern Sie einen Zustand:
    Softkey Store State Tastenfeld und Drehknopf Softkey Store State
    Die Statusdatei wird mit der Erweiterung .sta angelegt, mit dem Namen, den Sie über Drehknopf und Pfeile angeben

    Zum Abruf einer Datei:
    Softkey Recall State Tastenfeld und Drehknopf
    Verwenden Sie die Pfeil-nach-rechts-Taste, um einen Ordner einzublenden. Zur Auswahl einer Datei drücken Sie Select.

    So löschen Sie einen Zustand:
    Softkey Delete State Tastenfeld und Drehknopf
    Über Drehknopf und Pfeiltasten wählen Sie die .sta-Datei und drücken dann auf Select.
  • Sie können das Gerät konfigurieren, um den Status von Speicherort 0 beim Einschalten auszuschalten. Die Grundeinstellung ist, beim Einschalten die Werkseinstellung herzustellen.
  • Frontplatte:
    System-Taste Softkey Store - Recall Softkey Power On (FACTORY) Softkey Power On LAST
  • SCPI: MEMory:STATe:RECall:AUTO {ON|1|OFF|0}

Fehlerbedingungen

Es können in jedem schnittstellenspezifischen Error-Queue des Gerätes bis zu 20 Befehlssyntax- oder Hardware-Fehlermeldungen gespeichert werden (jeweils eine für GPIB, USB, VXI-11 und Telnet/Sockets.) Siehe hierzu SCPI-Fehlermeldungen für nähere Informationen.

  • Frontplatte:
    System-Taste Softkey Help Softkey Down arrow Softkey Select
  • SCPI: SYSTem:ERRor?

Signalton-Steuerung

Wenn am vorderen Bedienfeld oder über die Remoteschnittstelle ein Fehler generiert wird, ertönt normalerweise ein Signalton.

  • Die Einstellung ist permanent; sie bleibt bei einem Aus- und Wiedereinschalten des Geräts oder einem *RST erhalten.
  • Frontplatte:
    System-Taste Softkey System Setup Softkey User Settings Softkey Beeper
  • SCPI:
    SYSTem:BEEPer:STATe {ON|1|OFF|0}

    SYSTem:BEEPer
Bei der 33600 Series können Sie ebenso den Klick aktivieren oder deaktivieren, der ertönt, wenn eine Taste gedrückt wird. Details finden Sie unter SYSTem:CLICk:STATe.

Bildschirmschoner

Die Display-Hintergrundbeleuchtung wird normalerweise nach 8 Stunden Inaktivität ausgeschaltet und die Helligkeit des Bildschirms wird reduziert. Sie können den Bildschirmschoner nur über die Frontplatte deaktivieren.

  • Die Einstellung ist permanent; sie bleibt bei einem Aus- und Wiedereinschalten des Geräts oder einem *RST erhalten.
  • Frontplatte:
    System-Taste Softkey System Setup Softkey User Settings Softkey Display Options Softkey Scrn Svr (ON)

Display-Helligkeit

Sie können die Helligkeit des Displays (10% bis 100%) ausschließlich über das vordere Bedienfeld anpassen.

  • Die Einstellung ist permanent; sie bleibt bei einem Aus- und Wiedereinschalten des Geräts oder einem *RST erhalten.
  • Frontplatte:
    System-Taste Softkey System Setup Softkey User Settings Softkey Display Options Softkey Brightness

Datum und Uhrzeit

Sie können die Datum und Uhrzeit auf dem Gerät einstellen.

  • Frontplatte:
    System-Taste Softkey System Setup Softkey Date-Time
  • SCPI:
    SYSTem:DATE <yyyy>, <mm>, <dd>

    SYSTem:TIME <hh>, <mm>, <ss>

Dateien verwalten

Sie können Dateiverwaltungsaufgaben ausführen wie Kopieren, Umbenennen, Löschen und Erstellen von Ordnern.

  • Frontplatte:
    System-Taste Softkey System Setup Softkey Manage Files
    Bildschirm Dateiverwaltung
  • Sie können Dateien oder Ordner kopieren, umbenennen oder löschen. Beim Löschen eines Ordners werden alle Dateien in diesem Ordner gelöscht, prüfen Sie daher, ob Sie alle Dateien in dem Ordner löschen möchten.
  • Der wichtigste Softkey ist Action, über diese Taste können Sie den auszuführenden Vorgang bestimmen. Sobald Sie den auszuführenden Vorgang gewählt haben, drücken Sie Browse, um die zu verwaltende Datei auszuwählen. Wenn Sie alles vorbereitet haben, um die Aufgabe auszuführen, drücken Sie auf Perform.
  • SCPI: (siehe MEMory und MMEMory Subsysteme).

Selbsttest

  • Beim Einschalten des Geräts wird ein begrenzter Selbsttest durchgeführt, um sicherzustellen, dass das Gerät funktionsbereit ist. Sie können auch einen ausführlichen Selbsttest durchführen. Weitere Informationen finden Sie unter Selbsttest-Verfahren.

Display-Steuerung

Aus Sicherheitsgründen oder um die Geschwindigkeit zu erhöhen, mit der das Gerät Fernsteuerungsbefehle verarbeitet, können Sie das Display ausschalten. Sie können auf dem Display über die Fernsteuerung auch eine Meldung anzeigen oder eine Meldung löschen.

  • Beim Aus- und Wiedereinschalten des Gerätes, bei einem Reset (*RST) und beim Umschalten vom Fernsteuerungsbetrieb auf manuelle Bedienung wird das Display automatisch reaktiviert. Um das Gerät vom Fernsteuerungsbetrieb auf manuelle Bedienung umzuschalten, müssen Sie die Taste [Local] drücken oder den IEEE-488-Befehl GTL (Go To Local) senden.
  • Wenn Sie den Gerätezustand mit Hilfe des Befehls *SAV über *RCL abspeichern, wird auch der Display-Zustand mit abgespeichert.
  • Frontplatte:
    System-Taste Softkey System Setup Softkey User Settings Softkey Display Options Softkey Display Off/On (ON)
  • SCPI:
    DISPlay {ON|1|OFF|0}
    DISPlay:TEXT "<string>"

    DISPlay:TEXT:CLEar

Zahlenformat

Das Gerät kann auf der Frontplatte Zahlen mit Punkt und Komma für Dezimaltrennzeichen und Zifferntrennzeichen anzeigen. Standardanzeige ist ein Dezimaltrennzeichen mit Kommas als Zifferntrennzeichen (1.000,000,00 kHz).

  • Die Einstellung ist permanent; sie bleibt bei einem Aus- und Wiedereinschalten des Geräts oder einem *RST erhalten.
  • Frontplatte:
    System-Taste Softkey System Setup Softkey User Settings Softkey Number Format
  • SCPI: (No equivalent command)

Firmware-Versionsabfrage

Senden Sie *IDN? um festzulegen, welche Firmware-Version aktuell installiert ist. Die Abfrage sendet einen String in folgendem Format zurück:

Keysight Technologies,[Model Number],[10-char Serial Number],A.aa-B.bb-C.cc-DD-EE

  • Frontplatte: System-Taste Softkey Help Softkey About
  • SCPI: *IDN?

Abfrage der SCPI-Sprachversion

Das Gerät ist mit den Regeln und Konventionen der aktuellen Version von SCPI (Standard Commands for Programmable Instruments) konform. Über SYSTem:VERSion? stellen Sie fest, welcher SCPI-Version das Gerät entspricht. Die Abfrage sendet einen String in folgendem Format zurück: "YYYY.V", welches das Jahr und die Versionsnummer für das betreffende Jahr repräsentiert (zum Beispiel: 1999.0).

Lizenzinstallation

Die Trueform Series besitzt mehrere optionale Funktionen, für deren Installation Lizenzen erforderlich sind. Lizenzen installieren:

  1. Installieren Sie die Lizenzdatei auf einem USB-Laufwerk und schließen Sie das USB-Laufwerk über die Frontplatte des Instruments an.
  2. Drücken Sie auf [System] > System Setup > Install License.
  3. Verwenden Sie Drehknopf und Pfeile, um die Datei unter External auszuwählen, drücken Sie dann auf Enter.

Es gibt außerdem mehrere SCPI-Befehle im Zusammenhang mit der Lizenzinstallation.


Konfiguration der Remoteschnittstelle

Das Gerät unterstützt die Remoteschnittstellenkommunikation über drei Schnittstellen: GPIB (optional), USB und LAN. Alle drei werden beim Einschalten des Geräts aktiviert.

  • GPIB-Schnittstelle: GPIB-Adresse einstellen und mit einem GPIB-Kabel an Ihren PC anschließen.
  • USB-Schnittstelle: Keine Konfiguration; Gerät einfach mit einem USB-Kabel an den PC anschließen.
  • LAN-Schnittstelle: DHCP ist standardmäßig aktiviert; dadurch kann auch die LAN-Kommunikation bereits aktiviert sein. Das Akronym DHCP steht steht für Dynamic Host Configuration Protocol, ein Protokoll für die Zuordnung dynamischer IP-Adressen zu Netzwerkgeräten. Bei der dynamischen Adressierung kann ein Gerät bei jeder Verbindung mit dem Netzwerk über eine andere IP-Adresse verfügen.

Konnektivitäts-Software und Produkt-CD-ROMs

Dem Gerät sind zwei CD-ROMS beigelegt:

  • Keysight IO Libraries Suite CD: Enthält die Software Keysight IO Libraries Suite, die installiert werden muss, um den Fernsteuerungsbetrieb zu aktivieren. Die CD-ROM startet die Installation automatisch und enthält Informationen für die Software-Installation. Enthält auch den Keysight Technologies USB/LAN/GPIB Connectivity Guide, der zusätzliche Informationen enthält.
  • Keysight Trueform Series Product Reference CD: Enthält Gerätetreiber, Produktdokumentation und Programmierbeispiele. Startet automatisch und bietet Anweisungen.

GPIB-Konfiguration

Jedes Gerät an der GPIB-Schnittstelle (IEEE-488) muss eine eindeutige ganzzahlige Nummernadresse zwischen 0 und 30 besitzen. Das Gerät hat die Standardadresse 10, die GPIB-Adresse wird beim Einschalten angezeigt.

  • Die Einstellung ist permanent; sie bleibt bei einem Aus- und Wiedereinschalten des Geräts oder einem *RST erhalten.
  • Die Adresse der GPIB-Schnittstelle Ihres Computers darf mit keinem der Geräte am Schnittstellenbus in Konflikt geraten.
  • Frontplatte:
    Drücken Sie auf [System] > I/O Config > GPIB Settings, um die GPIB-Adresse einzustellen und den GPIB ein- oder auszuschalten.
  • SCPI:
    SYSTem:COMMunicate:GPIB:ADDRess <address>
    SYSTem:COMMunicate:ENABle <state>,GPIB
    SYSTem:COMMunicate:ENABle? GPIB

LAN-Konfiguration

In den folgenden Kapiteln werden die Hauptbedienfeldfunktionen der LAN-Konfiguration beschrieben, inklusive SCPI-Befehle, soweit anwendbar. Einige LAN-Konfigurationsfunktionen können nur über SCPI ausgeführt werden. Siehe Einführung in die LAN-Konfiguration für alle LAN-Konfigurationsbefehle und LAN-Konfigurationsverfahren bezüglich des Verfahrens zur LAN-Konfiguration über die Frontplatte.

Hinweis

Bei einigen LAN-Einstellungen muss das Gerät aus- und eingeschaltet werden, damit die Funktionen aktiviert werden. Das Gerät zeigt in diesem Fall eine Meldung an, daher müssen Sie den Bildschirm aufmerksam beobachten, wenn Sie LAN-Einstellungen ändern.

Zurücksetzen des LAN

Sie können das Passwort für Webschnittstelle jederzeit löschen, das DHCP einschalten und das LAN jederzeit neu starten:

  • Frontplatte:
    System-Taste Softkey I/O Config Softkey LAN Reset
    Die Meldung "Performing LAN Reset" wird angezeigt, während das LAN zurückgesetzt wird.
  • SCPI: (No equivalent command)

DHCP On/Off

Das DHCP (Dynamic Host Configuration Protocol) kann einem LAN-Gerät automatisch eine dynamische IP-Adresse zuweisen. Die einfachste Art, um ein Gerät für LAN zu konfigurieren.

  • Die Einstellung ist permanent; sie bleibt bei einem Aus- und Wiedereinschalten des Geräts oder einem *RST erhalten.
  • Frontplatte:
    System-Taste Softkey I/O Config Softkey LAN Settings Softkey Modify Settings

    Stellen Sie schließlich den ersten Softkey auf DHCP, um DHCP zur automatischen Zuweisung einer IP-Adresse zu verwenden.
  • SCPI: SYSTem:COMMunicate:LAN:DHCP {ON|1|OFF|0}

Um eine IP-Adresse, Subnetzmaske oder einen Standard-Gateway manuell einzustellen, schalten Sie DHCP aus, ändern Sie dann die IP-Einstellung wie unten beschrieben.

IP-Adresse

Sie können eine statische IP-Adresse für das Gerät als 4 Byte lange Ganzzahl eingeben. Jedes Byte wird als Dezimalwert ohne eine vorangestellte Null ausgedrückt (beispielsweise 169.254.2.20).

  • Ist das DHCP eingeschaltet, versucht es, dem Gerät eine IP-Adresse zuzuweisen. Schlägt dies fehl, versucht AutoIP, dem Gerät eine IP-Adresse zuzuweisen.
  • Wenden Sie sich an Ihren LAN-Administrator, um die IP-Adresse zu erhalten.
  • Die Einstellung ist permanent; sie bleibt bei einem Aus- und Wiedereinschalten des Geräts oder einem *RST erhalten.
  • Frontplatte:
    System-Taste Softkey I/O Config Softkey LAN Settings Softkey Modify Settings
  • Schließlich schalten Sie den ersten Softkey aus Manual und drücken auf IP Address, um eine neue IP-Adresse einzugeben. Geben Sie die gewünschte Adresse ein.
  • SCPI: SYSTem:COMMunicate:LAN:IPADdress "<address>"

Subnetzmaske

Durch die Unterteilung in Subnetze kann ein LAN-Administrator ein Netzwerk in kleinere Einheiten aufteilen, was die Verwaltung vereinfacht und den Netzwerkverkehr reduziert. Die Subnetzmaske gibt an, welcher Teil der Host-Adresse zur Kennzeichnung des Subnetzes dient.

  • Näheres erfahren Sie von Ihrem Netzwerkadministrator.
  • Die Einstellung ist permanent; sie bleibt bei einem Aus- und Wiedereinschalten des Geräts oder einem *RST erhalten.
  • Frontplatte:
    System-Taste Softkey I/O Config Softkey LAN Settings Softkey Modify Settings
  • Am Schluss schalten Sie den ersten Softkey um auf Manual und drücken auf Subnet Mask, um über die numerische Tastatur oder mit dem Drehknopf eine neue Subnetzmaske einzugeben (zum Beispiel: 255.255.0.0).
  • SCPI: SYSTem:COMMunicate:LAN:SMASk "<mask>"

Standard-Gateway

Ein Gateway ist ein Netzwerkgerät, das die Verbindungen zwischen verschiedenen Netzwerken herstellt. Die Standardeinstellung des Gateway ist die IP-Adresse des Geräts.

  • Falls DHCP oder Auto IP verwendet werden, muss keine Gateway-Adresse eingegeben werden.
  • Näheres über Gateways erfahren Sie von Ihrem LAN-Administrator.
  • Die Einstellung ist permanent; sie bleibt bei einem Aus- und Wiedereinschalten des Geräts oder einem *RST erhalten.
  • Frontplatte:
    System-Taste Softkey I/O Config Softkey LAN Settings Softkey Modify Settings

    Setzen Sie schließlich den ersten Softkey auf Manual und drücken Sie More und Gateway. Dann legen Sie mit der Zifferntastatur oder mit Drehknopf die entsprechende Gateway-Adresse fest.
  • SCPI: SYSTem:COMMunicate:LAN:GATeway "<address>"

Hostname

Beim Hostnamen handelt es sich um den Host-Anteil des Domain-Namens, der anschließend in eine IP-Adresse übersetzt wird.

  • Werkseitig wird dem Gerät ein eindeutiger Hostname zugeordnet, aber Sie können ihn ändern. Der Hostname muss auf dem LAN eindeutig sein.
  • Der Name muss mit einem Buchstaben beginnen; weitere Zeichen können Groß- und Kleinbuchstaben, numerische Ziffern oder Bindestriche („-“") sein.
  • Die Einstellung ist permanent; sie bleibt bei einem Aus- und Wiedereinschalten des Geräts oder einem *RST erhalten.
  • Frontplatte:
    System-Taste Softkey I/O Config Softkey LAN Settings Softkey Modify Settings

    Drücken Sie schließlich auf Host Name und geben Sie den Hostnamen mit den Pfeiltasten ein. Der Drehknopf verändert das Zeichen; die Pfeiltasten bewegen sich zwischen den Zeichen.
  • SCPI: SYSTem:COMMunicate:LAN:HOSTname "<name>"

Domain-Name

Der Domain-Name ist ein registrierter Name im Internet, der anschließend in eine IP-Adresse übersetzt wird. Sie können ihn nicht über die Frontplatte oder über SCPI einstellen.

DNS-Server

DNS (Domain Name Service) ist ein Internet-Dienst, der die Namen von Domains in IP-Adressen übersetzt. Die Adresse des DNS-Servers ist die IP-Adresse des Servers, der die Übersetzung durchführt.

  • Normalerweise erkennt DHCP die DNS-Adressinformation; Sie müssen dies nur ändern wenn DHCP nicht verwendet wird oder nicht funktionsbereit ist. Näheres erfahren Sie von Ihrem LAN-Administrator.
  • Die Einstellung ist permanent; sie bleibt bei einem Aus- und Wiedereinschalten des Geräts oder einem *RST erhalten.
  • Frontplatte:
    System-Taste Softkey I/O Config Softkey LAN Settings Softkey Modify Settings

    Stellen Sie schließlich den ersten Softkey auf Manual und drücken Sie More und Primary DNS oder Second DNS zur Eingabe einer DNS-Adresse mit den Pfeiltasten oder dem Drehknopf.
  • SCPI: SYSTem:COMMunicate:LAN:DNS[1|2] "<address>"

Aktuelle Konfiguration (LAN)

  • Wählen Sie die Ansicht Currently Active Settings, um die MAC-Adresse und die aktuelle Konfiguration des LAN anzuzeigen.
  • Frontplatte: System-Taste Softkey I/O Config Softkey LAN Settings
  • SCPI: (No equivalent command)

Das Display zeigt nur die aktuell aktiven Einstellungen der ersten Anzeige; es wird nicht aktualisiert durch Änderungen, die nach dem Aufrufen der Informationen vorgenommen wurden. Wenn beispielsweise DHCP eine neue IP-Adresse zuweist, während die Anzeige geöffnet ist, so wird die neue IP-Adresse nicht angezeigt.

Geht das Gerät in den Fernsteuerungsbetrieb über, werden alle LAN-Änderungen gelöscht und die Bildschirmanzeige verändert sich. Wird die Seite LAN-Einstellungen erneut aufgerufen, werden die neuen Einstellungen angezeigt, wenn ein LAN-Neustart stattgefunden hat.

Weitere LAN-Konfigurationsbefehle siehe Einführung in das Subsystem SYSTem.

Webschnittstelle

Das Gerät umfasst eine integrierte Web-Schnittstelle. Sie können diese Schnittstelle über ein LAN für den Remote-Zugang zum Gerät verwenden und über einen Java™-fähigen Webbrowser wie Microsoft Internet Explorer steuern.

Bild einer Webschnittstelle

Verwendung der Webschnittstelle:

  1. Erstellen Sie eine LAN-Verbindung von Ihrem PC zum Gerät.
  2. Öffnen Sie den Internet-Browser des PCs.
  3. Starten Sie die Webschnittstelle des Geräts durch Eingabe der IP-Adresse des Geräts oder des gültigen Hostnamens im Adressfeld des Browsers.
  4. Folgen Sie den Anweisungen der Online-Hilfe für die Web-Schnittstelle.

USB-Konfiguration

Frontplatte:
System-Taste Softkey I/O Config Softkey USB Settings

Bei der 33500 Series, gibt es keine benutzerkonfigurierbaren USB -Parameter. Sie können den (vom Hersteller festgelegten) USB-ID-String nur über den Softkey Show USB Id erhalten.

Dateizugriff (nur 33600 Series)

File Access verwendet das Media Transfer Protocol (MTP) für den einfachen Download von Gerätedateien auf Ihren PC. Schließen Sie einfach den rückseitigen USB-Anschluss des Geräts an einen USB-Anschluss Ihres PCs an. Der DMM wird im Dateisystem Ihres PCs als Laufwerk mit Schreibschutz angezeigt. Beachten Sie, dass der interne Speicher des Geräts eine vordefinierte Verzeichnisstruktur enthält, wie unten gezeigt.

Sie können mit den Standardfunktionen zur Dateiverwaltung Dateien vom DMM auf Ihren PC kopieren.

Um File Access gleichzeitig zur Remoteprogrammierung des Geräts mit SCPI über die USB-Schnittstelle (USB SCPI) zu nutzen, müssen Sie Keysight IO Libraries Suite 16.3 oder eine neuere Version auf Ihrem PC installiert haben. Sie können die neueste Version unter www.keysight.com/find/iosuite herunterladen.

Stellen Sie zur Verwendung von File Access auf einem PC mit dem Betriebssystem Windows XP sicher, dass Microsoft Windows Media Player 11 für Windows XP oder eine neuere Version installiert ist, bevor Sie das USB-Kabel anschließen. Sie können diese Software unter www.microsoft.com/en-us/download/details.aspx?id=8163 herunterladen.


Externe Zeitbasisreferenz

Beim BNC-Anschluss des externern 10 MHz-Referenzeingangs sind sowohl Buchse als auch mittlerer Stecker am hinteren Bedienfeld des Geräts bis zu ±42 Vpk vom Gehäuse isoliert. Die Buchse dieses BNC-Anschlusses ist vom Rest des Geräts isoliert. Der interne Schaltkreis hält die isolierte Spannung auf ±42 Vpk gegen Gehäuse. Ein Verbinden dieses Eingangs mit über ±42 Vpk vom Gehäuse kann zur Beschädigung des Geräts sowie zu Personenschäden, u. U. mit Todesfolge, führen.

Die externe Zeitbasisreferenz der rückseitigen Steckverbinder (10 MHz In und 10 MHz Out) und der Schaltkreis ermöglichen es Ihnen, mehrere Funktionsgeneratoren des Geräts miteinander oder mit einem externen 10 MHz Taktsignal zu synchronisieren. Dabei können Sie den Phasen-Offset des Ausgangssignals sowohl über die Frontplatte als auch über die Remoteschnittstelle steuern.

Um die Phase von zwei Geräten auszurichten, können Sie ein Zwei-Kanal-Oszilloskop zum Vergleich der Ausgangssignale verwenden:

  1. Beide Geräte anschließen, 10 MHz Out mit 10 MHz In verbinden. Verwenden Sie das Gerät mit der präzisieren Zeitbasis als die 10 MHz Referenz-Signalquelle.

    Geräte angeschlossen, um die Zeitbasis zu sperren
  2. Geräteausgänge an die Kanaleingänge des Oszilloskops anschließen:

    Geräte an das Oszilloskop anschließen
  3. Stellen Sie bei beiden Geräten die gleiche Frequenz ein. Das Oszilloskop sollte nun synchrone Signale bezüglich der Frequenz, jedoch nicht Phase anzeigen. (Eine Rechteckwelle eignet sich gut für das Anzeigen der Phasendifferenz.)
  4. Bei Zweikanalgeräten, Phase Sync beider Kanäle aufeinander abstimmen. Dadurch werden auch jeweils die Modulationssignale der Kanäle mit dem Träger synchronisiert.

    Frontplatte:

    Taste Channel Taste Parameters Softkey Phase Softkey Sync Internal

    SCPI: [SOURce[1|2]:]PHASe:SYNChronize
  5. Stellen Sie die Phase des ersten Geräts auf den Standard (Null) ein, und verwenden Sie die Funktion Adjust Phase, um die Phase des zweiten Geräts anzupassen und die Ausgangssignale auszurichten:
Nicht ausgerichtetes Bild | Ausgerichtetes Bild
Außerhalb der Phase | Ausgerichtet

Verwenden Sie die Funktion Set 0 Phase, um einen neuen Null-Phasen-Referenzpunkt mit den beiden nun ausgerichteten Funktionsgeneratoren einzurichten.

  • Frontplatte:
    Taste Channel Taste Parameters Softkey Phase

    Dann mit Hilfe der Tastatur oder des Drehknopfs den Phasenwinkel einstellen. Sobald sie ausgerichtet wurden, drücken Sie auf Set 0 Phase.
  • SCPI:
    [SOURce[1|2]:]PHASe {<angle>|MINimum|MAXimum|DEFault}

    [SOURce[1|2]:]PHASe:REFerence


Integrierter Signaleditor

Das Gerät enthält einen integrierten Signaleditor für die Erstellung und Bearbeitung von Einkanal-Arbiträrsignalen in ASCII-Arbiträrsignalen (Endung .ARB). Sie können die Spannungs- und Stromstärkenwerte direkt oder durch die Kombination von bis zu 12 verschiedenen Arten von Standardsignalen eingeben und bearbeiten, wie in den folgenden Abschnitten beschrieben wird:

Standardsignale

Basiswellenformbearbeitung

Erweiterte Bearbeitung

Erweiterte mathematische Funktionen

Menü Dienstprogramm

Die maximale Signalgröße für den integrierten Signaleditor beträgt unabhängig von den installierten Optionen 1 MSa.

Standardsignale

Der integrierte Signaleditor umfasst die folgenden 12 Signalformen:

Sinus | Sinuswelle | y = sin(x)
Rechteck | Rechteckwelle | Eine Rechteckwelle, die zwischen zwei Spannungspegeln wechselt
Sägezahn | Sägezahnsignal | Ein Signal mit linear ansteigender oder abfallender Spannung
Linie | Liniensegment | Liniensegment
Gleichstrom | DC-Spannung | A DC-Spannung
Rauschen | Weißes Rauschen | Weißes Rauschen
Gaußsch | Gaußsche Welle | Gaußsche Verteilungskurve (normale Verteilung)
Sinc | Sinc-Welle | y = sin(x)/x
D-Lorentz | D-Lorentz-Welle | Eine Ableitung der Lorentz-Funktion. Die Lorentz-Funktion ist y = 1/(x²+1), daher ist die D-Lorentz-Funktion y = -2x/(x²+1)².
Exponentieller Abfall | Exponentieller Abfall | Exponentieller Zerfall: y = e-kx
Exponentieller Anstieg | Exponentieller Anstieg | Exponentieller Anstieg: y = 1 – e-kx
Haversine | Haversine-Signal | y = [1 – cos(x)]/2

Wenn Sie eine Signalform wählen, zeigt das Gerät einen Bildschirm an, über den Sie die Signalparameter bestimmen können, wie nachstehend beschrieben.

Amplitude | Die Spitzenhöhe über 0 V, wenn der Versatz des Signals 0 beträgt, von 10 μV bis 10 V (Standard 1).
Offset | Die Distanz, um die das Signal im Verhältnis zu 0 V nach oben oder nach unten verschoben wird, von -10 bis 10 V (Standard 0).
Amplitude plus Versatz muss zwischen -10 V und 10 V liegen.
Phase | Die Gradzahl, um die das Signal von 0 Grad heraufgesetzt (positiver Wert) oder herabgesetzt (negativer Wert) wird, von -360 bis 360 (Standard 0).
Zyklen | Die Anzahl der vollständigen Ausgangszyklen (eine positive Ganzzahl), die das Signal einbezieht.
Punkte | Die Anzahl der Punkte, welche die Signalform umfasst, bis zu 1.000.000 (Standard 100). Die minimale Anzahl an Punkten bei der 33500 Series beträgt 8 und bei der 33600 Series beträgt sie 32.
Halbe Breite (nur D-Lorentz) | Ein Wert, der die Signalbreite bestimmt; größere Werte erzeugen breitere Kurven. Angegeben als Ganzzahl von 1 bis zur Gesamtzahl der Punkte in einem Zyklus (Standard 10).
Fallfaktor (nur Exponentieller Abfall) | Eine Dezimalzahl von -99 bis 99, die bestimmt, wie schnell das Signal abfällt oder ansteigt (Standard -5).
Anstiegsfaktor (nur Exponentieller Anstieg)
Volle Breite (nur Gaußsches Signal) | Die Breite der Verteilungskurve zwischen den Punkten auf der Kurve, die exakt eine Hälfte der Kurvenhöhe ausmachen, von 1 bis zur Anzahl der Punkte in einem Zyklus (Standard 10).
Symmetrie (nur Sägezahn) | Prozentsatz der Zeit (pro Zyklusperiode), bei der der Sägezahn ansteigt, eine Dezimalzahl von 0 bis 100 (Standard 100).
Nulldurchgang (nur Sinc) | Die Anzahl der X-Achsendurchgänge des Signals pro Signalseite, von 0 bis 100 (Standard 10).
Tastgrad (nur Rechteck) | Prozentsatz der Zeit (pro Zyklusperiode), bei der die Signalspannung ansteigt, von 0 bis 100 (Standard 50).
Startpegel (nur Linie) | Die Spannung zu Beginn oder Ende des Liniensegments.
Endpegel (nur Linie)

Basiswellenformbearbeitung

Wenn Sie den integrierten Signaleditor starten ([Waveforms] > Arb > Arbs > Edit Arb File > New Arb File), wird der Eröffnungsbildschirm angezeigt. (Beachten Sie, dass dasselbe Menü, das den Softkey Edit Arb File enthält, auch den Softkey Import Data enthält. Sie können ihn verwenden, um ASCII-Dateien von Oszilloskopen und anderen gemeinsamen Geräten zu importieren.)

Über Edit Points können Sie die Spannungswerte einzelner Punkte in der Wellenform bearbeiten. Sie können auch Punkte in die Wellenform einfügen oder daraus entfernen und auf die Advanced Edit-Funktionen zugreifen, die unten beschrieben werden. Der aktuelle Bildschirm zeigt die standardmäßige neue Wellenform mit 8 Punkten bei 0 VDC.

Die Standardgröße des Arbiträrsignals beträgt bei der 33500 Series 8 Punkte und bei der 33600 Series 32 Punkte.

WFE Punkte bearbeiten

Mit Edit Params können Sie die Abtastrate des Signals einstellen, also die Geschwindigkeit (in Punkten pro Sekunde) mit der das Signal abgespielt wird. Sie können diesen Wert als Geschwindigkeit oder als Periode angeben. Wenn Sie einen Wert verändern, wird der andere basierend auf der Anzahl der Punkte im Signal neu berechnet. Über diese Funktion können Sie außerdem bestimmen, ob die Wellenform entlang der horizontalen Achse mit Zeiteinheiten oder mit Punkten beschriftet wird.

Mit Insert Built-In können Sie eine der 12 vordefinierten Wellenformen in die aktuelle Wellenform einfügen.

WFE Insert Built-in

Mit Select Point # könnn Sie angeben, wo das Signal engefügt werden soll, über den Softkey Choose Wave können Sie festlegen, welche der 12 Signalarten eingeführt werden soll.

Wenn Sie über die Pfeiltasten das einzufügende Signal ausgewählt und auf OK gedrückt haben, zeigt das Gerät die Parameter für das einzufügende Signal an. Notieren Sie die Softkey Pfeile nach oben und nach unten, die Sie verwenden, um ein Parameter bei der Bearbeitung auszuwählen. Bestimmen Sie die Parameter und drücken Sie auf OK.

WFE Parameter eingeben

Save ermöglicht das Speichern des aktuellen Signals an seinem aktuellen Ort im internen Speicher des Geräts.

Exit Editor schließt den Signaleditor und nimmt den normalen Betrieb wieder auf.

WFE Editor schließen

Wenn noch nicht gespeicherte Änderungen vorliegen, bietet eine Meldung die Möglichkeit an, im integrierten Signaleditor zu bleiben. Wenn Sie den Editor schließen, haben Sie die Option, das Signal auf dem Wellenformgenerator abzuspielen.

WFE Warnmeldung Schließen ohne Speichern

Erweiterte Bearbeitung

Wie oben beschrieben enthält das Menü Edit Points den Softkey Advanced Edit. Über diesen Softkey können Sie Teile der Wellenform ausschneiden, kopieren und einfügen, Wellenformpunkte in einer Tabelle bearbeiten und mathematische Operationen an einer Wellenform ausführen.

WFE Erweiterte Bearbeitung

Cut/Copy/Paste ermöglicht es Ihnen, einen Abschnitt des Signals zwischen zwei Markern zu definieren und dann die von diesen Markern definierten Signalpunkte auszuschneiden oder zu kopieren. Wenn Sie den Abschnitt ausgeschnitten oder kopiert haben, können Sie ihn über den Softkey Paste beliebig oft einfügen.

WFE Auswahl bearbeiten

Paste Location ermöglicht es, einen Abschnitt am Anfang der Wellenform, am Ende der Wellenform oder an einem beliebigen Punkt innerhalb der Wellenform einzufügen.

WFE Menü Paste Location

Über Edit Via Table können Sie die Spannungswerte einzelner Punkte in einer Tabelle bearbeiten. Sie können den Drehknopf verwenden, um die Tabelle zu durchsuchen oder den Softkey Point #, um einen bestimmten Punkt direkt auszuwählen. Sie können auch Wellenformpunkte einfügen oder daraus entfernen.

WFE Bearbeiten über Tabelle

Perform Math ermöglicht die Verwendung von Markern, um einen Abschnitt der Wellenform festzulegen. Dann können Sie die Spannungswerte in diesem Abschnitt zu dem Spannungswert eines anderen Signals hinzufügen, von diesem abziehen oder mit diesem multiplizieren,.

WFE Mathematische Operationen durchführen

Wenn Sie auf Add, Subtract oder Multiply gedrückt haben, zeigt das Gerät eine Liste von Wellenformen an. Wählen Sie das Signal aus und drücken Sie auf OK.

Hilfe Mathematische Wellenform hinzufügen

Wenn Sie OK drücken, zeigt das Gerät eine Liste von Parametern an, die Sie verwenden können, um die Wellenform zu bestimmen. In diesem Fall zeigt der unten abgebildete Bildschirm an, dass Sie D-Lorentz gewählt haben. Sie können auch die Parameter From Point und To Point verwenden, um eine Reihe von Punkten zu bestimmen, an denen die mathematische Operation auszuführen ist.

WFE Mathematische Wellenformparameter ausführen

Erweiterte mathematische Funktionen

Advanced Math ermöglicht die Ausführung verschiedener mathematischer Operationen an der Wellenform. Um zu beginnen, dürcken Sie Edit Points > Advanced Edit > Perform Math > Advanced Math.

WFE Mathematische Operationen durchführen

Das Menü Advanced Math wird mit folgendem Bildschirm geöffnet. Jede der unten gezeigten Operationen wird weiter unten beschrieben, dabei werden Abbildungen verwendet, die vor und nach jeder Operation festgehalten wurden, um die Auswirkungen der jeweiligen Operation zu demonstrieren.

WFE Hauptbildschirm Erweiterte mathematische Funktionen

Invert gibt die Wellenform über die horizontale Achse wieder.

Abbildung Vor Invert

WFE Vor Jeder Operation

Abbildung nach Invert

WFE nach Invert

Absolute multipliziert alle negativen Signalwerte mit -1.

Abbildung Vor Absolute
WFE Vor Jeder Operation

Abbildung Nach Absolute
WFE nach Absolute

Mirror kehrt die Reihenfolge der Punkte im Abschnitt um.

Abbildung Vor Mirror
WFE Vor Jeder Operation

Abbildung nach Mirror
WFE nach Mirror

Scale ermöglicht die Skalierung von Amplitude und Offset der Wellenform. Hier wurde die Amplitudenskala auf 180 % eingestellt und die Offset-Skala auf 1 V.

Abbildung Vor Scale
WFE Vor Jeder Operation

Abbildung nach Scale

WFE nach Scale

Clip ermöglicht die Veränderung der Spannungswerte außerhalb der oberen und unteren Grenzwerte, um sie den Grenzwerten anzugleichen. In diesem Beispiel wurde das Signal an den unteren Grenzwert von -400 mV und den oberen Grenzwert von 700 mV gekoppelt.

Abbildung vor Clip
WFE Vor Jeder Operation

Abbildung nach Clip

WFE nach Clip

Trim ermöglicht die Verwendung von Markern, um das Signal zuzuschneiden, so dass nur die vom Marker definierten Punkte in der Wellenform bleiben.

Abbildung vor Trim
WFE Vor Jeder Operation

Abbildung nach Trim

WFE nach Trim

Menü Dienstprogramm

Sie können auf mehrere Dienstfunktionen zugreifen, wenn sie vom integrierten Signaleditor aus auf die Taste [System] drücken.

Undo ermöglicht es, die letzten Operationen rückgängig zu machen, je nach der Größe des vorhandenen Speicherplatzes und der Größe der rückgängig zu machenden Operation. Redo ermöglicht es, rückgängig gemachte Aufgaben wieder herzustellen, je nach der Größe des vorhandenen Speicherplatzes und der Größe der rückgängig zu machenden Operation.

Pan/Zoom Control ermöglicht es, horizontal oder vertikal zu panoramieren oder zu zoomen. Sie zoomen mit einem prozentualen Zoomfaktor und panoramieren, indem Sie einen Punkt oder eine Spannung angeben.

Show All setzt die Skalierung zurück, um die gesamte Wellenform anzuzeigen.


Tutorial Erzeugung von Wellenformen

In diesem Abschnitt wird die Theorie der Betriebsinformation für mehrere Wellenformarten und Betriebsarten des Geräts beschrieben. Die letzten beiden Themen enthalten Informationen, die Ihnen helfen können, die Signalqualität zu verbessern.

  • Arbiträrsignale
  • Quasi-Gauß'sches Rauschen
  • PRBS
  • Modulation
  • Burst
  • Frequenzwobbelung
  • Eigenschaften von AC-Signalen
  • Signalfehler
  • Erdschleifen

Arbiträrsignale

Arbiträrsignale können Anforderungen erfüllen, die von den Standardsignalen des Gerätes nicht erfüllt werden. Sie benötigen vielleicht einen einmaligen Stimulus oder möchten Signalfehler wie z.B. Überschwingen, Nachschwingen, Störimpulse oder Rauschen simulieren. Arbiträrsignale können sehr komplex sein, weshalb sie sich gut für die Simulation von Signalen in modernen Kommunikationssystemen eignen.

Sie können Arbiträrsignale mit einer Mindestanzahl von 8 Punkten (33500 Series) bzw. 32 Punkten (33600 Series) und mit bis zu 1.000.000 Punkten erstellen. Das Gerät speichert diese numerischen Datenpunkte (die sogenannten Abtastproben) im Speicher und wandelt sie in Spannungen um, wenn die Wellenform generiert wird. Die Frequenz, mit der diese Punkte gelesen werden, ist die „Abtastrate“. Die Signalfrequenz entspricht der Abtastrate geteilt durch die Anzahl der Punkte in der Wellenform. Beispiel: Angenommen, eine Wellenform hat 40 Punkte und die Abtastrate beträgt 10 MHz. Die Frequenz wäre (10 MHz)/40 = 250 kHz und die entsprechende Periode 4 µs.

Duale Arbiträrsignale

Arbiträrsignale können Einkanal-Wellenformen oder (mit der Option IQP) Zweikanal-Arbiträrsignale sein (z. B. IQ Baseband-Signale). Ein duales Arbiträrsignal entspricht einer Stereo-Musikdatei. Es verfügt über zwei Informationskanäle, die die gleiche Anzahl von Samples enthalten, jeweils zusammen beginnen und enden und stets bei der gleichen Abtastrate abgespielt werden.

Sie können Zeitversatz und Abgleich zwischen zwei Kanälen bei dualen Arbiträrsignalen entweder über die Befehle im Subsystem SCPI FUNCtion oder über die Frontplatte steuern.

Signalfilter

Das Gerät enthält zwei Filter, um die Übergänge zwischen den Punkten auszugleichen, wenn Arbiträrsignale erzeugt werden.

  • Normaler Filter: Ein breiter, flacher Frequenzgang, aber seine Sprungantwort zeigt Überschwingen und Nachschwingen.
  • Schritt-Filter: Eine nahezu ideale Sprungantwort, jedoch mit mehr Welligkeit in seinem Frequenzgang als beim normalen Filter.
  • Off: Der Ausgang verändert sich abrupt zwischen den Punkten, mit einer Übergangszeit von annähernd 10 ns.

Jede Abschaltfrequenz des Filters entspricht einem festen Anteil der Samplingrate der Wellenform. Die Ansprechzeit des Normalfilters liegt bei -3 dB bei 27 % der Samplingrate, die Ansprechzeit des Stufenfilters -3 dB bei 13 % der Samplingrate. Zum Beispiel bei einem Arbiträrsignal mit 100 MSa/s beträgt die Frequenzbandbreite -3 dB des Normalfilters 27 MHz.

Ein Abschalten des Filters kann die Abtastrate reduzieren, wenn diese vor dem Abschalten des Filters größer war als 250 MSa/s.

Anwendungen der Signalsequenzierung

Arbiträrsignalsequenzen sind nützlich, wenn für das Signal, das Sie generieren möchten, zwei Situationen zutreffen:

  • Das Signal ist sehr lang und enthält Wiederholungen kürzerer Fragmente. Diese Fragmente können beliebig oft und in beliebiger Reihenfolge wiederholt werden.
  • Sie benötigen eine Echtzeitkontrolle (Trigger) für den Wechsel von einem Signalfragment zum anderen.

Beispiel für den ersten Fall: Ein Signal, das mehrmals das gleiche einleitende Signal abspielen muss, dann drei andere Signals jeweils einmal wiedergibt und dann wieder dazu übergeht, das erste Signal kontinuierlich abzuspielen. Hierbei kann es sich um ein simuliertes Modem-Datenpaket handeln, das aus einem "inaktiven" Signal, einem Titel, Daten, einer Prüfsumme und einer Rückkehr zum "inaktiven" Signal besteht.

Es könnte folgender Sequenzbeschreibung entsprechen:

  1. "idle.arb" 10 Mal abspielen
  2. "header.arb" einmal wiedergeben
  3. "data.arb" einmal wiedergeben
  4. "checksum.arb" einmal wiedergeben
  5. "idle.arb," unendlich oft wiederholt wiedergeben.

Im zweiten Fall möchten Sie evtl. das Senden von "header.arb" mit einem externen Hardware-Trigger initiieren. Für diesen Fall könnte folgende Beschreibung gelten:

  1. "idle.arb" wiederholt wiedergeben, bis ein Trigger eingeht
  2. "header.arb" einmal wiedergeben
  3. "data.arb" einmal wiedergeben
  4. "checksum.arb" einmal wiedergeben
  5. "idle.arb," unendlich oft wiederholt wiedergeben.

Eine Sequenzdatei (*.seq) enthält die Informationen der nummerierten Listen, die Arbiträrsignaldateien (*.arb) die einzelnen Signale.

Implementierung der Signalsequenzierung

Das Gerät kann lange, komplexe Sequenzen von Arbiträrsignalen (Segmente) zusammenfügen. Der Übergang zwischen Segmenten findet nahtlos in Echtzeit statt. Als Analogie stellen Sie sich die Segmente als Musikstücke in einem Musikplayer vor und die Sequenzen als Playlist.

Jeder Sequenzschritt bestimmt ein Segment und wie oft es abgespielt wird. Er bestimmt auch, ob die Sequenz auf einen Auslöser für den nächsten Schritt wartet und wie das Sync-Signal schrittweise erzeugt wird.

Für jedes Segment gibt es folgende Möglichkeiten:

  • Segment von 1 bis 1.000.000 Mal abspielen und dann zum nächsten Schritt übergehen.
  • Segment einmal abspielen und dann stoppen und auf einen Auslöser warten, um weiterzuschalten.
  • Segment wiederholen, bis ein Auslöser stattfindet und dann weiterschalten.
  • Segment wiederholen, bis explizit angehalten wird.

Optionen für die Sync-Signalerzeugung:

  • Sync zu Beginn des Segments aktivieren.
  • Sync zu Beginn des Segments aufheben.
  • Aktuellen Sync-Status im ganzen Segment beibehalten.
  • Sync zu Beginn des Segment aktivieren und an einem bestimmten Punkt innerhalb des Segments aufheben.

Um eine Sequenz für einen Trigger zu starten, stellen Sie ein kurzes DC-Signal mit 0 V (oder einem beliebigen anderen Wert) vor die anderen Signale der Sequenz und stellen Sie das Segment so ein, dass es auf einen Trigger wartet, bevor es fortfährt. Bei 33500 Series Geräten beträgt die Mindestsegmentlänge 8 Sa, bei 33600 Series Geräten 32 Sa.

Wenn ein Segment so eingestellt ist, dass es sich wiederholt, bis ein Trigger eingeht, endet das Segment stets, bevor der Übergang zum nächsten Segment erfolgt. Zusätzlich kann sich ein kurzes Segment für Zusatzzyklen wiederholen, um den Abtastpuffer der Sequenz zu löschen, bevor fortgefahren wird.

Quasi-Gauß'sches Rauschen

Die Signalform „Noise“ ist sowohl für quantitative als auch qualitative statistische Eigenschaften optimiert. Sie wiederholt sich nicht länger als 50 Jahre kontinuierlichen Betriebs. Anders als bei einer echten Gaußschen Verteilung ist die Wahrscheinlichkeit Null, dass der Spannungswert die Vpp-Einstellung des Geräts überschreitet. Der Scheitelfaktor (Spitzenspannung dividiert durch RMS-Spannung) beträgt annähernd 4,6.

Sie können die Bandbreite des Rauschens von 1 mHz bis zur maximalen Bandbreite des Geräts variieren. Die Energie des Rauschsignals wird in einem Band von DC bis zur gewählten Bandbreite konzentriert. Dadurch erhält das Signal eine größere Spektraldichte in dem entsprechenden Band, wenn die Einstellung der Bandbreite niedriger ist. Bei der Audio-Arbeit zum Beispiel können Sie die Bandbreite auf 30 kHz einstellen, um die Stärke des Audio-Bandsignals 30 dB höher einzustellen als mit einer Einstellung der Bandbreite auf 30 MHz.

PRBS

Eine pseudozufälligen Binärfolge (Pseudo-Random Bit Sequence - PRBS) besitzt zwei Level (hoch und niedrig) und wechselt zwischen beiden auf eine Weise, die schwierig vorauszusagen ist, wenn der Algorithmus der Frequenzerzeugung nicht bekannt ist. Ein PRBS wird durch ein linear rückgekoppeltes Schieberegister (Linear-feedback shift register - LFSR) erzeugt (siehe unten).

Ein LFSR wird über die Anzahl der Stadien definiert, die es enthält und darüber, welche Stadien („Taps“) die Exklusiv-ODER (XOR) Tore in seinem Feedback-Netzwerk speisen. Der PRBS-Ausgang wird vom letzten Stadium geliefert. Mit korrekt ausgewählten Stadien produziert ein L-Stadium-LFSR eine repetitive PRBS mit einer Länge von 2L-1. Die Taktfrequenz des LFSR bestimmt die „Bitrate“ der PRBS.

33500 Series Geräte ermöglichen die Einstellung von L auf 7, 9, 11, 15, 20 oder 23, was Sequenzen mit einer Länge von 127 bis 8.388.607 Bits ergibt.

Bei 33600 Series Modellen können Sie L auf jede Ganzzahl von 3 bis 32 einstellen, was zu Sequenzen mit einer Länge von 7 bis 4.294.967.295 Bits führt.

Der Standardwert für L beträgt 7, was zu einer Sequenz mit einer Länge von 127 Bits führt.

Modulation

Amplitudenmodulation (AM)

Das Gerät implementiert zwei AM-Formen:

  • Double-sideband full-carrier (DSB-FC), das die ITU-Bezeichnung A3E hat und im AM-Funk verwendet wird.

    Die Gleichung für DSB-FC ist

    y(t)= [(½)+(½)•d•m(t)]•Ac•sin(ωc t)

    wobei

    m(t) dem Modulationssignal entspricht
    Ac der Trägeramplitude entspricht
    ωc der Trägerfrequenz des Trägers entspricht
    d dem "Modulationsgrad" entspricht, oder ein Bruchteil des Amplitudenbereichs von der Modulation verwendet wird

    Zum Beispiel schwankt bei einem Modulationsgrad von 80 % die Amplitude zwischen 10 % und 90 % der Amplitudeneinstellung (90% - 10% = 80%), mit einem internen oder einem vollausgesteuerten (±5 V oder ±1 V bei 33600 Series) externen Modulationssignal. Sie können den Modulationsgrad bis auf 120 % einstellen, solange Sie die maximale Ausgangsspannung des Geräts nicht überschreiten (±5 V für eine Last von 50 Ω, ±10 V für eine hochohmige Last).

    Die obere Messkurve (siehe unten) stellt das Modulationssignal dar und die untere Messkurve den modulierten Träger.

  • Zweiseitenband-Amplitudenmodulation mit unterdrücktem Träger (Double-sideband Suppressed carrier - DSSC). Viele moderne Kommunikationssysteme verwenden DSSC auf jedem von zwei Trägern, die die selbe Frequenz haben, aber einen Phasenunterschied von 90 Grad. Dies nennt man Quadraturamplitudenmodulation (QAM).

    Die Gleichung für DSSC ist y(t)=d•m(t)•sin(ωc t)

    Bei DSB-SC wird das Trägersignal immer dann invertiert, wenn m(t) < 0. Bei der QAM wäre das zweite Trägersignal cos(ωc t), wodurch es vom ersten Träger um 90 Grad phasenverschoben wird.

Frequenzmodulation (FM)

Die Frequenzmodulation wandelt die Frequenz eines Trägersignals entsprechend dem modulierenden Signal ab:

y(t)=Ac•sin[(ωc+d•m(t) )•t]

wobei m(t) das modulierende Signal und d die Frequenzabweichung ist. FM wird als Schmalband bezeichnet, wenn die Abweichung weniger als 1 % der Bandbreite des modulierenden Signals entspricht, sonst wird sie als Breitband bezeichnet. Sie können die Bandbreite des modulierten Signals mit den folgenden Gleichungen annähern.

BW ≈ 2•(Modulierende Signalbandbreite) für Schmalband-FM

BW ≈ 2•(Abweichung+Modulierende Signalbandbreite) für Breitband-FM

Die obere Messkurve (siehe unten) stellt das Modulationssignal dar und die untere Messkurve den modulierten Träger.

Phasenmodulation (PM)

PM entspricht FM, jedoch variiert die Phase des Trägersignals eher als die Frequenz:

y(t)=sin[ωc t+d•m(t) ]

wobei m(t) das modulierende Signal ist und d die Phasenabweichung.

FSK-Modulation (Frequenzumtastung)

FSK entspricht FM, abgesehen davon, dass die Trägerfrequenz zwischen zwei voreingestellten Werten wechselt, der Trägerfrequenz und der Hop-Frequenz. Manchmal werden die Hop- und Trägerfrequenzen auch als „Mark“- und „Space“-Frequenz bezeichnet. Die Geschwindigkeit, mit der der Wechsel zwischen diesen Werten erfolgt, wird von einem internen Timer oder dem Signal am rückseitigen Anschluss Ext Trig bestimmt. Frequenzänderungen sind unverzögert und phasenkontinuierlich.

Bei dem internen Modulationssignal handelt es sich um ein Rechtecksignal mit einem Tastverhältnis von 50 %.

Die obere Messkurve (siehe unten) stellt das Modulationssignal dar und die untere Messkurve den modulierten Träger.

Binäre Phasenmodulation (BPSK-Modulation)

BPSK entspricht FSK, abgesehen davon, dass es eher die Phase des Trägers als seine Frequenz ist, die zwischen zwei Werten abwechselt. Die Geschwindigkeit, mit der der Wechsel zwischen diesen Werten erfolgt, wird von einem internen Timer oder dem Signal am rückseitigen Anschluss Ext Trig bestimmt. Phasenwechsel sind unverzögert.

Bei dem internen Modulationssignal handelt es sich um ein Rechtecksignal mit einem Tastverhältnis von 50 %.

Pulsbreitenmodulation (PWM)

PWM steht nur für das Pulssignal zur Verfügung und die Pulsbreite ist vom Mosulationssignal abhängig. Der Wert der Pulsbreitenschwankung wird als Pulsbreitenabweichung bezeichnet und kann als Prozentsatz der Signalperiode (d. h. des Tastverhältnisses) oder in Zeiteinheiten angegeben werden. Wenn Sie z. B. einen Puls mit einem Tastverhältnis von 20 % angeben und dann PWM mit einer Abweichung von 5% aktivieren, schwankt das Tastverhältnis von 15% bis 25%, je nach Modulationssignal.

Additive Modulation (Summe)

Die Funktion „Summe“ fügt das modulierende Signal zum Träger hinzu. Zum Beispiel können Sie eine bestimmte Menge variablen Breitbandrauschens zu einem Signal addieren oder Zweiton-Signale erzeugen. Der interne Modulationsgenerator des Geräts kann die selbe kontinuierliche Wellenform erzeugen wie der Hauptgenerator, daher ermöglicht es die Summen-Funktion, viele Signale zu erzeugen, wofür zuvor zwei Geräte erforderlich waren.

Die Summen-Funktion vergrößert die Amplitude des Ausgangssignals um die Amplitude des modulierenden Signals. Dies könnte bewirken, dass das Gerät in einen höheren Ausgangsspannungsbereich umschaltet, was zu einem momentanen Signalverlust führen kann. Falls dies in Ihrer Anwendung ein Problem darstellt, schalten sie die Funktion Range Hold ein. Falls der Spannungsanstieg Ihr zu testendes Gerät beschädigen könnte, wenden Sie Spannungsbegrenzungen an.

Burst

Sie können das Gerät so konfigurieren, dass es einen Burst, d.h. ein Signal für eine bestimmte Anzahl von Zyklen ausgibt. Sie können Burst in einer der beiden Betriebsarten verwenden: N-Cycle Burst (auch als „triggered burst“ bezeichnet) oder Gated Burst.

Ein „N-Cycle burst“ besteht aus einer spezifizierten Anzahl von Signalzyklen (1 bis 1.000.000) und wird stets durch ein Triggerereignis ausgelöst. Sie können die Burst-Anzahl auch auf „Infinite“ einstellen. In diesem Fall gibt das Gerät nach erfolgter Triggerung ein kontinuierliches Signal aus.

In der Abbildung unten ist die obere Spur der Sync-Ausgang, die untere Spur ist das Haupt-Ausgangssignal.

Burst mit drei Signalzyklen

Die Triggerquelle für Bursts kann ein externes Signal, ein interner Timer, die Taste oder ein Befehl über die Fernsteuerungsschnittstelle sein. Als Eingang für externe Triggersignale dient der rückseitige Anschluss Ext Trig. Dieser Anschluss ist auf Chassis-Masse bezogen (nicht erdfrei). Wenn er nicht als Eingang genutzt wird, kann der Anschluss Ext Trig als Ausgang konfiguriert werden, damit das Gerät andere Geräte jedesmal gleichzeitig triggern kann, wenn er intern getriggert wird.

Ein „N-Cycle burst“ beginnt und endet stets an demselben Signalpunkt. Dieser wird als Start-Phase bezeichnet.

In der Betriebsart GATed Burst ist das Ausgangssignal an oder aus, je nach dem Signal am rückseitigen Ext Trig Anschluss. Wählen Sie die Polarität dieses Signals mit dem Befehl BURSt:GATE:POLarity. Wenn das Torsignal sich im Zustand WAHR befindet, gibt das Gerät ein kontinuierliches Signal aus. Geht das Torsignal in den Zustand FALSE über, wird der aktuelle Signalzyklus beendet. Das Gerät stoppt und die Ausgangsspannung bleibt auf dem durch die Start-Burst-Phase der Signalform vorgegebenen Wert. Bei der Signalform „Noise“ wird die Signalausgabe beim TRUE/FALSE-Übergang des Torsignals sofort beendet.

Frequenzwobbelung

Frequenzwobbelung entspricht der FM, es wird jedoch keine modulierende Wellenform verwendet. Stattdessen bestimmt das Gerät die Ausgangsfrequenz entweder auf der Grundlage einer linearen oder einer logarithmischen Funktion oder über eine Liste von bis zu 128 benutzerdefinierten Frequenzen. Eine lineare Wobbelung ändert die Ausgangsfrequenz über eine konstante Hertz-Zahl pro Sekunde, eine logarithmische Wobbelung ändert die Frequenz über eine konstante Anzahl von Dekaden pro Sekunde. Mit der logarithmischen Wobbelung können Sie weite Frequenzbereiche abdecken, bei denen mit einer linearen Wobbelung die Auflösung bei niedrigen Frequenzen verloren gehen könnte.

Eine Frequenzwobbelung ist gekennzeichnet durch die Wobbelzeit (während der die Frequenz gleichmäßig von der Start-Frequenz zur Stop-Frequenz wechselt), die Haltezeit (während der die Frequenz die Stop-Frequenz beibehält) und die Rücklaufzeit (während der die Frequenz gleichmäßig und linear zur Start-Frequenz zurückkehrt). Triggereinstellungen bestimmen, wann der nächste Sweep beginnt.

Eigenschaften von AC-Signalen

Die am häufigsten verwendete AC-Signalform ist Sinus. Tatsächlich lässt sich jedes periodische Signal durch eine Summe verschiedener Sinussignale darstellen. Die Stärke eines Sinussignals wird meistens durch Angabe des Spitzenwertes, des Spitze-Spitze-Wertes oder des Effektivwertes (RMS) spezifiziert. Alle diese Angaben setzen voraus, dass dem Signal keine Offsetspannung überlagert ist.

Abbildung Sinuskurve RMS

Die Scheitelspannung eines Signals ist der größte Absolutwert aller seiner Punkte. Die Spitze-Spitze-Spannung ist die Differenz zwischen dem maximalen und dem minimalen Wert. Die RMS-Spannung entspricht der Standardabweichung aller Signalpunkte; die stellt außerdem die durchschnittliche Signalleistung in einem Zyklus dar minus der Leistung in jeder DC-Komponente des Signals. Der Scheitelfaktor ist das Verhältnis zwischen dem Spitzenwert eines Signals und seinem RMS-Wert und variiert je nach Signalform. Die nachstehende Tabelle zeigt mehrere gängige Wellenformen mit ihren jeweiligen Scheitelfaktoren und RMS-Werten.

Bei Verwendung eines Durchschnittsmessungs-Voltmeters zur Messung der DC-Spannung eines Signals stimmt die Messung womöglich nicht mit der DC-Offset-Einstellung überein. Der Grund hierfür ist, dass das Signal einen Wert ungleich Null aufweisen könnte, der zur DC-Offsetspannung hinzugefügt würde.

Gelegentlich kann es vorkommen, dass AC-Pegel in „Dezibel relativ zu 1 Milliwatt” (dBm) angegeben werden. Da dBm den Leistungsgrad angibt, müssen Sie die RMS-Spannung des Signals und den Lastwiderstand des Signals kennen. um die Berechnung ausführen zu können.

dBm = 10 x log10 (P / 0.001) wobei P = VRMS2 / RL

Die nachfolgende Tabelle zur Umrechnung von dBm in Spannung gilt für Sinussignale und einen Lastwiderstand von 50 Ω.

dBm | Effektivspannung | Spitze-Spitze-Spannung
+23,98 dBm | 3,54 Vrms | 10,00 Vpp
+13,01 dBm | 1,00 Vrms | 2,828 Vpp
+10,00 dBm | 707 mVrms | 2,000 Vpp
+6,99 dBm | 500 mVrms | 1,414 Vpp
3,98 dBm | 354 mVrms | 1,000 Vpp
0,00 dBm | 224 mVrms | 632 mVpp
-6,99 dBm | 100 mVrms | 283 mVpp
-10,00 dBm | 70,7 mVrms | 200 mVpp
-16,02 dBm | 35,4 mVrms | 100 mVpp
-30,00 dBm | 7,07 mVrms | 20,0 mVpp
-36,02 dBm | 3,54 mVrms | 10,0 mVpp
-50,00 dBm | 0,707 mVrms | 2,00 mVpp
-56,02 dBm | 0,354 mVrms | 1,00 mVpp

Für 75 Ω oder 600 Ω Lastwiderstand gelten folgende Umrechnungsfaktoren:

dBm (75 Ω) = dBm (50 Ω) – 1,76

dBm (600 Ω) = dBm (50 Ω) – 10,79

Signalfehler

Bei Sinuskurven lassen sich häufige Signalfehler am einfachsten beschreiben und in der Frequenzebene mit einem Spektrumanalysator beobachten. Alle Komponenten des Ausgangssignals mit einer von der Grundfrequenz („Trägerfrequenz“) abweichenden Frequenz werden als Verzerrung betrachtet. Diese Signalfehler können den Kategorien harmonische Verzerrung, nicht harmonische Nebenwellen oder Phasenrauschen zugeordnet werden, sie werden in „Dezibel relativ zum Trägersignalpegel“ oder „dBc“ angegeben

Harmonische Verzerrung

Harmonische Komponenten sind dadurch gekennzeichnet, dass ihre Frequenz ein ganzzahliges Vielfaches der Grundfrequenz beträgt. Sie entstehen durch nicht lineare Komponenten im Signalpfad. Bei kleineren Amplituden ist eine weitere mögliche Quelle harmonischer Verzerrung das Sync-Signal, ein Rechtecksignal mit vielen starken harmonischen Komponenten, die in das Hauptsignal einkoppeln können. Obwohl Sync stark von den Hauptsignalausgängen des Geräts isoliert ist, kann eine Kopplung bei der externen Verkabelung auftreten. Um optimale Ergebnisse zu erzielen, verwenden Sie hochwertige Koaxialkabel mit Doppel- oder Dreifachschutz. Wird Sync nicht benötigt, schließen Sie es nicht an oder lassen Sie es ausgeschaltet.

Nicht-harmonische Nebenwellen

Eine Quelle von nicht harmonischen Nebenwellenverzerrungen (sogenannte „spurs") ist der Digital-Analog-Wandler (DAC), der digitale Signalwerte in Spannungswerte umwandelt. Nichtlinearität in diesem DAC führt zu einem Anstieg zu Oberwellen, die höher sein können als die Nyquist-Frequenz und daher in einer niedrigere Frequenz angegeben werden (Aliasing). Zum Beispiel könnte die fünfte Oberwelle von 30 MHz (150 MHz) eine harmonische Nebenwellenverzerrung mit 100 MHz erzeugen.

Eine weitere Quelle nicht-harmonischer Nebenwellenverzerrungen sind Kopplungen nicht verknüpfter Signalquellen (beispielsweise die integrierte Controller-Uhr) auf das Ausgangssignal. Diese Nebenwellenverzerrungen haben normalerweise eine konstante Amplitude und sind bei Amplituden unter 100 mVpp sehr störend. Um eine optimale Signalreinheit bei niedrigen Amplituden zu erzielen, halten Sie den Ausgangspegel des Geräts relativ hoch und verwenden Sie einen externen Abschwächer.

Phasenrauschen

Phasenrauschen resultiert aus kleineren, momentanen Schwankungen ("Jitter") der Ausgangsfrequenz. Auf einem Spektrumanalysator erscheint es als ein erhöhtes Grundrauschen im Bereich der Frequenz des Ausgangssignals. Bei der Phasenrausch-Spezifikation wird die Amplitude des Rauschsignals in einer Bandbreite von 1 Hz angegeben, die sich 1 kHz, 10 kHz und 100 kHz von einer 30-MHz Sinuskurve befindet. Beachten Sie, dass auch Spektrumanalysatoren Phasenrauschen aufweisen, daher können die Pegel, die Sie ablesen, das Phasenrauschen des Analysators enthalten.

Quantisierungsgeräusch

Die endliche Amplitudenauflösung des Signal-D/A-Wandlers führt zu Spannungs-Quantisierungsfehlern. Unter der Annahme, dass diese Fehler gleichmäßig über einen Bereich von ±0,5 LSB (niedrigstwertiges Bit) verteilt sind, beträgt der äquivalente Rauschpegel bei Standardsignalen annähernd -95 dBc. Bei diesem Pegel dominieren andere Rauschquellen im Gerät. Quantisierungsgeräusche können jedoch bei Arbiträrsignalen von Bedeutung sein, die nicht den gesamtem Bereich der DAC-Codes nutzen (-32767 bis +32767). Wenn möglich, skalieren Sie Arbiträrsignale, um den gesamten Bereich zu nutzen.

Erdschleifen

Die Baugruppe des Geräts zur Signalerzeugung ist von der Gehäuse-Masse isoliert. Dies reduziert das Risiko von Erdschleifen und ermöglicht es, das Ausgangssignal auf ein von Chassis-Masse abweichendes Potential zu beziehen. Die nachfolgende Abbildung zeigt das Gerät, das über ein Koaxialkabel an eine Last angeschlossen ist. Ein Unterschied in den Massepotentialen (VGND) wird dazu führen, dass ein Strom (IGND) durch die Abschirmung des Kabels fließt, der durch die Impedanz der Kabelabschirmung (ZSHIELD) einen Spannungsabfall hervorruft. Diese Spannung (IGND x ZSHIELD) tritt als Fehler in der Lastspannung auf. Da das Gerät jedoch isoliert ist, wird eine hohe Serienimpedanz (üblicherweise >1 MΩ parallel zu 50 nF) dem IGND-Strom entgegengesetzt, wodurch dieser Effekt minimiert wird.

Bei Frequenzen oberhalb einiger Kilohertz ist die Abschirmung eines Koaxialkabels nicht mehr resistiv, sondern induktiv. Das Kabel wirkt in diesem Fall als Transformator. Wenn dies auftritt, neigen die Spannungsabfälle in der Abschirmung durch IGND dazu, durch gleiche Spannungen im Mittelleiter aufgehoben zu werden, dadurch reduziert sich die Wirkung von Erdungsschleifen bei höheren Frequenzen. Koaxialkabel mit zwei oder drei Schirmgeflechten sind sehr viel besser als solche mit einfachem Schirmgeflecht oder Folienabschirmung, da sie einen geringen Widerstand haben und dadurch bei niedrigeren Frequenzen zu Transformatoren werden.

Zur Minimierung von Fehlern durch Erdschleifen verbinden Sie das Gerät über ein hochwertiges Koaxialkabel mit der Last und erden Sie es über die Abschirmung des Kabels. Wenn möglich stellen Sie sicher, dass das Gerät und die Last an die gleiche Netzsteckdose angeschlossen werden, um weitere Unterschiede im Erdpotential zu minimieren.

Beachten Sie, dass die äußeren Buchsen der Anschlüsse Sync und Modulation In mit denen der Hauptausgangsanschlüsse verbunden sind. Kabel, die mit Sync und/oder Modulation In verbunden sind, sind daher potentielle Quellen für Erdschleifen. Beachten Sie außerdem, dass der Versuch, diese Anschlussbuchsen an unterschiedliche Spannungen anzuschließen, zu Hochstromfluss durch das Gerät führen und dort Schäden verursachen kann.


Tutorial Animationen

Animationen

Die folgenden Animationen demonstrieren, wie verschiedene Vorgänge am Gerät über die Frontplatte ausgeführt werden.

Ein Sinussignal vorbereiten

Einen Burst vorbereiten

Eine Frequenzkopplung vorbereiten


SCPI-Programmierreferenz

Dieser Abschnitt beschreibt die SCPI-Programmiersprache für das Gerät.

Einführung in die SCPI-Sprache

Interne Funktionssignale

Alphabetische Liste der SCPI-Befehle und Abfragen

Programmierbeispiele

Befehl Schnellübersicht

Gerätestatus nach dem Zurücksetzen auf die Werkseinstellungen

SCPI-Fehlermeldungen


Einführung in die SCPI-Sprache

SCPI (Standard Commands for Programmable Instruments) ist eine ASCII-basierte Befehlssprache zur Steuerung von Test- und Messgeräten. SCPI-Befehle basieren auf einer hierarchischen Struktur, auch bekannt als Baumsystem. In diesem System sind zusammengehörige Befehle jeweils unter einem gemeinsamen Knoten zu Subsystemen zusammengefasst. Ein Ausschnitt des OUTPut Subsystems ist unten dargestellt, um das Baumsystem zu veranschaulichen.

OUTPut:
SYNC {OFF|0|ON|1}

SYNC:
MODE {NORMal|CARRier}
POLarity {NORMal|INVerted}

OUTPut ist das primäre Schlüsselwort, SYNC ist ein sekundäres Schlüsselwort und MODE und POLarity sind tertiäre Schlüsselwörter. Ein Doppelpunkt ( : ) trennt Schlüsselwörter verschiedener Ebenen.

Syntaxkonventionen

Das Befehlsanzeigeformat ist nachstehend dargestellt:

[SOURce[1|2]:]VOLTage:UNIT {VPP|VRMS|DBM}

[SOURce[1|2]:]FREQuency:CENTer {<frequency>|MINimum|MAXimum|DEFault}

Die Befehlssyntax zeigt die meisten Befehle (und einige Parameter) in gemischter Groß-/Kleinschreibung. Die Großbuchstaben geben die abgekürzte Schreibweise des Befehls wieder. Bei kürzeren Programmzeilen können Sie die abgekürzte Version senden. Für eine bessere Lesbarkeit des Programms können Sie die lange Version senden.

So kann beispielsweise in der oben aufgeführten Syntaxbeschreibung der Begriff VOLT ebenso verwendet werden wie der Begriff VOLTAGE. Sie können Groß- oder Kleinbuchstaben verwenden. Es können also VOLTAGE, volt und Volt verwendet werden. Andere Formen wie VOL und VOLTAG sind dagegen ungültig und erzeugen einen Fehler.

  • In geschweiften Klammern ( { } ) sind die Parameter für eine bestimmte Befehlszeile angegeben. Die geschweiften Klammern werden nicht mit dem Befehlsstring gesendet.
  • Ein senkrechter Strich ( | ) trennt mehrere Parameter für einen bestimmten Befehlsstring. So gibt z. B. {VPP|VRMS|DBM} im obigen Befehl a, dass Sie "VPP", "VRMS" oder "DBM" angeben können. Der Strich wird nicht mit dem Befehlsstring gesendet.
  • Die spitzen Klammern im zweiten Beispiel ( < > ) zeigen an, dass für den betreffenden Parameter ein Wert spezifiziert werden muss. Im obigen Beispiel ist der Parameter <Frequenz> in spitze Klammern eingeschlossen. Die Klammern werden nicht mit dem Befehlsstring gesendet. Sie müssen einen Parameterwert angeben (z. B. "FREQ:CENT 1000"), außer Sie wählen eine andere Option, die in der Syntax angezeigt wird (z. B. "FREQ:CENT MIN").
  • Einige Syntax-Elemente (z. B. Knoten und Parameter) stehen in eckigen Klammern ( [ ]). Dies zeigt an, dass das Element optional ist und weggelassen werden kann. Die Klammern werden nicht mit dem Befehlsstring gesendet. Wenn Sie für einen optionalen Parameter keinen Wert spezifizieren, wählt das Gerät einen Standardwert. In obenstehenden Beispielen gibt "SOURce[1|2]" an, dass Sie Quellkanal 1 mit "SOURce", "SOURce1", "SOUR1" oder "SOUR" beschreiben können. Da der gesamte Knoten SOURce optional ist (in Klammern steht), besteht zusätzlich die Möglichkeit, bei der Beschreibung von Kanal 1 den Knoten SOURce völlig wegzulassen. Dies ist der Fall, da Kanal 1 der Standardkanal für den SOURce Sprachknoten ist. Andererseits müssen Sie zur Beschreibung von Kanal 2 entweder "SOURce2" oder "SOUR2" in Ihren Programmzeilen verwenden.

Befehlstrennzeichen

Ein Doppelpunkt ( : ) trennt Schlüsselwörter verschiedener Ebenen. Zwischen Schlüsselwort und Parameter muss ein Leerzeichen stehen. Wenn ein Befehl mehrere Parameter erfordert, müssen diese jeweils durch ein Komma voneinander getrennt werden. Beispiel:

APPL:SIN 455E3,1.15,0.0

In diesem Beispiel gibt der Befehl APPLy eine Sinuswelle mit einer Frequenz von 455 KHz an, mit einer Amplitude von 1,15 Volt und einem DC-Offset von 0,0 Volt.

Zwei Befehle innerhalb des gleichen Subsystems werden durch einen Strichpunkt ( ; ) voneinander getrennt. Dadurch ist es möglich, mehrere Befehle in einer Zeile zusammenzufassen. Beispielsweise ist der folgende Befehlsstring:

TRIG:SOUR EXT; COUNT 10

gleichwertig zu den beiden folgenden Befehlen:

TRIG:SOUR EXT
TRIG:COUNT 10

Verwenden der Parameter MIN, MAX und DEF

Bei zahlreichen Befehlen können Sie "MIN" oder "MAX" statt eines Parameters verwenden. Manchmal können Sie auch "DEF" ersetzen. Beispiel:

[SOURce[1|2]:]APPLy:DC [{<Frequenz>|DEF} [,{<amplitude>|DEF} [,{<offset>|MIN|MAX|DEF}]]]

Anstatt einen bestimmten Wert für den Parameter <offset> zu wählen, können Sie MIN ersetzen, indem Sie den Offset auf den Mindestwert einstellen und MAX, indem Sie den Offset auf den Höchstwert einstellen. Sie können auch DEF angeben, um den Standardwert für jeden Parameter einzustellen: <Frequenz>, <Amplitude> und <Offset>.

Abfrage von Parametereinstellungen

Sie können die Werte der meisten Parameter abfragen, indem Sie dem betreffenden Befehl ein Frage zeichen ( ? ) hinzufügen. So stellt beispielsweise der folgende Befehl die Triggerzahl auf 10 Messwerte:

TRIG:COUN 10

Mit folgendem Befehl können Sie den Wert abfragen:

TRIG:COUN?

Folgendermaßen können Sie die zulässigen Mindest- oder Höchstwerte abfragen:

TRIG:COUN? MIN
TRIG:COUN? MAX

SCPI-Befehlsabschlusszeichen

Ein an den Funktionsgenerator gesendeter Befehlsstring muss mit einen Zeichen für eine <neue Zeile> (<NL>) abschließen. Die Meldung IEEE-488 EOI (End-Or-Identify) wird als <Zeilenvorschub>-Zeichen interpretiert und kann als Abschluss eines Befehlsstrings anstatt eines <Zeilenvorschub>-Zeichens verwendet werden. Ein <Wagenrücklauf>-Zeichen, gefolgt von einem <Zeilenvorschub>-Zeichen ist ebenfalls zulässig. Der Abschluss eines Befehlsstrings setzt immer den momentanen SCPI-Pfad auf die oberste Ebene zurück.

Hinweis

Für jede SCPI-Meldung, die eine Abfrage enthält und an das Gerät gesendet wird, schließt das Gerät die Antwort mit einem <Zeilenvorschub>- oder Wagenrücklaufzeichen (EOI) ab. Wird beispielsweise "DISP:TEXT?" gesendet, endet die Antwort mit einem Zeilenvorschub< nach dem zurückgegebenen Datenblock. Wenn eine SCPI-Meldung mehrere durch Semikolon getrennte Abfragen enthält (z. B. "DISP?;DISP:TEXT?"), endet die zurückgesandte Antwort nach der Antwort auf die letzte Abfrage erneut mit <Zeilenvorschub>. In jedem Fall muss das Programm diesen <Zeilenvorschub< in der Antwort lesen, bevor ein anderer Befehl an das Gerät gesandt wird, oder ein Fehler tritt auf.

IEEE-488.2 Universalbefehle

Der Standard IEEE-488.2 definiert einen Satz von Universalbefehlen, die Funktionen wie Zurücksetzen, Selbsttest und Status-Operationen ausführen. Universalbefehle beginnen immer mit einem Sternchen ( *), sind drei Zeichen lang und können einen oder mehrere Parameter umfassen. Das Befehlsschlüsselwort ist vom ersten Parameter durch ein Leerzeichen getrennt. Mehrere aufeinanderfolgende Universalbefehle werden durch Semikolons ( ; ) voneinander getrennt, wie unten dargestellt:

*RST; *CLS; *ESE 32;*OPC?

SCPI-Parametertypen

Die Befehlssprache SCPI definiert mehrere Datenformate für die Verwendung in Programmier- und Antwortnachrichten.

Numerische Parameter

Befehle mit numerischen Parametern akzeptieren alle gängigen dezimalen Zahlendarstellungen einschließlich optionalem Vorzeichen, Dezimalpunkt und wissenschaftlicher Darstellung (Fließkomma). Auch generische Werte für numerische Parameter wie MIN, MAX und DEF werden akzeptiert. Numerische Parameter können zusammen mit einer Maßeinheit (beispielsweise M, k, m, oder u) gesendet werden. Falls ein Befehl nur bestimmte numerische Werte akzeptiert und ein davon abweichender Wert spezifiziert wird, wird dieser vom Gerät automatisch auf den nächstliegenden zulässigen Wert gerundet. Folgender Befehl erfordert einen numerischen Parameter für den Frequenzwert:

[SOURce[1|2]:]FREQuency:CENTer {<Frequenz>|MINimum|MAXimum}

Hinweis

Da der SCPI-Parser nicht zwischen Groß- und Kleinschreibung unterscheidet, ist der Buchstabe "M" (oder "m") unklar. Für mehr Benutzerfreundlichkeit interpretiert das Gerät "mV" (oder "MV") als Millivolt, aber "MHZ" (oder "Mhz") als Megahertz. Entsprechend wird "MΩ" (oder "mΩ") als Megohm interpretiert. Sie können das Präfix "MA" für Mega verwenden. So wird beispielsweise "MAV" als Megavolt interpretiert.

Diskrete Parameter

Diskrete Parameter werden dazu verwendet, Einstellungen zu programmieren, für die nur eine begrenzte Anzahl von Werten zur Auswahl stehen (beispielsweise IMMediate, EXTernal oder BUS). Für diskrete Parameter existiert evtl. – wie für Befehlsschlüsselwörter – jeweils eine Kurzform und eine Langform. Groß- oder Kleinbuchstaben dürfen miteinander kombiniert werden. Rückmeldungen auf Abfragen verwenden für Großbuchstaben stets die Kurzschreibweise. Folgender Befehl erfordert einen diskreten Parameter für den Spannungswert:

[SOURce[1|2]:]VOLTage:UNIT {VPP|VRMS|DBM}

Boolesche Parameter

Boolesche Parameter repräsentieren einen binären Zustand (TRUE oder FALSE). Anstelle des Wertes FALSE akzeptiert das Gerät "OFF" oder "0". Anstelle des Werts TRUE akzeptiert das Gerät "ON" oder "1". Bei der Abfrage eines Booleschen Parameters gibt das Gerät stets „0“ oder „1“ zurück. Der folgende Befehl benötigt einen Booleschen Parameter:

DISPlay {OFF|0|ON|1}

ASCII-Stringparameter

Stringparameter können fast jede beliebige Folge von ASCII-Zeichen enthalten. Ein String muss von zueinander passenden Anführungszeichen eingeschlossen sein; es sind sowohl einfache als auch doppelte Anführungszeichen zulässig. Sie können das gleiche Anführungszeichen auch innerhalb des Strings als Zeichen verwenden, indem Sie es zweimal nacheinander ohne Zwischenraum schreiben. Hier ein Beispiel für einen Befehl mit Stringparameter:

DISPlay:TEXT <String in Anführungszeichen>

Beispielsweise zeigt folgender Befehl die Meldung "WAITING..." auf der Frontplatte des Geräts an (die Anführungszeichen werden nicht dargestellt).

DISP:TEXT "WAITING..."

Sie können auch die gleiche Meldung anzeigen, indem Sie einfache Anführungszeichen verwenden.

DISP:TEXT 'WAITING...'

Verwendung des Befehls "Device Clear"

Mit der IEEE-488-Low-Level-Busnachricht „Device Clear“ können Sie das Gerät initialisieren. Sie können über verschiedene Programmierbefehle und die IEEE-488-Schnittstelle über eindeutige Befehle auf diese Funktion zugreifen. Statusregister, Fehlermeldungspuffer und Konfigurationsdaten werden durch den Befehl Device Clear nicht beeinflusst.

Der Befehl „Device Clear“ bewirkt folgendes:

  • Evtl. begonnene Messungen werden abgebrochen.
  • Das Gerät kehrt in den "inaktiven" Triggerstatus zurück.
  • Die Eingangs- und Ausgangspuffer des Geräts werden geleert.
  • Das Gerät wird für den Empfang eines neuen Befehlsstrings vorbereitet.

Hinweis

Der Befehl ABORt wird empfohlen, um einen Vorgang des Geräte zu beenden.


Interne Funktionssignale

Im Folgenden werden die internen Funktionssignalformen aufgeführt.

  • SINusoid: eine Sinuswelle, keine Phasenverschiebung.

    Sinussignal
  • SQUare: eine Rechteckwelle, Tastverhältnis von 50%.

    Rechtecksignal mit Tastverhältnis von 50%
  • RAMP: Sägezahn, 100% Symmetrieverhältnis.

    Sägezahnmodulationssignal mit Symmetrieverhältnis von 100%
  • NRAMp: Negativ-Sägezahn-Modulationssignal, Symmetrieverhältnis von 0%.

    NRAMp mit Symmetrieverhältnis von 0%
  • TRIangle: Sägezahnmodulationssignal, Symmetrieverhältnis von 50%.

    Dreickmodulationssignal mit Symmetrieverhältnis von 50%
  • NOISe: Gaußsches Rauschsignal; ist NOISe die interne Funktion, kann sie nicht auch der Träger sein.

    Signalform „Noise“
  • PRBS: Modulation der pseudozufälligen Binärfolge; ist PRBS die interne Funktion, kann sie nicht auch der Träger sein.

    PRBS-Signal
  • ARBitrary: Arbiträrsignal; Standardeinstellung ist exponentieller Anstieg; ist ARB die interne Funktion, kann sie nicht auch Träger sein.

    Arbiträrsignal

Siehe auch

AM-Subsystem

FM-Subsystem

PM-Subsystem

PWM-Subsystem

SUM-Subsystem


Alphabetische Liste der SCPI-Befehle und Abfragen

ABORt

AM-Subsystem

APPLy Subsystem

BPSK-Subsystem

BURSt Subsystem

CALibration Subsystem

COMBine:FEED

DATA Subsystem

DISPlay Subsystem

FM-Subsystem

FORMat:BORDer

FREQuency-Subsystem

FSKey-Subsystem

FUNCtion Subsystem

HCOPy Subsystem

IEEE-488.2 Universalbefehle

INITiate-Subsystem

INPut_ATTenuation_STATe

LIST-Subsystem

LXI-Subsystem

MARKer-Subsystem

MEMory-Subsystem

MMEMory Subsystem

OUTPut-Subsystem

PHASe-Subsystem

PM-Subsystem

PWM-Subsystem

RATE-Subsystem

ROSC Subsystem

SOURce Subsystem

STATus Subsystem

SUM-Subsystem

SWEep Subsystem

SYSTem Subsystem

SYSTem: LAN Konfiguration

TRACk

TRIGger Subsystem

UNIT:ANGLe

UNIT:ARBitrary:ANGLe

VOLTage Subsystem


ABORt

Hält eine Sequenz, Liste, Wobbelung oder Burst (sogar einen unendlichen Burst). Löst eine Rückkehr des Trigger-Subsystems in den inaktiven Zustand aus. Steht INITiate:CONTinuous auf ON, aktiviert das Gerät sofort den 'Warten-auf-Trigger'-Status.

Parameter | Typische Rückgabe
(keine) | (keine)
Hält die oben aufgelisteten Elemente: ABORt
  • Hält eine beliebige getriggerte Aktion (getriggerte Liste, getriggerte Wobbelung, getriggerter Burst, Wiedergabe eines getriggerten Arbiträrsignals).
  • ABORt hat keine Auswirkungen, wenn sich das Gerät im Normalmodus oder im modulierten Modus befindet, mit Ausnahme sequenzierter Arbiträrsignale, Listen, Bursts und Wobbelungen. Wenn das Gerät eine Sequenz, Liste, einen Burst oder eine Wobbelung ausführt, startet ABORt das gestoppte Element mit den aktuellen INIT und Triggerbedingungen.
  • Wenn ABORt im Listenmodus auftritt, geht die Frequenz zurück zur "normalen" Modusfrequenz, bis der erste Trigger auftritt. Nach dem ersten Trigger wird die erste Frequenz in der Liste verwendet.
  • Wenn ABORt während einer Wobbelung ausgeführt wird, kehrt die Wobbelung zur Anfangs-Wobbelfrequenz zurück.
  • ABORt gilt stets für beide Kanäle eines Zweikanalgeräts.


AM-Subsystem

Mit dem AM-Subsystem kann eine Amplitudenmodulation (AM) zu einem Trägersignal hinzugefügt werden.

Beispiel

So wird ein Amplitudenmodulationssignal (AM-Signal) erzeugt:

  1. Konfiguration des Trägersignals: Verwenden Sie die Befehle FUNCtion, FREQuency VOLTage und VOLTage:OFFSet zur Angabe von Funktion, Frequenz, Amplitude und Offset des Trägersignals.
  2. Wählen Sie den Modus der Amplitudenmodulation: AM:DSSC
  3. Modulationsquelle auswählen (intern, extern, CH1 oder CH2): AM:SOURce. Bei einer externen Quelle können Sie die unten aufgeführten Schritte 4 und 5 überspringen.
  4. Modulationssignal wählen: AM:INTernal:FUNCtion
  5. Modulationsfrequenz einstellen: AM:INTernal:FREQuency
  6. Einstellen des Modulationsgrads: AM[:DEPTh]
  7. AM aktivieren: AM:STATe:ON

Der folgende Code bewirkt das unten abgebildete Oszilloskopbild.

FUNCtion SQU
FREQuency +1,0E+04
VOLTage +1
VOLTage:OFFset 0,0
AM:SOURce INT
AM:DSSC 0
AM:DEPTh +120
AM:INTernal:FUNCtion TRI
AM:INTernal:FREQ 5E+02
AM:STATe 1
OUTPut1 1

[SOURce[1|2]:]AM[:DEPTh] {<depth_in_percent>|MINimum|MAXimum}
[SOURce[1|2]:]AM[:DEPTh]? [{MINimum|MAXimum}]

Stellt den internen Modulationsgrad in Prozent ein.

Parameter | Typische Rückgabe
0 bis 120, Standard 100 | +5,000000000000000E+01
Stellen Sie den Modulationsgrad auf 50%: AM:DEPT 50 Stellen Sie den Modulationsgrad auf 120%: AM:DEPT MAX
  • Selbst bei einem Grad von über 100% überschreitet das Gerät nicht den Spitzenwert von ±5 V am Ausgang (in eine 50 Ω Last). Um einen Modulationsgrad über 100% zu erzielen, kann die Trägeramplitude des Ausgangs reduziert werden.
  • Bei AM:SOURce EXTernal, Trägersignal ist mit einem externen Signal moduliert. Der Modulationsgrad wird durch den ±5 V Signalpegel (oder den optionalen ±1 V Signalpegel bei 33600 Series Geräten) am rückseitigen Anschluss Modulation In gesteuert. Beträgt der Modulationsgrad (AM[:DEPTh]) z. B. 100%, entspricht die Ausgabe bei einem Modulationssignal von +5 V (oder optional +1 V bei 33600 Series Geräten) der maximalen Amplitude. Ähnlich erzeugt ein -5 V Modulationssignal (oder optional -1 V bei 33600 Series Geräten) eine Ausgabe mit der minimalen Amplitude.

Siehe auch

INPut:ATTenuation[:STATe]

[SOURce[1|2]:]AM:DSSC {ON|1|OFF|0}
[SOURce[1|2]:]AM:DSSC?

Wählt den Modus der Amplitudenmodulation − Zweiseitenband-AM mit unterdrücktem Träger (ON) oder AM-modulierter Träger mit Seitenfrequenzen (OFF).

Parameter | Typische Rückgabe
{ON|1|OFF|0} | 0 (OFF) oder 1 (ON)
Einstellung von AM auf DSSC-Modus: AM:DSSC ON
  • Die Standardeinstellung beim Einschalten des Geräts ist OFF.
  • In DSSC AM führt die Nullmodulation zu einem Nullausgangsignal und ein steigendes Modulationseingangssignal erhöht die Amplitude der Seitenfrequenzen im Verhältnis zur Amplitude des Modulationssignals.
  • DSSC AM ist nützlich für einige digitale Modulationsmodi.
  • Bei "normaler" AM führt die Nullmodulation zur Ausgabe eines Trägersignals mit der halben Amplitude. Mit dem Anstieg des Modulationseingangssignals wird der Träger amplitudenmoduliert (Amplitude von 0 bis 100%).
  • In DSSC gilt die Einstellung AM[:DEPTh] und skaliert die Modulation des Modulationssignal von 0 bis 120%.

[SOURce[1|2]:]AM:INTernal:FREQuency {<frequency>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]AM:INTernal:FREQuency? [{MINimum|MAXimum}]

Stellt die Frequenz des Modulationssignals ein. Das als Modulationssignal gewählte Signal arbeitet dann mit dieser Frequenz, in den Grenzen der Signalfrequenz.

Parameter | Typische Rückgabe
1 μHz bis zum zulässigen Höchstwert für die interne Funktion. Standard 100 Hz | +1,000000000000000E+04
Modulationsfrequenz auf 10 kHz einstellen: AM:INT:FUNC 10000
  • Wenn Sie ein Arbiträrsignal als Modulationsquelle wählen, wechselt die Frequenz zur Frequenz des Arbiträrsignals, das auf der Abtastrate und der Punktzahl im Arbiträrsignal basiert.
  • Bei Verwendung eines Arbiträrsignals für die Modulationsquelle ändern sich durch eine Änderung dieses Parameters auch die zwischengespeicherten Metadaten, die die Abtastrate des Arbiträrsignals darstellen. Sie können die Modulationsfrequenz eines Arbiträrsignals auch mit FUNCtion:ARBitrary:FREQuency, FUNCtion:ARBitrary:PERiod und FUNCtion:ARBitrary:SRATe ändern. Diese Befehle und der Modulationsfrequenzbefehl sind direkt gekoppelt, damit sich das Arbiträrsignal genau so verhält wie beim letzten Abspielen. Wenn Sie die Modulation später ausschalten und das gleiche Arbiträrsignal als aktuelle Funktion wählen, ist seine Abtastrate (und die entsprechende Frequenz, basierend auf der Punktzahl) identisch mit denen beim Abspielen als Modulationsquelle.
  • Wenn die interne Funktion TRIangle, UpRamp oder DnRamp entspricht, ist die maximale Frequenz bei 33500 Series Geräten auf 200 kHz oder bei 33600 Series Geräten auf 800 kHz begrenzt. Wenn die interne Funktion PRBS entspricht, bezieht sich die Frequenz auf die Bitrate und ist begrenzt, wie hier dargestellt.
  • Dieser Befehl sollte nur mit der internen Modulationsquelle verwendet werden (AM:SOURce INTernal).

[SOURce[1|2]:]AM:INTernal:FUNCtion <Funktion>
[SOURce[1|2]:]AM:INTernal:FUNCtion?

Wählt die Form des Modulationssignals aus.

Parameter | Typische Rückgabe
{SINusoid|SQUare|RAMP|NRAMp|TRIangle|NOISe|PRBS|ARB}, Standard SINusoid, Standard SINusoid. Interne Funktionssignale anzeigen. | SIN, SQU, RAMP, NRAM, TRI, NOIS, PRBS oder ARB
Wählen Sie eine Sinuswelle als Modulationssignal. AM:INT:FUNC SIN
  • Dieser Befehl sollte nur mit der internen Modulationsquelle verwendet werden (AM:SOURce INTernal).
  • Puls und DC können kein AM-Trägersignal sein.


AM:SOURce

[SOURce[1|2]:]AM:SOURce {INTernal|EXTernal|CH1|CH2}
[SOURce[1|2]:]AM:SOURce?

[SOURce[1|2]:]BPSK:SOURce {INTernal|EXTernal}
[SOURce[1|2]:]BPSK:SOURce?

[SOURce[1|2]:]FM:SOURce {INTernal|EXTernal|CH1|CH2}
[SOURce[1|2]:]FM:SOURce?

[SOURce[1|2]:]FSKey:SOURce {INTernal|EXTernal}
[SOURce[1|2]:]FSKey:SOURce?

[SOURce[1|2]:]PM:SOURce {INTernal|EXTernal|CH1|CH2}
[SOURce[1|2]:]PM:SOURce?

[SOURce[1|2]:]PWM:SOURce {INTernal|EXTernal|CH1|CH2}
[SOURce[1|2]:]PWM:SOURce?

Dieser Befehl wählt die Quelle des Modulationssignals.

Parameter | Typische Rückgabe
{INTernal|EXTernal|CH1|CH2}, Standard INTernal. BPSK und FSKey können CH1 oder CH2 nicht akzeptieren | INT, EXT, CH1 oder CH2
Wählen Sie die externe Modulationsquelle: AM:SOUR EXT (könnte FM, BPSK, FSK, PM, oder PWM auch durch AM ersetzen)
  • Wenn Sie die Modulationsquelle EXTernal wählen, wird das Trägersignal mit einem externen Signal moduliert. Insbesondere:
  • AM: Der Modulationsgrad wird durch den ±5 V Signalpegel (oder den optionalen ±1 V Signalpegel bei 33600 Series Geräten) am rückseitigen Anschluss Modulation In gesteuert. Beträgt der Modulationsgrad (AM[:DEPTh]) z. B. 100%, entspricht die Ausgabe bei einem Modulationssignal von +5 V (oder optional +1 V bei 33600 Series Geräten) der maximalen Amplitude. Ähnlich erzeugt ein -5 V Modulationssignal (oder optional -1 V bei 33600 Series Geräten) eine Ausgabe mit der minimalen Amplitude.
  • FM: Bei Auswahl der externen Modulationsquelle External wird die Abweichung durch den ±5 V Signalpegel (optional ±1 V bei 33600 Series Geräten) am rückseitigen Anschluss Modulation In gesteuert. Beträgt die Frequenzabweichung z. B. 100 kHz, entspricht ein +5 V Signalpegel (optional +1 V bei 33600 Series) einem 100 kHz-Anstieg der Frequenz. Niedrigere externe Signalpegel ergeben eine geringere Abweichung und negative Signalpegel reduzieren die Frequenz unter der Trägerfrequenz.
  • PM: Mit der externen Modulationsquelle wird die Abweichung durch den ±5 V Signalpegel (optional ±1 V bei 33600 Series Geräten) am rückseitigen Anschluss Modulation In gesteuert. Wenn Sie beispielsweise die Frequenzabweichung auf 180 Grad eingestellt haben, entspricht ein +5 V Signalpegel (optional ± 1 V bei 33600 Series Geräten) einer Abweichung von +180 Grad Phasenabweichung. Ein niedrigerer externer Signalpegel verursacht einen geringeren und ein negativer Signalpegel einen negativen Phasenhub.
  • Puls als ausgewählte Funktion: Die Abweichung von Pulsbreite oder Tastverhältnis wird durch das ±5 V Signalniveau (optional ±1 V bei 33600 Series Geräten) des Anschlusses Modulation In am rückseitigen Eingang gesteuert. Wurde z. B. die Pulsbreitenabweichung mit dem Befehl PWM:DEViation auf 50 μs eingestellt, entspricht ein +5 V Signalniveau (optional +1 V bei 33600 Series Geräten) einer Erhöhung der Breite um 50 μs. Ein niedriger externer Signalpegel verursacht eine geringere Abweichung.
  • Mit einer EXTernal Quelle ist die Ausgangsphase (BPSK) oder -frequenz (FSK) durch das Signalniveau am rückseitigen Anschluss Ext Trig festgelegt. Wenn das externe Signal sich im LOW-Zustand befindet, wird die Trägerphase oder -frequenz ausgegeben. Wenn das externe Signal sich im HIGH-Zustand befindet, wird die phasenbedingte Phasenverschiebung oder Hop-Frequenz ausgegeben.
  • Die maximale externe BPSK-Rate beträgt 1 MHz und die maximale FSK-Rate beträgt 1 MHz.
  • Hinweis: Der für die externe BPSK oder FSK-Modulation verwendete Anschluss (Trig In) ist nicht dergleiche Anschluss, der für extern modulierte AM-, FM-, PM- und PWM-Signale verwendet wird (Modulation In). Wenn der Anschluss Trig In für BPSK oder FSK verwendet wird, hat er keine einstellbare Flankenpolarität und wird durch den Befehl TRIGger[1|2]:SLOPe nicht beeinflusst.
  • Bei Auswahl der Quelle INTernal wird die Rate, mit welcher die Ausgangsphase (BPSK) oder -frequenz (FSKey) zwischen der Trägerfrequenz und der „Hop“-Frequenz umschaltet, durch die spezifizierte BPSK-Rate (BPSK:INTernal:RATE) oder die FSK-Rate (FSKey:INTernal:RATE) bestimmt.
  • Ein Kanal kann nicht als seine eigene Modulationsquelle dienen.

Siehe auch

INPut:ATTenuation[:STATe]

AM-Subsystem

BPSK-Subsystem

FM-Subsystem

FSKey-Subsystem

PM-Subsystem

PWM-Subsystem


AM:STATe

[SOURce[1|2]:]AM:STATe {ON|1|OFF|0}
[SOURce[1|2]:]AM:STATe?

[SOURce[1|2]:]BPSK:STATe {ON|1|OFF|0}
[SOURce[1|2]:]BPSK:STATe?

[SOURce[1|2]:]FM:STATe {ON|1|OFF|0}
[SOURce[1|2]:]FM:STATe?

[SOURce[1|2]:]FSKey:STATe {ON|1|OFF|0}
[SOURce[1|2]:]FSKey:STATe?

[SOURce[1|2]:]PM:STATe {ON|1|OFF|0}
[SOURce[1|2]:]PM:STATe?

[SOURce[1|2]:]PWM:STATe {ON|1|OFF|0}
[SOURce[1|2]:]PWM:STATe?

Aktiviert bzw. deaktiviert die Modulation.

Parameter | Typische Rückgabe
{ON|1|OFF|0}, Standard OFF | 0 (OFF) oder 1 (ON)
Aktivieren von AM (auch möglich als Ersatz von FM, BPSK, FSK, PM oder PWM): AM:STAT ON
  • Um ein mehrmaliges Umschalten der Signalform zu vermeiden, sollte die Modulation nach der Konfiguration anderer Modulationsparameter aktiviert werden.
  • Es kann nur jeweils ein Modulationsmodus aktiviert werden.
  • Wenn Wobbelung oder Burst aktiviert sind, aktiviert das Gerät die Modulation nicht. Wenn Sie die Modulation aktivieren, werden die Burst- und Wobbelbetriebsart automatisch deaktiviert.
  • PWM ist nur zulässig, wenn die Funktion Puls ausgewählt ist.

Siehe auch

AM-Subsystem

BPSK-Subsystem

FM-Subsystem

FSKey-Subsystem

PM-Subsystem

PWM-Subsystem


APPLy Subsystem

Mit dem APPLy Subsystem können Sie ganze Signale mit einem Befehl konfigurieren. Die allgemeine Form eines APPLy Befehls ist unten dargestellt:

[SOURce[1|2]:]APPLy:<function> [<Frequenz> [,<amplitude> [,<offset>]]]

So ersetzt

APPLy:SIN 1e4,1,0.1

beispielsweise folgende Befehle:

FUNCtion SIN
FREQ 1e4
VOLT 1
VOLT:OFF 0,1
OUTP ON

APPLy ist nicht nur kürzer, sondern es vermeidet auch Einstellungskonflikte, die beim Senden von Einzelbefehlen entstehen. Zudem führt APPLy folgende Operationen durch:

  • Stellt die Triggerquelle auf IMMediate (entspricht TRIGger[1|2]:SOURce IMMediate).
  • Falls eine Modulations-, Wobbel- oder Burst-Betriebsart aktiv ist, wird diese deaktiviert und das Gerät für die Ausgabe eines kontinuierlichen Signals konfiguriert.
  • Schaltet den Kanalausgang (OUTPut ON) ein, ohne die Einstellung des Lastwiderstands (OUTPut[1|2]:LOAD) zu wechseln.
  • Überschreibt die automatische Spannungsbereichswahl und aktiviert die automatische Bereichswahl (VOLTage:RANGe:AUTO).

Das Gerät kann acht Arten von Signalen generieren: DC-Spannung, Gaußsches Rauschen, PRBS, Puls, Sägezahn/Dreieckssignal, Sinussignal, Rechtecksignal und Arbiträgsignal (Benutzersignal). Signalspezifische Einstellungen bestehen im FUNCtion subsystem.

Sie können die aktuelle Ausgangskonfiguration auch abfragen (APPLy?).

Allgemeine Hinweise

Amplitude

  • Eine Änderung der Amplitude kann die Ausgabe bei bestimmten Spannungswerten aufgrund des Wechsels des Ausgangsabschwächers kurz unterbrechen. Die Amplitudenregelung gewährleistet jedoch, dass die Ausgangsspannung bei einer Bereichsumschaltung niemals den aktuellen Wert überschreitet. Um solche Unterbrechungen zu vermeiden, muss die automatische Bereichswahl mit VOLTage:RANGe:AUTO OFF deaktiviert werden. Der Befehl APPLy aktiviert die automatische Bereichswahl.
  • Einschränkungen durch den Lastwiderstandswert: Der Offset-Bereich ist abhängig von der Einstellung des Lastwiderstands. Wenn Sie zum Beispiel den Offset auf 100 mVDC festlegen und dann den Lastwiderstand von 50 Ω auf "high impedance" stellen, verdoppelt sich der auf der Frontplatte angezeigte Offset-Spannungswert auf 200 mVDC (es wird kein Fehler generiert). Wenn Sie von "high impedance" auf 50 Ω wechseln, halbiert sich der angezeigte Offset-Spannungswert. Ausführlichere Informationen finden Sie unter OUTPut[1|2]:LOAD.
  • Einschränkungen durch die Maßeinheit: Die Amplitudeneinschränkungen werden durch die ausgewählten Ausgangseinheiten bestimmt.
  • Die Ausgangsamplitudenmaßeinheit „dBm“ ist nicht verfügbar, wenn Sie den Lastwiderstand „high impedance“ spezifiziert haben. Die Einheiten werden automatisch in Vpp umgerechnet.

Befehle und Anfragen

[SOURce[1|2]:]APPLy?

[SOURce[1|2]:]APPLy:ARBitrary [{<sample_rate>|MIN|MAX|DEF} [,{<amplitude>|MIN|MAX|DEF} [,{<offset>|MIN|MAX|DEF}]]]

[SOURce[1|2]:]APPLy:DC

[SOURce[1|2]:]APPLy:NOISe

[SOURce[1|2]:]APPLy:PRBS

[SOURce[1|2]:]APPLy:PULSe

[SOURce[1|2]:]APPLy:RAMP

[SOURce[1|2]:]APPLy:SINusoid

[SOURce[1|2]:]APPLy:SQUare

[SOURce[1|2]:]APPLy:TRIangle

[SOURce[1|2]:]APPLy?

Abfrage der Ausgangskonfiguration.

Parameter | Typische Rückgabe
(keine) | "SIN +5,000000000000000E+03, +3,0000000000000E+00, -2,5000000000000E+00"
Rückgabe der Konfiguration für ein 5 kHz, 3 V Sinussignal mit einem -2,5 VDC Offset. APPLY?
  • Funktion, Frequenz, Amplitude und Offset werden wie oben dargestellt zurückgegeben. Die Amplitude, aber nicht der Offset, werden zurückgegeben wie in VOLTage:UNIT angegeben.

[SOURce[1|2]:]APPLy:ARBitrary [{<sample_rate>|MIN|MAX|DEF} [,{<amplitude>|MIN|MAX|DEF} [,{<offset>|MIN|MAX|DEF}]]]

Gibt ein Arbiträgsignal aus, ausgewählt durch FUNCtion: ARBitrary und mit der angegebenen Abtastrate, Amplitude und Offset.

Parameter | Typische Rückgabe
<sample_rate> von 1 µSa/s bis 250 MSa/s (33500 Series) oder 1 GSa/s (33600 Series), Standard 40 kSa/s | (keine)
<amplitude> von 1 mVpp bis 10 Vpp in 50 Ω, 2 mVpp bis 20 Vpp in einen offenen Kreislauf, Standard 100 mVpp in 50 Ω
<offset> ist die DC-Offset-Spannung (Standard: 0), ab ±5 VDC in 50 Ω, oder ab ±10 VDC in einen offenen Schaltkreis.
Ausgabe des Arbiträrsignals mit FUNCtion:ARBitrary: APPLy:ARBitrary 1 kHz, 5,0, -2,5 V

Allgemeines

  • Wird eine Abtastrate eingestellt, wenn sich das Gerät nicht im ARB-Modus befindet, ändert sich die Frequenz nicht. Ist die aktuelle Funktion z. B. Sinus, hat die Einstellung der Abtastrate keine Auswirkungen, bevor die Funktion zu ARB geändert wird.
  • Hohe Abtastraten können die aktuelle Amplitude durch Filter-Roll-Off beeinflussen.

Optionen

  • Siehe FUNCtion: ARBitrary für verfügbare Arbiträrsignaloptionen. Mit FUNCtion:ARBitrary können Sie ein integriertes Arbiträrsignal oder ein aktuell mit MMEMory Befehlen in den flüchtigen Speicher heruntergeladenes Signal auswählen.

Offset-Spannung

  • Der Zusammenhang zwischen Offset-Spannung und Ausgangsamplitude ist unten beschrieben. Vmax ist die maximale Spitzenspannung für den gewählten Lastwiderstand (5 V für eine 50 Ω Last oder 10 V für eine hochohmige Last).

    |Voffset| < Vmax - Vpp/2

    Ist die angegebene Offsetspannung nicht gültig, passt das Gerät den Wert auf die maximal zulässige DC-Spannung mit der angegebenen Amplitude an. Über die Remote-Schnittstelle wird ebenfalls der Fehler "Data out of range" generiert.

  • Einschränkungen durch den Lastwiderstandswert: Der Offset-Bereich ist abhängig von der Einstellung des Lastwiderstands. Wenn Sie zum Beispiel den Offset auf 100 mVDC festlegen und dann den Lastwiderstand von 50 Ω auf "high impedance" stellen, verdoppelt sich der auf der Frontplatte angezeigte Offset-Spannungswert auf 200 mVDC (es wird kein Fehler generiert). Wenn Sie von "high impedance" auf 50 Ω wechseln, halbiert sich der angezeigte Offset-Spannungswert. Ausführlichere Informationen finden Sie unter OUTPut[1|2]:LOAD.

[SOURce[1|2]:]APPLy:DC [{<frequency>|MIN|MAX|DEF} [,{<amplitude>|MIN|MAX|DEF} [,{<offset>|MIN|MAX|DEF}]]]

Gibt eine DC-Spannung aus.

Parameter | Typische Rückgabe
<Frequenz> gilt nicht für die DC Funktion. Muss als Platzhalter angegeben sein; der Wert wird gespeichert, wenn Sie zu einer anderen Funktion wechseln. | (keine)
<amplitude> gilt nicht für die DC Funktion. Muss als Platzhalter angegeben sein; der Wert wird gespeichert, wenn Sie zu einer anderen Funktion wechseln.
<offset> ist die DC-Offset-Spannung (Standard: 0), ab ±5 VDC in 50 Ω, oder ab ±10 VDC in einen offenen Schaltkreis.
Ausgabe einer DC-Spannung von -2,5 V: APPLy:DC DEF, DEF, -2.5 V
  • Einschränkungen durch den Lastwiderstandswert: Der Offset-Bereich ist abhängig von der Einstellung des Lastwiderstands. Wenn Sie zum Beispiel den Offset auf 100 mVDC festlegen und dann den Lastwiderstand von 50 Ω auf "high impedance" stellen, verdoppelt sich der auf der Frontplatte angezeigte Offset-Spannungswert auf 200 mVDC (es wird kein Fehler generiert). Wenn Sie von "high impedance" auf 50 Ω wechseln, halbiert sich der angezeigte Offset-Spannungswert. Ausführlichere Informationen finden Sie unter OUTPut[1|2]:LOAD. Eine Änderung des Lastwiderstands ändert nicht die Spannung an den Ausgangsanschlüssen des Geräts. Sie ändert lediglich die an der Frontplatte angezeigten Werte und die Werte, die über die Remote-Schnittstelle abgefragt werden. Die Spannung am Ausgang des Geräts ist abhängig von der Last, die mit dem Gerät verbunden ist. Ausführlichere Informationen finden Sie unter OUTPut[1|2]:LOAD.

[SOURce[1|2]:]APPLy:NOISe [{<frequency>|MIN|MAX|DEF} [,{<amplitude>|MIN|MAX|DEF} [,{<offset>|MIN|MAX|DEF}]]]

Dieser Befehl bewirkt die Ausgabe eines Gaußschen Rauschsignals mit der spezifizierten Amplitude und dem angegebenen DC-Offset.

Parameter | Typische Rückgabe
<Frequenz> gilt nicht für Rauschfunktion. Muss als Platzhalter angegeben sein; der Wert wird gespeichert, wenn Sie zu einer anderen Funktion wechseln. | (keine)
<amplitude> Gewünschte Ausgangsamplitude in Vpp, Vrms oder dBm, wie unter VOLTage:UNIT angegeben.1 mVpp bis 10 Vpp in 50 Ω, oder der doppelte Wert in einen offenen Schaltkreis. Wenn in Vpp angegeben, wird der Spitze-zu-Spitze-Ausgang nur sehr selten ausgegeben, da es sich um ein Gaußsches Rauschen handelt.
<offset> ist die DC-Offset-Spannung (Standard: 0), ab ±5 VDC in 50 Ω, oder ab ±10 VDC in einen offenen Schaltkreis.
Ausgabe eines Gaußschen Rauschsignals, festgelegt durch 3 Vpp, mit -2,5 V Offset: APPL:NOIS 5 KHZ, 3.0 V, -2.5 V

Frequenz

  • Falls Sie einen expliziten Frequenzwert spezifizieren, hat dieser keinen Einfluss auf das Rauschsignal, aber das Gerät „erinnert“ sich an diesen Wert, wenn später eine andere Ausgangsfunktion gewählt wird.
  • Informationen über die wechselnde Bandbreite des Rauschens finden Sie unter FUNCtion:NOISe:BANDwidth.

Offset-Spannung

  • Der Zusammenhang zwischen Offset-Spannung und Ausgangsamplitude ist unten beschrieben. Vmax ist die maximale Spitzenspannung für den gewählten Lastwiderstand (5 V für eine 50 Ω Last oder 10 V für eine hochohmige Last).

    |Voffset| < Vmax - Vpp/2

    Ist die angegebene Offsetspannung nicht gültig, passt das Gerät den Wert auf die maximal zulässige DC-Spannung mit der angegebenen Amplitude an.

    Über die Remote-Schnittstelle wird ebenfalls der Fehler "Data out of range" generiert.

  • Einschränkungen durch den Lastwiderstandswert: Der Offset-Bereich ist abhängig von der Einstellung des Lastwiderstands. Wenn Sie zum Beispiel den Offset auf 100 mVDC festlegen und dann den Lastwiderstand von 50 Ω auf "high impedance" stellen, verdoppelt sich der auf der Frontplatte angezeigte Offset-Spannungswert auf 200 mVDC (es wird kein Fehler generiert). Wenn Sie von "high impedance" auf 50 Ω wechseln, halbiert sich der angezeigte Offset-Spannungswert. Ausführlichere Informationen finden Sie unter OUTPut[1|2]:LOAD.

[SOURce[1|2]:]APPLy:PRBS [{<frequency>|MIN|MAX|DEF} [,{<amplitude>|MIN|MAX|DEF} [,{<offset>|MIN|MAX|DEF}]]]

Gibt eine pseudozufällige Binärfolge mit der angegebenen Abtastrate, Amplitude und Offset an.

Standardsignal ist ein PN7 Schieberegistergenerator mit maximaler Länge.

Parameter | Typische Rückgabe
<Frequenz> in Bit/s, Standard 1000 | (keine)
<amplitude> Gewünschte Ausgangsamplitude in Vpp, Vrms oder dBm, wie unter VOLTage:UNIT angegeben. 1 mVpp bis 10 Vpp in 50 Ω, oder der doppelte Wert in einen offenen Schaltkreis. Standard 100 mVpp in 50 Ω.
<offset> ist die DC-Offset-Spannung (Standard: 0), ab ±5 VDC in 50 Ω, oder ab ±10 VDC in einen offenen Schaltkreis.
Ausgabe einer pseudozufälligen Bit-Sequenz, festgelegt durch 3 Vpp, mit -2,5 V Offset: APPL:PRBS 5 KHZ, 3.0 V, -2.5 V

Frequenz

  • PRBS wird durch einen Sequenzgenerator mit maximaler Länge (MLS) generiert (rückgekoppeltes Schieberegister), der in mehreren Standardkonfigurationen konfiguriert werden kann. Standard ist PN7 mit 1000 Bits/Sekunde.
  • Ein PRBS-Signal, das ein Polynom PNx verwendet, wird durch ein x-Bit-Schieberegister generiert und das Ausgangssignal beginnt mit x Samplingperioden mit hoher Ausgabe. Die Samplingperiode ist der Reziprokwert der Abtastrate (FUNCtion:PRBS:BRATe) und der Sync-Puls des Kanals gibt den Start des Signals an. Verwendet beispielsweise das PRBS-Signal PN23 mit einer Abtastrate von 500 Hz, beginnt die Ausgabe mit einer 46 ms hohen Ausgabe (23 x 2 ms).
  • Im Gegensatz zur Funktion APPLy:NOISe arbeitet die Funktion APPLy:PRBS mit aktiviertem Sync Ausgang. Die Sync Funktion gibt den Beginn der pseudozufälligen Funktionssequenz an.

Offset-Spannung

  • Der Zusammenhang zwischen Offset-Spannung und Ausgangsamplitude ist unten beschrieben. Vmax ist die maximale Spitzenspannung für den gewählten Lastwiderstand (5 V für eine 50 Ω Last oder 10 V für eine hochohmige Last).

    |Voffset| < Vmax - Vpp/2

    Ist die angegebene Offsetspannung nicht gültig, passt das Gerät den Wert auf die maximal zulässige DC-Spannung mit der angegebenen Amplitude an. Über die Remote-Schnittstelle wird ebenfalls der Fehler "Data out of range" generiert.
  • Einschränkungen durch den Lastwiderstandswert: Der Offset-Bereich ist abhängig von der Einstellung des Lastwiderstands. Wenn Sie zum Beispiel den Offset auf 100 mVDC festlegen und dann den Lastwiderstand von 50 Ω auf "high impedance" stellen, verdoppelt sich der auf der Frontplatte angezeigte Offset-Spannungswert auf 200 mVDC (es wird kein Fehler generiert). Wenn Sie von "high impedance" auf 50 Ω wechseln, halbiert sich der angezeigte Offset-Spannungswert. Ausführlichere Informationen finden Sie unter OUTPut[1|2]:LOAD.

[SOURce[1|2]:]APPLy:PULSe [{<frequency>|MIN|MAX|DEF} [,{<amplitude>|MIN|MAX|DEF} [,{<offset>|MIN|MAX|DEF}]]]

Dieser Befehl bewirkt die Ausgabe eines Pulssignals mit der spezifizierten Frequenz, Amplitude und DC-Offset. Zudem führt APPLy folgende Operationen durch:

  • Hat keine Auswirkungen entweder auf die aktuelle Einstellung der Pulsbreite (FUNCtion:PULSe:WIDTh) oder die aktuelle Puls-Tastverhältnis-Einstellung (FUNCtion:PULSe:DCYCle).
  • Hat keine Auswirkungen auf die aktuelle Übergangszeiteinstellung (FUNCtion:PULSe:TRANsition[:BOTH]).
  • Kann ein Überschreiben der Pulsbreite oder der Flankenzeiteinstellung durch das Gerät auslösen, um die angegebene Frequenz oder Periode einzuhalten (FUNCtion:PULSe:PERiod).
Parameter | Typische Rückgabe
<Frequenz> in Hz, Standard 1 kHz | (keine)
<amplitude> Gewünschte Ausgangsamplitude in Vpp, Vrms oder dBm, wie unter VOLTage:UNIT angegeben. 1 mVpp bis 10 Vpp in 50 Ω, oder der doppelte Wert in einen offenen Schaltkreis. Standard 100 mVpp in 50 Ω.
<offset> ist die DC-Offset-Spannung (Standard: 0), ab ±5 VDC in 50 Ω, oder ab ±10 VDC in einen offenen Schaltkreis.
Ausgabe eines 5 Vpp Pulssignals mit 1 kHz und einem Offset von -2,5 V: APPL:PULS 1 kHz, 5.0 V, -2.5 V

Frequenz

  • Der Befehl APPLy muss für die Funktion geeignet sein. So führt beispielsweise der Befehl APPL:PULS 300 MHz zum Fehler "Data out of range". In diesem Fall wird für die Frequenz die maximale Pulsfrequenz des Geräts eingestellt.

Offset-Spannung

  • Der Zusammenhang zwischen Offset-Spannung und Ausgangsamplitude ist unten beschrieben. Vmax ist die maximale Spitzenspannung für den gewählten Lastwiderstand (5 V für eine 50 Ω Last oder 10 V für eine hochohmige Last).

    |Voffset| < Vmax - Vpp/2

    Ist die angegebene Offsetspannung nicht gültig, passt das Gerät den Wert auf die maximal zulässige DC-Spannung mit der angegebenen Amplitude an. Über die Remote-Schnittstelle wird ebenfalls der Fehler "Data out of range" generiert.
  • Einschränkungen durch den Lastwiderstandswert: Der Offset-Bereich ist abhängig von der Einstellung des Lastwiderstands. Wenn Sie zum Beispiel den Offset auf 100 mVDC festlegen und dann den Lastwiderstand von 50 Ω auf "high impedance" stellen, verdoppelt sich der auf der Frontplatte angezeigte Offset-Spannungswert auf 200 mVDC (es wird kein Fehler generiert). Wenn Sie von "high impedance" auf 50 Ω wechseln, halbiert sich der angezeigte Offset-Spannungswert. Ausführlichere Informationen finden Sie unter OUTPut[1|2]:LOAD.

[SOURce[1|2]:]APPLy:RAMP [{<frequency>|MIN|MAX|DEF} [,{<amplitude>|MIN|MAX|DEF} [,{<offset>|MIN|MAX|DEF}]]]

[SOURce[1|2]:]APPLy:TRIangle [{<frequency>|MIN|MAX|DEF} [,{<amplitude>|MIN|MAX|DEF} [,{<offset>|MIN|MAX|DEF}]]]

Dieser Befehl bewirkt die Ausgabe eines Dreieckssignals mit der spezifizierten Frequenz, Amplitude und DC-Offset. Zudem führt APPLy folgende Operationen durch:

  • APPLy:RAMP überschreibt die aktuelle Symmetrieeinstellung (FUNCtion:RAMP:SYMMetry) und stellt 100% Symmetrie für das Sägezahnsignal ein.
  • APPLy:TRIangle ist nur ein Sonderfall von APPLy:RAMP. Es entspricht einem Sägezahnsignal mit einer 50% Symmetrie.
Parameter | Typische Rückgabe
<Frequenz> in Hz, Standard 1 kHz | (keine)
<amplitude> Gewünschte Ausgangsamplitude in Vpp, Vrms oder dBm, wie unter VOLTage:UNIT angegeben. 1 mVpp bis zulässiger Höchstwert für Modell und Signal in 50 Ω oder der doppelte Wert in einen offenen Schaltkreis. Standard 100 mVpp in 50 Ω.
<offset> ist die DC-Offset-Spannung (Standard: 0), ab ±5 VDC in 50 Ω, oder ab ±10 VDC in einen offenen Schaltkreis.
Konfigurieren eines 5 V Sägezahnsignals mit 3 kHz und 0 V Offset: APPL:RAMP 3 KHZ, 5,0 V, 0

Frequenz

  • Der Befehl APPLy muss für die Funktion geeignet sein. Der Befehl APPL:RAMP 5 MHz führt beispielsweise zu dem Fehler „Data out of range“. In diesem Fall würde die Frequenz auf 200 kHz eingestellt, was dem Maximalwert für ein Sägezahnsignal entspricht.

Offset-Spannung

  • Der Zusammenhang zwischen Offset-Spannung und Ausgangsamplitude ist unten beschrieben. Vmax ist die maximale Spitzenspannung für den gewählten Lastwiderstand (5 V für eine 50 Ω Last oder 10 V für eine hochohmige Last).

    |Voffset| < Vmax - Vpp/2

    Ist die angegebene Offsetspannung nicht gültig, passt das Gerät den Wert auf die maximal zulässige DC-Spannung mit der angegebenen Amplitude an. Über die Remote-Schnittstelle wird ebenfalls der Fehler "Data out of range" generiert.
  • Einschränkungen durch den Lastwiderstandswert: Der Offset-Bereich ist abhängig von der Einstellung des Lastwiderstands. Wenn Sie zum Beispiel den Offset auf 100 mVDC festlegen und dann den Lastwiderstand von 50 Ω auf "high impedance" stellen, verdoppelt sich der auf der Frontplatte angezeigte Offset-Spannungswert auf 200 mVDC (es wird kein Fehler generiert). Wenn Sie von "high impedance" auf 50 Ω wechseln, halbiert sich der angezeigte Offset-Spannungswert. Ausführlichere Informationen finden Sie unter OUTPut[1|2]:LOAD.

[SOURce[1|2]:]APPLy:SINusoid [{<frequency>|MIN|MAX|DEF} [,{<amplitude>|MIN|MAX|DEF} [,{<offset>|MIN|MAX|DEF}]]]

Dieser Befehl bewirkt die Ausgabe eines Sinussignals mit der spezifizierten Frequenz, Amplitude und DC-Offset.

Parameter | Typische Rückgabe
<Frequenz> 1 μHz bis zur Maximalfrequenz des Geräts. Standard 1 kHz. | (keine)
<amplitude> Gewünschte Ausgangsamplitude in Vpp, Vrms oder dBm, wie unter VOLTage:UNIT angegeben. 1 mVpp bis zulässiger Höchstwert für Modell und Signal in 50 Ω oder der doppelte Wert in einen offenen Schaltkreis. Standard 100 mVpp in 50 Ω.
<offset> ist die DC-Offset-Spannung (Standard: 0), ab ±5 VDC in 50 Ω, oder ab ±10 VDC in einen offenen Schaltkreis.
Ausgabe eines 3 Vpp Sinussignals mit 5 kHz und einem Offset von -2,5 V. APPL:SIN 5 KHZ, 3,0 VPP, -2,5 V

Offset-Spannung

  • Der Zusammenhang zwischen Offset-Spannung und Ausgangsamplitude ist unten beschrieben. Vmax ist die maximale Spitzenspannung für den gewählten Lastwiderstand (5 V für eine 50 Ω Last oder 10 V für eine hochohmige Last).

    |Voffset| < Vmax - Vpp/2

    Ist die angegebene Offsetspannung nicht gültig, passt das Gerät den Wert auf die maximal zulässige DC-Spannung mit der angegebenen Amplitude an. Über die Remote-Schnittstelle wird ebenfalls der Fehler "Data out of range" generiert.
  • Einschränkungen durch den Lastwiderstandswert: Der Offset-Bereich ist abhängig von der Einstellung des Lastwiderstands. Wenn Sie zum Beispiel den Offset auf 100 mVDC festlegen und dann den Lastwiderstand von 50 Ω auf "high impedance" stellen, verdoppelt sich der auf der Frontplatte angezeigte Offset-Spannungswert auf 200 mVDC (es wird kein Fehler generiert). Wenn Sie von "high impedance" auf 50 Ω wechseln, halbiert sich der angezeigte Offset-Spannungswert. Ausführlichere Informationen finden Sie unter OUTPut[1|2]:LOAD.

[SOURce[1|2]:]APPLy:SQUare [{<frequency>|MIN|MAX|DEF} [,{<amplitude>|MIN|MAX|DEF} [,{<offset>|MIN|MAX|DEF}]]]

Dieser Befehl bewirkt die Ausgabe eines Rechtecksignals mit der spezifizierten Frequenz, Amplitude und DC-Offset. Zusätzlich überschreibt APPLy:SQUare die aktuelle Tastverhältnis-Einstellung (FUNCtion:SQUare:DCYCle) und setzt ein Tastverhältnis von 50% für das Rechtecksignal.

Parameter | Typische Rückgabe
<Frequenz> 1 μHz bis zur Maximalfrequenz des Geräts. Standard 1 kHz. | (keine)
<amplitude> Gewünschte Ausgangsamplitude in Vpp, Vrms oder dBm, wie unter VOLTage:UNIT angegeben. 1 mVpp bis zulässiger Höchstwert für Modell und Signal in 50 Ω oder der doppelte Wert in einen offenen Schaltkreis. Standard 100 mVpp in 50 Ω.
<offset> ist die DC-Offset-Spannung (Standard: 0), ab ±5 VDC in 50 Ω, oder ab ±10 VDC in einen offenen Schaltkreis.
Ausgabe eines 3 V Rechtecksignals bei 5 kHz und mit einem Offset von -2,5 V: APPL:SQU 5 KHZ, 3,0 V, -2,5 V

Frequenz

  • Der Befehl APPLy muss für die Funktion geeignet sein. So hat beispielsweise der Befehl APPL:SQU 40 MHz einen "Data out of range"-Fehler zur Folge und das Gerät stellt die Frequenz auf die maximale Frequenz für Rechtecksignale.

Offset-Spannung

  • Der Zusammenhang zwischen Offset-Spannung und Ausgangsamplitude ist unten beschrieben. Vmax ist die maximale Spitzenspannung für den gewählten Lastwiderstand (5 V für eine 50 Ω Last oder 10 V für eine hochohmige Last).

    |Voffset| < Vmax - Vpp/2

    Ist die angegebene Offsetspannung nicht gültig, passt das Gerät den Wert auf die maximal zulässige DC-Spannung mit der angegebenen Amplitude an. Über die Remote-Schnittstelle wird ebenfalls der Fehler "Data out of range" generiert.
  • Einschränkungen durch den Lastwiderstandswert: Der Offset-Bereich ist abhängig von der Einstellung des Lastwiderstands. Wenn Sie zum Beispiel den Offset auf 100 mVDC festlegen und dann den Lastwiderstand von 50 Ω auf "high impedance" stellen, verdoppelt sich der auf der Frontplatte angezeigte Offset-Spannungswert auf 200 mVDC (es wird kein Fehler generiert). Wenn Sie von "high impedance" auf 50 Ω wechseln, halbiert sich der angezeigte Offset-Spannungswert. Ausführlichere Informationen finden Sie unter OUTPut[1|2]:LOAD.


BPSK-Subsystem

Mit dem BPSK-Subsystem können Sie eine Signalform mit BPSK-Modulation (Binary Phase Shift Keying), einem digitalen Modulationsformat, modulieren. In BPSK wird das Trägersignal mit einer On/Off-Tastung zwischen zwei Phaseneinstellungen phasenverschoben. Die Quelle kann intern sein (und ein Rechtecksignal mit spezifizierter Frequenz verwenden) oder extern (Verwendung des externen Triggereingangs).

Ist die Trägerfunktion ein Arbiträrsignal, betrifft die Phasenverschiebung nur die Position der Übergänge der Abtastvorgänge. Dies anders, als die Phase des gesamten Arbiträrsignals zu verschieben.

Beispiel

Generieren eines BPSK-Signals:

  1. Konfiguration des Trägersignals: Verwenden Sie die Befehle FUNCtion, FREQuency VOLTage und VOLTage:OFFSet zur Angabe von Funktion, Frequenz, Amplitude und Offset des Trägersignals.
  2. Modulationsquelle auswählen (intern, extern, CH1 oder CH2): BPSK:SOURce. Bei einer externen Quelle können Sie die unten aufgeführten Schritte 3 und 4 überspringen.
  3. BPSK-Phase auswählen: BPSK[:PHASe]
  4. BPSK-Rate einstellen: BPSK:INTernal:RATE
  5. BPSK-Modulation aktivieren: BPSK:STATe ON

Der folgende Code bewirkt das unten abgebildete Oszilloskopbild.

FUNCtion SQU
FREQuency +1,0E+04
VOLTage +1,0
VOLTage:OFFset 0,0
BPSK:SOURce INT
BPSK:INTernal:RATE +3000
BPSK:PHASe +90
BPSK:STATe 1
OUTPut1 1

[SOURce[1|2]:]BPSK:INTernal:RATE {<modulating_frequency>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]BPSK:INTernal:RATE? [{MINimum|MAXimum}]

Dieser Befehl spezifiziert die Rate, mit der die Ausgangsfrequenz zwischen der Träger- und der Offset-Phase wechselt.

Parameter | Typische Rückgabe
1 mHZ bis 1 MHz, Standard 10 Hz | +1,000000000000000E‑03
BPSK-Rate auf 10 mHz stellen: BPSK:INT:RATE MIN
  • Die BPSK-Rate wird nur verwendet, wenn die Quelle INTernal (BPSK:SOURce INTernal) ausgewählt wird. Sie wird ignoriert, wenn die Quelle EXTernal (BPSK:SOURce EXTernal) ausgewählt wird.
  • Das interne Modulationssignal ist ein Rechtecksignal mit einem Tastverhältnis von 50%.

[SOURce[1|2]:]BPSK[:PHASe] {<angle>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]BPSK[:PHASe]? [{MINimum|MAXimum}]

Stellt die Phasenverschiebung für die binäre Phasenmodulation in Grad ein.

Parameter | Typische Rückgabe
0 bis +360 Grad, Standard 180 | +1,800000000000000E+02
Phasenverschiebung auf 90 Grad einstellen: BPSK:PHAS 90


BURSt Subsystem

Dieser Abschnitt beschreibt das BURSt Subsystem.

Beispiel

Fasst die Schritte zusammen, die zur Generierung notwendig sind Burst.

  1. Konfigurieren Sie die Burst-Signalform: Verwenden Sie APPLy oder die entsprechenden FUNCtion, FREQuency, VOLTage, und VOLTage:OFFSet Befehle zur Einstellung von Funktion, Frequenz, Amplitude und Offset des Signals. Sie können ein Rechteck-, Dreieck-, Sägezahn-, Puls-, PRBS- oder Arbiträrsignal wählen (Rauschen ist nur für den Modus "Gated burst" zulässig, DC ist nicht zulässig). Die minimale Frequenz für intern getriggerte Bursts ist 2,001 mHz. Für Sinus- und Rechtecksignale sind Frequenzen oberhalb von 6 MHz nur in der Betriebsart „infinite burst count“ zulässig.
  2. Wählen Sie die Betriebsart „Triggered burst“ oder „GatedBurst“. Wählen Sie die Betriebsart „Triggered burst“ (an der Frontplatte als "N Cycle" bezeichnet) oder den externen Modus "Gated burst" mit BURSt:MODE. Spezifizieren Sie bei Verwendung des Modus "Gated burst" die Logik-Polarität (TRUE = HIGH oder TRUE = LOW) mit BURSt:GATE:POLarity.
  3. Wählen Sie die Burst-Anzahl: Spezifizieren Sie mit dem Befehl BURSt:NCYCles für die Burst-Anzahl (Anzahl der Zyklen pro Burst) einen Wert zwischen 1 und 100.000.000 Zyklen (oder „infinite“). Dieser Parameter betrifft nur die getriggerte Burst-Betriebsart. In PRBS wird mit BURSt:NCYCles die PRBS-Bit-Anzahl eingestellt. Jeder Burst startet bei Sequenzstart.
  4. Geben Sie die Burst-Periode an: Geben Sie für die Burst-Periode (das Zeitintervall zwischen je zwei intern getriggerten Bursts) einen beliebigen Wert von 1 μs bis 8000 Sekunden ein. verwenden Sie dazu den Befehl BURSt:INTernal:PERiod. Dieser Parameter betrifft nur die intern getriggerte Burst-Betriebsart.
  5. Spezifizieren Sie die Burst-Start-Phase: Spezifizieren Sie für die Burst-Start-Phase mit dem Befehl BURSt:PHASe einen Wert von -360 bis +360 Grad.
  6. Wählen Sie die Triggerquelle: Wählen Sie die Triggerquelle mit dem Befehl TRIGger[1|2]:SOURce. Dieser Parameter betrifft nur die getriggerte Burst-Betriebsart.
  7. Aktivieren Sie die Burst-Betriebsart: Aktivieren Sie den Burst-Modus nach der Konfiguration anderer Parameter (BURSt:STATe ON).

Der folgende Code bewirkt das unten abgebildete Oszilloskopbild.

APPLy:SIN 1e5,3 VPP,0
BURS:MODE TRIG
BURS:NCYC 3
BURS:INT:PER 4,4e-5
BURS:PHAS 0
TRIG:SOUR IMM
BURS:STAT ON
OUTP 1

Burst-Modi

Es gibt zwei Burst-Modi, siehe nachstehende Beschreibung. Das Gerät kann nicht beide Burst-Betriebsarten gleichzeitig aktivieren.

  • Betriebsart Triggered Burst (Standardeinstellung): Das Gerät gibt jedes Mal bei Empfang eines Triggers ein Signal für eine Anzahl von Zyklen aus (Burst-Anzahl). Nach der Ausgabe der spezifizierten Anzahl von Zyklen stoppt das Gerät und wartet auf den nächsten Trigger. Das Gerät kann einen internen Trigger verwenden, um einen Burst-Vorgang auszulösen. Sie können auch durch Drücken der Frontplattentaste [Trigger] ein externes Triggersignal auf den rückseitigen Ext Trig Anschluss anwenden, oder einen Softwaretriggerbefehl von der Remoteschnittstelle senden.
  • Betriebsart External Gated Burst: Der Geräteausgang ist entweder "on" oder "off", je nach dem Pegel des externen Signals am rückseitigen Ext Trig Anschluss. Wenn das Signal sich im Zustand WAHR befindet, gibt das Gerät ein kontinuierliches Signal aus. Geht das Signal in den Zustand FALSE über, wird der aktuelle Signalzyklus beendet, die Ausgangsspannung bleibt auf dem durch die Start-Burst-Phase der Signalform vorgegebenen Wert.

Folgende Tabelle zeigt, welche Modi mit welchen Burst-Funktionen verknüpft sind.

 | Burst-Betriebsart BURSt:MODE | Burst-Anzahl BURSt:NCYCles | Burst-Periode BURSt:INTernal:PERiod | „Burst Phase“ BURSt:PHASe | Triggerquelle TRIGger[1|2]:SOURce
Getriggerter Burst-Modus: Interner Trigger | TRIGgered | Verfügbar | Verfügbar | Verfügbar | IMMediate
Getriggerter Burst-Modus: Externer Trigger | TRIGgered | Verfügbar | Nicht verwendet | Verfügbar | EXTernal, BUS
Betriebsart „Gated Burst“: Externer Trigger | GATed | Nicht verwendet | Nicht verwendet | Verfügbar | Nicht verwendet

Der Unterschied zwischen "Gated burst" und "angesteuerter Ausgang" besteht darin, dass ein "Gated burst" synchron startet und stoppt und vollständige Signalzyklen verwendet, während ein "angesteuerter Ausgang" den Geräteausgang mit einem externen Trigger asynchron ein- oder ausschaltet, unabhängig von der Signalphase.

Wird das Tastverhältnis auf ein getriggertes Burst-Rechtecksignal geändert, wenn der Triggermodus auf Timer gestellt ist, endet der aktuelle Burst und ein zusätzlicher Burst wird ausgeführt, bevor das Tastverhältnis des Burst wechselt.

[SOURce[1|2]:]BURSt:GATE:POLarity {NORMal|INVerted}
[SOURce[1|2]:]BURSt:GATE:POLarity?

Wählt true-high (NORMal) oder true-low (INVerted) Logikwerte am rückseitigen Ext Trig Anschluss für einen "externally-gated burst".

Parameter | Typische Rückgabe
{NORMal|INVerted}, Standard NORMal | NORM oder INV
Wählen Sie einen True-low Logikwert für einen "externally-gated burst": BURS:GATE:POL INV

[SOURce[1|2]:]BURSt:INTernal:PERiod {<seconds>|MINimum|MAXimum}
[SOURce[1|2]:]BURSt:INTernal:PERiod? [{MINimum|MAXimum}]

Dieser Befehl spezifiziert die Burst-Periode für intern getriggerte Bursts.

Parameter | Typische Rückgabe
1 µs bis 8000 s, Standard 10 ms | +1.200000000000000E+01
Stellt die Burst-Periode auf 12 Sekunden ein: BURS:INT:PER 12
  • Die Burst-Periode ist die Zeit zwischen den Starts aufeinanderfolgender Bursts.
  • Wird verwendet, wenn IMMediate Triggering aktiviert ist (TRIGger[1|2]:SOURce IMMediate). Wird ignoriert, wenn die manuelle oder externe Triggerung aktiviert ist (oder mit dem Modus "gated Burst").
  • Für 33500 Series Geräte muss die Burst-Periode folgender Formel entsprechen:

    Burst-Periode > (Burst-Anzahl / Signalfrequenz) + 1 μs.

    Für 33600 Series Geräte muss die Burst-Periode folgender Formel entsprechen:

    Burst-Periode > (Burst-Anzahl / Signalfrequenz) + 500 ns mit einer Mindest-Burst-Periode von 1 μs.
  • Wenn die Burst-Periode zu kurz ist, wird sie vom Gerät automatisch auf einen geeigneten Wert abgeändert. Über die Remote-Schnittstelle wird ebenfalls der Fehler "Settings conflict" generiert.

[SOURce[1|2]:]BURSt:MODE {TRIGgered|GATed}
[SOURce[1|2]:]BURSt:MODE?

Wählt die Burst-Betriebsart.

Parameter | Typische Rückgabe
{TRIGgered|GATed}, Standard TRIGgered | TRIG oder GAT
Torgesteuerte Burst-Betriebsart einstellen BURS:MODE GATED
  • TRIGgered: Das Gerät gibt bei jedem Eingang eines Triggers von der Triggerquelle (TRIGger[1|2]:SOURce) ein Signal für eine bestimmte Anzahl von Zyklen aus (Burst-Anzahl).
  • In der Betriebsart GATed Burst ist das Ausgangssignal an oder aus, je nach dem Signal am rückseitigen Ext Trig Anschluss. Wählen Sie die Polarität dieses Signals mit dem Befehl BURSt:GATE:POLarity. Wenn das Torsignal sich im Zustand WAHR befindet, gibt das Gerät ein kontinuierliches Signal aus. Geht das Torsignal in den Zustand FALSE über, wird der aktuelle Signalzyklus beendet. Das Gerät stoppt und die Ausgangsspannung bleibt auf dem durch die Start-Burst-Phase der Signalform vorgegebenen Wert. Bei der Signalform „Noise“ wird die Signalausgabe beim TRUE/FALSE-Übergang des Torsignals sofort beendet.
  • GATed: Burst-Anzahl, Burst-Periode und Triggerquelle werden nicht berücksichtigt (diese werden nur für die Betriebsart „Triggered Burst“ verwendet). Wenn ein manueller Trigger eingeht (TRIGger[1|2] ), wird er ignoriert und kein Fehler generiert.

[SOURce[1|2]:]BURSt:NCYCles {<num_cycles>|INFinity|MINimum|MAXimum}
[SOURce[1|2]:]BURSt:NCYCles? [{MINimum|MAXimum}]

Stellt die Anzahl der Zyklen ein, die pro Burst eingestellt werden müssen (nur in der Betriebsart „Triggered Burst“).

Parameter | Typische Rückgabe
Ganzzahl von 1 (Standard) bis 100.000.000, wie folgt begrenzt | +5,000000000000000E+01
Anzahl der pro Burst ausgegebenen Zyklen: BURS:NCYC 50
  • Mit TRIGger[1|2]:SOURce IMMediate muss die Burst-Anzahl kleiner sein als das Produkt der maximalen Burst-Periode (8000 s) und der Signalfrequenz, wie unten dargestellt.

    Burst-Anzahl < (maximale Burst-Periode)(Signalfrequenz)
  • Vergrößern Sie dann die Burst-Periode automatisch bis zum Maximalwert, damit sie mit der Burst-Anzahl vereinbar ist (die Signalfrequenz bleibt unverändert). Über die Remote-Schnittstelle wird ebenfalls der Fehler "Settings conflict" generiert.
  • In der Burst-Betriebsart Gated ist die Burst-Anzahl ohne Bedeutung. Wenn Sie jedoch die Burst-Anzahl ändern, während das Gerät sich in der Burst-Betriebsart „Gated“ befindet, behält das Gerät die neue Burst-Anzahl „im Gedächtnis“ und verwendet nach dem Umschalten in die Betriebsart „Triggered“ diesen Wert.

[SOURce[1|2]:]BURSt:PHASe {<angle>|MINimum|MAXimum}
[SOURce[1|2]:]BURSt:PHASe? [{MINimum|MAXimum}]

Wählt den Startphasenwinkel für den Burst.

Parameter | Typische Rückgabe
-360 bis +360 Grad, Radiant von -2p bis +2p oder -(Periode) bis +(Periode), gemäß UNIT:ANGLe. Standard 0. | +6,0000000000000E+01
Einstellen der Start-Burst-Phase auf 60 Grad: UNIT:ANGLE DEG BURS:PHAS 60
  • Beachten Sie, dass BURSt:PHASe anstatt der Ausgangsphase verwendet wird, und bei Aktivierung von Burst die Ausgangsphase auf 0 steht.
  • Bei den Signalformen Sinus, Rechteck und Sägezahn entspricht 0 Grad dem Punkt, an dem das Signal 0 V (oder den DC-Offset) von unten nach oben schneidet. Bei Ausgangssignalen entspricht 0 Grad dem ersten Signalpunkt. Die Startphase hat keine Auswirkungen auf Rauschen.
  • Für Arbiträrsignale bei 33500 Series Geräten steht BURSt:PHASe nur zur Verfügung, wenn das Signal höchstens 1.000.000 Punkte hat.
  • Die Start-Phase wird auch in der "Gated Burst"-Betriebsart verwendet. Geht das Torsignal in den Zustand FALSE über, wird der aktuelle Signalzyklus beendet und der Ausgang bleibt bei dem Spannungswert der Start-Burst-Phase.

[SOURce[1|2]:]BURSt:STATe {ON|1|OFF|0}
[SOURce[1|2]:]BURSt:STATe?

Aktiviert oder deaktiviert den Burst-Modus.

Parameter | Typische Rückgabe
{ON|1|OFF|0}, Standard OFF | 0 (OFF) oder 1 (ON)
Aktivieren der Burst-Betriebsart: BURS:STAT ON
  • Die Ausgangsphase wird auf 0 gestellt, wenn Burst aktiviert ist.
  • Um ein mehrmaliges Umschalten der Signalform zu vermeiden, den Burst-Modus erst nach der Konfiguration anderer Parameter aktivieren.
  • Die Burst-Betriebsart kann nicht mit einer Wobbel- oder Modulationsbetriebsart kombiniert werden. Wenn Sie die Burst-Betriebsart wählen, wird die Wobbelbetriebsart oder die Modulationsbetriebsart automatisch deaktiviert.


CALibration Subsystem

Das CALibration Subsystem wird zum Kalibrieren des Geräts verwendet.

Befehle und Anfragen

CALibration[:ALL]?

CALibration:COUNt?

CALibration:SECure:CODE <new_code>

CALibration:SECure:STATe {ON|1|OFF|0} [,<code>]
CALibration:SECure:STATe?

CALibration:SETup <step>
CALibration:SETup?

CALibration:STORe

CALibration:STRing "<string>"
CALibration:STRing?

CALibration:VALue <value>
CALibration:VALue?

CALibration[:ALL]?

Führt eine Kalibrierung mit dem Kalibrierungswert (CALibration:VALue) aus. Der Kalibrierschutz des Geräts muss für die Kalibrierung deaktiviert sein (CALibration_SECure_STATe OFF,<code>).

Parameter | Typische Rückgabe
(keine) | +0 (pass) oder +1 (fehlgeschlagen)
Kalibrierung mit dem aktuellen Wert: CAL?
  • CALibration:SETup muss der Abfrage CALibration? stets vorangehen.
  • Erhöht den Kalibrierungszähler des Geräts (CALibration:COUNt?).
  • Ändert die flüchtige Version der Kalibrierungskonstanten. Verwenden Sie CALibration:STORe, um diese Konstanten nach der Kalibrierung im nichtflüchtigen Speicher zu speichern.

CALibration:COUNt?

Gibt die Anzahl der ausgeführten Kalibrierungen zurück. Lesen und zeichnen Sie die ursprüngliche Anzahl auf, wenn Sie Ihr Gerät vom Werk erhalten.

Parameter | Typische Rückgabe
(keine) | +117
Die Kalibrierungszahl ausgeben: CAL:COUN?
  • Da der Wert bei jedem Kalibrierpunkt ansteigt (jeden CALibration:ALL?), fügt eine komplette Kalibrierung viele Zahlen hinzu.
  • Sie können die Zahl unabhängig von der Sicherung des Geräts anzeigen.
  • Die Einstellung ist permanent; sie bleibt bei einem Aus- und Wiedereinschalten des Geräts oder einem *RST erhalten.

CALibration:SECure:CODE <new_code>

Stellt den Sicherheitscode ein, um nicht genehmigte Kalibrierungen zu verhindern.

Parameter | Typische Rückgabe
Zeichenfolge ohne Anführungszeichen, mit bis zu 12 Zeichen Muss mit einem Buchstaben (A-Z) beginnen Kann Buchstaben, Zahlen (0-9) und Unterstriche enthalten | (keine)
Neuen Sicherheitscode einstellen: CAL:SEC:CODE MY_CODE_272
  • Der werkseitige Standardsicherheitscode ist modellabhängig:

    Modelle | Sicherheitscode
    33521A und 33522A | AT33520A
    335XXB | AT33500
    33600 Series | AT33600
  • Ändern des Codes: Deaktivieren Sie den Kalibrierungsspeicher mit dem alten Code und stellen Sie dann den neuen Code ein.
  • Sollten Sie den Sicherheitscode vergessen haben, siehe Gerät ohne Sicherheitscode entsichern.
  • Die Einstellung ist permanent; sie bleibt bei einem Aus- und Wiedereinschalten des Geräts oder einem *RST erhalten.

CALibration:SECure:STATe {ON|1|OFF|0} [,<code>]
CALibration:SECure:STATe?

Dieser Befehl deaktiviert oder aktiviert den Kalibrierschutz. Für die Kalibrierung muss der Kalibrierschutz mit dem Code (CALibration:SECure:CODE) deaktivert werden.

Parameter | Typische Rückgabe
{ON|1|OFF|0}, Standard ON <code> ist eine Zeichenfolge ohne Anführungszeichen mit bis zu 12 Zeichen | 0 (OFF) oder 1 (ON)
Kalibrierschutz deaktivieren: CAL:SEC:STAT OFF,MY_CODE_272 Kalibrierung aktivieren: CAL:SEC:STAT ON
  • Der <Code> ist optional und dient der Sicherung des Geräts, muss jedoch korrekt sein.
  • Frontplatte und Remoteschnittstellenkalibrierung nutzen den gleichen Code. Wenn Sie den Kalibrierschutz des Geräts über eine Schnittstelle aktivieren, verwenden Sie den gleichen Code, um es über die andere Schnittstelle zu deaktivieren.
  • Die Einstellung ist permanent; sie bleibt bei einem Aus- und Wiedereinschalten des Geräts oder einem *RST erhalten.

CALibration:SETup <step>
CALibration:SETup?

Konfiguriert die Ausführung des Kalibrierungsschritts (Standard1). Der Kalibrierschutz des Geräts muss für die Kalibrierung deaktiviert sein (CALibration_SECure_STATe OFF,<code>). Ausführlichere Informationen finden Sie unter Kalibrierungssicherheit.

Parameter | Typische Rückgabe
Ganzzahl, Standardwert 1 | +16
Vorbereitung für Kalibrierung Schritt 5: CAL:SET 5
  • Die Einstellung ist permanent; sie bleibt bei einem Aus- und Wiedereinschalten des Geräts oder einem *RST erhalten.

CALibration:STORe

Nimmt Kalibrierkonstanten in den flüchtigen Speicher (CALibration:ALL?) auf und überträgt sie in den permanenten Speicher, wo sie durch Ein- und Ausschalten oder *RSTnicht geändert werden. Führen Sie dies am Ende der Kalibrierung durch, um einen Verlust der Änderungen zu verhindern.

Parameter | Typische Rückgabe
(keine) | (keine)
Speichern der Kalibrierungskonstanten im permanenten Speicher: CAL:STOR

CALibration:STRing "<string>"
CALibration:STRing?

Speichert eine Meldung mit bis zu 40 Zeichen im Kalibrierspeicher. Häufige Meldungen beinhalten das Datum der letzten Kalibrierung, das Fälligkeitsdatum der nächsten Kalibrierung oder Kontaktinformationen für die Kalibrierungsabteilung. Der Kalibrierschutz des Geräts muss deaktiviert sein (CALibration_SECure_STATe OFF,<code>), um diesen String zu speichern.

Parameter | Typische Rückgabe
Zeichenfolge ohne Anführungszeichen mit bis zu 40 Zeichen Kann Buchstaben, Ziffern, Leerstellen und andere allgemeine Zeichen enthalten. | "LAST CAL OCT 31 2011, DUE OCT 31 2012" (Ist keine Textzeichenkette gespeichert, wird "" angegeben)
CAL:STR "FOR CAL HELP, CALL JOE AT EXT 1234"
  • Kann nur von der Remoteschnittstelle gespeichert werden, wenn der Kalibrierschutz des Geräts deaktiviert ist (CALibration:SECure:STATe OFF).
  • Sie können die Meldung über die Frontplatte oder die Remoteschnittstelle lesen, unabhängig davon, ob das Gerät gesichert ist.
  • Durch Speichern einer Kalibriermeldung wird die letzte Meldung überschrieben.
  • Die Einstellung ist permanent; sie bleibt bei einem Aus- und Wiedereinschalten des Geräts oder einem *RST erhalten.

CALibration:VALue <value>
CALibration:VALue?

Gibt den Wert des bekannten Kalibriersignals an.

Parameter | Typische Rückgabe
Numerisch, Standard 0,0 | +2,37000000E-002
Kalibrierungswert 0,0237 angeben: CAL:VAL 2,37E-2
  • Die Einstellung ist permanent; sie bleibt bei einem Aus- und Wiedereinschalten des Geräts oder einem *RST erhalten.


COMBine:FEED

[SOURce[1|2]:]COMBine:FEED {CH1|CH2|NONE}
[SOURce[1|2]:]COMBine:FEED?

Aktiviert oder deaktiviert die Kombination beider Kanalausgänge eines Zweikanalgeräts in einem einzigen Kanalanschluss. Das Schlüsselwort "SOURce" (Standard, SOURce1) spezifiziert den Grundkanal und <source> spezifiziert den Kanal, der mit dem Grundkanal kombiniert werden soll.

Parameter | Typische Rückgabe
{CH1|CH2|NONE}, Standard NONE | CH1, CH2 oder NONE
Einstellen der COMBine:FEED Quelle für Grundkanal 1 auf Kanal 2: COMB:FEED CH2
  • COMBine:FEED ermöglicht das Addieren digitaler Daten von beiden Kanälen, zur Erstellung eines Ausgangssignals am Ausgangs-A/D-Wandler für den Grundkanal.
  • Nur ein Kanal kann gleichzeitig im COMBine:FEED laufen
  • Im Gegensatz zu den Befehlen Modulation und SUM kann COMBine:FEED zwei modulierte Signale hinzufügen.
  • COMBine:FEED kann quadratmodulierte Signale von den beiden Kanälen generieren, die miteinander zu einem einzigen Anschluss addiert werden.
  • Zur Verwendung von COMBine:FEED müssen Sie zunächst alle Parameter für die einzelnen Kanäle konfigurieren.
  • Die Signale können kombiniert werden, haben aber evtl. einen feststehenden Phasenoffset zwischen den Kanälen.
  • Sie können einem modulierten Signal des Grundkanals mit COMBine:FEED Rauschen von einem zweiten Kanal hinzufügen.
  • Wenn durch COMBine:FEED der kombinierte Ausgang die Ausgangswerte des Geräts oder die programmierten Grenzwerte überschreitet, stellt das Gerät COMBine:FEED auf NONE und berichtet einen Einstellungskonflikt-Fehler.
  • Signale werden in digitaler Form kombiniert. Wenn zwei Signale mit signifikant unterschiedlichen Amplituden kombiniert werden, kann das Signal mit der kleineren Amplitude über eine reduzierte Auflösung verfügen (proportional zum Verhältnis der beiden Amplituden).
  • Eine Änderung der Funktionsamplitude oder der Summenamplitude des Masters oder eines kombinierten Kanals ändert nicht die Amplitude oder den Offset anderer Funktionen oder Kanäle. Wenn eine Änderung der Funktions- oder Summenamplitude des Masters oder kombinierten Kanals zur Folge hätte, dass der Ausgangswert oder die programmierten Grenzwerte überschritten werden, wird der Amplitudenwert ausgeschnitten und ein Einstellungskonflikt-Fehler berichtet.
  • Eine Änderung des Kanal-Offsets des Masters oder des kombinierten Kanals ändert nicht die Amplitude oder den Offset anderer Funktionen oder Kanäle. Wenn eine Änderung des Kanal-Offsets des Masters oder des kombinierten Kanals zur Folge hätte, dass der Ausgangswert oder die programmierten Grenzwerte überschritten werden, wird der Amplitudenwert ausgeschnitten und ein Einstellungskonflikt-Fehler berichtet.
  • Wenn ein Einschalten der Grenzwerte oder eine Anpassung der programmierten Grenzwerte einen Grenzwert zur Folge hätte, der niedriger ist als ein Höchstsignalwert oder höher als ein Mindestsignalwert ist, werden die Grenzwerte nicht eingeschaltet oder angepasst und das Gerät berichtet einen Einstellungskonflikt-Fehler.


DATA Subsystem

Das DATA-Subsystem verwaltet benutzerdefinierte Arbiträrsignale:

  • [SOURce[1|2]:]DATA:ARBitrary2:FORMat {AABB|ABAB} - gibt die Reihenfolge für Bytes einer dualen Arbiträrsignaldatei an (erfordert den optionalen IQ-Player).
  • [SOURce[1|2]:]DATA:ARBitrary[1|2] <arb_name>, {<binary_block>|<value>, <value>, . . .} - lädt normalisierte Werte des Arbiträrsignals in den Signalspeicher herunter
  • [SOURce[1|2]:]DATA:ARBitrary[1|2]:DAC <arb_name>, {<binary_block>|<value>, <value>, . . .} - lädt DAC-Codes des Arbiträrsignals in den Signalspeicher herunter
  • [SOURce[1|2]:]DATA:ATTRibute:AVERage? [<arb_name>] - gibt einen arithmetischen Durchschnittswert aller Datenpunkte für ein Arbiträrsignal oder eine Sequenz zurück
  • [SOURce[1|2]:]DATA:ATTRibute:CFACtor? [<arb_name>]ATA:ATTRibute:CFACtor? - gibt den Scheitelfaktor aller Datenpunkte eines Arbiträrsignals oder einer Sequenz zurück
  • [SOURce[1|2]:]DATA:ATTRibute:POINts? [<arb_name>] - gibt die Anzahl der Datenpunkte für ein Arbiträrsignal oder eine Sequenz zurück
  • [SOURce[1|2]:]DATA:ATTRibute:PTPeak? [<arb_name>] - gibt den Spitzenwert aller Datenpunkte in einem Arbiträrsignal oder einer Sequenz zurück
  • [SOURce[1|2]:]DATA:SEQuence <block_descriptor> - kombiniert zuvor geladene Arbiträrsignale zu einer Sequenz
  • [SOURce[1|2]:]DATA:VOLatile:CATalog? - gibt die Inhalte des flüchtigen Signalspeichers wieder, einschließlich der Arbiträrsignale und Sequenzen
  • [SOURce[1|2]:]DATA:VOLatile:CLEar - löscht den flüchtigen Signalspeicher
  • [SOURce[1|2]:]DATA:VOLatile:FREE? - gibt die Anzahl verfügbarer (freier) Punkte im flüchtigen Speicher an

Beispiele

Folgendes Beispiel verwendet DATA-Befehle zur Einrichtung einer Arbiträrsignalsequenz.

Der unten angegebene Befehl DATA:SEQuence ist ein Beispiel für einen Block bestimmter Länge. Das Symbol "#3" am Anfang gibt an, dass die drei darauffolgenden Ziffern anzeigen, wie viele Zeichen der Block enthält. Die darauffolgende Zahl "164" zeigt an, dass der nachfolgende String 164 Zeichen enthält.

Beachten Sie, dass der lange DATA:SEQuence Befehl aus Gründen der Lesbarkeit auf mehrere Zeilen aufgeteilt wird.

Beachten Sie, dass die Anführungszeichen im Befehl DATA:SEQuence optional sind.

*CLS
*RST

MMEM:LOAD:DATA "INT:\BUILTIN\HAVERSINE.arb"
MMEM:LOAD:DATA "INT:\BUILTIN\CARDIAC.arb"
MMEM:LOAD:DATA "INT:\BUILTIN\GAUSSIAN.arb"

DATA:SEQuence #3164"testSeq","INT:\BUILTIN\HAVERSINE.arb",0,repeat,highAtStartGoLow,30,
"INT:\BUILTIN\CARDIAC.arb",0,repeat,maintain,10,
"INT:\BUILTIN\GAUSSIAN.arb",0,repeat,maintain,10
FUNC:ARB "testSeq"

FUNC ARB
OUTPUT1 ON

Diese Sequenz führt das Haversine-Signal 30 mal und dann das EKG- und Gaußsche Signal jeweils 10 mal aus. Das Haversine-Signal erzwingt einen hohen Markerstatus zu Beginn jedes Vorgangs und setzt ihn dann auf den Marker-Punkt herab. Die anderen beiden Signale behalten die Marker-Einstellung bei.

Format für <arb_name>

Viele DATA-Befehle verwenden den Namen eines Arbiträrsignals. Dabei gelten folgende Regeln:

  • <arb_name> muss passen zu:
  • Signal, das bereits in den Signalspeicher geladen wurde
  • Signal, das bereits im INTERNAL oder USB-Massen-Speichergerät besteht
  • Unter MMEMory:LOAD:DATA[1|2], DATA:ARBitrary oder DATA:ARBitrary:DAC sind gültige Formate für <arb_name> aufgeführt.

[SOURce[1|2]:]DATA:ARBitrary2:FORMat {AABB|ABAB}

(Gilt nur für Geräte mit der optionalen Funktion IQ player.)

Gibt an, ob das Format für Datenpunkte in den Befehlen DATA:ARB2 und DATA:ARB2:DAC interleaved ist (ABAB) oder alle von Kanal 2 auf die von Kanal 1 folgen (AABB).

Hinweis

Das Schlüsselwort ARBitrary2 kann ausgeschrieben werden, es muss jedoch als ARB2 abgekürzt werden. Die Abkürzung ARB ist nicht zulässig.

Parameter | Typische Rückgabe
{AABB|ABAB} | AABB oder ABAB
Angabe eines Interleaved-Datenformat für Daten eines dualen Arbiträrsignals: DATA:ARB2:FORM ABAB
  • Das Schlüsselwort SOURce ist für diesen Befehl ohne Bedeutung.
  • Möchten Sie ein 3-DAC-Zählsignal an Kanal 1 und ein 4-DAC-Zählsignal an Kanal 2, gibt das AABB-Format folgende Reihenfolge für das Senden der Daten vor: 3, 3, 3, 3, 3, 3, 3, 3, 4, 4, 4, 4, 4, 4, 4, 4. Das Format ABAB gäbe die Reihenfolge 3, 4, 3, 4, 3, 4, 3, 4, 3, 4, 3, 4, 3, 4, 3, 4 vor.

[SOURce[1|2]:]DATA:ARBitrary[1|2] <arb_name>, {<binary_block>|<value>, <value>, . . .}

[SOURce[1|2]:]DATA:ARBitrary[1|2]:DAC <arb_name>, {<binary_block>|<value>, <value>, . . .}

Download von Ganzzahlwerten, die DAC-Codes (DATA:ARBitrary[1|2]:DAC) oder Gleitkommazahlenwerten (DATA:ARBitrary[1|2]) entsprechen, in den flüchtigen Speicher des Signals – entweder als eine Liste kommagetrennter Werte oder als binären Datenblock. Die DAC Codes reichen von -32.768 bis +32.767 für 33500 Series und 33600 Series Geräte.

Hinweis

Das optionale [1|2] nach dem Schlüsselwort ARBitrary gibt an, ob die herunterzuladenden Daten einen (Standard) oder zwei Datenwerte enthalten.

Für die Verwendung von dualen Arbiträrsignaldateien (Einzeldateien, die zwei Kanäle mit Arbiträrsignaldateien enthalten) ist der optionale IQ Player erforderlich.)

Parameter | Typische Rückgabe
<arb_name> Eine Zeichenfolge ohne Anführungszeichen, mit bis zu 12 Zeichen. | (keine)
<binary_block> Ganzzahlwerte von -32767 bis +32767 oder Gleitkommazahlenwerte von -1.0 bis +1.0 in Format Arbiträr-Block bestimmter Länge (Details siehe unten). 8 bis 1M oder 16M Proben pro Signal, je nach Modell und Optionen.

Blockdaten mit bestimmter Länge ermöglichen die Übertragung jeder Art geräteabhängiger Daten als Serie von binären Datenbytes (8 Bit). Dies ist besonders nützlich, um große Datenmengen oder erweiterte ASCII-Codes mit 8 Bit zu übermitteln.
<value> kommagetrennte Werte mit Ganzzahlwerten von -32.767 bis +32.767 oder Gleitkommazahlenwerte von -1,0 bis +1,0. 8 bis 65.536 Punkte.

Download einer kommagetrennten Liste von neun Signalpunkten in den Signalspeicher:
DATA:ARB:DAC myArb, 32767, 24576, 16384, 8192, 0, -8192, -16384, -24576, - 32767

Download von neun Signalpunkten in den Signalspeicher (als binärer Block). <PMT> gibt den Abschluss der binären Daten an. Kann ein Zeilenumbruchzeichen sein oder das letzte Byte von your_binary_data kann das Ende oder die Identifikation aktivieren.
DATA:ARB myArb, #236<36 bytes of your_binary_data><PMT>

Download einer kommagetrennten Liste von neun Signalpunkten in den Signalspeicher:
DATA:ARB myArb, 1, .75, .50, .25, 0, -.25, -.50, -.75, -1

Download von acht Signalpunkten eines dualen Arbiträrsignals in den Signalspeicher, als kommagetrennte Liste von DAC Codes. Enthält insgesamt 16 Werte, acht für jeden der beiden Kanäle. Beachten Sie, dass die Daten Interleaved sind (ABAB) und die positiven Werte somit alle auf Kanal 1 sind und die negativen Werte auf Kanal 2:
DATA:ARB2:FORM ABAB
DATA:ARB2:DAC myArb, 30000, -10000, 29000, -9000, 27000, -7000, 24000, -4000, 27000, -7000, 29000, -9000, 30000, -10000, 29000, -9000

Laden Sie die gleichen Beispiele wie oben herunter, aber im AABB Format:
DATA:ARB2:FORM AABB
DATA:ARB2:DAC myArb, 30000, 29000, 27000, 24000, 27000, 29000, 30000, 29000, -10000, -9000, -7000, -4000, -7000, -9000, -10000, -9000
  • Jeder Datenpunkt ist entweder ein 16-Bit-Ganzzahlwert von -32.767 bis +32.767 oder ein 32-Bit-Gleitkommazahlenwert von -1,0 bis +1,0. Daher entspricht die Gesamtzahl von Bytes stets der zwei- oder vierfachen Anzahl von Datenpunkten im Signal. So sind beispielsweise 16.000 Bytes erforderlich, um ein Signal mit 8.000 Punkten als Ganzzahlen herunterzuladen, es sind jedoch 32.000 Bytes erforderlich, um das gleiche Signal als Gleitkommazahlenwerte herunterzuladen.
  • Die Werte -32767 und +32767 oder -1,0 bis +1,0 entsprechen den Spitzenwerten des Signals (bei einem Offset von 0 V). Setzen Sie z. B. die Offset-Amplitude auf 10 Vpp, entspricht +32767 einem Wert von +5 V und -32767 einem Wert von -5 V.
  • Verwenden Sie FORMat:BORDer zur Auswahl der Byte-Reihenfolge für Binärdatenblock-Übertragung.
  • Verwenden Sie DATA:ARB2:FORMat zur Angabe, ob duale Arbiträrsignale interleaved oder sequenziell sind (Kanal 1 gefolgt von Kanal 2).
  • Die Angabe eins Signals, das bereits geladen wurde, generiert die Fehlermeldung "Specified arb waveform already exists". Das Löschen eines bestehenden Signals erfordert das Löschen des gesamten Signalspeichers mit dem Befehl DATA:VOLatile:CLEar.
  • Die insgesamt verfügbare Abtastgröße für alle Signale, die pro Kanal geladen werden, beträgt 1 MSa oder 16 MSa (33500 Series) oder 4 MSa oder 64 MSa (33600 Series), je nach Modell und Optionen. Ein neues Signal kann durch bereits geladene Signale begrenzt werden.
Die maximale Signalgröße für den integrierten Signaleditor beträgt unabhängig von den installierten Optionen 1 MSa.

[SOURce[1|2]:]DATA:ATTRibute:AVERage? [<arb_name>]

Gibt den arithmetischen Durchschnittswert aller Datenpunkte des spezifizierten Arbiträrsignals zurück, in den INTERNEN oder USB Speicher oder in den Signalspeicher geladen.

Parameter | Typische Rückgabe
<arb_name> ist jeder gültige Dateiname. Ist nichts angegeben, ist das Standardsignal <arb_name> das aktuell aktive Arbiträrsignal (Auswahl mit dem Befehl FUNCtion:ARBitrary). | +2,47199927E‑002
Rückgabe des Durchschnittwerts aller Punkte, die in "SINC" gespeichert sind. DATA:ATTR:AVER? "INT:\BuiltIn\SINC.arb"
  • Die Abfrage eines nicht existierenden Signals generiert den Fehler "Specified arb waveform does not exist".
  • <arb_name> kann ein Dateiname sein (der mit dem Befehl MMEMory:LOAD:DATA[1|2]) in den Speicher gelangt) oder ein Name, der durch die Befehle DATA:ARBitrary oder DATA:ARBitrary:DAC generiert wird.

[SOURce[1|2]:]DATA:ATTRibute:CFACtor? [<arb_name>]

Rückgabe des Scheitelfaktors aller Datenpunkte für das angegebene Arbiträrsignalsegment im INTERNEN oder im USB Speicher, oder in den Signalspeicher geladen.

Parameter | Typische Rückgabe
<arb_name> ist jeder gültige Dateiname. Ist nichts angegeben, ist das Standardsignal <arb_name> das aktuell aktive Arbiträrsignal (Auswahl mit dem Befehl FUNCtion:ARBitrary). | +1,72513640E+000
Rückgabe des Scheitelfaktors aller Datenpunkte, die in "NEG_RAMP" gespeichert sind. DATA:ATTR:CFAC? "INT:\BuiltIn\NEG_RAMP.arb"
  • Der Scheitelfaktor ist das Verhältnis des Spitzenwerts zum RMS-Wert des Signals.
  • Die Abfrage eines nicht existierenden Signals generiert den Fehler "Specified arb waveform does not exist".
  • <arb_name> kann ein Dateiname sein (der mit dem Befehl MMEMory:LOAD:DATA[1|2]) in den Speicher gelangt) oder ein Name, der durch die Befehle DATA:ARBitrary oder DATA:ARBitrary:DAC generiert wird.

[SOURce[1|2]:]DATA:ATTRibute:POINts? [<arb_name>]

Rückgabe der Anzahl von Punkten im angegebenen Arbiträrsignalsegment im INTERNEN oder im USB Speicher, oder in den Signalspeicher geladen.

Parameter | Typische Rückgabe
<arb_name> ist jeder gültige Dateiname. Ist nichts angegeben, ist das Standardsignal <arb_name> das aktuell aktive Arbiträrsignal (Auswahl mit dem Befehl FUNCtion:ARBitrary). | +250
Rückgabe der Anzahl von Datenpunkten in "EXP_RISE": DATA:ATTR:POIN? "INT:\BuiltIn\EXP_RISE.arb"
  • <arb_name> kann ein Dateiname sein (der mit dem Befehl MMEMory:LOAD:DATA[1|2]) in den Speicher gelangt) oder ein Name, der durch die Befehle DATA:ARBitrary oder DATA:ARBitrary:DAC generiert wird.

[SOURce[1|2]:]DATA:ATTRibute:PTPeak? [<arb_name>]

Berechnet den Spitze-zu-Spitze-Wert aller Datenpunkte für das angegebene Arbiträrsignalsegment im INTERNEN oder im USB Speicher (oder in den Signalspeicher geladen).

Parameter | Typische Rückgabe
Ein beliebiger gültiger Dateiname. Ist nichts angegeben, ist das Standardsignal <arb_name> das aktuell aktive Arbiträrsignal (Auswahl mit dem Befehl FUNCtion:ARBitrary). | +1,00000000E+000
Rückgabe des Spitze-zu-Spitze-Werts für "EXP_FALL": DATA:ATTR:PTP? "INT:\BuiltIn\EXP_FALL.arb"
  • <arb_name> muss passen zu:
  • Signal, das bereits in den Signalspeicher geladen wurde
  • Signal, das bereits im INTERNAL oder USB-Massen-Speichergerät besteht
  • Unter MMEMory:LOAD:DATA[1|2], DATA:ARBitrary oder DATA:ARBitrary:DAC sind gültige Formate für <arb_name> aufgeführt.
  • Einschränkungen bei Arbiträrsignalen: Bei Arbiträrsignalen ist der Amplitudenbereich eingeschränkt, falls die Signalpunkte nicht den vollen Bereich des Ausgangs-D/A-Wandlers abdecken. Z. B. nutzt das integrierte "Sinc"-Signal nicht den gesamten Wertebereich, weshalb seine maximale Amplitude auf 6,087 Vpp (in 50 Ω) begrenzt ist.
  • <arb_name> kann ein Dateiname sein (der mit dem Befehl MMEMory:LOAD:DATA[1|2]) in den Speicher gelangt) oder ein Name, der durch die Befehle DATA:ARBitrary oder DATA:ARBitrary:DAC generiert wird.

[SOURce[1|2]:]DATA:SEQuence <block_descriptor>

Definiert eine Sequenz von Signalen, die bereits mit den Befehlen MMEMory:LOAD:DATA[1|2] oder DATA:ARBitrary in den Signalspeicher geladen wurden. Der Befehl MMEMory:LOAD:DATA[1|2] kann auch eine Sequenzdatei laden, die automatisch die zugehörigen Arbiträrsignale lädt und Amplitude, Offset, Abtastrate und Filtereinrichtung umfasst.

Parameter | Typische Rückgabe
IEEE Arbiträr-Block bestimmter Länge, wie unten beschrieben. | (keine)
(siehe Beispiel)
  • Sogar Arbiträrsignale mit Millionen Punkten sind evtl. bei Anwendungen nicht ausreichend, die eine Sondersequenzierung oder eine Wiederholung von Signalen erfordern, die von Zeit oder externen Ereignissen abhängt. Die Sequenzierung von Arbiträrsignalen ermöglicht Ihnen die Anordnung und die bedingte Wiederholung von Signalen. Weniger Speicherbedarf und eine größere Anwendungsflexibilität sind die Folge.

    • Blockdaten mit bestimmter Länge ermöglichen die Übertragung jeder Art geräteabhängiger Daten als Serie von binären Datenbytes (8 Bit). Dies ist besonders nützlich, um große Datenmengen oder erweiterte ASCII-Codes mit 8 Bit zu übermitteln.

  • <block_descriptor> gehört zur Formatnummer #<n><n digits><sequence name>,<arb name1>,<repeat count1>,<play control1>,<marker mode1>, <marker point1>, <arb name2>,<repeat count2>,<play control2>,<marker mode2>, <marker point2> etc., wobei:
  • <n>die Anzahl der Stellen angibt, die zur Angabe der Blockgröße verwendet werden.
  • <n digits> einer oder mehreren Ziffern entspricht, durch die die Anzahl der kommenden Datenbytes angegeben wird.
  • <sequence name> ist ein String, ggf. mit Anführungszeichen, der den Namen der Sequenz angibt, die die Arbiträrsignale enthält, die in folgenden Parametern angegeben sind.
  • <arb name> ist ein String, ggf. mit Anführungszeichen, der den Namen des Arbiträrsignals angibt, der mit den Befehlen MMEM:LOAD:DATA[1|2] oder DATA:ARBitrary geladen wurde.
  • <repeat count> ist ein String, ggf. mit Anführungszeichen, der angibt, wie oft das Signal wiederholt wird. Dieser Wert kann von 1 bis1E6 oder unendlich reichen. Wird vom Gerät nur erkannt, wenn für Wiedergabe-Steuerelement Wiederholen eingestellt ist
  • <play control> ist ein String, ggf. mit Anführungszeichen, der angibt, wie das Arbiträrsignal in der Sequenz abgespielt wird:
  • once- einmal abspielen
  • onceWaitTrig- einmal abspielen und dann auf Trigger warten. Trigger werden nicht akzeptiert, bevor das angegebene Segment komplett abgespielt wurde.
  • repeat- so oft wiederholen, wie es durch die Wiederholungsanzahl angegeben ist
  • repeatInf- wiederholen, bis gestoppt wird (unendlich oft)
  • repeatTilTrig - wiederholen bis Auslöser, dann weiter

    Bei kleinen Wellenformen kann es einige Zyklen dauern, nachdem der Trigger zum Übergang zur nächsten Wellenform empfangen wird. Dies liegt daran, dass die Abtastwerte im Abtastpuffer gelöscht werden müssen.
  • <marker mode> ist ein String, ggf. mit Anführungszeichen, der angibt, wie sich der Marker im Arbiträrsignal verhält:
  • maintain- aktuellen Marker-Status beim Start des Segments beibehalten
  • lowAtStart- erzwingt einen niedrigen Markerstatus bei Beginn des Segments
  • highAtStart- erzwingt einen hohen Markerstatus bei Beginn des Segments
  • highAtStartGoLow- erzwingt einen hohen Markerstatus bei Beginn des Segments, dann einen niedrigen Status an der Markerposition
  • <marker point> eine Zahl, die die Markerposition im Arbiträrsignal angibt. Dieser Wert muss zwischen 4 und der Punktzahl des Arbiträrsignals minus 3 liegen.
  • Wenn Sie ein Arbiträrsignal angeben, das nicht geladen wurde, wird der Fehler "Specified arb waveform does not exist" generiert.

Beispiel für den Befehl DATA:SEQuence

Folgender Befehl erstellt eine Sequenz (namens mySequence) aus drei Segmenten (A.arb, B.arb und C.arb), die zuvor mit dem Befehl MMEMory:LOAD:DATA[1|2] vom USB-Laufwerk geladen wurden. Die Sequenz spielt A einmal und B fünfmal ab. Dann spielt sie C wiederholt ab und wartet auf einen Trigger, um fortzufahren, und schließt mit A ab. Bei jedem Segment ist der <marker point> auf 10 gestellt.

Der Befehl wird nur aus Gründen der besseren Lesbarkeit auf mehreren Zeilen dargestellt.

DATA:SEQ #3158"mySequence","USB:\A.arb",0,once,lowAtStart,10,"USB:\B.arb",5,repeat,highAtStart,10,
"USB:\C.arb",0,repeatTilTrig,maintain,10,"USB:\A.arb",0,once,lowAtStart,10

Viele Texteditoren zählen die Anzahl von Bytes im Block, indem einfach ein Textstring markiert wird. In diesem Beispiel ist die Größe 158, die Darstellung erfordert also 3 Ziffern – und somit die Kopfzeile #3158.

Für diese Vorgehensweise müssen Sie alle Arbiträrsignale vorher laden und Amplitude und Offset (oder obere und untere Pegel), Abtastrate und Filter einstellen. Unter MMEM:LOAD:DATA sehen Sie, wie alle Informationen in eine einzige Datei aufgenommen werden, statt eine Blockübertragung mit mehreren SCPI-Befehlen zu erstellen.

[SOURce[1|2]:]DATA:VOLatile:CATalog?

Gibt die Inhalte des flüchtigen Signalspeichers wieder, einschließlich der Arbiträrsignale und Sequenzen.

Parameter | Typische Rückgabe
(keine) | "INT:\BUILTIN\EXP_RISE.ARB","USB:\XYZ\A.ARB","USB:\XYZ\B.ARB","USB:\xyz\xyz.seq"
Gibt die Inhalte des flüchtigen Signalspeichers wieder, vorausgesetzt, die Signale A.arb, B.arb, und C.arb wurden vorher über eine Sequenzdatei in Kanal 1 auf USB:\xyz\xyz.seq: geladen DATA:VOL:CAT?

[SOURce[1|2]:]DATA:VOLatile:CLEar

Löscht den Signalspeicher für den angegebenen Kanal und lädt das Standardsignal neu.

Parameter | Typische Rückgabe
(keine) | (keine)
Inhalte des Signalspeichers auf Kanal 1 löschen und Standardsignal neu laden: DATA:VOL:CLE

[SOURce[1|2]:]DATA:VOLatile:FREE?

Gibt die Anzahl verfügbarer (freier) Punkte im flüchtigen Speicher an. Jedes Arbiträrsignal, das in den flüchtigen Speicher geladen wird, benötigt Speicherplatz, der in 128-Punkt-Blöcken zugewiesen wird. Somit benötigt ein Signal mit 8 bis 128 Punkten einen solchen Block, ein Signal mit 129 bis 256 Punkten zwei Blöcke etc.

Das Standardgerät enthält einen Speicher für 1 Million Punkte pro Kanal (33500 Series) oder 4 Millionen Punkte pro Kanal (33600 Series). Sie können auch die Speicherkapazität um bis zu 16M (33500 Series) oder 64M Punkte (33600 Series) erhöhen.

Parameter | Typische Rückgabe
(keine) | +382956
Rückgabe der Anzahl von Bytes im freien flüchtigen Speicher: DATA:VOL:FREE?


Einführung DISPlay Subsystem

DISPlay Subsystem

Das DISPlay-Subsystem steuert das Display des Geräts.

Beispiel

Folgendes Programm schaltet das Display des Geräts ab und zeigt dann eine Meldung an, dass das Gerät nicht berührt werden soll.

DISP OFF
DISP:TEXT "Test running. Please do not touch."

Befehle

Das DISPlay Subsystem umfasst folgende Befehle.

  • DISPlay {ON|1|OFF|0} - aktiviert oder deaktiviert das Display
  • DISPlay:FOCus - wählt den Kanal in der Vorderansicht bei einem Zwei-Kanal-Gerät
  • DISPlay:TEXT "<string>" - zeigt eine Textmeldung auf dem Display an
  • DISPlay:TEXT:CLEar - löscht eine Textmeldung aus dem Display
  • DISPlay:UNIT:ARBRate {SRATe|FREQuency|PERiod} - wählt die Maßeinheiten der Arbiträrsignale
  • DISPlay:UNIT:PULse {WIDTh|DUTY} - wählt die Methode zur Angabe von Pulsbreiten
  • DISPlay:UNIT:RATE {FREQuency|PERiod} - wählt die Maßeinheiten für Sinus-, Rechteck-, Sägezahn-, Puls- und Dreieckwellen
  • DISPlay:UNIT:SWEep {STARtstop|CENTerspan} - wählt die Methode zur Angabe von Wobbelbereichen
  • DISPlay:UNIT:VOLT {AMPLitudeoff|HIGHlow} - wählt die Methode zur Angabe von Spannungsbereichen
  • DISPlay:VIEW {STANdard|TEXT|GRAPh|DUAL} - wählt die Ansicht auf dem Display

DISPlay {ON|1|OFF|0}
DISPlay?

Deaktiviert oder aktiviert das Display der Frontplatte. Wenn die Frontplatte deaktiviert ist, wird sie schwarz und alle Anzeigen sind deaktiviert. Der Bildschirm bleibt jedoch an.

Parameter | Typische Rückgabe
{ON|1|OFF|0}, Standard ON | 0 (OFF) oder 1 (ON)
Display ausschalten: DISP OFF
  • Die Deaktivierung des Displays beschleunigt die Befehlsausführung über die Remoteschnittstelle und bietet eine Grundsicherheit.
  • Durch das Senden von DISPlay:TEXT <string> wird der Anzeigezustand überschrieben. Sie können auch bei abgeschaltetem Display eine Meldung anzeigen.
  • Das Display wird durch Ein- und Ausschalten des Geräts aktiviert, oder bei Rückkehr zum Lokalbetrieb (über die Frontplatte) durch Druck der Taste [Local] auf der Frontplatte.

DISPlay:FOCus {CH1|CH2}

Wählt den Kanal aus der Vorderansicht bei einem Zwei-Kanal-Gerät

Parameter | Typische Rückgabe
{CH1|CH2} Standard CH1 | CH1 oder CH2
Kanal 2 in Vorderansicht bringen: DISP:FOCus CH2

DISPlay:TEXT "<string>"
DISPlay:TEXT?

Zeigt eine Textmeldung auf dem Frontplattendisplay an.

Parameter | Typische Rückgabe
String mit Anführungszeichen und bis zu 40 Zeichen einer Standardtastatur, Standard "". | "Test running. Do not touch."
Anzeige der Meldung auf dem Display: DISP:TEXT "Test in progress..."
  • Durch das Senden von DISPlay:TEXT <string> wird der Anzeigezustand überschrieben. Sie können auch bei abgeschaltetem Display eine Meldung anzeigen.
  • Während der Anzeige einer Meldung werden Informationen zum aktuellen Betrieb des Geräts nicht an das Frontplattendisplay gesendet.
  • *RST hat keine Auswirkungen auf den Display-Text. Er wird beim Einschalten gelöscht.

DISPlay:TEXT:CLEar

Löscht die Textmeldung aus dem Frontplattendisplay.

Parameter | Typische Rückgabe
(keine) | (keine)
Meldung auf dem Display löschen: DISP:TEXT:CLE
  • Mit DISPlay ON, DISP:TEXT:CLEar kehrt das Display in den Normalmodus zurück.
  • Mit DISPlay OFF, DISP:TEXT:CLEar wird die Meldung gelöscht und das Display bleibt deaktiviert. Senden Sie zur Aktivierung des Displays den Befehl DISPplay ON oder drücken Sie die Frontplattentaste [Local].
  • *RST hat keine Auswirkungen auf den Display-Text. Er wird beim Einschalten gelöscht.

DISPlay:UNIT:ARBRate {SRATe|FREQuency|PERiod}

Gibt an, ob die Maßeinheiten für Arbiträrsignale Proben pro Sekunde, (SRATe), Hz (FREQ) oder Sekunden (PER) sind.

Parameter | Typische Rückgabe
{SRATe|FREQuency|PERiod} Standard SRATe | SRAT, FREQ, oder PER
Einstellen der Einheit für Arbiträrsignale zu Sekunden: DISP:UNIT:ARBR PER
  • Die Frequenz und Periode eines Arbiträrsignals entsprechen der Dauer eines einzigen gesamten Wellenformdurchlaufs. Zum Beispiel würde eine Wellenform von 200 Proben, die mit 1 MSa/s ausgeführt wird, einer Periode von 0,0002 s und einer Frequenz von 5000 Hz entsprechen.

DISPlay:UNIT:PULse {WIDTh|DUTY}

Wählt die Methode zur Angabe der Pulsdauer. Sie können entweder Breite oder Tastverhältnis eingeben.

Parameter | Typische Rückgabe
{WIDTh|DUTY} Standard WIDTh | WIDT oder DUTY
Pulsbreite als Prozentsatz angeben (Tastverhältnis): DISP:UNIT:PULS DUTY

DISPlay:UNIT:RATE {FREQuency|PERiod}

Gibt an, ob die Maßeinheiten für Sinus-, Rechteck-, Sägezahn-, Puls- und Dreieckwellen in Hz (FREQ) oder Sekunden (PER) angezeigt werden.

Parameter | Typische Rückgabe
{FREQuency|PERiod} Standard FREQuency | FREQ oder PER
Einheiten auf Hz umstellen: DISP:UNIT:RATE FREQ

DISPlay:UNIT:SWEep {STARtstop|CENTerspan}

Wählt die Methode zur Angabe von Wobbelfrequenzbereichen. Sie können den Bereich als Start- und Stop-Werte oder als eine Spanne um einen Mittelwert eingeben.

Parameter | Typische Rückgabe
{STARtstop|CENTerspan} Standard STARtstop | STAR oder CENT
Die beiden folgenden Beispiele geben eine Wobbelung von 10 bis 500 Hz an: DISP:UNIT:SWE STAR FREQ:STAR 10 FREQ:STOP 500 DISP:UNIT:SWE CENT FREQ:SPAN 490 FREQ:CENT 255
  • Stellen Sie für eine Aufwärtswobbelung der Frequenz eine positive Wobbelbandbreite ein und für eine Abwärtswobbelung eine negative Wobbelbandbreite.

DISPlay:UNIT:VOLT {AMPLitudeoff|HIGHlow}

Wählt die Methode zur Angabe von Spannungsbereichen. Sie können einen Spannungsbereich als Amplituden- und Offsetwert oder als Werte der oberen und unteren Ebene eingeben.

Parameter | Typische Rückgabe
{AMPLitudeoff|HIGHlow} Standard: AMPLitudeoff | AMPL oder HIGH
Die beiden folgenden Beispiele geben eine Signalspannung von 1 bis 4 V an: DISP:UNIT:VOLT HIGH VOLT:LOW 1 VOLT:HIGH 4 DISP:UNIT:VOLT:AMPL VOLT 3 VOLT OFFS 2,5

DISPlay:VIEW {STANdard|TEXT|GRAPh|DUAL}

Wählt das Bildschirmlayout.

Parameter | Typische Rückgabe
{STANdard|TEXT|GRAPh|DUAL} Standard STANdard | STAN, TEXT, GRAP, oder DUAL
Große Grafikanzeige auswählen: DISP:VIEW GRAP
  • Die Schlüsselwörter STANdard, TEXT, GRAPh und DUAL entsprechen den Softkeys Standard View, Large Text, Large Graph und CH1/CH2 auf dem Menü [System] > System Setup > Screen Layout.


FM-Subsystem

Fasst die Schritte zusammen, die zur Generierung eines Frequenzmodulationssignals (FM-Signal) notwendig sind.

  1. Konfiguration des Trägersignals: Verwenden Sie die Befehle FUNCtion, FREQuency VOLTage und VOLTage:OFFSet zur Angabe von Funktion, Frequenz, Amplitude und Offset des Trägersignals.
  2. Modulationsquelle auswählen (intern, extern, CH1 oder CH2): FM:SOURce. Überspringen Sie bei einer externen Modulationsquelle die Schritte 3 und 4.
  3. Modulationssignal wählen: FM:INTernal:FUNCtion
  4. Modulationsfrequenz einstellen: FM:INTernal:FREQuency
  5. Abweichung der Spitzenfrequenz einstellen: FM:DEViation
  6. FM aktivieren: FM:STATe:ON

Der folgende Code bewirkt das unten abgebildete Oszilloskopbild.

FUNCtion SQU
FREQuency +4,0E+05
VOLTage +1,0
VOLTage:OFFset 0,0
FM:SOURce INT
FM:DEViation +3,5e5
FM:INTernal:FREQuency +5e4
FM:INTernal:FUNCtion RAMP
FM:STATe 1
OUTP 1

[SOURce[1|2]:]FM[:DEViation] {<peak_deviation_in_Hz>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]FM[:DEViation]? [{MINimum|MAXimum}]

Dieser Befehl spezifiziert den Spitzen-Frequenzhub in Hertz. Dieser Wert gibt die maximale Abweichung der Frequenz des modulated Signals von der Trägerfrequenz an.

Parameter | Typische Rückgabe
1 μHz bis 15,05 (begrenzt auf 150 kHz für SÄGEZAHN); Standard 100 Hz | +1,000000000000000E+03
Abweichung der Spitzenfrequenz auf 1 kHz einstellen : FM:DEV 1000 Abweichung der Spitzenfrequenz auf 1 μHz einstellen: FM:DEV MIN
  • Die Abweichung kann die Trägerfrequenz nicht überschreiten. Wenn Sie versuchen, eine Abweichung einzustellen, die höher ist als die Trägerfrequenz (mit aktivierter FM), passt das Gerät die Abweichung an den Maximalwert für diese Trägerfrequenz an. Über die Remote-Schnittstelle wird ebenfalls der Fehler "Settings conflict" generiert.
  • Trägerfrequenz plus Abweichung dürfen die maximalen Frequenzwerte für die gewählte Funktion plus 100 kHz nicht überschreiten. Wenn Sie versuchen, für die Abweichung einen ungültigen Wert einzustellen, passt das Gerät sie an den zulässigen Höchstwert für die derzeitige Trägerfrequenz an. Die Remoteschnittstelle generiert zudem den Fehler "Data out of range".
  • Wenn das Signal durch die Abweichung einen Frequenzgrenzwert für das aktuelle Tastverhältnis überschreitet (nur bei Rechtecksignalen), passt das Gerät das Tastverhältnis an den Höchstwert für die derzeitige Trägerfrequenz an. Über die Remote-Schnittstelle wird ebenfalls der Fehler "Settings conflict" generiert.
  • Bei Auswahl der externen Modulationsquelle External wird die Abweichung durch den ±5 V Signalpegel (optional ±1 V bei 33600 Series Geräten) am rückseitigen Anschluss Modulation In gesteuert. Beträgt die Frequenzabweichung z. B. 100 kHz, entspricht ein +5 V Signalpegel (optional +1 V bei 33600 Series) einem 100 kHz-Anstieg der Frequenz. Niedrigere externe Signalpegel ergeben eine geringere Abweichung und negative Signalpegel reduzieren die Frequenz unter der Trägerfrequenz.

[SOURce[1|2]:]FM:INTernal:FREQuency {<frequency>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]FM:INTernal:FREQuency? [{MINimum|MAXimum}]

Dieser Befehl spezifiziert die Frequenz des Modulationssignals. Das Modulationssignal arbeitet mit dieser Frequenz, in den Frequenzgrenzen dieses Signals.

Parameter | Typische Rückgabe
1 μHz bis zum zulässigen Höchstwert für die interne Funktion. Standard 10 Hz | +1,000000000000000E+04
Modulationsfrequenz auf 10 kHz einstellen: FM:INT:FREQ 10000
  • Wenn Sie ein Arbiträrsignal als Modulationsquelle wählen, wechselt die Frequenz zur Frequenz des Arbiträrsignals, das auf der Abtastrate und der Punktzahl im Arbiträrsignal basiert.
  • Bei Verwendung eines Arbiträrsignals für die Modulationsquelle ändern sich durch eine Änderung dieses Parameters auch die zwischengespeicherten Metadaten, die die Abtastrate des Arbiträrsignals darstellen. Sie können die Modulationsfrequenz eines Arbiträrsignals auch mit FUNCtion:ARBitrary:FREQuency, FUNCtion:ARBitrary:PERiod und FUNCtion:ARBitrary:SRATe ändern. Diese Befehle und der Modulationsfrequenzbefehl sind direkt gekoppelt, damit sich das Arbiträrsignal genau so verhält wie beim letzten Abspielen. Wenn Sie die Modulation später ausschalten und das gleiche Arbiträrsignal als aktuelle Funktion wählen, ist seine Abtastrate (und die entsprechende Frequenz, basierend auf der Punktzahl) identisch mit denen beim Abspielen als Modulationsquelle.
  • Wenn die interne Funktion TRIangle, UpRamp oder DnRamp entspricht, ist die maximale Frequenz bei 33500 Series Geräten auf 200 kHz oder bei 33600 Series Geräten auf 800 kHz begrenzt. Wenn die interne Funktion PRBS entspricht, bezieht sich die Frequenz auf die Bitrate und ist begrenzt, wie hier dargestellt.
  • Dieser Befehl sollte nur mit der internen Modulationsquelle verwendet werden (FM:SOURce INTernal).

[SOURce[1|2]:]FM:INTernal:FUNCtion <Funktion>
[SOURce[1|2]:]FM:INTernal:FUNCtion?

Dieser Befehl wählt die Form des Modulationssignals.

Parameter | Typische Rückgabe
{SINusoid|SQUare|RAMP|NRAMp|TRIangle|NOISe|PRBS|ARB}, Standard SINusoid Interne Funktionssignale anzeigen. | SIN, SQU, RAMP, NRAM, TRI, NOIS, PRBS oder ARB
Wählen Sie eine Sinuswelle als Modulationssignal. FM:INT:FUNC SIN
  • Dieser Befehl sollte nur mit der internen Modulationsquelle verwendet werden (FM:SOURce INTernal).
  • Bestimmte Kombinationen aus Träger und interner Funktion sind nicht zulässig: PRBS-Träger und interne PRBS-Funktion, ARB-Träger und interne ARB-Funktion.
  • Rauschen ist zwar als Modulationssignalform verwendbar, aber Rauschen, Puls und DC können nicht als Trägersignalform verwendet werden.


FORMat:BORDer

FORMat:BORDer {NORMal|SWAPped}
FORMat:BORDer?

Stellt die im Blockmodus für binäre Datenpunktübertragungen verwendete Byte-Reihenfolge ein.

Parameter | Typische Rückgabe
{NORMal|SWAPped}, Standard NORMal | NORM oder SWAP
SWAPped Reihenfolge einstellen: FORM:BORD SWAP
  • NORMal: das höchstwertige Byte (MSB) jedes Datenpunkts als erstes. Verwenden Sie diese Einstellung, wenn Sie Keysight IO Libraries verwenden.
  • SWAPped: das niedrigstwertige Byte (LSB) jedes Datenpunkts als erstes. Die meisten Computer verwenden diese Einstellung.


FREQuency-Subsystem

Das FREQuency Subsystem konfiguriert die Ausgabefrequenz des Geräts. Bei Zweikanalgeräten können die Kanalfrequenzen auf verschiedene Art und Weise gekoppelt werden.

FREQuency:COUPle[:STATe] {ON|OFF|ONCE} aktiviert oder deaktiviert die Kopplung; durch Verwendung von ONCE wird die Frequenz eines Kanals zur anderen kopiert, jedoch nicht mit ihr gekoppelt.

FREQuency:COUPle:MODE {OFFSet|RATio} spezifiziert den Frequenzkopplungsmodus.

FREQuency:MODE Ermöglicht Ihnen, die Angabe eines zu verwendenden Frequenzmodus einschl. Wobbelung, Frequenzliste oder festgelegten Frequenzen.

Beispiel

Die verbleibenden FREQuency-Befehle werden zum Erzeugen einer Wobbelung verwendet, siehe folgende Zusammenfassung:

  1. Spezifizieren Sie die Signalform, die Amplitude und den Offset: Verwenden Sie den Befehl APPLy oder die entsprechenden Befehle FUNCtion, FREQuency, VOLTage und VOLTage:OFFSet, um Funktion, Frequenz, Amplitude und Offset auszuwählen. Sie können alle Signale außer Arbiträrsignale verwenden.
  2. Stellen Sie die Frequenzgrenzen für die Wobbelung ein: FREQuency:STARt und FREQuency:STOP oder FREQuency:CENTer und FREQuency:SPAN.
  3. Betriebsart Wobbelung auswählen (linear oder logarithmisch): SWEep:SPACing
  4. Wobbelzeit in Sekunden einstellen: SWEep:TIME
  5. Triggerquelle für die Wobbelung auswählen: TRIGger[1|2]:SOURce
  6. Frequenz einstellen, bei der das Signal am Sync-Anschluss der Frontplatte bei der Wobbelung zu "niedrig" wechselt (optional): MARKer:FREQuency

[SOURce[1|2]:]FREQuency {<frequency>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]FREQuency? [{MINimum|MAXimum}]

Dieser Befehl spezifiziert die Ausgangsfrequenz. Dieser Befehl ist mit FUNCtion:PULSe:PERiod gepaart, wobei stets der zuletzt ausgeführte Befehl den anderen überschreibt.

Parameter | Typische Rückgabe
1 μHz bis maximale Gerätefrequenz. Standard 1 kHz. | +1,000000000000000E+03
Ausgangsfrequenz auf 60 Hz einstellen: FREQ 60
  • Funktionsbegrenzungen: Wie Sie der obigen Tabelle entnehmen können, ist der verfügbare Frequenzbereich von der Funktion abhängig. Wenn Sie einen Befehl senden, der eine Frequenz angibt, die nicht dem geeigneten Bereich für die aktuelle Funktion entspricht, tritt ein Fehler auf. Ist die aktuelle Funktion beispielsweise "Sägezahn" und Sie senden den Befehl FREQ 20 MHZ, wird der Fehler "Data out of range" generiert und die Frequenz auf 200 kHz (33500 Series) oder 800 kHz (33600 Series) gestellt, was dem Höchstwert für ein Sägezahnsignal entspricht.

[SOURce[1|2]:]FREQuency:CENTer {<frequency>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]FREQuency:CENTer? [{MINimum|MAXimum}]

Stellt die zentrale Frequenz ein. Mit Wobbelbandbreite für eine Frequenzwobbelung verwendet.

Parameter | Typische Rückgabe
1 μHz bis maximale Gerätefrequenz, Standard 550 Hz | +1,000000000000000E+03
Zentrale Frequenz für die Wobbelung auf 1 kHzeinstellen: FREQ:CENT 1000
  • Folgende Gleichung zeigt, wie die zentrale Frequenz durch die Bandbreitenfrequenz begrenzt wird.

    Zentrale Frequenz (max) = Max. Frequenz für die Wellenform - (Bandbreite/2)
  • Folgende Gleichung zeigt, wie die zentrale Frequenz mit den Start- und Stop-Frequenzen verknüpft ist.

    Zentrale Frequenz = |(Stop-Frequenz - Start-Frequenz)|/2

[SOURce[1|2]:]FREQuency:COUPle[:STATe] {ON|1|OFF|0}
[SOURce[1|2]:]FREQuency:COUPle[:STATe]?

Aktiviert/deaktiviert die Frequenzkopplung zwischen Kanälen in einem Zweikanalgerät.

Parameter | Typische Rückgabe
{ON|1|OFF|0}, Standard OFF | 0 (OFF) oder 1 (ON)
Frequenzkopplungsstatus einschalten: FREQ:COUP ON
  • Die Angabe von ON startet die Frequenzkopplung, wie in FREQuency:COUPle:MODE angegeben.
  • Wenn die Frequenz durch den aktuellen Offset oder Versatz in Kombination mit den aktuellen Frequenzeinstellungen die Gerätespezifikationen überschreitet, erzeugt das Gerät einen Fehler und die überschrittene Frequenz wird bei ihrem Höchst- oder Mindestwert abgeschnitten.
  • Wenn bei einer Einstellung des Modus auf RATIO und RATIO auf 1.0 die Spezifikationen jedes Kanals weiterhin überschritten werden (z. B. Kanal 1 ist ein 3 MHz Sinus- und Kanal 2 ein Sägezahnsignal, das nicht so hoch ansteigen kann), wird eine Fehlermeldung generiert und FREQuency:COUPle wird auf OFF gestellt.

[SOURce[1|2]:]FREQuency:COUPle:MODE {OFFSet|RATio}
[SOURce[1|2]:]FREQuency:COUPle:MODE?

Stellt die Art der Frequenzkopplung zwischen frequenzgekoppelten Kanälen ein; OFFSet gibt einen konstanten Frequenz-Offset zwischen Kanälen an; RATio gibt ein konstantes Verhältnis zwischen den Kanalfrequenzen an.

Parameter | Typische Rückgabe
{OFFSet|RATio}, Standard RATio mit Verhältnis 1.0 | OFFS oder RAT
Einstellen des Frequenzkopplungsmodus auf OFFSet: FREQ:COUP:MODE OFFS
  • Die Standardeinstellung beim Einschalten für die Frequenzkopplung ist OFF.
  • Die Angabe SOURce1 oder SOURce2 ist nicht relevant; jede Syntax stellt den gleichen Kopplungsmodus für beide Kanäle ein.

[SOURce[1|2]:]FREQuency:COUPle:OFFSet {<frequency>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]FREQuency:COUPle:OFFSet?

Stellt die Offset-Frequenz ein, wenn ein Gerät im frequenzgekoppelten Modus OFFSet arbeitet.

Parameter | Typische Rückgabe
Eine Zahl zwischen den Plus- und Minuswerten für die maximale Gerätefrequenz für die Wellenform; Standard 0. | +7,650000000000000E+05

Frequenz von Kanal 2 auf 10,245 MHz über der Frequenz von Kanal 1 einstellen:
FREQ:COUP:OFFS 10,245 MHZ

Frequenz von Kanal 1 auf 350 kHz über der Frequenz von Kanal 2 einstellen:
SOUR2:FREQ:COUP:OFFS 350 KHZ

Frequenz von Kanal 1 auf 455 kHz unter der Frequenz von Kanal 2 einstellen:
SOUR2:FREQ:COUP:OFFS -455 KHZ
  • Der SOURce Kanal (SOURce1 oder SOURce2) wird als Referenzkanal verwendet und der OFFSet wird auf den anderen Kanal angewendet. Nehmen wir beispielsweise an, dass für das Gerät FREQ:COUPLE:STATE ON und FREQ:COUPLE:MODE OFFSET (Frequenz-Offset-Modus aktiv) eingestellt ist und Kanal 1 derzeit mit 1,0 MHz arbeitet. Durch den Befehl SOURce1:FREQuency:COUPle:OFFSet 500 bleibt Kanal 1 bei 1,0 MHz, für Kanal 2 wird 1,5 MHz eingestellt. Da die Frequenz beider Kanäle geändert wird, ändert sich die Frequenz des anderen Kanals, um den Offset von 500 kHz beizubehalten.
  • Wenn durch die Frequenzkopplung ein Kanal die Frequenzspezifikationen des Geräts für die aktuelle Funktion überschreiten würde, hat der Befehl einen Fehler zur Folge und die Frequenz wird auf den Höchst- oder Mindestwert für diesen Kanal eingestellt.
  • Die Frequenzkopplung ist mit Arbiträrsignalen nicht gültig, Sie können jedoch die Abtastrate von Arbiträrsignalen koppeln.

[SOURce[1|2]:]FREQuency:COUPle:RATio <ratio>
[SOURce[1|2]:]FREQuency:COUPle:RATio?

Stellt das Offset-Verhältnis zwischen Kanalfrequenzen im frequenzgekoppelten Modus RATio ein.

Parameter | Typische Rückgabe
0,001 bis 1000, Standard 1 | +7,500000000000000E-01
Frequenz von Kanal 2 auf die doppelte Frequenz von Kanal 1 einstellen: FREQ:COUP:RAT 2,0 Frequenz von Kanal 1 auf 3,14 mal die Frequenz von Kanal 2 einstellen: SOUR2:FREQ:COUP:RAT 3,14
  • Der SOURce Kanal (SOURce1 oder SOURce2) wird als Referenzkanal verwendet und das RATIO wird auf den anderen Kanal angewendet. Nehmen wir beispielsweise an, dass für das Gerät FREQuency:COUPle ON und FREQuency:COUPle:MODE RATio eingestellt ist. Nehmen wir weiterhin an, dass Kanal 1 derzeit mit 2 kHz arbeitet und Kanal 2 mit 10 kHz. Durch den Befehl SOURce1:FREQuency:COUPle:RATio 2,5 bleibt Kanal 1 bei 2 kHz und Kanal 2 wird auf 5 kHz gestellt. Da die Frequenz beider Kanäle geändert wird, ändert sich die Frequenz des anderen Kanals, um das Verhältnis von 2,5 beizubehalten.
  • Wenn durch die Frequenzkopplung ein Kanal die Frequenzspezifikationen des Geräts für die aktuelle Funktion überschreiten würde, hat der Befehl einen Fehler zur Folge und die Frequenz wird auf den Höchst- oder Mindestwert für diesen Kanal eingestellt.
  • Die Frequenzkopplung ist mit Arbiträrsignalen nicht gültig, Sie können jedoch die Abtastrate von Arbiträrsignalen koppeln.

[SOURce[1|2]:]FREQuency:MODE {CW|LIST|SWEep|FIXed}
[SOURce[1|2]:]FREQuency:MODE?

Stellt die Art des Frequenzmodus als kontinuierliches Signal mit Festfrequenz (CW oder FIXed), Frequenzwobbelung (SWEep) oder Frequenzliste (LISTE) ein.

Parameter | Typische Rückgabe
{CW|LIST|SWEep|FIXed}, Standard CW | CW, LIST, SWE, oder FIX
Einstellen des Frequenzmodus auf LIST: FREQ:MODE LIST
  • Wenn der Modus auf Liste gestellt wird, verwenden Sie LIST:FREQuency zur Angabe der Frequenzliste.

[SOURce[1|2]:]FREQuency:SPAN {<frequency>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]FREQuency:SPAN? [{MINimum|MAXimum}]

Stellt die Wobbelbandbreite (in Kombination mit der zentralen Frequenz verwendet) für eine Frequenzwobbelung ein.

Parameter | Typische Rückgabe
± maximale Gerätefrequenz für die Wellenform, Standard 900 Hz | +1,000000000000000E+02
Wobbelbandbreite einstellen auf 100 kHz: FREQ:SPAN 100 KHZ
  • Folgende Gleichung zeigt die Begrenzung der maximalen Wobbelbandbreite:

    Wobbelbandbreite (max) = (Max. Frequenz für das gewählte Signal - zentrale Frequenz) X 2
  • Die folgende Gleichung beschreibt den Zusammenhang zwischen der Wobbelbandbreite und den Start-/Stop-Frequenzen.

    Wobbelbandbreite = Stop-Frequenz - Start-Frequenz
  • Stellen Sie für eine Aufwärtswobbelung der Frequenz eine positive Wobbelbandbreite ein und für eine Abwärtswobbelung eine negative Wobbelbandbreite.

[SOURce[1|2]:]FREQuency:STARt {<frequency>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]FREQuency:STARt? [{MINimum|MAXimum}]

[SOURce[1|2]:]FREQuency:STOP {<frequency>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]FREQuency:STOP? [{MINimum|MAXimum}]

Stellt die Start- und Stop-Frequenzen für eine Frequenzwobbelung ein.

Parameter | Typische Rückgabe
± maximale Gerätefrequenz für die Wellenform, Standard 100 Hz | +1,000000000000000E+02
Start- und Stopwobbelfrequenzwerte auf 100 Hz und 1 kHz einstellen entsprechend: FREQ:STAR 100 FREQ:STOP 1000


FSKey-Subsystem

Das FSKey-Subsystem konfiguriert ein Frequenzumtastungssignal (FSK-Signal).

Beispiel

Fasst die Schritte zusammen, die zur Generierung notwendig sind FSK-Signal.

  1. Verwenden Sie die Befehle FUNCtion, FREQuency, VOLTage und VOLTage:OFFSet zur Auswahl von Funktion, Frequenz, Amplitude und Offset des Trägersignals.
  2. Modulationsquelle auswählen (intern, extern, CH1 oder CH2): FSK:SOURce. Überspringen Sie bei einer externen Modulationsquelle die Schritte 3 und 4.
  3. Wählen Sie die alternative "Hop-" Frequenz: FSK:FREQuency
  4. FSK-Rate einstellen: FSK:INTernal:RATE
  5. FSK-Modulation aktivieren: FSK:STATe ON

Der folgende Code bewirkt das unten abgebildete Oszilloskopbild.

FUNCtion SQU
FREQuency +1e6
VOLTage +1,0
VOLTage:OFFset 0,0
FSKey:SOURce INT
FSKey:FREQuency +5e5
FSKey:INTernal:RATE +8e4
FSKey:STATe 1
OUTPut1 1

[SOURce[1|2]:]FSKey:FREQuency {<frequency>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]FSKey:FREQuency? [{MINimum|MAXimum}]

Stellt die alternative (oder "Hop-Frequenz") für die FSK-Modulation ein.

Parameter | Typische Rückgabe
1 μHz bis maximale Gerätefrequenz für die Wellenform, Standard 100 Hz | +1,000000000000000E‑06
Stellen Sie die Hop-Frequenz auf 10 kHz: FSK:FREQ 10000 Stellen Sie die Hop-Frequenz auf 1 μHz: FSK:FREQ MIN

[SOURce[1|2]:]FSKey:INTernal:RATE {<rate_in_Hz>|MINimum|MAXimum}
[SOURce[1|2]:]FSKey:INTernal:RATE? [{MINimum|MAXimum}]

Dieser Befehl spezifiziert die Rate, mit der die Ausgangsfrequenz zwischen der Trägerfrequenz und der „Hop“-Frequenz wechselt.

Parameter | Typische Rückgabe
0,125 mHz bis 1 MHz, Standard 10 Hz | +1,000000000000000E+01
Stellen Sie die FSK-Rate auf 10 kHz: FSK:INT:RATE 10000 Stellen Sie die FSK-Rate auf 1 mHz: FSK:INT:RATE MIN
  • Die FSK-Rate wird nur mit der internen Quelle (FSK:SOURce INTernal) verwendet.
  • Das Modulationssignal ist ein Rechtecksignal mit einem Tastverhältnis von 50%.
FSKey-Subsystem


FUNCtion Subsystem

Das FUNCtion Subsystem konfiguriert die Ausgabefunktion des Geräts:

  • [SOURce[1|2]:]FUNCtion <function> - Ausgangssignal
  • [SOURce[1|2]:]FUNCtion:ARBitrary {<filename>} - Arbiträrsignal (.arb/barb) oder Sequenz (.seq), die zuvor mit dem Befehl MMEMory:LOAD:DATA[1|2] in den flüchtigen Speicher geladen wurden.
  • [SOURce[1|2]:]FUNCtion:ARBitrary:ADVance {TRIGger|SRATe} - Methode für den Übergang zum nächsten Arbiträrsignaldatenpunkt.
  • FUNCtion:ARBitrary:BALance[:STATe] {ON|1|OFF|0} - (nur IQ Player Option) Status (on/off) für den Abgleich des dualen Arbiträrsignalkanals
  • FUNCtion:ARBitrary:BALance:GAIN {<percent>|MINimum|MAXimum|DEFine} - (nur IQ Player Option) legt das Verhältnis des Verstärkungsabgleichs für duale Arbiträrsignale fest
  • FUNCtion:ARBitrary:BALance:OFFSet{1|2} {<volts>|MINimum|MAXimum|DEFault} - (nur IQ Player Option) Offset für einzelne Kanäle dualer Arbiträrsignale
  • [SOURce[1|2]:]FUNCtion:ARBitrary:FILTer {NORMal|STEP|OFF} - Filter für Arbiträrsignal
  • [SOURce[1|2]:]FUNCtion:ARBitrary:FREQuency {<frequency>|MINimum|MAXimum|DEFault} - Frequenz für Arbiträrsignal
    [SOURce[1|2]:]FUNCtion:ARBitrary:PERiod {<period>|MINimum|MAXimum}DEFault} - Periode des Arbiträrsignals
  • [SOURce[1|2]:]FUNCtion:ARBitrary:POINts? - Anzahl an Punkten (Proben) im aktuellen Arbiträrsignal
  • [SOURce[1|2]:]FUNCtion:ARBitrary:PTPeak {<voltage>|MINimum|MAXimum|DEFault} - Spitze-Spitze-Spannung für ein Arbiträrsignal
  • FUNCtion:ARBitrary:SKEW[:STATe] {ON|1|OFF|0} - (nur IQ Player Option) Status (on/off) für Versatz des dualen Arbiträrsignals
  • FUNCtion:ARBitrary:SKEW:TIME [{<time>|MINimum|MAXimum|DEFault}] - (nur IQ Player Option) Zeitversatz in Sekunden
  • [SOURce[1|2]:]FUNCtion:ARBitrary:SRATe {<sample_rate>|MINimum|MAXimum|DEFault} - Abtastrate für das Arbiträrsignal
  • [SOURce[1|2]:]FUNCtion:ARBitrary:SYNChronize - Neustart des Arbiträrsignals bei der ersten Probe gleichzeitig für beide Signale
  • [SOURce[1|2]:]FUNCtion:NOISe:BANDwidth {<bandwidth>|MINimum|MAXimum|DEFault} - Bandbreite für Signal NOISe
  • [SOURce[1|2]:]FUNCtion:PRBS:BRATe {<bit_rate>| MINimum|MAXimum|DEFault} - Bitrate für die pseudozufällige Binärfolge (PRBS)
  • [SOURce[1|2]:]FUNCtion:PRBS:DATA <sequence_type> - Sequenztyp für PRBS
  • [SOURce[1|2]:]FUNCtion:PRBS:TRANsition[:BOTH] {<seconds>|MINimum|MAXimum|DEFault} - Übergangszeit für beide PRBS-Flanken
  • [SOURce[1|2]:]FUNCtion:PULSe:DCYCle {<percent>|MINimum|MAXimum|DEFault} - Tastverhältnis des Pulssignals für Pulssignal
  • [SOURce[1|2]:]FUNCtion:PULSe:HOLD {WIDTh|DCYCle} - legt fest, ob Pulsbreite oder Tastverhältnis konstant gehalten werden, wenn andere Parameter variieren
  • [SOURce[1|2]:]FUNCtion:PULSe:PERiod {<seconds>|MINimum|MAXimum|DEFault} - Periode für ein Pulssignal
  • [SOURce[1|2]:]FUNCtion:PULSe:TRANsition:LEADing {<seconds>|MINimum|MAXimum|DEFault}
    [SOURce[1|2]:]FUNCtion:PULSe:TRANsition:TRAiling {<seconds>|MINimum|MAXimum|DEFault}
    [SOURce[1|2]:]FUNCtion:PULSe:TRANsition[:BOTH] {<seconds>|MINimum|MAXimum|DEFault}     - Flankenzeit für ein Pulssignal
  • [SOURce[1|2]:]FUNCtion:PULSe:WIDTh {<seconds>|MINimum|MAXimum|DEFault} - Pulsbreite
  • [SOURce[1|2]:]FUNCtion:RAMP:SYMMetry {<percent>|MINimum|MAXimum|DEFault} - Symmetrieverhältnis für Sägezahnsignale
  • [SOURce[1|2]:]FUNCtion:SQUare:DCYCle {<percent>|MINimum|MAXimum} - Tastverhältnis für Rechtecksignale
  • [SOURce[1|2]:]FUNCtion:SQUare:PERiod {<seconds>|MINimum|MAXimum|DEFault} - Periode für Rechtecksignale

[SOURce[1|2]:]FUNCtion <function>
[SOURce[1|2]:]FUNCtion?

Dieser Befehl dient zur Wahl der Ausgangsfunktion.

Parameter | Typische Rückgabe
{SINusoid|SQUare|TRIangle|RAMP|PULSe|PRBS|NOISe|ARB|DC}, Standard SINusoid | SIN, SQU, TRI, RAMP, PULS, PRBS, NOIS, ARB, oder DC
Ausgang an Kanal 2 auf Sinus festlegen: SOUR2:FUNC SIN
  • Das gewählte Signal (außer Arbiträrsignal) wird unter Verwendung der zuletzt spezifizierten Frequenz-, Amplituden- und Offsetspannungswerte ausgegeben. Arbiträrsignale werden nach den Einstellungen abgespielt, die in der Arbiträrsignaldatei spezifiziert sind. Bei völlig neuen Arbiträrsignalen werden die aktuellen Arbiträrsignaleinstellungen übernommen.
  • NOISe erzeugt ein weißes Gaußsches Rauschen mit einstellbarer Bandbreite und einem Scheitelfaktor um 3,5.
  • PRBS erzeugt ein Pseudo-Rauschen durch ein linear rückgekoppeltes Schieberegister (LFSR) und benutzerdefinierbare Methoden.
  • ARB erzeugt das Arbiträrsignal, das durchFUNCtion:ARBitrary aktuell ausgewählt ist.
  • Funktionsbegrenzungen: Wenn Sie auf eine Funktion umschalten, deren maximale Frequenz niedriger ist als die der aktuellen Funktion, wird die Frequenz gegebenenfalls automatisch auf die Obergrenze für die neue Funktion reduziert. Wenn Sie zum Beispiel von einer hohen Sinussignalfrequenz auf die Sägezahnfunktion umschalten, stellt das Gerät die Ausgangsfrequenz auf 200 kHz (die maximale Frequenz für Sägezahnsignale) Über die Remote-Schnittstelle wird ebenfalls der Fehler "Settings conflict" generiert.
  • Amplitudenbegrenzungen: Wenn Sie auf eine Funktion umschalten, deren maximale Amplitude niedriger ist als die der aktuellen Funktion, wird die Amplitude automatisch auf die Obergrenze für die neue Funktion reduziert. Dies kann geschehen, wenn die Ausgangseinheiten Vrms oder dBm sind, was auf die Abweichungen des Scheitelfaktors für die verschiedenen Ausgangsfunktionen Wenn Sie z. B. ein 5 Vrms Rechtecksignal (in 50 Ω) in ein Sinussignal ändern, passt das Gerät die Amplitude auf 3,536 Vrms an (der obere Grenzwert für Sinussignale in Vrms). Zudem generiert die Remote-Schnittstelle einen "Settings conflict"-Fehler. zurückzuführen ist.

[SOURce[1|2]:]FUNCtion:ARBitrary {<filename>}
[SOURce[1|2]:]FUNCtion:ARBitrary?

Wählt ein Arbiträrsignal (.arb/.barb) oder eine Sequenz (.seq), die zuvor in den flüchtigen Speicher für den Kanal geladen wurde, der mit MMEMory:LOAD:DATA[1|2] oder DATA:ARBitrary angegeben ist. Einige Signale können gleichzeitig im flüchtigen Speicher sein.

Parameter | Typische Rückgabe
Siehe MMEMory:LOAD:DATA[1|2] für gültige <filename> Formate. | "INT:\MyArb103.arb"
Arbiträrsignal im Speicher auf Kanal 2 wählen: FUNC:ARB "INT:\MyArb103.arb" Laden Sie ein Arbiträrsignal vom internen Laufwerk in den flüchtigen Speicher. Wählen Sie dann das Signal und geben Sie es wieder: MMEM:LOAD:DATA "INT:\BUILTIN\Sinc.arb" FUNCtion:ARBitrary "INT:\BUILTIN\Sinc.arb" FUNCtion ARB
  • Der <filename> sollte dem Dateinamen entsprechen, der zum Laden des Arbiträrsignals oder der Sequenz in den flüchtigen Speicher verwendet wurde, mit MMEMory:LOAD:DATA[1|2], DATA:ARBitrary, DATA:ARBitrary:DAC oder DATA:SEQuence.
  • Wenn Sie ein Arbiträrsignal oder eine Sequenz speichern (MMEMory:STORe:DATA[1|2]), werden die aktuellen Einstellungen des Geräts (Spannungswerte, Abtastrate, Filtertyp etc.) im Segment oder in der Segmentdatei gespeichert. Beim ersten Abspielen der Datei mit FUNCtion:ARBitrary werden diese Einstellungen geladen und überschreiben die aktuellen Einstellungen des Geräts. Wenn Sie ein Segment- oder Sequenzdatei manuell bearbeitet haben, so dass die Geräteeinstellungen entfernt wurden, werden die Geräteeinstellungen nicht geändert, wenn Sie FUNCtion:ARBitrary ausführen.
  • Wenn Sie ein Arbiträrsignal oder eine Sequenz speichern (MMEMory:STORe:DATA[1|2]), werden die aktuellen Einstellungen des Geräts (Spannungswerte, Abtastrate, Filtertyp etc.) im Segment oder in der Segmentdatei gespeichert. Beim ersten Abspielen der Datei mit FUNCtion:ARBitrary werden diese Einstellungen geladen und überschreiben die aktuellen Einstellungen des Geräts. Wenn Sie ein Segment- oder Sequenzdatei manuell bearbeitet haben, so dass die Geräteeinstellungen entfernt wurden, werden die Geräteeinstellungen nicht geändert, wenn Sie FUNCtion:ARBitrary ausführen.

[SOURce[1|2]:]FUNCtion:ARBitrary:ADVance {TRIGger|SRATe}
[SOURce[1|2]:]FUNCtion:ARBitrary:ADVance?

Legt die Methode für den Übergang zum nächsten Arbiträrsignaldatenpunkt für den angegebenen Kanal fest.

Parameter | Typische Rückgabe
{TRIGger|SRATe}, Standard TRIG | TRIG oder SRAT
Erweiterte Methode zum Triggern festlegen: FUNC:ARB:ADV TRIG
  • TRIGger bewirkt, dass das Gerät mit jedem erhaltenen Trigger zum nächsten Datenpunkt übergeht und erzwingt für TRIGger[1|2]:SOURce EXTernal.
  • SRATe bewirkt, dass das Gerät bei der Abtastrate, die mit FUNCtion:ARBitrary:SRATe festgelegt wird, zum nächsten Datenpunkt übergeht.

[SOURce[1|2]:]FUNCtion:ARBitrary:FILTer {NORMal|STEP|OFF}
[SOURce[1|2]:]FUNCtion:ARBitrary:FILTer?

Legt die Filtereinstellung für ein Arbiträrsignal fest.

Parameter | Typische Rückgabe
{NORMal|STEP|OFF}, Standard STEP | NORMal, STEP, oder OFF
Einstellung des Filters auf NORMal: FUNCtion:ARBitrary:FILTer NORM
  • NORMal filtert die Datenpunkte mit dem Filter, der den flachsten Frequenzgang bereitstellt. Dies glättet das Signal, aber scharfe Übergänge weisen eine Vor- und Überschwingung auf.
  • STEP filtert die Datenpunke so, dass das Signal effektiv geglättet wird, Vor- und Überschwingungen jedoch minimiert werden. Diese Einstellung hat jedoch eine engere Bandbreite als die Einstellung NORMal.
  • OFF springt bei der Abtastrate von Punkt zu Punkt. Bewegungen zwischen Datenpunkten werden so schnell wie möglich ohne Glättung durchgeführt. Wenn der <mode> auf OFF steht, gebraucht das Gerät einen Filter, dessen Bandbreitenbegrenzung die maximale Abtastrate für das Arbiträrsignal auf 62,5 MSa/s (33500 Series) oder 250 MSa/s (33600 Series) beschränkt.
  • Um diesen Befehl bei 33600 Series Geräten zu verwenden, müssen Sie FUNCtion:ARBitrary:FILTer auf OFF einstellen.

[SOURce[1|2]:]FUNCtion:ARBitrary:FREQuency {<frequency>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]FUNCtion:ARBitrary:FREQuency? {MINimum|MAXimum}

[SOURce[1|2]:]FUNCtion:ARBitrary:PERiod {<period>|MINimum|MAXimum}DEFault}
[SOURce[1|2]:]FUNCtion:ARBitrary:PERiod? {MINimum|MAXimum}

Legt die Frequenz oder Periode für das Arbiträrsignal fest.

Parameter | Typische Rückgabe
<Frequenz> (Hz): Begrenzt durch die Anzahl der Signalpunkte; Standard basiert auf einer Abtastrate von 40 kSa/s. | +1,000000000000000E+03
<Periode> (Sekunden): Begrenzt durch die Anzahl der Signalpunkte; Standard basiert auf einer Abtastrate von 40 kSa/s. | +1,000000000000000E‑03
Arbiträrsignalfrequenz auf 1000 Hz einstellen. FUNC:ARB:FREQ 1000
  • Mit FUNCtion:ARBitrary:FILTer OFFwird die Arbiträrsignalabtastrate auf 1/4 der maximalen Abtastrate reduziert.
  • Die <Frequenz> reicht von 1 µHz bis 31,25 MHz bei 33500 Series Geräten oder 250 MHz bei 33600 Series Geräten. Die Frequenz wird außerdem durch die Filtereinstellung beschränkt. Mit FUNCtion:ARBitrary:FILTer OFF wird die Abtastrate des Arbiträrsignals auf 62,5 MSa/s beschränkt. Dazu wird die Frequenz auch auf 7,8125 MHz für ein Achtpunktesignal (33500 Series) oder auf ein Viertel davon für ein 32-Punkte-Signal (33600 Series) beschränkt.
  • Die Abtastrate und Frequenz des Arbiträrsignals sind nicht an SOUR:FREQ gekoppelt, da dies nur bei Nicht-Arbiträrsignalen angewendet wird.
  • Das Arbiträrsignal wird mit einer Geschwindigkeit abgespielt, die von der Abtastrate festgelegt wird. Beim Festlegen von Frequenz oder Periode eines Arbiträrsignals wechselt das Gerät die Abtastrate, die auf der Punktzahl im Signal und der neuen Frequenz oder Periodeneinstellung basiert. Bei der neuen Frequenz oder Periode kann es aufgrund der eingeschränkten Auflösung der Abtastrate und der Punktzahl zu geringfügigen Veränderungen kommen. Mit anderen Worten, die Frequenz wird ausgehend von der neuen Abtastrate und Punktzahl neu berechnet, um die Kompatibilität zwischen den gekoppelten Parametern zu gewährleisten. Dies ist auf eine mathematische Auflösung von 15 Ziffern in Kombination mit einer Abtastrate, die auch 15 Digits betragen kann, zurückzuführen.
  • Änderung der Anzahl der Punkte im Signal oder Änderung der Abtastrate mit FUNCtion:ARBitrary:SRATe ändert die Frequenz- und Periodeneinstellungen.

[SOURce[1|2]:]FUNCtion:ARBitrary:POINts?

Gibt die Anzahl der Punkte im aktuell ausgewählten Arbiträrsignal zurück.

Parameter | Typische Rückgabe
(keine) | +100000
Rückgabe der Anzahl von Punkten im aktuellen Arbiträrsignal auf Kanal 1: FUNC:ARB:POIN?
  • Die maximale Anzahl der Punkte hängt vom Speicher des Geräts ab, der auf den Modellen und Optionen basiert.

[SOURce[1|2]:]FUNCtion:ARBitrary:PTPeak {<voltage>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]FUNCtion:ARBitrary:PTPeak? [{MINimum|MAXimum}]

Legt Spitze-Spitze-Spannung fest.

Parameter | Typische Rückgabe
10 VDC in 50 Ω, 20 VDC in einen offenen Schaltkreis; Standard 100 mV | +4,000000000000000E+00
Legt Spitze-Spitze-Spannung auf 4 V fest: FUNC:ARBitrary:PTPeak 4
  • Einschränkungen durch die Amplitude: Sie können für die Spannungspegel einen positiven oder einen negativen Wert mit den unten dargestellten Einschränkungen angeben. Vpp ist die maximale Spitze-zu-Spitze-Amplitude für den gewählten Lastwiderstand (10 Vpp in 50 Ω oder 20 Vpp in einen offenen Schaltkreis).

    Vhigh – Vlow£ Vpp (max) und Vhigh, Vlow£Vpp (max)/2
  • Unterschiede bei der Bedienung von Frontplatte und Remoteschnittstelle:
  • Remoteschnittstelle: Bei der Einstellung des oberen oder unteren Pegels über die Remoteschnittstelle kann der obere oder untere Pegel geändert werden, um die gewünschte Einstellung zu erreichen. In diesem Fall tritt entweder der Fehler "Data out of range" oder der Fehler "Settings conflict" auf. Wenn für den oberen Pegel ein kleinerer Wert als für den unteren Pegel festgelegt wird, stellt das Gerät den unteren Pegel 1 mV kleiner ein als den oberen Pegel. Wenn für den oberen Pegel ein kleinerer Wert als die LOW-Grenze oder die Geräteausgabespezifikationen eingestellt wird, stellt das Gerät den unteren Pegel auf die LOW-Grenze oder die Geräteausgabespezifikationen und der obere Pegel wird 1 mV über den unteren Pegel gestellt. Ein ähnlicher Regelsatz gilt, wenn der untere Pegel nicht korrekt eingestellt wird.
  • Ähnlich kann über die Remoteschnittstelle der untere Pegel über den oberen gesetzt werden. In diesem Fall setzt das Gerät den oberen Pegel 1 mV höher als den unteren Pegel. Wenn der untere Pegel höher gesetzt wird als das HIGH-Limit oder die Geräteausgabespezifikationen, wird der obere Pegel auf das HIGH-Limit oder die Geräteausgabespezifikationen gesetzt und der untere Pegel wird 1 mV unter den oberen Pegel gesetzt.
  • Frontplatte: Durch die Einstellung des oberen oder unteren Pegels über die Frontplatte wird evtl. die Pegeleinstellung abgeschnitten, um die gewünschte Pegeleinstellung zu erzielen, und der Fehler "Data out of range" generiert. Für den Wert des oberen Pegels kann über die Frontplatte kein Wert eingestellt werden, der unter dem des unteren Pegels liegt.
  • Durch die Einstellung von oberem und unterem Pegel werden auch Signalamplitude und -Offset eingestellt. Stellen Sie beispielsweise den oberen Pegel auf +2 V und den unteren Pegel auf -3 V, führt dies zu einer Amplitude von 5 Vpp mit einem Offset von -500 mV.
  • Einschränkungen durch den Lastwiderstandswert: Wenn Sie die Einstellung des Lastwiderstands ändern, werden die angezeigten Spannungspegel angepasst (und es erfolgt keine Fehlermeldung). Wenn Sie zum Beispiel den oberen Pegel auf +100 mVDC festlegen und dann den Lastwiderstand von 50 Ω auf "high impedance" stellen, verdoppelt sich die auf der Frontplatte angezeigte Amplitude auf +200 mVDC. Wenn Sie von "high impedance" auf 50 Ω wechseln, halbiert sich die angezeigte Amplitude. Eine Änderung des Lastwiderstands ändert nicht die Spannung an den Ausgangsanschlüssen des Geräts. Sie ändert lediglich die an der Frontplatte angezeigten Werte und die Werte, die über die Remote-Schnittstelle abgefragt werden. Die Spannung am Ausgang des Geräts ist abhängig von der Last, die mit dem Gerät verbunden ist. Ausführlichere Informationen finden Sie unter OUTPut[1|2]:LOAD.
  • Einschränkungen durch Spannungsgrenzwerte: Wenn die Spannungsgrenzwerte aktiviert sind, werden die Pegeleinstellungen auf die festgelegten Grenzwerte überprüft (VOLTage:LIMit:HIGH, VOLTage:LIMit:LOW), bevor ein Pegelwechsel erfolgt. Sollte der Ausgangspegel eine LIMIT Einstellung überschreiten, wird der Pegel auf den maximal (oder minimal) erlaubten Wert eingestellt, der die LIMit Einstellung nicht überschreitet und die Fehlermeldung "Settings conflict" wird generiert.
  • Einschränkungen durch die Ausgangskopplung: Wenn zwei Kanäle gekoppelt werden, werden Einschränkungen in der Pegeleinstellung auf beiden Kanälen überprüft, bevor ein Pegelwechsel ausgeführt wird. In diesem Fall gilt: Wenn ein Pegelwechsel eine LIMIT Einstellung oder Geräteausgabespezifikationen auf jedem Kanal überschreiten sollte, wird der Pegel auf den maximal (oder minimal) erlaubten Wert eingestellt und die Fehlermeldung "Settings conflict" angezeigt.
  • Um das Signal im Verhältnis zur Offsetspannung umzukehren, verwenden Sie OUTPut[1|2]:POLarity.

[SOURce[1|2]:]FUNCtion:ARBitrary:SRATe {<sample_rate>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]FUNCtion:ARBitrary:SRATe? {MINimum|MAXimum}

Setzt die Abtastrate für das Arbiträrsignal fest.

Parameter | Typische Rückgabe
1 µSa/s bis 250 MSa/s (33500 Series) oder 1 GSa/s (33600 Series), Standard 40 kSa/s. Auf 62,5 MSa/s (33500 Series) oder 250 MSa/s (33600 Series) beschränkt, wenn FUNCtion:ARBitrary:FILTer auf OFF gestellt ist. | +1,000000000000000E+04
Einstellen der Abtastrate auf 10 kSa/s: FUNC:ARB:SRAT 1e4
  • Abtastrate und Frequenzparameter werden nicht gekoppelt, wenn ein Arbiträrsignalsegment abgespielt wird. Das Frequenzkonzept kommt bei Arbiträrsignalsequenzen nicht zur Anwendung.
  • Wird eine Abtastrate eingestellt, wenn sich das Gerät nicht im ARB-Modus befindet, ändert sich die Frequenz nicht. Ist die aktuelle Funktion z. B. Sinus, hat die Einstellung der Abtastrate keine Auswirkungen, bevor die Funktion zu ARB geändert wird.
  • Die maximale Abtastrate hängt von dem Filter ab, der auf das Arbiträrsignal angewendet wird. Für Details siehe FUNCtion:ARBitrary:FILTer.

[SOURce[1|2]:]FUNCtion:ARBitrary:SYNChronize

Bewirkt, dass zwei unabhängige Arbiträrsignale eine Synchronisation am ersten Punkt jedes Arbiträrsignals (nur Zweikanalgeräte) ausführen.

Parameter | Typische Rückgabe
(keine) | (keine)
Laden Sie ein Haversine-Signal in Kanal 1 und ein benutzerdefiniertes Arbiträrsignal von einem USB-Laufwerk in Kanal 2. Legen Sie beide Abtastraten auf 100 kSa/s fest und synchronisieren Sie beide Kanäle am ersten Punkt jedes Signals: MMEM:LOAD:DATA "Int:\Builtin\HAVERSINE.arb" FUNC:ARB "Int:\Builtin\HAVERSINE.ARB" FUNC ARB FUNC:ARB:SRATE 1E+05 MMEM:LOAD:DATA2 "USB:\MyFiles\TestDUT3.arb" SOUR2:FUNC:ARB "USB:\MyFiles\TestDUT3.arb" SOUR2:FUNC ARB SOUR2:FUNC:ARB:SRAT 1E+05 FUNC:ARB:SYNC
  • Dieser Befehl stoppt auf beiden Kanälen die Arbiträrsignale und startet sie neu, egal auf welche Abtastrate sie festgelegt sind.
  • Wenn die beiden Arbiträrsignale dieselbe Punktzahl und Abtastrate haben, bleiben sie über viele Wiederholungen synchronisiert; anderenfalls werden sie nur zu Beginn und nach einer bestimmten Anzahl von Wiederholungen synchronisiert, die ein Vielfaches der Punktzahl beider Signale ist. Wenn Sie zum Beispiel ein 8-Punkte-Signal und ein 10-Punkte-Signal synchronisieren, werden sie nach 40, 80 und 120 Wiederholungen neu synchronisiert.
  • Diese Funktion ist ähnlich wie die Burst-Betriebsart, bewirkt aber einen kontinuierlichen Signalmodus.
  • Beim Versuch, zwei Arbiträrsignale zu synchronisieren, arbeitet dieser Befehl auch mit Burst, Wobbelung und Modulation.

[SOURce[1|2]:]FUNCtion:NOISe:BANDwidth {<bandwidth>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]FUNCtion:NOISe:BANDwidth? [{MINimum|MAXimum}]

Legt Bandbreite der Rauschfunktion fest.

Parameter | Typische Rückgabe
1 mHz bis maximale Gerätefrequenz, Standard 100 kHz | +6,000000000000000E+03
Einstellen der Bandbreite auf 20 kHz: FUNC:NOISe:BWIDth 20000
  • Die Rauschfunktion erzeugt ein weißes Gaußsches Rauschen mit einem Scheitelfaktor von 4,6.
  • Die Bandbreite des Rauschens ist immer einstellbar, um die Rauschenergie im Frequenzbereich von 0 Hz bis zur spezifizierten Rauschbandbreitenfrequenz zu erhöhen.

[SOURce[1|2]:]FUNCtion:PRBS:BRATe {<bit_rate>| MINimum|MAXimum|DEFault}
[SOURce[1|2]:]FUNCtion:PRBS:BRATe? [{MINimum|MAXimum}]

Legt die Bitrate für die pseudozufällige Binärfolge (PRBS) fest.

Parameter | Typische Rückgabe
1 mbit/s bis Maximum für das Gerät zulässig, Standard 1000 bit/s | +1,920000000000000E+04
Festlegen der Bitrate auf 19.200 Bits pro Sekunde FUNC:PRBS:BRATe 19200
  • Ein PRBS-Signal, das ein Polynom PNx verwendet, wird durch ein x-Bit-Schieberegister generiert und das Ausgangssignal beginnt mit x Samplingperioden mit hoher Ausgabe. Die Samplingperiode ist der Reziprokwert der Abtastrate (FUNCtion:PRBS:BRATe) und der Sync-Puls des Kanals gibt den Start des Signals an. Verwendet beispielsweise das PRBS-Signal PN23 mit einer Abtastrate von 500 Hz, beginnt die Ausgabe mit einer 46 ms hohen Ausgabe (23 x 2 ms).
  • Die Bitrate ist unabhängig von der Datensequenzlänge.

[SOURce[1|2]:]FUNCtion:PRBS:DATA <sequence_type>
[SOURce[1|2]:]FUNCtion:PRBS:DATA?

Legt die (PRBS) -Art der pseudozufälligen Binärfolge fest. Die Einstellung des Sequenztyps legt Länge und Feedbackwerte wie unten beschrieben fest.

Parameter | Typische Rückgabe
33500 Series Geräte: {PN7|PN9|PN11|PN15|PN20|PN23} 33600 Series Geräte: PN3 bis PN32 (alle 30 möglichen Werte von 3 bis 32) Wert nach PN entspricht der maximalen Schieberegisterlänge in Bits. Standard ist PN7. | PN# (PN3 bis PN9) oder PN## (PN10 bis PN32), wobei jedes # einer Ziffer entspricht.
Datenformat auf PN23 einstellen: FUNC:PRBS:DATA PN23
  • SYNC Ausgang kann während einer PRBS-Funktion aktiv sein, im Gegensatz zur Funktion NOISe. Der SYNC Ausgang markiert das erste Datenbit eines PRBS-Signals.
  • Ein PRBS-Signal, das ein Polynom PNx verwendet, wird durch ein x-Bit-Schieberegister generiert und das Ausgangssignal beginnt mit x Samplingperioden mit hoher Ausgabe. Die Samplingperiode ist der Reziprokwert der Abtastrate (FUNCtion:PRBS:BRATe) und der Sync-Puls des Kanals gibt den Start des Signals an. Verwendet beispielsweise das PRBS-Signal PN23 mit einer Abtastrate von 500 Hz, beginnt die Ausgabe mit einer 46 ms hohen Ausgabe (23 x 2 ms). Die Polynome sind unten aufgeführt.

    Sequenztyp | Polynom | Länge
    PN3 | x3 + x2 + 1 | 3
    PN4 | x4 + x3 + 1 | 4
    PN5 | x5 + x3 + 1 | 5
    PN6 | x6 + x5 + 1 | 6
    PN7 | x7 + x6 + 1 | 7
    PN8 | x8 + x6 + x5 + x4 + 1 | 8
    PN9 | x9 + x5 + 1 | 9
    PN10 | x10 + x7 + 1 | 10
    PN11 | x11 + x9 + 1 | 11
    PN12 | x12 + x6 + x4 + x1 + 1 | 12
    PN13 | x13 + x4 + x3 + x1 + 1 | 13
    PN14 | x14 + x5 + x3 + x1 + 1 | 14
    PN15 | x15 + x14 + 1 | 15
    PN16 | x16 + x15 + x13 + x4 + 1 | 16
    PN17 | x17 + x14 + 1 | 17
    PN18 | x18 + x11 + 1 | 18
    PN19 | x19 + x6 + x2 + x1 + 1 | 19
    PN20 | x20 + x17 + 1 | 20
    PN21 | x21 + x19 + 1 | 21
    PN22 | x22 + x21 + 1 | 22
    PN23 | x23 + x18 + 1 | 23
    PN24 | x24 + x23 + x22 + x17 + 1 | 24
    PN25 | x25 + x22 + 1 | 25
    PN26 | x26 + x6 + x2 + x1 + 1 | 26
    PN27 | x27 + x5 + x2 + x1 + 1 | 27
    PN28 | x28 + x25 + 1 | 28
    PN29 | x29 + x27 + 1 | 29
    PN30 | x30 + x6 + x4 + x1 + 1 | 30
    PN31 | x31 + x28 + 1 | 31
    PN32 | x32 + x22 + x2 + x1 + 1 | 32

[SOURce[1|2]:]FUNCtion:PRBS:TRANsition[:BOTH] {<seconds>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]FUNCtion:PRBS:TRANsition[:BOTH]? [{MINimum|MAXimum}]

Legt PRBS-Übergangszeit an beiden Flanken eines PRBS-Übergangs fest.

Parameter | Typische Rückgabe
33500 Series Geräte: 8,4 ns (Standard) für 1 μsec, eingeschränkt wie unten beschrieben 33600 Series Geräte: 2,9 ns bis zu 4 Vpp, und 3,3 ns über 4Vpp bis 1 μsec; eingeschränkt wie unten beschrieben | +1,000000000000000E‑08
Stellt Flankenzeit auf 10 ns für die Anstiegs- und Abfallflanken ein (zwei Methoden): FUNC:PRBS:TRAN 10 ns FUNC:PRBS:TRAN ,000000010
  • Das Standardschlüsselwort "BOTH" ist optional und ermöglicht eine gleichzeitige Kontrolle der Anstiegs- und Abfallflanken des PRBS-Signals.
  • Die Flankenzeit betrifft sowohl steigende als auch fallende Flanken und stellt die Zeit zwischen den Schwellenwerten 10% und 90% jeder Flanke dar.
  • Die spezifizierte Flankenzeit muss zur spezifizierten Periode passen. Das Gerät wird die Flankenzeit beschränken, soweit dies nötig ist, um die spezifizierte Bitrate anzupassen. Über die Remote-Schnittstelle wird ebenfalls der Fehler "Settings conflict" generiert.

[SOURce[1|2]:]FUNCtion:PULSe:DCYCle {<percent>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]FUNCtion:PULSe:DCYCle? [{MINimum|MAXimum}]

Legt Tastverhältnis des Pulssignals fest.

Parameter | Typische Rückgabe
0 bis 100, eingeschränkt wie unten beschrieben; Standard 10 | +5,000000000000000E+01
Stellt Tastverhältnis auf 50% ein: FUNC:PULS:DCYC 50
  • Die Befehle FUNCtion:PULSe:DCYCle und FUNCtion:PULSe:WIDTh betreffen den gleichen Parameter. Bei manchen Anwendungen ist es normal, die Pulsbreite direkt (in Sekunden) anzupassen; bei anderen ist die Anpassung des Tastverhältnisses besser geeignet. Bei der Anpassung der Frequenz gilt: Wenn die Pulsbreite vor Kurzem als Tastverhältnis über die Frontplatte eingestellt wurde, wird das Tastverhältnis konstant gehalten, wenn sich Frequenz oder Periode ändern. Wurde jedoch die Pulsbreite zuletzt eingestellt, wird die Pulsbreite konstant gehalten, wenn sich Frequenz oder Periode ändern. Siehe FUNCtion:PULSe:HOLD.
  • Das Tastverhältnis eines Pulssignals ist folgendermaßen definiert:

    Duty Cycle = 100 x Pulse Width ÷ Period

    Die Pulsbreite ist die Zeit vom 50% Schwellenwert der steigenden Flanke eines Pulses bis zum 50% Schwellenwert der nächsten fallenden Flanke.
  • Der Tastverhältnisbereich liegt zwischen 0 Prozent und 100 Prozent. Es gelten jedoch die Einschränkungen für minimale Pulsbreite und Flankenzeit, so dass das Tastverhältnis nicht auf genau 0 Prozent oder genau 100 Prozent eingestellt werden kann. Bei einem 1 kHz Pulssignal beispielsweise ist das Tastverhältnis normalerweise auf einen Bereich zwischen 0,002 Prozent und 99,998 Prozent beschränkt. Dies ist durch die minimale Pulsbreite von 16 ns bei 33500 Series Geräten oder 5 ns bis zu 4 Vpp und 8 ns bis zu 10 Vpp bei 33600 Series Geräten begrenzt.
  • Einschränkungen durch die Pulsbreite: Das spezifizierte Tastverhältnis eines Pulssignals muss die folgenden Einschränkungen aufweisen, die durch die minimale Pulsbreite bedingt sind. Das Gerät passt das Tastverhältnis des Pulssignals automatisch entsprechend an die spezifizierte Periode an. Über die Remote-Schnittstelle wird ebenfalls der Fehler "Settings conflict" generiert.

Tastverhältnis ³ 100(minimale Pulsbreite/ Periode)

und

Tastverhältnis £ 100 (1 – minimale Pulsbreite/ Periode)

Bei 33500 Series Geräten beträgt die minimale Pulsbreite 16 ns. Bei 33600 Series Geräten beträgt die minimale Pulsbreite 5 ns bis 4 Vpp und 8 ns bis 10 Vpp.

  • Einschränkungen, die auf der Flankenzeit basieren und sich auf diese auswirken: Das spezifizierte Tastverhältnis eines Pulssignals hat möglicherweise Auswirkungen auf die Flankenzeit. Zuerst wird die Flankenzeit und dann das Tastverhältnis an die spezifizierte Periode angepasst, um folgende Beschränkung einzuhalten. Über die Remote-Schnittstelle wird ebenfalls der Fehler "Settings conflict" generiert.

Tastverhältnis ³ [(0,8 x Anstiegsflankenzeit) + (0,8 x Abfallflankenzeit) ]/ Periode x 100

und

Tastverhältnis £ [1 – [(0,8 x Anstiegsflankenzeit) + (0,8 x Abfallflankenzeit) ]/ Periode] x 100

[SOURce[1|2]:]FUNCtion:PULSe:HOLD {WIDTh|DCYCle}
[SOURce[1|2]:]FUNCtion:PULSe:HOLD?

Legt den Pulssignal-Parameter fest (entweder Pulsbreite oder Tastverhältnis), der konstant gehalten werden muss, wenn andere Parameter variieren.

Parameter | Typische Rückgabe
{WIDTh|DCYCle}, Standard WIDTh | WIDT oder DCYC
Das Gerät so einstellen, dass das Tastverhältnis für Pulssignale gehalten wird: FUNC:PULS:HOLD DCYC
  • WIDTh: Die Einstellung der Pulsbreite (in Sekunden) bleibt gleich, während die Periode geändert wird. Wenn ein Befehl zum Einstellen des Tastverhältnisses empfangen wird, wird das Tastverhältnis in die entsprechende Pulsbreite umgewandelt. Wenn die Pulsbreitenmodulation (PWM) aktiviert ist, werden Pulsbreite und Pulsbreitenabweichung gehalten, während die Periode variiert. Tastverhältnisabweichungsbefehle werden in Werte für die Abweichungen der Pulsbreite umgerechnet.

    Die Einschränkungen in Bezug auf minimale Pulsbreite und Flankenzeit sind gültig. Könnte zu einer Veränderung von gewählten Flankenzeiten, Pulsbreite oder beiden führen.
  • DCYCle: Die Einstellung des Tastverhältnisses (in Prozent) bleibt gleich, während die Periode geändert wird. Wenn ein Befehl zum Einstellen der Pulsbreite empfangen wird, wird die Pulsbreite in das entsprechende Tastverhältnis umgewandelt. Wenn die Pulsbreitenmodulation (PWM) aktiviert ist, werden das Tastverhältnis eines Pulssignals und die Tastverhältnisabweichung gehalten, während die Periode variiert. Eingaben zur Pulsbreitenabweichung werden in Werte für die Abweichung des Tastverhältnisses umgerechnet.

    Die Einschränkungen in Bezug auf minimale Pulsbreite und Flankenzeit sind gültig. Könnte zu einer Veränderung der gewählten Flankenzeiten, des Tastverhältnisses oder beider Werte führen.

Hinweis

Der Befehl FUNCtion:PULSe:HOLD schränkt die Periodeneinstellungen nicht ein. Pulsbreite oder Tastverhältnis können bei Bedarf einer neuen Periodeneinstellung angepasst werden.

[SOURce[1|2]:]FUNCtion:PULSe:PERiod {<seconds>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]FUNCtion:PULSe:PERiod? [{MINimum|MAXimum}]

Legt die Periode für Pulssignale fest. Dieser Befehl hängt mit dem Befehl FREQuency zusammen; der zuletzt ausgeführte hat Vorrang vor dem anderen, da Frequenz und Periode denselben Parameter angeben.

Parameter | Typische Rückgabe
Vom Reziprokwert der maximalen Gerätefrequenz bis 1.000.000 s. Standard 1 ms | +2,000000000000000E‑07
Stellen Sie die Periode auf 500 ms ein: FUNC:PULS:PER .5 oder FUNC:PULS:PER 500 ms
  • Die spezifizierte Periode muss größer sein als die Summe aus Pulsbreite und Flankenzeit. Das Gerät passt die Flankenzeit und die Pulsbreite automatisch an die angegebene Periode an. Über die Remote-Schnittstelle wird ebenfalls der Fehler "Settings conflict" generiert. Als Erstes wird die Flankenzeit minimiert und anschließend die Pulsbreite (oder das Tastverhältnis) wie unten dargestellt angepasst.

    Periode ³ [Pulsbreite + ((Anstiegsflankenzeit + Abfallflankenzeit) * 0,625)]
  • Dieser Befehl beeinflusst die Periode (und Frequenz) aller Ausgangsfunktionen (nicht nur der Ausgangsfunktion „Pulse“). Beispiel: Wenn Sie mit dem Befehl FUNCtion:PULSe:PERiod eine Periode spezifizieren und dann auf die Ausgangsfunktion Sinussignal umschalten, gilt die spezifizierte Periode auch für die neue Ausgangsfunktion.
  • Funktionsbegrenzungen: Beim Wechsel zu einer Funktion, deren minimale Periode den durch diesen Befehl eingestellten Wert überschreitet, wird die Periode an den minimalen Puls der neuen Periode angepasst. Wenn Sie beispielsweise eine Periode von 2 µs einstellen und dann zur Sägezahnfunktion wechseln, ändert das Gerät die Periode zu 5 µs (Mindestwert für Sägezahnfunktion). Über die Remote-Schnittstelle wird ebenfalls der Fehler "Settings conflict" generiert.

[SOURce[1|2]:]FUNCtion:PULSe:TRANsition[:BOTH] {<seconds>|MINimum|MAXimum|DEFault}

[SOURce[1|2]:]FUNCtion:PULSe:TRANsition:LEADing {<seconds>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]FUNCtion:PULSe:TRANsition:LEADing? [{MINimum|MAXimum}]

[SOURce[1|2]:]FUNCtion:PULSe:TRANsition:TRAiling {<seconds>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]FUNCtion:PULSe:TRANsition:TRAiling? [{MINimum|MAXimum}]

Stellt die Flankenzeit an der Anstiegsflanke, Abfallflanke oder an beiden Flanken eines Pulses ein.

Parameter | Typische Rückgabe
33500 Series Geräte: 8,4 ns (Standard) für 1 μsec, eingeschränkt wie unten beschrieben 33600 Series Geräte: 2,9 ns bis zu 4 Vpp, und 3,3 ns über 4Vpp bis 1 μsec; eingeschränkt wie unten beschrieben | +1,000000000000000E‑08
Anstiegsflankenzeit auf 10 ns einstellen (zwei Methoden): FUNC:PULS:TRAN:LEADing 10 ns FUNC:PULS:TRAN:LEADing ,000000010
  • Die Flankenzeit gilt für die steigende Flanke und stellt die Zeit zwischen den Schwellenwerten 10% und 90% der Flanke dar. Die Abfallflanke stellt die Zeit zwischen den Schwellenwerten 90% und 10% dar.
  • Die spezifizierte Flankenzeit muss kleiner sein als die spezifizierte Pulsbreite und Periode. Das Gerät passt die Flankenzeit an die angegebene Pulsbreite oder das Tastverhältnis an. Über die Remote-Schnittstelle wird ebenfalls der Fehler "Settings conflict" generiert.

[SOURce[1|2]:]FUNCtion:PULSe:WIDTh {<seconds>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]FUNCtion:PULSe:WIDTh? [{MINimum|MAXimum}]

Einstellung der Pulsbreite.

Parameter | Typische Rückgabe
16 ns (33500 Series), 5 ns (33600 Series bis 4 Vpp), oder 8 ns (33600 Series bis 10 Vpp) bis ca. 1.000.000 s, eingeschränkt wie unten beschrieben; Standard 100 µs | +5,000000000000000E‑03
Stellen Sie die Pulsbreite auf 5 ms ein (zwei Methoden): FUNC:PULS:WIDT 5 ms FUNC:PULS:WIDT ,005
  • Die Befehle FUNCtion:PULSe:DCYCle und FUNCtion:PULSe:WIDTh betreffen den gleichen Parameter. Bei manchen Anwendungen ist es normal, die Pulsbreite direkt (in Sekunden) anzupassen; bei anderen ist die Anpassung des Tastverhältnisses besser geeignet. Bei der Anpassung der Frequenz gilt: Wenn die Pulsbreite vor Kurzem als Tastverhältnis über die Frontplatte eingestellt wurde, wird das Tastverhältnis konstant gehalten, wenn sich Frequenz oder Periode ändern. Wurde jedoch die Pulsbreite zuletzt eingestellt, wird die Pulsbreite konstant gehalten, wenn sich Frequenz oder Periode ändern. Siehe FUNCtion:PULSe:HOLD.
  • Die Pulsbreite ist die Zeit vom 50% Schwellenwert der steigenden Flanke eines Pulses bis zum 50% Schwellenwert der nächsten fallenden Flanke.
  • Die spezifizierte Pulsbreite muss kleiner sein als die Differenz zwischen der Periode und der minimalen Pulsbreite; siehe nachfolgende Gleichung. Das Gerät passt zunächst die Pulsflankenzeit an und begrenzt dann die Pulsbreite, damit sie zur Periode passt. Über die Remote-Schnittstelle wird ebenfalls der Fehler "Settings conflict" generiert.

    Pulsbreite £ Periode – Wmin
  • Die spezifizierte Pulsbreite muss ebenfalls kleiner sein als die Differenz zwischen der Periode und der Flankenzeit; siehe nachfolgende Gleichung. Das Gerät passt zunächst die Pulsflankenzeit an und begrenzt dann die Pulsbreite, damit sie zur Periode passt. Über die Remote-Schnittstelle wird ebenfalls der Fehler "Settings conflict" generiert.

    Pulsbreite £ [Periode - ((Anstiegsflankenzeit + Abfallflankenzeit) * 0,625)]
  • Die Pulsbreite muss außerdem größer sein als die Gesamtzeit einer Flanke; siehe nachfolgende Gleichung.

    Pulsbreite ³ [(Anstiegsflankenzeit + Abfallflankenzeit) * 0,625]

[SOURce[1|2]:]FUNCtion:RAMP:SYMMetry {<percent>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]FUNCtion:RAMP:SYMMetry? [{MINimum|MAXimum}]

Dieser Befehl spezifiziert das Symmetrieverhältnis für Sägezahnsignale.

Parameter | Typische Rückgabe
0 bis 100, Standard 100 | +5,000000000000000E+01
Symmetrieverhältnis auf 50% festlegen: FUNC:RAMP:SYMM 50
  • Das Symmetrieverhältnis ist definiert als das prozentuale Verhältnis der Anstiegsdauer des Sägezahnsignals zur Periodendauer. Diese Definition bezieht sich auf normale (nicht-invertierte) Signalpolarität.

    • Symmetrie 0%

    Symmetrie 100%
  • Bei Sägezahnsignalen wählt der Befehl APPLy:RAMP unabhängig von der aktuellen Symmetrieverhältnis-Einstellung ein Tastverhältnis von 100%. Um ein anderes Symmetrieverhältnis als 100% einzustellen, wählen Sie mit dem Befehl FUNCtion RAMP einen anderen Sägezahlsignal Ausgang und benutzen Sie dann FUNCtion:RAMP:SYMMetry, um das Symmetrieverhältnis festzulegen.
  • Die Symmetrieverhältnis-Einstellung geht beim Umschalten von Sägezahn auf eine andere Funktion nicht verloren. Sobald Sie wieder auf Sägezahn umschalten, gilt wieder das zuvor gewählte Symmetrieverhältnis.
  • Wenn das Modulationssignal für AM, FM, PM oder PWM ein Sägezahnsignal ist, gilt die Symmetrieeinstellung nicht. Das Gerät verwendet immer ein Sägezahnsignal mit dem Symmetrieverhältnis 100%.

[SOURce[1|2]:]FUNCtion:SQUare:DCYCle {<percent>|MINimum|MAXimum}
[SOURce[1|2]:]FUNCtion:SQUare:DCYCle? [{MINimum|MAXimum}]

Legt das Tastverhältnis für Rechtecksignale fest.

Parameter | Typische Rückgabe
0,01 bis 99,99, es gilt eine Einschränkung auf 16 ns minimale Pulsbreite; Standard 50 | +5,000000000000000E+01
Stellt Tastverhältnis auf 30% ein: FUNC:SQU:DCYC 30 Stellt das Tastverhältnis auf seinen minimalen Wert ein: FUNC:SQU:DCYC MIN
  • Das Tastverhältnis ist definiert als der Zeitabschnitt, an dem das Rechtecksignal auf "HIGH" steht (bei normaler Polarität).
  • Bei Rechtecksignalen ersetzt APPLy:SQUare das aktuell eingestellte Tastverhältnis durch 50%. Um ein anderes Tastverhältnis als 50% einzustellen, Rechtecksignal mit FUNCtion SQUare wählen, dann FUNCtion:SQUare:DCYCle verwenden.
  • Die Tastverhältnis-Einstellung geht beim Umschalten von Rechteck auf eine andere Signalform nicht verloren. Sobald Sie wieder auf das Rechtecksignal umschalten, gilt wieder das zuvor gewählte Tastverhältnis.
  • Einschränkungen durch die Frequenz: Wenn die Frequenz erhöht wird, werden das minimale und maximale Tastverhältnis angepasst, um eine minimale Pulsbreite von 16 ns (33500 Series), 5ns (33600 Series bis 4 Vpp) oder 8 ns (33600 Series bis 10 Vpp) zu erhalten. Bei 1 MHz zum Beispiel beträgt das minimale Tastverhältnis bei 33500 Series Geräten 1,60% und das maximale Tastverhältnis 98,40%. Bei 10 MHz beträgt das minimale Tastverhältnis 16,00% und das maximale Tastverhältnis 84,00%.
  • Wenn ein Rechtecksignal als Modulationssignal für AM, FM, PM oder PWM ausgewählt wird, benutzt das Gerät immer ein Rechtecksignal mit einem Tastverhältnis von 50%.

[SOURce[1|2]:]FUNCtion:SQUare:PERiod {<seconds>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]FUNCtion:SQUare:PERiod? [{MINimum|MAXimum}]

Legt die Periode für das Rechtecksignal fest.

Parameter | Typische Rückgabe
Vom Reziprokwert der maximalen Rechtecksignalfrequenz bis 1.000.000 s, Standard 1 ms | +5,000000000000000E‑01
Stellen Sie die Periode auf 500 ms ein (zwei Methoden): FUNC:SQUare:PER ,5 FUNC:SQUare:PER 500 ms
  • Funktionsbegrenzungen: Beim Wechsel zu einer Funktion, deren minimale Periode den durch diesen Befehl eingestellten Wert überschreitet, wird die Periode an den minimalen Puls der neuen Periode angepasst. Wenn Sie beispielsweise eine Periode von 2 µs einstellen und dann zur Sägezahnfunktion wechseln, ändert das Gerät die Periode zu 5 µs (Mindestwert für Sägezahnfunktion). Über die Remote-Schnittstelle wird ebenfalls der Fehler "Settings conflict" generiert.

Die unten aufgeführten Befehle erfordern alle die IQ Player Option.

FUNCtion:ARBitrary:BALance[:STATe] {ON|1|OFF|0}
FUNCtion:ARBitrary:BALance[:STATe]?

(nur IQ Player Option)

Aktiviert oder deaktiviert die Kanalangleichung für duale Arbiträrsignale (FUNCtion:ARBitrary:BALance:GAIN und FUNCtion:ARBitrary:BALance:OFFSet).

Parameter | Typische Rückgabe
{ON|1|OFF|0}, Standard OFF | 0 (OFF) oder 1 (ON)

Laden Sie ein Arbiträrsignal über das USB-Laufwerk und stellen Sie den Verstärkungsabgleich (Kanal 2 um 1,02% niedriger) und Abgleich-Offsets (120 mV für Kanal 1 und -38 mV für Kanal 2) erneut ein:

FUNC:ARB "USB:\qam32.barb"
FUNC:ARB:BAL:GAIN 1,02
FUNC:ARB:BAL:OFFS1 0,12
FUNC:ARB:BAL:OFFS2 -0,038
FUNC:ARB:BAL ON
  • Diese Funktion kann benutzt werden, um kleinere Abweichungen der Lastimpendanzen der beiden Kanäle auszugleichen, oder bei kleineren Unterschieden zwischen den beiden Informationskanälen in der Originaldatei des dualen Arbiträrsignals.
  • Wenn <state> eingeschaltet ist, müssen beide Kanäle im selben Verstärkerbereich bleiben.
  • Diese Einstellung wird als Teil des Gerätezustands gespeichert und durch *RST verändert.

FUNCtion:ARBitrary:BALance:GAIN {<percent>|MINimum|MAXimum|DEFine}
FUNCtion:ARBitrary:BALance:GAIN? [{MINimum|MAXimum}]

(nur IQ Player Option)

Legt das Verhältnis des Verstärkungsabgleichs für duale Arbiträrsignale fest.

Parameter | Typische Rückgabe
-30 bis +30 | +1,02000000E+000

Laden Sie ein Arbiträrsignal über das USB-Laufwerk und stellen Sie den Verstärkungsabgleich (Kanal 2 um 1,02% niedriger) und Abgleich-Offsets (120 mV für Kanal 1 und -38 mV für Kanal 2) erneut ein:

FUNC:ARB "USB:\qam32.barb"
FUNC:ARB:BAL:GAIN 1,02
FUNC:ARB:BAL:OFFS1 0,12
FUNC:ARB:BAL:OFFS2 -0,038
FUNC:ARB:BAL ON
  • Beide Kanäle müssen im selben Verstärkerbereich bleiben.
  • Der Wert 0 bedeutet, dass beide Kanäle ihre aktuelle Amplitude benutzen. Ein positiver Wert bedeutet, dass die Amplitude von Kanal 2 gesenkt wird, während die Amplitude von Kanal 1 konstant bleibt. Ein negativer Wert senkt Kanal 1, während Kanal 2 konstant bleibt. Beispiele finden Sie in der folgenden Tabelle.

    <Prozent> Kanal 1
    Amplitude %     		Kanal 2
    Amplitude %
    -20 | 80 | 100
    -10 | 90 | 100
    0 | 100 | 100
    10 | 100 | 90
    20 | 100 | 80
  • Dieser Befehl wird aktiviert durch FUNCtion:ARBitrary:BALance ON.
  • Diese Einstellung wird als Teil des Gerätezustands gespeichert und durch *RST verändert.

FUNCtion:ARBitrary:BALance:OFFSet{1|2} {<volts>|MINimum|MAXimum|DEFault}
FUNCtion:ARBitrary:BALance:OFFSet{1|2}? [MINimum|MAXimum]

(nur IQ Player Option)

Spezifiziert den Offset (in Volt), der zum Offset des dualen Arbiträrsignals für den spezifizierten Kanal hinzugefügt wird.

Parameter | Typische Rückgabe
Ein Gleitkommawert, eingeschränkt durch die Amplitude des dualen Arbiträrsignals. | +1,00000000E+000

Laden Sie ein Arbiträrsignal über das USB-Laufwerk und stellen Sie den Verstärkungsabgleich (Kanal 2 um 1,02% niedriger) und Abgleich-Offsets (120 mV für Kanal 1 und -38 mV für Kanal 2) erneut ein:

FUNC:ARB "USB:\qam32.barb"
FUNC:ARB:BAL:GAIN 1,02
FUNC:ARB:BAL:OFFS1 0,12
FUNC:ARB:BAL:OFFS2 -0,038
FUNC:ARB:BAL ON
  • Beide Kanäle müssen im selben Verstärkerbereich bleiben.
  • Dieser Befehl wird aktiviert durch FUNCtion:ARBitrary:BALance ON.
  • Diese Einstellung wird als Teil des Gerätezustands gespeichert und durch *RST verändert.

FUNCtion:ARBitrary:SKEW[:STATe] {ON|1|OFF|0}
FUNCtion:ARBitrary:SKEW[:STATe]?

(nur IQ Player Option)

Aktiviert oder deaktiviert den Zeitversatzausgleich (FUNCtion:ARBitrary:SKEW:TIME). Steht immer auf OFF für modulierte Signale, Wobbelungen, Listen und Spitzen.

Parameter | Typische Rückgabe
{ON|1|OFF|0}, Standard OFF | 0 (OFF) oder 1 (ON)
Stellen Sie den Zeitversatz ein, um zu kompensieren, dass Kanal 1 um 140 Pikosekunden hinter Kanal 2 liegt: FUNCtion:ARBitrary:SKEW:TIME 1,4e-10 FUNCtion:ARBitrary:SKEW ON
  • Der Zeitversatzausgleich wird normalerweise empirisch bestimmt, indem ein Oszilloskop verwendet und dann One-Time festgelegt wird. Dieser One-Time-Setup bleibt dann gültig, bis sich das Messobjekt oder die Anordnung der Testgeräte ändert.
  • Der durch diesen Befehl angegebene Wert wird nicht im Gerätestatus gespeichert. Er wird im permanenten Speicher gespeichert und ist nicht von *RST betroffen.

FUNCtion:ARBitrary:SKEW:TIME [{<time>|MINimum|MAXimum|DEFault}]
FUNCtion:ARBitrary:SKEW:TIME? [{MINimum|MAXimum}]

(nur IQ Player Option)

Legt einen kleinen Zeitunterschied zwischen den Kanälen fest, um kleinere Abweichungen bei der Zeiteinstellung an der Ausgangsanschlussebene oder am Messobjekt (DUT) auszugleichen. Dann FUNC:ARB:SKEW[:STATe] OFF für modulierte Signale, Wobbelungen, Listen und Spritzen notieren.

Parameter | Typische Rückgabe
Gleitkommawert im Bereich ±4 ns. Standard 0. | +1.40000000E‑010
Stellen Sie den Zeitversatz ein, um zu kompensieren, dass Kanal 1 um 140 Pikosekunden hinter Kanal 2 liegt: FUNCtion:ARBitrary:SKEW:TIME 1,4e-10 FUNCtion:ARBitrary:SKEW ON
  • Kanäle können an der Ausgangsanschlussebene leichte Zeitverschiebungen aufweisen, die auf Abweichungen im inneren Schaltkreis zwischen den beiden Kanälen zurückzuführen sind. Sie können leichte Zeitverschiebungen am Messobjekt (DUT) aufweisen, die auf Abweichungen bei Signalpfaden inklusive Elementen wie Schaltern und Kabellängen zurückzuführen sind.
  • Ein positiver Wert verzögert Kanal 2, ein negativer Wert verzögert Kanal 1.
  • Der durch diesen Befehl angegebene Wert wird nicht im Gerätestatus gespeichert. Er wird im permanenten Speicher gespeichert und ist nicht von *RST betroffen.


HCOPy Subsystem

Das HCOPy-Subsystem produziert Bildschirmbilder ("Screenshots") von der Anzeige der Frontplatte.

Beispiel

Im folgenden Beispiel wird die Bildschirmanzeige der Frontplatte erfasst und im BMP-Format wiedergegeben.

HCOP:SDUM:DATA:FORM BMP
HCOP:SDUM:DATA?

HCOPy:SDUMp:DATA?

Gibt das Bildschirmbild der Frontplattenanzeige wieder ("Screenshot")

Parameter | Typische Rückgabe
(keine) | (Ein Binärblock bestimmter Länge, der das Bild enthält.) Blockdaten mit bestimmter Länge ermöglichen die Übertragung jeder Art geräteabhängiger Daten als Serie von binären Datenbytes (8 Bit). Dies ist besonders nützlich, um große Datenmengen oder erweiterte ASCII-Codes mit 8 Bit zu übermitteln.
Bildschirmbild erfassen und wiedergeben: HCOP:SDUM:DATA?
  • Das Bildformat (PNG oder BMP) wird angegeben durch HCOPy:SDUMp:DATA:FORMat.

HCOPy:SDUMp:DATA:FORMat {PNG|BMP}
HCOPy:SDUMp:DATA:FORMat?

Bestimmt das Bildformat für Bilder, die über HCOPy:SDUMp:DATA? wiedergegeben werden.

Parameter | Typische Rückgabe
{PNG|BMP}, Standard PNG | PNG oder BMP
Bildschirmbildformat einstellen auf BMP HCOP:SDUM:DATA:FORM BMP


IEEE-488 Universalbefehle

Dieses Subsystem enthält Befehle und Anfragen im Zusammenhang mit den IEEE-488 Standards:

*CLS - Status löschen

*ESE <enable_value> - Ereigniszustand aktivieren

*ESR? - Register Ereigniszustand abfragen

*IDN? - Geräteindentifizierung

*OPC - Bit Operation Complete setzen

*OPC? - Wartet auf Abschluss des aktuellen Vorgangs

*OPT? - Installierte Optionen anzeigen

*PSC {0|1} - Status beim Einschalten löschen

*RCL {0|1|2|3|4} - Gerätestatus abrufen

*RST - Gerät zurücksetzen auf Werkseinstellungen

*SAV {0|1|2|3|4} - Gerätestatus speichern

*SRE <enable_value> - Serviceanforderung auslösen (Bits im Aktivierungsregister der Registergruppe Status Byte aktivieren

*STB? - Statusbyte ablesen

*TRG - Triggerbefehl

*TST? - Selbsttest

*WAI - Warten auf Abschluss aller aktuellen Vorgänge

Register

Einige der IEEE-488 Befehle hängen mit verschiedenen Registern des Geräts zusammen. Diese Register werden unten beschrieben.

„Standard Event“-Register

Die folgende Tabelle beschreibt das „Standard Event“-Register.

    Bit-Nummer | Bit-Name | Dezimalwert | Definition
0 | Vorgang abgeschlossen | 1 | Alle vorherigen Befehle und *OPC wurden ausgeführt.
1 | (nicht verwendet) | 2 | (Für die zukünftige Verwendung vorgesehen)
2 | Query Error | 4 | Das Gerät versuchte, den Ausgangspuffer zu lesen, aber dieser war leer. Oder: Das Gerät hat eine neue Befehlszeile empfangen, bevor eine vorangehende Abfrage eingelesen war. Oder: Sowohl der Eingangspuffer als auch der Ausgangspuffer sind voll.
3 | Gerätespezifischer Fehler | 8 | Ein gerätespezifischer Fehler, u.a. ein Selbsttestfehler, ein Kalibrierungsfehler oder ein anderer gerätespezifischer Fehler ist aufgetreten. Siehe Fehlermeldungen.
4 | Ausführungsfehler | 16 | Ein Ausführungsfehler ist aufgetreten. Fehlermeldungen
5 | Befehl | 32 | Ein Befehlssyntaxfehler ist aufgetreten. Fehlermeldungen
6 | (nicht verwendet) | 64 | (Für die zukünftige Verwendung vorgesehen)
7 | Einschalten | 128 | Das Gerät wurde aus- und wieder eingeschaltet, seit das „Event“-Register das letzte Mal gelesen oder zurückgesetzt wurde.

„Status Byte“-Register

Die folgende Tabelle beschreibt das „Standard Byte“-Register.

Bit-Nummer | Bit-Name | Dezimalwert | Definition
0 | (nicht verwendet) | 1 | (Für die zukünftige Verwendung vorgesehen)
1 | (nicht verwendet) | 2 | (Für die zukünftige Verwendung vorgesehen)
2 | Fehlerwarteschlange | 4 | Ein oder mehrere Fehler in der Fehlerwarteschlange. Verwenden Sie SYSTem:ERRor?, um Fehler anzuzeigen und zu löschen.
3 | „Questionable Data“ Überblick | 8 | Ein oder mehrere Bits des „Questionable Data“-Registers sind gesetzt (diese Bits müssen aktiviert sein, siehe STATus:QUEStionable:ENABle ).
4 | Meldung Verfügbar | 16 | Im Ausgangspuffer stehen Daten bereit.
5 | „Standard Event“ Überblick | 32 | Ein oder mehrere Bits des „Standard Event“-Registers sind gesetzt (diese Bits müssen aktiviert sein, siehe *ESE).
6 | „Master Summary“ | 64 | Ein oder mehrere Bits des „Status Byte”-Registers sind gesetzt und können eine Serviceanforderung (Request for Service - RQS) generieren. Bits müssen mit dem Befehl *SRE aktiviert werden.
7 | „Operation“-Register | 128 | Ein oder mehrere Bits wurden im Register „Operation Status“ gesetzt. Bits werden mit dem Befehl STATus:OPERation:ENABle aktiviert.

*CLS

Befehl Status löschen. Dieser Befehl setzt die „Event“-Register in allen Registergruppen zurück. Setzt auch die Fehlerwarteschlange zurück.

Parameter | Typische Rückgabe
(keine) | (keine)
Bits des „Event“-Registers und Fehlerwarteschlange zurücksetzen: *CLS

*ESE <enable_value>
*ESE?

Befehl Ereigniszustand aktivieren und Abfrage. Aktiviert Bits im „Enable“-Register für die Gruppe „Standard Event“-Register. Die Werte der ausgewählten Bits werden dann dem Register „Status Byte“ gemeldet.

Parameter | Typische Rückgabe
Dezimalsumme der Bits im Register (s. unten stehende Tabelle), Standardwert: 0. Um beispielsweise Bit 2 (Wert 4), Bit 3 (Wert 8) und Bit 7 (Wert 128) zu aktivieren, würde die Dezimalsumme 140 (4 + 8 + 128) betragen. Standard 0. | +48
Bit 4 (Wert 16) und Bit 5 (Wert 32) im „Enable“-Register aktivieren: *ESE 48
  • Verwenden Sie *PSC, um zu prüfen, ob das Standard Event Enable“-Register beim Einschalten gelöscht wurde. Zum Beispiel bewirkt *PSC 0, dass der Inhalt des „Enable“-Registers beim Aus- und Wiedereinschalten des Gerätes erhalten bleibt.
  • *CLS löscht nicht das „Enable“-Register, löscht das „Event“-Register.

*ESR?

Abfrage „Standard Event Status“-Register. Fragt das „Event“-Register ab nach der Gruppe „Standard Event“-Register. Es handelt sich um ein Leseregister; die Bits werden bei der Abfrage nicht zurückgesetzt.

Parameter | Typische Rückgabe
(keine) | +24
„Event“-Register ablesen (Bits 3 und 4 sind gesetzt). *ESR
  • Einzelne dieser Bedingungen, oder auch alle, werden bei entsprechender Programmierung des „Enable“-Registers an das „Standard Event“-Bit gemeldet. Zum Konfigurieren der „Enable“-Register-Maske schreiben Sie mit dem Befehl *ESE einen entsprechenden Dezimalwert in das Register.
  • Ein gesetztes Bit bleibt so lange gesetzt, bis es mit dieser Abfrage oder mit dem Befehl *CLS gelöscht wird.

*IDN?

Identifikationsabfrage. Gibt den Identifikationsstring des Geräts aus.

Parameter | Typische Rückgabe
(keine) | Keysight Technologies,33522B,XXXXXXXXXX,0.179-1.19-8.88-52-00
Ausgabe des Identifikationsstrings des Geräts: *IDN?
  • Der Identifikationsstring enthält vier durch Komma getrennte Felder:
    • Name des Herstellers
    • Modellnummer
    • Seriennummer
    • Versionsnummer
  • Der Identifikationsstring hat folgendes Format für 33500 Series Geräte:

    Keysight Technologies,[Model Number],[10-char Serial Number],A.aaa-B.bb-C.cc-DD-EE

    A.aaa

    = Firmware revision

    B.bb

    = Front panel FW revision

    C.cc

    = Power supply controller FW revision

    DD

    = FPGA revision

    EE

    = PCBA revision

  • Der Identifikationsstring hat folgendes Format für 33600 Series Geräte:

    Keysight Technologies,[Model Number],[Serial Number],A.aa.aa-B.bb-CC-DD-EE

    A.aa.aa

    = Firmware revision

    B.bb

    = Front panel FW revision

    CC

    = Main board revision

    DD

    = FPGA revision

    EE

    = PCBA revision

*OPC

Dieser Befehl setzt das Bit „Operation Complete“ (Bit 0) des „Standard Event“-Registers, sobald der aktuelle Befehl ausgeführt wurde.

Parameter | Typische Rückgabe
(keine) | (keine)
Setzen des Bits Operation Complete: *OPC
  • Dieser Befehl synchronisiert Ihre Anwendung mit dem Gerät.
  • Dieser Befehl wird in der getriggerten Wobbel- oder Burst-Betriebsart, im Listenmodus oder im Modus Arbiträrsignalsequenz verwendet, um nach Abschluss des Befehls *TRG oder INITiate[:IMMediate] einen Computer-Interrupt zu pollen oder auszulösen.
  • Bevor das „Operation Complete“-Bit gesetzt wird, können noch andere Befehle ausgeführt werden.
  • Der Unterschied zwischen *OPC und *OPC? besteht darin, dass *OPC? "1" an den Ausgangspuffer zurückgibt, wenn der aktuelle Vorgang abgeschlossen ist. Dies bedeutet, dass keine weiteren Befehle nach *OPC? gesendet werden können, bis eine Reaktion erfolgt. Auf diese Weise kann eine explizite Abfrageschleife vermieden werden. Das heißt, dass der E/A-Treiber auf die Antwort wartet.

*OPC?

Schreibt Wert „1“ in den Ausgangspuffer, wenn alle anstehenden Befehle ausgeführt wurden.

Parameter | Typische Rückgabe
(keine) | 1
Rückgabe „1“, wenn alle vorherigen Befehle ausgeführt wurden: *OPC?
  • Dieser Befehl synchronisiert Ihre Anwendung mit dem Gerät.
  • Weitere Befehle können erst nach Ausführung dieses Befehls ausgeführt werden.
  • Der Unterschied zwischen *OPC und *OPC? besteht darin, dass *OPC? "1" an den Ausgangspuffer zurückgibt, wenn der aktuelle Vorgang abgeschlossen ist. Dies bedeutet, dass keine weiteren Befehle nach *OPC? gesendet werden können, bis eine Reaktion erfolgt. Auf diese Weise kann eine explizite Abfrageschleife vermieden werden. Das heißt, dass der E/A-Treiber auf die Antwort wartet.

*OPT?

Gibt einen String in Anführungszeichen zur Identifizierung aller installierten Optionen aus.

Parameter | Typische Rückgabe
(keine) | "0,MEM,SEC,IQP"
Gibt die installierten Optionen aus (Bsp.: Standard-Zeitbasis, erweiterter Speicher, Sicherheit, IQ-Player) *OPT?

*PSC {0|1}
*PSC?

Status beim Einschalten löschen . Aktiviert (1) oder deaktiviert (0) beim Einschalten das Löschen zweier spezifischer Register:

  • „Standard Event Enable“-Register (*ESE).
  • „Status Byte Condition“-Register (*SRE).
  • Questionable Data-Register
  • „Standard Operation"-Register
Parameter | Typische Rückgabe
{0|1}, Standard 1 | 0 oder 1
Deaktiviert die Einschaltfunktion Power-on Clearing der zugewiesenen Register: *PSC 0
  • Diese Einstellung ist während eines Ein- und Ausschaltens permanent. Sie eignet sich deshalb folgendermaßen für GPIB-Anschüsse:

    *PSC 0 zum Deaktivieren/Aktivieren des Löschvorgangs
    *ESE 128 zum Aktivieren des Einschaltvorgangs
    *SRE 32 zum Aktivieren eines "SRQ on std"-Ereignisses

    Dieses Kurzprogramm bietet ein GPIB SRQ-Signal, wenn die Einheit eingeschaltet ist.

*RCL {0|1|2|3|4}
*SAV {0|1|2|3|4}

Ruft den Gerätestatus ab (*RCL) oder speichert ihn (*SAV) an einem festgelegten permanenten Speicherort. Der vorherige abgespeicherte Status an diesem Speicherort wird überschrieben (es wird keine Fehlermeldung erzeugt).

Bei 33600 Series Geräten werden Zustandsdateien, die mit *SAV und *RCL verknüpft sind, in Dateien mit dem Namen STATE_0.STA bis STATE_4.STA gespeichert. Diese Dateien befinden sich im Verzeichnis Settings im internen Speicher. Sie können diese Dateien über MMEMory commands verwalten.

Parameter | Typische Rückgabe
{0|1|2|3|4} | (keine)
Laden des Status von Position 1: *RCL 1
  • Das Gerät verfügt über fünf permanente Speicherorte, in dem die Geräteeinstellungen gespeichert werden. Speicherort 0 speichert den Gerätestatus beim Ausschalten. Verwenden Sie die Speicherorte 1, 2, 3 und 4, um andere Einstellungen zu speichern. Sie können das Gerät so konfigurieren, dass der Ausschaltstatus beim Einschalten wieder hergestellt wird (MEM:STAT:REC:AUTO).
  • Der gespeicherte Gerätesstatus enthält folgende Informationen: Ausgangsfunktion (einschließlich dem gewählten Arbiträrsignal), Frequenz, Amplitude, DC-Offsetspannung, Tastverhältnis, Symmetrieverhältnis und Modulationsparameter. Außerdem den Zustand des vorderen Bedienfelds (DISP).
  • Im Auslieferungszustand des Geräts sind die Register „1“ bis „4“ leer. (Das Register „0“ enthält den Gerätezustand zum Zeitpunkt des Einschaltens).
  • Nur über die Fernsteuerungsschnittstelle (aber nicht in der manuellen Betriebsart über die Frontplatte) können Sie zusätzlich einen fünften Gerätezustand in das Register „0“ abspeichern. Jedoch wird das Register „0“ beim Ein- und Ausschalten überschrieben.
  • Sie können jedem der Register von 0 bis 4 einen benutzerdefinierten Namen zuordnen.
  • Die abgespeicherten Gerätezustände werden durch *RST nicht beeinflusst.
  • Wenn Sie ein Arbiträrsignal aus einem permanenten Speicher löschen, nachdem der Gerätezustand gespeichert wurde, gehen die Wellenformdaten verloren und das Gerät gibt das Signal nicht aus, wenn der Status abgerufen wird. Es verwendet stattdessen den internen „exponentiellen Anstieg“.
  • Das vordere Bedienfeld verwendet das MMEMory-Subsystem als Zustandsspeicher.

*RST

Setzt das Gerät zurück auf die Werkseinstellung, unabhängig von der Einstellung MEMory:STATe:RECall:AUTO.

Parameter | Typische Rückgabe
(keine) | (keine)
Gerät zurücksetzen: *RST
  • Hat keinen Einfluss auf gespeicherte Gerätezustände, gespeicherte Arbiträrsignale oder I/O-Einstellungen, die im nichtflüchtigen Speicher abgelegt sind.
  • Bricht einen Wobbel- oder Burstzyklus ab.

*SRE <enable_value>
*SRE?

Service Request Enable. Aktiviert Bits im „Enable“-Register für die Gruppe „Status Byte“-Register.

Parameter | Typische Rückgabe
Dezimalsumme der Bits im Register (s. unten stehende Tabelle), Standardwert: 0. Um beispielsweise Bit 2 (Wert 4), Bit 3 (Wert 8) und Bit 7 (Wert 128) zu aktivieren, würde die Dezimalsumme 140 (4 + 8 + 128) betragen. Standard 0. | +24
Bits 3 und 4 im „Enable“-Register aktivieren: *SRE 24
  • Zur Aktivierung spezifischer Bits, den Dezimalwert der binär gewichteten Summe der Bits im Register angeben. Die gewählten Bits werden im „Master Summary“-Bit (Bit 6) des „Status Byte“-Registers zusammengefasst. Wenn eines der gewählten Bits von 0 auf 1 wechselt, wird ein Serviceanforderungssignal (SRQ) ausgelöst.
  • *CLS löscht das „Event“-Register aber aktiviert nicht das „Enable“-Register.
  • *PSC (Power-On Status Clear) bestimmt, ob das Aktivierungsregister der Registergruppe Status Byte beim Einschalten gelöscht wird. Zum Beispiel bewirkt *PSC 0, dass der Inhalt des Aktivierungsregisters beim Aus- und Wiedereinschalten des Gerätes erhalten bleibt.
  • Das Aktivierungsregister Status Byte wird durch *RST nicht gelöscht.

*STB?

Abfrage Statusbyte ablesen. Dieser Befehl fragt das Betriebzustandsregister für die Gruppe „Status Byte“-Register ab.

Parameter | Typische Rückgabe
(keine) | +40
Condition-Register ablesen (Bit 3 und Bit 5 sind gesetzt): *STB?
  • Ähnelt einem Serial Poll (serielle Abfrage), wird jedoch wie jeder andere Gerätebefehl ausgeführt. Es handelt sich um ein Leseregister; die Bits werden bei der Abfrage nicht zurückgesetzt.
  • Liefert das gleiche Ergebnis wie eine serielle Abfrage, setzt aber das „Master Summary“-Bit (Bit 6) nicht durch *STB? zurück.
  • Beim Ein- und Ausschalten oder über *RST werden alle Bits im Betriebszustandsregister gelöscht.
  • Liefert einen Dezimalwert, welcher der binär gewichteten Summe aller im Register eingestellten Bits entspricht. Zum Beispiel ergibt die Abfrage, wenn Bit 3 (Wert 8) und Bit 5 (Wert 32) gesetzt sind (und die entsprechenden Bits aktiviert sind), den Wert +40.

*TRG

Triggerbefehl. Triggert einen Wobbelzyklus, Burst, Arbiträr signal-Vorlauf oder LIST-Vorlauf über die Remoteschnittstelle, wenn die Triggerquelle Bus (Software-) aktuell ausgewählt ist (TRIGger[1|2]:SOURce BUS).

Parameter | Typische Rückgabe
(keine) | (keine)
Einen sofortigen Trigger senden, um einen Burst-Vorgang auszulösen: BURS:STAT ON BURS:MODE TRIG TRIG:SOUR BUS *TRG

*TST?

Selbsttest-Abfrage. Führt einen vollständigen Selbsttest durch. Schlägt der Test fehl, werden zusätzliche Informationen über eine oder mehrere Fehlermeldungen angezeigt. Verwenden Sie SYSTem:ERRor?, um die Fehlerwarteschlange anzuzeigen.

Parameter | Typische Rückgabe
(keine) | +0 (pass) oder +1 (ein oder mehrere Tests sind fehlgeschlagen)
Selbsttest durchführen: *TST?
  • Beim Einschalten des Geräts wird ein Selbsttest durchgeführt. Dieser begrenzte Test stellt sicher, dass das Gerät funktionsbereit ist.
  • Ein vollständiger Selbsttest (*TST?) dauert ca. 15 Sekunden. Wenn das Gerät alle Tests besteht, können Sie mit hoher Sicherheit annehmen, dass es voll betriebsbereit ist.
  • Wird *TST erfolgreich durchgeführt, wird auf der Frontplatte "Self-Test Passed" angezeigt. Andernfalls wird "Self-Test Failed" zusammen mit einer Fehlernummer angezeigt. Siehe Service und Reparatur - Einführung für Hinweise zum Support-Kontakt oder zur Rücksendung des Geräts zur Durchführung von Servicemaßnahmen.

*WAI

Konfiguriert das Gerät, mit der Ausführung weiterer Fernsteuerungsbefehle so lange zu warten, bis alle in Gang befindlichen Operationen ausgeführt wurden.

Parameter | Typische Rückgabe
(keine) | (keine)
Warten Sie, bis alle ausstehenden Operationen ausgeführt wurden. *WAI
  • Sie können dies beispielsweise mit dem Befehl *TRG verwenden, um sicherzustellen, dass das Gerät bereit für eine Triggerung ist:

    *TRG;*WAI;*TRG


Enable-Register

Register

Das Gerät verwendet drei verschiedene Arten von Registern, um Gerätemerkmale zu aktivieren, zu markieren und zu verfolgen.

  • Ein „Enable“-Register definiert, welche Bits im „Event“-Register an die Registergruppe „Status Byte“ gemeldet werden. Die Bits eines „Enable“-Registers können sowohl gelesen als auch gesetzt/zurückgesetzt werden.
  • Ein „Condition“-Register überwacht kontinuierlich den Zustand des Gerätes. Die Bits des „Condition“-Registers werden in Echtzeit aktualisiert und sind weder selbsthaltend („latched“) noch gepuffert.
  • Ein Ereignisregister ist ein Nur-Lese-Register, das die verschiedenen Ereignisse aus dem "Condition"-Register festhält. Aufeinanderfolgende Ereignisse werden nicht gepuffert: Wenn ein „Event“-Bit gesetzt ist, werden weitere Ereignisse ignoriert, die durch dieses Bit repräsentiert werden.


INITiate-Subsystem

Das INITiate-Subsystem steuert, wie das Gerät aus dem "inaktiven" Status in den Status „Warten-auf-Trigger“ wechselt. Sie können dies jeweils mit einem Kanal durchführen oder mit dem Schlüsselwort „ALL“ mit beiden Kanälen.

Beispiel

Dieses Programm verwendet INITiate[1|2][:IMMediate] mit TRIGger[1|2]:SOURce und TRIGger[1|2]:COUNt. Der Befehl TRIG:SOUR EXT konfiguriert den Kanal für die externe Triggerung TRIG:COUNT setzt die Triggerzahl auf 10. Der Befehl INITiate setzt das Gerät in den Status „Warten-auf-Trigger“. Der Trigger wird ausgelöst, wenn der rückwärtige Anschluss Ext Trig gepulst wird (standardmäßig High). Der Kanal kehrt in den inaktiven Zustand zurück, wenn die Triggerzahl 10 erreicht ist. Ein weiterer INIT-Befehl ist dann erforderlich, um die Akzeptanz der Trigger über die externe Triggereingangsleitung neu zu starten.

INIT:CONT OFF
TRIG:SOUR EXT
TRIG:COUNT 10
INIT

INITiate[1|2]:CONTinuous {ON|1|OFF|0}
INITiate[1|2]:CONTinuous?

INITiate:CONTinuous:ALL {ON|1|OFF|0}

Bestimmt, ob das Triggersystem für einen oder für beide Kanäle (ALL) immer in den Status Warten-auf-Trigger (ON) zurückkehrt oder im inaktiven Status bleibt (OFF) und Trigger ignoriert, bis der Befehl INITiate:IMMediate erfolgt.

Parameter | Typische Rückgabe
{ON|1|OFF|0}, Standard ON | 0 (OFF) oder 1 (ON)
Beide Kanäle für kontinuierliche Triggerung konfigurieren: INIT:CONT:ALL ON
  • Nach dem Triggern des Kanals verlässt er den Wait-for-Trigger-Status und wechselt zum Action-in-Progress-Status (z. B. laufender Burst- oder Wobbelvorgang). Der Action-in-Progress-Status kann länger dauern. Zudem werden in diesem Status Trigger ignoriert (zählen nicht im Vergleich mit der Anzahl der durch TRIGger[1|2]:COUNt) angegebenen Trigger.
  • Bei INIT:CONT ON ist die Triggerzählung ohne Bedeutung, da der Abschluss einer Triggerzählung nicht von der ersten Triggerung der darauffolgenden Triggerzählung unterschieden werden kann. Wenn Sie gezählte Trigger benötigen, müssen Sie INIT:CONT OFF einstellen.

INITiate[1|2][:IMMediate]

INITiate[:IMMediate]:ALL

Ändert den Status des Triggerungssystems für beide Kanäle (ALL) für die Anzahl der über TRIGger[1|2]:COUNt festgelegten Trigger von "inaktiv" auf "Warten-auf-Trigger".

  • Nach dem Triggern des Kanals verlässt er den Wait-for-Trigger-Status und wechselt zum Action-in-Progress-Status (z. B. laufender Burst- oder Wobbelvorgang). Der Action-in-Progress-Status kann länger dauern. Zudem werden in diesem Status Trigger ignoriert (zählen nicht im Vergleich mit der Anzahl der durch TRIGger[1|2]:COUNt) angegebenen Trigger.
Parameter | Typische Rückgabe
(keine) | (keine)
Beide Kanäle auf den Status Warten auf Trigger wechseln: INIT:IMM:ALL
  • Das Trigger-System ist bereit nach INITiate[:IMMediate]. Sobald die Triggerzahl erfüllt ist, kehrt das Triggersystem in den inaktiven Status zurück und ignoriert weitere Trigger. Die getriggerte Funktion bleibt in dem Zustand, der bei Erreichen der Triggerzahl aktiv ist. Durch die erneute Wiederaufrüstung des Triggersystems durch INITiate[:IMMediate] können weitere Trigger ausgeführt werden.
  • Verwenden Sie ABORt, um das Gerät in den inaktiven Status zurückzusetzen.
  • Ist INIT:CONT des betreffenden Kanals auf ON eingestellt, haben INITiate[1|2]:IMMediate und INIT[:IMMediate]:ALL keine Auswirkung auf das Triggersystem und Fehler -213 wird generiert.


INPut:ATTenuation[:STATe] {ON|1|OFF|0}INPut:ATTenuation[:STATe]?

INPut:ATTenuation[:STATe] {ON|1|OFF|0}
INPut:ATTenuation[:STATe]?

Gibt an, ob der Modulationseingang bei 33600 Series Geräten mit Signalen bis zum 5 V Pegel (ON) oder zum 1 V Pegel (OFF) arbeitet.

Parameter | Typische Rückgabe
{ON|1|OFF|0}, Standard ON | 0 (OFF) oder 1 (ON)
Angeben, dass der Modulationseingang mit Signalen bis 5 V arbeiten soll: INP:ATT ON
  • Sie können dies über die Modulationsparameter des Frontplattendisplays einstellen, wenn die Modulationsquelle auf External eingestellt ist.


LIST-Subsystem

Konfiguriert die Frequenzliste, die vom Gerät ausgegeben werden soll. Dadurch ist ein schnellerer Frequenzwechsel zu einer vorgegebenen Frequenzliste möglich. Sie können Frequenzen entweder über einen externen Trigger, einen internen Trigger oder einen BUS-Trigger erhöhen. Die Liste wird über FREQuency:MODE LIST ausgelöst.

LIST_DWELl - gibt die Dauer an, mit der jede Frequenz der Liste generiert wird.

LIST_FREQuency - Bis zu 128 Frequenzen als Liste angeben (Frequenzen können auch in einer Datei abgespeichert oder abgelesen werden über den Befehl MMEMory:LOAD:LIST[1|2] and MMEMory:STORe:LIST.

LIST_FREQuency_POINts - Gibt die Anzahl der Punkte in einer Frequenzliste aus.

Ein Beispiel für die LIST-Programmierung finden Sie unter Eine Frequenzliste erstellen.

[SOURce[1|2]:]LIST:DWELl {<seconds>|MINimum|MAXimum}
[SOURce[1|2]:]LIST:DWELl? [{MINimum|MAXimum}]

Stellt die Verweilzeit ein, die Dauer, mit der jede Frequenz in einer Frequenzliste generiert wird.

Parameter | Typische Rückgabe
1 µs bis 1000 s, Standard 1 s | +1.200000000000000E+01
Verweilzeit für Kanal einstellen auf 1 bis 12 s: LIST:DWEL 12
  • Das Gerät generiert jede Frequenz in einer Frequenzliste für die angegebene Verweilzeit wenn TRIGger[1|2]:SOURce auf IMMediate gesetzt ist.

[SOURce[1|2]:]LIST:FREQuency <freq1>[, <freq2>, etc.]
[SOURce[1|2]:]LIST:FREQuency?

Spezifiziert die Frequenzwerte in einer Frequenzliste.

Parameter | Typische Rückgabe
Liste von 1 bis 128 Frequenzen, jede mit 1 μHz bis zur maximalen Gerätefrequenz (bis zu 200 kHz bei Dreieck und Sägezahn). Standardliste: 100 Hz, 1000 Hz und 550 Hz. | 2.17800000E+006,3.14000000E+003, 6.28318000E+006
Frequenzliste von Kanal 1 auf drei Frequenzwerte einstellen: LIST:FREQ 2.718E6, 3.14E3, 6.28318E6
  • Dieser Befehl überschreibt die vorherige Liste mit der neuen Liste.

[SOURce[1|2]:]LIST:FREQuency:POINts? [{MINimum|MAXimum}]

Gibt die Anzahl der Frequenzen in der aktuellen Frequenzliste aus.

Parameter | Typische Rückgabe
[{MINimum|MAXimum}] | +17
Anzahl der Eingänge in die Frequenzliste von Kanal 1 ausgeben: LIST:FREQ:POIN?
  • Die Standardliste enthält drei Frequenzen: 100 Hz, 1000 Hz und 550 Hz.
  • MINimum ist 1, MAXimum ist 128.


LXI-Subsystem

Das LXI-Subsystem unterstützt die Funktion LAN eXtensions for Instrumentation (LXI).

LXI:IDENtify[:STATE] {ON|1|OFF|0}
LXI:IDENtify[:STATE]?

Schaltet den LXI Identify-Indikator auf dem Bildschirm ein oder aus.

Parameter | Typische Rückgabe
{ON|1|OFF|0} | 0 (OFF) oder 1 (ON)
Den LXI Identify-Indikator einschalten: LXI:IDEN ON
  • Der LXI Identify-Indikator hilft, das Gerät zu identifizieren, das mit der LAN-Adresse verbunden ist.
  • Ein *RST schaltet den LXI Identify-Indikator aus.
  • Durch Drücken der Taste LOCAL wird der LXI Identify-Indikator ausgeschaltet.

LXI:MDNS:ENABle {ON|1|OFF|0}
LXI:MDNS:ENABle?

Deaktiviert oder aktiviert das Multicast Domain Name System (mDNS).

Parameter | Typische Rückgabe
{ON|1|OFF|0}, Standard ON | 0 (OFF) oder 1 (ON)
mDNS einschalten: LXI:MDSN:ENAB ON
  • Einstellung wird aktiviert nach SYSTem:SECurity:IMMediate, *RST, Einschalten oder LAN-Reset.

LXI:MDNS:HNAMe[:RESolved]?

Gibt den festgelegten (eindeutigen) mDNS-Hostnamen in der Form <mDNS Hostname>-N aus. Bei N handelt es sich um eine Ganzzahl, die ggf. angehängt werden kann, um den Namen eindeutig zu machen. Der gewünschte Name kann abgeschnitten werden, um Platz für die angehängte Ganzzahl zu schaffen.

Parameter | Typische Rückgabe
(keine) | "A-335xxx-00107", wobei xxx die letzten drei Zeichen der Modellnummer und 00107 die letzten fünf Ziffern der Seriennummer sind.
Den festgelegten mDNS-Hostnamen ausgeben: LXI:MDNS:HNAMe:RESolved?

LXI:MDNS:SNAMe:DESired <name>
LXI:MDNS:SNAMe:DESired?

Setzt den gewünschten mDNS-Servicenamen.

Parameter | Typische Rückgabe
String in Anführungszeichen mit bis zu 63 Zeichen, Standard ist Keysight <Model_Name> Arbitrary Wellenformgenerator - <Serial_Number>". | "Keysight 33xxxx Arbitrary Waveform Generator - 99999", wobei xxxx die letzten vier Zeichen der Modellnummer und 99999 die letzten fünf Ziffern der Seriennummer sind.
Den mDNS Servicenamen auf "Wellenformgenerator" setzen: LXI:MDNS:SNAM:DES "Wellenformgenerator"
  • Die Einstellung ist permanent; sie bleibt bei einem Aus- und Wiedereinschalten des Geräts oder einem *RST erhalten.
  • Einstellung wird nach SYSTem:SECurity:IMMediate auf den Standardwert gesetzt.

LXI:MDNS:SNAMe[:RESolved]?

Gibt den festgelegten (eindeutigen) mDNS-Servicenamen in der Form <Desired mDNS Service Name>(N) aus. Bei N handelt es sich um eine Ganzzahl, die ggf. angehängt werden kann, um den Namen eindeutig zu machen. Der gewünschte Name kann abgeschnitten werden, um Platz für die angehängte Ganzzahl zu schaffen.

Parameter | Typische Rückgabe
(keine) | "Keysight 33xxxx Arbitrary Waveform Generator - 99999", wobei xxxx die letzten vier Zeichen der Modellnummer und 99999 die letzten fünf Ziffern der Seriennummer sind.
Ausgeben des festgelegten mDNS-Servicenamens: LXI:MDNS:SNAMe:RESolved?
  • Der festgelegte mDNS-Servicename ist der gewünschte Servicename (LXI:MDNS:SNAMe:DESired), möglicherweise ist ein "(N)"angehängt, wobei N eine Ganzzahl ist, wenn es erforderlich ist, um den Namen eindeutig zu machen.

LXI:RESet

Setzt die LAN-Einstellungen zurück auf einen bekannten Betriebsstatus, beginnend mit DHCP. Gelingt DHCP nicht, wird AutoIP verwendet. Löscht außerdem das WebUI-Passwort, falls eingestellt.

Parameter | Typische Rückgabe
(keine) | (keine)
LAN Einstellungen zurücksetzen: LXI:RES
  • Je nach Ihrem Netzwerk kann die LAN-Schnittstelle evtl. mehrere Sekunden benötigen, um nach Senden dieses Befehls neu zu starten.
  • Wenn die LAN-Schnittstelle oder spezifische LAN-Dienste (VXI-11, Sockets etc.) durch den Befehl SYSTem:COMMunicate:ENABle deaktiviert wurden, müssen Sie die Schnittstelle oder die Dienste separat reaktivieren und das Gerät aus- und wieder einschalten, damit das LAN funktioniert.

LXI:RESTart

Startet das LAN mit den neuen Einstellungen neu, wie durch SYSTem:COMM:LAN commands angegeben.

Parameter | Typische Rückgabe
(keine) | (keine)
LAN Schnittstelle neu starten: LXI:REST
  • Je nach Ihrem Netzwerk kann die LAN-Schnittstelle evtl. mehrere Sekunden benötigen, um nach Senden dieses Befehls neu zu starten.
  • Wenn die LAN-Schnittstelle oder spezifische LAN-Dienste (VXI-11, Sockets etc.) durch den Befehl SYSTem:COMMunicate:ENABle deaktiviert wurden, müssen Sie die Schnittstelle oder die Dienste separat reaktivieren und das Gerät aus- und wieder einschalten, damit das LAN funktioniert.


MARKer-Subsystem

Das MARKer-Subsystem konfiguriert den Punkt innerhalb eines Arbiträrsignals, Wobbelzyklus oder Burst, an dem das Signal Sync auf der Frontplatte in den LOW-Zustand übergeht.

Befehle und Anfragen

  • [SOURce[1|2]:]MARKer:CYCle {<cycle_num>|MINimum|MAXimum|DEFault} - Zyklus eines Burst, bei dem das Signal Sync in den LOW-Zustand übergeht
  • [SOURce[1|2]:]MARKer:FREQuency {<frequency>|MINimum|MAXimum|DEFault} - Frequenz, bei der das Sync-Signal in den LOW-Zustand übergeht
  • [SOURce[1|2]:]MARKer:POINt {<sample_number>|MINimum|MAXimum} - Punkt in einem Arbiträrsignal, bei dem das Signal Sync in den LOW-Zustand übergeht

Falls (ausschließlich) SYNC:MODE auf MARKer gesetzt ist, bewirkt jeder dieser Befehle, dass sync/marker beim Start eines Burst, Wobbelzyklus oder eines Arbiträrsignals auf HIGH übergeht. OUTPut:SYNC:POLarity kann dies umkehren.

[SOURce[1|2]:]MARKer:CYCle {<cycle_num>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]MARKer:CYCLe? [{MINimum|MAXimum}]

Setzt die Marker-Zyklusnummer, bei der das Sync-Signal der Frontplatte in einem Burst-Modus-Vorgang in den LOW-Zustand übergeht. OUTPut:SYNC:POLarity kann dies umkehren.

Parameter | Typische Rückgabe
Ganze Zahl von 2 bis zur Anzahl der Zyklen im Burst plus Eins (NCYCles+1), Standard 2 | +2.000000000000000E+03
Marker-Zyklus auf 2000 setzen: MARK:CYCL 2000
  • Dies gilt nur, wenn ein Burst aktiviert ist und OUTP:SYNC:MODE MARKer entspricht.
  • Bei aktiviertem Burst muss der Marker-Zyklus kleiner oder gleich der Anzahl der Zyklen im Burst plus Eins sein. Durch den Versuch, den Marker-Zyklus außerhalb dieses Bereiches zu setzen, wird der Marker-Zyklus entsprechend der Mitte des Burst gesetzt. Über die Remote-Schnittstelle wird ebenfalls der Fehler "Settings conflict" generiert.

[SOURce[1|2]:]MARKer:FREQuency {<frequency>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]MARKer:FREQuency? [{MINimum|MAXimum}]

Setzt die Marker-Frequenz, bei der das Signal Sync auf der Frontplatte während eines Wobbelzyklus in den LOW-Zustand übergeht. OUTPut:SYNC:POLarity kann dies umkehren.

Parameter | Typische Rückgabe
Jede beliebige Frequenz zwischen der Start- und Stop-Frequenz, Standard 500 Hz | +2.000000000000000E+03
Marker-Frequenz auf 2 kHz einstellen: MARK:FREQ 2000
  • Dies gilt nur, wenn eine Wobbelung aktiviert ist und OUTP:SYNC:MODE MARKer entspricht.
  • Beim Aktivieren der Wobbelbetriebsart muss die Markenfrequenz zwischen der Start-Frequenz und der Stop-Frequenz liegen. Durch den Versuch, den Marker-Zyklus außerhalb dieses Bereichs zu setzen, wird die Marker-Frequenz automatisch gleich der Start-Frequenz oder der Stop-Frequenz eingestellt (je nachdem, welche dieser beiden Frequenzen der gewünschten Marker-Frequenz näher liegt). Über die Remote-Schnittstelle wird ebenfalls der Fehler "Settings conflict" generiert.

[SOURce[1|2]:]MARKer:POINt {<sample_number>|MINimum|MAXimum}
[SOURce[1|2]:]MARKer:POINt? [{MINimum|MAXimum}]

Setzt die Abtastnummer, bei der das Signal Sync der Frontplatte innerhalb des aktiven Arbiträrsignals in den LOW-Zustand übergeht. OUTPut:SYNC:POLarity kann dies umkehren.

Parameter | Typische Rückgabe
Ganze Zahl von 4 bis zur Anzahl der Proben in einem Signal minus 3; Standard ist der Wechselpunkt des Arbiträrsignals | +1,000000000000000E+01
Marker-Punkt auf die 10. Probe des Signals einstellen: MARK:POIN 10
  • Der Befehl stellt die Marker-Punkte nur für das aktuell aktive Signal ein (FUNCtion:ARBitrary), nicht in einer Sequenz.
  • Der Befehl gilt nur unter folgenden Bedingungen:
  • OUTPut:SYNC:MODE eingestellt auf MARK, FUNC eingestellt auf ARB, FREQuency:MODE eingestellt auf CW
  • OUTPut:SYNC:MODE eingestellt auf CARR, FUNC eingestellt auf ARB, BURSt ON.
  • OUTPut:SYNC:MODE eingestellt auf CARR, FUNC eingestellt auf ARB, FREQuency:MODE eingestellt auf SWEEP
  • OUTPut:SYNC:MODE eingestellt auf MARK, interne Modulation aktiv und entweder ist FUNCtion eingestellt auf ARB oder eine interne Funktion des Modulationssignals ist eingestellt auf ARB
  • OUTPut:SYNC:MODE eingestellt auf MARK, externe Modulation aktiv und FUNCtion eingestellt auf ARB


MEMory-Subsystem

Das MEMory-Subsystem arbeitet mit Gerätezustandsdateien, die in (*SAV) gespeichert und über (*RCL) permanente Speicherorte (nummeriert von 0 bis 4) abgerufen werden.

Bei 33600 Series Geräten werden Zustandsdateien, die mit *SAV und *RCL verknüpft sind, in Dateien mit dem Namen STATE_0.STA bis STATE_4.STA gespeichert. Diese Dateien befinden sich im Verzeichnis Settings im internen Speicher. Sie können diese Dateien über MMEMory commands verwalten.

Beispiel

MEM:STAT:DEL 3
*SAV 3
MEM:STAT:VAL? 3
MEM:STAT:NAME 3,PATS_STATE
MEM:STAT:CAT?

Befehle und Anfragen

  • MEMory:NSTates? - Gesamtzahl der Statusspeicherplätze abrufen
  • MEMory:STATe:CATalog? - die Namen für alle fünf Statusspeicherplätze auflisten
  • MEMory:STATe:DELete {0|1|2|3|4|} - Inhalte eines Statusspeicherplatzes löschen
  • MEMory:STATe:NAME {0|1|2|3|4} [,<name>] - einem Statusspeicherplatz einen benutzerdefinierten Namen zuweisen
  • MEMory:STATe:RECall:AUTO {ON|1|OFF|0} - angeben, ob der Ausschaltstatus beim Einschalten von Speicherplatz 0 abgerufen wird
  • MEMory:STATe:VALid? {0|1|2|3|4} - bestimmen, ob ein Speicherplatz einen gültigen Status enthält

MEMory:NSTates?

Gibt die Gesamtzahl der Speicherplätze an, die für die Statusspeicherung zur Verfügung stehen (immer +5, inklusive Speicherplatz 0).

Parameter | Typische Rückgabe
(keine) | +5
Anzahl der Statusspeicherplätze ausgeben: MEM:NST?

MEMory:STATe:CATalog?

Gibt die Namen aus, die den Speicherplätzen 0 bis 4 zugeordnet wurden.

Parameter | Typische Rückgabe
(keine) | "AUTO_RECALL","STATE_1","STATE_2","STATE_3","STATE_4"
Namen der Speicherplätze ausgeben: MEM:STAT:CAT?
  • Die Standardnamen sind "AUTO_RECALL", "STATE_1", "STATE_2", "STATE_3" und "STATE_4".
  • Sie können die Position 0 nennen, der Name wird jedoch überschrieben, wenn das Gerät aus- und wieder eingeschaltet wird und dort ein neuer Power-down Status gespeichert wird.

MEMory:STATe:DELete {0|1|2|3|4|}

Löscht einen Statusspeicherplatz.

Parameter | Typische Rückgabe
{0|1|2|3|4|} | (keine)
Inhalt des Speicherplatzes 1 löschen: MEM:STAT:DEL 1
  • Die Standardnamen sind "AUTO_RECALL", "STATE_1", "STATE_2", "STATE_3" und "STATE_4".
  • Obwohl Sie den Status in Speicherplatz 0 löschen können, wird das Gerät beim nächsten Einschalten auf seinen Ausschaltstatus zurückgesetzt.
  • Der Versuch, einen Status aus einem leeren Speicherplatz abzurufen, generiert eine Fehlermeldung.

MEMory:STATe:NAME {0|1|2|3|4} [,<name>]
MEMory:STATe:NAME? {0|1|2|3|4}

Bezeichnet einen Speicherplatz.

Parameter | Typische Rückgabe
Eine Zeichenfolge ohne Anführungszeichen, mit bis zu 12 Zeichen. Das erste Zeichen muss ein Buchstabe sein (A-Z). Die anderen Zeichen können Buchstaben, Ziffern (0-9) oder Unterstriche ("_") sein. Wird der Name ausgelassen, wird der Standardname der Werkseinstellung verwendet. | TEST_RACK_1
Speicherplatz 1 umbenennen: MEM:STAT:NAME 1,TEST_RACK_1
  • Die Standardnamen sind "AUTO_RECALL", "STATE_1", "STATE_2", "STATE_3" und "STATE_4".
  • Sie können die Position 0 nennen, der Name wird jedoch überschrieben, wenn das Gerät aus- und wieder eingeschaltet wird und dort ein neuer Power-down Status gespeichert wird.
  • Kann denselben Namen mehreren Speicherplätzen zuweisen.
  • Durch Löschen des Inhaltes eines Speicherplatzes (MEMory:STATe:DELete) wird der zugeordnete Name auf den Namen der Werkseinstellung zurückgesetzt ("AUTO_RECALL", "STATE_1", "STATE_2", "STATE_3", oder "STATE_4").
  • Statusnamen bleiben von *RST unberührt.

MEMory:STATe:RECall:AUTO {ON|1|OFF|0}
MEMory:STATe:RECall:AUTO?

Deaktiviert oder aktiviert das automatische Abrufen des Gerätestatus in Speicherplatz "0" beim Einschalten.

Parameter | Typische Rückgabe
{ON|1|OFF|0}, Standard ON | 0 (OFF) oder 1 (ON)
Automatischen Abruf des Abschaltstatus deaktivieren: MEM:STAT:REC:AUTO OFF
  • OFF entspricht dem Reset der Werkseinstellungen (*RST) beim Einschalten.

MEMory:STATe:VALid? {0|1|2|3|4}

Zeigt an, ob aktuell ein gültiger Status an einem Speicherplatz abgespeichert ist.

Parameter | Typische Rückgabe
{0|1|2|3|4} | 0 (kein gültiger Status gespeichert) oder 1 (gültiger Status gespeichert)
Speicherstatus von Speicherplatz 3 ausgeben: MEM:STAT:VAL 3?
  • Diesen Befehl verwenden, bevor Sie *SAV senden, um ein unbeabsichtigtes Überschreiben eines Status zu verhindern.


MMEMory Subsystem

Das Subsystem MMEMory verwaltet das Dateisystem im Instrument oder auf einem externen USB-Dateisystem. Das Dateisystem kann verschiedene Dateiformate speichern und laden.

Das Dateisystem "INT:\" Flash-Speicher im Gerät ist immer präsent. Wenn ein USB-Dateispeichergerät (manchmal als Flash-Laufwerk oder Speicherstick bezeichnet) in den USB-Anschluss auf der Frontplatte gesteckt wird, wird es vom Gerät als "USB:\" angezeigt.

Beispiel

Der folgende Code bewirkt die unten abgebildete Sequenz. Beachten Sie, dass der lange DATA:SEQuence Befehl aus Gründen der Lesbarkeit auf mehrere Zeilen aufgeteilt wird.

FUNC:ARB:SRATE 10E3
FUNC:ARB:FILTER OFF
FUNC:ARB:PTPEAK 10
DATA:ARB dc_ramp, 0.1, 0.1, 0.1, 0.1, 0.1, 0.2, 0.4, 0.6, 0.8, 1.0
DATA:ARB dc5v, 1.0, 1.0, 1.0, 1.0, 1.0, 1.0, 1.0, 1.0, 1.0, 1.0
DATA:ARB dc2_5v, 0.5, 0.5, 0.5, 0.5, 0.5, 0.5, 0.5, 0.5, 0.5, 0.5
DATA:ARB dc0v, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0
DATA:SEQuence #3128"seqExample","dc_ramp",0,once,highAtStart,5,"dc5v",2,repeat,maintain,5,
"dc2_v",2,repeat,lowAtStart,5,"dc0v",2,repeat,maintain,5
FUNC:ARB dc_ramp
MMEM:STORE:DATA "INT:\dc_ramp.arb"
FUNC:ARB dc5v
MMEM:STORE:DATA "INT:\dc5v.arb"
FUNC:ARB dc2_5v
MMEM:STORE:DATA "INT:\dc2_5.arb"
FUNC:ARB dc0v
MMEM:STORE:DATA "INT:\dc0v.arb"
FUNC:ARB seqExample
MMEM:STORE:DATA "INT:\seqExample.seq"
DATA:VOL:CLEAR <--- erase all waveforms to show LOAD will restore all waveforms
MMEM:LOAD:DATA "INT:\seqExample.seq"
FUNC ARB
FUNC:ARB "INT:\seqExample.seq"
OUTPUT ON

Die Datei seqExample.seq sieht wie folgt aus:

File Format:1.10
Sample Rate:10000,000000
High Level:5,000000
Low Level:0,000000
Filter:"off"
Header:Arb Name, Repeat Count, Play Control,Marker Mode, Marker Point
dc_ramp.arb,1,"once","highAtStart",5
dc5v.arb,2,"repeat","maintain",5
dc2_5v.arb,2,"repeat","lowAtStart",5
dc0v.arb,2,"repeat","maintain",5

Befehle und Anfragen

Das Subsystem MMEMory umfasst die folgenden Befehle und Abfragen.

MMEMory:CATalog[:ALL]? [<folder>] - listet den verfügbaren und den genutzten Speicherplatz und die Dateien auf dem Massenspeichergerät auf

MMEMory:CATalog:DATA:ARBitrary? [<folder>] - listet Arbiträrsignale und Sequenzen auf dem Massenspeichergerät auf

MMEMory:CATalog:STATe? [<folder>] - listet den verfügbaren und den genutzten Speicherplatz sowie die Statusdateien (*.sta) auf dem Massenspeichergerät auf

MMEMory:CDIRectory <folder> - wechselt zu einem Verzeichnis
MMEMory:CDIRectory?

MMEMory:COPY <file1>,<file2> - kopiert eine Datei auf einem Massenspeichergerät

MMEMory:COPY:SEQuence <source>,<destination> - kopiert eine Sequenz und ihre zugeordneten Arbiträrsignale auf einem Massenspeichergerät

MMEMory:DELete <file> - entfernt Daten von einem Massenspeichergerät

MMEMory:DOWNload:DATA <binary_block> - lädt Daten vom Host-Computer herunter auf den Massenspeicher des Geräts

MMEMory:DOWNload:FNAMe <filename> - gibt en Namen für die vom Computer auf den Massenspeicher des Geräts heruntergeladenen Daten an

MMEMory:LOAD:ALL <filename> - lädt die Gerätezustandsdatei

MMEMory:LOAD:DATA[1|2] <filename> - lädt das Arbiträrsignal aus der Datei

MMEMory:LOAD:LIST[1|2] <filename> - lädt die Frequenzliste aus der Datei

MMEMory:LOAD:STATe <filename> - lädt den gespeicherten Gerätezustand aus der Datei

MMEMory:MDIRectory <folder> - erstellt ein neues Verzeichnis (Ordner)

MMEMory:MOVE <file1>,<file2> - verschiebt eine Datei auf das Massenspeichergerät

MMEMory:RDIRectory <folder> - löscht ein Verzeichnis

MMEMory:STORe:ALL <filename> - speichert die Gerätezustandsdatei

MMEMory:STORe:DATA[1|2] <filename> - speichert das Arbiträrsignal in der Datei

MMEMory:STORe:LIST[1|2] <filename> - speichert die aktive Frequenzliste in der Datei

MMEMory:STORe:STATe <filename> - speichert den Gerätestatus in der Datei

MMEMory:UPLoad? <filename> - lädt den Inhalt einer Datei vom Gerät hoch zum Host-Computer

Ordner und Dateiformate

Viele MMEMory-Befehle beziehen sich auf Ordner und Dateien. Diese haben spezifische Strukturen, die im folgenden beschrieben werden.

Format für einen <Ordner>

  • Das Format für <folder> ist "<drive>:<path>", wobei <drive> INTernal oder USB sein kann und <path> ist ein absoluter Ordnerpfad.
  • INTernal gibt das interne Flash-Dateisystem an. USB gibt ein USB-Speichergerät an der Frontplatte an.
  • Absolute Pfade beginnen mit "\" oder "/" und beginnen am Stammordner von <drive>.
  • Der Ordnername wird in <path> angegeben und darf 240 Zeichen nicht überschreiten.
  • Der angegebene Ordner muss existieren und kann nicht als als verborgene Datei oder Systemdatei markiert werden.
  • Wenn <drive>:<path> ausgelassen wurde, wird der durch den Befehl MMEMory:CDIRectory angegebene Ordner verwendet.
  • Wenn <drive> nicht angegeben wurde:
  • Der Pfad wird als relativer Pfad behandelt und an den Ordner angehängt, der durch den Befehl MMEMory:CDIRectory angegeben wird.
  • Absolute Pfade sind NICHT zulässig.

Format für eine <Datei>

  • Das Format für <file1> und <file2> ist "[<drive>:<path>]<file_name>", wobei <drive> INTernal oder USB sein kann und <path> ein absoluter Ordnerpfad sein muss.
  • INTernal gibt das interne Flash-Dateisystem an. USB gibt ein USB-Speichergerät an der Frontplatte an.
  • Wenn <drive>:<path> ausgelassen wurde, wird der durch den Befehl MMEMory:CDIRectory angegebene Ordner verwendet.
  • Absolute Pfade beginnen mit "\" oder "/" und beginnen am Stammordner von <drive>.
  • Ordner- und Dateinamen dürfen folgende Zeichen nicht enthalten: \ / : * ? " < > |
  • Die Kombination aus Ordner- und Dateiname darf 240 Zeichen nicht überschreiten.
  • Quelldatei und -ordner sowie der Zielordner müssen existieren und dürfen nicht als verborgene Datei oder Systemdatei markiert werden.
  • Wenn die Zieldatei existiert, wird sie überschrieben, sofern sie nicht als verborgene Datei oder Systemdatei markiert ist.
  • Wenn <drive> nicht angegeben wurde:
  • Der Pfad wird als relativer Pfad behandelt und an den Ordner angehängt, der durch den Befehl MMEMory:CDIRectory angegeben wird.
  • Absolute Pfade sind NICHT zulässig.

Massenspeicher (MMEMory) und Zustandsspeicher

Die Frontplatte verwendet das Subsystem MMEM, nicht das Subsystem MEM, um einen Status abzuspeichern. Wenn Sie einen Zustand über die Frontplatte speichern, können Sie immer noch mit SCPI darauf zugreifen. Jedoch kann ein Zustand, der über SCPI mit *SAV in das Subsystem MEM gespeichert wurde, nicht über die Frontplatte abgerufen werden.

Beispiel: Konfigurieren Sie das Gerät wie gewünscht und schließen Sie ein USB-Laufwerk an die Frontplatte an. Dann geben Sie die folgenden Befehle ein. Falls Sie nicht über ein USB-Laufwerk verfügen, ändern Sie "USB:\" in "INT:\", um stattdessen das interne Flash-Laufwerk des Geräts zu verwenden.

MMEMory:CDIRectory "USB:\"
MMEMory:MDIRerctory "States"
MMEMory:STORe:STATE "USB:\States\State1"

Um jederzeit zu diesem Zustand zurückzukehren:

MMEMory:LOAD:STATE "USB:\States\State1"

Sie können eine Zustandsdatei auch über die Frontplatte abrufen, dazu drücken Sie auf [System] > Store/Recall.

MMEMory:CATalog[:ALL]? [<folder>]

Gibt eine Liste aller Dateien im aktuellen Massenspeicherverzeichnis aus, inklusive interner Speicherort und USB-Laufwerk.

Parameter | Typische Rückgabe
Ein beliebiger gültiger Ordnername; Standard sind Ordner, die durch den Befehl MMEMory:CDIRectory ausgewählt werden | +1000000000,+327168572, "command.exe,,375808", "MySetup.sta,STAT,8192", "MyWave.csv,ASC,11265"
Listet alle Dateien im Ordner MyData auf dem USB-Speichergerät an der Frontplatte auf: MMEM:CAT? "USB:\MyData"
  • Der Katalog nimmt folgende Form an:

    <mem_used>,<mem_free>{,"<file listing>"}

    Das Gerät gibt zwei numerische Werte aus und einen String für jede Zustandsdatei im Ordner. Der erste Zahlenwert gibt die Anzahl der belegten Speicherbytes für das Laufwerk an. Der zweite gibt die Anzahl verfügbarer Speicherbytes an. Jedes <file listing> hat das Format "<file_name>,<file_type>,<file_size>" (die Anführungszeichen werden ebenfalls ausgegeben), wobei <file_name> der Name der Datei mit der Dateierweiterung ist, falls vorhanden; <file_type> ist entweder STAT für STATe (.sta)-Dateien, ASC für DATA (.csv)-Dateien, FOLD für Ordner oder leer für alle anderen Dateierweiterungen; <file_size> ist die Größe der Datei in Bytes.
  • Existiert keine Datei, wird nur <mem_used>,<mem_free> angegeben.
  • Da das Gerät für den internen Gebrauch etwas Speicherplatz im Flash-Dateisystem braucht, entspricht der Wert <mem_used> selbst dann nicht Null, wenn keine Benutzerdateien im Laufwerk vorhanden sind.

MMEMory:CATalog:DATA:ARBitrary? [<folder>]

Gibt eine Liste aller arbiträren Sequenzdateien (.seq) und Ordner aus sowie Arbiträrsignal-Dateien (.arb/.barb) in einem Ordner.

Parameter | Typische Rückgabe
Ein beliebiger gültiger Ordnername; Standard sind Ordner, die durch den Befehl MMEMory:CDIRectory ausgewählt werden | (siehe unten)

Die folgende Abfrage listet alle Arbiträrsignale und Sequenzdateien im Verzeichnis BuiltIn des internen Speichers auf.

MMEM:CAT:DATA:ARBitrary? "INT:\BuiltIn"

Typische Reaktion:
96256,1019770880,"EXP_RISE.arb,ARB,1868","EXP_FALL.arb,ARB,2064",
"SINC.arb,ARB,1897","CARDIAC.arb,ARB,2410","NEG_RAMP.arb,ARB,1908",
"HAVERSINE.arb,ARB,374","GAUSSIAN.arb,ARB,587","LORENTZ.arb,ARB,1254",
"D_LORENTZ.arb,ARB,1373"
  • Das Gerät gibt zwei numerische Werte aus und einen String für jede .seq und .arb/.barb-Datei im ausgewählten Ordner. Der erste Zahlenwert gibt die Anzahl der belegten Speicherbytes für das Laufwerk an. Der zweite gibt die Anzahl verfügbarer Speicherbytes an. Jedes <file listing> hat das Format "<filename>,<file_type>,<file_size>" (die Anführungszeichen werden ebenfalls ausgegeben), wobei <filename> der Name der Datei mit der Dateierweiterung ist, falls vorhanden; <file_type> ist FOLD für Ordner, ARB für Arbiträrsegmente oder SEQUENCE für Arbiträrsequenzdateien; <file_size> ist die Größe der Datei in Bytes.
  • Existieren keine .seq, .arb, oder .barb-Dateien, wird nur <mem_used>,<mem_free> angegeben.
  • Da das Gerät für den internen Gebrauch etwas Speicherplatz im Flash-Dateisystem braucht, entspricht der Wert <mem_used> selbst dann nicht Null, wenn keine Benutzerdateien im Laufwerk vorhanden sind.

MMEMory:CATalog:STATe? [<folder>]

Listet alle Zustandsdateien (Dateierweiterung .sta) in einem Ordner auf.

Parameter | Typische Rückgabe
Ein beliebiger gültiger Ordnername; Standard sind Ordner, die durch den Befehl MMEMory:CDIRectory ausgewählt werden | +1000000000,+327168572,"MySetup.sta,STAT,8192"
Listet alle Zustandsdateien im Ordner MyData im USB-Laufwerk der Frontplatte auf. MMEM:CAT:STAT? "USB:\MyData"
  • Format für den ausgegebenen Katalog:

    <mem_used>,<mem_free>{,"<file listing>"}
  • Das Gerät gibt zwei numerische Werte aus und einen String für jede Zustandsdatei im ausgewählten Ordner. Der erste Zahlenwert gibt die Anzahl der belegten Speicherbytes für das Laufwerk an. Der zweite gibt die Anzahl verfügbarer Speicherbytes an. Jedes <file listing> hat das Format "<file_name>,<file_type>,<file_size>" (die Anführungszeichen werden ebenfalls ausgegeben), wobei <file_name> der Name der Datei mit der Dateierweiterung ist, falls vorhanden; <file_type> ist STAT für STATe (.sta)-Dateien; <file_size> ist die Größe der Datei in Bytes.
  • Existiert keine Datei, wird nur <mem_used>,<mem_free> angegeben.
  • Da das Gerät für den internen Gebrauch etwas Speicherplatz im Flash-Dateisystem braucht, entspricht der Wert <mem_used> selbst dann nicht Null, wenn keine Benutzerdateien im Laufwerk vorhanden sind.

MMEMory:CDIRectory <folder>
MMEMory:CDIRectory?
MMEMory:MDIRectory <folder>
MMEMory:RDIRectory <folder>

MMEMory:CDIRectory wählt den Standardordner für die Befehle des Subsystems MMEMory. Dieser Ordner muss existieren und wird verwendet, wenn Ordner- oder Dateinamen keinen Laufwerks- oder Ordnernamen enthalten.

MMEMory:MDIRectory erstellt ein neues Verzeichnis (Ordner) auf dem Massenspeichergerät.

MMEMory:MDIRectory entfernt ein Verzeichnis (Ordner) auf dem Massenspeichergerät.

Parameter | Typische Rückgabe
Jeder beliebige Verzeichnisname, inklusive Spezifikationssymbol des Massenspeichergeräts, Standard INT:\ | "INT:\"
Ein neues Verzeichnis mit dem Namen "test" auf dem internen Massenspeichergerät erstellen und löschen: MMEM:MDIR "test" MMEM:RDIR "test" Den Standardordner für MMEMory-Subsystem-Befehle ausgeben: MMEM:CDIR?
  • Das Gerät setzt den Standardordner zurück auf das auf das Stammverzeichnis des internen Flash-Dateisystems („INT:\“) zurück nach *RST.
  • Sie können nur leere Ordner löschen (keine Dateien). Andernfalls generiert das Gerät die Fehlermeldung "Directory not empty".

MMEMory:COPY <file1>,<file2>

Kopiert <file1> in <file2>. Die Dateinamen müssen eine Dateierweiterung enthalten.

Parameter | Typische Rückgabe
Beide Dateien können einen beliebigen gültigen Dateinamen haben | (keine)
Die Zustandsdatei MyFreqMeas.sta aus dem Stammverzeichnis in den Ordner "Backup" auf dem internen Flash-Dateisystem kopieren. MMEM:COPY "INT:\MySetup.sta","INT:\Backup"
  • Um eine Datei in eine Datei mit demselben Namen in einem anderen Ordner zu kopieren, geben Sie einfach <drive> und/oder <path> für <destination> ein.

MMEMory:COPY:SEQuence <source>,<destination>

Kopiert eine Sequenz von <source> nach <destination>. Die Dateinamen müssen eine Dateierweiterung enthalten. Erweiterung .seq für Textformat verwenden.

Parameter | Typische Rückgabe
<source> und <destination> können einen beliebigen gültigen Sequenzsdateinamen haben. | (keine)
Sequenzdatei MySequence.seq und alle zugeordneten Segmentdateien, die in der Sequenzdatei angegeben sind, vom internen Laufwerk in den Ordner "Backup" auf dem internen Speicherort kopieren. MMEM:COPY:SEQ "INT:\MySequence.seq","INT:\Backup"
  • Das Format für <source> und <destination> ist "[[<drive>:]<path>]<file_name>", wobei <drive> INTernal oder USB sein kann, und <path> ist ein Dateipfad.
  • INTernal gibt das interne Flash-Dateisystem an. USB gibt ein USB-Speichergerät an der Frontplatte an.
  • Wenn <drive> angegeben ist, wird <path> als absoluter Pfad interpretiert. Absolute Pfade beginnen mit "\" oder "/" und beginnen am Stammordner von <drive>.
  • Falls <drive> ausgelassen wurde, bezieht sich <path> auf den im durch MMEMory:CDIRectory angegebenen Ordner. Zugehörige Pfade dürfen nicht mit "\" oder "/" beginnen.
  • Ordner- und Dateinamen dürfen folgende Zeichen nicht enthalten: \ / : * ? " < > |
  • Die Kombination aus Ordner- und Dateiname darf 240 Zeichen nicht überschreiten.
  • Quelldatei und -ordner sowie der Zielordner müssen existieren und dürfen nicht als verborgene Datei oder Systemdatei markiert werden.
  • Wenn die Zieldatei existiert, wird sie überschrieben, sofern sie nicht als verborgene Datei oder Systemdatei markiert ist.
  • Um eine Sequenzdatei in eine Sequenzdatei mit demselben Namen in einem anderen Ordner zu kopieren, geben Sie einfach <drive> und/oder <path> für <destination> ein.

MMEMory:DELete <file>

Löscht eine Datei. Zum Löschen eines Ordners verwenden Sie MMEMory:RDIRectory.

Parameter | Typische Rückgabe
Ein beliebiger gültiger Dateiname, inklusive Dateierweiterung. | (keine)
Die angegebene Datei aus dem Stammverzeichnis des internen Flash-Dateisystems löschen: MMEM:DEL "INT:\MySetup.sta"
  • Sie können auch Platzhalter mit diesem Befehl verwenden. Der Befehl MMEM:DEL "INT:\MYDATA\*.csv" z. B. löscht alle CSV-Dateien in dem angegebenen Verzeichnis.

MMEMory:DOWNload:DATA <binary_block>

Lädt Daten vom Host-Computer herunter in eine Datei im Gerät. Der Dateiname muss vorab angegeben werden mit MMEMory:DOWNload:FNAMe.

Daten in einem <binary_block> werden in die ausgewählte Datei geschrieben und alle zuvor in der Datei gespeicherten Daten gehen verloren.

Parameter | Typische Rückgabe
Jeder IEEE-488-Block mit bestimmter oder unbestimmter Länge | (keine)
Schreibt das Wort "Hello" in die Datei "\Myfile" des internen Speichers. MMEM:DOWN:FNAM "INT:\Myfile" MMEM:DOWN:DATA #15Hello

MMEMory:DOWNload:FNAMe <filename>

Erstellt und öffnet den angegebenen Dateinamen, bevor Daten mit MMEMory:DOWNload:DATA in diese Datei geschrieben werden.

Parameter | Typische Rückgabe
Ein beliebiger gültiger Dateiname | (keine)
Schreiben Sie das Wort "Hello" in die Datei "\Myfile" auf dem internen Flash-Dateisystem. MMEM:DOWN:FNAM "INT:\Myfile"MMEM:DOWN:DATA #15Hello

MMEMory:LOAD:ALL <filename>

MMEMory:STORe:ALL <filename>

Lädt oder speichert ein vollständiges Geräte-Setup, verwendet dazu eine benannte Datei auf dem Massenspeicher.

Parameter | Typische Rückgabe
Ein beliebiger gültiger Dateiname auf dem aktuellen Massenspeicherverzeichnis | (keine)

Geräte-Setup in die Datei mit dem Namen "completeSetup.all" auf dem internen Speicher abspeichern:
MMEM:STOR:ALL "INT:\completeSetup.all"

Ein vollständiges Geräte-Setup aus der Datei im internen Massenspeicher laden.
MMEM:LOAD:ALL "INT:\completeSetup.all"
  • Über diese Befehle können Sie Gerätebedingungen aus früheren Einstellungen kopieren.
  • Dieser Befehl lädt das aktuelle Geräte-Setup (so wie es von *SAV und *RCL verwendet wird).
  • Die von diesen Befehlen verwendeten Setup-Dateien des Geräts enthalten sehr viel mehr als die Zustandsdateien, die von *SAV und *RCL verwendet werden. Sie enthalten außerdem gespeicherte Zustände und Arbiträrsignale, GPIB- und LAN-Parameter, Zahlenformat, Signalton ein/aus, Displayoptionen und Hilfesprache.
  • Wenn die Zieldatei existiert, wird sie überschrieben, sofern sie nicht als verborgene Datei oder Systemdatei markiert ist.

MMEMory:LOAD:DATA[1|2] <filename>

Lädt das angegebene Arbiträrsegment (.arb/.barb) oder die arbiträre Sequenzdatei (.seq) im INTERNAL- oder USB-Speicher in den flüchtigen Speicher für den angegebene Kanal.

Parameter | Typische Rückgabe
Ein beliebiger gültiger Dateiname, wie unten beschrieben. | (keine)
Lädt ein Arbiträrsignalsegment vom internen Laufwerk in den flüchtigen Speicher für Kanal 1 und aktiviert es für die Verwendung. MMEM:LOAD:DATA "Int:\Builtin\HAVERSINE.arb" FUNC:ARB "Int:\Builtin\HAVERSINE.ARB"
  • Wird eine Sequenzdatei (.seq) angegeben, werden alle in der Datei definierten Arbiträrsignale geladen.
  • Wurde das von <filename> angegebene Signal bereits geladen, gibt das Gerät die Fehlermeldung mit der Nummer +786 an, "Specified arb waveform already exists". Das Löschen eines bestehenden Signals erfordert das Löschen des Signals im permanenten Speicher mit DATA:VOLatile:CLEar.

MMEMory:LOAD:LIST[1|2] <filename>

MMEMory:STORe:LIST[1|2] <filename>

Lädt und speichert eine Frequenzlistendatei (.lst).

Parameter Typische Rückgabe
Jeder gültige Dateiname auf dem Massenspeichergerät

(keine)

Die aktuelle Frequenzliste in einer LIST-Datei auf dem internen Speicher abspeichern:
MMEM:STOR:LIST "INT:\FreqList.lst"

Eine LIST-Datei in das interne Massenspeichersystem laden (file named FreqList.lst).
MMEM:LOAD:LIST "INT:\FreqList.lst"
  • Eine Frequenzliste kontrolliert die Frequenz in FREQ:MODE LIST, die schnell zur nächsten Frequenz in der Liste wechselt, wenn ein Triggerereignis empfangen wird.
  • Eine Frequenzlistendatei enthält eine durch Kommata getrennte Sequenz von ASCII-Zahlen, die erste Zahl steht für die Anzahl der Frequenzen in der Liste:

3, 100.000000, 1000.000000, 550.000000

  • Wenn die Zieldatei existiert, wird sie überschrieben, sofern sie nicht als verborgene Datei oder Systemdatei markiert ist.

MMEMory:LOAD:STATe <filename>

MMEMory:STORe:STATe <filename>

Speichert den aktuellen Gerätezustand in einer Zustandsdatei. Der Dateiname enthält optional den Ordnernamen und die Dateierweiterung .sta.

Parameter | Typische Rückgabe
Ein beliebiger gültiger Dateiname auf dem aktuellen Verzeichnis | (keine)
Den aktuellen Gerätezustand in der Zustandsdatei MyFreqMeas.sta im Stammordner des internen Flash-Dateisystems speichern. MMEM:STOR:STAT "INT:\MySetup" Den Gerätszustand von MySetup.sta in das Stammverzeichnis des internen Speichers laden. MMEM:LOAD:STAT "INT:\MySetup.sta"

MMEMory:MOVE <file1>,<file2>

Verschiebt und/oder benennt <file1> in <file2> um. Die Dateinamen müssen die Dateierweiterung enthalten.

Parameter | Typische Rückgabe
Beide Dateien können einen beliebigen gültigen Dateinamen haben | (keine)

Die Zustandsdatei MySetup.sta aus dem aktuell ausgewählten Standardverzeichnis in den Ordner "Backup" auf dem internen Flash-Dateisystem kopieren;
MMEM:MOVE "MySetup.sta","INT:\Backup"

Das Arbiträrsignal arbMonday auf dem USB Laufwerk in arbTuesday umbenennen.
MMEM:MOVE "USB:\arbMonday", "USB:\arbTuesday"
  • Um eine Datei umzubenennen, geben Sie denselben Ordner an für <file1> und <file2>.
  • Um eine Datei in eine Datei mit demselben Namen in einem anderen Ordner zu verschieben, geben Sie einfach den Pfad <drive>:<path> für <file2> ein.

MMEMory:STORe:DATA[1|2] <filename>

Speichert das angegebene Arbiträrsegment (.arb/.barb) oder die arbiträren Sequenzdaten (.seq) in dem im flüchtigen Speicher angegebenen Kanal (Standard: Kanal 1) im INTERNAL- oder USB-Speicher.

Parameter | Typische Rückgabe
Ein beliebiger gültiger Dateiname | (keine)
Eine in den flüchtigen Speicher auf Kanal 1 geladene arbiträre Sequenz auf dem internen Laufwerk speichern. MMEM:STOR:DATA "INT:\Sequence1.seq"
  • Wenn Sie ein Arbiträrsignal oder eine Sequenz speichern (MMEMory:STORe:DATA[1|2]), werden die aktuellen Einstellungen des Geräts (Spannungswerte, Abtastrate, Filtertyp etc.) im Segment oder in der Segmentdatei gespeichert. Beim ersten Abspielen der Datei mit FUNCtion:ARBitrary werden diese Einstellungen geladen und überschreiben die aktuellen Einstellungen des Geräts. Wenn Sie ein Segment- oder Sequenzdatei manuell bearbeitet haben, so dass die Geräteeinstellungen entfernt wurden, werden die Geräteeinstellungen nicht geändert, wenn Sie FUNCtion:ARBitrary ausführen.
  • Wenn die Zieldatei existiert, wird sie überschrieben, sofern sie nicht als verborgene Datei oder Systemdatei markiert ist.
  • Wird eine Arbiträrsignalsequenzdatei (.seq) angegeben, werden alle Arbiträrsignalsegmentdateien, die dieser Sequenz zugeordnet sind, in der Datei gespeichert.
  • Der Befehl löst eine Fehlermeldung aus, wenn das angegebene Arbiträrsignalsegment oder die Arbiträrsignalsequenz im flüchtigen Speicher nicht gefunden wird.

MMEMory:UPLoad? <filename>

Lädt den Inhalt einer Datei vom Gerät zum Host-Computer hoch.

Parameter | Typische Rückgabe
Ein beliebiger gültiger Dateiname | IEEE 488.2 Block bestimmter Länge
Der folgende Befehl lädt den Inhalt der Zustandsdatei "Myfile.sta" im Stammverzeichnis des internen Flash-Dateisystems hoch auf den Host-Computer: MMEM:UPL? "INT:\Myfile.sta"


OUTPut-Subsystem

Das OUTPut-Subsystem steuert den Frontplattenausgang, die Sync-Anschlüsse und den rückseitigen Ext Trig Anschluss:

  • OUTPut[1|2] {ON|1|OFF|0} - Status des Ausgangsanschlusses des Frontplattenkanals
  • OUTPut[1|2]:LOAD {<ohms>|INFinity|MINimum|MAXimum|DEFault} - Impedanz des Lastwiderstands
  • OUTPut[1|2]:MODE {NORMal|GATed} - Kanalausgangsmodus
  • OUTPut[1|2]:POLarity {NORMal|INVerted} - Ausgangssignalpolarität
  • OUTPut:SYNC {ON|1|OFF|0} - Status des Frontplattenkanalanschlusses Sync
  • OUTPut[1|2]:SYNC:MODE? - Sync-Signal-Modus
  • OUTPut[1|2]:SYNC:POLarity {NORMal|INVerted} - Sync-Signalpolarität
  • OUTPut:SYNC:SOURce {CH1|CH2} - Kanal, der zum Ansteuern des Synchronisationssignals verwendet wird
  • OUTPut:TRIGger {ON|1|OFF|0} - Status des rückseitigen Ext Trig Anschlusses
  • OUTPut:TRIGger:SLOPe {POSitive|NEGative} - "trigger out"-Polarität
  • OUTPut:TRIGger:SOURce {CH1|CH2} - Kanal zum Ansteuern des Ausgangstriggers

OUTPut[1|2] {ON|1|OFF|0}
OUTPut[1|2]?

Deaktiviert oder aktiviert den Ausgangsanschluss der Frontplatte.

Parameter | Typische Rückgabe
{ON|1|OFF|0}, Standard OFF | 0 (OFF) oder 1 (ON)
Ausgangsanschluss für Kanal 1 aktivieren: OUTP ON
  • Ist der Ausgang aktiviert, leuchtet die Taste des Frontplattenausgangs.
  • Die APPLy Befehle überschreiben die aktuelle OUTPut-Einstelung und aktivieren den Anschluss des Kanalausgangs.
  • Wird eine zu hohe externe Spannung auf den Ausgangsanschluss der Frontplatte angewandt, wird eine Fehlermeldung angezeigt und der Ausgang wird deaktiviert. Um den Ausgang wieder zu aktivieren, entfernen Sie die Überlast vom Ausgangsanschluss und senden Sie OUTPut ON.
  • OUTPut ändert den Status des Kanalausgangsanschlusses durch Umschalten des Ausgangsrelais, ohne Nullstellung der Ausgangsspannung. Daher kann der Ausgang ca. eine Millisekunde einen Störimpuls verursachen, bis sich das Signal stabilisiert. Diese Glitches können minimiert werden, wenn Sie erst die Amplitude (VOLTage MIN) minimieren und den Offset auf 0 stellen (VOLTage:OFFSet 0), bevor Sie den Status des Ausgangs ändern.
  • Mit diesem Befehl wechselt die Ausgangsimpedanz zwischen 50 Ω (ON) und hohe (>1MΩ) Impedanz (OFF).

OUTPut[1|2]:LOAD {<ohms>|INFinity|MINimum|MAXimum|DEFault}
OUTPut[1|2]:LOAD? [{MINimum|MAXimum}]

Stellt den erwarteten Lastwiderstand ein. Sollte der Lastimpedanz entsprechen, die mit dem Ausgang verknüpft ist.

Parameter | Typische Rückgabe
1 Ω bis 10 kΩ, Standard 50 Ω | +5,000000000000000E+02
Ausgangsimpedanz auf 300 Ω stellen: OUTP:LOAD 300 Ausgangsimpedanz auf "high impedance" stellen: OUTP:LOAD INF
  • Der spezifizierte Wert wirkt sich auf die Amplituden-, Offset- und „High“/„Low“-Pegel-Einstellungen aus.
  • Das Gerät verfügt über eine unveränderliche Ausgangsimpedanz von 50 Ω für die Kanalanschlüsse der Frontplatte. Falls die Lastimpedanz vom angegebenen Wert abweicht, werden falsche Amplituden- und Offsetwerte angezeigt. Der Lastwiderstandswert dient lediglich zur Überprüfung, dass die angezeigten Spannungswerte der erwarteten Last entsprechen.
  • Wenn Sie die Einstellung des Lastwiderstandswerts ändern, ändern sich die angezeigten Amplituden-, Offset- und"High"-/"Low"-Werte entsprechend (wobei keine Fehlermeldung angezeigt wird). Beträgt die Amplitude 10 Vpp und Sie ändern den Lastwiderstand von 50 Ω auf "high impedance" (OUTPut[1|2]:LOAD INF), verdoppelt sich die angezeigte Amplitude und beträgt dann 20 Vpp. Der Wechsel von "high impedance" zu 50 Ω halbiert die angezeigte Amplitude. Die Einstellung des Lastwiderstands beeinflusst die tatsächliche Ausgangsspannung nicht; sie ändert lediglich die Werte, die über die Remote-Schnittstelle angezeigt und abgefragt werden. Die tatsächliche Ausgangsspannung ist abhängig von der verbundenen Last.
  • Die Ausgangsamplitudenmaßeinheit „dBm“ ist nicht verfügbar, wenn Sie den Lastwiderstand „high impedance“ spezifiziert haben. Die Einheiten werden automatisch in Vpp umgerechnet. Ausführlichere Informationen finden Sie unter VOLT:UNIT.
  • Sie können den Lastwiderstand nicht ändern, wenn Spannungsbegrenzungen aktiviert sind. Das Gerät kann nicht wissen, für welche Lastwiderstandeinstellung die Begrenzungen gelten. Deaktivieren Sie zur Änderung des Lastwiderstands stattdessen die Spannungsbegrenzungen, stellen Sie den neuen Widerstandswert ein, passen Sie die Spannungsbegrenzungen an und aktivieren Sie die Spannungsbegrenzungen erneut.
  • Ist INF ("high impedance") ausgewählt, gibt die Abfrage 9.9E+37 zurück.

OUTPut[1|2]:MODE {NORMal|GATed}
OUTPut[1|2]:MODE?

Aktiviert (GATed) oder deaktiviert (NORMal) die Zeittorfilterfunktion des Ausgangssignals mit dem Triggereingang.

Parameter | Typische Rückgabe
{NORMal|GATed}, Standardeinstellung NORMal | GAT oder NORM
Ausgang "Gated" aktivieren: OUTP:MODE GAT
  • Die Auswirkung des Gating ist unabhängig von der Signalphase oder Zeiteinstellungen. Wenn der Triggereingang zugeordnet ist, wird das Ausgangssignal generiert. Wird der Trigger nicht erkannt, wird das Signal weiterhin intern generiert, jedoch nicht an den Ausgangsanschluss des Signals weitergeleitet.
  • "Gating" ändert nicht den Lastwiderstand des Kanals (kein Ausgangsrelais-Ein/Aus).

OUTPut[1|2]:POLarity {NORMal|INVerted}
OUTPut[1|2]:POLarity?

Dieser Befehl invertiert das Signal relativ zur Offsetspannung.

Parameter | Typische Rückgabe
{NORMal|INVerted}, Standard NORMal | NORM oder INV
Ausgangspolarität auf INVerted stellen: OUTP:POL INV
  • NORMal: Das Signal geht zu Zyklusbeginn in eine Richtung;

    INVerted: Das Signal geht in die andere Richtung.
  • Wie unten dargestellt, ist das Signal bezüglich der Offset-Spannung invertiert. Die Offset-Spannung bleibt bei der Invertierung des Signals unverändert.

    Mit und ohne Offset-Spannung
  • Das Sync-Signal in Kombination mit einem invertierten Signal wird nicht inventiert.

OUTPut:SYNC {ON|1|OFF|0}
OUTPut:SYNC?

Deaktiviert oder aktiviert den Sync-Anschluss der Frontplatte.

Parameter | Typische Rückgabe
{ON|1|OFF|0}, Standard ON | 0 (OFF) oder 1 (ON)
Den Sync-Anschluss der Frontplatte deaktivieren: OUTP:SYNC OFF
  • Das Deaktivieren des Sync-Signals reduziert die Ausgangsverzerrung bei niedrigen Amplituden.
  • Mehr Informationen über das Sync-Signal für jede Signalfunktion finden Sie unter Sync-Ausgangssignal.
  • Wenn Sync deaktiviert ist, befindet sich der Ausgangspegel am Sync-Anschluss im LOW-Zustand.
  • Invertieren eines Signals (OUTPut[1|2]:POLarity INV) invertiert das Sync-Signal nicht.

OUTPut[1|2]:SYNC:MODE {NORMal|CARRier|MARKer}
OUTPut[1|2]:SYNC:MODE?

Spezifiziert normales Sync-Verhalten (NORMal), erzwingt, dass Sync dem Trägersignal (CARRier) folgt oder gibt die Markerposition an (MARKer).

Parameter | Typische Rückgabe
{NORMal|CARRier|MARKer}, Standard: NORMal | NORM, CARR oder MARK
Ausgangs-Sync-Modus auf CARRier setzen: OUTPut:SYNC:MODE CARR
  • Folgende Tabelle detailliert das Verhalten des Befehls:

    <Modus> | Sync-Verhalten | Bedingungen
    NORMal | Sync folgt Hüllkurve des Burst-Signals. | Wenn BURSt aktiviert ist.
    Sync folgt Hüllkurve des Wobbelsignals. | Wenn SWEep aktiviert ist
    Sync folgt dem Modulationssignal. | Wenn Modulation und Modulationsquelle intern sind
    Sync folgt FUNC-Signal. | Alle anderen Bedingungen
    CARRier | Sync folgt aktueller SOURce:MARKer:POINt Einstellung. | Wenn BURSt oder SWEep aktiviert ist und FUNC auf ARB steht
    Sync folgt FUNC-Signal, während Burst aktiviert ist. | Wenn BURSt aktiviert und FUNC nicht ARB ist
    Sync folgt FUNC-Signal. | Alle anderen Bedingungen
    MARKer Sync folgt aktueller SOURce:MARKer:POINt Einstellung.

    Wenn im CW-Modus und FUNC auf ARB steht

    Bei der Modulation ist die Modulationsquelle intern und FUNC entspricht ARB oder <modulation>:INT:FUNC entspricht ARB

    Bei der Modulation ist die Modulationsquelle extern und FUNC entspricht ARB

    Sync folgt der aktuellen SOURce:MARKer:CYCLe Einstellung. | Wenn BURST aktiviert ist
    Sync folgt der aktuellen SOURce:MARKer:FREQuency Einstellung. | Wenn SWEEP aktiviert ist
    Sync folgt dem Modulationssignal. | Bei der Modulation ist die Modulationsquelle extern, FUNC entspricht nicht ARB und INT:FUNC entspricht nicht ARB
    Sync folgt FUNC-Signal. | Alle anderen Bedingungen

OUTPut[1|2]:SYNC:POLarity {NORMal|INVerted}
OUTPut[1|2]:SYNC:POLarity?

Stellt die gewünschte Ausgangspolarität des Sync Ausgangs auf externe Trigger, die evtl. fallende oder steigende Flankentrigger erfordern.

Parameter | Typische Rückgabe
{NORMal|INVerted}, Standard NORMal | NORM oder INV
Stellen Sie den Ausgangs-Sync-Anschluss des Geräts auf normales Verhalten: OUTP:SYNC:POL NORM
  • NORMal: Spannung auf Sync Ausgangsanschluss geht gegen Null und steigt an, wenn ein Sync-Ereignis auftritt. Die Spannung bleibt hoch (ca. 3,3 V in Verbindung mit hoher Impedanz), bis das Sync-Signal nicht mehr erkannt wird, wenn es erneut gegen Null geht.
  • INVerted: Gegenteil von NORMal.
  • Das Sync-Signal kann bei einem Zweikanalgerät von beiden Kanälen abgeleitet werden (OUTPut:SYNC:SOURce) und von mehreren Betriebsarten des Sync-Signals (OUTPut:SYNC:MODE).

OUTPut:SYNC:SOURce {CH1|CH2}
OUTPut:SYNC:SOURce?

Legt die Quelle für den Sync Ausgangsanschluss fest.

Parameter | Typische Rückgabe
{CH1|CH2}, Standard CH1 | CH1 oder CH2
Sync-Quelle auf Kanal 2 stellen: OUTP :SYNC:SOUR CH2

OUTPut:TRIGger {ON|1|OFF|0}
OUTPut:TRIGger?

Deaktiviert oder aktiviert das Signal "Trigger out" für die Modi Wobbelung und Burst.

Parameter | Typische Rückgabe
{ON|1|OFF|0}, Standard OFF | 0 (OFF) oder 1 (ON)
Triggerausgangssignal aktivieren: OUTP:TRIG ON
  • Ist diese Option aktiviert, wird ein Pulssignal mit der angegebenen Flankenrichtung (OUTPut:TRIGger:SLOPe) vom rückseitigen Ext Trig Anschluss am Anfang des Bursts oder der Wobbelung ausgegeben.
  • Im getriggerten Burst-Modus:
  • Mit TRIGger[1|2]:SOURce IMMediate gibt das Gerät ein Rechtecksignal mit einem 50% Tastverhältnis über den Ext Trig Anschluss aus. Die Signalperiode entspricht der Burst-Periode (BURSt:INTernal:PERiod).
  • Mit TRIGger[1|2]:SOURce EXTernal oder BURSt:MODE GAT deaktiviert das Gerät "Trigger out". Der rückseitige Anschluss Ext Trig kann nicht für beide Vorgänge gleichzeitig verwendet werden (ein extern getriggertes Signal verwendet den gleichen Anschluss für das Triggern von Wobbelung oder Burst).
  • Mit TRIGger[1|2]:SOURce BUS gibt das Gerät bei Beginn jeder Wobbelung oder jedes Bursts einen Puls (>1 µs Pulsbreite bei 33500 Series Geräten und 100 ns bei 33600 Series Geräten) über den Ext Trig Anschluss aus.
  • Im Modus Frequenzwobbelung:
  • Mit TRIGger[1|2]:SOURce IMMediate gibt das Gerät ein Rechtecksignal mit einem Tastverhältnis von 50% aus (die Anstiegsflanke ist der Trigger für die Wobbelung) vom Anschluss Ext Trig. Die Signalperiode entspricht der Wobbelzeit (SWEep:TIME).
  • Mit TRIGger[1|2]:SOURce EXTernal deaktiviert das Gerät das "Trigger out" Signal. Der rückseitige Anschluss Ext Trig kann nicht für beide Vorgänge gleichzeitig verwendet werden (eine extern getriggerte Wobbelung verwendet den gleichen Anschluss für das Triggern der Wobbelung).
  • Mit TRIGger[1|2]:SOURce BUS gibt das Gerät bei Beginn jeder Wobbelung oder jedes Bursts einen Puls (>1 µs Pulsbreite bei 33500 Series Geräten und 100 ns bei 33600 Series Geräten) über den Ext Trig Anschluss aus.

OUTPut:TRIGger:SLOPe {POSitive|NEGative}
OUTPut:TRIGger:SLOPe?

Wählt aus, ob das Gerät die Anstiegsflanke oder die Abfallflanke für das Signal "Trigger out" verwendet.

Parameter | Typische Rückgabe
{POSitive|NEGative}, Standard POSitive | POS oder NEG
Stellt die Trigger-Neigung auf NEGative (negative Flanke): OUTP:TRIG:SLOP NEG
  • POSitive gibt einen Anstiegsflankenpuls aus; NEGative gibt einen Abfallflankenpuls aus.
  • Ist diese Option aktiviert und wird ein OUTPut:TRIGger verwendet, wird ein Pulssignal mit der angegebenen Flankenrichtung vom rückseitigen Trig Out Anschluss am Anfang des Bursts oder der Wobbelung ausgegeben.

OUTPut:TRIGger:SOURce {CH1|CH2}
OUTPut:TRIGger:SOURce?

Wählt den Quellkanal, der vom Trigger-Ausgang eines Zweikanalgeräts genutzt wird. Der Quellkanal legt fest, welches Ausgangssignal am Trigger Out Anschluss generiert wird.

Parameter | Typische Rückgabe
{CH1|CH2}, Standard CH1 | CH1 oder CH2
Ausgangs-Triggerquelle auf CH2 setzen: OUTP:TRIG:SOUR CH2
  • In einem Zweikanalgerät kann jeder Kanal der Quellkanal für den Trigger-Ausgang sein, aber Kanal 2 ist nicht gültig für duale Arbiträrsignale (IQ).
OUTPut-Subsystem


PHASe-Subsystem

Mit dem PHASe-Subsystem können Sie die Signalphase anpassen. Dies ist nützlich für Kanal-zu-Kanal-Anwendungen und Kanal-zu-Sync-Anwendungen. Weiterhin ermöglicht dieses Subsystem die Verwendung der rückseitigen Anschlüsse 10 MHz Out und 10 MHz In zur Synchronisierung mehrerer Geräte.

  • [SOURce[1|2]:]PHASe {<angle>|MINimum|MAXimum|DEFault} - stellt den Phasen-Offset des Ausgangssignals ein (nicht verfügbar für Arbiträrsignale oder Rauschen)
  • [SOURce[1|2]:]PHASe:ARBitrary {<angle>|MINimum|MAXimum} - stellt den Offset für das aktuell ausgewählte Arbiträrsignal ein
  • [SOURce[1|2]:]PHASe:MODulation {<angle>|MINimum|MAXimum} - stellt die Phase der internen Modulationsquelle bei Modulation durch die interne Quelle ein
  • [SOURce[1|2]:]PHASe:REFerence - stellt einen neuen Nullphasenreferenzpunkt ein, ohne den Geräteausgang zu wechseln
  • [SOURce[1|2]:]PHASe:SYNChronize - synchronisiert die Phase beider interner Kanäle eines Zweikanalgeräts.
  • [SOURce[1|2]:]PHASe:UNLock:ERRor:STATe {ON|1|OFF|0} - spezifiziert, ob das Gerät beim Verlust der Phasensynchronisation einen Fehler generiert

[SOURce[1|2]:]PHASe {<angle>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]PHASe? [{MINimum|MAXimum}]

Stellt den Phasenversatzwinkel des Signals ein.

Parameter | Typische Rückgabe
-360 bis +360 Grad, Radiant von -2p bis +2p oder -(Periode) bis +(Periode), gemäß UNIT:ANGLe. Standard 0. | +1,5000000000000E+01
Setzt den Phasenversatz von Kanal 1 auf 15 Grad: UNIT:ANGL DEG PHAS 15
  • Der Phasenversatz ist unabhängig von der Burst-Phase (BURSt:PHASe).
  • Dieser Befehl ändert nicht den primären Phasengenerator des Kanals, sondern fügt lediglich einen Phasenversatz hinzu.
  • Dieser Befehl ist auch nützlich, um das Phasenverhältnis zwischen Kanälen eines Zweikanalgeräts und zwischen dem Kanal und seinem Sync-Signal zu verändern.
  • Verwenden Sie bei einem Zweikanalgerät PHASe:SYNChronize für die Synchronisierung der Phasen der beiden internen Kanäle. Jeder Kanal behält seinen aktuellen Phasenversatz bei, aber beide Kanäle haben einen gemeinsamen Referenzpunkt, so dass der Kanal-zu-Kanal-Versatzunterschied bekannt ist.
  • Bei der Phasensynchronisierung mehrerer Geräte (ROSC commands) ermöglicht der Phasenbefehl eine Anpassung des Phasenverhältnisses zwischen den Geräten.

[SOURce[1|2]:]PHASe:ARBitrary {<angle>|MINimum|MAXimum}
[SOURce[1|2]:]PHASe:ARBitrary?

Stellt den Offset für das aktuell ausgewählte Arbiträrsignal auf Grad, Radiant, Sekunden oder Proben ein. Die Standardmaßeinheiten der <angle> Parameter werden mit UNIT:ARBitrary:ANGLe eingestellt.

Dieser Befehl gilt nur für 33600 Series Geräte und Arbiträrsignale von mindestens 64 Proben.

Parameter | Typische Rückgabe
Von -360 bis 360 (DEGree) Von -2π bis 2π (RADian) Von -Arbiträrsignalperiode bis +Arbiträrsignalperiode (SECond) Von -(Anzahl der Proben-1) bis +(Anzahl der Proben - 1) (SAMPle) | +3,000000000000000E+01
UNIT:ARB:ANGL DEG PHAS:ARB 30
  • Dieser Parameter bezieht sich nur auf die Phase des aktuell ausgewählten Arbiträrsignals. Weitere Funktionen finden Sie unter [SOURce[1|2]:]PHASe.
  • Dieser Parameter bezieht sich auf die Phase des Arbiträrsignals im normalen kontinuierlichen Modus, Modulations- und Wobbelmodus. Im Burstmodus wird die Arbiträrsignalphase von [SOURce[1|2]BURSt:PHASe gesteuert.
  • Wenn ein Arbiträrsignal in einen Speicher geladen wird, ist seine Ausgangsphase null und es übernimmt nicht die Phase des aktuell ausgewählten Arbiträrsignals. Jedes Arbiträrsignal behält seine eigene Phaseneinstellung bei, während es sich im Speicher befindet.
  • Die Arbiträrsignalphase wird entsprechend aller Punkte im Arbiträrsignaldatensatz definiert. Beispielsweise die Einstellung der Arbiträrphase auf 180 Grad bei einem 64-Proben-Arbiträrsignal dreht die Wiedergabe des Signals so, dass es mit der 33sten Probe beginnt (wie vom sync-Signal angegeben) und mit der 32sten Probe endet.

[SOURce[1|2]:]PHASe:MODulation {<angle>|MINimum|MAXimum}
[SOURce[1|2]:]PHASe:MODulation?

Setzt die Phase der internen Modulationsquelle bei Modulation durch die interne Quelle auf die Form SIN, SQU, RAMP, NRAMp, oder TRI. Dieser Befehl bezieht sich ausschließlich auf 33600 Series Geräte.

Dieser Befehl gilt nur für 33600 Series Geräte und Arbiträrsignale von mindestens 64 Proben.

Parameter | Typische Rückgabe
Von -360 bis 360 (DEGree) Von -2π bis 2π (DEGree) Von -Arbiträrsignalperiode bis +Arbiträrsignalperiode (SECond) | +3,000000000000000E+01
Einstellen der Modulationsphase auf 30 Grad: UNIT:ANGL DEG PHAS:MOD 30
  • Die Standardmaßeinheiten der <angle> Parameter werden mit UNIT:ANGLe eingestellt.

[SOURce[1|2]:]PHASe:REFerence

Gleichzeitig wird der durch den Befehl PHASe eingestellte Offset entfernt und der primäre Phasengenerator durch einen Betrag, der der Einstellung PHASe entspricht, angepasst. So wird das Phasenverhältnis beibehalten, das mit einem anderen Gerät eingestellt wurde, während das Sync-Signal erneut auf den Ausgang ausgerichtet wird.

Parameter | Typische Rückgabe
(keine) | (keine)
Null-Phasen-Referenzpunkt für Kanal 1 zurücksetzen: PHAS:REF
  • Der Hauptzweck dieses Befehls besteht darin, einen Nullpunkt zwischen zwei angeschlossenen Geräten zu erstellen. Verwenden Sie für den Kanal-zu-Kanal-Betrieb eines Zweikanalgeräts PHASe:SYNChronize.
  • Einen neuen Nullphasenreferenzpunkt einzustellen bedeutet, dass der Wert, der dann durch einen PHASe? Abfragebefehl zurückgegeben wird, auf "0" zurückgesetzt wird, sich aber das Ausgangssignal selbst nicht ändert.

[SOURce[1|2]:]PHASe:SYNChronize

Stellt gleichzeitig alle Phasengeneratoren im Gerät zurück (einschließlich des Modulationsphasengenerators), um einen gemeinsamen, internen Nullphasenreferenzpunkt festzulegen. Dieser Befehl betrifft nicht die Einstellung PHASe jedes Kanals, sondern definiert den Phasenunterschied zwischen Kanälen ledliglich als die Summe aus SOUR1:PHAS und SOUR2:PHAS anstatt als zufälligen Betrag.

Parameter | Typische Rückgabe
(keine) | (keine)
Zurücksetzen aller Phasengeneratoren: PHAS:SYNC
  • SOURce1 und SOURce2 sind für diesen Befehl nicht von Bedeutung.
  • Dieser Befehl bricht das Phasenverhältnis mit einem anderen Gerät, da es die Phasengeneratoren zurücksetzt.
  • Bei Einkanalgeräten wird so der Hauptkanal mit dem internen Modulationsgenerator synchronisiert.

  • Sie können die Phase zwischen dem primären Signal und dem SUM Signal durch Senden von [SOURce[1|2]:]PHASe:SYNChronize synchronisieren, nachdem Sie die Funktionen für das primäre Signal und das SUM Signal eingestellt haben. Ansonsten ist die Phase zwischen den beiden Signalen arbiträr.

[SOURce[1|2]:]PHASe:UNLock:ERRor:STATe {ON|1|OFF|0}
[SOURce[1|2]:]PHASe:UNLock:ERRor:STATe?

Aktiviert oder deaktiviert das Generieren eines Fehlers wenn die Zeitbasis des Geräts die Phasensynchronisation verliert. Das Gerät verwendet eine Zeitbasis für beide Kanäle.

Parameter | Typische Rückgabe
{ON|1|OFF|0}, Standard OFF | 0 (OFF) oder 1 (ON)
Generation von Phasensynchronisationsfehlern aktivieren: PHASe:UNLock:ERRor:STATe ON
  • SOURce1 und SOURce2 sind für diesen Befehl nicht von Bedeutung.
  • Wenn die Fehlermeldung aktiviert wurde, wird bei einem Verlust der Phasensynchronisation die Fehlermeldung „Reference phase-locked loop is unlocked“ generiert.
  • Flüchtige Einstellung, die beim Ausschalten des Geräts nicht gespeichert wird.
  • Ein defektes Referenzsignal, das auf den 10 MHz In Anschluss wirkt, kann zahlreiche Fehlermeldungen generieren.


PM-Subsystem

Mit dem PM-Subsystem können Sie ein Signal phasenmodulieren.

Fasst die Schritte zusammen, die zur Generierung notwendig sind ein phasenmoduliertes Signal.

  1. Konfiguration des Trägersignals: Verwenden Sie die Befehle FUNCtion, FREQuency VOLTage und VOLTage:OFFSet zur Angabe von Funktion, Frequenz, Amplitude und Offset des Trägersignals.
  2. Modulationsquelle auswählen (intern, extern, CH1 oder CH2): PM:SOURce. Überspringen Sie bei einer externen Modulationsquelle die Schritte 3 und 4.
  3. Modulationssignal einstellen: PM:INTernal:FUNCtion
  4. Modulationsfrequenz einstellen: PM:INTernal:FREQuency
  5. Phasenabweichungen einstellen: PM:DEViation
  6. PM aktivieren: PM:STATe:ON

Der folgende Code bewirkt das unten abgebildete Oszilloskopbild.

FUNCtion SQU
FREQuency +1,0E+04
VOLTage +1,0
VOLTage:OFFset 0,0
PM:SOURce INT
PM:DEViation +90
PM:INTernal:FREQuency +2500
PM:INTernal:FUNCtion RAMP
PM:STATe 1
OUTPut1 1

[SOURce[1|2]:]PM:DEViation {<deviation in degrees>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]PM:DEViation? [{MINimum|MAXimum}]

Stellt die Phasenabweichung in Grad ein. Dieser Wert gibt die maximale Abweichung der Phase des modulierten Signals von der Trägerfrequenz an.

Parameter | Typische Rückgabe
0 bis 360, Standard 180 | +9.000000000000000E+01
Phasenabweichung auf ± 90 Grad einstellen PM:DEV 90
  • Mit der externen Modulationsquelle wird die Abweichung durch den ±5 V Signalpegel (optional ±1 V bei 33600 Series Geräten) am rückseitigen Anschluss Modulation In gesteuert. Wenn Sie beispielsweise die Frequenzabweichung auf 180 Grad eingestellt haben, entspricht ein +5 V Signalpegel (optional ± 1 V bei 33600 Series Geräten) einer Abweichung von +180 Grad Phasenabweichung. Ein niedrigerer externer Signalpegel verursacht einen geringeren und ein negativer Signalpegel einen negativen Phasenhub.

[SOURce[1|2]:]PM:INTernal:FREQuency {<frequency>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]PM:INTernal:FREQuency? [{MINimum|MAXimum}]

Dieser Befehl spezifiziert die Frequenz des Modulationssignals. Das als Modulationssignal gewählte Signal arbeitet dann mit dieser Frequenz, in den Grenzen der Signalfrequenz.

Parameter | Typische Rückgabe
1 μHz bis zum zulässigen Höchstwert für die interne Funktion. Standard 10 Hz. | +1,000000000000000E‑06
Modulationsfrequenz auf 10 kHz einstellen: PM:INT:FREQ 10000 Stellen Sie die Modulationsfrequenz auf 1 μHz: PM:INT:FREQ MIN
  • Wenn Sie ein Arbiträrsignal als Modulationsquelle wählen, wechselt die Frequenz zur Frequenz des Arbiträrsignals, das auf der Abtastrate und der Punktzahl im Arbiträrsignal basiert.
  • Bei Verwendung eines Arbiträrsignals für die Modulationsquelle ändern sich durch eine Änderung dieses Parameters auch die zwischengespeicherten Metadaten, die die Abtastrate des Arbiträrsignals darstellen. Sie können die Modulationsfrequenz eines Arbiträrsignals auch mit FUNCtion:ARBitrary:FREQuency, FUNCtion:ARBitrary:PERiod und FUNCtion:ARBitrary:SRATe ändern. Diese Befehle und der Modulationsfrequenzbefehl sind direkt gekoppelt, damit sich das Arbiträrsignal genau so verhält wie beim letzten Abspielen. Wenn Sie die Modulation später ausschalten und das gleiche Arbiträrsignal als aktuelle Funktion wählen, ist seine Abtastrate (und die entsprechende Frequenz, basierend auf der Punktzahl) identisch mit denen beim Abspielen als Modulationsquelle.
  • Wenn die interne Funktion TRIangle, UpRamp oder DnRamp entspricht, ist die maximale Frequenz bei 33500 Series Geräten auf 200 kHz oder bei 33600 Series Geräten auf 800 kHz begrenzt. Wenn die interne Funktion PRBS entspricht, bezieht sich die Frequenz auf die Bitrate und ist begrenzt, wie hier dargestellt.
  • Dieser Befehl sollte nur mit der internen Modulationsquelle verwendet werden (PM:SOURce INTernal).

[SOURce[1|2]:]PM:INTernal:FUNCtion <function>
[SOURce[1|2]:]PM:INTernal:FUNCtion?

Wählt die Form des Modulationssignals aus.

Parameter | Typische Rückgabe
{SINusoid|SQUare|RAMP|NRAMp|TRIangle|NOISe|PRBS|ARB}, Standard SINusoid Interne Funktionssignale anzeigen. | SIN, SQU, RAMP, NRAM, TRI, NOIS, PRBS oder ARB
Wählen Sie eine Sinuswelle als Modulationssignal: PM:INT:FUNC SIN
  • Dieser Befehl sollte nur mit der internen Modulationsquelle verwendet werden (PM:SOURce INTernal).
  • Rauschen ist zwar als Modulationssignalform verwendbar, aber Rauschen, Puls und DC können nicht als Trägersignalform verwendet werden.
PM-Subsystem


PWM-Subsystem

Mit dem PWM-Subsystem können Sie eine Pulsbreitenmodulation (PWM) für ein Pulssignal durchführen.

Beispiel

Fasst die Schritte zusammen, die zur Generierung notwendig sind ein PWM-Signal.

  1. Konfigurieren Sie ein Trägerpulssignal: Verwenden Sie die Befehle FUNCtion, FREQuency VOLTage und VOLTage:OFFSet zur Angabe von Funktion, Frequenz, Amplitude und Offset des Trägersignals.
  2. Modulationsquelle auswählen (intern, extern, CH1 oder CH2): PWM:SOURce. Überspringen Sie bei einer externen Modulationsquelle die Schritte 3 und 4.
  3. Modulationssignal wählen: PWM:INTernal:FUNCtion
  4. Modulationsfrequenz einstellen: PWM:INTernal:FREQuency
  5. Pulsbreite oder Abweichung des Tastverhältnisses einstellen: PWM:DEViation oder PWM:DEViation:DCYCle
  6. PWM aktivieren: PWM:STATe:ON

Der folgende Code bewirkt das unten abgebildete Oszilloskopbild.

FUNCtion PULS
FREQuency +5000,0
VOLTage +1,0
VOLTage:OFFS +0,0
PWM:DEViation +5,0E-05
PWM:DEViation:DCYCle +25.0
PWM:INTernal:FREQuency +1000,0
PWM:INTernal:FUNCtion RAMP
PWM:STATe 1
OUTPut1 1

[SOURce[1|2]:]PWM:DEViation {<deviation>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]PWM:DEViation? [{MINimum|MAXimum}]

Pulsbreitenabweichung einstellen; die ± Abweichung der Breite (in Sekunden) von der Pulsbreite des Trägerpulssignals.

Parameter | Typische Rückgabe
0 bis 500.000 (Sekunden); Standardwert: 10 μs | +1,000000000000000E+00
Pulsbreitenabweichung auf 1 s einstellen: PWM:DEV 1 Pulsbreitenabweichung auf 0 s einstellen: PWM:DEV MIN
  • Bei der Abweichung handelt es sich um eine ± Abweichung. Beträgt die Pulsbreite 10 ms und die Abweichnug 4 ms kann die Breite von 6 bis 14 ms variieren.
  • Die Pulsbreitenabweichung darf die aktuelle Pulsbreite nicht überschreiten und ist auch begrenzt durch die minmiale Pulsbreite (Wmin):

Pulsbreitenabweichung < Pulsbreite – Wmin

und

Pulsbreitenabweichung < Periode – Pulsbreite – Wmin

  • Die Pulsbreitenabweichung ist durch die aktuelle Flankenzeiteinstellung begrenzt.

Pulsbreitenabweichung < Pulsbreite – (0,8 x Anstiegsflankenzeit) – (0,8 x Abfallflankenzeit)

und

Pulsbreitenabweichung < Periode – Pulsbreite – (0,8 x Anstiegsflankenzeit) – (0,8 x Abfallflankenzeit)

  • Bei Auswahl der externen Modulationsquelle (PWM:SOURce EXTernal) wird die Abweichung durch den ±5 V Signalpegel (optional ±1 V bei 33600 Series Geräten) am rückseitigen Anschluss Modulation In gesteuert. Wenn Sie beispielsweise die Pulsbreitenabweichung auf 10 μs eingestellt haben, entspricht ein +5 V Signalpegel (optional +1 V bei 33600 Series Geräten) einer Abweichung von 10 μs. Ein niedriger externer Signalpegel verursacht eine geringere Abweichung. Negative Signalpegel erzeugen eine negative Abweichung.

[SOURce[1|2]:]PWM:DEViation:DCYCle {<deviation_in_pct>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]PWM:DEViation:DCYCle? [{MINimum|MAXimum}]

Mit diesem Befehl stellen Sie die Abweichung des Tastverhältnisses in Prozent (Prozent der Periode) ein. Dies ist die maximale Abweichung des Tastverhältnisses vom zugrunde liegenden Pulssignal. Beträgt das Tastverhältnis beispielsweise 10% und die Abweichung des Tastverhältnisses 5%, variiert das Tastverhältnis des modulierten Signals um 5% bis 15%.

Parameter | Typische Rückgabe
Tastverhältnis in Prozent der Periode, von 0 bis 50; Standardwert 1 | +5.000000000000000E+00
Pulsbreitenabweichung auf 5% einstellen: PWM:DEV:DCYC 5
  • Die Tastverhältnisabweichung darf nicht größer sein als das Tastverhältnis des Pulssignals.
  • Sie ist ebenfalls durch die minimale Pulsbreite (Wmin) beschränkt:

Abweichung des Tastverhältnisses < Tastverhältnis - 100 x Wmin ÷ Periode

und

Abweichung des Tastverhältnisses < 100 – Tastverhältnis - 100 x Wmin ÷ Periode

wobei Wmin = 16 ns bei 33500 Series Geräten und 5 ns bis 4 Vpp oder 8 ns bis 10 Vpp bei 33600 Series Geräten.

  • Die Tastverhältnisabweichung wird durch die Flankenzeit begrenzt.

Tastverhältnisabweichung < Tastverhältnis – (80 x Anstiegsflankenzeit) ÷ Periode – (80 x Abfallflankenzeit) ÷ Periode

und

Tastverhältnisabweichung < 100 – Tastverhältnis – (80 x Anstiegsflankenzeit) ÷ Periode – (80 x Abfallflankenzeit) ÷ Periode

  • Bei PWM:SOURce EXTernal wird die Abweichung durch den ±5 V Signalpegel (optional ±1 V bei 33600 Series Geräten) am rückseitigen Anschluss Modulation In gesteuert. Beträgt beispielsweise die Tastverhältnisabweichung 5 Prozent, entspricht ein +5 V Signalpegel (optional +1 V bei 33600 Series Geräten) einer Abweichung von 5%, zusätzliche 5% der Periode hinzugefügt zum Tastverhältnis des Pulssignals. Ein niedrigerer externer Signalpegel verursacht eine geringere Abweichung, ein negativer Signalpegel führt zu einer Verringerung des Tastverhältnisses.

[SOURce[1|2]:]PWM:INTernal:FREQuency {<frequency>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]PWM:INTernal:FREQuency? [{MINimum|MAXimum}]

Wählt die Frequenz, bei der die Ausgangsspulsbreitenverschiebung in der Pulsbreitenabweichung erfolgt. Das als Modulationssignal genutzte Signal arbeitet dann mit dieser Frequenz, in den Grenzen der Signalfrequenz.

Parameter | Typische Rückgabe
1 μHz bis zum zulässigen Höchstwert für die interne Funktion. Standard 10 Hz | +1,000000000000000E+02
Einstellen der internen PWM Frequenz auf 100 Hz: PWM:INT:FREQ 100
  • Wenn Sie ein Arbiträrsignal als Modulationsquelle wählen, wechselt die Frequenz zur Frequenz des Arbiträrsignals, das auf der Abtastrate und der Punktzahl im Arbiträrsignal basiert.
  • Bei Verwendung eines Arbiträrsignals für die Modulationsquelle ändern sich durch eine Änderung dieses Parameters auch die zwischengespeicherten Metadaten, die die Abtastrate des Arbiträrsignals darstellen. Sie können die Modulationsfrequenz eines Arbiträrsignals auch mit FUNCtion:ARBitrary:FREQuency, FUNCtion:ARBitrary:PERiod und FUNCtion:ARBitrary:SRATe ändern. Diese Befehle und der Modulationsfrequenzbefehl sind direkt gekoppelt, damit sich das Arbiträrsignal genau so verhält wie beim letzten Abspielen. Wenn Sie die Modulation später ausschalten und das gleiche Arbiträrsignal als aktuelle Funktion wählen, ist seine Abtastrate (und die entsprechende Frequenz, basierend auf der Punktzahl) identisch mit denen beim Abspielen als Modulationsquelle.
  • Wenn die interne Funktion TRIangle, UpRamp oder DnRamp entspricht, ist die maximale Frequenz bei 33500 Series Geräten auf 200 kHz oder bei 33600 Series Geräten auf 800 kHz begrenzt. Wenn die interne Funktion PRBS entspricht, bezieht sich die Frequenz auf die Bitrate und ist begrenzt, wie hier dargestellt.
  • Dieser Befehl sollte nur mit der internen Modulationsquelle verwendet werden (PWM:SOURce INTernal).

[SOURce[1|2]:]PWM:INTernal:FUNCtion <function>
[SOURce[1|2]:]PWM:INTernal:FUNCtion?

Wählt die Form des internen Modulationssignals aus.

Parameter | Typische Rückgabe
{SINusoid|SQUare|RAMP|NRAMp|TRIangle|NOISe|PRBS|ARB}, Standard SINusoid Interne Funktionssignale anzeigen. | SIN, SQU, RAMP, NRAM, TRI, NOIS, PRBS oder ARB
Wählen Sie eine Sinuswelle als Modulationssignalform: PWM:INT:FUNC SIN
  • Dieser Befehl sollte nur mit der internen Modulationsquelle verwendet werden (PWM:SOURce INTernal).
PWM-Subsystem


RATE-Subsystem

Mit dem RATE-Subsystem können Sie die Abtastraten des Ausgangs eines Zweikanalgeräts durch Angabe folgender Elemente koppeln:

  • [SOURce[1|2]:]RATE:COUPle[:STATe] {ON|1|OFF|0}
  • [SOURce[1|2]:]RATE:COUPle:MODE {OFFSet|RATio}
  • [SOURce[1|2]:]RATE:COUPle:OFFSet {<sample_rate>|MINimum|MAXimum|DEFault}
  • [SOURce[1|2]:]RATe:COUPle:RATio {<ratio>|MINimum|MAXimum}

[SOURce[1|2]:]RATE:COUPle[:STATe] {ON|1|OFF|0}
[SOURce[1|2]:]RATE:COUPle[:STATe]?

Aktiviert oder deaktiviert die Abtastratenkopplung zwischen Kanälen oder ermöglicht die One-Time-Kopie der Abtastrate eines Kanals in den anderen Kanal.

Parameter | Typische Rückgabe
{ON|1|OFF|0}, Standard OFF | 0 (OFF) oder 1 (ON)
Abtastratenkopplungsstatus einschalten: RATE:COUP ON
  • Der ON-Wert beginnt die Abtastratenkopplung in dem Modus, der durch RATE:COUPle:MODE angegeben ist.
  • Wenn durch die aktuellen Offset- oder Verhältniswerte in Kombination mit den aktuellen Abtastrateneinstellungen eine Abtastrate die Geräteeinstellungen überschreitet, erzeugt das Gerät einen Fehler und die überschrittene Abtastrate wird bei ihrem Höchst- oder Mindestwert abgeschnitten.
  • Wenn bei Einstellung des Modus auf RATIO und die Einstellung von RATIO auf 1.0 weiterhin die Spezifikationen jedes Kanals überschritten wird, wird eine Fehlermeldung generiert und RATE:COUPle[:STATe] wird nicht auf ON gesetzt.
  • Beide Kanäle müssen für FUNCtion ARB konfiguriert sein, um die Kopplung der Abtastrate zu aktivieren.

[SOURce[1|2]:]RATE:COUPle:MODE {OFFSet|RATio}
[SOURce[1|2]:]RATE:COUPle:MODE?

Stellt für den Typ der Abtastratenkopplung entweder einen konstanten Abtastraten-Offset (OFFSet) oder ein konstantes Verhältnis (RATio) zwischen den Abtastraten der Kanäle ein.

Parameter | Typische Rückgabe
{OFFSet|RATio}, Standard RATio | OFFS oder RAT
Modus der Abtastratenkopplung auf OFFSet stellen. RATE:COUP:MODE OFFSet
  • Standard-RATio ist 1.
  • Die Standard-Abtastratenkopplung ist OFF.
  • Das Schlüsselwort SOURce[1|2] wird ignoriert; die Einstellung gilt für beide Kanäle.

[SOURce[1|2]:]RATE:COUPle:OFFSet {<sample_rate>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]RATE:COUPle:OFFSet?

Stellt den Offset der Abtastrate ein, wenn ein Zweikanalgerät sich im OFFSet des Abtastratenkopplungsmodus befindet.

Parameter | Typische Rückgabe
Gültige Werte sind abhängig von der Einstellung FUNCtion:ARBitrary:FILTer. Für NORMal und STEP liegt der Bereich zwischen ±250 MSa/s (33500 Series) oder ±1 GSa/s (33600 Series). Für OFF liegt der Bereich zwischen ±62.5 MSa/s (33500 Series) oder ±250 MSa/s (33600 Series). In jedem Fall ist der Standard 0. | +8,000000000000000E+02
Abtastraten-Offsets von Kanal 2 auf 10,3 kSa/s höher einstellen als die Abtastrate von Kanal 1. RATE:COUPle:OFFSet 10300 Stellt den Abtastraten-Offset von Kanal 1 auf 45 kSa/s niedriger als die Abtastrate von Kanal 2. SOUR2:RATE:COUP:OFFS -45000
  • Bei der Angabe von OFFSet oder RATio wird der SOURce-Kanal (SOURce1 oder SOURce2) als Referenzkanal verwendet und der Offset oder das Verhältnis wird auf den anderen Kanal angewandt. Angenommen, RATE:COUPle[:STATe] steht auf ON und RATE:COUPle:MODE steht auf OFFSet. Nehmen wir weiterhin an, dass Kanal 1 mit 2 kSa/s arbeitet und Kanal 2 mit 10 kSa/s. Durch Befehl SOUR1:RATE:COUP:OFFS 2.5 bleibt Kanal 1 bei 2 Sa/s und Kanal 2 wird auf 4,5 Sa/s gestellt. Wenn sich die Abtastrate eines Kanals ändert, ändert sich die Abtastrate des anderen Kanals ebenfalls, um die angegebene Kopplung beizubehalten.
  • Wenn durch die Abtastratenkopplung ein Kanal die Abtastratenspezifikationen des Geräts für die aktuelle Funktion überschreiten würde, hat der Befehl einen Fehler zur Folge und die Abtastrate wird auf den Höchst- oder Mindestwert für den Kanal eingestellt.

[SOURce[1|2]:]RATe:COUPle:RATio {<ratio>|MINimum|MAXimum}
[SOURce[1|2]:]RATe:COUPle:RATio? [{MINimum|MAXimum}]

Stellt das Offset-Verhältnis zwischen den Kanal-Abtastraten ein, wenn ein Zweikanalgerät sich im Abtastratenkopplungsmodus RATio befindet.

Parameter | Typische Rückgabe
0,001 bis 1000, Standard 1 | +7,500000000000000E-1
Stellen Sie die Abtastrate von Kanal 2 auf das Zweifache von Kanal 1 ein. SOUR1:RATE:COUP:RATio 2 Stellen Sie die Abtastrate von Kanal 1 3.14 mal so hoch wie die von Kanal 2 ein. SOUR2:RATE:COUPle:RAT 3,14
  • Bei der Angabe von OFFSet oder RATio wird der SOURce-Kanal (SOURce1 oder SOURce2) als Referenzkanal verwendet und der Offset oder das Verhältnis wird auf den anderen Kanal angewandt. Angenommen, das Gerät ist im Modus RATio gekoppelt. Nehmen wir weiterhin an, dass Kanal 1 mit 2 kSa/s arbeitet und Kanal 2 mit 10 kSa/s. Durch den Befehl SOUR1:RAT:COUP:RAT 2.5 bleibt Kanal 1 bei 2 kSa/s und Kanal 2 wird auf 5 kSa/s gestellt. Wenn sich die Abtastrate eines Kanals ändert, ändert sich die Abtastrate des anderen Kanals ebenfalls, um die angegebene Kopplung beizubehalten.
  • Wenn durch die Abtastratenkopplung ein Kanal die Abtastratenspezifikationen des Geräts für die aktuelle Funktion überschreiten würde, hat der Befehl einen Fehler zur Folge und die Abtastrate wird auf den Höchst- oder Mindestwert für den Kanal eingestellt.


ROSCillator Subsystem

Beim BNC-Anschluss des externern 10 MHz-Referenzeingangs sind sowohl Buchse als auch mittlerer Stecker am hinteren Bedienfeld des Geräts bis zu ±42 Vpk vom Gehäuse isoliert. Die Buchse dieses BNC-Anschlusses ist vom Rest des Geräts isoliert. Der interne Schaltkreis hält die isolierte Spannung auf ±42 Vpk gegen Gehäuse. Ein Verbinden dieses Eingangs mit über ±42 Vpk vom Gehäuse kann zur Beschädigung des Geräts sowie zu Personenschäden, u. U. mit Todesfolge, führen.

Der Geräteausgang 10 MHz ist auf die Chassis-Masse bezogen.

Das ROSCillator Subsystem steuert die Verwendug des 10 MHz Referenz-Oszillators und des externen Referenz-Oszillator-Eingangs. Der Referenz-Oszillator ist der primäre Taktgeber für alle Signalsynthesen. Alle Signale werden mit dem Referenz-Oszillator synchronisiert, der daher die Ausgangssignalfrequenz und -phase steuert.

  • ROSCillator:SOURce {INTernal|EXTernal} - wählt die interne oder externe Referenzoszillatorquelle
  • ROSCillator:SOURce:AUTO {ON|OFF} - deaktiviert oder aktiviert die automatische Auswahl der Referenzoszillatorsignalquelle
  • ROSCillator:SOURce:CURRent? - gibt INT oder EXT zurück, um die aktuelle Referenzoszillatorquelle anzugeben

ROSC:SOURce stellt ROSCillator:SOURce:AUTO auf OFF und ROSCillator:SOURce:AUTO ON überschreibt ROSC:SOURce. Der aktuellere Befehl (dieser beiden Befehle) ist prioritär.

ROSCillator:SOURce INTernal verwendet den internen Oszillator des Geräts als Referenzoszillator. Dies kann entweder ein standardmäßiger temperaturkompensierter Kristalloszillator (TCXO) sein oder der optionale ofengesteuerte Kristalloszillator (OCXO).

Unter *OPT? finden Sie Details, um zu bestimmen, ob OCXO installiert ist. Wenn ein externes 10 MHz Referenzsignal sich am rückseitigen 10 MHz In Anschluss befindet, verwendet das Gerät das externe Signal. Auch wird ein Symbol in der oberen rechte Ecke des Displays angezeigt, das den Wechsel der Referenzquelle angibt.

ROSCillator:SOURce {INTernal|EXTernal}
ROSCillator:SOURce?

Wählt die Quelle für den Referenzoszillator, die als Frequenz-/Phasenreferenz für Signale verwendet wird, die vom Gerät generiert werden.

Parameter | Typische Rückgabe
{INTernal|EXTernal}, Standard INT | INT oder EXT
Externe Referenzoszillatorquelle verwenden: ROSC:SOUR EXT
  • EXTernal: Gerät verwendet Signal am rückseitigen 10 MHz In Anschluss als Referenz und generiert einen Fehler, wenn dieses Signal nicht vorhanden ist oder das Gerät nicht damit synchronisiert werden kann. Bei solchen Fehlern geht die Ausgabe des Geräts weiter, die Frequenz ist jedoch instabil.
  • INTernal: Das Gerät verwedet den internen Referenzoszillator und ignoriert das Signal am Anschluss 10 MHz In.

ROSCillator:SOURce:AUTO {ON|OFF}
ROSCillator:SOURce:AUTO?

Deaktiviert oder aktiviert die automatische Auswahl ds Referenzoszillators.

Parameter | Typische Rückgabe
{ON|OFF}, Standard ON | ON oder OFF
Referenzquelle automatisch wählen: ROSC:SOUR:AUTO ON
  • ON: das Gerät stellt bevorzugt ein 10 MHz Signal vom rückseitigen 10 MHz In Anschluss ein.
  • OFF: das Gerät wählt den Referenzoszillator, der auf der Einstellung ROSC:SOURce beruht.

ROSCillator:SOURce:CURRent?

Gibt an, welches Oszillatorsignal derzeit verwendet wird, wenn ROSC:SOURce:AUTO auf ON steht.

Parameter | Typische Rückgabe
(keine) | INT (intern) oder EXT (10 MHz Anschluss an der Rückseite)
Referenzsignalquelle bestimmen: ROSC:SOUR:CURR?
  • INT bezieht sich auf das grundlegende interne TCXO oder den optionalen, ofengesteuerten OCXO-Oszillator (abhängig davon, welcher installiert ist).


SOURce Subsystem

Das SOURce Schlüsselwort ist bei zahlreichen Befehlen optional, die Parameter für einen Quell- oder Ausgangskanal einstellen.

Beispiel

Das Schlüsselwort SOURce und die Kanalnummer sind bei der Abfrage [SOURce[1|2]:]AM[:DEPTh]? optional. Werden sie weggelassen, verwendet die Quelle standardmäßig Kanal 1. Folgende Tabelle zeigt, wie verschiedene Formen der Abfrage interpretiert werden.

Parameter | Typische Rückgabe
AM:DEPTh? | gibt die Modulationstiefe von Kanal 1 zurück
SOUR1:AM:DEPTh? | gibt die Modulationstiefe von Kanal 1 zurück
SOUR2:AM:DEPTh? | Gibt die Modulationstiefe von Kanal 2 zurück (nur Zweikanalgeräte)

Subsysteme, die das optionale SOURce-Schlüsselwort verwenden

Da die SOURce Subsystem Befehle oft mit dem Schlüsselwort SOURce verwendet werden, sind diese Befehle nachstehend entsprechend ihren jeweiligen Subsystemen aufgeführt:

AM

APPLy

BPSK

BURSt

DATA

FM

FREQuency

FSKey

FUNCtion

LIST

MARKer

PHASe

PM

PWM

ROSCillator

SUM

SWEep

VOLTage

Befehle, die das optionale SOURce-Schlüsselwort verwenden

Folgende Befehle, die nicht zu einem Subsystem gehören, haben auch das optionale SOURce Schlüsselwort:

COMBine:FEED

TRACk


Einführung STATus Subsystem

STATus Subsystem Einführung

Das SCPI Statussystem des Geräts zeichnet verschiedene Gerätebedingungen und -zustände in verschiedenen Registergruppen auf.

In diesem Subsystem ist ein Ereignis etwas, das aufgetreten ist, auch wenn es evtl. nicht mehr auftritt. Eine Bedingung ist etwas, das aktuell auftritt. Eine Bedingung wird im Ereignisregister angezeigt, aber das Ereignisregister wird beim Lesen gelöscht (auf 0 gesetzt).

The STATus commands ändern Bits zu zwei der Aktivierungsregister. Folgende Optionen stehen zur Verfügung:

  • Bits im Questionable Data enable Register (STATus:QUEStionable:ENABle <enable_value>) aktivieren. Abfrage: STATus:QUEStionable:ENABle?
  • Bits im Operation enable Register (STATus:OPERation:ENABle <enable_value>) aktivieren. Abfrage: STATus:OPERation:ENABle?
  • Dieser Befehl setzt alle Bits des Questionable Data Enable-Registers und des „Standard Operation Enable“-Registers (STATus:PRESet) zurück.

The STATus queries greifen auf Informationen zu den Statusbits in den Questionable Data Registern zu, inklusive:

  • Die binär gewichtete Summe aller Bits, die im Questionable Data condition Register (STATus:QUEStionable:CONDition?) aktiviert sind
  • Die binär gewichtete Summe aller Bits, die im Questionable Data event Register (STATus:QUEStionable[:EVENt]?) aktiviert sind
  • Die binär gewichtete Summe aller Bits, die im Questionable Data enable Register (STATus:QUEStionable:ENABle <enable_value>) aktiviert sind.

The STATus queries ermöglichen Ihnen weiterhin den Zugriff auf Informationen über die Status-Bits im Register Operation, inkl.:

  • Die binär gewichtete Summe aller Bits, die im Operation condition Register (STATus:OPERation:CONDition?) aktiviert sind.
  • Die binär gewichtete Summe aller Bits, die im Operation event Register (STATus:OPERation[:EVENt]?) aktiviert sind.

„Standard Operation“-Registergruppe

Folgende Tabelle beschreibt die Registergruppe Standard Operation.

Bit-Nummer | Bit-Name | Dezimalwert | Definition
0 | Kalibrierung | 1 | Das Gerät führt eine Kalibrierung durch.
1 | Selbsttest | 2 | Ein Selbsttest läuft.
2 | (belegt) | 4 | (Für die zukünftige Verwendung vorgesehen)
3 | Kanal 1 initiiert | 8 | Der Kanal ist initiiert und gibt das gewünschte Signal aus. In INIT[1|2]:CONT OFF wird dieses Bit nach dem Eingang eines INIT eingestellt und nicht gelöscht, bis der Kanal auf IDLE umschaltet (Triggerzahl erreicht und nicht belegt.) Dieses Bit entspricht 0, wenn der Kanal sich im Modus INIT[1|2]:CONT ON befindet.
4 | Kanal 2 initiiert | 16
5 | Warten auf Trigger, Kanal 1 | 32 | Das Gerät wartet auf einen Trigger. In INIT[1|2]:CONT OFF wird dieses Bit nach dem Empfang von INIT eingestellt, während es auf einen Trigger wartet. Nach Eingang des Triggers wird es gelöscht. Dieses Bit entspricht 0, wenn der Kanal sich im Modus INIT[1|2]:CONT ON befindet.
6 | Warten auf Trigger, Kanal 2 | 64
7 | (belegt) | 128 | (Für die zukünftige Verwendung vorgesehen)
8 | Ereignis mit geänderter Konfiguration | 256 | Dieses Bit ist stets 0 im Bedingungsregister, da es ein Ereignis und keine Bedingung darstellt.
9 | (belegt) | 512 | (Für die zukünftige Verwendung vorgesehen)
10 | Gerät gesperrt | 1024 | Wenn eine Remote-Schnittstelle (USB oder LAN) über eine Sperrung verfügt (SYSTem:LOCK:REQuest?), wird dieses Bit eingestellt. Wen enie Remote-Schnittstelle die Sperrung (SYSTem:LOCK:RELease) aufhebt, wird dieses Bit gelöscht.
11 | (belegt) | 2048 | (Für die zukünftige Verwendung vorgesehen)
12 | (belegt) | 4096 | (Für die zukünftige Verwendung vorgesehen)
13 | Global Error | 8192 | Wird eingestellt, wenn eine Remote-Schnittstelle einen Fehler ihn der Warteschlange aufweist (und ansonsten gelöscht).
14-15 | (belegt) | 16,384 - 32,768 | (Für die zukünftige Verwendung vorgesehen)

„Questionable Data“-Registergruppe

Folgende Tabelle beschreibt die Registergruppe Questionable Data.

Bit-Nummer | Bit-Name | Dezimalwert | Definition
0 | Kanal 1 Überspannung | 1 | Überspannung am Ausgangsanschluss von Kanal 1. Der Ausgang wurde deaktiviert.
1 | Kanal 2 Überspannung | 2 | Überspannung am Ausgangsanschluss von Kanal 2. Der Ausgang wurde deaktiviert.
2 | (belegt) | 4 | (Für die zukünftige Verwendung vorgesehen)
3 | (belegt) | 8 | (Für die zukünftige Verwendung vorgesehen)
4 | (belegt) | 16 | (Für die zukünftige Verwendung vorgesehen)
5 | Loop Unlocked | 32 | Die Phasensynchronisation ist verloren gegangen. Hierdurch wird die Frequenzgenauigkeit beeinträchtigt.
6 | (belegt) | 64 | (Für die zukünftige Verwendung vorgesehen)
7 | (belegt) | 128 | (Für die zukünftige Verwendung vorgesehen)
8 | Kalibrierungsfehler | 256 | Während der Kalibrierung ist ein Fehler aufgetreten, die Kalibrierung ist nicht gesichert oder der Kalibrierungsspeicher ist verloren gegangen
9 | Externe Referenz | 512 | Die externe Zeitbasis wurde erkannt.
10-15 | (belegt) | 1024 - 32,768 | (Für die zukünftige Verwendung vorgesehen)

STATus:OPERation:CONDition?

Fragt das Condition Register für die Gruppe Standard Operation Register ab. Es handelt sich um ein Leseregister; die Bits werden bei der Abfrage nicht zurückgesetzt.

Parameter | Typische Rückgabe
(keine) | +32
Lesen des Condition Registers (Bit 5 ist eingestellt): STAT:OPER:COND?
  • Die Condition Register Bits stellen die aktuelle Bedingung dar. Wenn eine Bedingung nicht mehr aktuell ist, wird das entsprechende Bit gelöscht.
  • *RST löscht dieses Register, das nicht den Bits entspricht, bei denen die Bedingung noch nach *RST besteht.
  • Der Befehl liest die Bedingung Register gibt einen Dezimalwert zurück, der der binär gewichteten Summe aller im Register eingestellten Bits entspricht. Beispiel: Wenn Bit 5 (Dezimalwert = 32) und Bit 9 (Dezimalwert = 512) eingestellt sind, gibt der Befehl +544 zurück.

STATus:OPERation:ENABle <enable_value>
STATus:OPERation:ENABle?

Aktiviert Bits im Register enable register für die Gruppe Standard Operation Register. Die ausgewählten Bits werden dann dem Status Byte als Standard Operation Zusammenfassungsbit berichtet.

Parameter | Typische Rückgabe
Summe der Bit-Dezimalwerte im Register. | +256
Aktivieren von Bit 8 (Dezimalwert 256) im "Enable"-Register: STAT:OPER:ENAB 256
  • Geben Sie mit <enable_value> an, welche Bits an „Status Byte“ gemeldet werden. Der angegebene Wert entspricht der binär gewichteten Summe der zu aktivierenden Register-Bits. Um z. B. Bit 5 (Wert 32) und Bit 9 (Wert 512) zu aktivieren, wäre der Dezimalwert 544.
  • *CLS löscht nicht das Aktivierungsregister, löscht jedoch das Ereignisregister
  • Dieses Register wird beim Einschalten gelöscht, sofern *PSC auf 0 gestellt ist.

Siehe auch

*STB?

STATus:OPERation[:EVENt]?

Fragt das Event Register für die Gruppe Standard Operation Register ab. Dies ist ein Nur-Lese-Register; die Bits werden beim Abfragen des Registers zurückgesetzt.

Parameter | Typische Rückgabe
(keine) | +32
„Event“-Register ablesen : STAT:OPER:EVEN?
  • Ein eingestelltes Bit bleibt eingestellt, bis es durch das Lesen des Ereignisregisters oder *CLS gelöscht wird.
  • *RST hat keine Auswirkungen auf dieses Register.
  • Die Abfrage liest das Ereignis Register gibt einen Dezimalwert zurück, der der binär gewichteten Summe aller im Register eingestellten Bits entspricht. Sind beispielsweise Bit 5 ( Wert 32) und Bit 9 (Wert 512) eingestellt, gibt der Befehl +544 zurück.

STATus:PRESet

Löscht das Aktivierungsregister Questionable Data und das Aktivierungsregister Standard Operation.

Parameter | Typische Rückgabe
(keine) | (keine)
Enable-Register-Bits löschen: STAT:PRES

STATus:QUEStionable:CONDition?

Fragt das Condition Register für die Gruppe Questionable Data Register ab.

Parameter | Typische Rückgabe
(keine) | +512
Lesen des Condition Registers (Bit 9 ist eingestellt): STAT:QUES:COND?
  • Die Registergruppe Questionable Data bietet Informationen über die Gerätequalität oder -integrität.
  • Alle Bedingungen können dem Zusammenfassungsbit Questionable Data über das Ereignisregister hinzugefügt werden.
  • Es handelt sich um ein Leseregister; die Bits werden bei der Abfrage nicht zurückgesetzt.
  • Die Condition Register Bits stellen die aktuelle Bedingung dar. Wenn eine Bedingung nicht mehr aktuell ist, wird das entsprechende Bit gelöscht.
  • *RST löscht das Condition Register.
  • Die Abfrage liest die Bedingung Register gibt einen Dezimalwert zurück, der der binär gewichteten Summe aller im Register eingestellten Bits entspricht. Ist z.B. Bit 12 (Dezimalwert = 4096) eingestellt, gibt die Abfrage "+4096" zurück.

STATus:QUEStionable:ENABle <enable_value>
STATus:QUEStionable:ENABle?

Aktiviert Bits im Register enable register für die Gruppe Questionable Data Register. Die Werte der ausgewählten Bits werden dann dem Register „Status Byte“ gemeldet.

Parameter | Typische Rückgabe
Ein Dezimalwert, der mit der Summe der Bit-Dezimalwerte im Register identisch ist. | +512
Aktivieren von Bit 9 (Wert 512) im "Enable"-Register: STAT:QUES:ENAB 512
  • Geben Sie mit <enable_value> an, welche Bits an „Status Byte“ gemeldet werden. Der angegebene Wert entspricht der binär gewichteten Summe der zu aktivierenden Register-Bits. Um z. B. Bit 5 (Wert 32) und Bit 9 (Wert 512) zu aktivieren, wäre der Dezimalwert 544.
  • Aktivierungsregister gelöscht durch:
    • STATus:Questionable:ENABle 0
    • STATus:PRESet
    • Aus- und Wiedereinschalten (sofern *PSC auf 0 gestellt ist)
  • *CLS löscht nicht das „Enable“-Register, löscht jedoch das "Event"-Register.
  • *RST hat keine Auswirkungen auf dieses Register.
  • Die Abfrage liest das Aktivierungs-Register gibt einen Dezimalwert zurück, der der binär gewichteten Summe aller im Register eingestellten Bits entspricht. Sind beispielsweise Bit 0 (Wert 1) und Bit 1 ( Wert 2) aktiviert, gibt die Abfrage +3 zurück.

STATus:QUEStionable[:EVENt]?

Fragt das Ereignisregister für die Gruppe Questionable Data Register ab. Dies ist ein Nur-Lese-Register; die Bits werden beim Abfragen des Registers zurückgesetzt.

Parameter | Typische Rückgabe
(keine) | +512
Lesen des Event-Registers (Bit 9 eingestellt): STAT:QUES?
  • Ein gesetztes Bit bleibt so lange gesetzt, bis es mit dieser Abfrage oder mit dem Befehl *CLS gelöscht wird.
  • *RST, STATus:PRESet und *PSC haben keine Auswirkungen auf dieses Register.
  • Die Abfrage liest das Ereignis Register gibt einen Dezimalwert zurück, der der binär gewichteten Summe aller im Register eingestellten Bits entspricht. Sind z. B. Bit 1 (Wert 2) und Bit 9 ( Wert 512) eingestellt, gibt die Abfrage "+514" zurück.


Einführung in das SUM Subsystem

SUM Subsystem Einführung

Das SUM Subsystem addiert ein Modulationsquellensignal zum primären Signal eines Kanals. So können Sie ein Zweitonsignal an einem Kanal erstellen oder Rauschen zu einem primären Signal hinzufügen. Die SUM-Funktion verwendet die gleichen sekundären Quellen wie die Modulations-Subsysteme.

An einem Kanal kann nur eine Modulations- oder SUM-Funktion gleichzeitig aktiv sein, so dass Sie Rauschen nicht zu einem FM-Signal hinzufügen können, das nur einen Kanal verwendet. Benutzen Sie für diesen Vorgang COMBine:FEED. Dadurch werden beide Kanäle eines Zweikanalgeräts in einen Kanalausgangsanschluss kombiniert.

Wenn Signale SUMmed (summiert) werden, gilt folgendes:

  • Ihre Spitzen-Amplitude darf die Ausgangswerte des Geräts nicht überschreiten.
  • Keine weitere interne oder externe Modulation ist auf diesem Kanal möglich.

Sie können die Phase zwischen dem primären Signal und dem SUM Signal durch Senden von [SOURce[1|2]:]PHASe:SYNChronize synchronisieren, nachdem Sie die Funktionen für das primäre Signal und das SUM Signal eingestellt haben. Ansonsten ist die Phase zwischen den beiden Signalen arbiträr.

Wenn die Quelle der andere Kanal ist, kommt es zu einer deutlichen Verzögerung (von 350 ns) entsprechend des Trägers, auch nach PHAS:SYNC. Verwenden Sie wenn möglich immer die Funktion Combine für den anderen Kanal.

Beispiel

Um ein SUM-Signal zu erzeugen:

  1. Konfiguration des Trägersignals: Verwenden Sie die Befehle FUNCtion, FREQuency VOLTage und VOLTage:OFFSet zur Angabe von Funktion, Frequenz, Amplitude und Offset des Trägersignals.
  2. Wählen Sie die Summierquelle: Das Gerät akzeptiert eine interne oder externe Modulationsquelle (EXT, Kanal 1 oder Kanal 2). Wählen Sie die Modulationsquelle mit SUM:SOURce. Überspringen Sie bei einer externen Modulationsquelle die Schritte 3 und 4.
  3. Konfigurieren Sie ein Summiersignal: Verwenden Sie die Befehle FUNCtion, FREQuency, VOLTage und VOLTage:OFFSet, um das Summiersignal zu konfigurieren.
  4. Einstellung des zu summierenden Amplitudenprozentsatzes: SUM:AMPLitude.
  5. SUM-Modulation aktivieren: SUM:STATe:ON.
  6. Wenn Sie den anderen Kanal eines Zweikanalgeräts verwenden, synchronisieren Sie die Kanäle: PHASe:SYNChronize.

Der folgende Code bewirkt das unten abgebildete Oszilloskopbild.

SOURce1:FUNCtion RAMP
SOURce1:FREQuency +2000,0
SOURce1:VOLTage +1,0
SOURce1:VOLTage:OFFS +0,0
SOURce1:FUNCtion:RAMP:SYMMetry +50,0
SOURce2:FUNCtion SQU
SOURce2:FREQuency +4000,0
SOURce2:VOLTage +1,0
SOURce2:VOLTage:OFFS +0,0
SOURce1:SUM:AMPLitude +50,0
SOURce1:SUM:SOURce CH2
SOURce1:SUM:STATe 1
SOURce1:PHASe:SYNC
OUTPut1 1
OUTPut2 1

[SOURce[1|2]:]SUM:AMPLitude {<amplitude>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]SUM:AMPLitude? [{MINimum|MAXimum}]

Stellt den internen Modulationsgrad in Prozent ein.

Parameter | Typische Rückgabe
Die gewünschte SUM-Signal-Amplitude in Prozent der Trägeramplitude, von 0 bis 100; Standard: 0,1 | +3,200000000000000E+00
Interne SUM-Signal-Amplitude auf 1,0% der Signalamplitude stellen: SUM:AMPL 1,0 PHAS:SYNC Interne SUM-Signal-Amplitude von Kanal 2 auf 0,15% der Signalamplitude stellen: SOUR2:SUM:AMPL 0,15

  • Sie können die Phase zwischen dem primären Signal und dem SUM Signal durch Senden von [SOURce[1|2]:]PHASe:SYNChronize synchronisieren, nachdem Sie die Funktionen für das primäre Signal und das SUM Signal eingestellt haben. Ansonsten ist die Phase zwischen den beiden Signalen arbiträr.

  • Die summierte Ausgabe darf nicht höher sein als ±5 V Ausgangs-Spitzenspannung (in eine 50 Ω Last).
  • Wenn Sie die externe SUM-Quelle wählen (SUM:SOURce EXTernal), wird das Trägersignal zum externen Signal hinzugefügt. Das Summiersignal entspricht dem ±5 V Signalpegel (optional ±1 V bei 33600 Series Geräten) am rückseitigen Anschluss Modulation In. Wenn Sie beispielsweise die Trägeramplitude eines Sinussignals auf 4 Vpp und die Summenamplitude mit SUM:AMPLitude auf 20% eingestellt haben (was zu einem maximalen Summenbeitrag von 800 mVpp führt), erfolgt bei einem EXT-Signal von +5 V (optional +1 V bei 33600 Series Geräten) die zusätzliche Signalausgabe bei einer maximalen Amplitude von 4,8 Vpp. Beträgt das Modulationssignal -5 V (optional -1 V bei 33600 Series Geräten), erfolgt das Zusatzsignal bei einer minimalen Amplitude von -4.8 Vpp. Bei einem Modulationseingang von 0 V würde das Signal der Trägeramplitude entsprechen.

[SOURce[1|2]:]SUM:INTernal:FREQuency {<frequency>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]SUM:INTernal:FREQuency? [{MINimum|MAXimum}]

Stellt die Frequenz des Summiersignals ein, wenn eine interne Summierquelle ausgewählt wird (SUM:SOURce:INTernal). Das Modulationssignal arbeitet mit dieser Frequenz, in den Frequenzgrenzen dieses Signals.

Parameter | Typische Rückgabe
1 μHz bis zum zulässigen Höchstwert für die interne Funktion. Standard 100 Hz | +1,000000000000000E‑06
Folgender Befehl stellt die Summierfrequenz an Kanal 2 auf 10 kHz: SOUR2:SUM:INT:FREQ 10000 SOUR2:PHAS:SYNC Folgender Befehl stellt die Summierfrequenz an Kanal 1 auf 1 μHz: SUM:INT:FREQ MIN PHAS:SYNC

  • Sie können die Phase zwischen dem primären Signal und dem SUM Signal durch Senden von [SOURce[1|2]:]PHASe:SYNChronize synchronisieren, nachdem Sie die Funktionen für das primäre Signal und das SUM Signal eingestellt haben. Ansonsten ist die Phase zwischen den beiden Signalen arbiträr.

  • Wenn Sie ein Arbiträrsignal als Modulationsquelle wählen, wechselt die Frequenz zur Frequenz des Arbiträrsignals, das auf der Abtastrate und der Punktzahl im Arbiträrsignal basiert.
  • Bei Verwendung eines Arbiträrsignals für die Modulationsquelle ändern sich durch eine Änderung dieses Parameters auch die zwischengespeicherten Metadaten, die die Abtastrate des Arbiträrsignals darstellen. Sie können die Modulationsfrequenz eines Arbiträrsignals auch mit FUNCtion:ARBitrary:FREQuency, FUNCtion:ARBitrary:PERiod und FUNCtion:ARBitrary:SRATe ändern. Diese Befehle und der Modulationsfrequenzbefehl sind direkt gekoppelt, damit sich das Arbiträrsignal genau so verhält wie beim letzten Abspielen. Wenn Sie die Modulation später ausschalten und das gleiche Arbiträrsignal als aktuelle Funktion wählen, ist seine Abtastrate (und die entsprechende Frequenz, basierend auf der Punktzahl) identisch mit denen beim Abspielen als Modulationsquelle.
  • Wenn die interne Funktion TRIangle, UpRamp oder DnRamp entspricht, ist die maximale Frequenz bei 33500 Series Geräten auf 200 kHz oder bei 33600 Series Geräten auf 800 kHz begrenzt. Wenn die interne Funktion PRBS entspricht, bezieht sich die Frequenz auf die Bitrate und ist begrenzt, wie hier dargestellt.

[SOURce[1|2]:]SUM:INTernal:FUNCtion <function>
[SOURce[1|2]:]SUM:INTernal:FUNCtion?

Wählt das Summiersignal (das dem primären Signal hinzugefügt wird).

Parameter | Typische Rückgabe
{SINusoid|SQUare|RAMP|NRAMp|TRIangle|NOISe|PRBS|ARB}, Standard SINusoid | SIN, SQU, RAMP, NRAM, TRI, NOIS, PRBS oder ARB
Wählen Sie eine Sinuswelle als Summiersignalform für Kanal 2: SOUR2:SUM:INT:FUNC SIN

  • Sie können die Phase zwischen dem primären Signal und dem SUM Signal durch Senden von [SOURce[1|2]:]PHASe:SYNChronize synchronisieren, nachdem Sie die Funktionen für das primäre Signal und das SUM Signal eingestellt haben. Ansonsten ist die Phase zwischen den beiden Signalen arbiträr.

  • Dieser Befehl gilt nur mit der internen Summierquelle (SUM:SOURce INTernal).
  • Sie können SUM nicht mit DC als Träger verwenden.
  • Ein Arbiträrsignal darf nicht gleichzeitig ein Träger- und ein Summiersignal sein.

Folgende Tabelle zeigt, welche Träger und internen Funktionen kombiniert werden können.

Modulationssignal
Träger | Sinus | Rechteck | Sägezahn/Dreieck | Rauschen | PRBS | Arb | Extern
Sinus | • | • | • | • | • | • | •
Rechteck/Puls | • | • | • | • | • | • | •
Sägezahn/Dreieck | • | • | • | • | • | • | •
Gaußsches Rauschen | • | • | • |  | • | • | •
PRBS | • | • | • | • |  | • | •
Arbiträrsignal | • | • | • | • | • |  | •
Arb-Sequenz | • | • | • | • | • |  | •

[SOURce[1|2]:]SUM:SOURce {INTernal|EXTernal|CH1|CH2}
[SOURce[1|2]:]SUM:SOURce?

Wählt die Quelle des Summiersignals.

Parameter | Typische Rückgabe
{INTernal|EXTernal|CH1|CH2}, Standard INTernal | INT, EXT, CH1 oder CH2
Einstellen der Summierquelle auf EXTernal: SUM:SOUR EXT

  • Sie können die Phase zwischen dem primären Signal und dem SUM Signal durch Senden von [SOURce[1|2]:]PHASe:SYNChronize synchronisieren, nachdem Sie die Funktionen für das primäre Signal und das SUM Signal eingestellt haben. Ansonsten ist die Phase zwischen den beiden Signalen arbiträr.

  • SUM:SOURce EXTernal: Das Trägersignal wird mit einem externen Signal summiert. Amplitude und Polarität des Summensignals werden durch den ±5 V Signalpegel am rückseitigen Anschluss Modulation In (optional ±1 V bei 33600 Series Geräten) festgelegt. Wenn Sie beispielsweise die SUM-Amplitude mit dem Befehl SUM:AMPLitude auf 2.0 Vpp setzen und das EXT-Signal auf +5 V steht, beträgt das Sum-Signal 2 Vpp. Wenn das Modulationssignal -5 V beträgt, entspricht das Sum-Signal der vollständigen Amplitude und entgegengesetzten Polarität.

[SOURce[1|2]:]SUM:STATe {ON|1|OFF|0}
[SOURce[1|2]:]SUM:STATe?

Deaktiviert oder aktiviert die SUM-Funktion.

Parameter | Typische Rückgabe
{ON|1|OFF|0}, Standard OFF | 0 (OFF) oder 1 (ON)
SUM aktivieren SUM:STAT ON

  • Sie können die Phase zwischen dem primären Signal und dem SUM Signal durch Senden von [SOURce[1|2]:]PHASe:SYNChronize synchronisieren, nachdem Sie die Funktionen für das primäre Signal und das SUM Signal eingestellt haben. Ansonsten ist die Phase zwischen den beiden Signalen arbiträr.

  • Um mehrfache Signaländerungen zu vermeiden, SUM aktivieren, nachdem Sie die anderen Sum-Parameter konfiguriert haben.
  • Es kann nur jeweils ein Modulationsmodus aktiviert werden.
  • Das Gerät ermöglicht die Sum-Aktivierung nicht, wenn Wobbelung oder Burst aktiviert sind. Bei Aktivierung von SUM werden die Betriebsarten Wobbelung oder Burst deaktiviert.
  • Mit SUM:STATe ON dürfen Sum-Amplitude plus Trägeramplitude weder die programmierten Grenzwerte noch die Ausgangswerte des Geräts überschreiten. Wenn durch die Einstellung SUM:STATe ON die Ausgangs- oder die Grenzwerte überschritten werden, wird SUM:STATe auf OFF gesetzt und das Gerät berichtet einen Einstellungskonflikt-Fehler.


Einführung SWEep Subsystem

SWEep Subsystem Einführung

So wird eine Frequenzwobbelung generiert:

  1. Spezifizieren Sie die Signalform, die Amplitude und den Offset: Verwenden Sie den Befehl APPLy oder die entsprechenden Befehle FUNCtion, FREQuency, VOLTage und VOLTage:OFFSet, um Funktion, Frequenz, Amplitude und Offset auszuwählen. Es sind die Signalformen „Sine“, „Square“, „Ramp“, „Puls“ oder „Arbitrary“ verfügbar (nicht jedoch „PRBS“, „Noise“ und „DC“).
  2. Wählen Sie die Frequenzgrenzen für die Wobbelung: FREQuency:STARt und FREQuency:STOP, oder FREQuency:CENTer und FREQuency:SPAN
  3. Lineare oder logarithmische Betriebsart Wobbelung auswählen: SWEep:SPACing
  4. Wobbelzeit einstellen: SWEep:TIME
  5. Wobbelhalte-/ und -rücklaufzeit einstellen: SWEep:HTIMe und SWEep:RTIMe
  6. Triggerquelle für die Wobbelung auswählen: TRIGger[1|2]:SOURce
  7. Spezifizieren Sie die Markenfrequenz (optional): MARKer:FREQuency
  8. Wobbelung aktivieren: SWEep:STATe ON

Folgender Code generiert das unten abgebildete Signal.

SOURce1:FUNCtion SINE
SOURce1:FREQuency +2,0E+03
SOURce1:FREQuency:STARt +2,0E+03
SOURce1:FREQuency:STOP +6,0E+03
SOURce1:VOLTage +1,0
SOURce1:VOLTage:OFFS +0,0
SOURce1:SWEep:TIME +5,0E-03
TRIGger1:SOURce IMM
SOURce1:FREQuency:MODE SWE
OUTPut1 1

[SOURce[1|2]:]SWEep:HTIMe {<hold_time>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]SWEep:HTIMe? [{MINimum|MAXimum}]

Stellt die Haltezeit (Pause) der Wobbelung bei der Stopfrequenz in Sekunden ein, bevor sie zur Startfrequenz zurückkehrt.

Parameter | Typische Rückgabe
0 bis 3600, Standard 0 | +3,400000000000000E+00
Haltezeit der Wobbelung auf 3,4 Sekunden einstellen: SWE:HTIM 3,4

[SOURce[1|2]:]SWEep:RTIMe {<return_time>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]SWEep:RTIMe? [{MINimum|MAXimum}]

Stellt die Rücklaufzeit der Wobbelung von der Stopfrequenz zur Startfrequenz in Sekunden ein.

Parameter | Typische Rückgabe
0 bis 3600, Standard 0 | +5,600000000000000E+00
Rücklaufzeit der Wobbelung auf 5,6 Sekunden einstellen: SWE:RTIM 5,6
  • Die Rücklaufwobbelung ist stets eine lineare Wobbelung, unabhängig von der Einstellung SWEep:SPACing.

[SOURce[1|2]:]SWEep:SPACing {LINear|LOGarithmic}
[SOURce[1|2]:]SWEep:SPACing?

Dieser Befehl wählt die (lineare oder logarithmische) Wobbelcharakteristik.

Parameter | Typische Rückgabe
{LINear|LOGarithmic}, Standard LIN | LIN oder LOG
Stellt die logarithmische Wobbelcharakteristik ein: SWE:SPAC LIN
  • LINear: Die Ausgangsfrequenz während der Wobbelung variiert linear (von der Start- bis zur Stopfrequenz).
  • LOGarithmic: Die Ausgangsfrequenz während der Wobbelung variiert logarithmisch (von der Start- bis zur Stopfrequenz).

[SOURce[1|2]:]SWEep:STATe {ON|1|OFF|0}
[SOURce[1|2]:]SWEep:STATe?

Aktiviert oder deaktiviert die Wobbelung.

Parameter | Typische Rückgabe
{ON|1|OFF|0}, Standard OFF | 0 (OFF) oder 1 (ON)
Wobbelung aktivieren: SWE:STAT ON

[SOURce[1|2]:]SWEep:TIME {<seconds>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]SWEep:TIME? [{MINimum|MAXimum}]

Stellt die Wobbelzeit (in Sekunden) von der Start- bis zur Stopfrequenz ein.

Parameter | Typische Rückgabe
1 ms bis 250.000 s für die lineare Wobbelung, bis zu 500 s für die logarithmische Wobbelung; Standard: 1 s | +2,500000000000000E+01
Wobbelzeit auf 25 s stellen: SWE:TIME 25
  • Die Anzahl der diskreten Frequenzpunkte einer Wobbelung wird ausgehend von der Wobbelzeit berechnet.
Einführung SWEep Subsystem


Einführung in das Subsystem SYSTem

SYSTem Subsystem

Das Subsystem SYSTem verwaltet das Speichern des Gerätezustands, „Power-down recall“, Fehlerbedingungen, Selbsttest, Frontplatten-Display-Steuerung und die Konfiguration der Remoteschnittstelle.

Hinweis

Das Gerät verwendet den LAN-Anschluss 5024 für SCPI Telnet-Sitzungen und Anschlus 5025 für SCPI Socket-Sitzungen.
  • SYSTem:BEEPer[:IMMediate] - gibt einen Signalton aus
  • SYSTem:BEEPer:STATe {ON|1|OFF|0} - deaktiviert oder aktiviert den Signalton
  • SYSTem:CLICk:STATe - deaktiviert oder aktiviert den Tastaturklick
  • SYSTem:COMMunicate:ENABle {ON|1|OFF|0}, <interface> - deaktiviert oder aktiviert GPIB, USB, LAN-Schnittstelle und Remote-Services
  • SYSTem:COMMunicate:GPIB:ADDRess <address> - legt GPIB-Adresse (IEEE-488) des Geräts fest
  • SYSTem:DATE <yyyy>, <mm>, <dd> - stellt das Datum der Systemuhr ein
  • SYSTem:ERRor? - liest und löscht Fehler aus der Warteschlange
  • SYSTem:LICense:CATalog? - führt installierte Lizenzoptionen auf
  • SYSTem:LICense:DELete "<option_name>" - löscht eine Lizenz
  • SYSTem:LICense:DELete:ALL - löscht alle Lizenzen
  • SYSTem:LICense:DESCription? "<option_name>" - gibt die Beschreibung einer Lizenzoption aus
  • SYSTem:LICense:ERRor? - führt Fehler auf, die bei der Lizenzinstallation entstanden sind
  • SYSTem:LICense:ERRor:COUNt? - gibt die Zahl der Fehler aus, die bei der Lizenzinstallation generiert wurden
  • SYSTem:LICense:INSTall "<file>" - installiert Lizenzen von einer Datei oder einem Ordner
    SYSTem:LICense:INSTall? "<option>" - gibt an, ob eine Lizenz installiert ist
  • SYSTem:LOCK:NAME? - gibt die aktuelle E/A-Schnittstelle aus
  • SYSTem:LOCK:OWNer? - gibt die Schnittstelle aus, die die Sperre hat
  • SYSTem:LOCK:RELease - hebt Sperre auf und verringert Sperrzählung um 1
  • SYSTem:LOCK:REQuest? - fordert die Sperrung der aktuellen Schnittstelle an
  • SYSTem:SECurity:IMMediate - bereinigt den gesamten benutzerzugänglichen Gerätespeicher
  • SYSTem:TIME <hh>, <mm>, <ss> - stellt die Uhrzeit der Systemuhr ein
  • SYSTem:VERSion? - gibt die vom Gerät verwendete SCPI-Version aus

SYSTem:BEEPer[:IMMediate]

Ausgabe eines Signaltons.

Parameter | Typische Rückgabe
(keine) | (keine)
Ausgabe eines Signaltons: SYST:BEEP
  • Das Senden eines programmierten Signaltons kann bei der Programmentwicklung und Fehlerbehebung nützlich sein.
  • Dieser Befehl überschreibt den aktuellen Signaltonstatus (SYSTem:BEEPer:STATe ). Dies bedeutet, dass Sie auch dann einen Signalton ausgeben können, wenn der Signaltongeber ausgeschaltet ist.

SYSTem:BEEPer:STATe {ON|1|OFF|0}
SYSTem:BEEPer:STATe?

Aktiviert oder deaktiviert den Signalton, der ausgegeben wird, wenn an der Frontplatte oder der Remoteschnittstelle ein Fehler generiert wird.

Parameter | Typische Rückgabe
{ON|1|OFF|0}, Standard ON | 0 (OFF) oder 1 (ON)
Signaltonstatus deaktivieren: SYST:BEEP:STAT OFF
  • Durch Ausschalten des Signaltons wird der Tastenklick an der Frontplatte nicht deaktiviert.
  • Ein Signalton ertönt immer (selbst wenn der Signaltonstatus auf OFF steht), wenn ein SYSTem:BEEPer gesendet wird.
  • Die Einstellung ist permanent; sie bleibt bei einem Aus- und Wiedereinschalten des Geräts oder einem *RST erhalten.

SYSTem:CLICk:STATe {ON|1|OFF|0}
SYSTem:CLICk:STATe?

Deaktiviert oder aktiviert den Klick, der ertönt, wenn eine Frontplattentaste oder ein Softkey gedrückt wird.

Parameter | Typische Rückgabe
{ON|1|OFF|0}, Standard ON | 0 (OFF) oder 1 (ON)
Tastaturklick deaktivieren: SYST:CLIC:STAT OFF
  • Dieser Befehl bezieht sich nicht auf den Signalton, der Fehler meldet.
  • Die Einstellung ist permanent; sie bleibt bei einem Aus- und Wiedereinschalten oder einem Zurücksetzen auf die Werkseinstellungen (*RST) erhalten.

SYSTem:COMMunicate:ENABle {ON|1|OFF|0}, <interface>
SYSTem:COMMunicate:ENABle? <interface>

Aktiviert oder deaktiviert GPIB, USB oder LAN-Remoteschnittstelle. Aktiviert oder deaktiviert zudem verfügbare Remote-Services wie Sockets, Telnet, VXI11 und die integrierte Web-Schnittstelle.

Parameter | Typische Rückgabe
{ON|1|OFF|0}, Standard ON für alle Schnittstellen | 0 (OFF) oder 1 (ON)
{GPIB|USB|LAN|SOCKets|TELNet|VXI11|WEB}
Deaktivieren der USB-Schnittstelle: SYST:COMM:ENAB OFF,USB Setzt den Status der USB-Schnittstelle zurück: SYST:COMM:ENAB? USB

Hinweis

Wenn Sie eine Schnittstelle oder einen LAN-Service de- oder reaktivieren, müssen Sie das Gerät aus- und einschalten, um die neue Einstellung zu aktivieren.
  • Wenn Sie die LAN-Schnittstelle deaktivieren, werden beim Einschalten des Geräts nicht alle dazugehörigen LAN-Dienste gestartet.
  • Die Einstellung ist permanent; sie bleibt bei einem Aus- und Wiedereinschalten des Geräts oder einem *RST erhalten.
  • SYSTem:SECurity:IMMediate aktiviert alle Schnittstellen.

SYSTem:COMMunicate:GPIB:ADDRess <address>
SYSTem:COMMunicate:GPIB:ADDRess?

Legt die GPIB-Adresse (IEEE-488) des Geräts fest, die beim Einschalten des Geräts angezeigt wird. Jedem der an die GPIB-Schnittstelle angeschlossenen Geräte muss eine eindeutige Adresse zugeordnet werden.

Parameter | Typische Rückgabe
0 bis 30, Standard 10 | +15
GPIB-Adresse auf 15 setzen: SYST:COMM:GPIB:ADDR 15
  • Die Adresse der GPIB-Schnittstelle Ihres Computers darf mit keinem der Geräte am Schnittstellenbus in Konflikt geraten.
  • Die Einstellung ist permanent; sie bleibt bei einem Aus- und Wiedereinschalten des Geräts oder einem *RST erhalten.
  • SYSTem:SECurity:IMMediate setzt die GPIB-Adresse auf 10.
  • Sie müssen das Gerät aus- und einschalten, damit der Befehl wirksam wird.

SYSTem:DATE <yyyy>, <mm>, <dd>
SYSTem:DATE?

Stellt das Datum der Systemuhr ein.

Parameter | Typische Rückgabe
<yyyy> 2000 bis 2100 <mm> 1 bis 12 <dd> 1 bis 31 | +2011,+7,+26
Einstellung des Systemdatums auf den 26. Juli 2011: SYST:DAT 2011,7,26

SYSTem:ERRor?

Liest und löscht einen Fehler aus der Warteschlange.

Parameter | Typische Rückgabe
(keine) | -113,"Undefined header"
Lesen und Löschen des ersten Fehlers aus der Fehlerwarteschlange: SYST:ERR?
  • Es können in jedem schnittstellenspezifischen Error-Queue des Gerätes bis zu 20 Befehlssyntax- oder Hardware-Fehlermeldungen gespeichert werden (jeweils eine für GPIB, USB, VXI-11 und Telnet/Sockets.)
  • Die Fehlerabfrage erfolgt gemäß dem Prinzip First In - First Out (FIFO), Fehler werden beim Lesen gelöscht. Das Gerät gibt bei jeder Fehlergenerierung einen Signalton ab (außer diese Option ist mit dem Befehl SYSTem:BEEPer:STATe OFF deaktiviert).
  • Bei über 20 Fehlern wird der letzte Fehler in der Warteschlange (der zuletzt aufgetretene Fehler) durch -350 ("Error queue overflow") ersetzt. Wenn Sie keine Fehler aus der Warteschlange entfernen, werden keine weiteren Fehler gespeichert. Enthält die Fehlerwarteschlange beim Auslesen keine Fehlermeldungen, erfolgt die Meldung +0, „No error“.
  • Die Fehlerwarteschlange wird durch den *CLS gelöscht, und wenn das Gerät aus- und angeschaltet wird. Sie wird nicht durch *RST gelöscht.
  • Fehlermeldungen haben folgendes Format (der Fehlerstring kann bis zu 255 Zeichen enthalten).

    <error code>,<error string>

    Wobei:

    <error code> = ein dreistelliger Code, dem manchmal ein Gedankenstrich vorausgeht

    <error string> = ein ASCII-String in Anführungszeichen mit bis zu 255 Zeichen

Lizenzoptionen

Folgende Befehle sind an Lizenzoptionen gebunden. Die Lizenzoptionen sind unten aufgeführt.

Optionscode | Beschreibung
ARB | Arbiträrsignale
BW30 | Erhöhung der Bandbreite auf 30 MHz (33500 Series)
BW120 | Erhöhung der Bandbreite auf 120 MHz (33600 Series)
IQP | IQ-Player (nur bei Zweikanalgeräten)
MEM | 16 MSa Arb Speicher (33500 Series) oder 64 MSa Arb Speicher (33600 Series)
SEC | NISPOM & Datensicherheit aktivieren

SYSTem:LICense:CATalog?

Gibt eine kommagetrennte Liste installierter Lizenzoptionen zurück.

Parameter | Typische Rückgabe
(keine) | "SEC","IQP","MEM"
Aktuelle Lizenzoptionen zurückgeben: SYST:LIC:CAT?
  • Nur diejenigen installierten Optionen, die eine Lizenz erfordern, werden zurückgegeben.

SYSTem:LICense:DELete "<option_name>"

Löscht eine Lizenz.

Lassen Sie Vorsicht walten, bevor Sie diesen Befehl ausführen. Ein Löschen der Lizenz kann nur rückgängig gemacht werden, indem die Lizenz neu installiert wird.

Parameter | Typische Rückgabe
{ARB|BW30|BW120|IQP|MEM|SEC} | (keine)
Lizenz für IQ-Player löschen: SYST:LIC:DEL "IQP"
  • Gültige Optionsnamen sind Strings in doppelten Anführungszeichen, die die installierten Lizenzoptionen darstellen. Sie können über SYSTem:LICense:CATalog? ganz einfach identifiziert werden.

SYSTem:LICense:DELete:ALL

Löscht alle Lizenzen.

Lassen Sie Vorsicht walten, bevor Sie diesen Befehl ausführen. Ein Löschen der Lizenz kann nur rückgängig gemacht werden, indem die Lizenz neu installiert wird.

Parameter | Typische Rückgabe
(keine) | (keine)
Alle Lizenzen löschen: SYST:LIC:DEL:ALL

SYSTem:LICense:DESCription? "<option_name>"

Gibt eine Beschreibung einer festgelegten Option zurück, unabhängig davon, ob sie im Moment lizenziert ist.

Parameter | Typische Rückgabe
Siehe Liste der Lizenzoptionen | "Extended Memory Option: 16 MSa/channel waveform memory"
Ausgabe der Beschreibung für Option 002: SYST:LIC:DESC? "MEM"
  • Optionsnamen sind Strings in Anführungszeichen, die Optionen darstellen, die lizenziert werden können. Installierte lizenzierte Elemente können mit SYSTem:LICense:CATalog? identifiziert werden.

SYSTem:LICense:ERRor?

Gibt einen String aller Fehlermeldungen aus, die von SYSTem:LICense:INSTall generiert werden.

Parameter | Typische Rückgabe
(keine) | #279File: MyFile.lic<CR><LF>[Ignored - The license file is not formatted correctly.]<CR><LF>
Ausgabe des Lizenzinstallations-Fehlerstrings: SYST:LIC:ERR?
  • Der String kann bis zu 2096 Zeichen umfassen.
  • Gibt einen Block bestimmter Länge aus, der einen vielzeiligen ASCII-Text mit Wagenrückläufen und Zeilenumbrüchen enthält.

SYSTem:LICense:ERRor:COUNt?

Gibt die Zahl der Lizenzfehler aus, die von SYSTem:LICense:INSTall generiert werden.

Parameter | Typische Rückgabe
(keine) | +0
Anzahl von Lizenzfehlern zurückgeben: SYST:LIC:ERR:COUN?

SYSTem:LICense:INSTall "<file>"
SYSTem:LICense:INSTall? "<option>"

Dieser Befehl installiert alle Lizenzen von einer bestimmten Datei oder von allen Lizenzdateien im angegebenen Ordner. Sie fragen die Rückgaben 0 oder 1 ab, um anzugeben, ob die spezifizierte Lizenz installiert ist.

Parameter Typische Rückgabe

<folder> kann jeden beliebigen gültigen Ordnernamen haben. Standard ist das Stammverzeichnis eines USB Speichergeräts an der Frontplatte.
<file> kann einen beliebigen gültigen Dateinamen haben
<option> ist eine der Lizenzoptionen

0 (Lizenz nicht installiert) oder 1 (Lizenz installiert)
Lizenzen von einer Datei installieren:
SYST:LIC:INSTALL "USB:\33522B_LICENSE071.lic"
  • Lizenzdateien müssen eine ".lic"-Dateierweitung aufweisen.
  • Das Format für <file> ist "[<drive>:<path>]<file_name>", wobei <drive> INTernal oder USB sein kann und <Pfad> ein absoluter Ordnerpfad sein muss.
  • INTernal gibt das interne Flash-Dateisystem an. USB gibt ein USB-Speichergerät an der Frontplatte an.
  • Falls <drive>:<path> ausgelassen wurde, wird der durch den Befehl MMEMory:CDIRectory angegebene Ordner verwendet.
  • Absolute Pfade beginnen mit "\" oder "/" und beginnen am Stammordner von <drive>.
  • Ordner- und Dateinamen dürfen folgende Zeichen nicht enthalten: \ / : * ? " < > |
  • Die Kombination aus Ordner- und Dateiname darf 240 Zeichen nicht überschreiten.
  • Der angegebene Ordner muss existieren und kann nicht als als verborgene Datei oder Systemdatei markiert werden.

SYSTem:LOCK:NAME?

Gibt die aktuelle E/A-Schnittstelle zurück (die E/A-Schnittstelle, die beim abfragenden Computer verwendet wird).

Parameter | Typische Rückgabe
(keine) | "LAN169.254.149.35"
Siehe Beispiele für Schnittstellensperrung
  • Bestimmen Sie nach Verwendung dieses Befehls zum Festlegen des Namens der verwendeten Schnittstelle den Befehl SYSTem:LOCK:OWNer?, um zu bestimmen, welche Schnittstelle ggf. die Sperre aufweist.
  • Gibt "USB", "VXI11", "GPIB" oder "LAN<IP-Adresse>" zurück und bestimmt damit die E/A-Schnittstelle, die vom abfragenden Computer verwendet wird.

SYSTem:LOCK:OWNer?

Gibt die E/A-Schnittstelle aus, die derzeit eine Sperre aufweist.

Parameter | Typische Rückgabe
(keine) | "LAN169.254.149.35"
Siehe Beispiele für Schnittstellensperrung
  • Wenn eine Sperrung aktiv ist, wird Bit 10 im Standard Operation Register eingestellt (STATus:OPERation:CONDition?). Wenn die Sperrung für alle E/A-Schnittstellen aufgehoben wird, wird dieses Bit zurückgesetzt.
  • Gibt "USB", "VXI11", "GPIB" oder "LAN <IP-Adresse>" zurück und bestimmt damit die E/A-Schnittstelle, die gerade eine Sperre aufweist. Wenn keine Schnittstelle eine Sperre aufweist, wird "NONE" ausgegeben.

SYSTem:LOCK:RELease

Verringert die Sperrzählung um 1 und kann die E/A-Schnittstelle freigeben, von der der Befehl ausgeführt wird.

Parameter | Typische Rückgabe
(keine) | (keine)
Siehe Beispiele für Schnittstellensperrung
  • Wenn eine Sperrung aktiv ist, wird Bit 10 im Standard Operation Register eingestellt (STATus:OPERation:CONDition?). Wenn die Sperrung für alle E/A-Schnittstellen aufgehoben wird, wird dieses Bit zurückgesetzt.

SYSTem:LOCK:REQuest?

Fordert eine Sperre der aktuellen E/A-Schnittstelle an. Dies ermöglicht Ihnen, die Gerätekonfiguration zu sperren oder das Gerät mit anderen Computern gemeinsam zu nutzen.

Parameter | Typische Rückgabe
(keine) | 0 (verweigert) oder 1 (erlaubt)
Siehe Beispiele für Schnittstellensperrung
  • Sperranforderungen können verschachtelt werden; jede Anforderung erhöht die Sperrzählung um 1. Für jede Anforderung benötigen Sie eine Freigabe (SYSTem:LOCK:RELease) von dergleichen E/A-Schnittstelle.
  • Sperren werden auf der E/A-Schnittstellenebene (USB, LAN, etc.) behandelt und Sie sind für jede Koordinierung zwischen Threads und/oder Programmen auf dieser Schnittstelle verantwortlich.
  • Wenn eine Anforderung bewilligt wird, sind nur E/A-Sitzungen von der vorliegenden Schnittstelle berechtigt, den Gerätestatus zu ändern. Sie können den Gerätestatus über andere E/A-Schnittstellen abfragen.
  • LAN-Sitzungssperren werden automatisch aufgehoben, wenn eine getrennte LAN-Verbindung festgestellt wird.
  • Die Bewilligung einer Sperre legt Bit 10 im Register "Standard Operation" (STATus:OPERation:CONDition?) fest.

Beispiele für Schnittstellensperrung

Folgende Befehlsliste erläutert die Benutzung.

Initial State = unlocked, Count = 0

<FROM USB> SYST:LOCK:REQ? returns 1 (request successful)

State = locked, Count = 1

<FROM LAN> SYST:LOCK:REQ? returns 0 because USB has lock

State = locked, Count = 1

<FROM USB> SYST:LOCK:REQ? returns 1 (request successful)

State = locked, Count = 2

<FROM USB> SYST:LOCK:REL

State = locked, Count = 1

<FROM USB> SYST:LOCK:REL

State = unlocked, Count = 0

Beachten Sie, dass für jede erfolgreiche Sperranforderung eine Sperrfreigabe erforderlich ist. Für zwei Anforderungen sind zwei Freigaben erforderlich.

SYSTem:SECurity:IMMediate

Bereinigt den gesamten benutzerzugänglichen Gerätespeicher. Dieser Befehl entspricht den Anforderungen in Kapitel 8 des Handbuchs National Instrument Security Program Operating Manual (NISPOM).

Parameter | Typische Rückgabe
(keine) | (keine)
Gesamten benutzerzugänglichen Gerätespeicher bereinigen: SYST:SEC:IMM

Vorsicht

Dieser Befehl wird z. B. für Kunden empfohlen, die im militärischen Bereich tätig sind und das NISPOM einhalten müssen. Ein übermäßiger Gebrauch dieses Befehls kann zu einem vorzeitigen Defekt des Flash-Speichers führen.

Mit diesem Befehl werden alle benutzerdefinierten Statusdaten, benutzerdefinierten Arbiträrsignale und I/O-Einstellungen wie die IP-Adresse gelöscht.
  • Wird in der Regel benutzt, bevor ein Gerät von einem gesicherten Arbeitsbereich entfernt wird.
  • Das Gerät wird komplett auf die Werkseinstellungen (*RST) zurückgesetzt.

SYSTem:TIME <hh>, <mm>, <ss>
SYSTem:TIME?

Stellt die Uhrzeit der Systemuhr ein.

Parameter | Typische Rückgabe
<hh> 0 bis 23 <mm> 0 bis 59 <ss> 0 bis 60 | 20,15,30.000
Uhrzeit des Systems auf 20:15:30 (8:15:30 PM) stellen SYST:TIM 20,15,30
  • Diese Zeit wird für Daten-Zeitstempel im Massenspeichersystem (MMEMory) verwendet.

SYSTem:VERSion?

Gibt Version der SCPI (Standard Commands for Programmable Instruments) aus, denen das Gerät entspricht. Kann nicht von der Frontplatte aus festgelegt werden.

Parameter | Typische Rückgabe
(keine) | 1994.0
Ausgabe der SCPI-Version: SYST:VERS?


LAN-Konfiguration

Konfiguriert das Gerät für den Fernbetrieb über das lokale Netzwerk (LAN).

Hinweis

Das Gerät verwendet den LAN-Anschluss 5024 für SCPI Telnet-Sitzungen und Anschlus 5025 für SCPI Socket-Sitzungen.

Angaben zur Punktnotation

Adressen in Punktnotation ("nnn.nnn.nnn.nnn", wobei "nnn" einem Byte-Wert von 0 bis 255 entspricht) müssen sorgfältig angegeben werden, da die meisten PC-Web-Softwares Byte-Werte, die mit Nullen beginnen, als Zahlen im Oktalformat (mit Basis 8) interpretieren. So entspricht z. B. "192.168.020.011" tatsächlich dem Dezimalwert "192.168.16.9", da ".020" als "16" im Oktalformat interpretiert wird, und ".011" als "9". Um Missverständnisse auszuschließen, empfiehlt es sich, ausschließlich Dezimalwerte (von 0 bis 255) ohne führende Nullen zu verwenden.

SYSTem:COMMunicate:LAN:CONTrol?

Liest die Initial-Portnummer der Steuerungsverbindung für die Socket-Kommunikation ab. Diese Verbindung wird zum Senden und Empfangen von Befehlen und Abfragen verwendet.

Parameter | Typische Rückgabe
(keine) | 5000 (0 wenn die Schnittstelle Sockets nicht unterstützt)
Portnummer der Steuerungsverbindung ausgeben: SYST:COMM:LAN:CONT?

  • Verbindung zum Steuerungssocket verwenden, um einen „Device Clear“-Befehl an das Gerät zu senden oder um anstehende Serviceanfrageereignisse (SRQ) zu erkennen. Der „Device Clear“-Befehl lautet „DCL“.

SYSTem:COMMunicate:LAN:DHCP {ON|1|OFF|0}
SYSTem:COMMunicate:LAN:DHCP?

Deaktiviert oder aktiviert die Verwendung von DHCP am Gerät. Das Akronym DHCP steht steht für Dynamic Host Configuration Protocol, ein Protokoll für die Zuordnung dynamischer IP-Adressen zu Netzwerkgeräten. Bei der dynamischen Adressierung kann ein Gerät bei jeder Verbindung mit dem Netzwerk über eine andere IP-Adresse verfügen.

ON: Gerät versucht, eine IP-Adresse von einem DHCP-Server abzurufen. Wird ein DHCP-Server gefunden, weist dieser dem Gerät eine dynamische IP-Adresse, eine Subnetzmaske und ein Standard-Gateway zu.

OFF oder DHCP nicht verfügbar: Das Gerät verwendet die statische IP-Adresse, eine Subnetzmaske und ein Standard-Gateway, während es eingeschaltet ist.

Hinweis

Wenn Sie diese Einstellung ändern, müssen Sie den Befehl SYSTem:COMMunicate:LAN:UPDate senden, um die neue Einstellung zu aktivieren.

Parameter | Typische Rückgabe
{ON|1|OFF|0}, Standard ON | 0 (OFF) oder 1 (ON)
DHCP deaktivieren: SYST:COMM:LAN:DHCP OFF SYST:COMM:LAN:UPDate
  • Die meisten lokalen Firmennetzwerke besitzen einen DHCP-Server.
  • Wird die DHCP LAN-Adresse nicht durch den DHCP-Server zugewiesen, wird nach etwa zwei Minuten die statische IP-Adresse vorausgesetzt.
  • Die Einstellung ist permanent; sie bleibt bei einem Aus- und Wiedereinschalten des Geräts oder einem *RST erhalten.
  • Aktiviert, wenn das Gerät ab Werk ausgeliefert wird oder nach SYSTem:SECurity:IMMediate.

SYSTem:COMMunicate:LAN:DNS[1|2] "<address>"
SYSTem:COMMunicate:LAN:DNS[1|2]? [{CURRent|STATic}]

Ordnet statische IP-Adressen der Domain Name System (DNS)-Server zu. Es können eine primäre und eine sekundäre Server-Adresse zugewiesen werden. Näheres erfahren Sie von Ihrem Netzwerkadministrator. Ist DHCP verfügbar und aktiviert, weist DHCP automatisch die DNS-Serveradresse zu. Diese automatisch zugewiesene DNS-Serveradresse hat Vorrang vor der mit diesem Befehl zugewiesenen statischen DNS-Adresse.

Hinweis

Wenn Sie diese Einstellung ändern, müssen Sie den Befehl SYSTem:COMMunicate:LAN:UPDate senden, um die neue Einstellung zu aktivieren.

Parameter | Typische Rückgabe
Befehl: "nnn.nnn.nnn.nnn", Standard "0.0.0.0" Abfrage: {CURRent|STATic}, Standard CURRent | "198.105.232.4"
Eine statische primäre DNS-Adresse einstellen: SYST:COMM:LAN:DNS "198.105.232.4" SYST:COMM:LAN:UPD
  • CURRent: Lesen der Adresse, die derzeit vom Gerät verwendet wird.
  • STATic: Statische Adresse aus dem nicht-flüchtigen Speicher ablesen. Diese Adresse wird verwendet, wenn DHCP deaktiviert wurde oder nicht verfügbar ist.
  • Die Einstellung ist permanent; sie bleibt bei einem Aus- und Wiedereinschalten des Geräts oder einem *RST erhalten.
  • Einstellen auf "0.0.0.0" über SYSTem:SECurity:IMMediate.

SYSTem:COMMunicate:LAN:DOMain?

Gibt den Domänennamen des LAN aus, an das das Gerät angeschlossen ist.

Parameter | Typische Rückgabe
(keine) | "example.com"
Vom Gerät verwendeten Domain-Namen zurückgeben: SYST:COMM:LAN:DOM?
  • Ist das Dynamic Domain Name System (DNS) auf Ihrem Netzwerk verfügbar und benutzt Ihr Gerät DHCP, so wird der Domänenname beim Einschalten mit dem Dynamic DNS-Service registriert.
  • Ein leerer String ("") zeigt an, dass kein Domänenname zugewiesen wurde.

SYSTem:COMMunicate:LAN:GATeway "<address>"
SYSTem:COMMunicate:LAN:GATeway? [{CURRent|STATic}]

Weist dem Gerät einen Standard-Gateway zu. Die angegebene IP-Adresse setzt den Standard-Gateway, über den das Gerät mit Systemen kommunizieren kann, die sich nicht im lokalen Netzwerk befinden. Folglich ist dies der Standard-Gateway, an den Pakete gesendet werden, die an ein Gerät gehen, das sich nicht im lokalen Subnetz befindet. Wird über die Einstellungen der Subnetzmaske festgelegt. Ist DHCP aktiviert (SYSTem:COMMunicate:LAN:DHCP ), wird der angegebene Standard-Gateway nicht genutzt. Kann der DHCP-Server jedoch keine gültige IP-Adresse zuweisen, wird der aktuell konfigurierte Standard-Gateway verwendet. Näheres erfahren Sie von Ihrem Netzwerkadministrator.

Hinweis

Wenn Sie diese Einstellung ändern, müssen Sie den Befehl SYSTem:COMMunicate:LAN:UPDate senden, um die neue Einstellung zu aktivieren.

Parameter | Typische Rückgabe
Befehl: "nnn.nnn.nnn.nnn", Standard "0.0.0.0" Abfrage: {CURRent|STATic}, Standard CURRent | "198.105.232.1"
Eine Standard-Gateway-Adresse einstellen: SYST:COMM:LAN:GATEWAY "198.105.232.1" SYST:COMM:LAN:UPD
  • CURRent: Lesen der Adresse, die derzeit vom Gerät verwendet wird.
  • STATic: Statische Adresse aus dem nicht-flüchtigen Speicher ablesen. Diese Adresse wird verwendet, wenn DHCP deaktiviert wurde oder nicht verfügbar ist.
  • Einstellen auf "0.0.0.0", wenn das Gerät ab Werk ausgeliefert wird oder nach SYSTem:SECurity:IMMediate.

SYSTem:COMMunicate:LAN:HOSTname "<name>"
SYSTem:COMMunicate:LAN:HOSTname? [{CURRent|STATic}]

Weist dem Gerät einen Hostnamen zu. Beim Hostnamen handelt es sich um den Host-Anteil des Domain-Namens, der anschließend in eine IP-Adresse übersetzt wird. Ist das Dynamic Domain Name System (DNS) auf Ihrem Netzwerk verfügbar und benutzt Ihr Gerät DHCP, so wird der Hostname beim Einschalten mit dem Dynamic DNS-Service registriert. Ist DHCP aktiviert (SYSTem:COMMunicate:LAN:DHCP ), kann der DHCP-Server den angegebenen Hostnamen ändern.

Hinweis

Wenn Sie diese Einstellung ändern, müssen Sie den Befehl SYSTem:COMMunicate:LAN:UPDate senden, um die neue Einstellung zu aktivieren.

Parameter | Typische Rückgabe
String mit bis zu 15 Zeichen. Muss mit einem Buchstaben (A-Z) beginnen Kann Buchstaben, Ziffern (0-9) und Bindestriche ("-") enthalten | "LAB1-33522A"
Hostnamen definieren: SYST:COMM:LAN:HOST "LAB1" SYST:COMM:LAN:UPD
  • Einstellen auf "A-33521A-nnnnn" oder "A-33522A-nnnnn", wobei nnnnn die letzten fünf Ziffern der Seriennummer des Geräts sind, wenn das Gerät ab Werk ausgeliefert wird oder nach SYSTem:SECurity:IMMediate.
  • Besteht kein Hostname, wird ein leerer String ( "" ) zurückgegeben.

SYSTem:COMMunicate:LAN:IPADdress "<address>"
SYSTem:COMMunicate:LAN:IPADdress? [{CURRent|STATic}]

Weist dem Gerät eine statische Internet Protocol (IP)-Adresse zu. Ist DHCP aktiviert (SYSTem:COMMunicate:LAN:DHCP ), wird die angegebene IP-Adresse nicht genutzt. Näheres erfahren Sie von Ihrem Netzwerkadministrator.

Hinweis

Wenn Sie diese Einstellung ändern, müssen Sie den Befehl SYSTem:COMMunicate:LAN:UPDate senden, um die neue Einstellung zu aktivieren.

Parameter | Typische Rückgabe
Befehl: "nnn.nnn.nnn.nnn", Standard "0.0.0.0" Abfrage: {CURRent|STATic}, Standard CURRent | "169.254.149.35"
Statische IP-Adresse einstellen: SYST:COMM:LAN:IPAD "169.254.149.35" SYST:COMM:LAN:UPD
  • CURRent: Lesen der Adresse, die derzeit vom Gerät verwendet wird.
  • STATic: Statische Adresse aus dem nicht-flüchtigen Speicher ablesen. Diese Adresse wird verwendet, wenn DHCP deaktiviert wurde oder nicht verfügbar ist.
  • Die Einstellung ist permanent; sie bleibt bei einem Aus- und Wiedereinschalten des Geräts oder einem *RST erhalten.
  • Einstellen auf "169.254.5.21", wenn das Gerät ab Werk ausgeliefert wird oder nach SYSTem:SECurity:IMMediate.

SYSTem:COMMunicate:LAN:MAC?

Liest die MAC-Adresse (Media Access Control) des Geräts.

Hinweis

Ihr LAN-Administrator benötigt ggf. die MAC-Adresse, um diesem Gerät eine statische IP-Adresse zuzuweisen.

Parameter | Typische Rückgabe
(keine) | "0030D3001041"
MAC-Adresse zurückgeben: SYST:COMM:LAN:MAC?
  • Die MAC-Adresse ist auch bekannt unter dem Namen Link-Layer-Adresse, Ethernetadresse (Stationsadresse), LANIC ID oder Hardware-Adresse. Die 48-Bit-Adresse ist unveränderlich und wird vom Hersteller jedem einzelnen Internetgerät zugewiesen.
  • Die MAC-Adresse für das Gerät wird werkseitig eingestellt und kann nicht geändert werden.
  • Die Einstellung ist permanent; sie bleibt bei einem Aus- und Wiedereinschalten des Geräts oder einem *RST erhalten.

SYSTem:COMMunicate:LAN:SMASk "<mask>"
SYSTem:COMMunicate:LAN:SMASk? [{CURRent|STATic}]

Weist dem Gerät eine Subnetzmaske zu. Das Gerät verwendet die Subnetzmaske, um festzustellen, ob die IP-Adresse eines Clients sich in demselben lokalen Subnetz befindet. Wenn die IP-Adresse eines Clients sich in einem anderen Subnetz befindet, müssen alle Pakete an den Standard-Gateway gesendet werden. Näheres erfahren Sie von Ihrem Netzwerkadministrator.

Hinweis

Wenn Sie diese Einstellung ändern, müssen Sie den Befehl SYSTem:COMMunicate:LAN:UPDate senden, um die neue Einstellung zu aktivieren.

Parameter | Typische Rückgabe
Befehl: "nnn.nnn.nnn.nnn", Standard "0.0.0.0" Abfrage: {CURRent|STATic}, Standard CURRent | "255.255.0.0"
Richten Sie die Subnet Mask ein: SYST:COMM:LAN:SMAS "255.255.255.0" SYST:COMM:LAN:UPD
  • Ist DHCP aktiviert (SYSTem:COMMunicate:LAN:DHCP ), wird die angegebene Subnetzmaske nicht genutzt. Kann der DHCP-Server jedoch keine gültige IP-Adresse zuweisen, verwendet das Gerät die Subnetzmaske AutoIP.
  • Ein Wert von "0.0.0.0" oder "255.255.255.255" zeigt an, dass das Netzwerk nicht in Subnetze unterteilt ist.
  • Die Einstellung ist permanent; sie bleibt bei einem Aus- und Wiedereinschalten des Geräts oder einem *RST erhalten.
  • Werkseitig bei der Auslieferung oder nach dem Befehl SYSTem:SECurity:IMMediate ist die Subnetzmaske eingestellt auf "255.255.0.0".
  • CURRent: Lesen der Adresse, die derzeit vom Gerät verwendet wird.
  • STATic: Statische Adresse aus dem nicht-flüchtigen Speicher ablesen. Diese Adresse wird verwendet, wenn DHCP deaktiviert wurde oder nicht verfügbar ist.

SYSTem:COMMunicate:LAN:TELNet:PROMpt "<string>"
SYSTem:COMMunicate:LAN:TELNet:PROMpt?

Setzt diese Befehlsanzeige bei der Kommunikation mit dem Gerät über Telnet.

Parameter | Typische Rückgabe
String mit bis zu 15 Zeichen | "Befehl>"
Befehlsanzeige einstellen: SYST:COMM:LAN:TELN:PROM "Command>"
  • Eine Telnet-Sitzung wird normalerweise von der Shell eines Host-Computers aus gestartet:

    telnet <IP_address> <port>

    Zum Beispiel: telnet 169.254.4.10 5024

    Um eine Telnet-Sitzung zu beenden, drücken Sie auf <Ctrl-D>.
  • Die Einstellung ist permanent; sie bleibt bei einem Aus- und Wiedereinschalten des Geräts oder einem *RST erhalten.
  • Dies ist auf "33521A> " (Modell 33521A), auf "33522A> " (Modell 33522A), auf "33500> " (andere 33500 Series Modelle), oder auf "33600> " (33600 Series Modelle) eingestellt, wenn das Gerät ab Werk ausgeliefert wird oder nach SYSTem:SECurity:IMMediate.

SYSTem:COMMunicate:LAN:TELNet:WMESsage "<string>"
SYSTem:COMMunicate:LAN:TELNet:WMESsage?

Legt die Begrüßungsnachricht fest, wenn eine Telnet-Sitzung für die Kommunikation mit dem Gerät verwendet wird.

Parameter | Typische Rückgabe
String mit bis zu 63 Zeichen | "Welcome to the Telnet Session"
Begrüßungsnachricht definieren: SYST:COMM:LAN:TELN:WMES "Welcome to the Telnet Session"
  • Die Einstellung ist permanent; sie bleibt bei einem Aus- und Wiedereinschalten des Geräts oder einem *RST erhalten.
  • Diese ist auf "Welcome to Keysight's 33521A Wellenformgenerator" (Modell 33521A), auf "Welcome to Keysight's 33522A Wellenformgenerator" (Modell 33522A), auf "Welcome to Keysight's 33500-Series Wellenformgenerator" (andere 33500 Series Modelle), oder auf "Welcome to Keysight's 33600-Series Wellenformgenerator" (33600 Series Modelle) eingestellt, wenn das Gerät ab Werk ausgeliefert wird oder nach SYSTem:SECurity:IMMediate.

SYSTem:COMMunicate:LAN:UPDate

Speichert alle Änderungen der LAN-Einstellungen im permanenten Speicher und startet das LAN mit den neuen Einstellungen neu.

Parameter | Typische Rückgabe
(keine) | (keine)
(siehe unten)
  • Dieser Befehl muss nach der Änderung der Einstellungen für DHCP, DNS, Gateway, Hostname, IP-Adresse, Subnetzmaske, WINS gesendet werden.
  • Alle Änderungen an den LAN-Einstellungen vornehmen, bevor dieser Befehl gesendet wird.

Beispiel

Das folgende Beispiel konfiguriert das Gerät für die Verwendung der statisch zugewiesenen LAN-Einstellungen.

SYST:COMM:LAN:DHCP OFF
SYST:COMM:LAN:DNS "198.105.232.4"
SYST:COMM:LAN:DNS2 "198.105.232.5"
SYST:COMM:LAN:GATEWAY "198.105.232.1"
SYST:COMM:LAN:HOST "LAB1-33522A"
SYST:COMM:LAN:IPAD "198.105.232.101"
SYST:COMM:LAN:SMAS "255.255.255.0"
SYST:COMM:LAN:WINS "198.105.232.4"
SYST:COMM:LAN:WINS "198.105.232.5"
SYST:COMM:LAN:UPD

Das folgende Beispiel konfiguriert das Gerät zurück für die Verwendung von DHCP.

SYST:COMM:LAN:DHCP ON
SYST:COMM:LAN:UPD

SYSTem:COMMunicate:LAN:WINS[1|2] "<address>"
SYSTem:COMMunicate:LAN:WINS[1|2]? [{CURRent|STATic}]

Weist die statischen IP-Adressen der Windows Internet Name System (WINS) Server zu. Es können eine primäre und eine sekundäre Server-Adresse zugewiesen werden. Näheres erfahren Sie von Ihrem Netzwerkadministrator. Ist DHCP verfügbar und aktiviert, weist DHCP automatisch die WINS-Serveradressen zu. Diese automatisch zugewiesenen WINS-Serveradressen haben Vorrang vor der mit diesem Befehl zugewiesenen statischen WINS-Adressen.

Hinweis

Wenn Sie diese Einstellung ändern, müssen Sie den Befehl SYSTem:COMMunicate:LAN:UPDate senden, um die neue Einstellung zu aktivieren.

Parameter | Typische Rückgabe
Befehl: "nnn.nnn.nnn.nnn", Standard "0.0.0.0" Abfrage: {CURRent|STATic}, Standard CURRent | "198.105.232.4"
Eine statische primäre WINS-Adresse einstellen: SYST:COMM:LAN:WINS "198.105.232.4" SYST:COMM:LAN:UPD
  • Die zugewiesenen WINS-Adressen werden verwendet, wenn DHCP deaktiviert oder nicht verfügbar ist. Andernfalls werden die WINS-Serveradressen von DHCP automatisch zugewiesen.
  • Die Einstellung ist permanent; sie bleibt bei einem Aus- und Wiedereinschalten des Geräts oder einem *RST erhalten.
  • Einstellen auf "0.0.0.0" (keine Server) nach SYSTem:SECurity:IMMediate.
  • CURRent: Lesen der Adresse, die derzeit vom Gerät verwendet wird.
  • STATic: Statische Adresse aus dem nicht-flüchtigen Speicher ablesen. Diese Adresse wird verwendet, wenn DHCP deaktiviert wurde oder nicht verfügbar ist.


TRACk

[SOURce[1|2]:]TRACk {ON|OFF|INVerted}
TRACk?

Bewirkt, dass die Kanäle 1 und 2 eines Zweikanalgeräts dasgleiche Signal oder ein Signal mit invertierter Polarität ausgeben.

Parameter | Typische Rückgabe
{ON|OFF|INVerted} | ON, OFF, oder INV
Kanal 2 so einstellen, dass er ein Signal ausgibt, das mit dem von Kanal 1 identisch ist: TRACk ON
  • Bewirkt, dass alle Einstellungen des genannten Kanals in den anderen Kanal kopiert werden, mit Ausnahme der unten aufgeführten Einstellungen. Dies schließt die Frequenzlisteneinstellungen und jedes im Speicher geladene Arbiträrsignal mit ein.
  • Über die Option INVerted wird das Verfolgen der Amplitude des Kanals invertiert, wodurch ein Signal gebildet wird, das einem differenziellen Ausgang zwischen Kanal 1 und Kanal 2 gleicht. Der DC-Offset wird nicht invertiert.
  • Wenn TRACk auf ON steht, gelten die Spannungsgrenzen für beide Kanäle. Falls Spannungsgrenzen an einem der beiden Kanäle verhindern würden, dass das Setup des anderen Kanals angewendet wird, generiert das Gerät einen Einstellungskonflikt-Fehler und die Kanalverfolgung bleibt auf OFF.
  • Wenn TRACk auf ON steht, wirken sich Änderungen an einem der Kanäle auf beide Kanäle aus. Wird TRACk von ON oder INV auf OFF gesetzt, behalten die Kanäle ihre vorhandene Einstellung (Frequenz, Amplitude usw.), aber Sie können nun einen Kanal ändern, ohne den anderen Kanal zu beeinflussen.
  • Spannungsgrenzen können im Verfolgungsmodus angepasst werden, sie können jedoch nicht unter Missachtung des aktuellen Signals eingestellt werden.
  • Durch Umstellen der Nachverfolgung auf ON wird COMBine:FEED auf NONE gesetzt und FREQuency:COUPle, VOLTage:COUPle sowie RATE:COUPle ausgeschaltet.
  • TRACK ist nicht zulässig, wenn die interne Modulationsquelle für den verfolgten Kanal der andere Kanal ist.
  • OUTPut:SYNC:SOURce wird auf den zu verfolgenen Kanal eingestellt.


Einführung in das Subsystem TRIGger

TRIGger Subsystem Einführung

Der rückseitige externe Trigger-BNC-Anschluss ist auf die Chassis-Masse bezogen.

Konfiguriert die Triggerung für Sequenz, Liste, Burst und Wobbelung:

TRIGger[1|2] - sofortige Triggerung

TRIGger[1|2]:COUNt {<number>MINimum|MAXimum|DEFault} - Triggerzahl

TRIGger[1|2]:DELay {<seconds>|MINimum|MAXimum} - Triggerverzögerung

TRIGger[1|2]:LEVel {<level>|MINimum|MAXimum} - Trigger-Level

TRIGger[1|2]:SLOPe {POSitive|NEGative} - Flanke für das Triggersignal am rückwärtigen Anschluss Ext Trig

TRIGger[1|2]:SOURce {IMMediate|EXTernal|TIMer|BUS} - Quelle (intern, extern, Timer oder Bus), von der das Gerät Trigger annimmt

TRIGger[1|2]:TIMer {<seconds>|MINimum|MAXimum} - Timer wird verwendet, wenn TRIGger[1|2]:SOURce TIMer ist.

TRIGger[1|2]

Zwingt den sofortigen Trigger, eine Sequenz, Liste, Wobbelung oder einen Burst auszulösen.

Parameter | Typische Rückgabe
(keine) | (keine)
Einen sofortigen Trigger an Kanal 2 senden: TRIG
  • Kann mit IMMediate, EXTernal oder BUS Triggerquelle (TRIGger[1|2]:SOURce) verwendet werden. Sie können zum Beispiel TRIGger verwenden, um einen sofortigen Trigger auszugeben, während das Gerät auf einen externen Trigger wartet.
  • Beabsichtigt als Überbrückung. Für die allgemeine softwaregesteuerte Triggerung verwenden Sie *TRG.

TRIGger[1|2]:COUNt {<number>MINimum|MAXimum|DEFault}
TRIGger[1|2]:COUNt? [{MINimum|MAXimum}]

Legt die Triggerzahl fest.

Parameter | Typische Rückgabe
1 bis 1.000.000; Standard, 1 | 10000
Triggerzahl von Kanal 2 auf 10000 setzen: TRIG2:COUN 10000
  • Kann mit IMMediate, EXTernal oder BUS Triggerquelle (TRIGger[1|2]:SOURce) verwendet werden.
  • Gilt nur, wenn INITiate[1|2]:CONTinuous auf OFF steht.

TRIGger[1|2]:DELay {<seconds>|MINimum|MAXimum}
TRIGger[1|2]:DELay? [{MINimum|MAXimum}]

Setzt die Triggerverzögerung (die Zeit von der Aktivierung des Triggers bis zum Auftreten des getriggerten Ereignisses).

Parameter | Typische Rückgabe
0 bis 1.000 s, mit Auflösung von 4 ns; Standard 0 | +1.050000000000000E-01
Triggerverzögerung von Kanal 1 auf 105 ms setzen: TRIG:DEL 105e-3
  • Kann mit IMMediate, EXTernal oder BUS Triggerquelle (TRIGger[1|2]:SOURce) verwendet werden.

TRIGger[1|2]:LEVel {<level>|MINimum|MAXimum}
TRIGger[1|2]:LEVel? [{MINimum|MAXimum}]

Stellt den Ausgangstrigger-Level und den Eingangstriggerschwellenwert auf Volt. Der Triggerschwellenwert beträgt die Hälfte des Trigger-Levels.

Parameter | Typische Rückgabe
0,9 bis 3,8 V | +3.300000000000000E+00
Trigger-Level auf 2 V setzen: TRIG:LEV 2

TRIGger[1|2]:SLOPe {POSitive|NEGative}
TRIGger[1|2]:SLOPe?

Gibt die Polarität des Triggersignals am rückwärtigen Anschluss Trig In für jeden extern getriggerten Modus an.

Parameter | Typische Rückgabe
{POSitive|NEGative}, Standard POS (ansteigende Flanke) | POS oder NEG
Stellt die Trigger-Neigung auf negative Flanke: TRIG:SLOP NEG

TRIGger[1|2]:SOURce {IMMediate|EXTernal|TIMer|BUS}
TRIGger[1|2]:SOURce?

Wählt die Triggerquelle für Sequenz, Liste, Burst oder Wobbelung. Das Gerät akzeptiert einen sofortigen oder zeitgesteuerten internen Trigger, einen externen Hardware-Trigger über den rückwärtigen Anschluss Ext Trig oder einen Software- (Bus-)Trigger.

Parameter | Typische Rückgabe
{IMMediate|EXTernal|TIMer|BUS}, Standard IMMediate | IMM, EXT, TIM, BUS
Externe Triggerquelle auswählen (jedes Mal triggern, wenn am Triggereingang auf der Rückwand ein Low-True-TTL-Impuls empfangen wird): TRIG:SOUR EXT

Im getriggerten Burst-Modus:

  • Das Gerät gibt jedes Mal bei Empfang eines Triggers ein Signal mit der spezifizierten Anzahl von Zyklen (Burst-Anzahl) aus. Nach der Ausgabe der angegebenen Anzahl von Zyklen stoppt das Gerät und wartet auf den nächsten Trigger.
  • IMMediate (intern): bei aktiviertem Burst-Modus erfolgt die Geräteausgabe kontinuierlich. Die Geschwindigkeit der Burst-Erstellung wird mit dem Befehl BURSt:INTernal:PERiod festgelegt.
  • EXTernal: Das Gerät akzeptiert Hardware-Trigger über den rückseitigen Anschluss Ext Trig. Das Gerät gibt immer dann einen Burst mit der angegebenen Zahl von Zyklen aus, wenn Ext Trig einen Pegelübergang mit der korrekten Polarität (TRIGger[1|2]:SLOPe) empfängt. Externe Triggersignale während eines Bursts werden ignoriert.
  • BUS (Software): das Gerät initiiert immer dann einen Burst, wenn ein Bus-Trigger (*TRG) empfangen wird. Die Taste [Trigger] auf der Frontplatte ist beleuchtet, wenn das Gerät auf einen Bus-Trigger wartet.
  • EXTernal oder BUS: Burst-Anzahl und Burst-Phase bleiben wirksam, die Burst-Periode wird jedoch ignoriert.
  • TIMer: Die Abstände zwischen Triggerereignissen werden durch einen Timer festgelegt, wobei der erste Trigger erfolgt, sobald INIT auftritt.

Im Modus Frequenzwobbelung:

    • IMMediate (intern): Die Gerätausgabe erfolgt kontinuierlich, wenn die Wobbelung aktiviert ist. Der Zeitraum, in der eine Wobbelung generiert wird, ist die Wobbelzeit (SWEep:TIME) plus 1 ms.
    • EXTERN: Das Gerät akzeptiert Hardware-Trigger über den rückseitigen Anschluss Ext Trig. Das Gerät startet jedes Mal eine Wobbelung, wenn Trig In einen TTL-Impuls mit der passenden Flankenpolarität empfängt (TRIGger[1|2]:SLOPe). Die Triggerperiode muss mindestens der Wobbelzeit (SWEep:TIME) plus 1 ms entsprechen.
    • BUS (Software): Das Gerät startet jedes Mal eine Wobbelung, wenn ein Bus-Trigger (*TRG) empfangen wird. Die Taste [Trigger] auf der Frontplatte ist beleuchtet, wenn das Gerät auf einen Bus-Trigger wartet.
  • APPLy setzt die Triggerquelle auf IMMediate.
  • Um die Synchronisation mit der BUS-Quelle zu gewährleisten, senden Sie *WAI (warten), dadurch wartet das Gerät, bis alle anstehenden Operationen abgeschlossen sind, bevor es weitere Befehle ausführt. Beispiel: Der folgende Befehlsstring gewährleistet, dass der erste Trigger akzeptiert und die Operation ausgeführt wird, bevor der zweite Trigger erkannt wird.

    TRIG:SOUR BUS;*TRG;*WAI;*TRG;*WAI
  • Verwenden Sie *OPC? oder *OPC, um zu bestimmen, wann ein Wobbelzyklus oder Burst abgeschlossen ist. Der Abfragebefehl *OPC? bewirkt, dass nach Abschluss des Wobbelzyklus oder Burst der Wert „1“ in den Ausgangspuffer geschrieben wird. Der Befehl *OPC setzt nach Abschluss des Wobbelzyklus oder Bursts das Bit „Operation Complete“ (Bit 0) im Standard-Ereignisregister.

TRIGger[1|2]:TIMer {<seconds>|MINimum|MAXimum}
TRIGger[1|2]:TIMer? [{MINimum|MAXimum}]

Stellt den verwendeten Timer ein, wenn TRIGger[1|2]:SOURce TIMer ist.

Parameter | Typische Rückgabe
1 µs bis 8.000 s | +3,000000000000000E-01
Trigger-Timer auf Kanal 2 auf 300 ms einstellen: TRIG2:TIM 0,3
  • In der Burst-Betriebsart „Triggered“ (BURSt:MODE TRIG) setzt dieser Befehl BURSt:INTernal:PERiod außer Kraft.


UNIT:ANGLe

UNIT:ANGLe {DEGree|RADian|SECond|DEFault}
UNIT:ANGLe?

Gibt die Winkeleinheiten an, die auf dem Bildschirm angezeigt und zum Festlegen der Winkel verwendet werden. Die ausgewählten Einheiten werden für die Einstellung der Startphase eines Burst verwendet (BURSt:PHASe) und für die Einstellung des Phasenversatzes (PHASe). Die zugeordneten Abfragen werden ebenfalls beeinflusst.

Parameter | Typische Rückgabe
{DEGree|RADian|SECond|DEFault}, Standard DEGree | DEG, RAD, oder SEC
Winkeleinheiten auf Radiant einstellen: UNIT:ANGL RAD
  • Die SECond Option ist nur bei 33600 Series Geräten verfügbar.
  • Die Einstellung kann überschrieben werden durch Hinzufügen von Einheiten zu den numerischen Parametern im Befehl. Zum Beispiel gibt PHASE 90 DEG ungeachtet dieser Einstellung 90 Grad an.
  • Auf der Frontplatte werden immer Grad angezeigt, ungeachtet der Einstellung UNIT:ANGLe.


UNIT:ARBitrary:ANGLe {DEGree|RADian|SECond|SAMPle|DEFault}UNIT:ARBitrary:ANGLe?

UNIT:ARBitrary:ANGLe {DEGree|RADian|SECond|SAMPle|DEFault}
UNIT:ARBitrary:ANGLe?

Stellt die Einheiten zur Angabe der Arbiträrsignalphase ein. Auf der Frontplatte werden die Phasenparameter in den ausgewählten Einheiten angezeigt.

Parameter | Typische Rückgabe
{DEGree|RADian|SECond|SAMPle|DEFault}, Standard DEGree | DEG, RAD, SEC, oder SAMP
Einstellen der Winkeleinheiten der Arbiträrsignale auf Proben: UNIT:ARB:ANGL SAMP
  • Die Optionen SECond und SAMPle sind nur bei 33600 Series Modellen verfügbar.
  • Sie können Einheiten auch angeben, indem Sie Einheiten zu den numerischen Parametern hinzufügen: ARB:PHAS 10 DEG.


Einführung in das Subsystem VOLTage

VOLTage Subsystem Einführung

Das Subsystem VOLTage bestimmt die Parameter im Zusammenhang mit der Ausgangsspannung.

Beispiel

Das folgende Beispiel ist ein typisches Verfahren für die Verwendung des Subsystems VOLTage.

  1. Spezifizieren Sie die Signalform, die Amplitude und den Offset: Verwenden Sie den Befehl APPLy oder die entsprechenden Befehle FUNCtion, FREQuency, VOLTage und VOLTage:OFFSet, um Funktion, Frequenz, Amplitude und Offset auszuwählen.
  2. Einheiten für die Ausgangsamplitude einstellen: VOLTage:UNIT
  3. Ausgangsamplitude einstellen: VOLTage
  4. DC-Offsetspannung einstellen: VOLTage:OFFSet
  5. Hohes und niedriges Spannungsniveau einstellen: VOLTage:HIGH und VOLTage:LOW
  6. Ausgangsspannungsbegrenzungen auswählen, um das zu testende Gerät zu schützen (DUT): VOLTage:LIMit:HIGH, VOLTage:LIMit:LOW und VOLTage:LIMit:STATe
  7. Status der automatischen Bereichswahl für alle Ausgangsfunktionen auswählen: VOLTage:RANGe:AUTO
  8. Spannungskopplung einstellen, um Amplitude und Versatz der Kanäle zusammen zu sperren (nur Zweikanalgeräte): VOLTageLCOUPle[:STATe]

Dieses Beispiel illustriert das oben dargestellte Verfahren:

SOURce1:FUNCtion SQU
SOURce1:FREQuency +1,0E+06
SOURce1:VOLTage +0,5
SOURce1:VOLTage:OFFSet +0,5
SOURce1:FUNCtion:SQUare:PERiod +1,0E-06
SOURce1:FUNCtion:PULSe:PERiod +1,0E-06
SOURce1:VOLTage:LIMit:LOW +0,0
SOURce1:VOLTage:LIMit:HIGH +1,0
SOURce1:VOLTage:LIMit:STATe 1
OUTP1 ON
SOURce2:FUNCtion SIN
SOURce2:FREQuency +1,0E+06
SOURce2:VOLTage +2,0
SOURce2:VOLTage:OFFSet +0,0
SOURce2:VOLTage:LIMit:LOW -1,0
SOURce2:VOLTage:LIMit:HIGH +1,0
SOURce2:VOLTage:LIMit:STATe 1
OUTP2 ON

[SOURce[1|2]:]VOLTage {<amplitude>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]VOLTage? [{MINimum|MAXimum}]

Stellt die Ausgangsamplitude ein.

Parameter | Typische Rückgabe
1 mVpp bis zulässiger Höchstwert für Signal und Modell, Standard 100 mVpp | +5,0000000000000E+00
Ausgangsamplitude auf 5 Vpp einstellen: VOLT 5 Vpp
  • Der Zusammenhang zwischen Offset-Spannung und Ausgangsamplitude ist unten beschrieben. Vmax ist die maximale Spitzenspannung für den gewählten Lastwiderstand (5 V für eine 50 Ω Last oder 10 V für eine hochohmige Last).

    |Voffset| < Vmax - Vpp/2

    Ist die angegebene Offsetspannung nicht gültig, passt das Gerät den Wert auf die maximal zulässige DC-Spannung mit der angegebenen Amplitude an. Über die Remote-Schnittstelle wird ebenfalls der Fehler "Data out of range" generiert.
  • Unterschiede bei der Bedienung von Frontplatte und Remoteschnittstelle:
  • Remoteschnittstelle: Die Einstellung der Amplitude über die Remoteschnittstelle kann den Versatz verändern, um die gewünschte Amplitude zu erreichen. In diesem Fall generiert das Gerät entweder den Fehler "Data out of range" oder den Fehler "Settings conflict". Ist die angegebene Offsetspannung nicht gültig, passt das Gerät den Wert auf den maximal zulässigen Wert mit der angegebenen Amplitude an.
  • Frontplatte: Die Einstellung der Amplitude über die Frontplatte bewirkt keine Änderung der Offset-Einstellung. Ist die angegebene Amplitude nicht gültig, passt das Gerät sie an die maximal zulässige Amplitude mit dem aktuellen Offset an und generiert die Fehlermeldung "Data out of range".
  • Einschränkungen durch den Lastwiderstandswert: Beträgt die Amplitude 10 Vpp und Sie ändern den Lastwiderstand von 50 Ω auf "high impedance" (OUTPut[1|2]:LOAD INF), verdoppelt sich die angezeigte Amplitude und beträgt dann 20 Vpp. Der Wechsel von "high impedance" zu 50 Ω halbiert die angezeigte Amplitude. Die Einstellung des Lastwiderstands beeinflusst die tatsächliche Ausgangsspannung nicht; sie ändert lediglich die Werte, die über die Remote-Schnittstelle angezeigt und abgefragt werden. Die tatsächliche Ausgangsspannung ist abhängig von der verbundenen Last.
  • Einschränkungen durch die Ausgangskopplung:
  • Unterschiede bei der Bedienung von Frontplatte und Remoteschnittstelle: Wenn zwei Kanäle gekoppelt werden, werden Einschränkungen im Amplitudenbereich auf beiden Kanälen überprüft, bevor ein Amplitudenwechsel ausgeführt wird. Falls eine Änderung der Ausgangsamplitude ein LIMIT für beide Kanäle überschreiten sollte oder die Ausgangsspezifikationen des Geräts für beide Kanäle überschreitet:
  • Remoteschnittstelle: Das Gerät wird zunächst den Offset anpassen, dann gegebenenfalls die Amplitude dieses Kanals, um den Spannungsgrenzwerten oder der Spannungsspezifikation zu entsprechen. In diesem Fall generiert das Gerät entweder den Fehler "Data out of range" oder den Fehler "Settings conflict".
  • Frontplatte: Das Gerät wird den Amplitudenwert an den Maximalwert zur aktuellen Offseteinstellung angleichen. Es wird die Fehlermeldung "Data out of range" generiert.
  • Spannungseinheiten angeben: Sie können die Ausgangsamplitude in Vpp, Vrms oder dBm einstellen, wenn die Einheiten als Teil des VOLTage-Befehls festgelegt werden, z.B. VOLT 3.0 VRMS.

Verwenden Sie VOLTage:UNIT, um die Ausgangseinheiten für alle nachfolgenden Befehle festzulegen.

Die Ausgangsamplitudenmaßeinheit „dBm“ ist nicht verfügbar, wenn Sie den Lastwiderstand „high impedance“ spezifiziert haben. Die Einheiten werden automatisch in Vpp umgerechnet.

  • Einschränkungen durch die Maßeinheit: Amplitudeneinschränkungen werden manchmal durch die ausgewählten Ausgangseinheiten bestimmt. Dies kann auftreten, wenn die Einheiten aufgrund der Unterschiede der Scheitelfaktoren verschiedener Funktionen Vrms oder dBm entsprechen. Wenn Sie z. B. ein 5 Vrms Rechtecksignal (in 50 Ω) in ein Sinussignal ändern, passt das Gerät die Amplitude auf 3,536 Vrms an (der obere Grenzwert für Sinussignale in Vrms). Zudem generiert die Remote-Schnittstelle einen "Settings conflict"-Fehler.
  • Einschränkungen bei Arbiträrsignalen: Bei Arbiträrsignalen ist der Amplitudenbereich eingeschränkt, falls die Signalpunkte nicht den vollen Bereich des Ausgangs-D/A-Wandlers abdecken. Z. B. nutzt das integrierte "Sinc"-Signal nicht den gesamten Wertebereich, weshalb seine maximale Amplitude auf 6,087 Vpp (in 50 Ω) begrenzt ist.

  • Eine Änderung der Amplitude kann die Ausgabe bei bestimmten Spannungswerten aufgrund des Wechsels des Ausgangsabschwächers kurz unterbrechen. Die Amplitudenregelung gewährleistet jedoch, dass die Ausgangsspannung bei einer Bereichsumschaltung niemals den aktuellen Wert überschreitet. Um solche Unterbrechungen zu vermeiden, muss die automatische Bereichswahl mit VOLTage:RANGe:AUTO OFF deaktiviert werden. Der Befehl APPLy aktiviert die automatische Bereichswahl.

  • Sie können die Amplitude (zusammen mit einer Offsetspannung) auch durch Vorgabe eines oberen (VOLTage:HIGH) und eines unteren Spannungspegels (VOLTage:LOW) spezifizieren. Stellen Sie beispielsweise den oberen Pegel auf +2 V und den unteren Pegel auf -3 V, führt dies zu einer Amplitude von 5 Vpp mit einem Offset von -500 mV.
  • Wählen Sie für die Ausgabe eines DC-Spannungspegels die DC-Spannungsfunktion (FUNCtion DC) und stellen Sie dann die Offset-Spannung ein (VOLTage:OFFSet). Gültige Werte liegen zwischen ±5 VDC in 50 Ω oder ±10 VDC in einen offenen Schaltkreis. Wenn das Gerät im DC-Modus arbeitet, hat die Einstellung der Amplitude keine Auswirkungen.

[SOURce[1|2]:]VOLTage:COUPle[:STATe] {ON|1|OFF|0}
[SOURce[1|2]:]VOLTage:COUPle[:STATe]?

Aktiviert oder deaktiviert die Beibehaltung der selben Einstellungen für Amplitude, Offset, Bereich, Last und Einheiten auf beiden Kanälen eines Zweikanalgeräts. Der Befehl gilt für beide Kanäle; das Schlüsselwort SOURce wird ignoriert.

Parameter | Typische Rückgabe
{ON|1|OFF|0}, Standard OFF | 0 (OFF) oder 1 (ON)
Spannungskopplung aktivieren: VOLT:COUP ON

[SOURce[1|2]:]VOLTage:HIGH {<voltage>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]VOLTage:HIGH? [{MINimum|MAXimum}]

[SOURce[1|2]:]VOLTage:LOW {<voltage>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]VOLTage:LOW? [{MINimum|MAXimum}]

Oberen und unteren Spannungswert des Signals einstellen.

Parameter | Typische Rückgabe
±5 VDC in 50 Ω, sofern HIGH mindstens 1 mV größer ist als LOW. Standardwerte: HIGH +50 mV, LOW -50 mV. | +4,000000000000000E+00
Hochspannungsbereich auf 4 V einstellen: VOLT:HIGH 4
  • Einschränkungen durch die Amplitude: Sie können für die Spannungspegel einen positiven oder einen negativen Wert mit den unten dargestellten Einschränkungen angeben. Vpp ist die maximale Spitze-zu-Spitze-Amplitude für den gewählten Lastwiderstand (10 Vpp in 50 Ω oder 20 Vpp in einen offenen Schaltkreis).

    Vhigh – Vlow£ Vpp (max) und Vhigh, Vlow£Vpp (max)/2
  • Unterschiede bei der Bedienung von Frontplatte und Remoteschnittstelle:
  • Remoteschnittstelle: Bei der Einstellung des oberen oder unteren Pegels über die Remoteschnittstelle kann der obere oder untere Pegel geändert werden, um die gewünschte Einstellung zu erreichen. In diesem Fall tritt entweder der Fehler "Data out of range" oder der Fehler "Settings conflict" auf. Wenn für den oberen Pegel ein kleinerer Wert als für den unteren Pegel festgelegt wird, stellt das Gerät den unteren Pegel 1 mV kleiner ein als den oberen Pegel. Wenn für den oberen Pegel ein kleinerer Wert als die LOW-Grenze oder die Geräteausgabespezifikationen eingestellt wird, stellt das Gerät den unteren Pegel auf die LOW-Grenze oder die Geräteausgabespezifikationen und der obere Pegel wird 1 mV über den unteren Pegel gestellt. Ein ähnlicher Regelsatz gilt, wenn der untere Pegel nicht korrekt eingestellt wird.
  • Frontplatte: Durch die Einstellung des oberen oder unteren Pegels über die Frontplatte wird evtl. die Pegeleinstellung abgeschnitten, um die gewünschte Pegeleinstellung zu erzielen, und der Fehler "Data out of range" generiert. Für den Wert des oberen Pegels kann über die Frontplatte kein Wert eingestellt werden, der unter dem des unteren Pegels liegt.
  • Durch die Einstellung von oberem und unterem Pegel werden auch Signalamplitude und -Offset eingestellt. Stellen Sie beispielsweise den oberen Pegel auf +2 V und den unteren Pegel auf -3 V, führt dies zu einer Amplitude von 5 Vpp mit einem Offset von -500 mV.
  • Einschränkungen durch den Lastwiderstandswert: Beträgt die Amplitude 10 Vpp und Sie ändern den Lastwiderstand von 50 Ω auf "high impedance" (OUTPut[1|2]:LOAD INF), verdoppelt sich die angezeigte Amplitude und beträgt dann 20 Vpp. Der Wechsel von "high impedance" zu 50 Ω halbiert die angezeigte Amplitude. Die Einstellung des Lastwiderstands beeinflusst die tatsächliche Ausgangsspannung nicht; sie ändert lediglich die Werte, die über die Remote-Schnittstelle angezeigt und abgefragt werden. Die tatsächliche Ausgangsspannung ist abhängig von der verbundenen Last.
  • Einschränkungen durch den Befehl VOLTage:LIMit:STATe: Wenn die Spannungsgrenzwerte aktiviert sind, werden die Pegeleinstellungen auf die festgelegten Grenzwerte überprüft (VOLTage:LIMit:HIGH, VOLTage:LIMit:LOW), bevor ein Pegelwechsel erfolgt. Sollte bei einer Änderung des Ausgangspegels eine LIMIT-Einstellung überschritten werden, wird der Pegel auf den maximal (oder minimal) erlaubten Wert eingestellt, der die LIMit-Einstellung nicht überschreitet, und die Fehlermeldung "Settings conflict" wird generiert.
  • Einschränkungen durch die Ausgangskopplung: Wenn zwei Kanäle gekoppelt werden, werden Einschränkungen in der Pegeleinstellung auf beiden Kanälen überprüft, bevor ein Pegelwechsel ausgeführt wird. Sollte bei einer Änderung des Ausgangspegels eine LIMIT-Einstellung überschritten werden oder die Ausgangsspezifikationen des Geräts für beide Kanäle, wird der Pegel auf den maximal (oder minimal) erlaubten Wert eingestellt, der die LIMit-Einstellung nicht überschreitet, und die Fehlermeldung "Settings conflict" wird generiert.
  • Um das Signal im Verhältnis zur Offsetspannung umzukehren, verwenden Sie OUTPut[1|2]:POLarity.

[SOURce[1|2]:]VOLTage:LIMit:HIGH {<voltage>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]VOLTage:LIMit:HIGH? [{MINimum|MAXimum}]

[SOURce[1|2]:]VOLTage:LIMit:LOW {<voltage>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]VOLTage:LIMit:LOW? {MINimum|MAXimum}?

Bestimmt die oberen und unteren Grenzwerte für die Ausgangsspannung.

Parameter | Typische Rückgabe
±5 VDC in 50 Ω, sofern HIGH mindstens 1 mV größer ist als LOW. Standardwerte: HIGH +50 mV, LOW -50 mV. | +5,0000000000000E+00
Oberes Ausgangslimit von Kanal 1 auf 5 V einstellen: VOLT:LIMIT:HIGH 5,0 VOLT:LIMIT:STATE ON
  • Damit Spannungsgrenzwerte gelten, muss VOLTage:LIMit:STATe auf ON gesetzt sein. Ist dies der Fall und der obere Grenzwert wurde unterhalb des oberen Werts des Signals eingestellt oder der untere Grenzwert liegt über dem unteren Wert des Signals, wird der betreffende Grenzwert an den oberen oder unteren Wert des Signals angepasst. In diesem Fall generiert das Gerät entweder den Fehler "Data out of range" oder den Fehler "Settings conflict".
  • Der obere Grenzwert bestimmt die maximal zulässige Ausgangsspannung, einschließlich DC-Offset und Scheitelwert. Sie wird in Bezug auf die aktuelle Einstellung OUTPUT[1|2]:LOAD bestimmt. Wenn die angegebene Lastimpedanz nicht am Geräteausgang vorhanden ist, stellt der Ausgangsgrenzwert evtl. nicht die tatsächlichen Spannungswerte am Ausgangsanschlus dar. Ist die Ausgangsimpedanz z. B. auf 50 Ω eingestellt, die tatsächliche Last jedoch hochohmig, kann die tatsächliche Ausgangsspitzenspannung bis zu zweimal so hoch sein wie die angegebene Spannungsgrenze.
  • Spannungseinheiten angeben: Sie können den Grenzwert der Ausgangsspannung nur in Volt angeben.
  • Wenn VOLTage:COUPle[:STATe] auf ON steht und VOLTage:LIMit:STATe auf ON, wirken sich die Spannungsgrenzwerte beider Kanäle auf die maximale Amplitude und die Offset-Einstellungen an beiden Kanälen aus. Verwendet wird die restriktivste Kombination von hohen und niedrigen Grenzen jedes Kanals.

[SOURce[1|2]:]VOLTage:LIMit:STATe {ON|1|OFF|0}
[SOURce[1|2]:]VOLTage:LIMit:STATe?

Aktiviert oder deaktiviert die Spannungsgrenzwerte der Ausgangsamplitude.

Parameter | Typische Rückgabe
{ON|1|OFF|0}, Standard OFF | 0 (OFF) oder 1 (ON)
Ausgangsgrenzwerte ±2.5 V auf Kanal 1 einstellen und aktivieren: VOLT:LIM:HIGH 2,5 VOLT:LIM:LOW -2,5 VOLT:LIM:STAT ON
  • Ist dies auf ON geschaltet, wenn die vorhandenen Einstellungen von Amplitude und Offset die Grenzwerte überschreiten, werden die Grenzwerte deaktiviert. Das Gerät generiert die Fehlermeldung "Settings conflict".
  • Wenn VOLTage:COUPle[:STATe] auf ON steht und VOLTage:LIMit:STATe auf ON, wirken sich die Spannungsgrenzwerte beider Kanäle auf die maximale Amplitude und die Offset-Einstellungen an beiden Kanälen aus. Verwendet wird die restriktivste Kombination von hohen und niedrigen Grenzen jedes Kanals.
  • Die Grenzwerte werden in Bezug auf die aktuelle Einstellung von OUTPut[1|2]:LOAD bestimmt. Wenn die angegebene Lastimpedanz nicht am Geräteausgang vorhanden ist, stellt der Ausgangsgrenzwert evtl. nicht die tatsächlichen Spannungswerte am Ausgangsanschlus dar. Ist die Ausgangsimpedanz z. B. auf 50 Ω eingestellt, die tatsächliche Last jedoch hochohmig, kann die tatsächliche Ausgangsspitzenspannung bis zu zweimal so hoch sein wie die angegebene Spannungsgrenze.

[SOURce[1|2]:]VOLTage:OFFSet {<offset>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]VOLTage:OFFSet? [{MINimum|MAXimum}]

Bestimmt die DC-Offsetspannung.

Parameter | Typische Rückgabe
± 5 VDC in 50 Ω, Standard 0 | +1,0000000000000E-01
Stellt die Offsetspannung auf 100 mV ein: VOLT:OFFS 100 mV
  • Der Zusammenhang zwischen Offset-Spannung und Ausgangsamplitude ist unten beschrieben.

    |Voffset| < Vmax - Vpp/2
  • Unterschiede bei der Bedienung von Frontplatte und Remoteschnittstelle:
  • Remoteschnittstelle: Die Offseteinstellung über die Remoteschnittstelle kann die Amplitude ändern, um die gewünschte Offseteinstellung zu erreichen. In diesem Fall generiert das Gerät entweder den Fehler "Data out of range" oder den Fehler "Settings conflict".
  • Frontplatte: Die Offseteinstellung über die Frontplatte ändert nicht die Amplitude, um die gewünschte Offseteinstellung zu erreichen. Ist der angegebene Offset nicht gültig, passt das Gerät den Wert an den maximal zulässigen Offset mit der aktuellen Amplitude an und generiert die Fehlermeldung "Data out of range".
  • Einschränkungen durch den Lastwiderstandswert: Der Offset-Bereich ist abhängig von der Einstellung des Lastwiderstands. Wenn Sie zum Beispiel den Offset auf 100 mVDC festlegen und dann den Lastwiderstand von 50 Ω auf "high impedance" stellen, verdoppelt sich der auf der Frontplatte angezeigte Offset-Spannungswert auf 200 mVDC (es wird kein Fehler generiert). Wenn Sie von "high impedance" auf 50 Ω wechseln, halbiert sich der angezeigte Offset-Spannungswert. Ausführlichere Informationen finden Sie unter OUTPut[1|2]:LOAD. Eine Änderung des Lastwiderstands ändert nicht die Spannung an den Ausgangsanschlüssen des Geräts. Sie ändert lediglich die an der Frontplatte angezeigten Werte und die Werte, die über die Remote-Schnittstelle abgefragt werden. Die Spannung am Ausgang des Geräts ist abhängig von der Last, die mit dem Gerät verbunden ist. Ausführlichere Informationen finden Sie unter OUTPut[1|2]:LOAD.
  • Einschränkungen durch die Ausgangskopplung: Wenn zwei Kanäle gekoppelt sind, werden Einschränkungen in der Offseteinstellung auf beiden Kanälen überprüft, bevor ein Offsetwechsel ausgeführt wird. Sollte bei einer Änderung des Offsets eine LIMIT-Einstellung oder die Ausgangsspezifikationen des Geräts für beide Kanäle überschritten werden:
  • Remoteschnittstelle: Zuerst wird die Amplitude, anschließend falls erforderlich der Offset des Kanals angepasst, um den Spannungsgrenzwerten oder Spezifikationen zu entsprechen. In diesem Fall generiert das Gerät entweder den Fehler "Data out of range" oder den Fehler "Settings conflict".
  • Frontplatte: Der Offset-Wert wird an den maximal zulässigen Wert angeglichen, der die LIMit-Einstellung nicht überschreitet, die Fehlermeldung "Data out of range" wird generiert.
  • Einschränkungen bei Arbiträrsignalen: Bei Arbiträrsignalen ist der Amplitudenbereich eingeschränkt, falls die Signalpunkte nicht den vollen Bereich des Ausgangs-D/A-Wandlers abdecken. Z. B. nutzt das integrierte "Sinc"-Signal nicht den gesamten Wertebereich, weshalb seine maximale Amplitude auf 6,087 Vpp (in 50 Ω) begrenzt ist.

  • Eine Änderung der Amplitude kann die Ausgabe bei bestimmten Spannungswerten aufgrund des Wechsels des Ausgangsabschwächers kurz unterbrechen. Die Amplitudenregelung gewährleistet jedoch, dass die Ausgangsspannung bei einer Bereichsumschaltung niemals den aktuellen Wert überschreitet. Um solche Unterbrechungen zu vermeiden, muss die automatische Bereichswahl mit VOLTage:RANGe:AUTO OFF deaktiviert werden. Der Befehl APPLy aktiviert die automatische Bereichswahl.

  • Durch die Einstellung von oberem und unterem Pegel werden auch Signalamplitude und -Offset eingestellt. Stellen Sie beispielsweise den oberen Pegel auf +2 V und den unteren Pegel auf -3 V, führt dies zu einer Amplitude von 5 Vpp mit einem Offset von -500 mV.
  • Wählen Sie für die Ausgabe eines DC-Spannungspegels die DC-Spannungsfunktion (FUNCtion DC) und stellen Sie dann die Offset-Spannung ein (VOLTage:OFFSet). Gültige Werte liegen zwischen ±5 VDC in 50 Ω oder ±10 VDC in einen offenen Schaltkreis. Wenn das Gerät im DC-Modus arbeitet, hat die Einstellung der Amplitude keine Auswirkungen.

[SOURce[1|2]:]VOLTage:RANGe:AUTO {OFF|0|ON|1|ONCE}
[SOURce[1|2]:]VOLTage:RANGe:AUTO?

Dieser Befehl aktiviert oder deaktiviert die automatische Spannungsbereichswahl für alle Funktionen. Durch den Befehl ONCE wird eine sofortige Bereichswahl durchgeführt, dann wird die automatische Bereichswahl auf OFF gesetzt

Parameter | Typische Rückgabe
{OFF|0|ON|1|ONCE}, Standard ON | 0 (OFF) oder 1 (ON)
Automatische Bereichswahl auf OFF setzen: VOLT:RANG:AUTO 0
  • In der Grundeinstellung ist die automatische Spannungsbereichswahl aktiv. Das Gerät wählt automatisch die optimalen Einstellungen für Wellenformgenerator und Abschwächer.
  • Ist die automatische Spannungsbereichswahl deaktiviert (OFF), verwendet das Gerät die aktuellen Verstärkungs- und Abschwächereinstellungen.
  • Der Befehl APPLy hat Vorrang gegenüber der Einstellung automatische Spannungsbereichswahl und aktiviert stets die automatische Bereichswahl (ON).
  • Das Abschalten der automatischen Bereichswahl vermeidet kurzzeitige Signalunterbrechungen, die beim Ändern der Amplitudeneinstellung durch das Umschalten des Abschwächers hervorgerufen werden können. Jedoch können Genauigkeit und Auflösung von Amplitude und der Offsetspannung (sowie die Signalformgenauigkeit) beeinträchtigt werden, wenn die Amplitude auf einen Wert unterhalb der Bereichsumschaltgrenze reduziert wird.
  • Steht ein VOLTage:COUPle[:STATe] auf ON, werden durch die Änderung dieser Einstellung auf einem der Kanäle die Einstellung beide Kanäle verändert.

[SOURce[1|2]:]VOLTage:UNIT {VPP|VRMS|DBM}
[SOURce[1|2]:]VOLTage:UNIT?

Wählt die Einheiten für die Ausgangsamplitude.

Parameter | Typische Rückgabe
{VPP|VRMS|DBM}, Standard VPP | VPP, VRMS oder DBM
Einheiten der Ausgangsamplitude auf Vrms einstellen: VOLT:UNIT VRMS
  • Wirkt sich nicht aus auf Offsetspannung (VOLTage:OFFSet), hohen Pegel (VOLTage:HIGH) oder niedrigen Pegel (VOLTage:LOW). Bei allen werden Volt-Einheiten verwendet.
  • Das Gerät verwendet die aktuelle Einstellung der Einheit sowohl für Frontplatten- als auch für Remoteschnittstellenvorgänge. Wenn Sie beispielsweise über die Remoteschnittstelle die Einheit „VRMS“ wählen (VOLTage:UNIT VRMS), wird die Einheit auf der Frontplatte als „VRMS“ angezeigt.
  • Der Befehl gilt für VOLTage? Abfrageergebnisse.
  • Die Ausgangseinheiten für die Amplitude können nicht auf dBm eingestellt werden, wenn der ausgewählte Lastwiderstand auf "high impedance" gesetzt wurde. Die Einheiten werden automatisch in Vpp umgerechnet.
  • Arbiträrsignalsequenzen akzeptieren die Einheiten Vrms oder dBm nicht.
  • Sofern Sie die Einheit nicht als Teil des Befehls VOLTage oder eines der APPLy-Befehle spezifiziert haben, hat der Befehl VOLTage:UNIT Vorrang. Wenn Sie beispielsweise VOLTage:UNIT VRMS wählen und die Einheiten nicht über einen APPLy-Befehl mit einschließen, wird die <amplitude> im APPLy-Befehl in "Vrms" angegeben.


Programmierbeispiele

Diese Programmierbeispiele helfen Ihnen beim Einstieg in die häufigsten Arbeitsschritte.

Sinussignal konfigurieren

Rechtecksignal konfigurieren

Sägezahnsignal konfigurieren

Pulssignal konfigurieren

Frequenzliste erstellen

Arbiträrsignal konfigurieren


Sinussignal konfigurieren

In diesem Abschnitt wird die Konfiguration einer Sinuswellenfunktion beschrieben.

Beschreibung

Amplitude, Offset und Phase einer Sinuswelle sind an den Synchronisationsimpuls geknüpft. Amplitude und Offset können auch mit den hohen und niedrigen Spannungswerten eingestellt werden.

Beispiel

Folgendes Signal kann mit der Serie von SCPI-Befehlen eingerichtet werden, wobei HIGH und LOW statt SOUR:VOLT und SOUR:VOLT:OFFS verwendet werden kann.

Die folgenden Befehle erzeugen die oben gezeigte Sinuswelle.

FUNCtion SIN
FREQuency +1,0E+05
VOLTage:HIGH +2,0
VOLTage:LOW +0,0
OUTPut ON
PHASe +90,0

Hinweise

  • Obwohl die Periode über die Frontplatte eingestellt werden kann, gibt es keinen SOUR:FUNC:SIN:PER oder SOUR:PER-Befehl, der zusätzlich zu SOUR:FREQ verwendet werden kann.


Rechtecksignal konfigurieren

Beschreibung

Amplitude, Offset und Phase einer Rechteckwelle sind an den Synchronisationsimpuls geknüpft. Außerdem Tastverhältnis und Periode. Amplitude und Offset können auch mit den hohen und niedrigen Spannungswerten eingestellt werden.

Beispiel

Folgendes Signal kann mit der Serie von SCPI-Befehlen eingerichtet werden, wobei HIGH und LOW statt SOUR:VOLT und SOUR:VOLT:OFFS verwendet werden kann.

Die folgenden Befehle erzeugen die oben gezeigte Rechteckwelle.

FUNC SQU
FUNC:SQU:DCYC +20,0
FREQ +1,0E+04
VOLT:HIGH +4,0
VOLT:LOW +0,0
OUTP 1

Hinweise

  • Wenn Sie bei einer Rechteckwelle SOUR:FREQ ändern, ändert sich auch SOUR:FUNC:SQU:PER. Beispiel: SOUR:FREQ +2,0E+03 entspricht SOUR:FUNC:SQU:PER +5,0E-04.


Sägezahnsignal konfigurieren

Beschreibung

Amplitude, Offset und Phase einer Sägezahnwelle sind an den Synchronisationsimpuls geknüpft. Sie besitzt außerdem Symmetrie für die Erstellung von Dreieckwellen und ähnlichen Signalformen. Amplitude und Offset können auch mit den hohen und niedrigen Spannungswerten eingestellt werden.

Beispiel

Folgendes Signal kann mit der Serie von SCPI-Befehlen eingerichtet werden, wobei HIGH und LOW statt SOUR:VOLT und SOUR:VOLT:OFFS verwendet werden kann.

Die folgenden Befehle erzeugen die oben gezeigte Sägezahnwelle.

FUNCtion RAMP
FUNCtion:RAMP:SYMMetry 25
FREQ +1,0E+03
VOLTage +2,0
VOLTage:OFFSet +1,0
OUTP 1

Hinweise

  • Die Sägezahnfrequenz ist auf 200 kHz begrenzt.
  • Obwohl die Periode über die Frontplatte eingestellt werden kann, gibt es keinen SOUR:FUNC:RAMP:PER oder SOUR:PER-Befehl, der zusätzlich zu SOUR:FREQ verwendet werden kann.


Pulssignal konfigurieren

Beschreibung

Amplitude, Offset und Phase eines Pulssignals sind an den Synchronisationsimpuls geknüpft. Es fügt steigende Flanke, Periode und Tastverhältnis hinzu (oder Impulsbreite, abhängig von der Konfiguration von FUNC:PULSe:HOLD). Amplitude und Offset können auch mit den hohen und niedrigen Spannungswerten eingestellt werden.

Beispiel

Folgendes Signal kann mit der Serie von SCPI-Befehlen eingerichtet werden, wobei HIGH und LOW statt SOUR:VOLT und SOUR:VOLT:OFFS verwendet werden kann.

Die folgenden Befehle erzeugen das oben gezeigte Pulssignal.

FUNC PULS
FUNC:PULS:TRAN:LEAD 4E-8
FUNC:PULS:TRAN:TRA 1E-6
FUNC:PULS:WIDT 3E-6
FREQ 2E5
VOLT 3
OUTP ON

Hinweise

  • Sie können FUNC:PULS:PER verwenden statt FREQ. Diese Befehle sind gepaart; die Änderung des einen ändert auch den anderen.
  • Ein Impuls kann definiert werden über Breite oder Tastverhältnis, die ebenfalls gekoppelt sind. Verwenden Sie FUNCtion:PULSe:HOLD DCYC, um festzulegen, dass das Tastverhältnis als konstanter Wert gehalten wird, während Frequenz oder Periode sich ändern. Verwenden Sie FUNCtion:PULSe:HOLD WIDTh um festzulegen, dass die Pulsbreite als konstanter Wert gehalten wird, während Frequenz oder Periode sich ändern.


Frequenzliste erstellen

Beschreibung

Die LIST-Befehle stellen die Ausgangsfrequenz entsprechend den Eintragungen in einer Freuquenzliste ein, was einen schnellen Wechsel zu den Frequenzen in einer Liste von bis zu 128 Frequenzen ermöglicht. Die zu verwendenden Frequenzen werden über den Befehl LIST:FREQuency eingegeben, sie können auch aus einer Datei abgerufen werden über den Befehl MMEMory:LOAD:LIST[1|2].

Beispiele

Der folgende Code demonstriert die Methode LIST:FREQuency.

FUNCtion SQU
TRIGger:SOURce IMMediate
FREQuency:MODE LIST
LIST:DWELl +5,0E-03
LIST:FREQuency +1,0E+03,+3,0E+03,+7,0E+03
VOLTage +1,0
OUTPut 1

Die Ergebnisse dieses Codes werden unten angezeigt.


Arbiträrsignal konfigurieren

In diesem Abschnitt wird die Konfiguration eines Arbiträrsignals beschrieben.

Beschreibung

Ein benutzererstelltes Arbiträrsignal besteht aus Amplitude, Offset, Abtastrate und Filtertyp. Diese können eingestellt werden, wenn die Arbiträrsignaldatei (Erweiterung .arb oder .barb) in einen Signalspeicher geladen wird. Der Beginn eines typischen Arbiträrsignals ist weiter unten abgebildet; beachten Sie, dass Amplitude und Offset durch hohe und niedrige Spannungswerte dargestellt sind:

Dateiformat:1.10
Prüfsumme:0
Kanalanzahl:1
Samplingrate:20000.000000
High Level:2,000000
Low Level:0,000000
Marker-Punkt:50
Datentyp:"short"
Filter:"off"
Datenpunkte:100
Daten:
23259
23114

Die Zeilen 23259 und 23114 nach der Data: Zeile sind ASCII DAC-Codes und stehen für die ersten beiden Signaldatenwerte. Liegen die DAC Codes des Signals nicht im Bereich von -32767 bis + 32767, ist die Ausgangsamplitude asymmetrisch.

Bei den Firmwareversionen 1.12 und älter aktualisierte das Gerät die Signal-Metadaten nicht (Abtastrate, Spannungsbereich und Filtereinstellung), wenn vom Arbiträrsignal auf ein andere Signalform umgeschaltet wurde. Das neue Arbiträrsignal hat die Metadaten des bereits im Speicher abgelegten Signals übernommen. Darum wurde ein Arbiträrsignal, das mit einem/r einzigen Spannungsbereich, Abtastrate und Filtereinstellung wiedergegeben werden soll (wie in den Metadaten des Signals festgelegt), zu einem anderen Satz Metadaten gewechselt. Bei Firmware-Versionen nach 1.12 lädt das Arbiträrsignal jeweils die Metadaten, die in der Arbiträrsignaldatei vorhanden sind, daher werden sie so wiedergegeben, wie sie zuvor wiedergegeben wurden.

Interne Signale machen wenige oder keine Änderungen, wenn sie in einen Signalspeicher geladen werden. Sie werden gemäß der aktuellen Gerätekonfiguration wiedergegeben. Als Beispiel der Beginn der unten abgebildeten Haversine.arb.

Copyright: Keysight Technologies, 2010
Dateiformat:1.10
Kanalanzahl:1
Datenpunkte:40
Daten:
0
202
802

Aufgrund der fehlenden Metadaten, werden die aktuellen Einstellungen für Spannungsbereich, Abtastrate und Filtereinstellung verwendet.

Beispiel

Der folgende Code lädt und ändert ein internes Arbiträrsignal.

FUNCtion ARB
VOLTage +3
VOLTage:OFFSet +1
FUNC:ARB:SRAT 1E5
FUNCtion:ARBitrary "INT:\BUILTIN\EXP_RISE.ARB"
OUTPut 1

Das Signal, das sich aus diesen Befehlen ergibt, ist unten abgebildet.


Befehl Schnellübersicht

Keysight Trueform Series Befehl Schnellübersicht

Siehe Syntaxkonventionen für SCPI.

APPLy-Befehle

[SOURce[1|2]:]APPLy?

[SOURce[1|2]:]APPLy:ARBitrary [{<sample_rate>|MIN|MAX|DEF} [,{<amplitude>|MIN|MAX|DEF} [,{<offset>|MIN|MAX|DEF}]]]

[SOURce[1|2]:]APPLy:DC [{<frequency>|MIN|MAX|DEF} [,{<amplitude>|MIN|MAX|DEF} [,{<offset>|MIN|MAX|DEF}]]]

[SOURce[1|2]:]APPLy:NOISe [{<frequency>|MIN|MAX|DEF} [,{<amplitude>|MIN|MAX|DEF} [,{<offset>|MIN|MAX|DEF}]]]

[SOURce[1|2]:]APPLy:PRBS [{<frequency>|MIN|MAX|DEF} [,{<amplitude>|MIN|MAX|DEF} [,{<offset>|MIN|MAX|DEF}]]]

[SOURce[1|2]:]APPLy:PULSe [{<frequency>|MIN|MAX|DEF} [,{<amplitude>|MIN|MAX|DEF} [,{<offset>|MIN|MAX|DEF}]]]

[SOURce[1|2]:]APPLy:RAMP [{<frequency>|MIN|MAX|DEF} [,{<amplitude>|MIN|MAX|DEF} [,{<offset>|MIN|MAX|DEF}]]]

[SOURce[1|2]:]APPLy:SINusoid [{<frequency>|MIN|MAX|DEF} [,{<amplitude>|MIN|MAX|DEF} [,{<offset>|MIN|MAX|DEF}]]]

[SOURce[1|2]:]APPLy:SQUare [{<frequency>|MIN|MAX|DEF} [,{<amplitude>|MIN|MAX|DEF} [,{<offset>|MIN|MAX|DEF}]]]

[SOURce[1|2]:]APPLy:TRIangle [{<frequency>|MIN|MAX|DEF} [,{<amplitude>|MIN|MAX|DEF} [,{<offset>|MIN|MAX|DEF}]]]

DATA-Befehle

[SOURce[1|2]:]DATA:ARBitrary2:FORMat {AABB|ABAB}

[SOURce[1|2]:]DATA:ARBitrary[1|2] <arb_name>, {<binary_block>|<value>, <value>, . . .}

[SOURce[1|2]:]DATA:ARBitrary[1|2]:DAC <arb_name>, {<binary_block>|<value>, <value>, . . .}

[SOURce[1|2]:]DATA:ATTRibute:AVERage? [<arb_name>]

[SOURce[1|2]:]DATA:ATTRibute:CFACtor? [<arb_name>]

[SOURce[1|2]:]DATA:ATTRibute:POINts? [<arb_name>]

[SOURce[1|2]:]DATA:ATTRibute:PTPeak? [<arb_name>]

[SOURce[1|2]:]DATA:SEQuence <block_descriptor>

[SOURce[1|2]:]DATA:VOLatile:CATalog?

[SOURce[1|2]:]DATA:VOLatile:CLEar

[SOURce[1|2]:]DATA:VOLatile:FREE?

Pfeil nach oben

Befehle zum Konfigurieren des Ausgangs

[SOURce[1|2]:]FUNCtion <function>
[SOURce[1|2]:]FUNCtion?

FREQUENZKONTROLLE

[SOURce[1|2]:]FREQuency {<frequency>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]FREQuency? [{MINimum|MAXimum}]

[SOURce[1|2]:]FREQuency:CENTer {<frequency>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]FREQuency:CENTer? [{MINimum|MAXimum}]

[SOURce[1|2]:]FREQuency:COUPle:MODE {OFFSet|RATio}
[SOURce[1|2]:]FREQuency:COUPle:MODE?

[SOURce[1|2]:]FREQuency:COUPle:OFFSet {<frequency>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]FREQuency:COUPle:OFFSet?

[SOURce[1|2]:]FREQuency:COUPle:RATio <ratio>
[SOURce[1|2]:]FREQuency:COUPle:RATio?

[SOURce[1|2]:]FREQuency:COUPle[:STATe] {ON|1|OFF|0}
[SOURce[1|2]:]FREQuency:COUPle[:STATe]?

[SOURce[1|2]:]FREQuency:MODE {CW|LIST|SWEep|FIXed}
[SOURce[1|2]:]FREQuency:MODE?

[SOURce[1|2]:]FREQuency:SPAN {<frequency>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]FREQuency:SPAN? [{MINimum|MAXimum}]

[SOURce[1|2]:]FREQuency:STARt {<frequency>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]FREQuency:STARt? [{MINimum|MAXimum}]

[SOURce[1|2]:]FREQuency:STOP {<frequency>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]FREQuency:STOP? [{MINimum|MAXimum}]

MODUS FREQUENZLISTE

[SOURce[1|2]:]LIST:DWELl {<seconds>|MINimum|MAXimum}
[SOURce[1|2]:]LIST:DWELl? [{MINimum|MAXimum}]

[SOURce[1|2]:]LIST:FREQuency <freq1>[, <freq2>, etc.]
[SOURce[1|2]:]LIST:FREQuency?

[SOURce[1|2]:]LIST:FREQuency:POINts? [{MINimum|MAXimum}]

MMEMory:LOAD:LIST[1|2] <filename>

MMEMory:STORe:LIST[1|2] <filename>

Pfeil nach oben

VOLTAGE (Spannung)

[SOURce[1|2]:]VOLTage {<amplitude>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]VOLTage? [{MINimum|MAXimum}]

[SOURce[1|2]:]VOLTage:COUPle[:STATe] {ON|1|OFF|0}
[SOURce[1|2]:]VOLTage:COUPle[:STATe]?

[SOURce[1|2]:]VOLTage:HIGH {<voltage>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]VOLTage:HIGH? [{MINimum|MAXimum}]

[SOURce[1|2]:]VOLTage:LOW {<voltage>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]VOLTage:LOW? [{MINimum|MAXimum}]

[SOURce[1|2]:]VOLTage:LIMit:HIGH {<voltage>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]VOLTage:LIMit:HIGH? [{MINimum|MAXimum}]

[SOURce[1|2]:]VOLTage:LIMit:LOW {<voltage>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]VOLTage:LIMit:LOW? {MINimum|MAXimum}?

[SOURce[1|2]:]VOLTage:LIMit:STATe {ON|1|OFF|0}
[SOURce[1|2]:]VOLTage:LIMit:STATe?

[SOURce[1|2]:]VOLTage:OFFSet {<offset>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]VOLTage:OFFSet? [{MINimum|MAXimum}]

[SOURce[1|2]:]VOLTage:RANGe:AUTO {OFF|0|ON|1|ONCE}
[SOURce[1|2]:]VOLTage:RANGe:AUTO?

[SOURce[1|2]:]VOLTage:UNIT {VPP|VRMS|DBM}
[SOURce[1|2]:]VOLTage:UNIT?

RECHTECKWELLE

[SOURce[1|2]:]FUNCtion:SQUare:DCYCle {<percent>|MINimum|MAXimum}
[SOURce[1|2]:]FUNCtion:SQUare:DCYCle? [{MINimum|MAXimum}]

[SOURce[1|2]:]FUNCtion:SQUare:PERiod {<seconds>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]FUNCtion:SQUare:PERiod? [{MINimum|MAXimum}]

SÄGEZAHN

[SOURce[1|2]:]FUNCtion:RAMP:SYMMetry {<percent>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]FUNCtion:RAMP:SYMMetry? [{MINimum|MAXimum}]

RAUSCHEN

[SOURce[1|2]:]FUNCtion:NOISe:BANDwidth {<bandwidth>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]FUNCtion:NOISe:BANDwidth? [{MINimum|MAXimum}]

PRBS

[SOURce[1|2]:]FUNCtion:PRBS:BRATe {<bit_rate>| MINimum|MAXimum|DEFault}
[SOURce[1|2]:]FUNCtion:PRBS:BRATe? [{MINimum|MAXimum}]

[SOURce[1|2]:]FUNCtion:PRBS:DATA <sequence_type>
[SOURce[1|2]:]FUNCtion:PRBS:DATA?

[SOURce[1|2]:]FUNCtion:PRBS:TRANsition[:BOTH] {<seconds>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]FUNCtion:PRBS:TRANsition[:BOTH]? [{MINimum|MAXimum}]

ARBITRÄRSIGNAL

[SOURce[1|2]:]FUNCtion:ARBitrary {<filename>}
[SOURce[1|2]:]FUNCtion:ARBitrary?

[SOURce[1|2]:]FUNCtion:ARBitrary:ADVance {TRIGger|SRATe}
[SOURce[1|2]:]FUNCtion:ARBitrary:ADVance?

[SOURce[1|2]:]FUNCtion:ARBitrary:FILTer {NORMal|STEP|OFF}
[SOURce[1|2]:]FUNCtion:ARBitrary:FILTer?

[SOURce[1|2]:]FUNCtion:ARBitrary:FREQuency {<frequency>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]FUNCtion:ARBitrary:FREQuency? {MINimum|MAXimum}

[SOURce[1|2]:]FUNCtion:ARBitrary:PERiod {<period>|MINimum|MAXimum}DEFault}
[SOURce[1|2]:]FUNCtion:ARBitrary:PERiod? {MINimum|MAXimum}

[SOURce[1|2]:]FUNCtion:ARBitrary:POINts?

[SOURce[1|2]:]FUNCtion:ARBitrary:PTPeak {<voltage>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]FUNCtion:ARBitrary:PTPeak? [{MINimum|MAXimum}]

[SOURce[1|2]:]FUNCtion:ARBitrary:SRATe {<sample_rate>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]FUNCtion:ARBitrary:SRATe? {MINimum|MAXimum}

FUNCtion:ARBitrary:BALance[:STATe] {ON|1|OFF|0} (nur IQ Player Option)
FUNCtion:ARBitrary:BALance[:STATe]? (nur IQ Player Option)

FUNCtion:ARBitrary:BALance:GAIN {<percent>|MINimum|MAXimum|DEFine} (nur IQ Player Option)
FUNCtion:ARBitrary:BALance:GAIN? [{MINimum|MAXimum}] (nur IQ Player Option)

FUNCtion:ARBitrary:BALance:OFFSet{1|2} {<volts>|MINimum|MAXimum|DEFault} (nur IQ Player Option)
FUNCtion:ARBitrary:BALance:OFFSet{1|2}? [MINimum|MAXimum] (nur IQ Player Option)

FUNCtion:ARBitrary:SKEW[:STATe] {ON|1|OFF|0} (nur IQ Player Option)
FUNCtion:ARBitrary:SKEW[:STATe]? (nur IQ Player Option)

FUNCtion:ARBitrary:SKEW:TIME [{<time>|MINimum|MAXimum|DEFault}] (nur IQ Player Option)
FUNCtion:ARBitrary:SKEW:TIME? [{MINimum|MAXimum}] (nur IQ Player Option)

[SOURce[1|2]:]FUNCtion:ARBitrary:SYNChronize

[SOURce[1|2]:]RATE:COUPle[:STATe] {ON|1|OFF|0}
[SOURce[1|2]:]RATE:COUPle[:STATe]?

[SOURce[1|2]:]RATE:COUPle:MODE {OFFSet|RATio}
[SOURce[1|2]:]RATE:COUPle:MODE?

[SOURce[1|2]:]RATE:COUPle:OFFSet {<sample_rate>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]RATE:COUPle:OFFSet?

[SOURce[1|2]:]RATe:COUPle:RATio {<ratio>|MINimum|MAXimum}
[SOURce[1|2]:]RATe:COUPle:RATio? [{MINimum|MAXimum}]

Pfeil nach oben

AUSGANG

OUTPut[1|2] {ON|1|OFF|0}
OUTPut[1|2]?

OUTPut[1|2]:LOAD {<ohms>|INFinity|MINimum|MAXimum|DEFault}
OUTPut[1|2]:LOAD? [{MINimum|MAXimum}]

OUTPut[1|2]:MODE {NORMal|GATed}
OUTPut[1|2]:MODE?

OUTPut[1|2]:POLarity {NORMal|INVerted}
OUTPut[1|2]:POLarity?

OUTPut:SYNC {ON|1|OFF|0}
OUTPut:SYNC?

OUTPut[1|2]:SYNC:MODE {NORMal|CARRier|MARKer}
OUTPut[1|2]:SYNC:MODE?

OUTPut[1|2]:SYNC:POLarity {NORMal|INVerted}
OUTPut[1|2]:SYNC:POLarity?

OUTPut:SYNC:SOURce {CH1|CH2}
OUTPut:SYNC:SOURce?

OUTPut:TRIGger {ON|1|OFF|0}
OUTPut:TRIGger?

OUTPut:TRIGger:SLOPe {POSitive|NEGative}
OUTPut:TRIGger:SLOPe?

OUTPut:TRIGger:SOURce {CH1|CH2}
OUTPut:TRIGger:SOURce?

Puls-Konfigurationsbefehle

[SOURce[1|2]:]FUNCtion:PULSe:DCYCle {<percent>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]FUNCtion:PULSe:DCYCle? [{MINimum|MAXimum}]

[SOURce[1|2]:]FUNCtion:PULSe:HOLD {WIDTh|DCYCle}
[SOURce[1|2]:]FUNCtion:PULSe:HOLD?

[SOURce[1|2]:]FUNCtion:PULSe:PERiod {<seconds>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]FUNCtion:PULSe:PERiod? [{MINimum|MAXimum}]

[SOURce[1|2]:]FUNCtion:PULSe:TRANsition[:BOTH] {<seconds>|MINimum|MAXimum|DEFault}

[SOURce[1|2]:]FUNCtion:PULSe:TRANsition:LEADing {<seconds>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]FUNCtion:PULSe:TRANsition:LEADing? [{MINimum|MAXimum}]

[SOURce[1|2]:]FUNCtion:PULSe:TRANsition:TRAiling {<seconds>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]FUNCtion:PULSe:TRANsition:TRAiling? [{MINimum|MAXimum}]

[SOURce[1|2]:]FUNCtion:PULSe:WIDTh {<seconds>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]FUNCtion:PULSe:WIDTh? [{MINimum|MAXimum}]

Pfeil nach oben

Modulationsbefehle

AM

[SOURce[1|2]:]AM[:DEPTh] {<depth_in_percent>|MINimum|MAXimum}
[SOURce[1|2]:]AM[:DEPTh]? [{MINimum|MAXimum}]

[SOURce[1|2]:]AM:DSSC {ON|1|OFF|0}
[SOURce[1|2]:]AM:DSSC?

[SOURce[1|2]:]AM:INTernal:FREQuency {<frequency>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]AM:INTernal:FREQuency? [{MINimum|MAXimum}]

[SOURce[1|2]:]AM:INTernal:FUNCtion <Funktion>
[SOURce[1|2]:]AM:INTernal:FUNCtion?

[SOURce[1|2]:]AM:SOURce {INTernal|EXTernal|CH1|CH2}
[SOURce[1|2]:]AM:SOURce?

[SOURce[1|2]:]AM:STATe {ON|1|OFF|0}
[SOURce[1|2]:]AM:STATe?

FM

[SOURce[1|2]:]FM[:DEViation] {<peak_deviation_in_Hz>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]FM[:DEViation]? [{MINimum|MAXimum}]

[SOURce[1|2]:]FM:INTernal:FREQuency {<frequency>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]FM:INTernal:FREQuency? [{MINimum|MAXimum}]

[SOURce[1|2]:]FM:INTernal:FUNCtion <Funktion>
[SOURce[1|2]:]FM:INTernal:FUNCtion?

[SOURce[1|2]:]FM:SOURce {INTernal|EXTernal|CH1|CH2}
[SOURce[1|2]:]FM:SOURce?

[SOURce[1|2]:]FM:STATe {ON|1|OFF|0}
[SOURce[1|2]:]FM:STATe?

BPSK-Befehle

[SOURce[1|2]:]BPSK:SOURce {INTernal|EXTernal}
[SOURce[1|2]:]BPSK:SOURce?

[SOURce[1|2]:]BPSK:STATe {ON|1|OFF|0}
[SOURce[1|2]:]BPSK:STATe?

[SOURce[1|2]:]BPSK:INTernal:RATE {<modulating_frequency>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]BPSK:INTernal:RATE? [{MINimum|MAXimum}]

[SOURce[1|2]:]BPSK[:PHASe] {<angle>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]BPSK[:PHASe]? [{MINimum|MAXimum}]

Pfeil nach oben

PM

[SOURce[1|2]:]PM:DEViation {<deviation in degrees>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]PM:DEViation? [{MINimum|MAXimum}]

[SOURce[1|2]:]PM:INTernal:FREQuency {<frequency>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]PM:INTernal:FREQuency? [{MINimum|MAXimum}]

[SOURce[1|2]:]PM:INTernal:FUNCtion <function>
[SOURce[1|2]:]PM:INTernal:FUNCtion?

[SOURce[1|2]:]PM:SOURce {INTernal|EXTernal|CH1|CH2}
[SOURce[1|2]:]PM:SOURce?

[SOURce[1|2]:]PM:STATe {ON|1|OFF|0}
[SOURce[1|2]:]PM:STATe?

FSK

[SOURce[1|2]:]FSKey:FREQuency {<frequency>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]FSKey:FREQuency? [{MINimum|MAXimum}]

[SOURce[1|2]:]FSKey:INTernal:RATE {<rate_in_Hz>|MINimum|MAXimum}
[SOURce[1|2]:]FSKey:INTernal:RATE? [{MINimum|MAXimum}]

[SOURce[1|2]:]FSKey:SOURce {INTernal|EXTernal}
[SOURce[1|2]:]FSKey:SOURce?

[SOURce[1|2]:]FSKey:STATe {ON|1|OFF|0}
[SOURce[1|2]:]FSKey:STATe?

PWM

[SOURce[1|2]:]PWM:DEViation {<deviation>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]PWM:DEViation? [{MINimum|MAXimum}]

[SOURce[1|2]:]PWM:DEViation:DCYCle {<deviation_in_pct>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]PWM:DEViation:DCYCle? [{MINimum|MAXimum}]

[SOURce[1|2]:]PWM:INTernal:FREQuency {<frequency>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]PWM:INTernal:FREQuency? [{MINimum|MAXimum}]

[SOURce[1|2]:]PWM:INTernal:FUNCtion <function>
[SOURce[1|2]:]PWM:INTernal:FUNCtion?

[SOURce[1|2]:]PWM:SOURce {INTernal|EXTernal|CH1|CH2}
[SOURce[1|2]:]PWM:SOURce?

[SOURce[1|2]:]PWM:STATe {ON|1|OFF|0}
[SOURce[1|2]:]PWM:STATe?

SUM

[SOURce[1|2]:]SUM:AMPLitude {<amplitude>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]SUM:AMPLitude? [{MINimum|MAXimum}]

[SOURce[1|2]:]SUM:INTernal:FREQuency {<frequency>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]SUM:INTernal:FREQuency? [{MINimum|MAXimum}]

[SOURce[1|2]:]SUM:INTernal:FUNCtion <function>
[SOURce[1|2]:]SUM:INTernal:FUNCtion?

[SOURce[1|2]:]SUM:SOURce {INTernal|EXTernal|CH1|CH2}
[SOURce[1|2]:]SUM:SOURce?

[SOURce[1|2]:]SUM:STATe {ON|1|OFF|0}
[SOURce[1|2]:]SUM:STATe?

Pfeil nach oben

Frequenzwobbelung

[SOURce[1|2]:]SWEep:HTIMe {<hold_time>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]SWEep:HTIMe? [{MINimum|MAXimum}]

[SOURce[1|2]:]SWEep:RTIMe {<return_time>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]SWEep:RTIMe? [{MINimum|MAXimum}]

[SOURce[1|2]:]SWEep:SPACing {LINear|LOGarithmic}
[SOURce[1|2]:]SWEep:SPACing?

[SOURce[1|2]:]SWEep:STATe {ON|1|OFF|0}
[SOURce[1|2]:]SWEep:STATe?

[SOURce[1|2]:]SWEep:TIME {<seconds>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]SWEep:TIME? [{MINimum|MAXimum}]

Betriebsart Burst

[SOURce[1|2]:]BURSt:GATE:POLarity {NORMal|INVerted}
[SOURce[1|2]:]BURSt:GATE:POLarity?

[SOURce[1|2]:]BURSt:INTernal:PERiod {<seconds>|MINimum|MAXimum}
[SOURce[1|2]:]BURSt:INTernal:PERiod? [{MINimum|MAXimum}]

[SOURce[1|2]:]BURSt:MODE {TRIGgered|GATed}
[SOURce[1|2]:]BURSt:MODE?

[SOURce[1|2]:]BURSt:NCYCles {<num_cycles>|INFinity|MINimum|MAXimum}
[SOURce[1|2]:]BURSt:NCYCles? [{MINimum|MAXimum}]

[SOURce[1|2]:]BURSt:PHASe {<angle>|MINimum|MAXimum}
[SOURce[1|2]:]BURSt:PHASe? [{MINimum|MAXimum}]

[SOURce[1|2]:]BURSt:STATe {ON|1|OFF|0}
[SOURce[1|2]:]BURSt:STATe?

Marker

[SOURce[1|2]:]MARKer:CYCle {<cycle_num>|MINimum|MAXimum|DEFault}

[SOURce[1|2]:]MARKer:FREQuency {<frequency>|MINimum|MAXimum|DEFault}

[SOURce[1|2]:]MARKer:POINt {<sample_number>|MINimum|MAXimum}

Triggereinstellung

TRIGger[1|2]

TRIGger[1|2]:COUNt {<number>MINimum|MAXimum|DEFault}
TRIGger[1|2]:COUNt? [{MINimum|MAXimum}]

TRIGger[1|2]:DELay {<seconds>|MINimum|MAXimum}
TRIGger[1|2]:DELay? [{MINimum|MAXimum}]

TRIGger[1|2]:LEVel {<level>|MINimum|MAXimum}
TRIGger[1|2]:LEVel? [{MINimum|MAXimum}]

TRIGger[1|2]:SLOPe {POSitive|NEGative}
TRIGger[1|2]:SLOPe?

TRIGger[1|2]:SOURce {IMMediate|EXTernal|TIMer|BUS}
TRIGger[1|2]:SOURce?

TRIGger[1|2]:TIMer {<seconds>|MINimum|MAXimum}
TRIGger[1|2]:TIMer? [{MINimum|MAXimum}]

Pfeil nach oben

Zustandsspeicher

MEMory:NSTates?

MEMory:STATe:CATalog?

MEMory:STATe:DELete {0|1|2|3|4|}

MEMory:STATe:NAME {0|1|2|3|4} [,<name>]
MEMory:STATe:NAME? {0|1|2|3|4}

MEMory:STATe:RECall:AUTO {ON|1|OFF|0}
MEMory:STATe:RECall:AUTO?

MEMory:STATe:VALid? {0|1|2|3|4}

Massenspeicher

MMEMory:CATalog[:ALL]? [<folder>]

MMEMory:CATalog:DATA:ARBitrary? [<folder>]

MMEMory:CATalog:STATe? [<folder>]

MMEMory:CDIRectory <folder>
MMEMory:CDIRectory?

MMEMory:COPY <file1>,<file2>

MMEMory:COPY:SEQuence <source>,<destination>

MMEMory:DELete <file>

MMEMory:DOWNload:DATA <binary_block>

MMEMory:DOWNload:FNAMe <filename>

MMEMory:LOAD:ALL <filename>

MMEMory:LOAD:DATA[1|2] <filename>

MMEMory:LOAD:LIST[1|2] <filename>

MMEMory:LOAD:STATe <filename>

MMEMory:MDIRectory <folder>

MMEMory:MOVE <file1>,<file2>

MMEMory:RDIRectory <folder>

MMEMory:STORe:ALL <filename>

MMEMory:STORe:DATA[1|2] <filename>

MMEMory:STORe:LIST[1|2] <filename>

MMEMory:STORe:STATe <filename>

MMEMory:UPLoad? <filename>

Display

DISPlay {ON|1|OFF|0}
DISPlay?

DISPlay:TEXT "<string>"
DISPlay:TEXT?

DISPlay:TEXT:CLEar

DISPlay:UNIT:ARBRate {SRATe|FREQuency|PERiod}

DISPlay:UNIT:PULse {WIDTh|DUTY}

DISPlay:UNIT:RATE {FREQuency|PERiod}

DISPlay:UNIT:SWEep {STARtstop|CENTerspan}

DISPlay:UNIT:VOLT {AMPLitudeoff|HIGHlow}

DISPlay:VIEW {STANdard|TEXT|GRAPh|DUAL}

Screenshots

HCOPy:SDUMp:DATA?

HCOPy:SDUMp:DATA:FORMat {PNG|BMP}
HCOPy:SDUMp:DATA:FORMat?

Pfeil nach oben

LXI

LXI:IDENtify[:STATE] {ON|1|OFF|0}
LXI:IDENtify[:STATE]?

LXI:MDNS:ENABle {ON|1|OFF|0}
LXI:MDNS:ENABle?

LXI:MDNS:HNAMe:RESolved?

LXI:MDNS:SNAMe:DESired <name>
LXI:MDNS:SNAMe:DESired?

LXI:MDNS:SNAMe[:RESolved]?

LXI:RESet

LXI:RESTart

Konfiguration der Remoteschnittstelle

SYSTem:COMMunicate:ENABle {ON|1|OFF|0}, <interface>
SYSTem:COMMunicate:ENABle? <interface>

SYSTem:COMMunicate:GPIB:ADDRess <address>
SYSTem:COMMunicate:GPIB:ADDRess?

SYSTem:COMMunicate:LAN:CONTrol?

SYSTem:COMMunicate:LAN:DHCP {ON|1|OFF|0}
SYSTem:COMMunicate:LAN:DHCP?

SYSTem:COMMunicate:LAN:DNS[1|2] "<address>"
SYSTem:COMMunicate:LAN:DNS[1|2]? [{CURRent|STATic}]

SYSTem:COMMunicate:LAN:DOMain?

SYSTem:COMMunicate:LAN:GATeway "<address>"
SYSTem:COMMunicate:LAN:GATeway? [{CURRent|STATic}]

SYSTem:COMMunicate:LAN:HOSTname "<name>"
SYSTem:COMMunicate:LAN:HOSTname? [{CURRent|STATic}]

SYSTem:COMMunicate:LAN:IPADdress "<address>"
SYSTem:COMMunicate:LAN:IPADdress? [{CURRent|STATic}]

SYSTem:COMMunicate:LAN:MAC?

SYSTem:COMMunicate:LAN:SMASk "<mask>"
SYSTem:COMMunicate:LAN:SMASk? [{CURRent|STATic}]

SYSTem:COMMunicate:LAN:TELNet:PROMpt "<string>"
SYSTem:COMMunicate:LAN:TELNet:PROMpt?

SYSTem:COMMunicate:LAN:TELNet:WMESsage "<string>"
SYSTem:COMMunicate:LAN:TELNet:WMESsage?

SYSTem:COMMunicate:LAN:UPDate

SYSTem:COMMunicate:LAN:WINS[1|2] "<address>"
SYSTem:COMMunicate:LAN:WINS[1|2]? [{CURRent|STATic}]

System

SYSTem:BEEPer[:IMMediate]

SYSTem:BEEPer:STATe {ON|1|OFF|0}
SYSTem:BEEPer:STATe?

SYSTem:CLICk:STATe{ON|1|OFF|0}
SYSTem:CLICk:STATe?

SYSTem:DATE <yyyy>, <mm>, <dd>
SYSTem:DATE?

SYSTem:ERRor?

SYSTem:LICense:CATalog?

SYSTem:LICense:DELete "<option_name>"

SYSTem:LICense:DELete:ALL

SYSTem:LICense:DESCription? "<option_name>"

SYSTem:LICense:ERRor?

SYSTem:LICense:ERRor:COUNt?

SYSTem:LICense:INSTall "<file>"
SYSTem:LICense:INSTall? "<option>"

SYSTem:LOCK:NAME?

SYSTem:LOCK:OWNer?

SYSTem:LOCK:RELease

SYSTem:LOCK:REQuest?

SYSTem:SECurity:IMMediate

SYSTem:TIME <hh>, <mm>, <ss>
SYSTem:TIME?

SYSTem:VERSion?

Pfeil nach oben

Phase

[SOURce[1|2]:]PHASe {<angle>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]PHASe? [{MINimum|MAXimum}]

[SOURce[1|2]:]PHASe:ARBitrary {<angle>|MINimum|MAXimum}

[SOURce[1|2]:]PHASe:MODulation {<angle>|MINimum|MAXimum}
[SOURce[1|2]:]PHASe:MODulation?

[SOURce[1|2]:]PHASe:REFerence

[SOURce[1|2]:]PHASe:SYNChronize

[SOURce[1|2]:]PHASe:UNLock:ERRor:STATe {ON|1|OFF|0}
[SOURce[1|2]:]PHASe:UNLock:ERRor:STATe?

Referenzoszillator

ROSCillator:SOURce {INTernal|EXTernal}
ROSCillator:SOURce?

ROSCillator:SOURce:AUTO {ON|OFF}
ROSCillator:SOURce:AUTO?

ROSCillator:SOURce:CURRent?

Kalibrierung

CALibration[:ALL]?

CALibration:COUNt?

CALibration:SECure:CODE <new_code>

CALibration:SECure:STATe {ON|1|OFF|0} [,<code>]
CALibration:SECure:STATe?

CALibration:SETup <step>
CALibration:SETup?

CALibration:STORe

CALibration:STRing "<string>"
CALibration:STRing?

CALibration:VALue <value>
CALibration:VALue?

IEEE-488

*CLS

*ESE <enable_value>

*ESE?

*ESR?

*IDN?

*OPC

*OPC?

*OPT?

*PSC {0|1}
*PSC?

*RCL {0|1|2|3|4}

*RST

*SAV {0|1|2|3|4}

*SRE <enable_value>
*SRE?

*STB?

*TRG

*TST?

*WAI

Pfeil nach oben

Status

STATus:OPERation:CONDition?

STATus:OPERation:ENABle <enable_value>
STATus:OPERation:ENABle?

STATus:OPERation[:EVENt]?

STATus:PRESet

STATus:QUEStionable:CONDition?

STATus:QUEStionable:ENABle <enable_value>
STATus:QUEStionable:ENABle?

STATus:QUEStionable[:EVENt]?

Verschiedenes

ABORt

[SOURce[1|2]:]PHASe:ARBitrary {<angle>|MINimum|MAXimum}
[SOURce[1|2]:]PHASe:ARBitrary?

[SOURce[1|2]:]COMBine:FEED {CH1|CH2|NONE}
[SOURce[1|2]:]COMBine:FEED?

FORMat:BORDer {NORMal|SWAPped}
FORMat:BORDer?

INITiate[1|2]:CONTinuous {ON|1|OFF|0}
INITiate[1|2]:CONTinuous?

INITiate:CONTinuous:ALL {ON|1|OFF|0}

INITiate[1|2][:IMMediate]

INITiate[:IMMediate]:ALL

[SOURce[1|2]:]MARKer:CYCle {<cycle_num>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]MARKer:CYCLe? [{MINimum|MAXimum}]

INPut:ATTenuation[:STATe] {ON|1|OFF|0}
INPut:ATTenuation[:STATe]?

[SOURce[1|2]:]MARKer:FREQuency {<frequency>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]MARKer:FREQuency? [{MINimum|MAXimum}]

[SOURce[1|2]:]MARKer:POINt {<sample_number>|MINimum|MAXimum}
[SOURce[1|2]:]MARKer:POINt? [{MINimum|MAXimum}]

[SOURce[1|2]:]TRACk {ON|OFF|INVerted}
TRACk?

UNIT:ANGLe {DEGree|RADian|SECond|DEFault}
UNIT:ANGLe?

UNIT:ARBitrary:ANGLe {DEGree|RADian|SECond|SAMPle|DEFault}
UNIT:ARBitrary:ANGLe?

Pfeil nach oben


Gerätestatus nach dem Zurücksetzen auf die Werkseinstellungen

In der folgenden Tabelle werden die Standardwerkseinstellungen aufgeführt. Parameter, die mit einem Punkt (•) gekennzeichnet sind, sind nichtflüchtig und werden durch das Aus- und Einschalten des Geräts oder *RST nicht beeinflusst . Andere Parameter sind flüchtig und werden beim Einschalten oder nach *RST auf die angegebenen Werte zurückgesetzt.

Hinweis

Der Einschalt/Zurücksetzen-Status kann sich von dem unten gezeigten unterscheiden, wenn Sie im [System]-Menü den Modus Einschaltstatus laden aktiviert haben. Siehe Abspeichern des Gerätezustands.
Konfiguration des Ausgangskanals
Funktion | Sinus
Verfolgung | Aus
Frequenz | 1 kHz
Frequenzmodus | CW
Frequenzkopplungsstatus | OFF
Frequenzkopplungsmodus | Verhältnis
Frequenzkopplungsverhältnis | 1
Frequenzkopplungs-Offset | 0
Amplitude | 100 mVpp
Offset | 0 VDC
Spannungskopplungsstatus | OFF
Status des Spannungsgrenzwerts | OFF
Oberer Spannungsgrenzwert | 5 V
Unterer Spannungsgrenzwert | -5 V
Spannungseinheit | VPP
Spannungsbereich | AUTO
Status | OFF
Last | 50 Ω
Polarität | Normal
Modus (Normal im Vergleich zu "Gated") | Normal
Synchronisationsimpuls-Polarität | Normal
Sync-Modus | Normal
Konfiguration des Ausgangskanals
Sync-Status | ON
Sync-Quelle | CH1
Triggerquelle | CH1
Triggerflanke | Positiv
Triggerstatus | OFF
Rauschen
Bandbreite | 100 kHz
PRBS
Daten | PN7
Bitrate | 1 kbps
Wechsel | 8,4E-09
Puls
Tastverhältnis | 10%
Periode | 1 ms
Anstiegs-/Abfallflanke | 10 ns
Breite | 0,1 ms
Sägezahn
Symmetrie | 100
Rechteck
Tastverhältnis | 50%
Periode | 1 ms
Arbiträrsignale
Arb | Exponentieller Anstieg
Filter | STEP
Samplingrate | 40 kSa/s
Fortschritt | SRATE
Marker-Punkt | Arb-Wechselpunkt
Amplitudenmodulation
Status | OFF
Modulationsquelle | Intern
Interne Funktion | Sinus
Interne Frequenz | 100 Hz
Tiefe | 100%
DSSC | OFF
Frequenzmodulation
Status | OFF
Modulationsquelle | Intern
Interne Funktion | Sinus
Interne Frequenz | 10 Hz
Abweichung | 100 Hz
FSK-Modulation
Status | OFF
Modulationsquelle | Intern
Interne Rate | 10 Hz
Frequenz | 100 Hz
Phasenmodulation
Status | OFF
Modulationsquelle | Intern
Funktion | Sinus
Frequenz | 10 Hz
Abweichung | 180 Grad
BPSK-Modulation
Status | OFF
Modulationsquelle | Intern
Interne Rate | 10 Hz
Phase | 180 Grad
Pulsbreitenmodulation
Status | OFF
Modulationsquelle | Intern
Funktion | Sinus
Frequenz | 10 Hz
Abweichung | 1 % oder 1E-5 s, abhängig von der Art der Spezifizierung
SUM
Status | OFF
Quelle | Intern
Funktion | Sinus
Frequenz | 100 Hz
Sum Amplitude | 0.10%
Phasensteuerung
Phasenanpassung | 0 Grad
Status "Unlock Error" | OFF
Einheiten | Grad
Referenzoszillator
Quelle Auto | ON
Quelle | Intern
Burst
Status | OFF
Torsignalpolarität | Normal
Mode | Getriggert
Zyklen | 1
Periode | 10 ms
Phase | 0 Grad
Marker-Zyklus | 2
Wobbelung
Status | OFF
Abstand | Linear
Startfrequenz | 100 Hz
Stoppfrequenz | 1 kHz
Zentrale Frequenz | 550 Hz
Spanne | 900 Hz
Markenfrequenz | 500 Hz
Wobbelzeit | 1 s
Haltezeit | 0 s
Reaktionszeit | 0 s
List
Frequenz | 100, 1000, 550 Hz
Punkte | 3
Verzögerung | 1 s
Trigger
Delay | 0 s
Flanke | Positiv
Quelle | Immediate
Timer | 1 s
Continuous starten | ON
Count | 1
Kanalunabhängige Triggerkonfiguration
Continuous All starten | ON
Verschiedenes
Format-Byte-Reihenfolge | Normal
Combine Feed | NONE
Die nachfolgenden Themen beziehen sich nicht auf die Kanalkonfiguration.
Display
Status | ON
Text ""
Hcopy-Format | PNG
Remote-Schnittstellenkommunikation
GPIB-Adresse • | 10
DHCP • | Aktiviert
statische IP-Adresse • | 169.254.5.21
statische Subnetzmaske • | 255.255.0.0
Stat. Gateway • | 0.0.0.0
primärer DNS-Server • | 0.0.0.0
sekundärer DNS-Server • | 0.0.0.0
statischer Hostname • | "A-33xxxx-nnnnn" oder "A-33xxxx-nnnnn", wobei xxxx die letzten drei Ziffern der Modellnummer und nnnnn die letzten fünf Ziffern der Seriennummer des Geräts sind
Telnet-Anzeige • | 33xxxx>, wobei xxxx die letzten vier Ziffern der Modellnummer sind.
Telnet-Begrüßungsnachricht • | Welcome to Keysight's 33xxxx Wellenformgenerator, wobei xxxx die letzten vier Ziffern der Modellnummer sind.
primärer WINS-Server • | 0.0.0.0
sekundärer WINS-Server • | 0.0.0.0
System
Signaltonstatus | ON
Power Down Recall • | OFF
LXI
Identifikation | OFF
Kalibrierung
Kalibrierzustand | Geschützt

Hinweis

Das Gerät verwendet den LAN-Anschluss 5024 für SCPI Telnet-Sitzungen und Anschlus 5025 für SCPI Socket-Sitzungen.


SCPI-Fehlermeldungen

Das Gerät gibt Fehlermeldungen gemäß SCPI-Standard aus.

  • Es können in jedem schnittstellenspezifischen Error-Queue des Gerätes bis zu 20 Befehlssyntax- oder Hardware-Fehlermeldungen gespeichert werden (jeweils eine für GPIB, USB, VXI-11 und Telnet/Sockets.) Fehler werden in der Fehler-Queue der I/O-Sitzung angezeigt, in welcher der Fehler verursacht wurde.
  • Das Gerät gibt bei jeder Fehlergenerierung einen Signalton ab (außer diese Option ist mit dem Befehl SYSTem:BEEPer:STATe OFF deaktiviert). Die ERROR-Anzeige der Frontplatte schaltet sich ein, wenn sich ein oder mehrere Fehler in der Fehlerwarteschlange befinden.
  • Eine spezielle allgemeine Fehlerwarteschlange enthält alle einschalt- und hardwarebezüglichen Fehler (z.B. Überhitzung).
  • Die Fehlerabfrage erfolgt gemäß dem Prinzip First In - First Out (FIFO), Fehler werden beim Lesen gelöscht. Sobald Sie alle schnittstellenspezifischen Fehler abgerufen haben, werden die Fehler in der allgemeinen Fehlerwarteschlange abgerufen. Wenn Sie alle Fehlermeldungen aus der allgemeinen Fehler-Queue abgefragt haben, schaltet sich die ERROR-Anzeige aus.
  • Bei über 20 Fehlern wird der letzte Fehler in der Warteschlange (der zuletzt aufgetretene Fehler) durch -350 ("Error queue overflow") ersetzt. Wenn Sie keine Fehler aus der Warteschlange entfernen, werden keine weiteren Fehler gespeichert. Enthält die Fehlerwarteschlange beim Auslesen keine Fehlermeldungen, erfolgt die Meldung +0, „No error“.
  • Die Frontplatte meldet Fehler aus allen I/O-Sitzungen und aus der allgemeinen Fehler-Queue. Um die Fehler-Queue über die Frontplatte abzulesen, drücken Sie auf die Schaltfläche [System] und dann auf den Softkey Help. Dann wählen Sie "View remote command error queue" im Hilfe-Menü.
  • Fehlerbedingungen werden auch im Status Byte-Register zusammengefasst. Weitere Informationen dazu unter Einführung in das Status Subsystem
  • Die schnittstellenspezifischen Fehlerwarteschlangen werden beim Ein- und Ausschalten und durch den Befehl *CLS gelöscht. Die Fehler-Queue wird nicht gelöscht durch *RST.
  • SCPI:

SYSTem:ERRor? Einen Fehler aus der Warteschlange lesen und löschen

Fehlermeldungen haben das folgende Format (der Fehlerstring kann bis zu 255 Zeichen enthalten):

-113,"Undefined header"

Pfeil nach oben

-315 Configuration memory lost; due to firmware revision change

-315 Configuration memory lost; memory corruption detected

-314 Save/recall memory lost; due to firmware revision change

-314 Save/recall memory lost; memory corruption detected

-313 Calibration memory lost

-313 Calibration memory lost; due to firmware revision change

-313 Cannot read file; due to corrupt data

-313 Cannot read file; due to file revision change

-313 Invalid number of channels for operation

-310 System error; internal software error

-310 System error; out of memory

-310 System error; software initialization failed

-292 Referenced name does not exist

-257 File name error;

access denied

drive name missing or not recognized

file or folder already exists

file too large

folder is default folder

folder not empty

invalid character in name

not a folder name

path is a folder name

path name missing

path too long

relative path not allowed

unknown file extension

Pfeil nach oben

-256 File or folder name not found

-254 Media full

-252 Missing media

-250 Mass storage error: file read/write error

-241 Hardware missing

-241 Hardware missing; Command not valid in one channel instrument.

-240 Hardware error; GPIB interface failed

-230 Data corrupt or stale

-222 Data out of range;

AM depth

amplitude

arb frequency

arb period

burst count

burst count limited by length of burst

burst period

burst period limited by length of burst

cannot combine channel with itself. Combine disabled

duty cycle

duty cycle limited by frequency

FM deviation

FM deviation limited by maximum frequency

FM deviation limited by minimum frequency

frequency

frequency in burst mode

frequency in FM

high level limited by high soft limit

high level limited by low level

high level limited by low soft limit

high limit value limited by high signal level

large period limits minimum pulse width

low level limited by high level

low level limited by high soft limit

low level limited by low soft limit

low limit value limited by low signal level

marker confined to burst cycles

marker confined to sweep span

offset

period

PRBS edge time

PRBS edge time limited by bit rate

pulse duty cycle limited by period

pulse edge at maximum

pulse edge at minimum

pulse edge time

pulse edge time limited by duty cycle

pulse edge time limited by period

pulse edge time limited by width

pulse frequency

pulse period

pulse width

pulse width limited by period

PWM deviation

PWM deviation limited by pulse parameters

ramp frequency

ramp Symmetry

Sample rate

sample rate clipped to lower limit

sample rate clipped to upper limit

square edge time

square edge time limited by duty cycle

square edge time limited by period

square edge time limited by width

square period

square width

sum amplitude limited by channel or combine amplitudes

sum amplitude value clipped to lower limit

sweep time

Track exceeds limits on channel 1. Tracking disabled

Track exceeds limits on channel 2. Tracking disabled

trigger count clipped to lower limit

trigger count clipped to upper limit

trigger delay

trigger delay clipped to lower limit

trigger delay clipped to upper limit

trigger delay limited by length of burst

trigger level clipped to lower limit (nur 33600 Series)

trigger level clipped to upper limit (nur 33600 Series)

trigger level (nur 33600 Series)

trigger timer clipped to lower limit

trigger timer clipped to upper limit

trigger timer limited by length of burst

user frequency

USER setting only valid for channel 1

value clipped to dwell time's lower limit

value clipped to dwell time's upper limit

value clipped to lower limit

value clipped to sweep time's lower limit

value clipped to upper limit

value limited due to coupling

-222 List Data out of range; Arb frequency : Mode is changed to Normal (nur 33600 Series)

-222 List Data out of range; Pulse frequency : Mode is changed to Normal

-222 List Data out of range; Ramp frequency : Mode is changed to Normal

-222 List Data out of range; Sine frequency : Mode is changed to Normal

-222 List Data out of range; Square frequency : Mode is changed to Normal

-222 List Data out of range; User frequency : Mode is changed to Normal

Pfeil nach oben

-221 Setting the advance mode to trigger forced the trigger source to external.

-221 Setting the Arb Filter OFF changed the maximum sample rate value to 6.25e7.

-221 Setting the trigger source changed the arb advance mode.

-221 Settings conflict;

50V input range not compatible with 50 ohm input impedance; impedance set to 1 Mohm

AM depth forced amplitude change

AM turned off by selection of other mode or modulation

amplitude changed due to function

amplitude changed due to offset

amplitude units changed to Vpp due to high-Z load

amplitude units changed to Vpp, dBm and Vrms not applicable to arb sequences

amplitude units unchanged, dBm and Vrms not applicable to arb sequences

arb advance changed to SRATE due to filter (nur 33600 Series)

arb advance changed to SRATE due to mode

arb voltage reduced due to output load or limits

Balance gain limited due to amplitude.

Balance offset changed due to amplitude

both edge times decreased due to period

both edge times decreased due to pulse duty cycle

both edge times decreased due to pulse width

BPSK turned off by selection of other mode or modulation

burst count reduced to fit entire burst

Burst mode has caused output phase to be set to zero degrees

burst period increased to fit entire burst

burst phase inapplicable for arbs larger than 1M. burst phase set to 0 (nur 33500 Series)

burst turned off by selection of other mode or modulation

Cannot combine DC function

cannot delete state selected and enabled for automatic power-on recall

Cannot modulate ARB carrier with ARB as modulation function. Modulation turned off.

Cannot modulate ARB carrier with ARB modulation function. Function unchanged.

Cannot modulate ARB carrier with USER as modulation function. Modulation turned off.

Cannot modulate ARB carrier with USER modulation function. Function unchanged.

Cannot modulate by a two-channel Arb

Cannot modulate Noise carrier with Noise as modulation function. Modulation turned off.

Cannot modulate Noise carrier with Noise modulation function. Function unchanged.

Cannot modulate PRBS carrier with PRBS as modulation function. Modulation turned off.

Cannot modulate PRBS carrier with PRBS modulation function. Function unchanged.

Cannot modulate USER carrier with ARB as modulation function. Modulation turned off.

Cannot modulate USER carrier with ARB modulation function. Function unchanged.

Cannot modulate USER carrier with USER as modulation function. Modulation turned off.

Cannot modulate USER carrier with USER modulation function. Function unchanged.

Cannot select channel as modulating source

Cannot use filter in advance arb trigger mode. (nur 33600 Series)

combine amplitude exceeds limit. Combine disabled

Combine turned off by selection of DC function

coupling cannot be ON with this function, coupling turned off

coupling violates settings, coupling turned off

edge time decreased due to bit rate

external gating not compatible with gate output; gate output disabled

FM deviation cannot exceed carrier

FM deviation exceeds maximum frequency

FM turned off by selection of other mode or modulation

frequency changed for pulse function

frequency changed for sine function (nur 33600 Series)

frequency changed for square function (nur 33600 Series)

frequency forced duty cycle change

frequency made compatible with burst mode (nur 33500 Series)

frequency reduced for ramp function

frequency reduced for user function

FSK turned off by selection of other mode or modulation

Function or modulation source cannot be USER. Tracking disabled

Function selection limited the FSK frequency.

Gated output not available for gated burst. Output mode changed to normal.

high level changed due to low level

high limit less than low limit. Limits disabled

infinite burst changed trigger source to BUS

input threshold voltage > input range; threshold clipped to range

leading edge time decreased due to period

leading edge time decreased due to pulse width

leading edge times decreased due to pulse duty cycle

limited frequency to 1MHz when sync mode carrier, burst ON, and function sine (nur 33500 Series)

list turned off by selection of other mode or modulation

low level changed due to high level

low reference >= high reference

marker forced into sweep span

marker off forced sync to normal mode

marker on forced sync to marker mode

marker point changed to fit arb length

modulation frequency made compatible with modulation shape

must stop operation to update trigger count

must stop operation to update trigger delay

not able to adjust phase for arb < 64 samples (nur 33600 Series)

not able to adjust phase in this function

not able to adjust phase in this mode

not able to burst DC, burst turned off

not able to burst this function

not able to change output load with limits enabled

not able to list arb, list turned off

not able to list DC, list turned off

not able to list noise, list turned off

not able to list PRBS, list turned off

not able to list this function

not able to modulate arb, modulation turned off

not able to modulate DC, modulation turned off

not able to modulate noise, modulation turned off

not able to modulate PRBS, modulation turned off

not able to modulate this function

not able to sweep arb, sweep turned off

not able to sweep DC, sweep turned off

not able to sweep noise, sweep turned off

not able to sweep PRBS, sweep turned off

not able to sweep this function

offset changed due to amplitude

offset changed on exit from DC function

PM turned off by selection of other mode or modulation

prbs edge time increased due to amplitude (nur 33600 Series)

pulse duty cycle and edge times increased due to amplitude (nur 33600 Series)

pulse duty cycle decreased due to period

pulse duty cycle increased due to amplitude (nur 33600 Series)

pulse duty cycle increased due to period

pulse edge times increased due to amplitude (nur 33600 Series)

pulse width and edge times increased due to amplitude (nur 33600 Series)

pulse width decreased due to period

pulse width increased due to amplitude (nur 33600 Series)

pulse width increased due to large period

PWM deviation decreased due to pulse parameters

PWM only available in pulse function

PWM turned off by selection of other mode or modulation

Range hold turned off by selection of new function (nur 33600 Series)

selected arb is missing, changing selection to default

selecting a sequence turned off modulation

sequences not supported, changing selection to default

signal exceeds high limit. Limits disabled

signal exceeds low limit. Limits disabled

Skew time between channels not available in Burst, Modulation, or Sweep

sum amplitude exceeds limit or range. Sum disabled

SUM turned off by selection of other mode or modulation

Sweep + Hold + Return time larger than trigger TIMER. Trig timer increased.

Sweep + Hold + Return time max (8000s) limited time setting.

Sweep + Hold + Return time max (8000s) limited time setting.

Sweep + Hold + Return time too large for IMM or TIMER trigger. Sweep turned off.

Sweep + Hold + Return time too large for IMM or TIMER trigger. Trig source unchanged.

Sweep time reduced due to log sweep setting.

sweep turned off by selection of other mode or modulation

Tracking turned off by selection of USER function or modulation source

trailing edge decreased due to leading edge

trailing edge time decreased due to period

trailing edge time decreased due to pulse width

trailing edge times decreased due to pulse duty cycle

trigger delay reduced to fit entire burst

trigger output connector used by BPSK

trigger output connector used by burst gate

trigger output connector used by FSK

trigger output connector used by trigger external

trigger output disabled

trigger output disabled by trigger external

Trigger source limited the sweep time; value clipped to upper limit

triggered burst not available for noise

turned off infinite burst to allow immediate trigger source

Use FUNC:ARB to select an ARB before selecting ARB as modulation function. Function unchanged.

Use FUNC:ARB to select an ARB before selecting ARB as modulation function. Modulation disabled.

Use FUNC:USER to select a user arb before selecting USER as modulation function. Function unchanged.

Use FUNC:USER to select a user arb before selecting USER as modulation function. Modulation disabled.

Pfeil nach oben

-213 INIT ignored

-203 Command protected; Enter calibration password from front panel calibration menu (nur 33500 Series)

-203 Command protected; instrument must be unsecured (nur 33600 Series)

-203 Command protected; requires license BWD (nur 33600 Series)

-203 Command protected; requires license SEC (nur 33600 Series)

-203 Secure option: Instrument security is unlocked

-115 Invalid parameter; Parameter not supported on one channel instrument

-114 Header suffix out of range

100 Network Error

110 LXI mDNS Error

201 Memory lost: stored state

202 Memory lost: power-on state

203 Memory lost: stored measurements

263 Not able to execute while instrument is measuring

291 Not able to recall state: it is empty

292 State file size error

293 State file corrupt

301 Cannot reset input protection; high voltage present

305 Not able to perform requested operation

514 Not allowed

514 Not allowed; Instrument locked by another I/O session

521 Communications: input buffer overflow

522 Communications: output buffer overflow

532 Not able to achieve requested resolution

540 Cannot use overload as math reference

550 Not able to execute command in local mode

560 No valid external timebase

561 High voltage present on input channel

570 DDS Processor is not responding

580 Reference phase-locked loop is unlocked

581 Waveform DAC Timing is unlocked (nur 33600 Series)

581 Waveform DAC Timing regained lock (nur 33600 Series)

582 The DATA controller failed to lock for WFDAC (nur 33600 Series)

582 The MU controller failed to lock for WFDAC (nur 33600 Series)

582 The SYNC controller failed to lock for WFDAC (nur 33600 Series)

Pfeil nach oben

600 Internal licensing error

601 License file corrupt or empty

602 No valid licenses found for this instrument

603 Some licenses could not be installed

604 License not found

605 License already installed

Die meisten Fehlermeldungen zwischen 600 und 699 beziehen sich auf Selbsttestfehler. Weitere Informationen finden Sie unter Selbsttest-Verfahren.

Pfeil nach oben

701 Calibration error; security defeated by hardware jumper

702 Calibration error; calibration memory is secured

703 Calibration error; secure code provided was invalid

704 Calibration error: secure code too long

705 Calibration error; calibration aborted

706 Calibration error; provided value is out of range

707 Calibration error: computed correction factor out of range

707 Calibration error; signal input is out of range

708 Calibration error: signal measurement out of range

709 Calibration error: no calibration for this function/range

710 Calibration error: full scale correction out of range

710 Selbstkalibrierung fehlgeschlagen

711 Calibration error: calibration string too long

711 Selbstkalibrierung fehlgeschlagen

712 Calibration failed

712 Selbstkalibrierung fehlgeschlagen

715 Selbstkalibrierung fehlgeschlagen

720 Selbstkalibrierung fehlgeschlagen

740 Calibration data lost: secure state

741 Calibration data lost: string data

742 Calibration data lost: corrections

748 Calibration memory write failure

770 Nonvolatile arb waveform memory corruption detected

781 Not enough memory to store new arb waveform; bad sectors

781 Not enough memory to store new arb waveform; use DATA:DELETE

782 Cannot overwrite a built-in arb waveform

784 Name of source arb waveform for copy must be VOLATILE

785 Specified arb waveform does not exist

786 Not able to delete a built-in arb waveform

786 Specified arb waveform already exists

787 Not able to delete the currently selected active arb waveform

787 Specified arb not loaded in waveform memory

788 Could not load specified arb; Loaded Built-in default arb

791 Firmware update error; unable to begin download

792 Firmware update error; programming operation failed

793 Firmware update error; data record invalid character

794 Firmware update error; data record length mismatch

795 Firmware update error; data record checksum mismatch

796 Firmware update error; bad checksum for download start

797 Firmware update error; bad checksum for download complete

798 Firmware update error; download in progress

799 Firmware update error; unable to complete download

Pfeil nach oben

800 Firmware update error; invalid programming address

810 State has not been stored

850 Calibration error; set up is invalid

851 Calibration error; set up is out of order

870 Arb: Text File Format error; invalid format

871 Arb: Segment name is too long

872 Arb: File name is too long

873 Arb: Too many sequence steps

874 Arb: Too many segments defined

875 Arb: Too many sequences defined

876 Arb: Sequence already defined

877 Arb: Segment not found

878 Arb: Sequence not found

879 Arb: Segment edit too large

880 Arb: Out of memory

881 Arb: Channel count mismatch

881 Arb: Values are out of range

882 Arb: Segment too small

883 Arb: Error in closing file

884 Arb: Seek too large

885 Arb: Arb file cannot be stored as sequence file

886 Arb: Sequence file cannot be stored as arb file

887 File name error; not a valid extension

888 Arb: Could not create built in arb directory

889 Arb: Could not copy built in arb

890 enable combine forced tracking off

891 enable coupling forced tracking off

892 enable tracking forced coupling off

893 enable tracking forced combine off

894 Enable tracking forced range hold off (nur 33600 Series)

Pfeil nach oben


Service und Reparatur - Einführung

Dieser Abschnitt enthält grundlegende Service-Informationen für Ihr Gerät.

Verfügbare Service-Arten

Reinigung

Vorsichtsmaßnahmen gegen elektrostatische Entladung (ESD)

Ausführlichere Service-Informationen finden Sie hier:

Blockdiagramm - 33500 Series

Blockdiagramm - 33600 Series

Stromversorgungen - 33500 Series

Stromversorgungen - 33600 Series

Fehlerbehebung - 33500 Series

Fehlerbehebung - 33600 Series

Selbsttests

Ersatzteile

Demontage - 33500 Series

Demontage - 33600 Series

Batterieaustausch

Installation der optionalen GPIB-Schnittstelle

Verfügbare Service-Arten

Tritt bei Ihrem Gerät innerhalb der Garantiezeit eine Funktionsstörung auf, wird die Einheit gemäß den Garantiebedingungen von Keysight Technologies repariert oder ausgetauscht. Nach Ablaufen der Garantiefrist bietet Keysight Reparaturservices zu günstigen Preisen.

Erweiterte Service-Verträge

Für zahlreiche Keysight-Produkte stehen optionale Service-Verträge zur Verfügung, die auch nach dem Standardgarantiezeitraum gelten.

Inanspruchnahme von Serviceleistungen (weltweit)

Um Serviceleistungen für Ihr Gerät in Anspruch zu nehmen, wenden Sie sich an das nächstgelegene Keysight Technologies Service Center. Dort werden Reparatur oder Austausch Ihres Geräts organisiert; ggf. erhalten Sie Informationen zu Garantie oder Reparaturkosten. Im Keysight Technologies Service Center erhalten Sie auch Versandhinweise (u. a., welche Komponenten versandt werden müssen). Keysight empfiehlt, den Originalkarton für Rücksendungen aufzubewahren.

Verpackung für den Versand

So bereiten Sie Ihr Gerät zum Versand vor, wenn es für Service oder Reparatur an Keysight gesandt werden muss:

  • Befestigen Sie ein Etikett am Gerät, das den Namen des Eigentümers und die erforderlichen Reparatur-/Serviceleistung angibt. Geben Sie darauf auch die Modellnummer und die vollständige Seriennummer an.
  • Geben Sie das Gerät mit entsprechendem Verpackungsmaterial in den Originalbehälter.
  • Sichern Sie den Karton mit starkem Klebeband oder Metallbändern.
  • Steht der Originalbehälter nicht mehr zur Verfügung, verwenden Sie einen Karton, der mindestens 10 cm Platz für verdichtbares Verpackungsmaterial um das gesamte Gerät bietet. Verwenden Sie antistatische Verpackungsmaterialien.

Keysight empfiehlt, stets versicherte Versandarten zu nutzen.

Reinigung

Reinigen Sie die Außenseiten des Geräts mit einem weichen, faserfreien und nur mit Wasser leicht angefeuchteten Tuch. Verwenden Sie keine Reinigungsmittel oder alle Arten von Sprays. Eine Demontage ist für die Reinigung nicht erforderlich und wird nicht empfohlen.

Vorsichtsmaßnahmen gegen elektrostatische Entladung (ESD)

Nahezu alle elektrischen Komponenten können bei der Handhabung durch elektrostatische Entladung (ESD) beschädigt werden. Eine Beschädigung des Geräts kann bereits bei Entladespannungswerten von 50 V auftreten.

Folgende Hinweise können dazu beitragen, ESD-Schäden bei Service-Vorgängen zu verhindern:

  • Geräte nur in einem antistatischen Arbeitsbereich auseinandernehmen.
  • Nutzen Sie einen leitenden Arbeitsbereich, um statische Aufladung zu verhindern.
  • Nutzen Sie eine leitfähige Handschlaufe, um die statische Aufladung zu verringern.
  • Reduzieren Sie die Handhabung des Geräts so weit wie möglich.
  • Bewahren Sie Ersatzteile in Ihrer antistatischen Originalverpackung auf.
  • Entfernen Sie alle Materialien, die statische Aufladungen erzeugen können, aus dem unmittelbaren Arbeitsbereich.
  • Verwenden Sie ausschließlich antistatische Entlötpumpen.


Einführung in die Kalibrierung - 33500 Series

Dieses Kapitel enthält Verfahren zur Überprüfung von Leistung und Einstellung (Kalibrierung) des Geräts.

Bei diesem Instrument wird die Kalibrierung elektronisch bei geschlossenem Gehäuse vorgenommen. Interne mechanische Einstellungen sind nicht erforderlich. Das Instrument berechnet Korrekturfaktoren auf der Basis Ihrer Eingabereferenzwerte und legt die Korrekturfaktoren im permanenten Speicher ab, bis die nächste Kalibrierungseinstellung durchgeführt wird. Diese Daten werden durch Ein- und Ausschalten oder den Reset-Befehl *RST nicht verändert.

Keysight Technologies Kalibrierungsservice

Ihr Keysight Technologies Service Center bietet eine kostengünstige Neukalibrierung. Das Service Center nutzt automatisierte Kalibrierungssysteme, so dass Keysight diesen Service zu attraktiven Preisen anbieten kann.

Kalibrierung Inhalt

Dieser Abschnitt umfasst die folgenden Abschnitte:

Überblick über die Kalibrierung

  • Kalibrierungsintervall
  • Einstellung wird empfohlen
  • Erforderliche Zeit für die Kalibrierung
  • Automatisierte Kalibrierungsverfahren
  • Empfohlene Testausrüstung
  • Überlegungen zum Test
  • Kalibrierungszahl
  • Kalibrierungsmeldung

Kalibrierungssicherheit

Leistungsüberprüfungstests

  • Selbsttest
  • Leistungsschnelltest
  • Leistungsüberprüfungstests
  • Prüfverfahren für Amplitude und Frequenzgang

Interne Zeitbasisprüfung

Überprüfung AC-Amplitude (hochohmige Last)

Überprüfung DC-Offsetspannung

Überprüfung des -8 dB Frequenzgangbereichs

Überprüfung des -24 dB Frequenzgangbereichs

Allgemeines Kalibrierungs-/Anpassungsverfahren

Laufende Kalibrierung abbrechen

Anpassungssequenz

Selbsttest

Frequenzanpassung (interne Zeitbasis)

Anpassung des internen A/D-Konverters

Anpassung der Selbstkalibrierung

Anpassung der Ausgangsimpedanz

Anpassung der AC-Amplitude (hochohmige Last)

Anpassung des -24 dB Frequenzgangbereichs

Anpassung des -8 dB Frequenzgangbereichs

Kanal 2 anpassen (falls erforderlich)

  • Anpassung der Selbstkalibrierung (Kanal 2)
  • Anpassung der Ausgangsimpedanz (Kanal 2)
  • Anpassung der AC-Amplitude (hochohmige Last) (Kanal 2)
  • Anpassung des -24 dB Frequenzgangbereichs (Kanal 2)
  • Anpassung des -8 dB Frequenzgangbereichs (Kanal 2)

Kalibrierungsfehler

Nächstes Kalibrierungsthema


Überblick über die Kalibrierung - 33500 Series

Dieser Abschnitt gibt eine Einführung in die Kalibrierfunktionen des Geräts. Ausführlichere Informationen zur Kalibrierung finden Sie unter Einführung in die Kalibrierung.

Kalibrierungsintervall

Das Gerät sollte in regelmäßigen Intervallen kalibriert werden, die durch die Anforderungen Ihrer Anwendung an die Genauigkeit bestimmt werden. Für die meisten Anwendungen reicht ein einjähriges Intervall aus. Garantie für Genauigkeitsspezifikationen wird nur übernommen, falls die Einstellung in regulären Kalibrierungsintervallen stattfindet. Garantie für Genauigkeitsspezifikationen wird nicht übernommen, wenn das einjährige Kalibrierungsintervall nicht eingehalten wird. Keysight Technologies empfiehlt für keine Anwendung ein Kalibrierungsintervall von mehr als 2 Jahren.

Einstellung wird empfohlen

Welches Kalibrierungsintervall Sie auch wählen, Keysight Technologies empfiehlt, die vollständige Neueinstellung stets zum Kalibrierungsintervall durchzuführen. Dies gewährleistet, dass das Gerät während des Kalibrierungsintervalls innerhalb der Spezifikationen bleibt und bietet die beste Langzeitstabilität. Leistungsdaten, die mit dieser Methode gemessen wurden, können verwendet werden, um spätere Kalibrierungsintervalle auszudehnen. Verwenden Sie die Kalibrierungszahl, um zu prüfen, ob alle Einstellungen durchgeführt wurden.

Erforderliche Zeit für die Kalibrierung

Bei eingehender Geräteprüfung führen Sie zunächst die Leistungsüberprüfungstests durch. Nehmen Sie die Einstellungen vor und führen Sie die Leistungsüberprüfungstests erneut aus. Jeder dieser Schritte dauert bei manueller Durchführung etwa 30 Minuten pro Kanal.

Das Gerät kann auch automatisch unter Computersteuerung kalibriert werden. Bei der Computersteuerung können Sie das gesamte Kalibrierungsverfahren und die Leistungsüberprüfungstests in etwa 30 Minuten (ein Kanal) oder 60 Minuten (zwei Kanäle) durchführen, sobald das Gerät aufgewärmt ist (siehe Überlegungen zum Test).

Automatisierte Kalibrierungsverfahren

Sie können eine programmierbare Testausrüstung verwenden, um die gesamten Überprüfungs- und Anpassungsvorgänge zu automatisieren. Sie können jede Gerätekonfiguration des Tests über die Remoteschnittstelle konfigurieren. Dann geben Sie die abgelesenen Messdaten in ein Testprogramm ein und vergleichen die Ergebnisse mit den entsprechenden Testgrenzwerten.

Sie können das Gerät auch über die Remoteschnittstelle einstellen, der Vorgang entspricht der Einstellung über die Frontplatte. Verwenden Sie einen Computer für die Einstellungen, wählen Sie dabei zunächst die erforderliche Funktion und den Bereich auf der Messausrüstung aus. Senden Sie den Kalibrierungswert an das Gerät und starten Sie anschließend die Kalibrierung über die Remoteschnittstelle.

Sie müssen vor der Kalibrierung den Kalibrierschutz des Geräts aufheben.

Eine typische Programmiersequenz für einen Kalibrierungs-Setup sieht wie folgt aus:

  1. CAL:SETup 2 (konfiguriert das Gerät für Kalibrierungsschritt 2)
  2. Messung der Ausgangsfrequenz mit dem externen Frequenzzähler
  3. CAL:VALue 9.99994321E6 (sendet den gemessenen Wert an das Gerät)
  4. CAL? (startet die Kalibrierungseinstellung für Setup 2)
  5. Abgefragten Wert CAL? ablesen, um Misslingen (+1) oder Erfolg (+0) der Einstellung festzustellen
  6. CAL:SETup 3 (konfiguriert das Gerät für Kalibrierungsschritt 3)

Weitere Informationen zur Geräteprogrammierung unter Einführung in die SCPI-Sprache.

Empfohlene Testausrüstung

Die empfohlene Testausrüstung für Leistungsüberprüfung und Einstellungsverfahren ist nachstehend aufgeführt. Falls das empfohlene Instrument nicht verfügbar ist, verwenden Sie Kalibrierungsstandards von gleicher Genauigkeit.

Gerät | Anforderungen | Empfohlenes Modell | Verwendung*
Digitalmultimeter (DMM) | ACV, True RMS, AC-gekoppelte Genauigkeit: ±0,02% bis 1 MHz DC-Spannungsgenauigkeit: 50 ppm Auflösung: 100 µV Widerstandsgenauigkeit mit Offset-Ausgleich: ±0,1 Ω | Keysight 3458A | Q, P, T
Präzisions-AC-Spannungsmesser | 1000 Hz bis 30 MHz 0,1 Vrms bis 2 Vrms (–7 dBm bis +20 dBm) Genauigkeit: 0,02 dB Auflösung: 0,01 dB | Fluke 5790A | Q, P, T
Frequenzzähler | Genauigkeit: 0,1 ppm | Keysight 53132A Opt 012 (Hochstabilität) | Q, P, T
Oszilloskop | 1 GHz 4 Gs/Sekunde 50 Ω Eingangsbegrenzung | Keysight MSO6104A | T
Adapter | N Typ (m) bis BNC (m) | Keysight E9623A | Q, P, T
Kabel (2 erforderlich) | Doppelbananenstecker (m) an Doppelbananenstecker (m) | Keysight 11000-60000 | Q, P, T
Kabel | RG58, BNC (m) an Doppelbananenstecker ODER RG58 Koaxialkabel mit BNC (m) an Doppelbananenstecker | Keysight 11001-60001 | Q, P, T
Kabel | RG58, BNC (m) an BNC (m) | Keysight 11170C | Q, P, T

* Q = Quick Verification (Schnellüberprüfung) P = Performance Verification (Leistungsüberprüfung) T = Troubleshooting (Fehlerbehebung)

Überlegungen zum Test

Für optimale Leistung sollten alle Verfahren folgenden Empfehlungen entsprechen:

  • Die Umgebungstemperatur bei der Kalibrierung muss stabil bleiben und zwischen 18 und 28 °C liegen. Idealerweise liegt sie bei 23 ±1 °C.
  • Stellen Sie sicher, dass die relative Luftfeuchtigkeit unter 80 % beträgt.
  • Einstündiges Warmlaufen vor einer Überprüfung oder einer Einstellung.
  • Messkabel so kurz wie möglich, in Übereinstimmung mit den Anforderungen an die Kabelimpedanz.
  • RG-58 oder gleichwertiges 50 Ω Kabel.

Kalibrierungszahl

Sie können das Instrument abfragen, um zu bestimmen, wie viele Kalibrierungen durchgeführt wurden. Das Gerät wurde im Werk kalibriert. Wenn Sie das Gerät erhalten, sollten Sie den Kalibrierungszähler ablesen, um den Ausgangswert zu bestimmen.

  • Die Einstellung ist permanent; sie bleibt bei einem Aus- und Wiedereinschalten des Geräts oder einem *RST erhalten.
  • Da der Wert für jeden Kalibrierungspunkt inkrementiert, der einen Wert speichert, erhöht eine vollständige Kalibrierung den Wert um viele Zahlen.
  • Frontplatte: Systemtaste Softkey Instr Setup Softkey Calibrate
  • SCPI: CAL:COUNt?

Kalibrierungsmeldung

Sie können eine Meldung mit bis zu 40 Zeichen im Kalibrierungsspeicher ablegen. Sie können zum Beispiel das Datum der letzten Kalibrierung speichern, das Fälligkeitsdatum der nächsten Kalibrierung, die Seriennummer des Geräts oder die Kontaktinformationen Ihrer Kalibrierungsexperten.

Kalibrierschutz des Gerätes deaktivieren, um eine neue Kalibrierungsmeldung aufzuzeichnen. Sie können die Kalibrierungsmeldung sowohl über das vordere Bedienfeld als auch über die Remoteschnittstelle abfragen, auch bei aktiviertem Kalibrierschutz.

  • Beim Speichern einer Kalibrierungsmeldung wird die vorige Meldung überschrieben.
  • Die Einstellung ist permanent; sie bleibt bei einem Aus- und Wiedereinschalten des Geräts oder einem *RST erhalten.
  • Frontplatte: Systemtaste Softkey Instr Setup Softkey Calibrate
  • SCPI: CAL:STR "Cal Due: 01 August 2012"


Kalibrierungssicherheit - 33500 Series

In diesem Abschnitt wird das Kalibrierschutzsystem des Geräts beschrieben.

Übersicht Sicherheit

Ein Sicherheitscode verhindert versehentliche oder unberechtigte Einstellungen des Geräts. Bei 33500 Series Geräten ist der werkseitige Standardsicherheitscode modellabhängig:

Modelle | Sicherheitscode
33521A und 33522A | AT33520A
335XXB | AT33500
  • Derselbe Sicherheitscode gilt für die manuelle Betriebsart und für den Fernsteuerungsbetrieb. Wenn Sie den Kalibrierschutz über das vordere Bedienfeld aktivieren und ihn später über die Remoteschnittstelle deaktivieren möchten, müssen Sie denselben Sicherheitscode verwenden.
  • Die Einstellung ist permanent; sie bleibt bei einem Aus- und Wiedereinschalten des Geräts oder einem *RST erhalten.
  • Regeln zum Sicherheitscode:
    Zeichenfolge ohne Anführungszeichen, mit bis zu 12 Zeichen
    Muss mit einem Buchstaben (A-Z) beginnen
    Kann Buchstaben, Zahlen (0-9) und Unterstriche enthalten
  • Frontplatte:
    Taste System Softkey Instr Setup Softkey Calibrate Tastenfeld und Drehknopf
  • SCPI: CALibration_SECurity:STATe

Kalibrierschutz des Geräts ohne Sicherheitscode deaktivieren

Lesen Sie Vorsichtsmaßnahmen gegen elektrostatische Entladung (ESD), bevor Sie mit diesem Vorgang beginnen.
  1. Stromkabel und alle Eingangs- und Ausgangsverbindungen des Geräts trennen.
  2. Gerät zerlegen (siehe Demontage - 33500 Series).
  3. Einen vorübergehenden Kurzschluss zwischen Pin 1 und Pin 6 des Headers auf der Hauptplatine auslösen, siehe unten.

  4. Strom anschließen und Gerät einschalten.

    5. Warnung

    Achten Sie sorgfältig darauf, die Hauptstromanschlüsse oder hohe Spannungen am Netzanschlussmodul nicht zu berühren. Es fließt Strom, auch wenn das Gerät ausgeschaltet ist.
  5. Die Fehlerwarteschleife zeigt die Meldung "Calibration security has been disabled."

    Der Kalibrierschutz wird entsichert, das Kennwort wird auf die Standardeinstellung zurückgesetzt. Die Kalibrierungszahl wird inkrementiert, da die Steckbrücke während des Einschaltens angeschlossen war, folgende Fehlermeldung wird angezeigt: +701,"Calibration error; security defeated by hardware jumper". Die permanente Kalibrierungsspeicherung wird aktualisiert, um diese Arbeitsschritte wiederzugeben.
  6. Gerät ausschalten, Kurzschluss aufheben und Netzkabel entfernen.
  7. Gerät wieder zusammensetzen.
  8. Einen neuen Sicherheitscode eingeben, wie oben beschrieben, und diesen Sicherheitscode an einem sicheren Ort notieren.


Überprüfung - 33500 Series

Die folgenden Themen beschreiben den Bereich Überprüfung des Kalibrierungsverfahrens:

  • Leistungsüberprüfungstests
  • Interne Zeitbasisprüfung
  • Überprüfung AC-Amplitude (hochohmige Last)
  • Überprüfung DC-Offsetspannung
  • Überprüfung des -8 dB Frequenzgangbereichs
  • Überprüfung des -24 dB Frequenzgangbereichs


Leistungsüberprüfungstests - 33500 Series

Verwenden Sie die Leistungsüberprüfungstests zur Überprüfung der Messleistung des Instruments. Die Leistungsüberprüfungstests verwenden die auf dem Produktdatenblatt des Geräts aufgelisteten Spezifikationen.

Sie können drei verschiedene Stufen von Leistungsüberprüfungstests durchführen:

  • Selbsttest Ein Reihe interner Überprüfungstests, die hohe Sicherheit schaffen, dass das Gerät funktionsbereit ist.
  • Quick Verification Eine Kombination aus internen Selbsttests und ausgewählten Überprüfungstests.
  • Leistungsüberprüfungstests Eine umfangreiche Reihe von Tests, die als Akzeptanztests empfohlen werden, wenn Sie das Gerät neu erhalten oder nach Durchführung von Einstellungen.

Selbsttest

Beim Einschalten führt das Gerät automatisch einen kurzen Selbsttest durch. Dieser begrenzte Test stellt sicher, dass das Gerät funktionsbereit ist. Weitere Informationen finden Sie unter Selbsttest-Verfahren.

Leistungsschnelltest

Der Leistungsschnelltest ist eine Kombination von internem Selbsttest und einem abgekürzten Leistungstest (angegeben durch den Buchstaben Q in den Leistungsüberprüfungstests). Dieser Test bietet eine einfache Methode, um mit hoher Sicherheit festzustellen, ob das Gerät ordnungsgemäß funktioniert und den Spezifikationen entspricht. Diese Tests sind das absolute Minimum an empfohlenen Leistungsüberprüfungen nach der Ausführung einer technischen Serviceleistung. Die Prüfung der Leistung des Geräts über die Schnell-Check-Punkte (gekennzeichnet durch ein Q) überprüft die Leistung bei normalen Abweichungsmechanismen. Dieser Test überprüft nicht auf anormale Komponentenfehler.

Um einen Leistungsschnelltest durchzuführen, gehen Sie wie folgt vor:

  1. Vollständigen Selbsttest ausführen.
  2. Führen sie nur die Leistungsüberprüfungstests aus, die mit dem Buchstaben Q gekennzeichnet sind.
  3. Falls das Gerät den Leistungsschnelltest nicht besteht, ist eine Einstellung oder Reparatur erforderlich.

Leistungsüberprüfungstests

Die Leistungsüberprüfungstests werden als Akzeptanztests empfohlen, wenn Sie das Instrument erhalten. Die Ergebnisse des Akzeptanztests sollten mit den Spezifikationen auf dem Produktdatenblatt verglichen werden. Führen Sie die Leistungsüberprüfungstests nach der Akzeptanz zu jedem Kalibrierungsintervall durch.

Falls das Instrument den Leistungsüberprüfungstest nicht besteht, ist eine Einstellung oder Reparatur erforderlich.

Eine Einstellung wird zu jedem Kalibrierungsintervall empfohlen. Wird keine Einstellung vorgenommen, müssen Sie ein Schutzband einrichten, bei denen nicht mehr als 80 % der auf dem Datenblatt aufgeführten Spezifikationen als Überprüfungsgrenzen genutzt werden.

Prüfverfahren für Amplitude und Frequenzgang

Für das Prüfverfahren des Frequenzgangs ist ein Präzisions-AC-Spannungsmesser und ein Leistungsmessgerät zu verwenden. Sie können ihn durch einen Spannungswandler (Thermal Voltage Converter - TVC) ersetzen, um Messungen mit geeigneter Arbeitsweise und Testausrüstung durchzuführen.

Frequenzgang-Messungen für die Abschwächerbereiche -24 dB und -8 dB werden während des Überprüfungsverfahrens vorgenommen. Andere Abschwächerbereiche werden als Teil der Überprüfungsverfahren der Abschwächerbereiche -24 dB und -8 dB geprüft. Für diese Bereiche ist kein gesondertes Überprüfungsverfahren erforderlich.


Interne Zeitbasisprüfung - 33500 Series

Überprüft die Ausgangsfrequenzgenauigkeit. Alle Ausgangsfrequenzen werden von einer einzigen generierten Frequenz abgeleitet.

  1. Einen Frequenzzähler an den Ausgang von Kanal 1 anschließen, siehe Abbildung unten (der Frequenzzählereingang sollte bei 50 Ω abgeschlossen sein).

    Anpassungs-Setup 1
  2. Gerät auf den in der Tabelle unten beschriebenen Ausgang einstellen und die Ausgangsfrequenz messen. Sicherstellen, dass der Geräteausgang aktiviert ist.
    3. Standardwerte | Wellenformgenerator |  |  | Messung
 | Funktion | Amplitude | Frequenz | Nennwert | Fehler*
Q | Sinus | 1,00 Vpp | 10,0000000 MHz | 10,000 MHz | ±10 Hz

    * Mit der optionalen Stabilitäts-OCXO-Zeitbasis beträgt der Messfehler ±1 Hz.

  3. Vergleichen Sie den gemessenen Wert mit den Testgrenzen aus der Tabelle.


Überprüfung AC-Amplitude (hochohmige Last) - 33500 Series

Prüft die Genauigkeit des AC-Amplitudenausgangs bei 1 kHz-Frequenz mit jedem Abschwächer.

  1. DMM-Wert zur Messung der Effektivspannung einstellen. Schließen Sie das DMM wie unten dargestellt an den Kanalausgang an.

    Anpassungs-Setup 2
  2. Gerät auf jeden Ausgang der Tabelle unten einstellen und die Ausgangsspannung mit dem DMM messen. Sicherstellen, dass die Ausgangsimpedanz auf High–Z eingestellt und der Ausgang aktiviert ist.
    3. Standardwerte | Wellenformgenerator |  |  |  | Messung
 | Ausgangseinstellung | Funktion | Frequenz | Amplitude | Nennwert | Fehler*
Q | High Z** | Sinus | 1,000 kHz | 400,0 mVrms | 400,0 mVrms | ±0,004707 Vrms
Q | High Z | Sinus | 1,000 kHz | 400,0 mVrms | 400,0 mVrms | ±0,004707 Vrms
Q | High Z | Sinus | 1,000 kHz | 1,00 Vrms | 1,00 Vrms | ±0,010707 Vrms
Q | High Z | Sinus | 1,000 kHz | 2,500 Vrms | 2,500 Vrms | ±0,025707 Vrms
Q | High Z | Sinus | 1,000 kHz | 7,000 Vrms | 7,000 Vrms | ±0,070707 Vrms

    * Basierend auf 1 % der Einstellung ±1 mVpp (50 Ω); bei High–Z in Effektivspannung (Vrms) umgewandelt.

    ** Folgende Sequenz verwenden, um diesen Ausgang einzustellen:

    1. Amplitude auf 400,0 mVrms einstellen
    2. DC-Offset auf 1,0 VDC einstellen
    3. Automatische Bereichswahl auf AUS schalten
    4. DC-Offset auf 0,0 VDC einstellen
    5. Nach dem Messvorgang die Automatische Bereichswahl für die restlichen Messungen auf EIN schalten.
  3. Vergleichen Sie den gemessenen Wert mit den Testgrenzen aus der Tabelle.
  4. Nur Zwei-Kanal-Instrumente: Schließen Sie DMM an den Ausgang von Kanal 2 an und wiederholen Sie die Schritte 2 und 3.


Überprüfung DC-Offsetspannung - 33500 Series

Prüft die DC-Offsetspannung an zwei Abschwächerbereichen:

  1. DMM-Wert zur Messung der DC-Spannung einstellen. Schließen Sie das DMM wie unten dargestellt an den Kanalausgang an.
    Anpassungs-Setup 2
  2. Gerät auf jeden Ausgang der Tabelle unten einstellen und die Ausgangsspannung mit dem DMM messen.
    3. Standardwerte | Wellenformgenerator |  |  | Messung
 | Ausgangseinstellung | Funktion | Spannung | Nennwert | Fehler*
Q | High Z | Gleichstrom | 0,0 V | 0,0 VDC | ±0,002 VDC
Q | High Z | Gleichstrom | 500 mV | 0,500 VDC | ±0,007 VDC
Q | High Z | Gleichstrom | 10,0 V | 10,0 VDC | ±0,102 VDC

    * Basierend auf 1 % der Einstellung ±2 mVDC für High-Z.

  3. Vergleichen Sie den gemessenen Wert mit den Testgrenzen aus der Tabelle.
  4. Nur Zwei-Kanal-Instrumente: Schließen Sie DMM an den Ausgang von Kanal 2 an und wiederholen Sie die Schritte 2 und 3.


Überprüfung des -8 dB Frequenzgangbereichs - 33500 Series

Prüft den hochfrequenten AC-Amplitudenfrequenzgang im -8 dB Abschwächerbereich. Prüft außerdem den Frequenzgang für alle anderen Bereiche mit Ausnahme der Abschwächerbereiche -24 dB und 0 dB.

  1. Schließen Sie einen Präzisions-AC-Spannungsmesser an, um die Ausgangsamplitude zu messen, wie unten dargestellt. Schließen Sie das BNC-Kabel an den Breitbandeingang des Fluke 5790A an.Wenn Sie eine Ersatz-Testausstattung verwenden, sollten Sie prüfen, dass die Eingangsimpedanz 50 Ω beträgt, da die Lastgenauigkeit die Messqualität direkt beeinflusst.

    Anpassungs-Setup 3
  2. Stellen Sie den Präzisions-AC-Spannungsmesser auf "Medium, Medium" Digitalfilter und Filterneustart.
  3. Gerät auf jeden in der unten stehenden Tabelle beschriebenen Ausgang einstellen und die Ausgangsamplitude mit dem AC-Spannungsmesser messen. Dies wird zur Referenzmessung. Stellen Sie die Ausgangsimpedanz auf 50 Ω. Stellen Sie sicher, dass der Ausgang aktiviert ist.
    4. Standardwerte | Wellenformgenerator |  |  |  | Messung
 | Ausgangslast | Funktion | Amplitude | Frequenz | Nennwert | Fehler
Q | 50 Ω | Sinus | 1,200 Vrms | 1,000 kHz | 1,200 Vrms | ±0,0127 Vrms
  4. Stellen Sie den in Schritt 3 gemessenen Wert als Referenzwert für den AC-Spannungsmesser ein.
  5. Stellen Sie das Gerät für jede in der unten stehenden Tabelle beschriebene Ausgabe ein und messen Sie die Ausgangsamplitude relativ zur Quelle als Prozentsatz mit dem AC-Spannungsmesser. Beachten Sie, dass die Tabelle auch die Ausgabe in dB auflistet, wenn Sie ein Leistungsmessgerät für diesen Test verwenden.
    6. Standardwerte | Wellenformgenerator |  |  |  | Messung
 | Ausgangslast | Funktion | Amplitude | Frequenz | Nennwert | Fehler | Nennwert | Fehler
 | 50 Ω | Sinus | 1,200 Vrms | 100,000 kHz | 100% | ±1,15% | 0 dB | ±0,10 dB
 |  |  |  | 500,000 kHz |  | ±1,74% |  | ±0,15 dB
 |  |  |  | 1,000 MHz |  | ±1,74% |  | ±0,15 dB
Q | 50 Ω | Sinus | 1,200 Vrms | 2,000 MHz | 100% | ±1,74% | 0 dB | ±0,15 dB
 | 50 Ω | Sinus | 1,200 Vrms | 5,000 MHz | 100% | ±1,74% | 0 dB | ±0,15 dB
 |  |  |  | 10,00 MHz |  | ±3,51% |  | ±0,30 dB
 |  |  |  | 15,00 MHz |  | ±3,51% |  | ±0,30 dB
 |  |  |  | 20,00 MHz |  | ±3,51% |  | ±0,30 dB
 |  |  |  | 22,00 MHz (für 20 MHz Geräte nicht notwendig) |  | ±4,71% |  | ±0,40 dB
 |  |  |  | 27,00 MHz (für 20 MHz Geräte nicht notwendig) |  | ±4,71% |  | ±0,40 dB
 |  |  |  | 30,00 MHz (für 20 MHz Geräte nicht notwendig) |  | ±4,71% |  | ±0,40 dB
  6. Vergleichen Sie den gemessenen Wert mit den Testgrenzen aus der Tabelle.
  7. Nur Zwei-Kanal-Instrumente: Schließen Sie den AC-Spannungsmesser an Kanal 2 an und wiederholen Sie die Schritte 2 bis 6.


Überprüfung des -24 dB Frequenzgangbereichs - 33500 Series

Prüft den hochfrequenten AC-Amplitudenfrequenzgang im Abschwächerbereich -24 dB. Prüft außerdem den Frequenzgang für den Abschwächerbereich 0 dB.

  1. Schließen Sie einen Präzisions-AC-Spannungsmesser an, um die Ausgangsamplitude zu messen, wie unten dargestellt. Schließen Sie das BNC-Kabel an den Breitbandeingang des Fluke 5790A an.Wenn Sie eine Ersatz-Testausstattung verwenden, sollten Sie prüfen, dass die Eingangsimpedanz 50 Ω beträgt, da die Lastgenauigkeit die Messqualität direkt beeinflusst.

    Anpassungs-Setup 3
  2. Stellen Sie den Präzisions-AC-Spannungsmesser auf "Medium, Medium" Digitalfilter und Filterneustart.
  3. Gerät auf jeden in der unten stehenden Tabelle beschriebenen Ausgang einstellen und die Ausgangsamplitude mit dem AC-Spannungsmesser messen. Dies wird zur Referenzmessung. Stellen Sie die Ausgangsimpedanz auf 50 Ω. Stellen Sie sicher, dass der Ausgang aktiviert ist.
    4. Standardwerte | Wellenformgenerator |  |  |  | Messung
 | Ausgangslast | Funktion | Amplitude | Frequenz | Nennwert | Fehler
Q | 50 Ω | Sinus | 0,190 Vrms | 1,000 kHz | 0,190 Vrms | ±0,0026 Vrms
  4. Stellen Sie den in Schritt 3 gemessenen Wert als Referenzwert für den AC-Spannungsmesser ein.
  5. Stellen Sie das Gerät für jede in der unten stehenden Tabelle beschriebene Ausgabe ein und messen Sie die Ausgangsamplitude relativ zur Quelle als Prozentsatz mit dem AC-Spannungsmesser. Beachten Sie, dass die Tabelle auch die Ausgabe in dB auflistet, wenn Sie ein Leistungsmessgerät für diesen Test verwenden.
    6. Standardwerte | Wellenformgenerator |  |  |  | Messung
 | Ausgangslast | Funktion | Amplitude | Frequenz | Nennwert | Fehler | Nennwert | Fehler
 | 50 Ω | Sinus | 0,190 Vrms | 100,000 kHz | 100% | ±1,15% | 0 dB | ±0,10 dB
 |  |  |  | 500,000 kHz |  | ±1,74% |  | ±0,15 dB
 |  |  |  | 1,000 MHz |  | ±1,74% |  | ±0,15 dB
Q | 50 Ω | Sinus | 0,190 Vrms | 2,000 MHz | 100% | ±1,74% | 0 dB | ±0,15 dB
 | 50 Ω | Sinus | 0,190 Vrms | 5,000 MHz | 100% | ±1,74% | 0 dB | ±0,15 dB
 |  |  |  | 10,00 MHz |  | ±3,51% |  | ±0,30 dB
 |  |  |  | 15,00 MHz |  | ±3,51% |  | ±0,30 dB
 |  |  |  | 20,00 MHz |  | ±3,51% |  | ±0,30 dB
 |  |  |  | 22,00 MHz (für 20 MHz Geräte nicht notwendig) |  | ±4,71% |  | ±0,40 dB
 |  |  |  | 27,00 MHz (für 20 MHz Geräte nicht notwendig) |  | ±4,71% |  | ±0,40 dB
 |  |  |  | 30,00 MHz (für 20 MHz Geräte nicht notwendig) |  | ±4,71% |  | ±0,40 dB
  6. Vergleichen Sie den gemessenen Wert mit den Testgrenzen aus der Tabelle.
  7. Nur Zwei-Kanal-Instrumente: Schließen Sie den AC-Spannungsmesser an Kanal 2 an und wiederholen Sie die Schritte 2 bis 6.


Allgemeines Kalibrierungs-/Anpassungsverfahren - 33500 Series

Empfohlene Methode für eine komplette Gerätekalibrierung:

  1. Lesen Sie die Überlegungen zum Test.
  2. Ausführung von Überprüfungstests zur Charakterisierung des Geräts (eingehende Daten).
  3. Drücken Sie [System > Instr Setup > Calibrate. Wenn das Gerät für die Kalibrierung gesichert ist, zunächst seine Sicherung deaktivieren.
  4. Geben Sie die Setup-Nummer für den ausgeführten Vorgang ein. Die Standard-Setup-Nummer ist "1" und über die Frontplatte steigt die Zahl mit der Ausführung der Verfahren an.
  5. Wählen Sie BEGIN.
  6. Passen Sie bei Setups, die eine Eingabe erfordern, den im Display angezeigten Wert an den gemessenen Wert an und wählen Sie ENTER VALUE.
  7. Das Setup geht automatisch bis zum nächsten erforderlichen Wert.

    Um den Anpassungsvorgang abzubrechen, wählen Sie CANCEL STEP. Das Display kehrt dann zum Eintrag der Setup-Nummer zurück.
  8. Wählen Sie nach Beenden des Vorgangs END CAL.
  9. (Optional) Wählen Sie mit der Remote-Schnittstelle eine neue Kalibrierungsmeldung. Die Meldung (bis zu 40 Zeichen) wird mit den Kalibrierungskoeffizienten gespeichert.
  10. Aktivieren Sie den Kalibrierungsschutz des Geräts.
  11. Notieren Sie den neuen Sicherheitscode und den Kalibrierungszähler in den Wartungsunterlagen des Geräts.


Laufende Kalibrierung abbrechen - 33500 Series

Manchmal kann es notwendig sein, eine laufende Kalibrierung abzubrechen. Sie können eine Kalibrierung jederzeit abbrechen, indem Sie den Strom ausschalten oder über die Remote-Schnittstelle eine Löschmeldung eingeben und dann*RST eingeben.

Das Gerät speichert Kalibrierungskonstanten am Ende jedes Anpassungsvorgangs. Wenn die Stromversorgung unterbrochen wird oder eine laufende Anpassung anderweitig abgebrochen wird, müssen Sie den unterbrochenen Anpassungsvorgang einfach erneut ausführen.

Vorsicht

Wenn die Stromversorgung unterbrochen wird, während das Gerät versucht, neue Kalibrierungskonstanten in den Speicher zu schreiben, kann es sein, dass alle Kalibrierungskonstanten für die Funktion verloren gehen. Typischerweise zeigt das Gerät bei der Wiederherstellung der Stromversorgung die Fehlermeldung "-313, Calibration Memory Lost" an.


Anpassungssequenz - 33500 Series

Die Anpassungssequenz in den nummerierten Segmenten minimiert die Anzahl der Testausstattungs-Setups und Anschlusswechsel.

Benutzerdefinierte Anpassungen können wie erforderlich durchgeführt werden, aber die Setups 1 bis 7 müssen in dieser Reihenfolge ausgeführt werden, bevor ein anderer Setup-Vorgang begonnen wird.


Selbsttest - 33500 Series

Führen Sie einen Selbsttest aus, um sicherzustellen, dass das Gerät funktionsfähig ist, bevor Sie zusätzliche Anpassungen vornehmen.

Stellen Sie sicher, dass dass Gerät entsperrt ist und die unter Testüberlegungen aufgeführten Anforderungen eingehalten werden, bevor Sie mit den Anpassungen beginnen.

  1. Drücken Sie [System > Instr Setup > Calibrate. Geben Sie die Setup-Nummer 1 ein und wählen Sie BEGIN.
    2. Setup |
1 | Führt einen Geräteselbsttest durch. Der Hauptausgang ist beim Test deaktiviert.
  2. Falls ein Selbsttest fehlschlägt, müssen Sie das Gerät reparieren, bevor das Gerät mit den Anpassungsverfahren fortfährt.

Ein vollständiger Selbsttest (*TST?) dauert ca. 15 Sekunden.


Frequenzanpassung (interne Zeitbasis) - 33500 Series

Das Gerät speichert eine Kalibrierkonstante, die den Kristalloszillator so einstellt, dass genau 10 MHz ausgegeben werden. Das Gerät sollte vor dieser Kalibrierungsanpassung 30 Minuten lang kontinuierlich gearbeitet haben, um die Zeitbasisstabilität sicherzustellen.

  1. Stellen Sie die Frequenzzählerauflösung besser als 0,01 ppm ein und die Eingangsbegrenzung auf 50 Ω (wenn Ihr Frequenzzähler keine 50 Ω Eingangsbegrenzung hat, müssen Sie eine externe Begrenzung bereitstellen). Nehmen Sie die Anschlüsse vor wie unten angegeben.

    Anpassungs-Setup 1
  2. Verwenden Sie den Frequenzzähler, um die Ausgangsfrequenz für jeden Setup in folgender Tabelle zu messen.
    3.  | Nennsignal |  |
Setup | Frequenz | Amplitude |
2 | <10 MHz | ~1 Vpp | Die Ausgangsfrequenz ist etwas geringer als 10 MHz
3 | >10 MHz |  | Die Ausgangsfrequenz ist etwas höher als 10 MHz
4 | ~10 MHz |  | Die Ausgangsfrequenz sollte ca. 10 MHz betragen
5* | 10 MHz |  | Die Ausgangsfrequenz sollte 10 MHz ± 1 ppm betragen

    * Konstanten werden nach Abschluss dieses Setups gespeichert.

  3. Stimmen Sie mit der Zifferntastatur oder mit dem Drehknopf die angezeigte Frequenz bei jedem Setup auf die gemessene Frequenz ab. Wählen Sie ENTER VALUE.
  4. Um fortzufahren:
  1. Wenn Ihr Kalibriervorgang eine Überprüfung der soeben vorgenommen Anpassungen erfordert, verlassen Sie das Kalibriermenü und führen Sie Interne Zeitbasisprüfung.
  2. Wenn Sie alle Anpassungen vornehmen und dann die Leistung des Geräts überprüfen, fahren Sie mit dem nächsten Vorgang in diesem Abschnitt fort.


Anpassung des internen A/D-Konverters - 33500 Series

Das Gerät speichert Kalibrierkonstanten, die sich auf Verstärkung und Offset des internen A/D-Konverters beziehen. Setup 6 muss stets ausgeführt werden, bevor versucht wird, andere Amplitudenanpassungen vorzunehmen. Der interne A/D-Konverter wird dann als Quelle für die Kalibrierkonstanten verwendet, die bei der Selbstkalibrierung generiert werden (Setup 7).

  1. Schließen Sie den Ausgang von Kanal 1 wie unten dargestellt an den Modulationseingang an der Rückwand des Geräts und DMM an.
    Anpassungs-Setup 4
  2. Stellen Sie den DMM-Wert so ein, dass 5½ Ziffern angezeigt werden, und die Funktion auf DCV.
  3. Geben Sie folgendes Setup ein.
    4.  | Nennsignal |
Setup | DC-Pegel |
6* | ~1,0 VDC ±10% | Kalibriert den internen A/D-Konverter.

    * Konstanten werden nach Abschluss dieses Setups gespeichert.

  4. Verwenden Sie die Zifferntastatur oder den Drehknopf, um den gemessenen DMM-Wert einzugeben.

    5. Hinweis

    Dieses Setup erfordert ca. 15 Sekunden.
  5. Trennen Sie alle Kabel vom Gerät.


Anpassung der Selbstkalibrierung - 33500 Series

  1. Geben Sie folgendes Setup ein und beginnen Sie mit der Ausführung.
    2. Setup |
7* | Selbstkalibrierung. Der Ausgang ist deaktiviert.

    * Konstanten werden nach Abschluss dieses Setups gespeichert.

  2. Um fortzufahren:
  1. Wenn Ihr Kalibriervorgang eine Überprüfung der soeben vorgenommen Anpassungen erfordert, verlassen Sie das Kalibriermenü und führen Sie eine Überprüfung DC-Offsetspannung durch.
  2. Wenn Sie alle Anpassungen vornehmen und dann die Leistung des Geräts überprüfen, fahren Sie mit dem nächsten Vorgang in diesem Abschnitt fort.

Hinweis

Dieses Setup erfordert ca. 15 Sekunden.


Anpassung der Ausgangsimpedanz - 33500 Series

Das Gerät speichert die Kalibrierungskonstanten für die Ausgangsimpedanz des Kanals. Diese Konstanten werden mit und ohne den dem Verstärker nachgeschalteten Abschwächer generiert.

  1. Stellen Sie das DMM für eine Messung mit Offset-Ausgleich und 4-Draht-Widerstand ein. Stellen Sie das DMM so ein, dass eine 100 NPLC Integration verwendet wird. Schließen Sie die DMM-Eingänge Ohm-Quelle und Ohm-Abtastung an den Kanalausgang an, wie unten dargestellt.
    Anpassungs-Setup 5
  2. Führen Sie mit dem DMM eine 4-Draht-Widerstandsmessung am Frontplattenausgangsanschluss für jedes Setup der folgenden Tabelle durch. Das erwartete Messergebnis beträgt ca. 50 Ω.
    3. Setup |
8* | -24 dB Nachabschwächer-Bereich
9* | 0 dB

    * Konstanten werden nach Abschluss dieses Setups gespeichert.

  3. Stimmen Sie mit der Zifferntastatur oder mit dem Drehknopf die angezeigte Impedanz bei jedem Setup auf die gemessene Impedanz ab. Wählen Sie ENTER VALUE.
  4. Es gibt keine speziellen Funktionsprüfungstests für die Ausgangsimpedanz. Fahren Sie mit dem nächsten Anpassungsvorgang dieses Abschnitts fort.


Anpassung der AC-Amplitude (hochohmige Last) - 33500 Series

Das Gerät speichert eine Kalibrierungskonstante für jeden Abschwächer-Pfad für hochohmige Lasten. Der Verstärkungskoeffizient jedes Pfades wird über zwei Messungen berechnet: eine mit dem Signal-DAC bei + Ausgang und eine mit dem Signal-DAC bei – Ausgang. Daher müssen die Setups paarweise erfolgen.

  1. Schließen Sie das DMM wie unten dargestellt an den Kanalausgang an.
    Anpassungs-Setup 2
  2. Messen Sie mit dem DMM die DC-Spannung am Frontplattenanschluss für jedes Setup der folgenden Tabelle.

    Setup | Nennsignal
    DC-Pegel
    10 | +0,0028 V | Ausgabe aus dem -72 dB Bereich
    11* | -0,0028 V | Ausgabe aus dem -72 dB Bereich
    12 | +0,007 V | Ausgabe aus dem -64 dB Bereich
    13* | -0,007 V | Ausgabe aus dem -64 dB Bereich
    14 | +0,017 V | Ausgabe aus dem -56 dB Bereich
    15* | -0,017 V | Ausgabe aus dem -56 dB Bereich
    16 | +0,044 V | Ausgabe aus dem -48 dB Bereich
    17* | -0,044 V | Ausgabe aus dem -48 dB Bereich
    18 | +0,11 V | Ausgabe aus dem -40 dB Bereich
    19* | -0,11 V | Ausgabe aus dem -40 dB Bereich
    20 | +0,28 V | Ausgabe aus dem -32 dB Bereich
    21* | -0,28 V | Ausgabe aus dem -32 dB Bereich
    22 | +0,68 V | Ausgabe aus dem -24 dB Bereich
    23* | -0,68 V | Ausgabe aus dem -24 dB Bereich
    24 | +1,7 V | Ausgabe aus dem -16 dB Bereich
    25* | -1,7 V | Ausgabe aus dem -16 dB Bereich
    26 | +4,3 V | Ausgabe aus dem -8 dB Bereich
    27* | -4,3 V | Ausgabe aus dem -8 dB Bereich
    28 | +10,8 V | Ausgabe aus dem 0 dB Bereich
    29* | -10,8 V | Ausgabe aus dem 0 dB Bereich
    30 | +0,044V | Ausgabe aus dem hohen -48 dB DC-Bereich
    31* | -0,044V | Ausgabe aus dem hohen -48 dB DC-Bereich
    32 | +0,11 V | Ausgabe aus dem hohen -40 dB DC-Bereich
    33* | -0,11 V | Ausgabe aus dem hohen -40 dB DC-Bereich
    34 | +0,28 V | Ausgabe aus dem hohen -32 dB DC-Bereich
    35* | -0,28 V | Ausgabe aus dem hohen -32 dB DC-Bereich
    36 | +0,68 V | Ausgabe aus dem hohen -24 dB DC-Bereich
    37* | -0,68 V | Ausgabe aus dem hohen -24 dB DC-Bereich

    3. * Konstanten werden nach Abschluss dieses Setups gespeichert.

  3. Stimmen Sie mit der Zifferntastatur oder mit dem Drehknopf die angezeigte Spannung bei jedem Setup auf die gemessene Spannung ab. Wählen Sie ENTER VALUE.
  4. Um fortzufahren:
  1. Wenn der Kalibrierungsvorgang eine Überprüfung dieser Anpassung erfordert, verlassen Sie das Kalibrierungsmenü und führen Sie eine Überprüfung AC-Amplitude (hochohmige Last) durch.
  2. Wenn Sie alle Anpassungen vornehmen und dann die Leistung des Geräts überprüfen, fahren Sie mit dem nächsten Vorgang in diesem Abschnitt fort.


Anpassung des -24 dB Frequenzgangbereichs - 33500 Series

  1. Schließen Sie einen Präzisions-AC-Spannungsmesser an, um die Ausgangsamplitude zu messen, wie unten dargestellt. Schließen Sie das BNC-Kabel an den Breitbandeingang des Fluke 5790A an.

    Anpassungs-Setup 3
  2. Verwenden Sie den Präzisions-AC-Spannungsmesser zur Messung der Ausgangsamplitude für jedes Setup der unten abgebildeten Tabelle.

    Setup | Nennsignal
    Frequenz | Amplitude
    38* | 1 kHz | 0,192 Vrms | Frequenzgang für den -24 dB Bereich
    39* | 100 kHz
    40* | 1 MHz
    41* | 5 MHz
    42* | 10 MHz
    43* | 20 MHz
    44* | 25 MHz
    45* | 30 MHz

    * Konstanten werden nach Abschluss dieses Setups gespeichert.
  3. Stimmen Sie mit der Zifferntastatur oder mit dem Drehknopf die angezeigte Spannung bei jedem Setup auf die gemessene Spannung ab. Wählen Sie ENTER VALUE.
  4. Um fortzufahren:
  1. Wenn Ihr Kalibriervorgang eine Überprüfung der soeben vorgenommen Anpassungen erfordert, verlassen Sie das Kalibriermenü und führen Sie eine Überprüfung des -24 dB Frequenzgangbereichs durch.
  2. Wenn Sie alle Anpassungen vornehmen und dann die Leistung des Geräts überprüfen, fahren Sie mit dem nächsten Vorgang in diesem Abschnitt fort.


Anpassung des -8 dB Frequenzgangbereichs - 33500 Series

  1. Schließen Sie einen Präzisions-AC-Spannungsmesser an, um die Ausgangsamplitude zu messen, wie unten dargestellt. Schließen Sie das BNC-Kabel an den Breitbandeingang des Fluke 5790A an.

    Anpassungs-Setup 3
  2. Verwenden Sie den Präzisions-AC-Spannungsmesser zur Messung der Ausgangsamplitude für jedes Setup der unten abgebildeten Tabelle.
    3. Setup | Nennsignal |  |
 | Frequenz | Amplitude |
46* | 1 kHz | 1,22 Vrms | Frequenzgang für den -8 dB Bereich
47* | 100 kHz
48* | 1 MHz
49* | 5 MHz
50* | 10 MHz
51* | 20 MHz
52* | 25 MHz
53* | 30 MHz

    * Konstanten werden nach Abschluss dieses Setups gespeichert.

  3. Stimmen Sie mit der Zifferntastatur oder mit dem Drehknopf die angezeigte Spannung bei jedem Setup auf die gemessene Spannung ab. Wählen Sie ENTER VALUE.
  4. Um fortzufahren:
  1. Wenn Ihr Kalibriervorgang eine Überprüfung der soeben vorgenommen Anpassungen erfordert, verlassen Sie das Kalibriermenü und führen Sie Überprüfung des -8 dB Frequenzgangbereichs.
  2. Wenn Sie alle Anpassungen vornehmen und dann die Leistung des Geräts überprüfen, prüfen Sie die Ausgangsspezifikationen des Geräts Leistungsüberprüfungstests.

Damit sind die Anpassungsvorgänge für das Einkanalgerät abgeschlossen. Eine Überprüfung der Ausgangsspezifikationen wird empfohlen.

Wenn Sie an einem Zweikanalgerät Anpassungen vornehmen, fahren Sie mit dem nächsten Verfahren dieses Abschnitts fort.


Anpassungen Kanal 2 - 33500 Series

Folgende Themen beschreiben die Kalibrierungsanpassungen von Kanal 2.

  • Anpassung der Selbstkalibrierung (Kanal 2)
  • Anpassung der Ausgangsimpedanz (Kanal 2)
  • Anpassung der AC-Amplitude (hochohmige Last) (Kanal 2)
  • Anpassung des -24 dB Frequenzgangbereichs (Kanal 2)
  • Anpassung des -8 dB Frequenzgangbereichs (Kanal 2)


Anpassung der Selbstkalibrierung (Kanal 2) - 33500 Series

  1. Geben Sie folgendes Setup ein und beginnen Sie mit der Ausführung.
    2. Setup |
54* | Selbstkalibrierung. Der Ausgang ist deaktiviert.

    * Konstanten werden nach Abschluss dieses Setups gespeichert.

  2. Um fortzufahren:
  1. Wenn Ihr Kalibriervorgang eine Überprüfung der soeben vorgenommen Anpassungen erfordert, verlassen Sie das Kalibriermenü und führen Sie eine Überprüfung DC-Offsetspannung durch. Stellen Sie sicher, dies für Kanal 2 durchzuführen.
  2. Wenn Sie alle Anpassungen vornehmen und dann die Leistung des Geräts überprüfen, fahren Sie mit dem nächsten Vorgang in diesem Abschnitt fort.

Hinweis

Dieses Setup erfordert ca. 15 Sekunden.


Anpassung der Ausgangsimpedanz (Kanal 2) - 33500 Series

Das Gerät speichert die Kalibrierungskonstanten für die Ausgangsimpedanz des Kanals. Diese Konstanten werden mit und ohne den dem Verstärker nachgeschalteten Abschwächer generiert.

  1. Stellen Sie das DMM für eine Messung mit Offset-Ausgleich und 4-Draht-Widerstand ein. Stellen Sie das DMM so ein, dass eine 100 NPLC Integration verwendet wird. Schließen Sie die DMM-Eingänge Ohm-Quelle und Ohm-Abtastung an den Kanalausgang an, wie unten dargestellt.
    Anpassungs-Setup 6
  2. Führen Sie mit dem DMM eine 4-Draht-Widerstandsmessung am Frontplattenausgangsanschluss für jedes Setup der folgenden Tabelle durch. Das erwartete Messergebnis beträgt ca. 50 Ω.
    3. Setup |
55* | -24 dB Nachabschwächer-Bereich
56* | 0 dB

    * Konstanten werden nach Abschluss dieses Setups gespeichert.

  3. Stimmen Sie mit der Zifferntastatur oder mit dem Drehknopf die angezeigte Impedanz bei jedem Setup auf die gemessene Impedanz ab. Wählen Sie ENTER VALUE.
  4. Es gibt keine speziellen Funktionsprüfungstests für die Ausgangsimpedanz. Fahren Sie mit dem nächsten Anpassungsvorgang dieses Abschnitts fort.


Anpassung der AC-Amplitude (hochohmige Last) (Kanal 2) - 33500 Series

Das Gerät speichert eine Kalibrierungskonstante für jeden Abschwächer-Pfad für hochohmige Lasten. Der Verstärkungskoeffizient jedes Pfades wird über zwei Messungen berechnet: eine mit dem Signal-DAC bei + Ausgang und eine mit dem Signal-DAC bei – Ausgang. Daher müssen die Setups paarweise erfolgen.

  1. Schließen Sie das DMM wie unten dargestellt an den Kanalausgang an.
    Anpassungs-Setup 7
  2. Messen Sie mit dem DMM die DC-Spannung am Frontplattenanschluss für jedes Setup der folgenden Tabelle.

    Nennsignal
    Setup | DC-Pegel
    57 | +0,0028 V | Ausgabe aus dem -72 dB Bereich
    58* | -0,0028 V | Ausgabe aus dem -72 dB Bereich
    59 | +0,007 V | Ausgabe aus dem -64 dB Bereich
    60* | -0,007 V | Ausgabe aus dem -64 dB Bereich
    61 | +0,017 V | Ausgabe aus dem -56 dB Bereich
    62* | -0,017 V | Ausgabe aus dem -56 dB Bereich
    63 | +0,044 V | Ausgabe aus dem -48 dB Bereich
    64* | -0,044 V | Ausgabe aus dem -48 dB Bereich
    65 | +0,11 V | Ausgabe aus dem -40 dB Bereich
    66* | -0,11 V | Ausgabe aus dem -40 dB Bereich
    67 | +0,28 V | Ausgabe aus dem -32 dB Bereich
    68* | -0,28 V | Ausgabe aus dem -32 dB Bereich
    69 | +0,68 V | Ausgabe aus dem -24 dB Bereich
    70* | -0,68 V | Ausgabe aus dem -24 dB Bereich
    71 | +1,7 V | Ausgabe aus dem -16 dB Bereich
    72* | -1,7 V | Ausgabe aus dem -16 dB Bereich
    73 | +4,3 V | Ausgabe aus dem -8 dB Bereich
    74* | -4,3 V | Ausgabe aus dem -8 dB Bereich
    75 | +10,8 V | Ausgabe aus dem 0 dB Bereich
    76* | -10,8 V | Ausgabe aus dem 0 dB Bereich
    77 | +0,044 V | Ausgabe aus dem hohen -48 dB DC-Bereich
    78* | -0,044 V | Ausgabe aus dem hohen -48 dB DC-Bereich
    79 | +0,11 V | Ausgabe aus dem hohen -40 dB DC-Bereich
    80* | -0,11 V | Ausgabe aus dem hohen -40 dB DC-Bereich
    81 | +0,28 V | Ausgabe aus dem hohen -32 dB DC-Bereich
    82* | -0,28 V | Ausgabe aus dem hohen -32 dB DC-Bereich
    83 | +0,68 V | Ausgabe aus dem hohen -24 dB DC-Bereich
    84* | -0,68 V | Ausgabe aus dem hohen -24 dB DC-Bereich

    * Konstanten werden nach Abschluss dieses Setups gespeichert.

  3. Stimmen Sie mit der Zifferntastatur oder mit dem Drehknopf die angezeigte Spannung bei jedem Setup auf die gemessene Spannung ab. Wählen Sie ENTER VALUE.
  4. Um fortzufahren:
  1. Wenn der Kalibrierungsvorgang eine Überprüfung dieser Anpassung erfordert, verlassen Sie das Kalibrierungsmenü und führen Sie eine Überprüfung AC-Amplitude (hochohmige Last) durch.
  2. Wenn Sie alle Anpassungen vornehmen und dann die Leistung des Geräts überprüfen, fahren Sie mit dem nächsten Vorgang in diesem Abschnitt fort.


Anpassung des -24 dB Frequenzgangbereichs (Kanal 2) - 33500 Series

  1. Schließen Sie einen Präzisions-AC-Spannungsmesser an, um die Ausgangsamplitude zu messen, wie unten dargestellt. Schließen Sie das BNC-Kabel an den Breitbandeingang des Fluke 5790A an.

    Anpassungs-Setup 8
  2. Verwenden Sie den Präzisions-AC-Spannungsmesser zur Messung der Ausgangsamplitude für jedes Setup der unten abgebildeten Tabelle.
    3. Setup | Nennsignal |  |
 | Frequenz | Amplitude |
85* | 1 kHz | 0,192 Vrms | Frequenzgang für den -24 dB Bereich
86* | 100 kHz
87* | 1 MHz
88* | 5 MHz
89* | 10 MHz
90* | 20 MHz
91* | 25 MHz
92* | 30 MHz

    * Konstanten werden nach Abschluss dieses Setups gespeichert.

  3. Stimmen Sie mit der Zifferntastatur oder mit dem Drehknopf die angezeigte Spannung bei jedem Setup auf die gemessene Spannung ab. Wählen Sie ENTER VALUE.
  4. Um fortzufahren:
  1. Wenn Ihr Kalibriervorgang eine Überprüfung der soeben vorgenommen Anpassungen erfordert, verlassen Sie das Kalibriermenü und führen Sie eine Überprüfung des -24 dB Frequenzgangbereichs durch. Stellen Sie sicher, dies für Kanal 2 durchzuführen.
  2. Wenn Sie alle Anpassungen vornehmen und dann die Leistung des Geräts überprüfen, fahren Sie mit dem nächsten Vorgang in diesem Abschnitt fort.


Anpassung des -8 dB Frequenzgangbereichs (Kanal 2) - 33500 Series

Dieser Abschnitt bezieht sich auf Kanal 2. Prüft den hochfrequenten AC-Amplitudenfrequenzgang im -8 dB Abschwächerbereich. Zudem prüft er den Frequenzgang für alle anderen Bereiche mit Ausnahme der -24 dB und 0 dB Abschwächerbereiche.

  1. Schließen Sie einen Präzisions-AC-Spannungsmesser an, um die Ausgangsamplitude zu messen, wie unten dargestellt. Schließen Sie das BNC-Kabel an den Breitbandeingang des Fluke 5790A an.

    Anpassungs-Setup 8
  2. Verwenden Sie den Präzisions-AC-Spannungsmesser zur Messung der Ausgangsamplitude für jedes Setup der unten abgebildeten Tabelle.
    3.  | Nennsignal |  |
Setup | Frequenz | Amplitude |
93* | 1 kHz | 1,22 Vrms | Frequenzgang für den -8 dB Bereich
94* | 100 kHz
95* | 1 MHz
96* | 5 MHz
97* | 10 MHz
98* | 20 MHz
99* | 25 MHz
100 | 30 MHz

    * Konstanten werden nach Abschluss dieses Setups gespeichert.

  3. Stimmen Sie mit der Zifferntastatur oder mit dem Drehknopf die angezeigte Spannung bei jedem Setup auf die gemessene Spannung ab. Wählen Sie ENTER VALUE.
  4. Die empfohlenen Anpassungsvorgänge sind nun abgeschlossen. Eine Überprüfung der Ausgangsspezifikationen wird empfohlen.
    1. Wenn Ihr Kalibriervorgang eine Überprüfung der soeben vorgenommen Anpassungen erfordert, verlassen Sie das Kalibriermenü und führen Sie Überprüfung des -8 dB Frequenzgangbereichs.


Kalibrierungsfehler - 33500 Series

Folgende Fehler können bei der Kalibrierung auftreten. Es gibt Systemfehler und Selbsttestfehler. Manche Fehlermeldungen enthalten eine fehlerhafte Kanalnummer (1 oder 2), wie in den Meldungen unten.

701 Calibration error; security defeated by hardware jumper

Bei einem Kurzschließen der Steckbrücke zur Kalibrierungssicherung (CAL ENABLE) beim Einschalten des Geräts zeigt dieser Fehler an, dass das Sicherheitskennwort überschrieben wurde.Ausführlichere Informationen finden Sie unter Kalibrierungssicherheit.

702 Calibration error; calibration memory is secured

Vor der Kalibrierung muss der Kalibrierschutz des Geräts deaktiviert werden.Ausführlichere Informationen finden Sie unter Kalibrierungssicherheit.

703 Calibration error; secure code provided was invalid

Der angegebene Sicherheitscode war ungültig.

706 Calibration error; value out of range

Der eingegebene Wert befindet sich außerhalb des Gültigkeitsbereichs.

707 Calibration error; signal input is out of range

Erfolgt während der Anpassung des internen A/D-Konverters, Setup 6, wenn die 1 V Eingangsspannung zu hoch ist. Kann auch während der Selbstkalibrierung auftreten (Setup 7). Selbsttest für die Problemdiagnose ausführen.

710 Self-calibration failed; Chan n, null DAC cal, invalid self cal
Self-calibration failed; Chan n, offset DAC cal with attenuator, invalid self cal
Self-calibration failed; Chan n, offset DAC cal no attenuator, invalid self cal

Bei der internen Kalibrierung des angegebenen A/D-Wandlers ist ein Fehler aufgetreten. Selbstkalibrierung wurde beendet, ohne die Selbstkalibrierungskonstanten zu ändern. Selbsttest für die Problemdiagnose ausführen.

711 Self-calibration failed; Chan n, null DAC cal gain too low (too high), <meas_value>
Self-calibration failed; Chan n, offset DAC cal with attenuator gain too low (too high), <meas_value>
Self-calibration failed; Chan n, offset DAC cal no attenuator gain too low (too high), <meas_value>

Der berechnete Verstärkungsfaktor für den angegebenen A/D-Wandler lag außerhalb des Bereichs. Selbstkalibrierung wurde beendet, ohne die Selbstkalibrierungskonstanten zu ändern. Selbsttest für die Problemdiagnose ausführen.

712 Self-calibration failed; Chan n, null DAC cal zero too low (too high), <meas_value>
Self-calibration failed; Chan n, offset DAC cal with attenuator zero too low (too high), <meas_value>
Self-calibration failed; Chan n, offset DAC cal no attenuator zero too low (too high), <meas_value>
Self-calibration failed; Chan n, GND measurement out of limits, <meas_value>

Der berechnete Kalibrierfaktor für den angegebenen Kalibrierfaktor A/D-Wandler lag außerhalb des Bereichs. Selbstkalibrierung wurde beendet, ohne die Selbstkalibrierungskonstanten zu ändern. Selbsttest für die Problemdiagnose ausführen.

715 Selbstkalibrierung fehlgeschlagen; Chan n, null DAC cal, convergence error sub attenuator value dB

Die interne Nullkalibrierung des A/D-Wandlers verlief bei der internen Kalibrierung nicht konvergent. Selbstkalibrierung wurde beendet, ohne die Selbstkalibrierungskonstanten zu ändern. Selbsttest für die Problemdiagnose ausführen.

720 Selbstkalibrierung fehlgeschlagen; Chan n, offset DAC cal with attenuator, convergence error
Selbstkalibrierung fehlgeschlagen; Chan n, offset DAC cal no attenuator, convergence error

Die interne Offset-Kalibrierung des A/D-Wandlers verlief bei der internen Kalibrierung nicht konvergent. Selbstkalibrierung wurde beendet, ohne die Selbstkalibrierungskonstanten zu ändern. Selbsttest für die Problemdiagnose ausführen.

850 Calibration error; set up is invalid

Die ausgewählte Kalibrierungs-Setup-Nummer ist ungültig.

850 Calibration error; set up is out of order

Bestimmte Kalibrierungsschritte erfordern spezifische Anfangs- und Endwerte. Gehen Sie nicht in die Mitte einer Kalibrierungssequenz.

Vorheriges Kalibrierungsthema


Einführung in die Kalibrierung - 33600 Series

Dieses Kapitel enthält Verfahren zur Überprüfung von Leistung und Einstellung (Kalibrierung) des Geräts.

Bei diesem Instrument wird die Kalibrierung elektronisch bei geschlossenem Gehäuse vorgenommen. Interne mechanische Einstellungen sind nicht erforderlich. Das Instrument berechnet Korrekturfaktoren auf der Basis Ihrer Eingabereferenzwerte und legt die Korrekturfaktoren im permanenten Speicher ab, bis die nächste Kalibrierungseinstellung durchgeführt wird. Diese Daten werden durch Ein- und Ausschalten oder den Reset-Befehl *RST nicht verändert.

Keysight Technologies Kalibrierungsservice

Ihr Keysight Technologies Service Center bietet eine kostengünstige Neukalibrierung. Das Service Center nutzt automatisierte Kalibrierungssysteme, so dass Keysight diesen Service zu attraktiven Preisen anbieten kann.

Kalibrierung Inhalt

Dieser Abschnitt umfasst die folgenden Abschnitte:

Überblick über die Kalibrierung

  • Kalibrierungsintervall
  • Einstellung wird empfohlen
  • Erforderliche Zeit für die Kalibrierung
  • Automatisierte Kalibrierungsverfahren
  • Empfohlene Testausrüstung
  • Überlegungen zum Test
  • Kalibrierungszahl
  • Kalibrierungsmeldung

Kalibrierungssicherheit

Überprüfung

Leistungsüberprüfungstests

  • Selbsttest
  • Leistungsschnelltest
  • Leistungsüberprüfungstests
  • Prüfverfahren für Amplitude und Frequenzgang

Interne Zeitbasisprüfung

Überprüfung AC-Amplitude (hochohmige Last)

Überprüfung DC-Offsetspannung

Überprüfung des 1 Vpp Frequenzgangbereichs

Überprüfung des 4 Vpp Frequenzgangbereichs

Überprüfung des 8 Vpp Frequenzgangbereichs

Allgemeines Kalibrierungs-/Anpassungsverfahren

Laufende Kalibrierung abbrechen

Anpassungssequenz

Selbsttest

Frequenzanpassung (interne Zeitbasis)

Anpassung des internen A/D-Konverters

Anpassung der Selbstkalibrierung

Anpassung der Ausgangsimpedanz

Anpassung der AC-Amplitude (hochohmige Last)

Anpassung des 1 Vpp Frequenzgangs

Anpassung des 4 Vpp Frequenzgangs

Anpassung des 8 Vpp Frequenzgangs

Kanal 2 anpassen (falls erforderlich)

  • Anpassung der Selbstkalibrierung (Kanal 2)
  • Anpassung der Ausgangsimpedanz (Kanal 2)
  • Anpassung der AC-Amplitude (hochohmige Last) (Kanal 2)
  • Anpassung des 1 Vpp Frequenzgangs (Kanal 2)
  • Anpassung des 4 Vpp Frequenzgangs (Kanal 2)
  • Anpassung des 8 Vpp Frequenzgangs

Kalibrierungsfehler

Nächstes Kalibrierungsthema


Überblick über die Kalibrierung - 33600 Series

Dieser Abschnitt gibt eine Einführung in die Kalibrierfunktionen des Geräts. Ausführlichere Informationen zur Kalibrierung finden Sie unter Einführung in die Kalibrierung.

Kalibrierungsintervall

Das Gerät sollte in regelmäßigen Intervallen kalibriert werden, die durch die Anforderungen Ihrer Anwendung an die Genauigkeit bestimmt werden. Für die meisten Anwendungen reicht ein einjähriges Intervall aus. Garantie für Genauigkeitsspezifikationen wird nur übernommen, falls die Einstellung in regulären Kalibrierungsintervallen stattfindet. Garantie für Genauigkeitsspezifikationen wird nicht übernommen, wenn das einjährige Kalibrierungsintervall nicht eingehalten wird. Keysight Technologies empfiehlt für keine Anwendung ein Kalibrierungsintervall von mehr als 2 Jahren.

Einstellung wird empfohlen

Welches Kalibrierungsintervall Sie auch wählen, Keysight Technologies empfiehlt, die vollständige Neueinstellung stets zum Kalibrierungsintervall durchzuführen. Dies gewährleistet, dass das Gerät während des Kalibrierungsintervalls innerhalb der Spezifikationen bleibt und bietet die beste Langzeitstabilität. Leistungsdaten, die mit dieser Methode gemessen wurden, können verwendet werden, um spätere Kalibrierungsintervalle auszudehnen. Verwenden Sie die Kalibrierungszahl, um zu prüfen, ob alle Einstellungen durchgeführt wurden.

Erforderliche Zeit für die Kalibrierung

Bei eingehender Geräteprüfung führen Sie zunächst die Leistungsüberprüfungstests durch. Nehmen Sie die Einstellungen vor und führen Sie die Leistungsüberprüfungstests erneut aus. Jeder dieser Schritte dauert bei manueller Durchführung etwa 30 Minuten pro Kanal.

Das Gerät kann auch automatisch unter Computersteuerung kalibriert werden. Bei der Computersteuerung können Sie das gesamte Kalibrierungsverfahren und die Leistungsüberprüfungstests in etwa 30 Minuten (ein Kanal) oder 60 Minuten (zwei Kanäle) durchführen, sobald das Gerät aufgewärmt ist (siehe Überlegungen zum Test).

Automatisierte Kalibrierungsverfahren

Sie können eine programmierbare Testausrüstung verwenden, um die gesamten Überprüfungs- und Anpassungsvorgänge zu automatisieren. Sie können jede Gerätekonfiguration des Tests über die Remoteschnittstelle konfigurieren. Dann geben Sie die abgelesenen Messdaten in ein Testprogramm ein und vergleichen die Ergebnisse mit den entsprechenden Testgrenzwerten.

Sie können das Gerät auch über die Remoteschnittstelle einstellen, der Vorgang entspricht der Einstellung über die Frontplatte. Verwenden Sie einen Computer für die Einstellungen, wählen Sie dabei zunächst die erforderliche Funktion und den Bereich auf der Messausrüstung aus. Senden Sie den Kalibrierungswert an das Gerät und starten Sie anschließend die Kalibrierung über die Remoteschnittstelle.

Sie müssen vor der Kalibrierung den Kalibrierschutz des Geräts aufheben.

Eine typische Programmiersequenz für einen Kalibrierungs-Setup sieht wie folgt aus:

  1. CAL:SETup 2 (konfiguriert das Gerät für Kalibrierungsschritt 2)
  2. Messung der Ausgangsfrequenz mit dem externen Frequenzzähler
  3. CAL:VALue 9.99994321E6 (sendet den gemessenen Wert an das Gerät)
  4. CAL? (startet die Kalibrierungseinstellung für Setup 2)
  5. Abgefragten Wert CAL? ablesen, um Misslingen (+1) oder Erfolg (+0) der Einstellung festzustellen
  6. CAL:SETup 3 (konfiguriert das Gerät für Kalibrierungsschritt 3)

Weitere Informationen zur Geräteprogrammierung unter Einführung in die SCPI-Sprache.

Empfohlene Testausrüstung

Die empfohlene Testausrüstung für Leistungsüberprüfung und Einstellungsverfahren ist nachstehend aufgeführt. Falls das empfohlene Instrument nicht verfügbar ist, verwenden Sie Kalibrierungsstandards von gleicher Genauigkeit.

Gerät | Anforderungen | Empfohlenes Modell | Verwendung*
Digitalmultimeter (DMM) | ACV, True RMS, AC-gekoppelte Genauigkeit: ±0,02% bis 1 MHz DC-Spannungsgenauigkeit: 50 ppm Auflösung: 100 µV Widerstandsgenauigkeit mit Offset-Ausgleich: ±0,1 Ω | Keysight 3458A | Q, P, T
Präzisions-AC-Spannungsmesser | 1000 Hz bis 30 MHz, 0,1 Vrms bis 2 Vrms (–7 dBm bis +20 dBm) Genauigkeit: 0,02 dB Auflösung: 0,01 dB | Fluke 5790A | Q, P, T
Frequenzzähler | Genauigkeit: 0,1 ppm | Keysight 53230A Opt 010 (OCXO) | Q, P, T
Leistungssensor | Spezifisches Modell | Keysight N8482A | Q, P, T
Leistungsmesser | Spezifisches Modell (eines von vier auswählen) | Keysight N1911A, N1912A, N1913A oder N1914A | Q, P, T
Oszilloskop | 1 GHz 4 Gs/Sekunde 50 Ω Eingangsbegrenzung | Keysight MSO6104A | T
Adapter | N Typ (m) bis BNC (m) | Keysight E9623A | Q, P, T
Kabel (2 erforderlich) | Doppelbananenstecker (m) an Doppelbananenstecker (m) | Keysight 11000-60000 | Q, P, T
Kabel | RG58, BNC (m) an Doppelbananenstecker ODER RG58 Koaxialkabel mit BNC (m) an Doppelbananenstecker |  | Q, P, T
Kabel | RG58, BNC (m) an BNC (m) | Keysight 11170C | Q, P, T
Kabel mit geringer Kabeldämpfung | Verwendung für den Anschluss an einen Abschwächer des Typs N, Fluke 5790A und N8482A. Frequenzgang geprüft durch Präsisions-Netzwerkanalysator (PNA) | (Alle, sofern sie durch einen PNA überprüft werden) | Q, P, T
10 bis 20 dB Abschwächer | Frequenzgang geprüft durch Präsisions-Netzwerkanalysator (PNA) | (Alle, sofern sie durch einen PNA überprüft werden) | Q, P, T

* Q = Quick Verification (Schnellüberprüfung) P = Performance Verification (Leistungsüberprüfung) T = Troubleshooting (Fehlerbehebung)

Überlegungen zum Test

Für optimale Leistung sollten alle Verfahren folgenden Empfehlungen entsprechen:

  • Die Umgebungstemperatur bei der Kalibrierung muss stabil bleiben und zwischen 18 und 28 °C liegen. Idealerweise liegt sie bei 23 ±1 °C.
  • Stellen Sie sicher, dass die relative Luftfeuchtigkeit unter 80 % beträgt.
  • Einstündiges Warmlaufen vor einer Überprüfung oder einer Einstellung.
  • Messkabel so kurz wie möglich, in Übereinstimmung mit den Anforderungen an die Kabelimpedanz.
  • RG-58 oder gleichwertiges 50 Ω Kabel.

Kalibrierungszahl

Sie können das Instrument abfragen, um zu bestimmen, wie viele Kalibrierungen durchgeführt wurden. Das Gerät wurde im Werk kalibriert. Wenn Sie das Gerät erhalten, sollten Sie den Kalibrierungszähler ablesen, um den Ausgangswert zu bestimmen.

  • Die Einstellung ist permanent; sie bleibt bei einem Aus- und Wiedereinschalten des Geräts oder einem *RST erhalten.
  • Da der Wert für jeden Kalibrierungspunkt inkrementiert, der einen Wert speichert, erhöht eine vollständige Kalibrierung den Wert um viele Zahlen.
  • Frontplatte: Systemtaste Softkey Instr Setup Softkey Calibrate
  • SCPI: CAL:COUNt?

Kalibrierungsmeldung

Sie können eine Meldung mit bis zu 40 Zeichen im Kalibrierungsspeicher ablegen. Sie können zum Beispiel das Datum der letzten Kalibrierung speichern, das Fälligkeitsdatum der nächsten Kalibrierung, die Seriennummer des Geräts oder die Kontaktinformationen Ihrer Kalibrierungsexperten.

Kalibrierschutz des Gerätes deaktivieren, um eine neue Kalibrierungsmeldung aufzuzeichnen. Sie können die Kalibrierungsmeldung sowohl über das vordere Bedienfeld als auch über die Remoteschnittstelle abfragen, auch bei aktiviertem Kalibrierschutz.

  • Beim Speichern einer Kalibrierungsmeldung wird die vorige Meldung überschrieben.
  • Die Einstellung ist permanent; sie bleibt bei einem Aus- und Wiedereinschalten des Geräts oder einem *RST erhalten.
  • Frontplatte: Systemtaste Softkey Instr Setup Softkey Calibrate
  • SCPI: CAL:STR "Cal Due: 01 August 2012"


Kalibrierungssicherheit - 33600 Series

In diesem Abschnitt wird das Kalibrierschutzsystem des Geräts beschrieben.

Übersicht Sicherheit

Ein Sicherheitscode verhindert versehentliche oder unberechtigte Einstellungen des Geräts. Der werkseitige Standardsicherheitscode für 33600 Series Geräte entspricht AT33600.

  • Derselbe Sicherheitscode gilt für die manuelle Betriebsart und für den Fernsteuerungsbetrieb. Wenn Sie den Kalibrierschutz über das vordere Bedienfeld aktivieren und ihn später über die Remoteschnittstelle deaktivieren möchten, müssen Sie denselben Sicherheitscode verwenden.
  • Die Einstellung ist permanent; sie bleibt bei einem Aus- und Wiedereinschalten des Geräts oder einem *RST erhalten.
  • Regeln zum Sicherheitscode:
    Zeichenfolge ohne Anführungszeichen, mit bis zu 12 Zeichen
    Muss mit einem Buchstaben (A-Z) beginnen
    Kann Buchstaben, Zahlen (0-9) und Unterstriche enthalten
  • Frontplatte:
    Taste System Softkey Instr Setup Softkey Calibrate Tastenfeld und Drehknopf
  • SCPI: CALibration_SECurity:STATe

Kalibrierschutz des Geräts ohne Sicherheitscode deaktivieren

Lesen Sie Vorsichtsmaßnahmen gegen elektrostatische Entladung (ESD), bevor Sie mit diesem Vorgang beginnen.
  1. Stromkabel und alle Eingangs- und Ausgangsverbindungen des Geräts trennen.
  2. Gerät zerlegen (siehe Demontage - 33600 Series).
  3. Führen Sie für 33600 Series Geräte einen vorübergehenden Kurzschluss zwischen Pins A1 und B1 auf der Leiterplatte der Frontplatte PCBA aus, wie unten dargestellt.

  4. Strom anschließen und Gerät einschalten.

    5. Warnung

    Achten Sie sorgfältig darauf, die Hauptstromanschlüsse oder hohe Spannungen am Netzanschlussmodul nicht zu berühren. Es fließt Strom, auch wenn das Gerät ausgeschaltet ist.
  5. Die Fehlerwarteschleife zeigt die Meldung "Calibration security has been disabled."

    Der Kalibrierschutz wird entsichert, das Kennwort wird auf die Standardeinstellung zurückgesetzt. Die Kalibrierungszahl wird inkrementiert, da die Steckbrücke während des Einschaltens angeschlossen war, folgende Fehlermeldung wird angezeigt: +701,"Calibration error; security defeated by hardware jumper". Die permanente Kalibrierungsspeicherung wird aktualisiert, um diese Arbeitsschritte wiederzugeben.
  6. Gerät ausschalten, Kurzschluss aufheben und Netzkabel entfernen.
  7. Gerät wieder zusammensetzen.
  8. Einen neuen Sicherheitscode eingeben, wie oben beschrieben, und diesen Sicherheitscode an einem sicheren Ort notieren.


Überprüfung - 33600 Series

Die folgenden Themen beschreiben den Bereich Überprüfung des Kalibrierungsverfahrens:

  • Leistungsüberprüfungstests
  • Interne Zeitbasisprüfung
  • Überprüfung AC-Amplitude (hochohmige Last)
  • Überprüfung DC-Offsetspannung
  • Überprüfung des 1 Vpp Frequenzgangbereichs
  • Überprüfung des 4 Vpp Frequenzgangbereichs
  • Überprüfung des 8 Vpp Frequenzgangbereichs


Leistungsüberprüfungstests - 33600 Series

Verwenden Sie die Leistungsüberprüfungstests zur Überprüfung der Messleistung des Instruments. Die Leistungsüberprüfungstests verwenden die auf dem Produktdatenblatt des Geräts aufgelisteten Spezifikationen.

Sie können drei verschiedene Stufen von Leistungsüberprüfungstests durchführen:

  • Selbsttest Ein Reihe interner Überprüfungstests, die hohe Sicherheit schaffen, dass das Gerät funktionsbereit ist.
  • Quick Verification Eine Kombination aus internen Selbsttests und ausgewählten Überprüfungstests.
  • Leistungsüberprüfungstests Eine umfangreiche Reihe von Tests, die als Akzeptanztests empfohlen werden, wenn Sie das Gerät neu erhalten oder nach Durchführung von Einstellungen.

Selbsttest

Beim Einschalten führt das Gerät automatisch einen kurzen Selbsttest durch. Dieser begrenzte Test stellt sicher, dass das Gerät funktionsbereit ist. Weitere Informationen finden Sie unter Selbsttest-Verfahren.

Leistungsschnelltest

Der Leistungsschnelltest ist eine Kombination von internem Selbsttest und einem abgekürzten Leistungstest (angegeben durch den Buchstaben Q in den Leistungsüberprüfungstests). Dieser Test bietet eine einfache Methode, um mit hoher Sicherheit festzustellen, ob das Gerät ordnungsgemäß funktioniert und den Spezifikationen entspricht. Diese Tests sind das absolute Minimum an empfohlenen Leistungsüberprüfungen nach der Ausführung einer technischen Serviceleistung. Die Prüfung der Leistung des Geräts über die Schnell-Check-Punkte (gekennzeichnet durch ein Q) überprüft die Leistung bei normalen Abweichungsmechanismen. Dieser Test überprüft nicht auf anormale Komponentenfehler.

Um einen Leistungsschnelltest durchzuführen, gehen Sie wie folgt vor:

  1. Vollständigen Selbsttest ausführen.
  2. Führen sie nur die Leistungsüberprüfungstests aus, die mit dem Buchstaben Q gekennzeichnet sind.
  3. Falls das Gerät den Leistungsschnelltest nicht besteht, ist eine Einstellung oder Reparatur erforderlich.

Leistungsüberprüfungstests

Die Leistungsüberprüfungstests werden als Akzeptanztests empfohlen, wenn Sie das Instrument erhalten. Die Ergebnisse des Akzeptanztests sollten mit den Spezifikationen auf dem Produktdatenblatt verglichen werden. Führen Sie die Leistungsüberprüfungstests nach der Akzeptanz zu jedem Kalibrierungsintervall durch.

Falls das Instrument den Leistungsüberprüfungstest nicht besteht, ist eine Einstellung oder Reparatur erforderlich.

Eine Einstellung wird zu jedem Kalibrierungsintervall empfohlen. Wird keine Einstellung vorgenommen, müssen Sie ein Schutzband einrichten, bei denen nicht mehr als 80 % der auf dem Datenblatt aufgeführten Spezifikationen als Überprüfungsgrenzen genutzt werden.

Prüfverfahren für Amplitude und Frequenzgang

Für das Prüfverfahren des Frequenzgangs ist ein Präzisions-AC-Spannungsmesser und ein Leistungsmessgerät zu verwenden. Sie können ihn durch einen Spannungswandler (Thermal Voltage Converter - TVC) ersetzen, um Messungen mit geeigneter Arbeitsweise und Testausrüstung durchzuführen.

Der Fluke 5790A Präzisions-AC-Spannungsmesser dient der Messung von Amplituden von 1 kHz bis 20 MHz. Von 20 bis 120 MHz wird ein Leistungsmessgerät mit dem Keysight N8482A Leistungssensor verwendet. Messungen von Amplituden für 5790A und N8482A mit 1 MHz bis 20 MHz werden zur Skalierung von N8482A und 5790A verwendet.


Interne Zeitbasisprüfung - 33600 Series

Überprüft die Ausgangsfrequenzgenauigkeit. Alle Ausgangsfrequenzen werden von einer einzigen generierten Frequenz abgeleitet.

  1. Einen Frequenzzähler an den Ausgang von Kanal 1 anschließen, siehe Abbildung unten (der Frequenzzählereingang sollte bei 50 Ω abgeschlossen sein).

    Anpassungs-Setup 1
  2. Gerät auf den in der Tabelle unten beschriebenen Ausgang einstellen und die Ausgangsfrequenz messen. Sicherstellen, dass der Geräteausgang aktiviert ist.
    3. Standardwerte | Wellenformgenerator |  |  | Messung
 | Funktion | Amplitude | Frequenz | Nennwert | Fehler*
Q | Sinus | 1,00 Vpp | 10,0000000 MHz | 10,000 MHz | ±10 Hz

    * Mit der optionalen Stabilitäts-OCXO-Zeitbasis beträgt der Messfehler ±1 Hz.

  3. Vergleichen Sie den gemessenen Wert mit den Testgrenzen aus der Tabelle.


Überprüfung AC-Amplitude (hochohmige Last) - 33600 Series

Prüft die Genauigkeit des AC-Amplitudenausgangs bei 1 kHz-Frequenz mit jedem Abschwächer.

  1. DMM-Wert zur Messung der Effektivspannung einstellen. Schließen Sie das DMM wie unten dargestellt an den Kanalausgang an.

    Anpassungs-Setup 2
  2. Gerät auf jeden Ausgang der Tabelle unten einstellen und die Ausgangsspannung mit dem DMM messen. Sicherstellen, dass die Ausgangsimpedanz auf High–Z eingestellt und der Ausgang aktiviert ist.
    3. Standardwerte | Wellenformgenerator |  |  |  | Messung
 | Ausgangseinstellung | Funktion | Frequenz | Amplitude | Nennwert | Fehler*
Q | High Z** | Sinus | 1,000 kHz | 400,0 mVrms | 400,0 mVrms | ±0,004707 Vrms
Q | High Z | Sinus | 1,000 kHz | 400,0 mVrms | 400,0 mVrms | ±0,004707 Vrms
Q | High Z | Sinus | 1,000 kHz | 1,00 Vrms | 1,00 Vrms | ±0,010707 Vrms
Q | High Z | Sinus | 1,000 kHz | 2,500 Vrms | 2,500 Vrms | ±0,025707 Vrms
Q | High Z | Sinus | 1,000 kHz | 7,000 Vrms | 7,000 Vrms | ±0,070707 Vrms

    * Basierend auf 1 % der Einstellung ±1 mVpp (50 Ω); bei High–Z in Effektivspannung (Vrms) umgewandelt.

    ** Folgende Sequenz verwenden, um diesen Ausgang einzustellen:

    1. Amplitude auf 400,0 mVrms einstellen
    2. DC-Offset auf 1,0 VDC einstellen
    3. Automatische Bereichswahl auf AUS schalten
    4. DC-Offset auf 0,0 VDC einstellen
    5. Nach dem Messvorgang die Automatische Bereichswahl für die restlichen Messungen auf EIN schalten.
  3. Vergleichen Sie den gemessenen Wert mit den Testgrenzen aus der Tabelle.
  4. Nur Zwei-Kanal-Instrumente: Schließen Sie DMM an den Ausgang von Kanal 2 an und wiederholen Sie die Schritte 2 und 3.


Überprüfung DC-Offsetspannung - 33600 Series

Prüft die DC-Offsetspannung an zwei Abschwächerbereichen:

  1. DMM-Wert zur Messung der DC-Spannung einstellen. Schließen Sie das DMM wie unten dargestellt an den Kanalausgang an.
    Anpassungs-Setup 2
  2. Gerät auf jeden Ausgang der Tabelle unten einstellen und die Ausgangsspannung mit dem DMM messen.
    3. Standardwerte | Wellenformgenerator |  |  | Messung
 | Ausgangseinstellung | Funktion | Spannung | Nennwert | Fehler*
Q | High Z | Gleichstrom | 0,0 V | 0,0 VDC | ±0,002 VDC
Q | High Z | Gleichstrom | 500 mV | 0,500 VDC | ±0,007 VDC
Q | High Z | Gleichstrom | 10,0 V | 10,0 VDC | ±0,102 VDC

    * Basierend auf 1 % der Einstellung ±2 mVDC für High-Z.

  3. Vergleichen Sie den gemessenen Wert mit den Testgrenzen aus der Tabelle.
  4. Nur Zwei-Kanal-Instrumente: Schließen Sie DMM an den Ausgang von Kanal 2 an und wiederholen Sie die Schritte 2 und 3.


Überprüfung des 1 Vpp Frequenzgangbereichs - 33600 Series

Prüft den hochfrequenten AC-Amplitudenfrequenzgang im Bereich 1 Vpp.

  1. Schließen Sie einen Präzisions-AC-Spannungsmesser an, um die Ausgangsamplitude zu messen, wie unten dargestellt. Schließen Sie das BNC-Kabel an den Breitbandeingang des Fluke 5790A an.Wenn Sie eine Ersatz-Testausstattung verwenden, sollten Sie prüfen, dass die Eingangsimpedanz 50 Ω beträgt, da die Lastgenauigkeit die Messqualität direkt beeinflusst.

    Anpassungs-Setup 3
  2. Stellen Sie den Präzisions-AC-Spannungsmesser auf "Medium, Medium" Digitalfilter und Filterneustart.
  3. Stellen Sie die Ausgangsimpedanz auf 50 Ω. Stellen Sie sicher, dass der Ausgang aktiviert ist. Gerät konfigurieren wie in der unten stehenden Tabelle beschrieben und die Ausgangsamplitude mit dem AC-Spannungsmesser messen. Dies wird zur Referenzmessung. Tragen Sie diesen Wert in Vrms in die untere Tabelle ein und erfassen Sie auch den entsprechenden Wert in dBm, indem Sie folgende Formel anwenden dBm = 10×log10(20×Vrms2).

    Standardwerte | Wellenformgenerator | Messung
    Ausgangslast | Funktion | Amplitude | Frequenz | Messergebnis
    Q 50 Ω Sinus 0,354 Vrms (3,990 dBm) 1,000 kHz

    Vrms

    dBm

  4. Stellen Sie die Funktion, Amplitude und Frequenz des Signalgenerators ein wie unten in der Tabelle beschrieben. Messen Sie die Amplitude und zeichnen Sie die Ergebnisse in der unteren Tabelle auf.
    Wellenformgenerator | Messung
    Standardwerte Ausgangslast Funktion Amplitude Frequenz Fehler bei Schritt 3 Referenz (Vrms) Messergebnis
    (Vrms)
    50 Ω | Sinus | 0,354 Vrms | 100,000 kHz | ±1,15%
    500,000 kHz
    1,000 MHz*
    5,000 MHz*
    50 Ω | Sinus | 0,354 Vrms | 10,00 MHz* | ±2,92%
    20,00 MHz*

    * Diese Werte werden in der unten abgebildeten Korrekturfaktor-Tabelle verwendet.

  5. Um das Leistungsmessgerät auf den Fluke 5790A abzustimmen wird ein Korrekturfaktor mithilfe der unten abgebildeten Tabelle berechnet. Es werden die Amplitudenmessungen vom 5790A und dem Leistungsmessgerät bei 1 MHz bis 20 MHz verwendet. Geben Sie die mit dem Fluke 5790A gemessenen Werte für 1, 5, 10, und 20 MHz unten in die Korrekturfaktor-Tabelle ein. Wenden Sie dann folgende Formel an, um die Ergebnisse von Vrms auf dBm umzurechnen:

    dBm = 10×log10(20×Vrms2)

    Berechnen Sie den Durchschnitt (arithmetischer Mittelwert) der vier dBm-Ergebnisse und geben Sie das Ergebnis unten in die Spalte Fluke 5790A dBm der Tabelle ein.
  6. Schließen Sie den N8482A an den Ausgang von Kanal 1 des Signalgenerators über einen Type-N-Steckverbinder an, wie unten gezeigt. Wiederholen Sie die 1, 5, 10, und 20 MHz-Messungen und geben Sie die dBm-Ergebnisse in die unten abgebildete Tabelle ein. Berechnen Sie den Durchschnitt (arithmetischer Mittelwert) der vier dBm-Ergebnisse und geben Sie das Ergebnis unten in die Spalte Leistungsmessgerät dBm der Tabelle ein.

  7. Subtrahieren Sie den mit dem Leistungsmessgerät gemessenen Durchschnittswert in dBm von dem mit dem Fluke 5790A gemessenen Durchschnittswert in dBm, um den Korrekturfaktor zu berechnen. Zeichnen Sie das Ergebnis in der unteren rechten Ecke der Korrekturfakor-Tabelle auf. Addieren Sie diesen Korrekturfakor zu all Ihren mit dem Leistungsmessgerät durchgeführten Messungen.

    Korrekturfaktor-Tabelle

    Fluke 5790A | Leistungsmesser
    Frequenz | Vrms (gemessen) | dBm (siehe Formel) | dBm (gemessen)
    1 MHz
    5 MHz
    10 MHz
    20 MHz
    Durchschnitt (Mittelwert): Durchschnitt (Mittelwert):
    Korrekturfaktor (Fluke 5790A Durchschnitt minus durchschnittlicher Leistungswert):
  8. Führen Sie die folgenden Messungen mit dem Leistungsmessgerät durch. Stellen Sie das 33600 Series Gerät auf die Funktion, Amplitude und Frequenzen wie unten angegeben ein. Zeichnen Sie die gemessenen dBm-Werte (unter Hinzufügen des Korrekturfaktors) für jede Frequenz in der unten abgebildeten Tabelle auf.

    Wellenformgenerator | Messung
    Standardwerte | Ausgangslast | Funktion | Amplitude | Frequenz | Fehler bei Schritt 3 Referenz | Messergebnis (dBm) | Korrigiertes Ergebnis (dBm)
    50 Ω | Sinus | 0,354 Vrms | 30,00 MHz | ±0,25 dB
    40,00 MHz
    50,00 MHz
    60,00 MHz
    50 Ω | Sinus | 0,354 Vrms | 70,00 MHz | ±0,40 dB
    80,00 MHz
    50 Ω | Sinus | 0,354 Vrms | 90,00 MHz | ±0,50 dB
    100,00 MHz
    110,00 MHz
    120,00 MHz
  9. Vergleichen Sie die gemessenen Werte mit den Testgrenzen aus beiden Tabellen.
  10. Nur Zwei-Kanal-Instrumente: Schließen Sie den AC-Spannungsmesser an Kanal 2 an und wiederholen Sie die Schritte 2 bis 6.


Überprüfung des 4 Vpp Frequenzgangbereichs - 33600 Series

Prüft den hochfrequenten AC-Amplitudenfrequenzgang im Bereich 4 Vpp.

  1. Schließen Sie einen Präzisions-AC-Spannungsmesser an, um die Ausgangsamplitude zu messen, wie unten dargestellt. Schließen Sie das BNC-Kabel an den Breitbandeingang des Fluke 5790A an. Wenn Sie eine Ersatz-Testausstattung verwenden, sollten Sie prüfen, dass die Eingangsimpedanz 50 Ω beträgt, da die Lastgenauigkeit die Messqualität direkt beeinflusst.

    Anpassungs-Setup 3
  2. Stellen Sie den Präzisions-AC-Spannungsmesser auf "Medium, Medium" Digitalfilter und Filterneustart.
  3. Stellen Sie die Ausgangsimpedanz auf 50 Ω. Stellen Sie sicher, dass der Ausgang aktiviert ist. Gerät konfigurieren wie in der unten stehenden Tabelle beschrieben und die Ausgangsamplitude mit dem AC-Spannungsmesser messen. Dies wird zur Referenzmessung. Tragen Sie diesen Wert in Vrms in die untere Tabelle ein und erfassen Sie auch den entsprechenden Wert in dBm, indem Sie folgende Formel anwenden dBm = 10×log10(20×Vrms2).

    Standardwerte | Wellenformgenerator | Messung
    Ausgangslast | Funktion | Amplitude | Frequenz | Messergebnis
    Q 50 Ω Sinus 1,414 Vrms (16,019 dBm) 1,000 kHz

    Vrms

    dBm

  4. Stellen Sie die Funktion, Amplitude und Frequenz des Signalgenerators ein wie unten in der Tabelle beschrieben. Messen Sie die Amplitude und zeichnen Sie die Ergebnisse in der unteren Tabelle auf.
    Wellenformgenerator | Messung
    Standardwerte Ausgangslast Funktion Amplitude Frequenz Fehler bei Schritt 3 Referenz (Vrms) Messergebnis
    (Vrms)
    50 Ω | Sinus | 1,414 Vrms | 100,000 kHz | ±1,15%
    500,000 kHz
    1,000 MHz*
    5,000 MHz*
    50 Ω | Sinus | 1,414 Vrms | 10,00 MHz* | ±2,92%
    20,00 MHz*

    * Diese Werte werden in der unten abgebildeten Korrekturfaktor-Tabelle verwendet.

  5. Um das Leistungsmessgerät auf den Fluke 5790A abzustimmen wird ein Korrekturfaktor mithilfe der unten abgebildeten Tabelle berechnet. Es werden die Amplitudenmessungen vom 5790A und dem Leistungsmessgerät bei 1 MHz bis 20 MHz verwendet. Geben Sie die mit dem Fluke 5790A gemessenen Werte für 1, 5, 10, und 20 MHz unten in die Korrekturfaktor-Tabelle ein. Wenden Sie dann folgende Formel an, um die Ergebnisse von Vrms auf dBm umzurechnen:

    dBm = 10×log10(20×Vrms2)

    Berechnen Sie den Durchschnitt (arithmetischer Mittelwert) der vier dBm-Ergebnisse und geben Sie das Ergebnis unten in die Spalte Fluke 5790A dBm der Tabelle ein.
  6. Schließen Sie den N8482A an den Ausgang von Kanal 1 des Signalgenerators über einen Type-N-Steckverbinder an, wie unten gezeigt. Wiederholen Sie die 1, 5, 10, und 20 MHz-Messungen und geben Sie die dBm-Ergebnisse in die unten abgebildete Tabelle ein. Berechnen Sie den Durchschnitt (arithmetischer Mittelwert) der vier dBm-Ergebnisse und geben Sie das Ergebnis unten in die Spalte Leistungsmessgerät dBm der Tabelle ein.

  7. Subtrahieren Sie den mit dem Leistungsmessgerät gemessenen Durchschnittswert in dBm von dem mit dem Fluke 5790A gemessenen Durchschnittswert in dBm, um den Korrekturfaktor zu berechnen. Zeichnen Sie das Ergebnis in der unteren rechten Ecke der Korrekturfakor-Tabelle auf. Addieren Sie diesen Korrekturfakor zu all Ihren mit dem Leistungsmessgerät durchgeführten Messungen.

    Korrekturfaktor-Tabelle

    Fluke 5790A | Leistungsmesser
    Frequenz | Vrms (gemessen) | dBm (siehe Formel) | dBm (gemessen)
    1 MHz
    5 MHz
    10 MHz
    20 MHz
    Durchschnitt (Mittelwert): Durchschnitt (Mittelwert):
    Korrekturfaktor (Fluke 5790A Durchschnitt minus durchschnittlicher Leistungswert):
  8. Führen Sie die folgenden Messungen mit dem Leistungsmessgerät durch. Stellen Sie das 33600 Series Gerät auf die Funktion, Amplitude und Frequenzen wie unten angegeben ein. Zeichnen Sie die gemessenen dBm-Werte (unter Hinzufügen des Korrekturfaktors) für jede Frequenz in der unten abgebildeten Tabelle auf.

    Wellenformgenerator | Messung
    Standardwerte | Ausgangslast | Funktion | Amplitude | Frequenz | Fehler bei Schritt 3 Referenz | Messergebnis (dBm) | Korrigiertes Ergebnis (dBm)
    50 Ω | Sinus | 1,414 Vrms | 30,00 MHz | ±0,25 dB
    40,00 MHz
    50,00 MHz
    60,00 MHz
    50 Ω | Sinus | 1,414 Vrms | 70,00 MHz | ±0,40 dB
    80,00 MHz
    50 Ω | Sinus | 1,414 Vrms | 90,00 MHz | ±0,50 dB
    100,00 MHz
    110,00 MHz
    120,00 MHz
  9. Vergleichen Sie die gemessenen Werte mit den Testgrenzen aus beiden Tabellen.
  10. Nur Zwei-Kanal-Instrumente: Schließen Sie den AC-Spannungsmesser an Kanal 2 an und wiederholen Sie die Schritte 2 bis 6.


Überprüfung des -8 dB Frequenzgangbereichs - 33600 Series

Prüft den hochfrequenten AC-Amplitudenfrequenzgang im Bereich 8 Vpp.

  1. Schließen Sie einen Präzisions-AC-Spannungsmesser an, um die Ausgangsamplitude zu messen, wie unten dargestellt. Schließen Sie das BNC-Kabel an den Breitbandeingang des Fluke 5790A an.Wenn Sie eine Ersatz-Testausstattung verwenden, sollten Sie prüfen, dass die Eingangsimpedanz 50 Ω beträgt, da die Lastgenauigkeit die Messqualität direkt beeinflusst.

    Anpassungs-Setup 3
  2. Stellen Sie den Präzisions-AC-Spannungsmesser auf "Medium, Medium" Digitalfilter und Filterneustart.
  3. Stellen Sie die Ausgangsimpedanz auf 50 Ω. Stellen Sie sicher, dass der Ausgang aktiviert ist. Gerät konfigurieren wie in der unten stehenden Tabelle beschrieben und die Ausgangsamplitude mit dem AC-Spannungsmesser messen. Dies wird zur Referenzmessung. Tragen Sie diesen Wert in Vrms in die untere Tabelle ein und erfassen Sie auch den entsprechenden Wert in dBm, indem Sie folgende Formel anwenden dBm = 10×log10(20×Vrms2).

    Standardwerte | Wellenformgenerator | Messung
    Ausgangslast | Funktion | Amplitude | Frequenz | Messergebnis
    Q 50 Ω Sinus 2,828 Vrms (22,040 dBm) 1,000 kHz

    Vrms

    dBm

  4. Stellen Sie die Funktion, Amplitude und Frequenz des Signalgenerators ein wie unten in der Tabelle beschrieben. Messen Sie die Amplitude und zeichnen Sie die Ergebnisse in der unteren Tabelle auf.
    Wellenformgenerator | Messung
    Standardwerte Ausgangslast Funktion Amplitude Frequenz Fehler bei Schritt 3 Referenz (Vrms) Messergebnis
    (Vrms)
    50 Ω | Sinus | 2,828 Vrms | 100,000 kHz | ±1,15%
    500,000 kHz
    1,000 MHz*
    5,000 MHz*
    50 Ω | Sinus | 2,828 Vrms | 10,00 MHz* | ±2,92%
    20,00 MHz*

    * Diese Werte werden in der unten abgebildeten Korrekturfaktor-Tabelle verwendet.

  5. Um das Leistungsmessgerät auf den Fluke 5790A abzustimmen wird ein Korrekturfaktor mithilfe der unten abgebildeten Tabelle berechnet. Es werden die Amplitudenmessungen vom 5790A und dem Leistungsmessgerät bei 1 MHz bis 20 MHz verwendet. Geben Sie die mit dem Fluke 5790A gemessenen Werte für 1, 5, 10, und 20 MHz unten in die Korrekturfaktor-Tabelle ein. Wenden Sie dann folgende Formel an, um die Ergebnisse von Vrms auf dBm umzurechnen:

    dBm = 10×log10(20×Vrms2)

    Berechnen Sie den Durchschnitt (arithmetischer Mittelwert) der vier dBm-Ergebnisse und geben Sie das Ergebnis unten in die Spalte Fluke 5790A dBm der Tabelle ein.
  6. Schließen Sie den N8482A an den Ausgang von Kanal 1 des Signalgenerators über einen Type-N-Steckverbinder an, wie unten gezeigt. Wiederholen Sie die 1, 5, 10, und 20 MHz-Messungen und geben Sie die dBm-Ergebnisse in die unten abgebildete Tabelle ein. Berechnen Sie den Durchschnitt (arithmetischer Mittelwert) der vier dBm-Ergebnisse und geben Sie das Ergebnis unten in die Spalte Leistungsmessgerät dBm der Tabelle ein.

    Um eine Beschädigung des N8482A Leistungssensors zu verhindern, muss der 10 bis 20 dB Abschwächer in Reihe mit der Messung eingesetzt werden.

  7. Subtrahieren Sie den mit dem Leistungsmessgerät gemessenen Durchschnittswert in dBm von dem mit dem Fluke 5790A gemessenen Durchschnittswert in dBm, um den Korrekturfaktor zu berechnen. Zeichnen Sie das Ergebnis in der unteren rechten Ecke der Korrekturfakor-Tabelle auf. Addieren Sie diesen Korrekturfakor zu all Ihren mit dem Leistungsmessgerät durchgeführten Messungen.

    Korrekturfaktor-Tabelle

    Fluke 5790A | Leistungsmesser
    Frequenz | Vrms (gemessen) | dBm (siehe Formel) | dBm (gemessen)
    1 MHz
    5 MHz
    10 MHz
    20 MHz
    Durchschnitt (Mittelwert): Durchschnitt (Mittelwert):
    Korrekturfaktor (Fluke 5790A Durchschnitt minus durchschnittlicher Leistungswert):
  8. Führen Sie die folgenden Messungen mit dem Leistungsmessgerät durch. Stellen Sie das 33600 Series Gerät auf die Funktion, Amplitude und Frequenzen wie unten angegeben ein. Zeichnen Sie die gemessenen dBm-Werte (unter Hinzufügen des Korrekturfaktors) für jede Frequenz in der unten abgebildeten Tabelle auf.

    Wellenformgenerator | Messung
    Standardwerte | Ausgangslast | Funktion | Amplitude | Frequenz | Fehler bei Schritt 3 Referenz | Messergebnis (dBm) | Korrigiertes Ergebnis (dBm)
    50 Ω | Sinus | 2,828 Vrms | 30,00 MHz | ±0,25 dB
    40,00 MHz
    50,00 MHz
    60,00 MHz
    50 Ω | Sinus | 2,828 Vrms | 70,00 MHz | ±0,40 dB
    80,00 MHz
  9. Vergleichen Sie die gemessenen Werte mit den Testgrenzen aus beiden Tabellen.
  10. Nur Zwei-Kanal-Instrumente: Schließen Sie den AC-Spannungsmesser an Kanal 2 an und wiederholen Sie die Schritte 2 bis 6.


Allgemeines Kalibrierungs-/Anpassungsverfahren - 33600 Series

Empfohlene Methode für eine komplette Gerätekalibrierung:

  1. Lesen Sie die Überlegungen zum Test.
  2. Ausführung von Überprüfungstests zur Charakterisierung des Geräts (eingehende Daten).
  3. Drücken Sie [System > Instr Setup > Calibrate. Wenn das Gerät für die Kalibrierung gesichert ist, zunächst seine Sicherung deaktivieren.
  4. Geben Sie die Setup-Nummer für den ausgeführten Vorgang ein. Die Standard-Setup-Nummer ist "1" und über die Frontplatte steigt die Zahl mit der Ausführung der Verfahren an.
  5. Wählen Sie BEGIN.
  6. Passen Sie bei Setups, die eine Eingabe erfordern, den im Display angezeigten Wert an den gemessenen Wert an und wählen Sie ENTER VALUE.
  7. Das Setup geht automatisch bis zum nächsten erforderlichen Wert.

    Um den Anpassungsvorgang abzubrechen, wählen Sie CANCEL STEP. Das Display kehrt dann zum Eintrag der Setup-Nummer zurück.
  8. Wählen Sie nach Beenden des Vorgangs END CAL.
  9. (Optional) Wählen Sie mit der Remote-Schnittstelle eine neue Kalibrierungsmeldung. Die Meldung (bis zu 40 Zeichen) wird mit den Kalibrierungskoeffizienten gespeichert.
  10. Aktivieren Sie den Kalibrierungsschutz des Geräts.
  11. Notieren Sie den neuen Sicherheitscode und den Kalibrierungszähler in den Wartungsunterlagen des Geräts.


Laufende Kalibrierung abbrechen - 33600 Series

Manchmal kann es notwendig sein, eine laufende Kalibrierung abzubrechen. Sie können eine Kalibrierung jederzeit abbrechen, indem Sie den Strom ausschalten oder über die Remote-Schnittstelle eine Löschmeldung eingeben und dann*RST eingeben.

Das Gerät speichert Kalibrierungskonstanten am Ende jedes Anpassungsvorgangs. Wenn die Stromversorgung unterbrochen wird oder eine laufende Anpassung anderweitig abgebrochen wird, müssen Sie den unterbrochenen Anpassungsvorgang einfach erneut ausführen.

Vorsicht

Wenn die Stromversorgung unterbrochen wird, während das Gerät versucht, neue Kalibrierungskonstanten in den Speicher zu schreiben, kann es sein, dass alle Kalibrierungskonstanten für die Funktion verloren gehen. Typischerweise zeigt das Gerät bei der Wiederherstellung der Stromversorgung die Fehlermeldung "-313, Calibration Memory Lost" an.


Anpassungssequenz - 33600 Series

Die Anpassungssequenz in den nummerierten Segmenten minimiert die Anzahl der Testausstattungs-Setups und Anschlusswechsel.

Benutzerdefinierte Anpassungen können wie erforderlich durchgeführt werden, aber die Setups 1 bis 7 müssen in dieser Reihenfolge ausgeführt werden, bevor ein anderer Setup-Vorgang begonnen wird.


Selbsttest - 33600 Series

Führen Sie einen Selbsttest aus, um sicherzustellen, dass das Gerät funktionsfähig ist, bevor Sie zusätzliche Anpassungen vornehmen.

Stellen Sie sicher, dass dass Gerät entsperrt ist und die unter Testüberlegungen aufgeführten Anforderungen eingehalten werden, bevor Sie mit den Anpassungen beginnen.

  1. Drücken Sie [System > Instr Setup > Calibrate. Geben Sie die Setup-Nummer 1 ein und wählen Sie BEGIN.
    2. Setup |
1 | Führt einen Geräteselbsttest durch. Der Hauptausgang ist beim Test deaktiviert.
  2. Falls ein Selbsttest fehlschlägt, müssen Sie das Gerät reparieren, bevor das Gerät mit den Anpassungsverfahren fortfährt.

Ein vollständiger Selbsttest (*TST?) dauert ca. 15 Sekunden.


Frequenzanpassung (interne Zeitbasis) - 33600 Series

Das Gerät speichert eine Kalibrierkonstante, die den Kristalloszillator so einstellt, dass genau 10 MHz ausgegeben werden. Das Gerät sollte vor dieser Kalibrierungsanpassung 30 Minuten lang kontinuierlich gearbeitet haben, um die Zeitbasisstabilität sicherzustellen

  1. Stellen Sie die Frequenzzählerauflösung besser als 0,01 ppm ein und die Eingangsbegrenzung auf 50 Ω (wenn Ihr Frequenzzähler keine 50 Ω Eingangsbegrenzung hat, müssen Sie eine externe Begrenzung bereitstellen). Nehmen Sie die Anschlüsse vor wie unten angegeben.

    Anpassungs-Setup 1
  2. Verwenden Sie den Frequenzzähler, um die Ausgangsfrequenz für jeden Setup in folgender Tabelle zu messen.
    3.  | Nennsignal |  |
Setup | Frequenz | Amplitude |
2 | <10 MHz | ~1 Vpp | Die Ausgangsfrequenz ist etwas geringer als 10 MHz
3 | >10 MHz |  | Die Ausgangsfrequenz ist etwas höher als 10 MHz
4 | ~10 MHz |  | Die Ausgangsfrequenz sollte ca. 10 MHz betragen
5* | 10 MHz |  | Die Ausgangsfrequenz sollte 10 MHz ± 1 ppm betragen

    * Konstanten werden nach Abschluss dieses Setups gespeichert.

  3. Stimmen Sie mit der Zifferntastatur oder mit dem Drehknopf die angezeigte Frequenz bei jedem Setup auf die gemessene Frequenz ab. Wählen Sie ENTER VALUE.
  4. Um fortzufahren:
  1. Wenn Ihr Kalibriervorgang eine Überprüfung der soeben vorgenommen Anpassungen erfordert, verlassen Sie das Kalibriermenü und führen Sie Interne Zeitbasisprüfung.
  2. Wenn Sie alle Anpassungen vornehmen und dann die Leistung des Geräts überprüfen, fahren Sie mit dem nächsten Vorgang in diesem Abschnitt fort.


Anpassung des internen A/D-Konverters - 33600 Series

Das Gerät speichert Kalibrierkonstanten, die sich auf Verstärkung und Offset des internen A/D-Konverters beziehen. Setup 8 muss stets ausgeführt werden, bevor versucht wird, andere Amplitudenanpassungen vorzunehmen. Der interne A/D-Konverter wird dann als Quelle für die Kalibrierkonstanten verwendet, die bei der Selbstkalibrierung generiert werden (Setup 9). (Setup 6 and Setup 7 are not used.)

  1. Schließen Sie den Ausgang von Kanal 1 wie unten dargestellt an den Modulationseingang an der Rückwand des Geräts und DMM an.
    Anpassungs-Setup 4
  2. Stellen Sie den DMM-Wert so ein, dass 5½ Ziffern angezeigt werden, und die Funktion auf DCV.
  3. Geben Sie folgendes Setup ein.
    4.  | Nennsignal |
Setup | DC-Pegel |
8* | ~1,1 VDC ±10% | Kalibriert den internen A/D-Konverter.

    * Konstanten werden nach Abschluss dieses Setups gespeichert.

  4. Verwenden Sie die Zifferntastatur oder den Drehknopf, um den gemessenen DMM-Wert einzugeben.

    5. Hinweis

    Dieses Setup erfordert ca. 15 Sekunden.
  5. Trennen Sie alle Kabel vom Gerät.


Anpassung der Selbstkalibrierung - 33600 Series

  1. Geben Sie folgendes Setup ein und beginnen Sie mit der Ausführung.
    2. Setup |
9* | Selbstkalibrierung. Der Ausgang ist deaktiviert.

    * Konstanten werden nach Abschluss dieses Setups gespeichert.

  2. Um fortzufahren:
  1. Wenn Ihr Kalibriervorgang eine Überprüfung der soeben vorgenommen Anpassungen erfordert, verlassen Sie das Kalibriermenü und führen Sie eine Überprüfung DC-Offsetspannung durch.
  2. Wenn Sie alle Anpassungen vornehmen und dann die Leistung des Geräts überprüfen, fahren Sie mit dem nächsten Vorgang in diesem Abschnitt fort.

Hinweis

Dieses Setup erfordert ca. 15 Sekunden.


Anpassung der Ausgangsimpedanz - 33600 Series

Das Gerät speichert die Kalibrierungskonstanten für die Ausgangsimpedanz des Kanals. Diese Konstanten werden mit und ohne den dem Verstärker nachgeschalteten Abschwächer generiert.

  1. Stellen Sie das DMM für eine Messung mit Offset-Ausgleich und 4-Draht-Widerstand ein. Stellen Sie das DMM so ein, dass eine 100 NPLC Integration verwendet wird. Schließen Sie die DMM-Eingänge Ohm-Quelle und Ohm-Abtastung an den Kanalausgang an, wie unten dargestellt.
    Anpassungs-Setup 5
  2. Führen Sie mit dem DMM eine 4-Draht-Widerstandsmessung am Frontplattenausgangsanschluss für jedes Setup der folgenden Tabelle durch. Das erwartete Messergebnis beträgt ca. 50 Ω.
    3. Setup |
10* | Gleichstromverstärker
11* | Verstärker plus 100 MHz-Filter
12* | Verstärker plus 150 MHz-Filter
13* | 24 dB-Nachabschwächer
14* | 24 dB-Nachabschwächer plus 150 MHz-Filter

    * Konstanten werden nach Abschluss dieses Setups gespeichert.

  3. Stimmen Sie mit der Zifferntastatur oder mit dem Drehknopf die angezeigte Impedanz bei jedem Setup auf die gemessene Impedanz ab. Wählen Sie ENTER VALUE.
  4. Es gibt keine speziellen Funktionsprüfungstests für die Ausgangsimpedanz. Fahren Sie mit dem nächsten Anpassungsvorgang dieses Abschnitts fort.


Anpassung der AC-Amplitude (hochohmige Last) - 33600 Series

Das Gerät speichert eine Kalibrierungskonstante für jeden Abschwächer-Pfad für hochohmige Lasten. Der Verstärkungskoeffizient jedes Pfades wird über zwei Messungen berechnet: eine mit dem Signal-DAC bei + Ausgang und eine mit dem Signal-DAC bei – Ausgang. Daher müssen die Setups paarweise erfolgen.

  1. Schließen Sie das DMM wie unten dargestellt an den Kanalausgang an.
    Anpassungs-Setup 2
  2. Messen Sie mit dem DMM die DC-Spannung am Frontplattenanschluss für jedes Setup der folgenden Tabelle.

    Setup | Nennsignal
    DC-Pegel
    15 | +0,0028 V | Ausgabe aus dem -72 dB Bereich
    16* | -0,0028 V | Ausgabe aus dem -72 dB Bereich
    17 | +0,0068 V | Ausgabe aus dem -64 dB Bereich
    18* | -0,0068 V | Ausgabe aus dem -64 dB Bereich
    19 | +0,0170 V | Ausgabe aus dem -56 dB Bereich
    20* | -0,0170 V | Ausgabe aus dem -56 dB Bereich
    21 | +0,0430 V | Ausgabe aus dem -48 dB Bereich
    22* | -0,0430 V | Ausgabe aus dem -48 dB Bereich
    23 | +0,1060 V | Ausgabe aus dem -40 dB Bereich
    24* | -0,1060 V | Ausgabe aus dem -40 dB Bereich
    25 | +0,2680 V | Ausgabe aus dem -32 dB Bereich
    26* | -0,2680 V | Ausgabe aus dem -32 dB Bereich
    27 | +0,6600 V | Ausgabe aus dem -24 dB Bereich
    28* | -0,6600 V | Ausgabe aus dem -24 dB Bereich
    29 | +1,6500 V | Ausgabe aus dem -16 dB Bereich
    30* | -1,6500 V | Ausgabe aus dem -16 dB Bereich
    31 | +4,2000 V | Ausgabe aus dem -8 dB Bereich
    32* | -4,2000 V | Ausgabe aus dem -8 dB Bereich
    33 | +10,4000 V | Ausgabe aus dem 0 dB Bereich
    34* | -10,4000 V | Ausgabe aus dem 0 dB Bereich
    35 | +0,0430 V | Ausgabe aus dem hohen -48 dB DC-Bereich
    36* | -0,0430V | Ausgabe aus dem hohen -48 dB DC-Bereich
    37 | +0,1060 V | Ausgabe aus dem hohen -40 dB DC-Bereich
    38* | -0,1060 V | Ausgabe aus dem hohen -40 dB DC-Bereich
    39 | +0,2680 V | Ausgabe aus dem hohen -32 dB DC-Bereich
    40* | -0,2680 V | Ausgabe aus dem hohen -32 dB DC-Bereich
    41 | +0,6600 V | Ausgabe aus dem hohen -24 dB DC-Bereich
    42* | -0,6600 V | Ausgabe aus dem hohen -24 dB DC-Bereich

    3. * Konstanten werden nach Abschluss dieses Setups gespeichert.

  3. Stimmen Sie mit der Zifferntastatur oder mit dem Drehknopf die angezeigte Spannung bei jedem Setup auf die gemessene Spannung ab. Wählen Sie ENTER VALUE.
  4. Um fortzufahren:
  1. Wenn der Kalibrierungsvorgang eine Überprüfung dieser Anpassung erfordert, verlassen Sie das Kalibrierungsmenü und führen Sie eine Überprüfung AC-Amplitude (hochohmige Last) durch.
  2. Wenn Sie alle Anpassungen vornehmen und dann die Leistung des Geräts überprüfen, fahren Sie mit dem nächsten Vorgang in diesem Abschnitt fort.


Anpassung des 1 Vpp Frequenzgangs - 33600 Series

  1. Schließen Sie für Frequenzen bis einschließlich 20 MHz einen Präzisions-AC-Spannungsmesser an, um die Ausgangsamplitude zu messen, wie unten dargestellt. Schließen Sie das BNC-Kabel an den Breitbandeingang des Fluke 5790A an.

    Anpassungs-Setup 3

    Schließen Sie für Frequenzen über 20 MHz einen Präzisions-Leistungssensor und ein Leistungsmessgerät an, um die Ausgangsamplitude zu messen, wie unten dargestellt.

  2. Verwenden Sie den Präzisions-AC-Spannungsmesser zur Messung der Ausgangsamplitude für jedes Setup der unten abgebildeten Tabelle.

    Setup | Nennsignal
    Frequenz | Amplitude
    43* | 1 kHz | 380 mVrms | Frequenzgang für den 1 Vpp Bereich
    44* | 100 kHz
    45* | 1 MHz
    46* | 5 MHz
    47* | 10 MHz
    48* | 20 MHz
    49* | 25 MHz
    50* | 30 MHz
    51 | 40 MHz
    52 | 50 MHz
    53 | 60 MHz
    54 | 70 MHz
    55 | 80 MHz
    56 | 90 MHz
    57 | 100 MHz
    58 | 110 MHz
    59 | 120 MHz

    * Konstanten werden nach Abschluss dieses Setups gespeichert.
  3. Stimmen Sie mit der Zifferntastatur oder mit dem Drehknopf die angezeigte Spannung bei jedem Setup auf die gemessene Spannung ab. Wählen Sie ENTER VALUE.
  4. Um fortzufahren:
  1. Wenn Ihr Kalibriervorgang eine Überprüfung der soeben vorgenommen Anpassungen erfordert, verlassen Sie das Kalibriermenü und führen Sie Überprüfung des 1 Vpp Frequenzgangbereichs.
  2. Wenn Sie alle Anpassungen vornehmen und dann die Leistung des Geräts überprüfen, fahren Sie mit dem nächsten Vorgang in diesem Abschnitt fort.


Anpassung des 4 Vpp Frequenzgangs - 33600 Series

  1. Schließen Sie für Frequenzen bis einschließlich 20 MHz einen Präzisions-AC-Spannungsmesser an, um die Ausgangsamplitude zu messen, wie unten dargestellt. Schließen Sie das BNC-Kabel an den Breitbandeingang des Fluke 5790A an.

    Anpassungs-Setup 3

    Schließen Sie für Frequenzen über 20 MHz einen Präzisions-Leistungssensor und ein Leistungsmessgerät an, um die Ausgangsamplitude zu messen, wie unten dargestellt.

  2. Verwenden Sie den Präzisions-AC-Spannungsmesser zur Messung der Ausgangsamplitude für jedes Setup der unten abgebildeten Tabelle.
    3. Setup | Nennsignal |  |
 | Frequenz | Amplitude |
60* | 1 kHz | 960 mVrms | Frequenzgang für den -8 dB Bereich
61* | 100 kHz
62* | 1 MHz
63* | 5 MHz
64* | 10 MHz
65* | 20 MHz
66* | 25 MHz
67* | 30 MHz
68 | 40 MHz
69 | 50 MHz
70 | 60 MHz
71 | 70 MHz
72 | 80 MHz
73 | 90 MHz
74 | 100 MHz
75 | 110 MHz
76 | 120 MHz

    * Konstanten werden nach Abschluss dieses Setups gespeichert.

  3. Stimmen Sie mit der Zifferntastatur oder mit dem Drehknopf die angezeigte Spannung bei jedem Setup auf die gemessene Spannung ab. Wählen Sie ENTER VALUE.
  4. Um fortzufahren:
  1. Wenn Ihr Kalibriervorgang eine Überprüfung der soeben vorgenommen Anpassungen erfordert, verlassen Sie das Kalibriermenü und führen Sie Überprüfung des 4 Vpp Frequenzgangbereichs.
  2. Wenn Sie alle Anpassungen vornehmen und dann die Leistung des Geräts überprüfen, prüfen Sie die Ausgangsspezifikationen des Geräts Leistungsüberprüfungstests.

Damit sind die Anpassungsvorgänge für das Einkanalgerät abgeschlossen. Eine Überprüfung der Ausgangsspezifikationen wird empfohlen.

Wenn Sie an einem Zweikanalgerät Anpassungen vornehmen, fahren Sie mit dem nächsten Verfahren dieses Abschnitts fort.


Überprüfung des -8 Vpp Frequenzgangs - 33600 Series

  1. Schließen Sie für Frequenzen bis einschließlich 20 MHz einen Präzisions-AC-Spannungsmesser an, um die Ausgangsamplitude zu messen, wie unten dargestellt. Schließen Sie das BNC-Kabel an den Breitbandeingang des Fluke 5790A an.

    Anpassungs-Setup 3

    Schließen Sie für Frequenzen über 20 MHz einen Präzisions-Leistungssensor und ein Leistungsmessgerät an, um die Ausgangsamplitude zu messen, wie unten dargestellt.

  2. Verwenden Sie den Präzisions-AC-Spannungsmesser zur Messung der Ausgangsamplitude für jedes Setup der unten abgebildeten Tabelle.
    3. Setup | Nennsignal |  |
 | Frequenz | Amplitude |
77* | 1 kHz | 2,4 Vrms | Frequenzgang für 0 dB Bereich
78* | 100 kHz
79* | 1 MHz
80* | 5 MHz
81* | 10 MHz
82* | 20 MHz
83* | 25 MHz
84* | 30 MHz
85 | 40 MHz
86 | 50 MHz
87 | 60 MHz
88 | 70 MHz
89 | 80 MHz

    * Konstanten werden nach Abschluss dieses Setups gespeichert.

  3. Stimmen Sie mit der Zifferntastatur oder mit dem Drehknopf die angezeigte Spannung bei jedem Setup auf die gemessene Spannung ab. Wählen Sie ENTER VALUE.
  4. Um fortzufahren:
  1. Wenn Ihr Kalibriervorgang eine Überprüfung der soeben vorgenommen Anpassungen erfordert, verlassen Sie das Kalibriermenü und führen Sie Überprüfung des 8 Vpp Frequenzgangbereichs.
  2. Wenn Sie alle Anpassungen vornehmen und dann die Leistung des Geräts überprüfen, prüfen Sie die Ausgangsspezifikationen des Geräts Leistungsüberprüfungstests.

Damit sind die Anpassungsvorgänge für das Einkanalgerät abgeschlossen. Eine Überprüfung der Ausgangsspezifikationen wird empfohlen.

Wenn Sie an einem Zweikanalgerät Anpassungen vornehmen, fahren Sie mit dem nächsten Verfahren dieses Abschnitts fort.


Anpassungen Kanal 2 - 33600 Series

Folgende Themen beschreiben die Kalibrierungsanpassungen von Kanal 2.

  • Anpassung der Selbstkalibrierung (Kanal 2)
  • Anpassung der Ausgangsimpedanz (Kanal 2)
  • Anpassung der AC-Amplitude (hochohmige Last) (Kanal 2)
  • Anpassung des -16 dB Frequenzgangbereichs (Kanal 2)
  • Anpassung des -8 dB Frequenzgangbereichs (Kanal 2)
  • Anpassung des 0 dB Frequenzgangbereichs


Anpassung der Selbstkalibrierung (Kanal 2) - 33600 Series

  1. Geben Sie folgendes Setup ein und beginnen Sie mit der Ausführung.
    2. Setup |
90* | Selbstkalibrierung. Der Ausgang ist deaktiviert.

    * Konstanten werden nach Abschluss dieses Setups gespeichert.

  2. Um fortzufahren:
  1. Wenn Ihr Kalibriervorgang eine Überprüfung der soeben vorgenommen Anpassungen erfordert, verlassen Sie das Kalibriermenü und führen Sie eine Überprüfung DC-Offsetspannung durch. Stellen Sie sicher, dies für Kanal 2 durchzuführen.
  2. Wenn Sie alle Anpassungen vornehmen und dann die Leistung des Geräts überprüfen, fahren Sie mit dem nächsten Vorgang in diesem Abschnitt fort.

Hinweis

Dieses Setup erfordert ca. 15 Sekunden.


Anpassung der Ausgangsimpedanz (Kanal 2) - 33600 Series

Das Gerät speichert die Kalibrierungskonstanten für die Ausgangsimpedanz des Kanals. Diese Konstanten werden mit und ohne den dem Verstärker nachgeschalteten Abschwächer generiert.

  1. Stellen Sie das DMM für eine Messung mit Offset-Ausgleich und 4-Draht-Widerstand ein. Stellen Sie das DMM so ein, dass eine 100 NPLC Integration verwendet wird. Schließen Sie die DMM-Eingänge Ohm-Quelle und Ohm-Abtastung an den Kanalausgang an, wie unten dargestellt.
    Anpassungs-Setup 6
  2. Führen Sie mit dem DMM eine 4-Draht-Widerstandsmessung am Frontplattenausgangsanschluss für jedes Setup der folgenden Tabelle durch. Das erwartete Messergebnis beträgt ca. 50 Ω.
    3. Setup |
91* | Gleichstromverstärker
92* | Verstärker plus 100 MHz-Filter
93* | Verstärker plus 150 MHz-Filter
94* | 24 dB-Nachabschwächer
95* | 24 dB-Nachabschwächer plus 150 MHz-Filter

    * Konstanten werden nach Abschluss dieses Setups gespeichert.

  3. Stimmen Sie mit der Zifferntastatur oder mit dem Drehknopf die angezeigte Impedanz bei jedem Setup auf die gemessene Impedanz ab. Wählen Sie ENTER VALUE.
  4. Es gibt keine speziellen Funktionsprüfungstests für die Ausgangsimpedanz. Fahren Sie mit dem nächsten Anpassungsvorgang dieses Abschnitts fort.


Anpassung der AC-Amplitude (hochohmige Last) (Kanal 2) - 33600 Series

Das Gerät speichert eine Kalibrierungskonstante für jeden Abschwächer-Pfad für hochohmige Lasten. Der Verstärkungskoeffizient jedes Pfades wird über zwei Messungen berechnet: eine mit dem Signal-DAC bei + Ausgang und eine mit dem Signal-DAC bei – Ausgang. Daher müssen die Setups paarweise erfolgen.

  1. Schließen Sie das DMM wie unten dargestellt an den Kanalausgang an.
    Anpassungs-Setup 7
  2. Messen Sie mit dem DMM die DC-Spannung am Frontplattenanschluss für jedes Setup der folgenden Tabelle.

    3. Setup | Nennsignal |
 | DC-Pegel |
96 | +0,0028 V | Ausgabe aus dem -72 dB Bereich
97* | -0,0028 V | Ausgabe aus dem -72 dB Bereich
98 | +0,0068 V | Ausgabe aus dem -64 dB Bereich
99* | -0,0068 V | Ausgabe aus dem -64 dB Bereich
100 | +0,0170 V | Ausgabe aus dem -56 dB Bereich
101* | -0,0170 V | Ausgabe aus dem -56 dB Bereich
102 | +0,0430 V | Ausgabe aus dem -48 dB Bereich
103* | -0,0430 V | Ausgabe aus dem -48 dB Bereich
104 | +0,1060 V | Ausgabe aus dem -40 dB Bereich
105* | -0,1060 V | Ausgabe aus dem -40 dB Bereich
106 | +0,2680 V | Ausgabe aus dem -32 dB Bereich
107* | -0,2680 V | Ausgabe aus dem -32 dB Bereich
108 | +0,6600 V | Ausgabe aus dem -24 dB Bereich
109* | -0,6600 V | Ausgabe aus dem -24 dB Bereich
110 | +1,6500 V | Ausgabe aus dem -16 dB Bereich
111* | -1,6500 V | Ausgabe aus dem -16 dB Bereich
112 | +4,2000 V | Ausgabe aus dem -8 dB Bereich
113* | -4,2000 V | Ausgabe aus dem -8 dB Bereich
114 | +10,4000 V | Ausgabe aus dem 0 dB Bereich
115* | -10,4000 V | Ausgabe aus dem 0 dB Bereich
116 | +0,0430 V | Ausgabe aus dem hohen -48 dB DC-Bereich
117* | -0,0430V | Ausgabe aus dem hohen -48 dB DC-Bereich
118 | +0,1060 V | Ausgabe aus dem hohen -40 dB DC-Bereich
119* | -0,1060 V | Ausgabe aus dem hohen -40 dB DC-Bereich
120 | +0,2680 V | Ausgabe aus dem hohen -32 dB DC-Bereich
121* | -0,2680 V | Ausgabe aus dem hohen -32 dB DC-Bereich
122 | +0,6600 V | Ausgabe aus dem hohen -24 dB DC-Bereich
123* | -0,6600 V | Ausgabe aus dem hohen -24 dB DC-Bereich

    * Konstanten werden nach Abschluss dieses Setups gespeichert.
  3. Stimmen Sie mit der Zifferntastatur oder mit dem Drehknopf die angezeigte Spannung bei jedem Setup auf die gemessene Spannung ab. Wählen Sie ENTER VALUE.
  4. Um fortzufahren:
  1. Wenn der Kalibrierungsvorgang eine Überprüfung dieser Anpassung erfordert, verlassen Sie das Kalibrierungsmenü und führen Sie eine Überprüfung AC-Amplitude (hochohmige Last) durch.
  2. Wenn Sie alle Anpassungen vornehmen und dann die Leistung des Geräts überprüfen, fahren Sie mit dem nächsten Vorgang in diesem Abschnitt fort.


Anpassung des 1 Vpp Frequenzgangs (Kanal 2) - 33600 Series

  1. Schließen Sie für Frequenzen bis einschließlich 20 MHz einen Präzisions-AC-Spannungsmesser an, um die Ausgangsamplitude zu messen, wie unten dargestellt. Schließen Sie das BNC-Kabel an den Breitbandeingang des Fluke 5790A an.

    Anpassungs-Setup 3

    Schließen Sie für Frequenzen über 20 MHz einen Präzisions-Leistungssensor und ein Leistungsmessgerät an, um die Ausgangsamplitude zu messen, wie unten dargestellt.

  2. Verwenden Sie den Präzisions-AC-Spannungsmesser zur Messung der Ausgangsamplitude für jedes Setup der unten abgebildeten Tabelle.

    Setup | Nennsignal
    Frequenz | Amplitude
    124* | 1 kHz | 380 mVrms | Frequenzgang für den 1 Vpp Bereich
    125* | 100 kHz
    126* | 1 MHz
    127* | 5 MHz
    128* | 10 MHz
    129* | 20 MHz
    130* | 25 MHz
    131* | 30 MHz
    132 | 40 MHz
    133 | 50 MHz
    134 | 60 MHz
    135 | 70 MHz
    136 | 80 MHz
    137 | 90 MHz
    138 | 100 MHz
    139 | 110 MHz
    140 | 120 MHz

    * Konstanten werden nach Abschluss dieses Setups gespeichert.
  3. Stimmen Sie mit der Zifferntastatur oder mit dem Drehknopf die angezeigte Spannung bei jedem Setup auf die gemessene Spannung ab. Wählen Sie ENTER VALUE.
  4. Um fortzufahren:
  1. Wenn Ihr Kalibriervorgang eine Überprüfung der soeben vorgenommen Anpassungen erfordert, verlassen Sie das Kalibriermenü und führen Sie Überprüfung des 1 Vpp Frequenzgangbereichs. Stellen Sie sicher, dies für Kanal 2 durchzuführen.
  2. Wenn Sie alle Anpassungen vornehmen und dann die Leistung des Geräts überprüfen, fahren Sie mit dem nächsten Vorgang in diesem Abschnitt fort.


Anpassung des 4 Vpp Frequenzgangs (Kanal 2) - 33600 Series

Dieser Abschnitt bezieht sich auf Kanal 2. Prüft den hochfrequenten AC-Amplitudenfrequenzgang im -8 dB Abschwächerbereich. Zudem prüft er den Frequenzgang für alle anderen Bereiche mit Ausnahme der -24 dB und 0 dB Abschwächerbereiche.

  1. Schließen Sie für Frequenzen bis einschließlich 20 MHz einen Präzisions-AC-Spannungsmesser an, um die Ausgangsamplitude zu messen, wie unten dargestellt. Schließen Sie das BNC-Kabel an den Breitbandeingang des Fluke 5790A an.

    Anpassungs-Setup 3

    Schließen Sie für Frequenzen über 20 MHz einen Präzisions-Leistungssensor und ein Leistungsmessgerät an, um die Ausgangsamplitude zu messen, wie unten dargestellt.

  2. Verwenden Sie den Präzisions-AC-Spannungsmesser zur Messung der Ausgangsamplitude für jedes Setup der unten abgebildeten Tabelle.

    Setup | Nennsignal
    Frequenz | Amplitude
    141* | 1 kHz | 960 mVrms | Frequenzgang für den -8 dB Bereich
    142* | 100 kHz
    143* | 1 MHz
    144* | 5 MHz
    145* | 10 MHz
    146* | 20 MHz
    147* | 25 MHz
    148* | 30 MHz
    149 | 40 MHz
    150 | 50 MHz
    151 | 60 MHz
    152 | 70 MHz
    153 | 80 MHz
    154 | 90 MHz
    155 | 100 MHz
    156 | 110 MHz
    157 | 120 MHz

    3. * Konstanten werden nach Abschluss dieses Setups gespeichert.

  3. Stimmen Sie mit der Zifferntastatur oder mit dem Drehknopf die angezeigte Spannung bei jedem Setup auf die gemessene Spannung ab. Wählen Sie ENTER VALUE.
  4. Die empfohlenen Anpassungsvorgänge sind nun abgeschlossen. Eine Überprüfung der Ausgangsspezifikationen wird empfohlen.
    1. Wenn Ihr Kalibriervorgang eine Überprüfung der soeben vorgenommen Anpassungen erfordert, verlassen Sie das Kalibriermenü und führen Sie Überprüfung des 4 Vpp Frequenzgangbereichs.


Anpassung des 8 Vpp Frequenzgangs - 33600 Series

  1. Schließen Sie für Frequenzen bis einschließlich 20 MHz einen Präzisions-AC-Spannungsmesser an, um die Ausgangsamplitude zu messen, wie unten dargestellt. Schließen Sie das BNC-Kabel an den Breitbandeingang des Fluke 5790A an.

    Anpassungs-Setup 3

    Schließen Sie für Frequenzen über 20 MHz einen Präzisions-Leistungssensor und ein Leistungsmessgerät an, um die Ausgangsamplitude zu messen, wie unten dargestellt.

  2. Verwenden Sie den Präzisions-AC-Spannungsmesser zur Messung der Ausgangsamplitude für jedes Setup der unten abgebildeten Tabelle.
    3. Setup | Nennsignal |  |
 | Frequenz | Amplitude |
158* | 1 kHz | 2,4 Vrms | Frequenzgang für 0 dB Bereich
159* | 100 kHz
160* | 1 MHz
161* | 5 MHz
162* | 10 MHz
163* | 20 MHz
164* | 25 MHz
165* | 30 MHz
166 | 40 MHz
167 | 50 MHz
168 | 60 MHz
169 | 70 MHz
170 | 80 MHz

    * Konstanten werden nach Abschluss dieses Setups gespeichert.

  3. Stimmen Sie mit der Zifferntastatur oder mit dem Drehknopf die angezeigte Spannung bei jedem Setup auf die gemessene Spannung ab. Wählen Sie ENTER VALUE.
  4. Um fortzufahren:
  1. Wenn Ihr Kalibriervorgang eine Überprüfung der soeben vorgenommen Anpassungen erfordert, verlassen Sie das Kalibriermenü und führen Sie Überprüfung des 8 Vpp Frequenzgangbereichs.
  2. Wenn Sie alle Anpassungen vornehmen und dann die Leistung des Geräts überprüfen, prüfen Sie die Ausgangsspezifikationen des Geräts Leistungsüberprüfungstests.

Damit sind die Anpassungsvorgänge für das Einkanalgerät abgeschlossen.Eine Überprüfung der Ausgangsspezifikationen wird empfohlen.

Wenn Sie an einem Zweikanalgerät Anpassungen vornehmen, fahren Sie mit dem nächsten Verfahren dieses Abschnitts fort.


Kalibrierungsfehler - 33600 Series

Folgende Fehler können bei der Kalibrierung auftreten. Es gibt Systemfehler und Selbsttestfehler. Manche Fehlermeldungen enthalten eine fehlerhafte Kanalnummer (1 oder 2), wie in den Meldungen unten.

701 Calibration error; security defeated by hardware jumper

Bei einem Kurzschließen der Steckbrücke zur Kalibrierungssicherung (CAL ENABLE) beim Einschalten des Geräts zeigt dieser Fehler an, dass das Sicherheitskennwort überschrieben wurde.Ausführlichere Informationen finden Sie unter Kalibrierungssicherheit.

702 Calibration error; calibration memory is secured

Vor der Kalibrierung muss der Kalibrierschutz des Geräts deaktiviert werden.Ausführlichere Informationen finden Sie unter Kalibrierungssicherheit.

703 Calibration error; secure code provided was invalid

Der angegebene Sicherheitscode war ungültig.

706 Calibration error; value out of range

Der eingegebene Wert befindet sich außerhalb des Gültigkeitsbereichs.

707 Calibration error; signal input is out of range

Erfolgt während der Anpassung des internen A/D-Konverters, Setup 6, wenn die 1 V Eingangsspannung zu hoch ist. Kann auch während der Selbstkalibrierung auftreten (Setup 7). Selbsttest für die Problemdiagnose ausführen.

710 Self-calibration failed; Chan n, null DAC cal, invalid self cal
Self-calibration failed; Chan n, offset DAC cal with attenuator, invalid self cal
Self-calibration failed; Chan n, offset DAC cal no attenuator, invalid self cal

Bei der internen Kalibrierung des angegebenen A/D-Wandlers ist ein Fehler aufgetreten. Selbstkalibrierung wurde beendet, ohne die Selbstkalibrierungskonstanten zu ändern. Selbsttest für die Problemdiagnose ausführen.

711 Self-calibration failed; Chan n, null DAC cal gain too low (too high), <meas_value>
Self-calibration failed; Chan n, offset DAC cal with attenuator gain too low (too high), <meas_value>
Self-calibration failed; Chan n, offset DAC cal no attenuator gain too low (too high), <meas_value>

Der berechnete Verstärkungsfaktor für den angegebenen A/D-Wandler lag außerhalb des Bereichs. Selbstkalibrierung wurde beendet, ohne die Selbstkalibrierungskonstanten zu ändern. Selbsttest für die Problemdiagnose ausführen.

712 Self-calibration failed; Chan n, null DAC cal zero too low (too high), <meas_value>
Self-calibration failed; Chan n, offset DAC cal with attenuator zero too low (too high), <meas_value>
Self-calibration failed; Chan n, offset DAC cal no attenuator zero too low (too high), <meas_value>
Self-calibration failed; Chan n, GND measurement out of limits, <meas_value>

Der berechnete Kalibrierfaktor für den angegebenen Kalibrierfaktor A/D-Wandler lag außerhalb des Bereichs. Selbstkalibrierung wurde beendet, ohne die Selbstkalibrierungskonstanten zu ändern. Selbsttest für die Problemdiagnose ausführen.

715 Selbstkalibrierung fehlgeschlagen; Chan n, null DAC cal, convergence error sub attenuator value dB

Die interne Nullkalibrierung des A/D-Wandlers verlief bei der internen Kalibrierung nicht konvergent. Selbstkalibrierung wurde beendet, ohne die Selbstkalibrierungskonstanten zu ändern. Selbsttest für die Problemdiagnose ausführen.

720 Selbstkalibrierung fehlgeschlagen; Chan n, offset DAC cal with attenuator, convergence error
Selbstkalibrierung fehlgeschlagen; Chan n, offset DAC cal no attenuator, convergence error

Die interne Offset-Kalibrierung des A/D-Wandlers verlief bei der internen Kalibrierung nicht konvergent. Selbstkalibrierung wurde beendet, ohne die Selbstkalibrierungskonstanten zu ändern. Selbsttest für die Problemdiagnose ausführen.

850 Calibration error; set up is invalid

Die ausgewählte Kalibrierungs-Setup-Nummer ist ungültig.

850 Calibration error; set up is out of order

Bestimmte Kalibrierungsschritte erfordern spezifische Anfangs- und Endwerte. Gehen Sie nicht in die Mitte einer Kalibrierungssequenz.

Vorheriges Kalibrierungsthema


Blockdiagramm - 33500 Series

Das Gerät verfügt über vier Hauptbaugruppen:

  • Prozessor
  • Hauptplatine
  • Frontplatte
  • Hauptstromversorgung

Ein vereinfachtes Blockdiagramm wird unten in diesem Abschnitt angezeigt.

Der Prozessor ist ein Einplatinenrechner mit CPU, RAM, ROM und den Schaltkreisen für den Antrieb von GPIB, LAN und USB-Anschlüssen. Die integrierte Webschnittstelle ist im ROM enthalten. Die Schaltkreise des Prozessors sind geerdet.

Nach dem Drücken des Ein-/Aus-Schalters kommuniziert der Prozessor mit dem FPGA und lädt dieses. Diese Kommunikation verwendet drei asynchrone Serial-Data-Leitungen und eine serielle Taktleitung. Diese vier Leitungen sind isoliert.

Das FPGA speichert alle Signale mit Ausnahme von Arbiträrsignalen. Arbiträrsignale werden in den SDRAM an der Hauptplatine geladen. Der FPGA leistet die gesamte Steuerung von Signalen, Triggern, Sync-Signalen, Ausgangspfaden, Dämpfung und Offset.

Das Hauptsignal für jeden Kanal (im Blockdiagramm ist nur ein Kanal dargestellt) wird in den Signal-D/A-Wandler geladen und von der Zeitbasis getaktet. Der D/A-Wandler-Ausgang läuft vor den Hauptabschwächern durch ein elliptisches Filter. Im Pfad stehen drei Abschwächer zur Verfügung: -7,96 dB, -15,91 dB und -23,87 dB.

Das Signal wird auf den Ausgangsverstärker angewendet. Der DC-Offset wird am Ausgangsverstärker hinzuaddiert. Ein dem Verstärker nachgeschalteter -23,87 dB Abschwächer steht für sehr schwacher Signale zur Verfügung. Nachstehende Tabelle zeigt die Abschwächer, die de Ausgangssignalamplitude erzeugen.

Ausgangsbereich DC-Offsetspannung < 320 mV | -7,96 dB | -15,91 dB | -23,87 dB | -23,87 dB (nach)
10 Vpp - 3,6 Vpp | Aus | Aus | Aus | Aus
4 Vpp - 1,44 Vpp | Ein | Aus | Aus | Aus
1,6 Vpp - 576 mVpp | Aus | Ein | Aus | Aus
640 mVpp - 230 mVpp | Aus | Aus | Aus | Ein
256 mVpp - 92 mVpp | Ein | Aus | Aus | Ein
102,4 mVpp - 36,86 mVpp | Aus | Ein | Aus | Ein
40,96 mVpp - 14,75 mVpp | Aus | Aus | Ein | Ein
16,38 mVpp - 5,90 mVpp | Ein | Aus | Ein | Ein
6,55 mVpp - 2,36 mVpp | Aus | Ein | Ein | Ein
2,62 mVpp - 1,00 mVpp | Ein | Ein | Ein | Ein

Ausgangsbereich DC-Offsetspannung ≥ 320 mV | -7,96 dB | -15,91 dB | -23,87 dB | -23,87 dB (nach)
9,36 Vpp - 3,6 Vpp | Aus | Aus | Aus | Aus
4 Vpp - 1,44 Vpp | Ein | Aus | Aus | Aus
1,6 Vpp - 576 mVpp | Aus | Ein | Aus | Aus
640 mVpp - 230 mVpp | Aus | Aus | Ein | Aus
256 mVpp - 92 mVpp | Ein | Aus | Ein | Aus
102,4 mVpp - 36,86 mVpp | Aus | Ein | Ein | Aus
40,96 mVpp - 1,00 mVpp | Ein | Ein | Ein | Aus

Wenn das Ausgangsrelais aktiviert ist, stellt es das Signal dem BNC-Anschluss an der Frontplatte BNC bereit. Ist dieses Relais deaktiviert, führt es das Signal zum Modulations-A/D-Wandler (für den internen Selbsttest und Kalibrierungsroutinen).

Das Ausgangsrelais wird durch das FPGA gesteuert. Zwei Schaltkreise bieten Überspannungs- und Überstromschutz, hauptsächlich durch einen externen Schaltkreis. Das Gerät erkennt sehr niedrige Ausgangsimpedanzen.

Das Sync Ausgangssignal wird als Signal vom FPGA zum Sync A/D-Wandler erzeugt.

Externer Trigger ein und aus ist am BNC-Anschluss auf Chassis-Masse bezogen, aber vor dem FPGA isoliert.

Der Modulationseingang ist ein isolierter Eingang zum A/D-Wandler. Das FPGA wendet das Modulationssignal auf das Ausgangssignal an.

Der Taktgenerator des Geräts verwendet einen 10-MHz-Kristalloszillator und eine PLL-Schaltung zum Erzeugen der 250-MHz-Takte, die von FPGA und Signal-D/A-Wandler genutzt werden. Wenn eine externe 10-MHz-Frequenzreferenz verwendet wird, behält eine digitale PLL-Schaltung im FPGA den Kristalloszillator im Sync.

Blockdiagramm - 33500 Series


Blockdiagramm - 33600 Series

Das Gerät verfügt über vier Hauptbaugruppen:

  • Prozessor
  • Hauptplatine
  • Frontplatte
  • Hauptstromversorgung

Ein vereinfachtes Blockdiagramm wird unten in diesem Abschnitt angezeigt.

Der Prozessor befindet sich im Frontplattenaufbau und umfasst CPU, RAM und ROM sowie Schaltkreise für den Antrieb von GPIB, LAN und USB-Anschlüssen. Die integrierte Webschnittstelle ist im ROM enthalten. Die Schaltkreise des Prozessors sind geerdet.

Nach dem Drücken des Ein-/Aus-Schalters kommuniziert der Prozessor mit dem FPGA am Zwischenboden und lädt dieses. Diese Kommunikation verwendet drei asynchrone Serial-Data-Leitungen und eine serielle Taktleitung. Diese vier Leitungen sind isoliert.

Das FPGA speichert alle Signale mit Ausnahme von Arbiträrsignalen. Arbiträrsignale werden am Zwischenboden in SDRAM geladen. Der FPGA leistet die gesamte Steuerung von Signalen, Triggern, Sync-Signalen, Ausgangspfaden, Dämpfung und Offset.

Das Hauptsignal für jeden Kanal (im Blockdiagramm ist nur ein Kanal dargestellt) wird in den Signal-D/A-Wandler geladen und vom Taktgenerator getaktet. Der D/A-Wandler-Ausgang läuft vor den Hauptabschwächern durch ein Anti-Alias-Filter. Im Pfad stehen drei Abschwächer zur Verfügung: -7,96 dB, -15,91 dB und -23,87 dB.

Das Signal wird auf den Ausgangsverstärker angewendet. Der DC-Offset wird am Ausgangsverstärker hinzuaddiert. Ein dem Verstärker nachgeschalteter -23,87 dB Abschwächer steht für sehr schwacher Signale zur Verfügung. Nachstehende Tabelle zeigt die Abschwächer, die de Ausgangssignalamplitude erzeugen.

Ausgangsbereich DC-Offsetspannung < 320 mV | -7,96 dB | -15,91 dB | -23,87 dB | -23,87 dB (nach)
10 Vpp - 4.0001 Vpp | Aus | Aus | Aus | Aus
4,1 Vpp - 1,44 Vpp | Ein | Aus | Aus | Aus
1,6 Vpp - 576 mVpp | Aus | Ein | Aus | Aus
640 mVpp - 230 mVpp | Aus | Aus | Aus | Ein
256 mVpp - 92 mVpp | Ein | Aus | Aus | Ein
102,4 mVpp - 36,86 mVpp | Aus | Ein | Aus | Ein
40,96 mVpp - 14,75 mVpp | Aus | Aus | Ein | Ein
16,38 mVpp - 5,90 mVpp | Ein | Aus | Ein | Ein
6,55 mVpp - 2,36 mVpp | Aus | Ein | Ein | Ein
2,62 mVpp - 1,00 mVpp | Ein | Ein | Ein | Ein

Ausgangsbereich DC-Offsetspannung ≥ 320 mV | -7,96 dB | -15,91 dB | -23,87 dB | -23,87 dB (nach)
9,36 Vpp - 3,6 Vpp | Aus | Aus | Aus | Aus
4 Vpp - 1,44 Vpp | Ein | Aus | Aus | Aus
1,6 Vpp - 576 mVpp | Aus | Ein | Aus | Aus
640 mVpp - 230 mVpp | Aus | Aus | Ein | Aus
256 mVpp - 92 mVpp | Ein | Aus | Ein | Aus
102,4 mVpp - 36,86 mVpp | Aus | Ein | Ein | Aus
40,96 mVpp - 1,00 mVpp | Ein | Ein | Ein | Aus
DC-Volt-Funktion < 320 mV | Ein | Ein | Ein | Ein
DC-Volt-Funktion ≥ 320 mV | Ein | Ein | Ein | Aus

Zwei Relais im Ausgangswechsel- und Filterblock bieten drei Wege zum BNC-Anschluss der Frontplatte (einen direkten und zwei durch Filter, die die Ausgangsverzerrung reduzieren) sowie einen offenen Weg zur Deaktivierung des Ausgangs. Eine abgeschwächte Version des Ausgangs wird für interne Selbsttests und zur Kalibrierung in den Modulations-A/D-Wandler eingegeben.

Die Ausgangsrelais werden durch das FPGA gesteuert. Zwei Schaltkreise bieten Überspannungs- und Überstromschutz, hauptsächlich durch einen externen Schaltkreis. Das Gerät erkennt sehr niedrige Ausgangsimpedanzen.

Das Sync Ausgangssignal wird als Signal vom FPGA zum Sync A/D-Wandler erzeugt.

Externer Trigger ein und aus ist am BNC-Anschluss auf Chassis-Masse bezogen, aber vor dem FPGA isoliert.

Der Modulationseingang ist ein Eingang zum A/D-Wandler. Das FPGA wendet das Modulationssignal auf das Ausgangssignal an.

Der Taktgenerator des Geräts verwendet einen 10-MHz-Kristalloszillator und eine PLL-Schaltung zum Erzeugen der 2-GHz-Takte, die von FPGA und Signal-D/A-Wandler genutzt werden. Wenn eine externe 10-MHz-Frequenzreferenz verwendet wird, behält eine PLL-Schaltung im FPGA den Kristalloszillator im Sync.

Blockdiagramm - 33600 Series


Stromversorgungen - 33500 Series

Die Netzspannung wird gefiltert und wirkt auf die Hauptstromversorgung, eine +15 V-Stromversorgung, die stets eingeschaltet ist, wenn sie an das Stromnetz angeschlossen ist. Ein Regler erzeugt eine geerdete +3,3 V Stromversorgung von der Hauptstromversorgung, die ebenfalls immer aktiv ist, wenn sie an das Stromnetz angeschlossen ist.

Ein kleiner Mikroprozessor an der Hauptplatine erkennt den Ein-/Aus-Schalter und aktiviert alle anderen Stromversorgungen.

Blockdiagramm der Stromversorgung


Stromversorgungen - 33600 Series

Die Netzspannung wird gefiltert und wirkt auf die Hauptstromversorgung, eine +24 V-Stromversorgung, die stets eingeschaltet ist, wenn sie an das Stromnetz angeschlossen ist. Ein Regler erzeugt eine geerdete +5 V Stromversorgung von der Hauptstromversorgung, die ebenfalls immer aktiv ist, wenn sie an das Stromnetz angeschlossen ist.

Ein kleiner Mikroprozessor an der Frontplatte erkennt den Ein-/Aus-Schalter und aktiviert alle anderen Stromversorgungen.

Blockdiagramm der Stromversorgung


Fehlerbehebung - 33500 Series

Nachstehend finden Sie eine kurze Liste häufig auftretender Störungen. Stellen Sie vor einer Fehlerbehebung oder Reparatur des Geräts sicher, dass es sich um eine Störung am Gerät und nicht an den externen Anschlüssen handelt. Stellen Sie weiterhin sicher, dass das Gerät im letzten Jahr korrekt kalibriert wurde. Die Schaltkreise des Geräts ermöglichen eine Fehlerbehebung und Reparaturen mit einer einfachen Testausrüstung.

Das Gerät ist funktionsunfähig

Bitte prüfen Sie folgende Punkte:

  • Das AC-Netzkabel ist sicher an das Gerät angeschlossen und mit einer Steckdose verbunden
  • Der Einschalt-/Standby-Schalter an der Frontplatte ist gedrückt

Der Selbsttest schlägt fehl

Stellen Sie sicher, dass alle (vorder- und rückseitigen) Anschlüsse entfernt wurden, wenn der Selbsttest ausgeführt wird. Während des Selbsttests können Fehler durch Signale an externen Leitungen (z. B. langen Testleitungen, die als Antennen wirken) induziert werden.

Vorsicht

Tauschen Sie NICHT das Motherboard, die Prozessorplatine oder die Frontplattenplatine verschiedener Geräte aus. Diese Platinen enthalten die Modell- und Seriennummerangaben, die nur für ein spezifisches Gerät gelten. Platinen, die nicht zum Gerät passen, können zu Problemen hinsichtlich Leistung, Lizenz, Funktionstüchtigkeit, Import-/Exportfähigkeit oder Garantie führen.

Stromversorgung

Überprüfen Sie die Hauptstromversorgung.

Warnung

Gefahr eines elektrischen Schlags. Entfernen Sie für die Prüfung der Stromversorgungen die Geräteabdeckung, wie unter Demontage beschrieben.

Die Hauptstromversorgung bietet eine Stromversorgung von +15 VDC (±0,3 VDC) für die Hauptplatine. Alle anderen Stromversorgungen sind von dieser Stromversorgung abgeleitet. Diese Stromversorgung ist immer stromführend, wenn das Netzkabel angeschlossen ist.

Testen Sie die Stromversorgung am Anschluss der Hauptplatine. Beachten Sie, dass die Stromversorgung nicht auf Chassis-Masse bezogen ist, wenn sie von der Hauptplatine getrennt ist.

  • Fehler im Stromkreis können hohe Stromversorgungslasten erzeugen, die die Ausgangsspannung der Stromversorgung senken können. Trennen Sie die Hauptstromversorgung von der zu testenden Hauptplatine.
  • Prüfen Sie stets mit einem Oszilloskop, dass die Stromversorgung schwingungsfrei ist.
  • Die Hauptstromversorgung umfasst eine Sicherung. Ein Austauschen dieser Sicherung wird nicht empfohlen. Tauschen Sie die gesamte Hauptstromversorgung aus. Beachten Sie, dass Fehler der Hauptstromversorgung oft durch andere Gerätefehler verursacht werden.

Vorsicht

Die Kühlkörper an der Hauptplatine entsprechen verschiedenen Potenzialen. Schäden können durch einen Kurzschluss mehrerer Kühlkörper entstehen. Gehen Sie beim Test der Hauptplatine vorsichtig vor.

Überprüfen Sie die Stromversorgungen, die in folgender Tabelle aufgelistet und im Blockdiagramm dargestellt sind. Geerdete Stromversorgungen können mit der Gehäusemasse als Erdung getestet werden. Isolierte Stromversorgungen können mit einem der Kühlkörper getestet werden, die in der Abbildung dargestellt sind.

Versorgung

+3,3 V ER*

+5 ER

+15 V Isoliert

-15 V Isoliert

+9 V Isoliert

-9 V Isoliert

+3,3 V Isoliert

+5 V Isoliert

* Diese Stromversorgung ist aktiv, sobald Wechselstrom auf das Gerät wirkt.

Test der Stromversorgung

Selbsttestfehler 605 - 609

Die Selbsttestfehler 605-609 zeigen an, dass die Prozessorplatine die FPGA (U1005) an der Hauptplatine nicht korrekt programmieren oder mit dieser kommunizieren kann. In diesem Fall ist eine weitere Problembehebung erforderlich. Ursache des Problems könnte eine veraltete Firmware oder eine fehlerhafte oder gelöste Prozessorplatine/Hauptplatine sein.Vor der Problembehebung dieser Fehler muss sichergestellt werden, dass die Firmware des Geräts aktualisiert wurde. Werden die Fehler weiterhin angezeigt, gehen Sie folgendermaßen vor.

Platinen korrekt einsetzen

Trennen Sie das Gerät von der Stromversorgung und entfernen Sie die Abdeckung. Setzen Sie die Prozessorplatine und die Hauptplatine wieder korrekt ein. Schließen Sie das Gerät an und prüfen Sie, ob die Fehler 605-609 beim Einschalten weiterhin angezeigt werden.

Stromversorgungen überprüfen

Untersuchen Sie die Stromversorgungen des Systems und prüfen Sie, dass sie die Grenzwerte nicht überschreiten. Überschreitet eine der Stromversorgungen die Grenzwerte, prüfen Sie die Stromversorgung. Fahren Sie andernfalls mit der Prüfung der SPI-Kommunikation fort.

Prüfung der SPI-Kommunikation

Werden nach dem korrekten Einsetzen der Platinen weiterhin Fehler angezeigt, müssen Sie die SPI-Kommunikationsleitungen zwischen Prozessor- und Hauptplatine prüfen. Finden Sie zunächst LED DS1001 auf der Hauptplatine, wie unten dargestellt. Schalten Sie das Gerät aus und wieder ein. Warten Sie, bis es vollständig startet und überprüfen Sie, ob die LED der Hauptplatine aufleuchtet. Die LED der Hauptplatine gibt an, ob die FPGA-Programmierung erfolgreich war. Folgende Abschnitte geben an, welche Signalleitungen am Hauptplatinenanschluss (J201) geprüft werden müssen.

Hauptplatine LED leuchtet nach dem Start

Zeigt an, dass das FPGA progammiert wurde und läuft. Wahrscheinlich besteht ein Kommunikationsfehler zwischen Haupt- und Prozessorplatine. Testen Sie die Leitung J201, Stecker 27 mit einem Oszilloskop und schalten Sie das Gerät aus und wieder ein (warten Sie den vollständiges Start ab), um zu sehen, ob die Leitung aktiv ist. Die Aktivität sollte +3,3 V Pulsen (isoliert) entsprechen. Beachten Sie, dass die Aktivität endet, wenn das Gerät gestartet wurde.

  • Ist die Leitung nach dem Aufleuchten der LED nicht aktiv, hat wahrscheinlich die Hauptplatine die Störung verursacht.
  • Ist die Leitung aktiv, ist die Prozessorplatine die wahrscheinlichste Ursache der Störung.

Test serieller Daten

Hauptplatine LED leuchtet nach dem Start nicht

Zeigt an, dass die FPGA-Programmierung durch den Prozessor fehlgeschlagen ist. Wahrscheinlich handelt es sich um einen Kommunikationsfehler zwischen Haupt- und Prozessorplatine. Prüfen Sie die seriellen Datenleitungen beim Einschalten mit einem Oszilloskop:

  • J201, Stecker 23
  • J201, Stecker 24
  • J201, Stecker 26
  • J201, Stecker 32

Weisen alle oben genannten SPI-Leitungen während der FPGA-Programmierung eine Aktivität auf, hat wahrscheinlich die Hauptplatine die Störung verursacht. Andernfalls ist wahrscheinlich die Prozessorplatine die Ursache der Störung.

10 MHz Aus

Wenn die Stromversorgungen funktionieren und der Selbsttest erfolgreich, prüfen Sie den 10 MHz Ausgang an der Rückwand. Dieser Ausgang ist immer dann vorhanden, wenn das Gerät eingeschaltet wurde und Prozessor und Hauptplatine funktionsfähig sind. Ist 10 MHz vorhanden, das Display funktioniert jedoch nicht, sind evtl. die Frontplattenplatine oder der Displayaufbau für die Störung verantwortlich.


Fehlerbehebung - 33600 Series

Nachstehend finden Sie eine kurze Liste häufig auftretender Störungen. Stellen Sie vor einer Fehlerbehebung oder Reparatur des Geräts sicher, dass es sich um eine Störung am Gerät und nicht an den externen Anschlüssen handelt. Stellen Sie weiterhin sicher, dass das Gerät im letzten Jahr korrekt kalibriert wurde. Die Schaltkreise des Geräts ermöglichen eine Fehlerbehebung und Reparaturen mit einer einfachen Testausrüstung.

Das Gerät ist funktionsunfähig

Bitte prüfen Sie folgende Punkte:

  • Das AC-Netzkabel ist sicher an das Gerät angeschlossen und mit einer Steckdose verbunden
  • Der Einschalt-/Standby-Schalter an der Frontplatte ist gedrückt

Der Selbsttest schlägt fehl

Stellen Sie sicher, dass alle (vorder- und rückseitigen) Anschlüsse entfernt wurden, wenn der Selbsttest ausgeführt wird. Während des Selbsttests können Fehler durch Signale an externen Leitungen (z. B. langen Testleitungen, die als Antennen wirken) induziert werden.

Vorsicht

Tauschen Sie NICHT das Motherboard, die Prozessorplatine oder die Frontplattenplatine verschiedener Geräte aus. Diese Platinen enthalten die Modell- und Seriennummerangaben, die nur für ein spezifisches Gerät gelten. Platinen, die nicht zum Gerät passen, können zu Problemen hinsichtlich Leistung, Lizenz, Funktionstüchtigkeit, Import-/Exportfähigkeit oder Garantie führen.

Stromversorgung

Überprüfen Sie die Hauptstromversorgung.

Warnung

Gefahr eines elektrischen Schlags. Entfernen Sie für die Prüfung der Stromversorgungen die Geräteabdeckung, wie unter Demontage beschrieben.

Die Hauptstromversorgung bietet eine Stromversorgung von +24 VDC für die Hauptplatine. Alle anderen Stromversorgungen sind von dieser Stromversorgung abgeleitet. Diese Stromversorgung ist immer stromführend, wenn das Netzkabel angeschlossen ist.

Vorsicht

Testen Sie die Stromversorgung am Anschluss der Hauptplatine. Beachten Sie, dass die Stromversorgung nicht auf Chassis-Masse bezogen ist, wenn sie von der Hauptplatine getrennt ist. Ist der Anschluss mit der Hauptplatine verbunden, stellen Sie sicher, dass die Montageschraube der Hauptplatine eingesetzt ist und die Erdung des AC -Einlasses (grüner/gelber Draht) mit dem Chassis verbunden ist.
  • Fehler im Stromkreis können hohe Stromversorgungslasten erzeugen, die die Ausgangsspannung der Stromversorgung senken können. Trennen Sie die Hauptstromversorgung von der zu testenden Hauptplatine.
  • Prüfen Sie stets mit einem Oszilloskop, dass der Stromversorgungsausgang schwingungsfrei ist.

Vorsicht

Die Hauptstromversorgung umfasst zwei Sicherungen. Ein Austausch dieser Sicherungen wird nicht empfohlen. Tauschen Sie die gesamte Hauptstromversorgung aus. Beachten Sie, dass Fehler der Hauptstromversorgung oft durch andere Gerätefehler verursacht werden.

Vorsicht

Die Kühlkörper an der Hauptplatine entsprechen verschiedenen Potenzialen. Schäden können durch einen Kurzschluss mehrerer Kühlkörper entstehen. Gehen Sie beim Test der Hauptplatine vorsichtig vor.

Stromversorgungen der Hauptplatine

Überprüfen Sie die Stromversorgungen, die in folgender Tabelle aufgelistet und im Blockdiagramm dargestellt sind. Geerdete Stromversorgungen können mit der Gehäusemasse als Erdung getestet werden. Isolierte Stromversorgungen können durch Verwendung eines der Kühlkörper getestet werden.

Die Netzspannung wird gefiltert und wirkt auf die Hauptstromversorgung, eine +24 V-Stromversorgung (±0,3 VDC), die stets eingeschaltet ist, wenn sie an das Stromnetz angeschlossen ist. Regler an der Frontplattenplatine erzeugen geerdete +5 V und +3,3 V Strom von der Hauptstromversorgung, die ebenfalls immer eingeschaltet sind, wenn sie an das Stromnetz angeschlossen sind.

Die LEDs der Hauptplatine leuchten beim Einschalten auf, um anzuzeigen, dass die Stromversorgungen +5 V (isoliert) und +3,3 V (isoliert) korrekt arbeiten. Auf der Hauptplatine leuchtet LED DS2001 auf, um anzuzeigen, dass die isolierte Stromversorgung +3,3 V funktioniert und LED DS2002 leuchtet auf, um anzuzeigen, dass die isolierte +5 V Stromversorgung funktioniert.

Stromversorgungen an der Hauptplatine

+3,3 V ER*

+5 ER

+15 V Isoliert

-15 V Isoliert

+9 V Isoliert

-9 V Isoliert

+3,3 V Isoliert*** DS2001

+5 V Isoliert**, *** DS2002

* Diese Stromversorgung ist aktiv, sobald Wechselstrom auf das Gerät wirkt.
** Diese Stromversorgung versorgt auch die Stromversorgungen des Zwischenbodens mit Strom.
*** Diese Stromversorgung verfügt über eine "Power-Good"-LED-Anzeige (siehe nachstehende Abbildung).

Stromversorgungen der Zwischenbodenplatine

Stromversorgungen an der der Zwischenbodenplatine
+1,1 V*** DS1501 +1,5 V*** DS1501 +1,8 V*** DS1501 +2,5 V*** DS1501

*** Diese Stromversorgung verfügt über eine "Power-Good"-LED-Anzeige (siehe nachstehende Abbildung).

Selbsttestfehler 607 - 611

Die Selbsttestfehler 607-611 geben an, dass die Prozessorplatine das Signal FPGA (U301) an der Zwischenbodenplatine nicht programmieren oder mit ihm kommunizieren kann. In diesem Fall ist eine weitere Problembehebung erforderlich. Ursache des Problems könnte eine veraltete Firmware oder eine fehlerhafte oder gelöste Prozessorplatine/Hauptplatine sein. Vor der Problembehebung dieser Fehler muss sichergestellt werden, dass die Firmware des Geräts aktualisiert wurde. Werden die Fehler weiterhin angezeigt, gehen Sie folgendermaßen vor.

Platinen korrekt einsetzen

Trennen Sie das Gerät von der Stromversorgung und entfernen Sie die Abdeckung. Setzen Sie Zwischenbodenplatine und Hauptplatine wieder korrekt ein. Schalten Sie das Gerät ein und prüfen Sie, ob die Fehler 607 bis 611 weiterhin gemeldet werden. Prüfen Sie anhand aller „Power Good“-LEDs, ob die Stromversorgungen funktionieren. Nicht alle Stromversorgungen verfügen über eine LED-Anzeige.

Prüfung der SPI-Kommunikation

Werden nach dem korrekten Einsetzen der Platinen weiterhin Selbsttestfehler angezeigt, müssen Sie die SPI-Kommunikationsleitungen zwischen Prozessor- und Hauptplatine prüfen. Finden Sie zunächst LED DS1501 auf der Hauptplatine, wie oben dargestellt. Schalten Sie das Gerät aus und wieder ein. Warten Sie, bis es vollständig startet und überprüfen Sie, ob die "Power Good"-LEDs (DS2001, DS2002) aufleuchten. Prüfen Sie, ob die "Power Good"-LED DS1501 der Zwischenbodenplatine leuchtet, die anzeigt, dass die Stromversorgungen des Zwischenbodens funktionieren.

Erfolgreiche FPGA-Programmierung überprüfen

Die DS401 LED der Zwischenbodenplatine (links von DS1501 in der Abb. oben) zeigt an, ob das FPGA erfolgreich programmiert wurde. Wenn sie aufleuchtet, zeigt sie an, dass das FPGA progammiert wurde und läuft. Falls sie nicht aufleuchtet und alle Stromversorgungen funktionieren, besteht möglicherweise ein SPI-Kommunikationsfehler zwischen der Prozessorplatine und der Hauptplatine oder der Hauptplatine und der Zwischenbodenplatine.

Prüfung der SPI-Kommunikation

Testen Sie die J201-Stecker 23, 24, 26 und 27 des Anschlusses zwischen Frontplatte und Hauptplatine, um die Aktivität zwischen Hauptplatine und Frontplattenplatine beim Start zu prüfen. Die Aktivität sollte +3,3 V Pulsen (isoliert) entsprechen. Beachten Sie, dass die Aktivität endet oder unregelmäßig ist, wenn das Gerät gestartet wurde. Falls keine Aktivität vorhanden ist, liegt der Fehler meist in der Frontplattenplatine.

Testen Sie die Leitung U602, Stecker 6 mit einem Oszilloskop und schalten Sie das Gerät aus und wieder ein (warten Sie den vollständiges Start ab), um zu sehen, ob die Leitung aktiv ist. Diese Leitung wird zum Zurücksetzen des FPGA verwendet, um die Programmierung zu starten. Die Aktivität sollte +3,3 V Pulsen (isoliert) entsprechen.

Überprüfen Sie ebenso die Leitung U601 (auf der Hauptplatine), Stecker 11, 12, 13, und 14 auf Aktivität beim Start. Beachten Sie, dass die Aktivität endet oder unregelmäßig ist, wenn das Gerät gestartet wurde.

Falls keine Aktivität vorhanden ist, liegt der Fehler meist in der Hauptplatine.

Wenn keine Aktivität vorhanden ist und die DS401 LED nicht aufleuchtet, liegt der Fehler meist in der Zwischenbodenplatine.

10 MHz Aus

Wenn die Stromversorgungen funktionieren und der Selbsttest erfolgreich war, prüfen Sie den 10 MHz Ausgang an der Rückwand. Dieser Ausgang ist immer dann vorhanden, wenn das Gerät eingeschaltet wurde und Prozessor und Hauptplatine funktionsfähig sind. Ist 10 MHz vorhanden, das Display funktioniert jedoch nicht, sind evtl. die Frontplattenplatine oder der Displayaufbau für die Störung verantwortlich.


Selbsttests

Selbsttest Vorgehensweisen

Einschaltselbsttest

Bei jedem Einschalten des Geräts werden Selbsttests durchgeführt, um zu überprüfen, dass die minimalen Logik-Sets und ihre Subsysteme korrekt funktionieren.

Vollständiger Selbsttest

Durch die Selbsttests können Sie mit hoher Wahrscheinlichkeit annehmen, dass das Gerät normal funktioniert. Der Selbsttest prüft systematisch den internen Oszillator, die digitale Infrastruktur, den Signalspeicher und analoge Abschwächer-Pfade. Er versucht, Störungen auf eine bestimmte Baugruppe einzugrenzen, um den Service zu erleichtern. Während des Tests werden der Hauptausgang oder die Hauptausgänge intern von den BNC-Anschlüssen getrennt und an den internen ADC angeschlossen, mit Prüfungen für erwartete Signalstufen im gesamten Gerät.

Ein vollständiger Selbsttest (*TST?) dauert ca. 15 Sekunden. Sie hören bei diesem Vorgang evtl. das Umschalten der Relais. Nach Abschluss des Selbsttests wird entweder "Self-test Passed" oder "Self-test Failed" auf der Frontplatte angezeigt. Die Selbsttest-Fehlermeldungen sind nachstehend ausführlich beschrieben.

Führen Sie den Selbsttest aus, bevor Sie Prüfungen oder Anpassungen durchführen.

Ausführung des Selbsttests

Entfernen Sie vor dem Selbsttest alle Eingangsanschlüsse des Geräts. Schalten Sie das Gerät aus und wieder ein, um den Einschaltselbsttest durchzuführen.

E/A-Fernausführung

  1. Anschließen des Geräts über die Remoteschnittstelle (LAN-Konfigurationsverfahren).
  2. Senden Sie *TST? und lesen Sie das Ergebnis ab: "Pass" (+0) oder "Fail" (+1). Verwenden Sie SYSTem:ERRor? zur Anzeige der Fehler.

Ausführung über die Frontplatte

  1. Drücken Sie [System] > Instr Setup > Self Test.
  2. Eine Fortschrittsleiste wird beim Ausführen des Selbsttests angezeigt. Zeigen Sie nach dem Abschluss des Selbsttests Störungen durch einen Druck auf [System] > Help an und wählen Sie dann das Thema View remote command error queue.

Fehlernummern und -meldungen für Selbsttests (33500 Series Geräte)

Ein Fehler kann zahlreiche Fehlermeldungen generieren; die erste sollte dabei als die Hauptursache für die Störung angesehen werden. Manche Fehlermeldungen enthalten eine fehlerhafte Kanalnummer (1 oder 2), wie in den Meldungen unten.

Fehler | Meldung und Bedeutung (33500 Series Geräte) | Wahrsch. Ursache (33500 Series Geräte)
601 | Self-test failed; real time clock settings lost Die Datums- / Zeiteinstellungen der Echtzeit-Uhr sind verloren gegangen, wahrscheinlich durch eine getrennte oder entladene RTC-Batterie (Knopfzelle auf der Frontplattenplatine gefunden). Der Fehler kann auch auftreten, wenn eine Prozessorplatine entfernt und in die Frontplattenaufbau eingesteckt wurde. Dieser Fehlerbedingung wird beim Einschalten erkannt und durch den Selbsttest berichtet, bis das Problem behoben wurde und das Gerät ein- und wieder ausgeschaltet wird. | RTC-Batterie
602 | Self-test failed; main CPU power supply out of range Die Prozessorplatine hat detektiert, dass eine ihrer Stromversorgungen über 10% über dem Nennspannungsbereich liegt. | Prozessorplatine
603 | Self-test failed; main CPU error accessing boot env Der Prozessor konnte über Flash nicht auf seine Boot-Parameter zugreifen, wahrscheinlich durch eine abgelaufene Firmaware oder ein Problem der Prozessorplatine. | Prozessorplatine
604 | Self-test failed; front panel processor ping failed Die Prozessorplatine hat versucht, den Versionscode der Frontplatte zu lesen und eine 0 erhalten, wahrscheinlich wegen eines nicht programmierten Frontplattenprozessors, einer nicht korrekt eingesetzten Prozessorplatine oder eines defekten Frontplattenprozessors. | Frontplattenplatine
605 | Self-test failed; waveform FPGA not programmed Der Prozessor konnte das Signal FPGA (U1005) beim Start nicht programmieren. Die Hardware kann nicht korrekt arbeiten. | Prozessorplatine oder Hauptplatine. Unter Problembehebung finden Sie zusätzliche Informationen über die Problembehebung der Fehler 605-609.
606 | Self-test failed; waveform FPGA revision check failed Der Prozessor hat versucht, das Versionsregister des Signals FPGA (U1005) zu lesen und einen ungültigen Wert erhalten, wahrscheinlich aufgrund eines nicht programmierten FPGA oder eines internen SPI-Kommunkationsfehlers.
607 | Self-test failed; waveform FPGA read back error Der Prozessor konnte von einem Testort nicht in das Signal FPGA (U1005) schreiben oder lesen, wahrscheinlich aufgrund eines nicht progammierten FPGA oder eines internen SPI-Kommunkationsfehlers.
608 | Self-test failed; waveform FPGA security check failed Das Signal FPGA (U1005) hat den internen Sicherheitstest nicht bestanden, evtl. aufgrund von FPGA-Störungen (Tests 605-608), einem ungültigen FPGA-Bild oder einer Funktionsstörung der Sicherheitsvorrichtung (U1007).Der Selbsttest endet nach diesem Fehler.
609 | Self-test failed; waveform FPGA security check failed Das Signal FPGA (U1005) hat den internen Sicherheitstest nicht bestanden, evtl. aufgrund von FPGA-Störungen (Tests 605-608), einem ungültigen FPGA-Bild oder einer Funktionsstörung der Sicherheitsvorrichtung (U1007).Der Selbsttest endet nach diesem Fehler.
610 | Self-test failed; main PLL not locked Das Signal FPGA (U1005) konnte nicht mit dem internen 10MHz Oszillator (U903 oder U905) synchronisiert werden. | Hauptplatine
611 | Self-test failed; FPGA PLL not locked Das Signal FPGA (U1005) konnte nicht mit dem internen Abtast-Taktgenerator IC (U906) synchronisiert werden. | Hauptplatine
612 | Self-test failed; Chan n, waveform memory PLL not locked Der Signal-RAM für den angegebenen Kanal (U1101 oder U1102) konnte nicht mir seinem Taktgeber synchronisiert werden. | Hauptplatine
613 | Self-test failed; Chan n, waveform memory not initialized Der Signal-RAM für den angegebenen Kanal (U1101 oder U1102) konnte nicht initialisiert werden. | Hauptplatine
615 | Self-test failed; modulation ADC offset too low (too high) Die interne ACOM-Messung des A/D-Konverters überschreitet die Grenzwerte. | Hauptplatine
616 | Self-test failed; modulation ADC reference too low (too high) Die interne Messung der Spannungsreferenz (VRef) des A/D-Konverters liegt außerhalb der Grenzwerte. | Hauptplatine
620 | Self-test failed; Chan n, waveform memory test failed on idle Der Signalspeichertest wurde nicht korrekt gestartet, wahrscheinlich aufgrund eines Fehlers des Signals FPGA (U1005) | Hauptplatine
621 | Self-test failed; Chan n, waveform memory test failed Der Signal-RAM-Speichertest für den angegebenen Kanal (U1101 oder U1102) ist fehlgeschlagen; Der Test besteht darin, den gesamten Signal-RAM nach einem vorgegebenen Muster zu beschreiben und zu lesen. | Hauptplatine
625 | Self-test failed; Chan n, waveform DAC gain[idx] too low (too high) Der Signal-D/A-Wandler (U1801 oder U1501) bietet keinen korrekten Ausgangswert. Zunahme [idx] von 1 Referenz POS Spannungstest; Zunahme [idx] von 2 Referenzen NEG-Spannungstest. | Hauptplatine
630 | Self-test failed; Chan n, sub attenuator failure 0dB Abgeschnittener D/A-Wandler im Signal-D/A-Wandler (U1801 oder U1501) bietet keinen korrekten Ausgangswert bei 0 dB. Schlägt dieser Test fehl, wird Test 631 nicht ausgeführt. | Hauptplatine
631 | Self-test failed; Chan n, sub attenuator <-7,00 to 0,00>dB too low (too high) Die Ausgangswerte des abgeschnittenen D/A-Wandlers im Signal-D/A-Wandler (U1801 oder U1501) liegen außerhalb des Sollbereichs. | Hauptplatine
635 | Self-test failed; Chan n, null DAC gain[idx] too low (too high) Der Hilfs-D/A-Wandler des Signal-D/A-Wandlers (U1801 oder U1501) oder der entsprechende Analog-Schaltkreis erzeugt Ausgangswerte, die außerhalb des Sollbereichs liegen. Zunahme [idx] von 1 Referenz POS Spannungstest; Zunahme [idx] von 2 Referenzen NEG-Spannungstest. | Hauptplatine
640 | Self-test failed; Chan n, offset DAC gain[idx] too low (too high) Der Offset-D/A-Wandler (U1702 oder U2002) oder die entsprechenden Schaltkreise erzeugen Ausgangswerte, die außerhalb des Sollbereichs liegen. Für den Offset-D/A-Wandler sind die [idx] Polaritäten invertiert: Zunahme [idx] von 1 Referenz NEG Spannungstest; Zunahme [idx] von 2 Referenzen POS-Spannungstest. | Hauptplatine
650 | Self-test failed; Chan n, 0dB path failure expected 0dB, measured value dB Direkter Pfad (keine Abschwächung) von Signal-A/D-Wandler zu A/D-Wandlereingang, dessen Ausgangswerte außerhalb des Sollbereichs liegen. Wenn dies fehlschlägt, wird der erweiterte Abschwächer-Test 655 nicht ausgeführt. | Hauptplatine
655 | Self-test failed; Chan n, -8 dB pre attenuator path too low (too high) Self-test failed; Chan n, -16 dB pre attenuator path too low (too high) Self-test failed; Chan n, -24 dB pre attenuator path too low (too high) Self-test failed; Chan n, -24 dB post attenuator path too low (too high) Relais des angegebenen Abschwächers funktioniert nicht korrekt, oder die entsprechenden Schaltkreise bieten nicht die erwartete Abschwächung. | Hauptplatine

Fehlernummern und -meldungen für Selbsttests (33600 Series Geräte)

Ein Fehler kann zahlreiche Fehlermeldungen generieren; die erste sollte dabei als die Hauptursache für die Störung angesehen werden. Manche Fehlermeldungen enthalten eine fehlerhafte Kanalnummer (1 oder 2), wie in den Meldungen unten.

Fehler | Meldung und Bedeutung (33600 Series Geräte) | Wahrsch. Ursache (33600 Series Geräte)
601 | Self-test failed; real time clock settings lost Die Datums- / Zeiteinstellungen der Echtzeit-Uhr sind verloren gegangen, wahrscheinlich durch eine getrennte oder entladene RTC-Batterie (Knopfzelle auf der Frontplattenplatine gefunden). Der Fehler kann auch auftreten, wenn eine Prozessorplatine entfernt und in die Frontplattenaufbau eingesteckt wurde. Dieser Fehlerbedingung wird beim Einschalten erkannt und durch den Selbsttest berichtet, bis das Problem behoben wurde und das Gerät ein- und wieder ausgeschaltet wird. | RTC-Batterie
602 | Self-test failed; keyboard processor not responding Ein Frontplattenmikroprozessor ist nicht funktionsfähig. | Frontplattenplatine
603 | Self-test failed; incorrect keyboard processor product ID Ein Frontplattenmikroprozessor ist fehlerhaft. | Frontplattenplatine
604 | Self-test failed; FPGA temperature out of limits Temperatursensor des FPGA (U301 an der Zwischenbodenplatine) zeigt zu hohe Temperatur an. | Zwischenbodenplatine oder Lüfter
604 | Self-test failed; unknown CPU exception during temperature test Versuch, mit dem Temperatursensor des FPGA zu kommunizieren (U301 auf der Zwischenbodenplatine) fehlgeschlagen. | Frontplattenplatine
605 | Self-test failed; front panel I2C communication to main board temp sensor failed Kommunikation zwischen Frontplatte und Temperatursensor auf der Hauptplatine funktioniert nicht. | Hauptplatine
605 | Self-test failed; main board temperature out of limits Ein Temperatursensor auf der Hauptplatine zeigt zu hohe Temperatur an. | Hauptplatine oder Lüfter
606 | Self-test failed; front panel processor ping failed Die Prozessorplatine hat versucht, den Versionscode der Frontplatte zu lesen und eine 0 erhalten, wahrscheinlich wegen eines nicht programmierten oder defekten Frontplattenprozessors. | Frontplattenplatine
607 | Self-test failed; waveform FPGA not programmed Der Prozessor konnte das Signal FPGA (U301 auf der Zwischenbodenplatine) beim Start nicht programmieren. Die Hardware kann nicht korrekt arbeiten. | Frontplattenplatine, Hauptplatine oder Zwischenbodenplatine. Unter Problembehebung für 33600 Series Geräte finden Sie zusätzliche Informationen über die Problembehebung der Fehler 607-611.
608 | Self-test failed; waveform FPGA revision check failed Der Prozessor hat versucht, das Versionsregister des Signals FPGA (U1005 auf der Zwischenbodenplatine) zu lesen und einen ungültigen Wert erhalten, wahrscheinlich aufgrund eines nicht programmierten FPGA oder eines internen SPI-Kommunkationsfehlers.
609 | Self-test failed; waveform FPGA read back error Der Prozessor konnte von einem Testort nicht in das Signal FPGA (U1005 auf der Zwischenbodenplatine) schreiben oder lesen, wahrscheinlich aufgrund eines nicht progammierten FPGA oder eines internen SPI-Kommunkationsfehlers.
610 | Self-test failed; waveform FPGA error Der Prozessor konnte von FPGA aufgrund eines Hardwarefehlers nicht in das Signal FPGA (U301 auf der Zwischenbodenplatine) schreiben oder lesen, wahrscheinlich aufgrund eines nicht progammierten FPGA oder eines internen SPI-Kommunkationsfehlers.
611 | Self-test failed; waveform FPGA authentication failed Der Prozessor konnte den Sicherheitstest nicht überprüfen, und dass das FPGA korrekt programmiert wurde. | Zwischenbodenplatine. Unter Problembehebung für 33600 Series Geräte finden Sie zusätzliche Informationen über die Problembehebung der Fehler 607-611.
612 | Self-test failed; main PLL not locked Die Phasenregelschleifenschaltung auf der Zwischenbodenplatine konnte nicht mit dem internen 10 MHz Referenzoszillator synchronisiert werden. | Zwischenbodenplatine
613 | Self-test failed; FPGA not locked to 250MHz Die Phasenregelschleifenschaltung auf der Zwischenbodenplatine konnte nicht bei 250 MHz synchronisiert werden. | Zwischenbodenplatine
614 | Self-test failed; waveform memory PLL not locked Die Phasenregelschleifenschaltung auf der Zwischenbodenplatine konnte nicht mit der Signalspeicherfrequenz synchronisiert werden. | Zwischenbodenplatine
615 | Self-test failed; waveform memory not initialized Der Signalspeicher konnte nicht korrekt initialisiert werden. |
616 | Self-test failed; modulation ADC offset too low Der externe Modulations-A/D-Wandler-Schaltkreis konnte die Erdungsreferenzspannung nicht ordnungsgemäß messen. | Hauptplatine
616 | Self-test failed; modulation ADC offset too high Der externe Modulations-A/D-Wandler-Schaltkreis konnte die Erdungsreferenzspannung nicht ordnungsgemäß messen. | Hauptplatine
617 | Self-test failed; modulation ADC reference too low Der externe Modulations-A/D-Wandler-Schaltkreis konnte die Erdungsreferenzspannung nicht ordnungsgemäß messen. | Hauptplatine
617 | Self-test failed; modulation ADC reference too high Der externe Modulations-A/D-Wandler-Schaltkreis konnte die Erdungsreferenzspannung nicht ordnungsgemäß messen. | Hauptplatine
620 | Self-test failed; Chan n, waveform memory test failed on idle Der Signalspeichertest wurde nicht korrekt gestartet, wahrscheinlich aufgrund eines Fehlers des Signals FPGA (U301). | Zwischenbodenplatine
621 | Self-test failed; Chan n, waveform memory test failed Der Signal-RAM-Speichertest für den angegebenen Kanal (U601 und U602 oder U701 und U702) ist fehlgeschlagen; Der Test besteht darin, den gesamten Signal-RAM nach einem vorgegebenen Muster zu beschreiben und zu lesen. | Zwischenbodenplatine
625 | Self-test failed; Chan n, waveform DAC gain[idx] too low (too high) Der Signal-D/A-Wandler (U1001 oder U1101 auf der Zwischenbodenplatine) bietet keinen korrekten Ausgangswert. Zunahme [idx] von 1 Referenz Positiver Spannungstest; Zunahme [idx] von 2 Referenzen Negativer Spannungstest. Testet auch U901 und U902 für Kanal 1 oder U1401 und U1402 (für Kanal 2) auf der Hauptplatine. | Zwischenbodenplatine oder Hauptplatine
626 | Self-test failed; CH1 waveform DAC is not synchronized properly Das Signal DAC (U1001) auf Kanal 1 kann die Frequenz nicht mit den Taktsignalen synchronisieren. | Zwischenbodenplatine
626 | Self-test failed; CH2 waveform DAC is not synchronized properly Das Signal DAC (U1001) auf Kanal 2 kann die Frequenz nicht mit den Taktsignalen synchronisieren. | Zwischenbodenplatine
626 | Self-test failed; Sync waveform DAC is not synchronized properly Das Signal DAC (U1001) auf dem Sync-Kanal kann die Frequenz nicht mit den Taktsignalen synchronisieren. | Zwischenbodenplatine
630 | Self-test failed; Chan n, sub attenuator failure 0dB Abgeschnittener D/A-Wandler im Signal-D/A-Wandler (U1001 – Kanal 1 oder U1101 – Kanal 2) bietet keinen korrekten Ausgangswert bei 0 dB. Dieser Test hängt auch von der Signaldämpfungsschaltung auf der Hauptplatine ab (für Kanal 1 bedeutet dies U1401, U1402, Abschwächerrelais K1501 - K1503, K1701 - K1704 und die Verstärkerschaltung). Schlägt dieser Test fehl, wird Test 631 nicht ausgeführt. | Zwischenbodenplatine (DAC) oder Hauptplatine (Signalabschwächerkette).
631 | Self-test failed; Chan n, sub attenuator xx dB Die Ausgangswerte des abgeschnittenen D/A-Wandlers im Signal-D/A-Wandler (U1001 oder U1101) liegen außerhalb des Sollbereichs. | Zwischenbodenplatine
635 | Self-test failed; Chan n, null DAC gain xx Eine DC-Nullungsschaltung (U1404, U1405) konnte die erwartete Spannungsschwankung nicht erzeugen. | Hauptplatine
640 | Self-test failed; Chan n, offset DAC gain xx Eine DC-Offset-Signalerzeugungsschaltung (U1404, U1405) konnte die erwartete Spannungsschwankung nicht erzeugen. | Hauptplatine
650 | Self-test failed; 0dB path failure channel n expected 0dB, measured yy dB Direkter Pfad (keine Abschwächung) von Signal-A/D-Wandler zu A/D-Wandlereingang, dessen Ausgangswerte außerhalb des Sollbereichs liegen. Signal-D/A-Wandler (U1001 – Kanal 1 oder U1101 – Kanal 2) bietet keinen korrekten Ausgangswert bei 0 dB. Dieser Test hängt auch von der Signaldämpfungsschaltung auf der Hauptplatine ab (für Kanal 1 bedeutet dies U1401, U1402, Abschwächerrelais K1501 - K1503, K1701 - K1704 und die Verstärkerschaltung). Wenn dies fehlschlägt, wird der erweiterte Abschwächer-Test 655 nicht ausgeführt. | Signal D/A-Wandler Zwischenbodenplatine oder Hauptplatine
655 | Self-test failed; Chan n, -8 dB pre attenuator path too low (too high) Self-test failed; Chan n, -16 dB pre attenuator path too low (too high) Self-test failed; Chan n, -24 dB pre attenuator path too low (too high) Self-test failed; Chan n, -24 dB post attenuator path too low (too high) Relais des angegebenen Abschwächers funktioniert nicht korrekt, oder die entsprechenden Schaltkreise bieten nicht die erwartete Abschwächung. | Hauptplatine
660 | Self-test failed; Channel n: xx dB pre/post attenuator relay inoperative Der Selbsttest kann die Signalamplitude mit den genannten Abschwächerrelais nicht ändern. | Hauptplatine
661 | Self-test failed; EEPROM access failed Haupt-CPU kann einen Speicherchip (U2) auf der Frontplattenplatine nicht lesen. | Hauptplatine


Ersatzteile

Vorsicht

Ergreifen Sie bei Handhabung und Service stets Schutzmaßnahmen gegen elektrostatische Entladung.

In folgender Tabelle sind die Ersatzteile für das Gerät aufgelistet:

Teilenummer | Beschreibung
34401-86020 | Stoßschutzset
34401-45021 | Griff
33220-84101 | Abdeckung
1990-3263 | Codierer (33500 Series Geräte)
1990-3728 | Codierer (33600 Series Geräte)
35220-87401 | Drehknopf
33521-80001 | Tastenfeld für Einkanalmodelle
33522-80001 | Tastenfeld für Zweikanalmodelle
2090-0977 | Display (33500 Series Geräte)
2090-1051 | Display (33600 Series Geräte)
1250-3569 | Frontplatten-BNCs
33521-80002 | Frontplatte für 33.521A
33522-80002 | Frontplatte für 33522A
33520-80001 | Frontplatte für 335xxB Einkanalmodelle
33520-80002 | Frontplatte für 335xxB Zweikanalmodelle
33621-80002 | Frontplatte für 33600 Series Einkanalmodelle
33622-80002 | Frontplatte für 33600 Series Zweikanalmodelle
33522-66502 | Frontplattenplatine (33500 Series Geräte)
1252-8483 | USB-Anschluss
1253-4669 | LAN-Anschluss (33500 Series Geräte)
1254-0795 | LAN-Anschluss (33600 Series Geräte)
53200-61608 | Leitungsfilter (33500 Series Geräte)
5041-5250 | Leitungsfilter (33600 Series Geräte)
33250-68501 | Lüfter (33500 Series Geräte)
5041-5244 | Lüfter-Bausatz (33600 Series Geräte)
1420-0356 | Batterie (in der Frontplatte) CR2032
53200-80002 | Stromversorgung und Abdeckung* (33500 Series Geräte)
5041-5252 | Netzteil Abschirmung (nur 33600 Series)
5041-5256 | Netzteil* (nur 33600 Series)

* Die 33500 Series Modelle enthalten eine 15 A, 250 V Bleisicherung. Es wird nicht empfohlen, die Sicherung auszutauschen.

* Die 33600 Series Modelle enthalten zwei 3,15 A, 250 V Bleisicherungen. Es wird nicht empfohlen, die Sicherung auszutauschen.


Demontage

Demontage - 33500 Series Geräte

Dieser Abschnitt beschreibt, wie das Gerät auseinandergenommen wird.

Erforderliches Werkzeug

Folgendes Werkzeug ist für die Demontage des Geräts erforderlich.

  • T15 Torx-Schraubendreher (für die meisten Vorgänge)
  • T8 Torx-Schraubendreher (Demontage der Frontplatte)
  • Posidrive und Flachschraubendreher
  • 14 mm Steckschlüssel, Hohlwelle (rückseitige BNC-Anschlüsse)
  • 7 mm Steckschlüssel (rückseitiger GPIB-Anschluss)

Warnung

Die Abdeckungen des Geräts dürfen nur von qualifizierten Service-Technikern entfernt werden, die sich der damit verbundenen Gefahren bewusst sind. Das Gerät muss stets vom Netz genommen und von jedem externen Stromkreis getrennt werden, ehe die Abdeckung des Geräts entfernt wird. Einige Stromkreise sind selbst dann aktiv und es liegt eine Spannung an, wenn der Stromschalter ausgeschaltet ist.

Trennen Sie stets alle Eingänge, Leitungen und Kabel, bevor das Gerät auseinandergenommen wird.

Allgemeine Demontage

  1. Schalten Sie das Gerät aus. Trennen Sie alle Kabel vom Gerät.
  2. Drehen Sie den Griff nach oben und ziehen Sie ihn nach außen.
    Drehen Sie den Griff und nehmen Sie ihn ab
  3. Entfernen Sie den Stoßschutz des Geräts.
    Entfernung des Stoßschutzsets
  4. Lösen Sie die beiden gesicherten Schrauben (rot eingekreist, s. unten) an der hinteren Blende und entfernen Sie die hintere Blende.

    Schrauben zum Lösen der Blende
  5. Schieben Sie die Abdeckung vom Gerät.

Zahlreiche Servicevorgänge können jetzt ohne weitere Demontage ausgeführt werden. Problembehebungs- und Servicevorgänge, für die das Gerät unter Spannung stehen muss, können am Gerät in diesem Zustand ausgeführt werden.

Warnung

GEFAHR EINES ELEKTRISCHEN SCHLAGS. Die Geräteabdeckungen dürfen nur von geschultem Servicepersonal, das sich der Gefahren bewusst ist, entfernt werden. Bei entfernter Geräteabdeckung können gefährliche Spannungswerte auftreten.

Demontage der Hauptbaugruppe

  1. Prozessorplatine entfernen. Gerät umdrehen. T-8-Schraube, die die Prozessorplatine befestigt, lösen. Drücken Sie die Laschen am Anschluss der Prozessorplatine und schieben Sie die Prozessorplatine zur Geräterückseite, um den Anschluss zu lösen. Entfernen Sie die Prozessorplatine.

  2. Entfernen Sie die Frontplatte. Entfernen Sie die T15-Befestigungsschraube der Hauptplatine. Drücken Sie den Verschluss auf der linken Seite der Frontplatte und lassen Sie die Abdeckung der Stromversorgung auf der rechten Seite der Frontplatte einrasten. Schieben Sie die Seiten des Metallgehäuses zur Mitte, um die Bolzen an den Seiten der Frontplatte zu lösen. Ziehen Sie die Frontplatte vorsichtig vom Gehäuse. Beachten Sie, dass die Frontplatte über einen elektrischen Anschluss zur Hauptplatine verfügt. Achten Sie darauf, den Anschluss nicht zu beschädigen.
    Entfernung der Frontplatte
  3. Entfernen Hauptplatine. Stromversorgungsanschluss von der Hauptplatine trennen. Flachbandkabel GPIB und Oscillator In trennen. Ventilatorstromkabel von der Hauptplatine trennen. Muttern zur Befestigung des BNC-Anschlusses Modulation In und Ext Trig an der Rückwand lösen und ausbauen. Entfernen Sie die Schraube unter der GPIB-Platine, die die Hauptplatine mit dem Gehäuse verbindet. Schieben Sie die Hauptplatine zur Gerätevorderseite, um die Laschen an der Abdeckung der Stromversorgung zu lösen. Entfernen Sie die Hauptplatine.
    Ausbau der Hauptplatine
  4. Stromversorgung entfernen. Trennen Sie die Stromversorgung der Stromversorgungsplatine (blaue und braune Drähte). Trennen Sie den grünen Erdungsanschluss an der Stromversorgungsplatine. Entfernen Sie die Schraube, die die Abdeckung der Stromversorgung am Gehäuse befestigt. Schieben Sie die Stromversorgung zur Gerätevorderseite und bauen Sie sie aus.

    5. Warnung

            Befestigen Sie das grüne Erdungskabel vor Betrieb des Geräts stets erneut mit der Stromversorgung.
  5. Die verbleibenden Baugruppen können bei Bedarf vom Gehäuse abgebaut werden.

Demontage der Frontplatte

  1. Ziehen Sie den Drehknopf nach vorn ab. Entfernen Sie die sechs T8 Schrauben, die die Frontplattenklammer mit der Frontplatte verbinden. Entfernen Sie die Klammer.

    Demontage der Frontplatte
  2. Trennen Sie das Display-Flachbandkabel von der Frontplattenplatine. Entfernen Sie die T8 Schrauben, die die Frontplattenplatine an der Frontplatte befestigen. Entfernen Sie die Ersatzplatine.
    Demontage der Frontplatte

    Demontage der Frontplatte

  3. Alle zusätzlichen Frontplattenbaugruppen können nun aus dem Frontplattengehäuse genommen werden.


Demontage

Demontage - 33600 Series Geräte

Dieser Abschnitt beschreibt, wie das Gerät auseinandergenommen wird.

Erforderliches Werkzeug

Folgendes Werkzeug ist für die Demontage des Geräts erforderlich.

  • T15 Torx-Schraubendreher (für die meisten Vorgänge)
  • T8 Torx-Schraubendreher (Demontage der Frontplatte)
  • Posidrive und Flachschraubendreher
  • 14 mm Steckschlüssel, Hohlwelle (rückseitige BNC-Anschlüsse)
  • T10 Torx-Schraubendreher (rückseitiger GPIB-Anschluss)

Warnung

Die Abdeckungen des Geräts dürfen nur von qualifizierten Service-Technikern entfernt werden, die sich der damit verbundenen Gefahren bewusst sind. Das Gerät muss stets vom Netz genommen und von jedem externen Stromkreis getrennt werden, ehe die Abdeckung des Geräts entfernt wird. Einige Stromkreise sind selbst dann aktiv und es liegt eine Spannung an, wenn der Stromschalter ausgeschaltet ist.

Trennen Sie stets alle Eingänge, Leitungen und Kabel, bevor das Gerät auseinandergenommen wird.

Allgemeine Demontage

  1. Schalten Sie das Gerät aus. Trennen Sie alle Kabel vom Gerät.
  2. Drehen Sie den Griff nach oben und ziehen Sie ihn nach außen.
    Drehen Sie den Griff und nehmen Sie ihn ab
  3. Entfernen Sie den Stoßschutz des Geräts.
    Entfernung des Stoßschutzsets
  4. Lösen Sie die beiden gesicherten Schrauben (rot eingekreist, s. unten) an der hinteren Blende und entfernen Sie die hintere Blende.

    Schrauben zum Lösen der Blende
  5. Schieben Sie die Abdeckung vom Gerät.

Zahlreiche Servicevorgänge können jetzt ohne weitere Demontage ausgeführt werden. Problembehebungs- und Servicevorgänge, für die das Gerät unter Spannung stehen muss, können am Gerät in diesem Zustand ausgeführt werden.

Warnung

GEFAHR EINES ELEKTRISCHEN SCHLAGS. Die Geräteabdeckungen dürfen nur von geschultem Servicepersonal, das sich der Gefahren bewusst ist, entfernt werden. Bei entfernter Geräteabdeckung können gefährliche Spannungswerte auftreten.

Demontage der Hauptbaugruppe

So entfernen Sie die Frontplatte und die Leiterplatte der Frontplatte

  1. Entfernen Sie die beiden Schrauben neben der Vorderseite der Netzteilabdeckung, die diese fixieren.

  2. Kippen Sie die Netzteilabdeckung nach oben und heben Sie sie über den Gehäuserand. Positionieren Sie sie dann umgedreht auf dem Labortisch, wie unten gezeigt.

  3. Entfernen Sie die beiden Schrauben von der Hauptplatine. Diese befinden sich direkt unterhalb der beiden Schrauben, die Sie im ersten Schritt entfernt haben.
  4. Drücken Sie die Seiten des Gehäuses nach innen und schieben Sie die Frontplatte nach vorne, um sie herauszuziehen.
  5. Trennen Sie das Kabel zwischen Frontplattenplatine und Display durch Anheben mit dem Anschlusshebel, um das Kabel zu entfernen.
  6. Entfernen Sie anschließend die sieben Schrauben, über die die Leiterplatte am Kunststoffelement der Frontplatte befestigt ist.

So entfernen Sie die Hauptplatine

  1. Wenn die GPIB Option installiert ist, entfernen Sie sie wie hier beschrieben.
  2. Entfernen Sie die Frontplatte wie oben beschrieben.
  3. Um auf die Hauptplatine zugreifen zu können, heben Sie die Netzteilabdeckung an und entfernen Sie sie vom Gerät. Sie können sie entweder in der Gehäusefurche des Geräts belassen oder sie komplett entfernen und auf dem Labortisch platzieren, wie unten gezeigt.

  4. Trennen Sie das Kabel mit den roten und schwarzen Drähten vom Anschluss an der Vorderseite der Hauptplatine.
  5. Trennen Sie die anderen Kabel (vom AC-Spannungsversorgungsmodul) von der Rückseite des Netzteils.
  6. Trennen Sie das rote Kabel und das Lüfterkabel von der Rückseite der Hauptplatine.
  7. Entfernen Sie die Schraube, über die die Hauptplatine am Gehäuse auf der Rückseite des Geräts befestigt ist.
  8. Entfernen Sie die Federscheiben und Muttern von den unteren beiden BNC Anschlüssen auf der Rückseite.
  9. Verschieben Sie die Hauptplatine leicht, so dass die seitlichen Haken des Gehäuses freiliegen und ziehen Sie sie dann nach oben heraus, um die Platine zu entfernen.


Batterieaustausch

Dieser Abschnitt beschreibt, wie der Akku an der Frontplatte des Geräts ausgetauscht wird.

Warnung

Die Abdeckungen des Geräts dürfen nur von qualifizierten Service-Technikern entfernt werden, die sich der damit verbundenen Gefahren bewusst sind. Das Gerät muss stets vom Netz genommen und von jedem externen Stromkreis getrennt werden, ehe die Abdeckung des Geräts entfernt wird. Einige Stromkreise sind selbst dann aktiv und es liegt eine Spannung an, wenn der Stromschalter ausgeschaltet ist.

Trennen Sie stets alle Eingänge, Leitungen und Kabel, bevor das Gerät auseinandergenommen wird.

Erforderliches Werkzeug

  • T20 Torx-Schraubendreher (für die meisten Vorgänge)
  • Kleiner Flachschraubendreher (zum Herausdrücken)

Vorgehensweise

(Die nachstehenden Bilder wurden mit freundlicher Genehmigung von der Keystone Electronics Corp. zur Verfügung gestellt)

  1. Schalten Sie den Strom ab und entfernen Sie alle Messleitungen und anderen Kabel (auch das Netzkabel) vom Gerät, bevor Sie fortfahren.
  2. Befolgen Sie das Demontageverfahren für 33500 Series Geräte oder das Demontageverfahren für 33600 Series Geräte zur Demontage des Geräts.
  3. Bestimmen Sie die Position des Akkus auf der Frontplatte und setzen Sie den Schraubendreherspitze wie dargestellt unter den Akku.

  4. Drücken Sie den Akku mit den Schraubendreher aus dem Akkufach.

  5. Entfernen Sie den Akku und entsorgen oder recyceln Sie ihn gemäß den geltenden Vorschriften.
  6. Setzen Sie den neuen Akku in das Akkufach, + Seite nach oben. Drücken Sie ihn sanft nach unten, bis er im Akkufach einrastet.

  7. Das Gerät wieder vollständig montieren, bevor Kabel oder Leitungen angeschlossen werden.

Nun ist der Austausch des Akkus abgeschlossen.


Installation der optionalen GPIB-Schnittstelle

Warnung

Dieser Vorgang darf nur durch qualifiziertes Servicepersonal ausgeführt werden. Schalten Sie den Strom ab und entfernen Sie alle Messleitungen und anderen Kabel (auch das Netzkabel) vom Gerät, bevor Sie fortfahren.

Erforderliches Werkzeug

Dieser Vorgang erfordert einen T10 Torx-Schraubendreher.

Installationsvorgang

  1. Schalten Sie den Strom ab und entfernen Sie alle Messleitungen und anderen Kabel (auch das Netzkabel) vom Gerät, bevor Sie fortfahren.
  2. Entfernen Sie die Schraube aus der GPIB-Abdeckung mit einem Torx-Schraubendreher. Bewahren Sie die Schraube zur späteren Verwendung auf. Entfernen Sie dann die Abdeckung, indem Sie sie nach links schieben.

    3. GPIB-Abdeckung aufbewahren

    Bewahren Sie nach Installation der GPIB-Option die Abdeckung für den Fall auf, dass Sie die GPIB-Option wieder entfernen möchten. Das Gerät darf nie an das Stromnetz oder Eingänge an den Messterminals angeschlossen werden, ohne dass entweder das GPIB-Modul oder die Abdeckung sicher an die Öffnung der Rückseite angeschlossen sind.

  3. Anschluss für das Kabel des GPIB-Moduls im Gerät lokalisieren

  4. Kabel so biegen, dass es bis über die Leiterplatte reicht. Kabel an den Anschluss anschließen, der im letzten Schritt lokalisiert wurde.

  5. Modul in die Einheit einsetzen und GPIB-Platte nach rechts schieben, so dass sie mit der Blechabdeckung des Geräts bündig abschließt. Verwenden Sie die zuvor entfernte Schraube zur Befestigung der GPIB-Platte.

Nun ist die GPIB-Installation abgeschlossen.